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Chapter 1
SailWind Logic QuickStart

SailWind Logic is a robust, multi-sheet, schematic capture solution that builds an effective front-end 
environment for SailWind Layout.

Step 1 - Start a New Design
Step 2 - Select the Sheet Size
Step 3 - Add Parts and Connector Symbols
Step 4 - Add Buses
Step 5 - Add Connections to Parts, Connectors, and Buses
Step 6 - Add Off-Page Symbols
Step 7 - Add Power and Ground Symbols
Step 8 - Print the Schematic
Step 9 - Generate Reports
Step 10 - Create a Layout Netlist

Step 1 - Start a New Design
Launch SailWind Logic and start a new design from the Welcome Screen.

Procedure
1. Click the Windows Start  > SailWind [version]  > SailWind Logic  menu item.

2. On the Welcome Screen, click New.

Step 2 - Select the Sheet Size
SailWind Logic starts with an empty schematic sheet of the default size. You can change the sheet size.

Procedure
1. Click the Tools  > Options  menu item.

2. In the Options dialog box, click the Design  category.

3. Select the size you want from the Sheet area:

a. Choose the size of the sheet by clicking in the Size box and selecting from the dropdown list.

b. Choose a corresponding sheet border by clicking Choose  and selecting the appropriate border 
from the “Drafting Items” list of the “Get Drafting Item from Library” dialog box.

c. Click OK  to close the Get Drafting Item from Library dialog box.

d. Click OK  to close the Options dialog box.

4. To maximize the sheet size within your viewing area, on the main toolbar, click the Sheet  button.
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Step 3 - Add Parts and Connector Symbols
You can add parts and connector symbols to your design as needed.

Adding a Part
Adding a Connector Symbol

Adding a Part
You can add parts to your design individually, or you can add multiple instances.

Procedure
1. Click the Schematic Editing Toolbar button, then click the Add Part  button.

2. In the Filter section of the Add Part from Library dialog box, set the Library to “All Libraries.”

3. In the Items box, type the * wildcard character, and click Apply.

4. Select a part and notice the symbol of the part in the preview window. Click Add.

The part in outline form attaches to the pointer and is ready for placement.

5. Move the pointer to move the part to an appropriate location and click to place the part.

Another copy of the selected part automatically attaches to the pointer for placement.

Tip
SailWind Logic automatically adds reference designators to parts as they are added.

6. Click to place another part or press the Esc key to cancel the placement of the same part type.

7. Click Close  to close the Add Part from Library dialog box.

Adding a Connector Symbol
Each pin of a connector has a unique symbol for the schematic. This results in multiple symbols that 
make up one part. All connector pins have the same reference designator to show that they are symbol 
pins of the same part.

Procedure
1. On the Schematic Editing toolbar, click the Add Part  button.

2. In the Filter area of the “Add Part from Library” dialog box, select the “connect” library from the 
Library list, then click Apply.

3. Select a connector symbol to add to the schematic and click Add.
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Step 4 - Add Buses

Tip
If the symbol faces the wrong direction when attached to the pointer, right-click and click 
the Alternate  popup menu item. Right-clicking and clicking the Alternate  popup menu 
multiple times enables you to choose one of any available symbols to represent the 
connector.

4. Click to place the connector symbol.

5. When you have finished placing all of the desired symbols, right-click and select Cancel  or press 
the Esc key to end the placement mode.

6. Close the dialog box.

Step 4 - Add Buses
Buses are used to consolidate a group of nets into one connection. This eliminates the potential clutter of 
many nets going from, or to, the same location in the design.

Procedure
1. On the Schematic Editing toolbar, click the Add Bus  button.

2. Click to start the bus, click to add the corner, and double-click to finish the shape.

Tip
To remove the corner you just placed, press the Backspace key. To cancel the bus 
placement, press the Esc key.

3. In the Add Bus dialog box, type a name for the bus in the Bus Name box.

4. If the bus is to be used for strictly memory or data arrays, select Bit Format in the Bus Type area; 
otherwise, select Mixed Net.

• Bit Format  — The name of the bus must follow the bit format shown for arrayed connections.

Tip
[NN:NN] represents [LSB:MSB].

• Mixed Nets  — The name of the bus must be unique. Add the names of all subnets to the Bus 
Nets area. The mixed net bus can also contain bit format connections. To enter values for a 
range, double-click the Start and End cells.

5. Click OK.

6. Click to place the bus name.
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Step 5 - Add Connections to Parts, 
Connectors, and Buses
Add connections to parts, connectors, and buses to define the connectivity of your design.

Procedure
1. Click the Schematic Editing Toolbar  button and then click the Add Connection  button.

2. At the endpoint of a component pin, click to start a connection and draw the connection.

The connections are orthogonal by default, and you must click to create corners.

Tip
To remove the corner you just placed, press Backspace. To cancel the connection, press 
Esc.

3. End the connection using one of the following methods:

• Click at the endpoint of another pin on a part or connector.

• If you create a connection that ends in a bus, in the Add Bus Net Name dialog box, select the 
net from the Net name list and click OK.

The connection and its name remain selected in the design.

4. Place the label using one of the following:

• If you are satisfied with the location of the net name label, click in empty space.

• If the net name label is not in the correct location, right-click and click the Move  popup menu 
item. The label attaches to the pointer. Click to place the label.

Step 6 - Add Off-Page Symbols
When connections need to connect to a circuit on another schematic sheet in the design, an off-page 
symbol is used. The off-page symbol has multiple representations, similar to a connector.

Procedure
1. Create a connection from the pin of a part in the design.

2. Right-click and click the Off-page  popup menu item.

The default symbol appears on the pointer for placement, attached to the end of the connection.

3. If the symbol is not facing the correct direction, right-click and click the Alternate  popup menu item 
until you find the correctly oriented symbol.
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Step 7 - Add Power and Ground Symbols

4. Click to place the symbol.

5. In the Add Net Name dialog box, type the net name and click OK.

Step 7 - Add Power and Ground Symbols
Power and ground symbols are added to the end of a connection and have different representations 
according to the ground or power name.

Procedure
1. Create a connection from the pin of a part.

2. Click to make a corner and drag up for power or drag down for ground.

3. Right-click and click the Ground  popup menu item or Power  depending on the connection and the 
direction it has been drawn. The default ground or power symbol appears on the pointer.

Notice the name that is annotated to the connection is displayed on the status bar in the lower left 
corner. If you clicked Power, it is +5V; if you clicked Ground, it is GND.

4. If you want a different voltage or ground, right-click and click the Alternate  popup menu item for 
different graphical symbols and different names.

Step 8 - Print the Schematic
When you have finished editing your design, you can print it for checking and documentation purposes.

Procedure
1. Click the File  > Print  menu item.

2. In the Print dialog box, click Options.

3. In the Options dialog box, examine the Preview window. The outline within the larger area 
represents the area of the paper that will be taken up by the schematic. This plot area is often 
oriented perpendicular to the printed sheet. If this is the case, to maximize the design area on 
the printed sheet, click on the Orientation box (in the “Positioning” area) and select 90 as the 
orientation angle; then click OK.

4. Click the Properties  button to make any printer changes before printing/plotting. Do not change 
the orientation of the sheet (Portrait to Landscape) as this will conflict with the orientation set 
previously in the Options dialog box.

5. After completing this setup, click OK.

Step 9 - Generate Reports
You can generate a number of different reports for design analysis.
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Procedure
1. Click the File  > Reports  menu item.

2. In the Reports dialog box, click what you want to report on, and click OK.

Tip
You can report on more than one item at a time, with each item generating a report (TXT 
file). These reports open in the default text editor and are formatted with a default set of 
customizable options.

Results
The report generates and a link to the report displays in the Output window. Click the link to view the 
report.

Step 10 - Create a Layout Netlist
You can create a Layout netlist to examine the database and to pass the design data to SailWind Layout.

Procedure
1. Click the Tools > Layout Netlist  menu item.

The default name of the netlist is default.asc, unless you saved the schematic.

2. Give the file a unique name and click OK.

The netlist opens in the default text editor for viewing.

Tip
If you saved the schematic, the default name of the netlist (the Output File Name) is the 
name of the schematic followed by an .asc  file extension.
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Chapter 2
Getting Started With SailWind Logic

The SailWind Logic workflow guides you through the steps necessary to create a schematic design.

SailWind Logic Flow
Startup Options
Adding Startup Options to a Shortcut
SailWind Updates
Migrating User Settings
Customizing SailWind Logic Default Settings
Mouse Button Operations
Using the Numeric Keypad to Control the View

SailWind Logic Flow
Creating a schematic design of your system requires a number of steps to get from initial concept to 
completed design. Each step is presented in a logical order so that you can manage the entire process of 
creating the schematics for your system.

1. Set up a new design

◦ Create a new design (See Creating a New Schematic File)

◦ Select a sheet size (See Setting Schematic Editor Options)

◦ Add 2D line objects (See Adding Drafting Items From a Library)

◦ Set up options

• Global (See Options Dialog Box, General Category)

• Design (See Options Dialog Box, Design Category)

2. Set up rules and constraints

◦ Decide which design rules you need (See Setting Up Rules)

◦ Set up design rules (See Rules Setup)

3. Place parts
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◦ Locate parts in the library (See Managing Libraries and Library Data)

◦ Place parts (See Schematic Parts)

◦ Set attributes (See Attributes Overview)

4. Wire the schematic

◦ Connect the components (See Connections)

◦ Edit the connections (See Changing a Connection)

◦ Name the connections (See Naming a Connection)

◦ Assign net constraints (design rules) (See Setting Up Net Rules)

5. Prepare the Design for Layout

◦ Output a netlist to SailWind Layout (See Creation of a New PCB Layout from a SailWind 
Logic Design)

◦ Generate reports (See Reports)

6. Perform Design Annotations

◦ Forward annotate design changes to SailWind Layout (See Forward Annotation From 
SailWind Logic to SailWind Layout)

◦ Backward annotate design changes from SailWind Layout (See Backward Annotation From 
SailWind Layout to SailWind Logic)

Startup Options
You can use startup options, known as command line switches, to control the initial SailWind Logic 
configuration. Use command line switches to enable different options, to open a file, start macros, and 
record a SailWind Logic session. You can type multiple command line options.

For instructions to add options to a program shortcut, see “Adding Startup Options to a Shortcut”.

Table  1. SailWind Logic Command Line Options

Option Description

filename Opens the specified design file when you start SailWind Logic. Type the folder 
path and filename. Use quotation marks for directories or filenames with spaces, 
for example: “C:\SailWind Projects\Samples\previewpart.sch”

 Restriction:
Do not use a forward slash ( / ) before the filename in the command line.
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Adding Startup Options to a Shortcut

Table  1. SailWind Logic Command Line Options  (continued)

Option Description

/BMW[initials] Opens the Media Wizard. Use the Media Wizard to start recording a session log 
or to convert the previous session log to media that can be replayed by Basic Log 
Test. To create session media files for the current SailWind Logic session, use the 
BMW modeless command.
To use the BMW command line switch, type /BMW or /BMWxx, where xx  is your 
initials, in the command line. Capitalization. [] represents optional text.
This option is associated with another modeless command, BLT. BLT is the Log 
Test; it finds and runs the session media created by BMW to play back a recorded 
SailWind Logic session. For information, see Modeless Commands and Keyboard 
Shortcuts  on page 569.

/l Opens the last file you had open when you start SailWind Logic.

/mmacro name Runs the specified macro in the default macro file. For example, to run the macro 
MyMacro, type /mMyMacro.

/Mmacro file Specifies the file to use as the default macro file. For example, to run the macro 
MyMacro contained in the file user1.mcr, type /Muser1.mcr /mMyMacro. Note the 
required capitalization.

/nc Starts SailWind Logic without displaying the splash screen that includes copyright 
information.

/sXXX Starts a Basic script when you start SailWind Logic. 
Use quotation marks for filenames with spaces, for 
example:/s“C:\<install_folder>\SailWind<version>\Samples\Scripts\Logic\Unsuppo
rted\Attributes to Excel.bas”

 

Adding Startup Options to a Shortcut
If you repeatedly start your design sessions with the intention of launching a specific design file or 
specifying a particular design environment setting, then you can add startup options to the properties of a 
shortcut.

Tip
If you create your own shortcuts, copy the Start  menu shortcuts instead of generating them from 
the executables in the install directory. Start  menu shortcuts contain a "wrapper" that enables the 
proper environment variables to be defined as the program launches.

Procedure
1. In the shortcut properties, click in the box with the pathname.

2. Press End, press Spacebar, and then type the command line switch you want to use, and enclose 
with double quotes " " each string that contains a space.

SailWind Logic Guide 31



Getting Started With SailWind Logic
Adding Startup Options to a Shortcut  

When specifying a file to start, do not use a / before the filename. You can specify multiple 
command line switches. For example, to start the program with preview.sch, the command line 
might read:

“\<install_folder>\<version>\Programs\SailWindLogic.exe” “C:\SailWind 
 projects\Samples\preview.sch”
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SailWind Updates

SailWind Updates
The SailWind products automatically check for a new software version when you launch an application. If 
a new version is detected, a tooltip is displayed in the system tray.

Downloading the Update
Disabling the Check for Updates
Checking for Updates Manually

Downloading the Update
When a new version of SailWind is detected, you can download the update.

Prerequisites
An Internet connection is required for the check.

Procedure
1. Right-click the icon in the system tray.

2. Click the Open download page  popup menu item.

3. Follow the instructions on the download page.

Disabling the Check for Updates
If you do not want to check for updates automatically, disable the Check for Updates functionality. You can 
enable the check at any time, or you can manually check for updates.

Procedure
1. Click the Help > Check for Updates  menu item.

2. In the Check for Updates Dialog Box, select the “Disable ‘Check for Updates’ functionality” check 
box.

Checking for Updates Manually
Do not check for updates manually unless you have disabled the automatic check.

Procedure
1. Click the Help > Check for Updates  menu item.

2. In the Check for Updates Dialog Box, click Check for Updates.
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Migrating User Settings
You can use the SailWind User Settings Migration tool to extract your settings from one installation of 
SailWind Logic, Layout, and Router and import them into another installation or version.

For information on how to do this, see User Settings Migration in the SailWind User Settings Migration 
Guide.

Customizing SailWind Logic Default Settings
Several settings define the default ASCII parameters of operation of SailWind Logic. You can customize 
the user interface by modifying these system settings and saving the files.

The file default.txt  is a SailWind Logic ASCII file that contains default option settings. It is read into 
memory when you start SailWind Logic or click the File > New  menu item to begin a new design.

Procedure
1. Click the Tools > Options  menu item.

2. Change the settings as desired using the General  and Design  categories to change the sheet size 
and design grid, and so forth.

3. Click OK  to save the changes.

4. Click the File > Export  menu item, and then set the folder to C:\<install_folder>\SailWind<version>
\Settings.

5. Select default.txt  from the list of files. Type the name in the File name area if it does not exist.

6. Click Save.

This displays the ASCII Output dialog box.

7. In the ASCII Output dialog box, click Select All.

8. Leave the output format at the current setting and click OK.

Mouse Button Operations
SailWind Logic follows Microsoft®  Windows®  conventions for two-button mouse operations. SailWind 
Logic also supports the use of a three-button mouse. The middle button provides quick access to the pan 
and zoom commands.

Use the middle mouse button to pan (to move the view from side to side or up and down) without 
changing the size. Click the middle mouse button where you want to center the work area. The screen 
repaints, placing the point you chose at the center.

To define a specific area that you want to enlarge, hold the middle mouse button down, and move the 
mouse diagonally and up across the area you want to zoom. A dynamic rectangle expands with the 
cursor movement. When you release the middle mouse button, the view zooms to the rectangle.

To zoom out, press the middle mouse button and drag diagonally and down. When you zoom out, a solid 
rectangle appears at the cursor. This represents the current view size. The thin line that expands from the 
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Using the Numeric Keypad to Control the View
solid box represents the new view size in proportion to the old. The zoom-out ratio also displays with the 
cursor.

Using the Numeric Keypad to Control the View
You can control the view using the extended keypad or the numeric keypad, located on the far right of 
most keyboards. The NumLock light can be on or off except where specified.

Table  2. Numeric Keypad Functions

Click To

Home Fits board to the view.

End Redraws current view.

Arrows With Num Lock On, pans the viewing window. Moves one-half the screen 
width in the direction of the arrow. With Num Lock Off, moves cursor on grid 
unit.

5 With Num Lock On, draws zoom rectangle.

Pg Up Zooms In centered at cursor location.

Pg Dn Zooms Out centered at cursor location.

Ins Centers the view at current cursor location, without zooming.
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Chapter 3
User Interface

The software interface is robust and configurable. It offers numerous methods for viewing and navigating 
your designs, as well as extensive capabilities for generating custom macro scripts for playback and 
debugging.

View Control
Project Explorer
Output Window
Opening a File That is Already in Use
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View Control
You can use several methods to control which portion of the database is visible on the screen.

View Commands and Scroll Bars
Middle Mouse Button
Numeric Keypad
Saving and Restoring Views

View Commands and Scroll Bars
There are a number of different ways to interact with the design environment to control the view of the 
design. SailWind Logic provides a comprehensive set of commands to enable you to pan and zoom within 
the design including using the mouse buttons/wheel, keyboard shortcuts and various items on the View 
menu.

To control the view, use the scroll bars or the following commands in the View  menu:

• Click the View  > Zoom  menu item, or the Zoom  button on the toolbar to enter Zoom mode.

◦ To zoom in, position the cursor at the desired view center, and click the left mouse button.

◦ To zoom out, position the cursor at the desired view center, and click the right mouse button.

◦ To define a specific view area, position the cursor at the desired view center, click and drag to 
define the extents, and release.

• Click the View  > Redraw  menu item, or the Refresh  button on the toolbar to redraw the current 
view.

• Click the View  > Sheet  menu item, or the Sheet  button on the toolbar to display the entire sheet.

• Click the View  > Extents  menu item to resize the view to display all objects in the design.

• Use the scroll bars to pan the view.

Middle Mouse Button
You can use the middle mouse button to perform a number of viewing operations.

Use the middle mouse button to perform panning and zooming operations:

• To pan, click the middle mouse button. The view is centered at the cursor.

• To zoom in, click and hold the middle mouse button. Drag the cursor diagonally up. To adjust the 
bounding box, move the mouse. When you release the middle mouse button, the area within the 
bounding box displays.
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Numeric Keypad

• To zoom out, click and hold the middle mouse button. Drag the cursor diagonally down. This 
draws an inner box, representing the current view. Moving the cursor adjusts the outer box, which 
represents the new view. The relative size of the outer box to the inner box determines how far 
the view zooms out. Release the middle mouse button to complete the zoom out operation.

• To view the entire design, click and hold the middle mouse button, drag the cursor horizontally, 
and release.

Numeric Keypad
Use the numeric keyboard to control the view.

For more information, see Using the Numeric Keypad to Control the View.
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Saving and Restoring Views
If you repeatedly pan or zoom to a particular area of your design, you can save time by saving a work 
area view so that you can instantly restore it when needed.

Restriction:
Capture is not available while in the Part Editor.

Saving a View
Restoring a View

Saving a View
You can save a view of your design for later recall.

Procedure
1. Arrange the work area to display the view you want to capture.

2. Click the View > Save View  menu item.

Tip
In the Save View dialog box, the preview shows you the location of the selected view in 
relation to the extents of the design.

3. In the Save View dialog box, click Capture.

4. In the “Capture a new view” dialog box, type a new name for the view and then click OK.

The new view name is listed in the View Name list.

Tip
You can create up to nine views. The view names appear at the bottom of the View  menu.

5. Click Close.

Restoring a View
You can restore a previously saved view.

Procedure
1. Click the View  > Save View  menu item.

2. Select a name from the View Name list and click Apply  to apply a previously selected view to the 
work area.
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Project Explorer

Tip
When you apply a view, the previous view saves automatically. Click the View > Previous 
View  menu item to restore the view.

3. Select a name from the View Name list and click Delete  to remove it from the View Name list.

Project Explorer
The Project Explorer lists the objects in your design in a hierarchical structure. When you update your 
design, the hierarchical structure also updates automatically.

Restriction:
The Project Explorer is unavailable in the Part Editor.

Note:
To open the Project Explorer, click the Project Explorer  button.

You can configure the Project Explorer so you can click on a listed object to select it in the workspace, or 
select it and zoom to it.

Procedure
1. Right-click in Project Explorer, and click the Allow Selection  menu item.

A check mark indicates that the functionality is enabled.

2. If you want to Zoom to the object you select, click the Zoom to selection  menu item.

A check mark indicates that the functionality is enabled.

SailWind Logic Guide 41



User Interface
Output Window  

Output Window
Use the Output window for viewing reports and session logs, macro editing and debugging, and custom 
programming and debugging.

The Output window is located in the lower left section of the display window. You can dock or float the 
Output window. You can also open or close the Output window.

The Output window has two tabs:

• Status Tab  — Displays information on the current session.

• Macro Tab  — Enables you to run, edit, and debug scripts.

Session Log Management
Macros
Macro Playback
Macro Script Debug
Accessing Help on the Macro Language
CIS
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Session Log Management

Session Log Management
Various methods are available for managing the session logs, including filtering, viewing, printing and 
saving the log data.

Session Log
Navigating Pages in the Status Tab
Filtering the Status Tab Display
Searching in the Status Tab
Printing Session Log Messages
Viewing and Printing Reports
Saving a Session Log to File
Clearing the Session Log Display

Session Log
A session log, which appears in the Status  tab of the Output window, contains all program output for the 
current session, including names of open and saved files, integrity test results.

The session log file messages in the Status  tab are color coded by subject. Underlined items are links. 
The color codes are shown in the following table:

Table  3. Session Log Text Color Meanings

Color Meaning

Red Errors

Green Warnings

Black Messages

Blue Links to files, Web pages, and database objects

Navigating Pages in the Status Tab
Use the Status  tab toolbar buttons in the Output window to navigate to the previous or next page, and 
to refresh a display of reports and other pages. You can also stop updates to pages, and return to the 
session log display.

To perform these functions, use the following Status  tab toolbar buttons:

Table  4. Status Tab Toolbar Buttons

Command Description

Back Displays the previous page.

Forward Displays the next page.
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Table  4. Status Tab Toolbar Buttons  (continued)

Command Description

Stop Stops page updates.

Refresh Refreshes the display of reports and other pages.

Home Returns to the session log.

Filtering the Status Tab Display
The session log file messages in the Status  tab are color coded by subject. You can choose to view any 
combination of the color coded messages.

Use the following procedure to filter the display in the Status  tab.

Procedure
1. Right-click in the Output window and click one of the following commands from the Filter  popup 

menu item:
Table  5. Filter Submenu Commands

Command Description

Error Displays errors.

Warning Displays warnings.

Message Displays messages.

Show all Displays all items (errors, warnings, and messages).

2. Select an item to show it; clear the item to hide it.

Searching in the Status Tab
If you want to locate a specific item or term in the log, you can search for text in the Status  tab. There are 
options available to search for whole word only and specific case matches.

Procedure
1. Right-click and click the Find  popup menu item.

2. In the Find dialog box, type the text you want to find in the dialog box and complete any other 
dialog box options.

3. Click Next.

The tab scrolls to the occurrence of the word, highlighting the word.
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Printing Session Log Messages

Printing Session Log Messages
You can print a hard copy of the session log for review purposes.

Procedure
1. Right-click and click Print.

2. In the Windows standard Print dialog box, set options as needed.

3. Click Print.

Viewing and Printing Reports
The session log contains links to reports that you can view and print.

To view the report, click the link. The report appears replacing the session log as the active page in the 
Status  tab.

You can print the displayed report.

Procedure
1. Right-click the displayed report and click Print.

Tip
As an alternative, on the Status  tab toolbar, click the Print  button.

2. In the Windows standard Print dialog box change any Print dialog box options as needed.

3. Click Print.

Saving a Session Log to File
There are times when you might want to refer to something that was documented in the session log (such 
as when debugging a file or submitting a Support Center request. You can save a session log to a file for 
future reference.

Procedure
On the Status toolbar, click the Log to File  button to save the session log for future reference.

If a session log file already exists, new information is appended. If a session log file does not exist, a new 
file is created.

The default path for the session log comes from the .ini  file entry:

FileDir=C:\SailWind Projects

When you first start the software, the location is set in the following registry key:
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HKEY_CURRENT_USER\Software\Mentor Graphics\<version>\SailWind Layout\Status 
 Window\LastLogName

Clearing the Session Log Display
You can clear a session log when it is no longer needed.

Procedure
Right-click and click Clear  to clear the session log display each time you open a file.

Results
This prevents you from viewing information from a previously opened file. It does not delete the log file.
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Macros
You can create macros to simplify redundant activities. You can record any set of procedural steps for 
replay as a single action. You can also nest macros.

Tip
Dialog box actions are recorded as results rather than actions, so when you replay, you don't see 
the dialog boxes in the replay process. Because of this you can't create a macro that stops on an 
open dialog box; it must follow through to some result or action. For example, you can create a 
macro that selects the File  > Open  menu item, selects a file, and selects OK. The macro, when 
played back, opens a file.

Creating a New Macro
Recording Mouse Movements
Opening an Existing Macro File
Viewing Multiple Open Macros
Editing a Macro
Changing the Default Text Editor
Saving the Macro

Creating a New Macro
Macros can be very flexible and helpful beyond your current design session. You can create a new macro 
by recording your keystrokes, mouse movements and commands and then save it for later recall.

Procedure
1. On the main toolbar, click the Output Window  button.

2. On the Macro  tab, click the New  button.

New macros are given a name of Macro#, where # is a numeric sequence such as Macro1 or 
Macro2.

3. If desired, click the Compress mouse moves  and/or Relative mouse moves  buttons.

See Recording Mouse Movements  for more information.

4. On the Macro  tab toolbar, click the Record  button.

5. Perform the keystrokes, commands, and mouse clicks to include in the macro.

6. On the Macro  tab toolbar, click the Stop  button.

Alternatively, you can also script a macro instead of recording mouse actions.

Recording Mouse Movements
Mouse movements are recorded in macros. You can record compressed or uncompressed mouse 
movements and relative or absolute movements.

SailWind Logic Guide 47



User Interface
Opening an Existing Macro File  

• Compress Mouse Mode  — Compress mouse mode records only the start point and endpoint 
of a mouse movement. It does not record any of the intermediate coordinates between the start 
and end points. Compression is recommended under most circumstances because it significantly 
reduces the size of your macro file. Recording intermediate mouse movements increases the file 
size, but documents coordinate information if required for a special application.

• Relative Mouse Mode  — Relative mouse mode records the start point and endpoint of a 
movement in incremental coordinates instead of absolute coordinates.

Opening an Existing Macro File
Macros are created in and stored in macro files that have a .mcr  extension. To open an existing macro file 
(.mcr), you can use the menus or the toolbar.

You can open multiple macros in the macro editor. The macro editor also supports nested macros.

Procedure
1. On the main toolbar, click the Output Window  button; then, in the Output window, click the Macro 

tab.

2. Click the Open  button, or select the macro file in the Open File dialog box and click Open.

Viewing Multiple Open Macros
You can switch your view between multiple open macros. This enables you move back and forth between 
more than one macro without having to open and close them individually.

Procedure
Click a macro in the List of Open Macros area (left-hand pane) of the Macro  tab to switch between open 
macros.

Editing a Macro
You can copy or cut selected text to the Clipboard. You can also paste the selection from the Clipboard 
into the text window. You can paste text from the Clipboard into other applications. You can also switch 
between open macros to edit multiple macros.

Restriction:
If you have Notepad as the default text editor, longer macro files may not be loaded because 
of size constraints in Notepad. See Changing the Default Text Editor  for information on how to 
change the default text editor.

Procedure
1. Select the text you want to copy or cut.

2. On the Macro  tab toolbar, click the Copy  or Cut  buttons.

3. Place the pointer at the insertion point where you want to place the copied text.
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Changing the Default Text Editor

4. On the Macro  tab toolbar, click the Paste  button.

You will see that your selection has been pasted in the Output window at the insertion point.

As an alternative, right-click in the Output window and click Copy, Cut, or Paste.

Changing the Default Text Editor
To access large files using Edit, you must install an ASCII text editor with a suitable file size capacity.

Procedure
1. Open the SailWindlogic.ini  file in a text editor.

2. Modify the [general] section, specifying a new text editor executable name. Include the drive and 
folder if the new editor is not in your Windows folder.

3. Save the.ini  file and close the text editor.

Saving the Macro
Macros are not limited to your current design session. You can save a macro for future recall.

Procedure
1. Click the Save  button.

2. In the standard Windows “Save As” dialog box, enter a filename, if necessary, and click Save.

Related Topics
Using Command Line Switches with Macros [SailWind Logic Command Reference Manual]
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Macro Playback
You can play back an existing macro using Run. Run also resumes the playback of a paused macro. 
When you play a macro, you cannot use the mouse in the workspace.

Playing Back a Macro
Pausing a Playing Macro
Stopping a Playing Macro

Playing Back a Macro
Once a macro has been recorded, you can play it back.

Procedure
1. On the Macro  tab, click the Open  button and open a macro (.mcr) file.

Recent macros can be found by clicking the Tools > Macros  menu item, and then selecting the 
desired macro from the list.

2. On the Macro  tab toolbar, click the Run  button.

As an alternative, right-click in the Macro  tab and click Run.

Pausing a Playing Macro
You can pause a macro during playback.

Procedure
1. On the Macro  tab toolbar, click the Pause button to pause a playing macro at any time.

2. Click the Play  button to resume playing the macro.

Stopping a Playing Macro
You can stop a macro that is currently playing.

Procedure
Right-click in the Macro  tab and click Stop  or on the Macro  tab toolbar, click the Stop  button to stop a 
playing macro.

You cannot resume the playback of the macro once you have stopped it. When you click Run, the macro 
starts from the beginning.

Related Topics
Using Command Line Switches with Macros [SailWind Logic Command Reference Manual]
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Macro Script Debug

Macro Script Debug
When playing back a macro, you can run it step-by-step, or to a certain location in the script. To perform 
these debugging tasks, insert breakpoints in the macro at the points at which you want the macro to stop.

Setting or Removing Breakpoints
Debugging the Macro Scripts
Run-Time Error Correction

Setting or Removing Breakpoints
The ability to set or remove breakpoints is useful when you debug a macro. If the macro engine 
encounters a breakpoint when playing back a macro, it pauses the macro.

Procedure
1. Place the cursor on the line in which to add a breakpoint.

2. Right-click in the Macro  tab and click Toggle Break, or as an alternative, on the Macro  tab toolbar, 
click the Toggle Breakpoint  button.

This inserts a breakpoint at the current cursor location. A breakpoint marker appears in the gutter 
area.

When the macro engine encounters a breakpoint while playing back a macro, it pauses the macro. 
The next line in the macro is marked with the instruction pointer.
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Debugging the Macro Scripts
Once breakpoints are inserted, you can debug macros.

Play a Single Line of the Macro
Perform a Subroutine Call on the Current Line
Play Back a Macro to a Point
Return From the Subroutine to the Point From Which it was Called
Continue the Execution From the Current Point

Play a Single Line of the Macro
You can play a single line of a macro by using a button on the Macro  tab toolbar or the right mouse button 
menu command.

Procedure
Right-click in the Macro  tab and click the Step Over  menu item, or on the Macro  tab toolbar, click the 
Step Over  button

Perform a Subroutine Call on the Current Line
You can perform a subroutine call on the current line by using a button on the Macro  tab toolbar or the 
right mouse button menu command.

Procedure
Right-click in the Macro  tab and click Step Into  menu item, or, on the Macro  tab toolbar, click the Step 
into  button.

Play Back a Macro to a Point
You can play back a macro to a point by using a button on the Macro  tab toolbar or the right mouse 
button menu command.

Procedure
Right-click in the Macro  tab and click the Step to Cursor  menu item, or click the Step to cursor  button 
on the Macro  tab toolbar.

Return From the Subroutine to the Point From Which it was 
Called
You can return from the subroutine to the point from which it was called by using a button on the Macro 
tab toolbar or the right mouse button menu command.

Procedure
Right-click in the Macro  tab and click the Step Out  menu item, or, on the Macro  tab toolbar, click the 
Step out  button.

52 SailWind Logic Guide



 
User Interface

Continue the Execution From the Current Point

Continue the Execution From the Current Point
You can continue the execution of a macro from the current point by using a button on the Macro  tab 
toolbar or the right mouse button menu command.

Procedure
Right click in the Macro  tab and click the Run  menu item, or, on the Macro  tab toolbar, click the Run 
button.

Run-Time Error Correction
If run-time errors occur, the macro debugger switches to step-by-step mode and displays a detailed 
message on the status bar. The instruction pointer is set on the line that produced the error. After fixing 
the error, you can resume playback of the macro.

Related Topics
Using Command Line Switches with Macros [SailWind Logic Command Reference Manual]

Accessing Help on the Macro Language
You can access help on the macro language at any time.

Procedure
Click in the edit area of the Macro  tab and press F1 for information on the term and a sample script.
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CIS
The CIS  tab displays part information from CIS as indicated. You can:

1. Speficy a new configuration for data source to use and choose what to display in the CIS tab.

2. Search and add part(s) from CIS.

3. Compare part attributes in design with those in CIS to check the consistency.

Adding a New Configuration
Adding Parts from CIS
Comparing Part Attributes for Consistency Checking

Adding a New Configuration
After launch, SailWind Logic automatically connects to the specified data source, from which to load data 
into the CIS  tab.

Follow the steps below to specify a new configuration and choose what to display in the CIS  tab.

Procedure
1. On the CIS  tab toolbar, click the New  button.

2. In the Library Config dailog box, add and connect to the target data source as follows:

a. Click ODBC Config.

b. Add an ODBC data source to use in the pop-up window.

c. Click Update  to make the newly added data source active and available in the ODBC DSN  list.

d. Select the target database from the list to establish connection and load its table list in the 
Database Tables area.

3. Select the database table(s) to use by checking the To CIS  checkbox.

Only those selected will be available in the CIS  tab.

4. In the "Table Configuration" area, specify what and how table fields are displayed in the CIS  tab. 
For more information, see the table below.

Table  6. Table Configuration Description

Name Description

Field Name Lists all fields in the table selected on the left.

Field Type Specifies what type the table fields belong to from the drop-down 
list, wherein:
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Adding Parts from CIS

Name Description

• Part_Type is mandatory, based on which to load data into the 
CIS tab. Besides, you can see schematic symbol and PCB 
decal assigned to the part type in the local libraries from the CIS 
preview window.

• Part_Number is mandatory, based on which to check whether 
part attribute values in design are identical with those in CIS.

• Category allows to show table structure hierarchically by 
subcategories in the CIS tab.

• All field types except Normal must be unique.

Field Alias Specifies the table heading for each field to display in the CIS  tab.
• Field aliases corresponding to Field Type "Part_Type" and 

"Part_Number" are defined by default, and no modification is 
allowed.

• If nothing is set, Field Name will be used instead.

Transfer to 
Design

Specifies to add the Field Name to the part attributes. If yes, you 
can see it in the Part Attributes list by checking part properties in 
the design.

 Tip
When set, Field Alias will be used instead.

Visibility in CIS Specifies to display Field Name in the CIS  tab. When set, Field 
Alias will be used instead.

Key Reserved

Browsable Specifies to add hyperlinks to the field contents in the CIS  tab, 
which often links to such reference files as datasheets and 
drawings.

Property 
Checking

Specifies attribute(s) to compare in the Part Manager Dialog Box, 
checking whether the attribute values in design are identical with 
those in CIS.

5. Click Save  to save the configuration.

SailWind Logic automatically connects to the data source and loads specified information into the 
CIS  tab.

Adding Parts from CIS
After configuring data source as needed, you can check and use CIS data in the design. To locate parts 
effeciently, SailWind Logic provides you with filter feature. This section dsecribes how to use CIS data.

Procedure
1. Connect to the target data source and specify the table fields to display, as described in "Adding a 

New Configuration".

2. In the CIS  tab, select a table on the left, and view its part information on the right.
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3. Use the filter to locate parts, and click Search  to activate the filter. Parts that match the search filter 
settings are displayed.

Filtering by feild name and keyword is supported, whereas wildcard or expression is not currently 
supported.

4. Select a part and check its part type (CAE decal) and PCB decal in the preview window.

5. Add a part to the design as follows:

a. Double-click the target part in the table. The part attaches to and follows the cursor movement.

b. Click on the schematic to place the part; another instance attaches to the cursor automatically.

c. Press the Esc key when you are done adding the part(s).

6. Select the part in the design, right-click and click the Attributes popup menu item. In the attributes 
list, you can see attribute(s) added by "Transfer to Design" feature in the Library Config Dialog Box.

Comparing Part Attributes for Consistency Checking
Use the Part Manager to compare part attributes in design with those in CIS to check the consistency. For 
inconsistent attributes, you can update from CIS with multiple options. You can also specify the attributes 
to compare.

Procedure
1. Check that all attributes to compare are selected in the Library Config Dialog Box.

2. On the CIS  tab toolbar, click the Part...  button to activate the comparision.

Note:
The comparision is conducted on the basis of CIS attribute Part_Number.

3. Check the search results in the Part Attribute Info. area, where errors are highlighted in red. You 
can also:

• Use the filter to search for specific part(s) by the reference designator, schematic sheet, part 
number, error type, or the Show Error Only  button.

Note:
Filtering by Component Name or Part Number is case-sensitive and no wildcard or 
expression is currently supported.

• Click on any item in the table, and in the "Comparision Results" area see respective attribute 
values assigned in design and CIS, with differences highlighted in red.

4. Update inconsistent schematic part attribute(s) from CIS in either of the following ways, which 
takes effect only on parts found with "Attribute is not equal" error.
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• Click Update All  to update all inconsistent part attributes from CIS.

• Select one or more items in the table, and click Update the Selected  to update the inconsistent 
attributes of the selected parts only. Use Ctrl for multiple selections.

• Update attribute(s) for a specific part in the "Comparision Results" area, with two available 
options:

• Update the selected attribute: Right-click on the attribute cell and click the Update Selected 
Attribute From CIS  popup menu item

• Update all attributes: Right-click and click the Update Selected Part From CIS  popup 
menu item

Opening a File That is Already in Use
The SailWind products help you avoid making changes to a file that is already opened by another user.

The first user to open a file in a shared location becomes the owner of the file for the duration the file is 
open; the file is locked to all other users. If you try to open a file that someone else has already opened, 
you will get a warning message letting you know the current owner and the name of the computer from 
where the file is locked. You have the option to view a read-only version of the file but you will not be able 
to update it while the owner still has it open. You can save the file with another name using Save As.
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Chapter 4
File Operations

Use the file operations to create and save a new schematic file. You can also open and save existing 
designs, import and export files from other file formats, and archive your schematics.

Creating a New Schematic File
Saving a Schematic File
Opening a Schematic File
File Import and Export
Archiving Your Schematic

Creating a New Schematic File
You can create a new blank schematic file for your design. SailWind Logic uses previously-defined default 
settings to define the starting design configuration.

Prerequisites

• Use the File > New  menu item to clear the current schematic from memory and start a new 
schematic.

Procedure
1. On the main toolbar, click the New  button.

The prompt “Save old file before resetting?” displays.

2. If you click No, a blank drawing sheet representing sheet 1 of the new schematic displays in 
the work area. If you click Yes, the Saving a Schematic File  dialog box appears if the current 
schematic is untitled.

As an alternative, you can also create a new file from the popup menu in Microsoft® File Explorer.

a. In File Explorer, go to the folder where you want to create the file.

b. Right-click, and then click the New > SailWind Logic Schematic  menu item. This action 
creates a new design file in the current folder.

c. Type a name for the file and click Enter. Make sure the file has a .sch  extension. This creates a 
zero byte file.

When you open this file in SailWind Logic, SailWind Logic recognizes the zero byte file and 
performs a File > New  command using default.txt.

Saving a Schematic File
Use the File > Save  (or Save As) menu item to write design information to a file. The File Save As dialog 
box displays the schematic files contained in the default \SailWind Projects  folder. The list of displayed 
files includes those created in PowerLogic and SailWind Logic.
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Restriction:
Files opened by another user are locked to any edits. See Opening a File That is Already in Use.

The name of the currently open design is displayed in the File Name text box at the bottom of the dialog 
box. Click Save  to save the file. If the filename exists, a prompt is displayed to overwrite the existing file. 
The filename default  is displayed for new designs.

You can also save a file by clicking the Save  button on the Standard toolbar.

Related Topics
Opening a Schematic File

Import File Types

Exporting Files

Opening a Schematic File
You can open a schematic file in different ways.

Restrictions and Limitations
Files opened by another user are locked to any edits. See Opening a File That is Already in Use  on 
page 57.

Procedure
1. On the toolbar, click the Open  button.

The File Open dialog box displays the schematic files contained in the default \SailWind Projects 
folder. The list displays files according to the Files of type setting.

2. Select “Schematic Files (*.sch)” from the “Files of type” dropdown list.

3. Select a schematic file and then click Open  to load the design into SailWind Logic.

As an alternative, you can also open a file by dragging the file from Windows Explorer and 
dropping it into the SailWind Logic window.

Related Topics
Creating a New Schematic File

Import File Types

Exporting Files
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File Import and Export
Using SailWind Logic, you can import different file types, including data from schematics created with 
other tools. You can extract design information from an open schematic and save it in an ASCII format 
compatible with the previous or current software version.

Import File Types
Importing a File
Exporting Files
OLE Object Import and Export
ASCII File Format
Exporting to ASCII Output

Import File Types
SailWind Logic enables you to import different file types, including data from various formats and 
schematics created with other tools.

You can use the import functions for the following:

• Insert data from various formats into the current schematic.

• Translate schematics created with other tools, and open them as new SailWind Logic schematics.

This function invokes a non-GUI instance of the Symbol and Schematic Translator to translate 
a single design, using the default mapping files located in C:\<install_folder>\<version>\Settings 
(cadstar2pl.cnv, orcad2pl.cnv, pcad2pl.cnv, and protel2pl.cnv).

For information on more complex translations, such as translating only selected files from a .DDB 
container, or translating with special mappings, see the SailWind Symbol and Schematic Translator 
Guide.

Table  7. File Types Imported into the Current Schematic

File Type Description

ASCII File Format  (*.txt) PADS-format ASCII. The ASCII files you can import include those 
created from PowerLogic and SailWind Logic.

 Note:
Beginning with PADS 9.0, die parts and flip chips are identified by 
the Special Purpose settings in the Part Type rather than being 
designated by the DIE and FLP logic families. When you import 
an ASCII file created by a previous PADS version, these Special 
Purpose settings are automatically set for parts having the logic 
family DIE or FLP. The part’s family designation remains the 
same.

OLE Import/Export  on 
page 65(*.ole)

SailWind Logic enables you to embed files from other applications as 
OLE objects in your schematic using Edit/Insert New Object.
Once you have an OLE object in your design, you can export 
the object as a singular item to an .ole  file using File Export (see 
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Table  7. File Types Imported into the Current Schematic  (continued)

File Type Description
Exporting Files). You can then import the .ole  file into other SailWind 
Logic schematics.

ECO files (*eco) Similar to PADS-format ASCII. Each type of data begins with a 
header line with a key word surrounded by asterisks (*).

(.asc) files SailWind Layout rules.

Table  8. File Types Opened as New Schematics

File Type Description

CAD .csa  files CADSTAR Archive files (ASCII)

CADSTAR .scm  files CADSTAR Schematic files (binary)

OrCAD .dsn  files OrCAD Capture files

P-CAD .sch  files P-CAD Schematic files (ASCII & binary) generated in P-CAD 2002 & 
newer

Protel .sch  files Protel 99 Schematic files (ASCII & binary)

Protel .schdoc  files Protel DXP/Altium Designer Schematic files (ASCII & binary)

Protel .prjpcb  files Protel combined design/schematic files

Importing a File
SailWind Logic supports the importing of different file types into the design environment.

Procedure
1. Click the File > Import  menu item.

2. In the displayed prompt, Click Yes  to save the existing design before importing the file, or No  to 
import the file without saving changes.

3. From the “Files of type” dropdown list, select the type of file you want to import.

4. Select the file you want to import, then click Open.

Import progress is reported in the Status bar, and logging messages and links to log files are 
displayed in the Output Window.

Related Topics
Exporting Files

Opening a Schematic File

Import Rules from PCB
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Exporting Files
Extract design information from an open schematic file and save it in an ASCII format compatible with 
the previous or current software version. You can also use Export to create default startup conditions for 
SailWind Logic.

Note:
You can save all or some of the open design in ASCII format.

Procedure
1. Click the File > Export  menu item.

2. From the “Save as type” dropdown list, select the type of file you want to export to.

3. Type a name for the ASCII file in the File Name text box.

The default is the name of the currently open design.

4. Click Save.

This opens the Exporting to ASCII Output  Dialog Box. Select the appropriate check boxes to 
indicate the information that you want to write to the ASCII file.

Note:
SailWind Logic enables you to embed files from other applications as OLE objects in your 
design by clicking the Edit > Insert New Object  menu item. After you have an OLE object 
in your design, you can export the object as a singular item to an .ole  file.

5. Select the SailWind Logic output version for your exported file.

Beginning with PADS 9.0, die parts and flip chips are identified by the Special Purpose settings in 
the Part Type rather than being designated by the DIE and FLP logic families. With this change, 
the following changes occur when you export a design to an ASCII file of a previous PADS version:

• The Special Purpose settings of any die parts and flip chips are cleared.

• Die parts and flip chips having a family designation other than DIE and FLP lose their die part or 
flip chip special purpose and become normal parts.

• Any normal parts that have the DIE or FLP family designation are treated as die parts or flip 
chips in the previous PADS version.

For more information, see OLE Object Import and Export.

Related Topics
Import File Types

Opening a Schematic File
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Saving a Schematic File

Export Rules to PCB
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OLE Object Import and Export
You can import and export .ole  files in SailWind Logic to add images, text files, and other objects created 
in other programs and link to or embed them into your design. You can also export images and objects 
from SailWind Logic so that they can be included in documentation or reports.

Importing OLE Files
Exporting OLE Files

Importing OLE Files
You can import an .ole  file containing OLE objects into a SailWind Logic schematic, and you can export 
an OLE object from a schematic to an .ole  file.

Procedure
1. Click the File > Import  menu item.

2. Click Yes  at the prompt to save your current design changes or click No  to discard them.

3. In the File Import dialog box, select “OLE Files (*.ole)” as the file type to import.

4. Browse to and select the file you want to open.

5. Click Open  and then click Yes  at the prompt.

The OLE objects import into the current schematic.

Results
OLE objects are placed on the sheet on which they were created. For example, if you originally placed an 
OLE object on Sheet 1 and a second object on Sheet 2, these OLE objects are placed on Sheets 1 and 2 
when imported.

If some of the OLE objects you want to import exist on sheets that do not exist in the current schematic, 
these objects are deleted. For example, you originally created OLE objects on Sheets 1, 2, and 3. The 
schematic you are importing the OLE objects into only has Sheets 1 and 2. The OLE objects from Sheet 3 
are deleted.

Exporting OLE Files
You can export OLE objects from SailWind Logic so that they can be utilized by other programs or other 
SailWind Logic design sessions.

Tip
Handles appear around the object when it is selected.

Procedure
1. Select an OLE object and click the File > Export  menu item.

2. In the File Export dialog box, select OLE (*.ole) as the file type.
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3. Name the file and select a location in which to save the file.

4. Click Save. The .ole  file is created and is available for import into other SailWind Logic schematics.

Tip
You can also import application files from other sources using the Edit > Insert New 
Object  menu item. You cannot import an .ole  file.

ASCII File Format
You can export SailWind design files to the ASCII file format to edit information outside of the SailWind 
design environment. The ASCII files for SailWind Logic are organized into sections, beginning with a 
keyword enclosed with an asterisk.

The first section starts with *SCH, and gives the system setup parameters for the circuit.

The second section, starting with *CAM, lists the default settings for the plot and printing outputs.

Following this, all of the data for each sheet is grouped together in the *SHT* section. This data starts with 
*CAE*, listing the window zoom setting and cursor location for the sheet.

Table  9. ASCII File Formatting Sections

Option Description

*TXT* Free text items in the sheet.

*LINES* 2D line items, including library entry.

*CAEDECAL* Description of the CAE symbol decals for all parts in the sheet.

*PARTTYPE* Description of the part types that appear in the sheet.

*BUSSES* Description of buses in the sheet, including the name and location.

*PART* List of all parts, including their attributes, which appear in the sheet. Gates 
and connector pins are each listed separately.

*OFFPAGE REFS* List of all off-page flags in the sheet. This includes power and ground symbols 
and bus connections.

*TIE-DOTS* List of all tie-dots in the sheet.

*CONNECTION* List of the connections in the sheet, with the signal name and path.

*NETNAMES* List of all net names that are displayed in the schematic.

After all sheets are listed, the file ends with *END*.

Exporting to ASCII Output
Define what information you want to write to an ASCII file.

66 SailWind Logic Guide



 
File Operations

Archiving Your Schematic

Procedure
1. Click the File > Export  menu item.

2. Type a name for the output file, and then click Save.

Tip
The filename and path appear at the bottom of the ASCII Output dialog box.

3. In the ASCII Output Dialog Box, select items in the “Select Sections to Output” area to appear in 
the ASCII file.

You can click Select All  to select all items, or click Unselect All  to clear all selections.

4. In the SailWind Logic Output Version area, select the appropriate version of the software you are 
using from the list.

5. Click OK.

Archiving Your Schematic
You can create a folder, a PDF, and/or a .zip  file that contains all of your schematic files and supporting 
files. This includes the schematic itself, a design file, libraries, and any additional files or folders you want. 
You choose what to archive; all fields are optional.

Procedure
1. Open the schematic you want to archive.

2. Click the File > Archive  menu item.

3. Select the files and folders you want to archive in the Archiver Dialog Box.

4. Click OK.

Results
An archive folder that contains the design and/or schematic files, the libraries, and any additional files and 
folders you have indicated is created.

If you chose to compress the files, the .zip  file is the only file in this folder.

If you chose to create a PDF, the file is created using the schematic name and placed in the archive 
folder.

If you chose to compress the files using the zip format, a .zip  file is created in the following format:

<project_name>YYYYMMDDHHMMSS.zip
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Where YYYY is the year, MM is the month, DD is the day, HH is the hour (using a 24-hour format), MM is 
the minute, and SS is the second of the exact time you created the file. The file contains the same folder 
structure as the archive folder.

68 SailWind Logic Guide



 

 

 

Chapter 5
Design Setup

You can define various options for the initial setup of your design. These include the settings for the 
schematic editor, the part editor, file backups, the work area and grids. You can also specify colors 
settings, and fonts for your SailWind Logic schematic design.

Setting Options
Setting Display Colors
Setting Fonts
Managing Font Replacement
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Setting Options
Using the Options dialog box, you can preset options for commands in SailWind Logic, setting up how 
those SailWind Logic commands will work and overriding the default settings in the default.txt  file. Setting 
options enables you to set up a working environment that suits your design and the way you work.

You can set options for the Schematic Editor  on page 70 and for the Part Editor  on page 71.

Setting Schematic Editor Options
Creating a Backup File
Setting Part Editor Options
Preserving Reference Designators
Work Area and Grid Settings

Setting Schematic Editor Options
SailWind Logic includes an extensive set of options for the Schematic Editor. These options enable you 
complete control over general design properties as well as the appearance of text and line widths.

Procedure
1. While you are in the Schematic Editor, click the Tools > Options  menu item.

2. In the Options dialog box, select the appropriate category—“General”  on page 595, “Design”  on 
page 591, “Text”  on page 723, or “Line Widths”  on page 599.

See also Setting Fonts.

3. Set the options you want to change.

4. Click another category to set its options.

5. When you finish setting options, click OK.

Creating a Backup File
SailWind Logic automatically creates backup files based on the settings you choose. This enables you to 
choose backup intervals, file naming, the number of backup files desired as well as the storage location.

Procedure
1. Click the Tools > Options  menu item, and then select the General  category.

2. In the Interval box (in the “Automatic backups” area), type the time in minutes between automatic 
backups to a file.

3. In the Number of backups box, type the quantity (1-9) of different backup files to create.
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Tip
Backup files are named <filename>#.sch, where # is a sequential number. For example, 
logic1.sch,logic2.sch, and so on.

4. Perform one of the following:

• Click Backup File to change the folder or name of the backup file, and then, in the Backup File 
dialog box, browse to the folder, type the filename, and click Save.

• Select the “Use design name in backup file name” check box to use the design name instead of 
the product name as the filename, for example preview_logic1.sch, preview_logic2.sch  instead 
of logic1.sch, logic2.sch

5. Select the “Create backup files in design directory” check box to place all of your backup files in the 
same directory as the design.

Tip
Click to clear if you want your backup files in one, common backup directory.

6. Click OK.

Results
Table  10. Backup File Creation

If this is selected: The Backup File is Saved

Create backup 
files in design 
directory

Use design Name 
in backup file name

in one common directory without the design name.

X X in the design directory using the design name.

X in the design directory without the design name.

X in one common directory using the design name.

Setting Part Editor Options
You can set the options for the Part Editor including specific design properties such as cursor style, grids, 
text heights and line widths.

Procedure
1. While you are in the Schematic Editor, click the Tools > Part Editor  menu item.

2. In the Part Editor, click the Edit > CAE Decal Editor  menu item.
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3. In the CAE Decal Editor, click the Tools > Options  menu item.

4. In the Options dialog box, select the appropriate category— General  on page 595, Text  on 
page 600, or Line Widths  on page 599.

See also Setting Fonts.

5. Set the options you want to change.

6. Click another category to set its options.

7. If you want to save the options you have set as defaults for creating new parts, click the Save As 
Default button.

These defaults are used for any new parts (Part Types, Connectors, CAE Decals and Pin Decals) 
you create, using either the File > New  menu item in the Part Editor, or from the Library Manager 
dialog. (When you edit existing parts, SailWind Logic begins with the options stored with the part.)

Table 11  lists the options that are saved and set as defaults.
Table  11. Part Editor Options Saved and Set as Defaults

From the Options Dialog
General Category

From the Options Dialog
Text Category

From Setup menu > Fonts
Dialog

Design grid
Labels and Text grid
Display grid
Snap to Grid

Font, style and size of:
Pin Number
Pin Name
Ref-Des
Part Type
Attr Label 1
Attr Label 2

Current font mode (system or 
stroke)

8. When you finish setting options, click OK.

Preserving Reference Designators
When you paste a group in a design, SailWind Logic uses the reference designators current in the saved 
group file. You have the option of enabling or disabling the preservation of group reference designators.

Note:
When reference designators are preserved, if conflicts with current parts exist, SailWind Logic 
renames the duplicate reference designators and generates an error report containing the 
renamed parts. The report displays in the default text editor.

Procedure
1. Click the Tools > Options  menu item. In the Options dialog box, select the Design category.

2. In the Options area, select the “Preserve Ref Des on Paste” check box to preserve group reference 
designators.
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Results
If you enable preservation of group reference designators, SailWind Logic retains all reference 
designation when you copy the group. If you disable preservation, after pasting a group into a new 
design, reference designation starts at the first number; for example, U1. See also Options Dialog Box, 
Design Category.

SailWind Logic Guide 73



Design Setup
Work Area and Grid Settings  

Work Area and Grid Settings
The maximum work area is a square 56 inches by 56 inches. The current grid settings appear on the 
message line at the bottom of the work area, between the current default line width and the current cursor 
X and Y location. When you move an object or use a drafting command, the grid readout is replaced by 
a Delta X and Y reading, calculated from the cursor selection point when the command starts. Minus 
numbers mean left and downward.

Display Grid
Origin and Design Grid
Labels and Text Grid

Display Grid
SailWind Logic uses a dot grid as a drafting aid. You can set this field of white dots called the display grid 
to match your design grid, or set it at larger multiples of the design grid.

Use the General category in the Options dialog box to set the display grid or use the GD Modeless 
Command  on page 569. If you do not want to display the display grid, set it to 10.

Origin and Design Grid
When you start a new file, the default drawing format is centered in the work area with the origin, or 0,0 
point, in the lower left corner. The origin appears as a large white dot. As you move the cursor, its position 
relative to the origin displays in the lower right corner of the screen. The numbers change in the multiples 
of the design grid. The minimum design grid increment is 2 mils.

The design grid intervals begin in all directions from the origin. To set the design grid, use the General 
category in the Options dialog box or use the G modeless command.

During design, if you move a part across the board, the cursor may move smoothly but the part snaps 
from grid point to grid point. When Snap to Grid is checked in the status window, you cannot place a part 
off of the current design grid.

To set the origin while in the Part Editor, select Setup/Set Origin  on page 131 from the menu. Position 
the cursor where you want the new origin located and click.

Labels and Text Grid
All labels, fields, names, attributes, and text use the labels and text grid setting. Like the design grid, the 
minimum grid increment is 2 mils. To set the labels and text grid, use the General category in the Options 
dialog box.

Setting Display Colors
Use the Display Colors dialog box to control the colors of design objects and the design area. SailWind 
Logic saves setup information with the schematic.
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Procedure
1. Click the Setup > Display Colors  menu item.

2. In the Selected Color area, select a color to assign to items.

3. To change the available colors, click Palette. Palette opens the Color dialog box where you can 
specify new colors or customize colors that appear in the Selected Color area.

Tip
Click Default Palette to restore the default color settings in the Selected Color area.
Refer to the Microsoft Windows Help for more information on changing the Color Palette.

4. Click the color box of an object to change the color.

Note:
Two color box columns appear next to the items in the Titles area. “Frg” indicates the 
foreground color of the text item. “Box” indicates the color of the box that is drawn around 
the text item. This box serves two purposes:
• It indicates the exact size of the text item when it is plotted, thereby helping you avoid 

overlaps while moving the item.
• It provides visibility of the text item at very small zoom levels.

5. To make an item invisible, set the object color to the background color.

Tip
When working with the color configuration, note the following:
• The color selection for displaying items or making them invisible does not affect plotting 

of the schematic.
• Background sets the color of the work area surface.

6. To save your color assignments to a file, click Save, and then type the configuration name in the 
Save Configuration dialog box.

Tip
When saving the color configuration, observe the following:
• SailWind Logic saves configuration files in the C:\<install_folder>\<version>\Settings 

folder with a .ccf  extension.
• The configuration names also appear at the bottom of the Setup  menu.
• To modify an existing configuration with the current color settings, click Save. The 

current configuration filename appears in the Save Configuration dialog box. You can 
overwrite the settings in this file, or specify a different .ccf file, and click OK.

7. To change the default palette, complete the modifications to the Selected Color area and 
click Save. Type default  in the Save configuration dialog box to override the existing default 
configuration, and click OK.
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Related Topics
Display Colors Dialog Box - Part Editor
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Setting Fonts
You can set up your designs to use stroke font or the system fonts that ship with the Windows operating 
system. The system fonts installed on your system are available for use.

Restriction:
If the schematic uses fonts or character sets that are not installed on your system, a font 
substitution process begins automatically when the file is loaded. During this process, you are 
asked to select fonts to substitute for those that are missing from your system.

Use the Fonts dialog box to set up or change the fonts to be used in your design.

Choosing Stroke Font or System Fonts
Setting Stroke Font Options
Setting System Font Options
Setting Line Widths
Converting Stroke-to-System Fonts
Converting System-to-Stroke Fonts
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Choosing Stroke Font or System Fonts
Depending upon you design and visual style objectives, you can set up your design to use the stroke font 
or system fonts.

Stroke Font
System Fonts

Stroke Font
Use the Fonts dialog box to set or change the font type in your design. The “stroke” font is a simple font 
that is represented in SailWind Logic using lines and arcs. It does not depend upon any specific Windows 
font being on the system. There are some limitations imposed by the use of the stroke font.

Restrictions and Limitations

• Graphical symbols and special characters, such as arrows, check boxes, and bullets are not 
available in a stroke font.

• Other symbols such as mathematical, technical, and geometrical symbols, plus arrows and 
dingbat blocks are not available in a stroke font.

Procedure
1. Click the Setup > Fonts  menu item.

2. In the Fonts dialog box, select “Stroke” to use stroke font in your design then click OK.

3. Click Yes  when asked to verify that you want to change to stroke font.

Note:
When changing the font type, the following conditions may apply:
• After you confirm your selection, all text in your design changes to the new font type.
• You cannot undo the changes after you switch font types in your schematic. To revert to 

a prior font, you must change it to that type.
• Size and width of text characters in a stroke font are specified in mils; points are used 

exclusively for system fonts.
• Bold, underline, and italic font styles cannot be assigned to a stroke font.

System Fonts
You can choose which font to use as the system font. “System” fonts are typically fonts that are resident in 
your Windows environment and include a large selection of font styles. Be careful to use a font selection 
that is a standard font so that users on other systems can view your files using the same font.
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Setting Stroke Font Options

Restrictions and Limitations

• Be sure the non-ASCII symbols, such as +/-, ohm, and degrees are available on your system for 
the fonts you select. If the character sets you select are not available, a blank space or blank text 
box appears where the symbols should be. In this case, select character sets or fonts that are 
available on your system, and the symbols will display in your schematic.

Procedure
1. Click the Setup > Fonts  menu item.

2. In the Fonts dialog box, select “System” to use a system font in your design.

3. Select the name of the font you want to use from the Default Font dropdown list.

The font in use is shown at the top of the list.

4. Click the button for the font style you want: B  for Bold, I  for Italic, or U  for Underlined.

Tip
You can select any combination of the available styles:
• For example, you can select Bold and Italic or Italic and Underlined.
• By default, the style is regular—neither Bold, Italic, nor Underlined.

5. When you have finished selecting the desired font, click OK.

6. Click Yes  when asked to verify that you want to change the system font.

Note:
When changing the font type, the following conditions may apply:
• The default font and style in use are displayed in the Default Font area.
• If you change to system fonts, a verification message displays, asking for confirmation 

that you want to change to system fonts. After you click OK, all fonts in your design 
change to the new selection.

• You cannot undo the change once you switch font styles in your schematic. To revert to a 
prior font, you must change it to a new font.

• Non-letter symbols, such as ampersand (&), pound sign (#), and copyright (©), 
registered trademark (®), and trademark (™) symbols, as well as the Euro, Pound, Yen, 
and Cent are supported in system fonts.

Related Topics
Setting Fonts

Setting Stroke Font Options
You can set options for the text and line widths of objects in the workspace. The features of these tabs 
change depending on your use of either stroke font or system fonts for design objects.
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Procedure
1. Click the Tools > Options  menu item, and then click the Text  category.

2. To change the size or width of a text item, select a text Type and click the Edit  button, and then 
type a new value in mils in the size or width lists.

Tip
You must select a Type and click the Edit  button for each attribute you want to change; you 
cannot edit both size and width simultaneously.

3. When you have finished making changes, click OK.

Setting System Font Options
You can set the system font options to control how text objects in your design will appear. You can choose 
the font style, size, and other visual characteristics of the selected font.

Procedure
1. Click the Tools > Options  menu item, then click the Text  category.

2. To change the font for a type of text, select a text Type and click the Edit button, and then select 
the font you want from the list.

Note:
Fonts are displayed in the list in the following order:
• The fonts currently used in the design are listed at the top.
• The available system fonts are listed below the dividing line.

3. To change the style, select the check boxes in the B, I, or U columns.

4. To change the text size, select the Size box for the type you want to change, click the Edit  button, 
and type a new value.

Note:
System font sizes are whole point sizes.

5. When you have finished making changes, click OK.

Setting Line Widths
Use the Line Widths category to change the size of line widths in the workspace. This enables the 
capability for you to add visual emphasis to objects in your design.
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Converting Stroke-to-System Fonts

Procedure
1. Click the Tools > Options  menu item, and then click the Line Widths  category.

2. Select a line Type and click the Edit button, and then in the Width column, type a new value for the 
size you want in mils.

3. When you have finished making changes, click OK.

Converting Stroke-to-System Fonts
If your design or visual style objectives change, you can convert text from stroke to system fonts.

Restrictions and Limitations
Be sure the non-ASCII symbols, such as +/-, ohm, and degrees are available on your system for the fonts 
you select. If the character sets you select are not available, a blank space or blank text box appears 
where the symbols should be. In this case, select character sets or fonts that are available on your 
system, and the symbols will display in your schematic.

Procedure
1. Click the Setup > Fonts  menu item.

2. In the Fonts dialog box, click System to use a system font in your design.

3. Select the name of the font you want to use from the list.

The font in use is shown at the top of the list.

4. Click the button for the font style you want: B  for bold, I  for Italic, or U  for Underlined.

Tip
You can select any combination of the available styles:
• For example, you can select Bold and Italic or Italic and Underlined.
• By default, the style is regular—neither bold, italic, nor underlined.

5. When you have finished selecting the desired font, click OK.

Tip
Certain restrictions apply during the conversion:
• All text is converted to the nearest whole point size; there is no fractional point size 

conversion.
• Stroke font line widths are ignored during conversion.

6. Click Yes  when asked to verify that you want to change the system font.

Examples
A stroke font text string with a size of 125 mils becomes a system font text string with a size of 9 points. 
However, a text string with a size of 100 is rounded to 7 points (97 mils).
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Converting System-to-Stroke Fonts
If your design or visual style objectives change, you can convert text from system to stroke fonts.

Restrictions and Limitations

• Graphical symbols and special characters, such as arrows, check boxes, and bullets are not 
available in a stroke font.

• Other symbols such as mathematical, technical, and geometrical symbols, plus arrows and 
dingbat blocks are not available in a stroke font.

Procedure
1. Click the Setup > Fonts  menu item.

2. In the Fonts dialog box, select “Stroke” to use stroke font in your design, and then click OK.

3. Click Yes  when asked to verify that you want to change to stroke font.

Note:
When changing the font type, the following conditions may apply:
• After you confirm your selection, all text in your design changes to the new font type.
• You cannot undo the changes once you switch font types in your schematic. To revert to 

a prior font, you must change it to that type.
• Size and width of text characters in a stroke font are specified in mils; points are used 

exclusively for system fonts.
• Bold, underline, and italic font styles cannot be assigned to a stroke font.

Examples
A system font text string with a size of 9 points becomes a stroke font text string with a size of 125 mils, 
and a text string with a size of 7 points is rounded to 100 mils.

Related Topics
Setting Fonts
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Managing Font Replacement

Managing Font Replacement
When you open a design created with fonts that are not installed on your system, the Font Replacement 
dialog box opens automatically.

Tip
If the schematic uses fonts or character sets that are not installed on your system, empty boxes 
appear where you expect to find text or symbols. Once font replacement process completes, the 
symbols display properly.

There are two types of font replacement:

• Automatic Font Replacement

• Manual Font Replacement

Tip
You can select some fonts for automatic replacement, and select others for manual replacement.

Automatic Font Replacement
Manual Font Replacement

Automatic Font Replacement
If the design you are editing uses a font that is not resident on your system, you can use the automatic 
font replacement feature to substitute the font with one of your available system fonts. This feature uses 
the standard Windows font substitution routine to propose a suitable replacement font.

Procedure
1. When a design is opened that contains a font that is not resident on your system, SailWind Logic 

presents the Windows Font Replacement dialog box. In the Font Replacement dialog box, click in 
the Mode column and select “Skip” to preserve the original font settings, or select “Auto” to use a 
standard Windows font substitution.

Tip
The Design Font column lists the fonts in use.

2. In the Font column, select the name of the font you want to replace.

3. Click OK.
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Manual Font Replacement
If the design you are editing uses a font that is not resident on your system, you can manually replace it 
with one of the resident fonts. You can also use this capability to change an existing font if you need to 
improve legibility or use a compressed font to save space on your schematic sheet.

Procedure
1. When a design is opened that contains a font that is not resident on your system, SailWind Logic 

presents the Windows “Font Replacement” dialog box. In the Font Replacement dialog box, click in 
the Mode box and select “Manual.”

2. In the Font column, select the name of the font you want to replace.

Note:
If you need to replace only one font, only one font displays; clicking in the box has no 
effect.

3. In the Replacement column, select the font you want to use as a replacement.

4. Repeat steps 1-3 for all fonts identified for replacement.

5. Click OK.

Related Topics
Setting Fonts
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Chapter 6
Managing Libraries and Library Data

With SailWind Logic you can create and modify libraries, set searchability, manage library attributes, 
import and export libraries, report on contents, and use search parameters.

The parts, symbols and other items you use to create a schematic in SailWind reside in one or more 
SailWind libraries. A single SailWind library consists of four files, each containing items of a specific type 
identified by the filename extension.

Table  12. SailWind Library Files

File Extension File Contents

.pt Parts  — Data about a part, such as a 74LS02, including logic family, attributes, 
pins, and gates.

.pd Decals  — The graphical representation of the part when it is drawn. It is often 
referred to as the footprint.

.ld Logic  — The graphical representation of a schematic part, such as a NOR 
gate. This section functions as a part list reader only. Use SailWind Logic to 
create and modify Logic decals (sometimes called CAE Decals).

.ln Lines  — General graphical data you can store in the library, such as a 
company logo, to use in any design file.

For information on creating PCB decals, see Creation of a New Decal  in the SailWind Layout Guide.

Convert PADS Libraries to the Current Format
Creating a Library
Displaying Items in a Library
Modifying Library Data
Setting Library Availability and Search Options
Managing Library Attributes
Importing and Exporting Libraries
Creating Library Reports
Wildcards and Expressions
Library Search Order

Convert PADS Libraries to the Current Format
You can convert libraries from a previous version of PADS to the current format. This enables you to 
reuse library content from previous designs and to edit the content in the newer design environment.

For information on how to convert your older PADS libraries to the current SailWind format, see 
Converting Your Libraries  in the SailWind Netlist Library Converter Guide.
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Creating a Library
To add a new library to your library list, you first create a new empty library, and then populate it with 
content. After adding it, you can reposition it in the library list to the preferred location in the search order.

For more information, see Adding Libraries to the Library List.

Procedure
1. Click the File > Library  menu item.

2. In the Library Manager dialog box, click Create New Lib.

3. In the New Library dialog box, specify the folder and library filename, and then click Save.

4. Click Close.

Results
Your library is added to the bottom of the Library list, which is also the last library in the Library Search 
Order. To move your library up in the library list and search order, see Setting the Library List Order.

Displaying Items in a Library
You can display the items that exist in a library in the Library Manager dialog box. You can choose to view 
PCB decals, part types, drafting items, or logic CAE decals.

Procedure
1. Click the File > Library  menu item.

2. In the Library Manager Dialog Box, select a library in the Library list or select All Libraries.

3. Click one of these buttons to display categories of items in the library:

• Decals  — PCB decals (component footprints)

Tip
Use SailWind Layout to edit PCB decals.

• Parts  — Parts

• Lines  — Drafting objects

• Logic  — CAE decals (schematic symbols)
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Displaying Items in a Library

4. To filter the list, type wildcards or expressions  on page 105 in the Filter box, and then click 
Apply.

Tip
An empty filter box yields no results. If you do not want to restrict the results with a filter, 
but display all items, type * (asterisk) and click Apply.

Results
Library item names are displayed in the PCB Decals, Part Types, Line Items, or CAE Decals list. (The list 
name changes based on the Filter you’ve selected.) The preview window displays a graphic of the library 
object.

Note:
Since library Parts have no visual representation, the preview window displays the first CAE decal 
associated with the part.

Related Topics
Creating a Report of the Parts in a Library

Creating a Report of Decals, Lines or Logic Symbols in a Library
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Modifying Library Data
You can modify library data by adding, deleting, copying, editing, or transferring data to meet the 
requirements of your specific design.

Adding Items to a Library
Deleting Items From a Library
Copying a Library Item
Editing Items in a Library
Deleting All Items in a Library
Transferring Library Data

Adding Items to a Library
You can add new items to a library. When added to the library, the items are available for the current and 
future design sessions.

Procedure
1. Click the File > Library  menu item.

2. In the Library Manager Dialog Box, select a library in the Library list.

Restriction:
If you select (All Libraries), the New  button is unavailable.

3. Click one of these buttons to display categories of items in the library:

• Decals  — PCB decals (component footprints)

• Parts  — Parts

• Lines  — Drafting objects

• Logic  — CAE decals (schematic symbols)

4. Click the New  button.

• Decals  — Unavailable. The currently assigned PCB decal displays. Use the Library Manager in 
SailWind Layout to add PCB decals to a library.

See also Creation of a New Decal  in the SailWind Layout Guide.

• Parts  — You will enter the Part Editor. Click the Edit Electrical  button. The Part Information 
dialog box appears so you can define a new part.

See also Modifying Electrical Information for a Part.
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Deleting Items From a Library

• Lines  — New  and Edit  are unavailable. Any 2D drafting items appear, for example, drawing 
formats and title blocks, and you can only copy or delete them. There is no special library lines 
editor. Use drafting tools to create or edit lines and save them to the library.

Tip
To add new drafting items to the library, create and combine  on page 237 the items in 
SailWind Logic, then right-click and click Save to Library.

See also Creating 2D Line Items, Adding Drafting Items to a Library.

• Logic  — You will enter the CAE Decal Editor.

See also Creating a New CAE Decal.

Related Topics
Copying a Library Item

Deleting Items From a Library
You can delete one or more selected items from a library. This enables you to purge old or unwanted data 
from your library and improve library search times.

Procedure
1. Click the File > Library  menu item.

2. In the Library Manager Dialog Box, select a library in the Library list.

Restriction:
If you select (All Libraries), the Delete  button is unavailable.

3. Click the one of these buttons to display categories of items in the library:

• Decals  — PCB decals (component footprints)

• Parts  — Parts

• Lines  — Drafting objects

• Logic  — CAE decals (schematic symbols)

4. To filter the list, type wildcards or expressions  on page 105 in the Filter box, and then click 
Apply.

Tip
An empty filter box yields no results. If you do not want to restrict the results with a filter, 
but display all items, type * (asterisk) and click Apply.
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5. Select one or more items in the PCB Decals, Part Types, Line Items, or CAE Decals list. (The list 
name changes based on the Filter you have selected.)

Tip
Use Ctrl+click to select multiple non-sequential items. Use Shift+click or drag the cursor to 
select a range of items.

6. Click Delete.

Related Topics
Deleting All Items in a Library

Copying a Library Item
You can copy a selected item to another name or another library.

Procedure
1. Click the File > Library  menu item.

2. In the Library Manager Dialog Box, select a library in the Library list.

Restriction:
If you select (All Libraries), the Copy  button is unavailable.

3. Click one of these buttons to display categories of items in the library:

• Decals  — PCB decals (component footprints)

• Parts  — Parts

• Lines  — Drafting objects

• Logic  — CAE decals (schematic symbols)

4. To filter the list, type wildcards or expressions  on page 105 in the Filter box, and then click 
Apply.

Tip
An empty filter box yields no results. If you do not want to restrict the results with a filter, 
but display all items, type * (asterisk) and click Apply.

5. Select an item from the list and click Copy.

6. In the dialog box that opens, select another library to receive the copy of the item, and/or type a 
new item name, and then click OK.
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Editing Items in a Library

• Decals  — Opens the Save PCB Decal to Library Dialog Box

• Parts  — Opens the Save Part Type to Library Dialog Box

• Lines  — Opens the Save Drafting Item to Library Dialog Box

• Logic  — Opens the Save CAE Decal to Library Dialog Box

Related Topics
Importing and Exporting Libraries

Editing Items in a Library
As library content is frequently changing, you can use the Library Manager to edit items in a library. Select 
the item that you want to edit, make the desired edits, and then save the edits to the current library item or 
rename the item as a new library object.

Procedure
1. Click the File > Library  menu item.

2. In the Library Manager Dialog Box, select a library from the Library list.

Tip
If you select (All Libraries), the Edit  button is unavailable.

3. Click the one of these buttons to display categories of items in the library:

• Decals  — PCB decals (component footprints)

• Parts  — Parts

• Lines  — Drafting objects

• Logic  — CAE decals (schematic symbols)

4. To filter the list, type wildcards or expressions  on page 105 in the Filter box, and then click 
Apply.

Tip
An empty filter box yields no results. If you don’t want to restrict the results with a filter, but 
display all items, type * (asterisk) and click Apply.

5. Select an item in the list and click Edit.
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• Decals  — Unavailable. The currently assigned PCB decal appears and you can only copy or 
delete it. Use the Library Manager in the PCB design program to modify the PCB decal.

See Editing a Library Decal  in the SailWind Layout Guide.

• Parts  — You enter the Part Editor. Click the Edit Electrical  button. The Part Information dialog 
box appears so you can edit the part.

See Modifying Electrical Information for a Part, Part Editor Operations.

• Lines  — Unavailable. Any 2D drafting items appear, for example, drawing formats, title blocks, 
etc. and you can only copy or delete them. There is no special library lines editor. Use drafting 
tools to create or edit lines and save them to the library.

Tip
To add new drafting items to the library, create and combine  on page 237 the items in 
SailWind Logic, then right-click and click Save to Library.

• Logic  — Opens the CAE Decal Editor with the selected decal.

See Creating a New CAE Decal.

Deleting All Items in a Library
When you choose to delete all of the items in a library, the software replaces the existing library with a 
new empty one of the same name. By doing so, the software ensures that there are no leftover items in 
your library.

Restriction:
You cannot delete the contents of a read-only library.

Procedure
1. Click the File > Library  menu item.

2. Click Create New Lib. The New Library dialog box displays.

3. Select the library file whose contents you want to delete, click Save, and then click Yes  when 
prompted.

4. Click Close.

Related Topics
Deleting Items From a Library
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Transferring Library Data

Transferring Library Data
There may be times when it is desirable to transfer library objects from one library to another. This may 
be useful when you want to archive a specific library with a design or for creating libraries with a specific 
mixture of content for new designs.

Tip
To copy over single items, see Copying a Library Item.

Procedure
1. Follow the steps to export library data from the library  on page 102.

2. Follow the steps of the Importing Library Data topic of the SailWind Layout Guide  to import the 
library data to another library.
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Setting Library Availability and Search 
Options
Specify the libraries available to the design, the library search order, and other search-related options. 
Operations affect the contents of the Library list in the Library Manager dialog box.

Adding Libraries to the Library List
Removing Libraries From the Library List
Library Content and the Search Order
Setting the Library List Order
Sharing a Library Across a Network
Controlling Library Search Access
Protecting Library Files
Synchronizing With SailWind Layout

Adding Libraries to the Library List
You add libraries to the library list to make their contents available. The library must be listed in the Library 
Manager to search it and use its parts, decals, or line items in your design.

Procedure
1. Click the File > Library  menu item, then click the Manage Lib. List  button.

2. In the Library List Dialog Box, click Add.

3. In the Add Library dialog box select a file type:

• Select Library Files (*.pt9) from the file type list to add a SailWind Logic library.

• Select OrCAD Symbol Library Files (*.olb) from the file type list to add an OrCAD library. The 
OrCAD library translation may take some time. See the progress indicator in the Status Bar.

Any errors, warnings, or messages created during the translation display in the Logic.err  file, which 
opens in the default text editor.

4. Specify the folder and filename of the library to add, and then click Open.

Results
The library is added beneath the currently selected library in the Library list. If a library is not selected, the 
new library is added to the bottom of the list.

Removing Libraries From the Library List
If you want to prevent the contents of a library from being used in a design, remove the library from the 
library list.
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Library Content and the Search Order

Procedure
1. Click the File > Library  menu item, then click the Manage Lib. List  button.

2. In the Library List Dialog Box, select one or more libraries from the Library list and then click 
Remove.

Results
The library files are removed from the Library List but are not deleted from the computer.

Library Content and the Search Order
Parts, symbols, and decals you create do not have to be located in the same library together. When your 
part refers to a symbol or decal in a different library, the software automatically picks up the symbol or 
decal when needed.

If you have multiple library items of one type and with the same name, the first occurrence of the item is 
chosen when the library is searched.

For example, during import of a schematic netlist, the libraries are searched for a 0603 decal. But there 
are two, each in a different library. The libraries are searched from the first library in the list, to the last 
library in the list. The first occurrence found will be selected for use to represent the part in the design.

When you have multiple libraries available, they are processed in their order in the library list whenever 
the libraries are searched. The libraries are searched during the following procedures:

• Searching for library items using various dialogs

• Importing a netlist from the schematic

• Updating your design from the library

• Annotating your design with new components from the schematic

You can change the search order of libraries using the “Library List Dialog Box”  on page 555.

Setting the Library List Order
You can specify the order in which libraries are searched. The libraries are searched in the order in which 
they are listed in the Library list.

Procedure
1. Click the File > Library  menu item, then click the Manage Lib. List  button.

2. Select the library from the Library list in the Library List Dialog Box, and then click Up  or Down  as 
needed.

Results
With each click, the library moves up or down one place in the library list. The libraries are searched top 
to bottom.
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Related Topics
Library Search Order

Sharing a Library Across a Network
You can share a library across a networked environment, to enable more than one user to access the 
library simultaneously.

Procedure
1. Click the File > Library  menu item, then click the Manage Lib. List  button.

2. In the Library List Dialog Box, in the Library list, select the library.

Tip
You can select multiple libraries using the Shift and Ctrl keys.

3. Select the Shared check box.

Results
More than one user can access the library file at the same time.

Controlling Library Search Access
You can enable or disable the searching of a particular library when performing operations that involve 
libraries, such as adding parts.

Procedure
1. Click the File > Library  menu item, then click the Manage Lib. List  button.

2. In the Library List Dialog Box, in the Library list, select the library.

Tip
You can select multiple libraries using the Shift and Ctrl keys.

3. Select the “Allow Search” check box.

Protecting Library Files
The Read Only check box is only a status indicator. It is always shaded and unavailable. You can set 
library read-only status only in the Microsoft Windows File Manager.

Restrictions and Limitations
To ensure file protection, the system administrator who owns the files is the only one who can control the 
process.
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Procedure
1. In Windows File Explorer, locate your library files.

Tip
By default, libraries installed with the software are located at C:\<install_folder>\<version>
\Libraries

2. Select all four library files, right-click and click Properties.

3. In the Properties dialog box, click the General  tab and select the “Read-only” check box.

4. Click OK.

Results
The library Read-Only check box in the Library List Dialog Box  will not update until you reopen the dialog 
box.

Synchronizing With SailWind Layout
You can enable or disable the synchronizing of library settings between SailWind Logic and SailWind 
Layout. When the Synchronize with SailWind Layout check box is checked in SailWind Logic, all changes 
made in the libraries within SailWind Logic are pushed to SailWind Layout.

Tip
To ensure a round-trip synchronization, select the same check box in SailWind Layout.

Procedure
1. Click the File > Library  menu item, then click the Manage Lib. List  button.

2. In the Library List Dialog Box, select the Synchronize with SailWind Layout check box.
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Managing Library Attributes
Use the Manage Library Attributes dialog box to manage attributes on a library-by-library basis. You can 
add, delete, and rename attributes for all parts or decals in an individual library or in all libraries. You can 
also display all the attributes in a library, whether the attributes apply to all items or to individual items.

Tip
This dialog box does not manage attributes in the current design. Use the Manage Schematic 
Attributes Dialog Box  to manage attributes in an open design file.

Adding an Attribute to Multiple Library Items
Deleting Attributes From Library Items
Renaming Attributes of Library Items

Adding an Attribute to Multiple Library Items
You can add an attribute to all parts and decals, or just to parts or decals individually, in one or all 
libraries.

Restrictions and Limitations
This process will yield no result or warning if the library you are working with is read-only. Check the 
status of the library in the Library List Dialog Box.

Procedure
1. Click the File > Library  menu item, then, in the Library Manager dialog box, click the Attr Manager 

button.

2. In the Manage Library Attributes Dialog Box, in the Select Library list, select an individual library or 
the (All Libraries) item at the top of the list.

3. In the Item Types list, choose whether to apply the new attribute to All Items, or only either Part 
Types or PCB Decals.

4. Click Add Attr.

The Add New Attribute to Library Dialog Box  appears.

5. For the Attribute Name, do one of the following:

• Type an attribute name in the box.

• Click Browse Lib. Attr  to search all libraries for an existing attribute name.

6. (Optional) Type a value in the Attribute Value box.

7. Click OK.
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Deleting Attributes From Library Items

The Attribute Name appears in the Attributes in Library list.

8. Click Close.

Results
Your new attribute is added. Check for the new attribute in the Decal Attributes dialog box  (for PCB 
decals) or on the Attributes tab of the Part Information dialog box  on page 631 (for Part Types).

Related Topics
Manage Attributes in a Schematic

Deleting Attributes From Library Items
You can delete one or more attributes from all parts and decals, or just from parts or decals individually, in 
one or all libraries.

Restrictions and Limitations
This process will yield no result or warning if the library you are working with is read-only. Check the 
status of the library in the Library List Dialog Box.

Procedure
1. Click the File > Library  menu item, then, in the Library Manager dialog box, click the Attr Manager 

button.

2. In the Manage Library Attributes Dialog Box, in the Select Library list, select an individual library or 
the (All Libraries) item at the top of the list.

3. In the Item Types list, choose whether to delete the attribute(s) from All Items, or from either Part 
Types or PCB Decals.

4. In the Attributes in Library list, select one or more attributes to delete, and then click Delete Attrs.

5. In the prompt that appears, click OK.

6. Click Close.

Results
Your attribute(s) is deleted. Check for the deleted attribute in the Decal Attributes dialog box  (for PCB 
decals) or on the Attributes tab of the Part Information dialog box  on page 631 (for Part Types).

Related Topics
Manage Attributes in a Schematic

Renaming Attributes of Library Items
You can rename an attributes of all parts and decals, or just of parts or decals individually, in one or all 
libraries.
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Restrictions and Limitations
This process will yield no result or warning if the library you are working with is read-only. Check the 
status of the library in the Library List Dialog Box.

Procedure
1. Click the File > Library  menu item, then, in the Library Manager dialog box, click the Attr Manager 

button.

2. In the Manage Library Attributes Dialog Box, in the Select Library list, select an individual library or 
the (All Libraries) item at the top of the list.

3. In the Item Types list, choose whether to rename the attribute(s) from All Items, or from either Part 
Types or PCB Decals.

4. In the Attributes in Library list, select one or more attributes to rename, and then click Add.

5. Double-click in the New Name cell, type the name, and then click Rename Attrs.

Tip
You can specify the name of an existing attribute. No error message appears when you 
do this. The only time this may have an adverse effect is if both attributes are assigned 
to a single item, in which case the error is reported in the error file and the rename is not 
performed for those items where there are conflicts.

6. Click Close.

Results
Your attribute is renamed. Check for the renamed attribute in the Decal Attributes dialog box  (for PCB 
decals) or on the Attributes tab of the Part Information dialog box  on page 631 (for Part Types).

Related Topics
Manage Attributes in a Schematic
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Importing and Exporting Libraries

Importing and Exporting Libraries
Use the Library Manager dialog box to import or export library data in ASCII format.

Importing Library Data
Exporting Library Data

Importing Library Data
You can import library data from a previously-exported library ASCII file. This provides a convenient 
method for importing library data from another design or from another designer’s library.

Tip
Beginning with PADS 9.0, die parts and flip chips are no longer identified by their family 
designations (DIE or FLP), but instead by the Special Purpose settings in the General tab of the 
Part Information dialog box  on page 637. When you import an ASCII file created by a previous 
PADS version, these Special Purpose settings are automatically set for parts having the logic 
family DIE or FLP. The part’s family designation remains the same.

Procedure
1. Click the File > Library  menu item.

2. In the Library Manager Dialog Box, in the Library list, select the library to receive the library data.

3. To import one of the four file types, you must select the matching filter:

• If the file type is .c, select the Logic filter. This ASCII file contains CAE decals (logic symbols).

• If the file type is .l, select the Lines filter. This ASCII file contains drafting objects.

• If the file type is .d, select the Decals filter. This ASCII file contains PCB decals (component 
footprints).

• If the file type is .p, select the Parts filter. This ASCII file contains part types.

4. Click Import.

Tip
Import fails if the library to receive imported items is read-only.

5. In the Library Import File dialog box, specify the folder and the filename, and then click Open.

Related Topics
Transferring Library Data
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Exporting Library Data
You can export library data into an ASCII file for importing into a library. This provides a convenient 
method for exporting library data to another design or to another designer’s library.

Procedure
1. Click the File > Library  menu item.

2. In the Library Manager Dialog Box, in the Library list, select the library whose data you want to 
export.

3. Click any of the following:

• Decals  — Exports PCB decals (component footprints)

• Parts  — Exports Components

• Lines  — Exports drafting objects

• Logic  — Exports CAE decals (schematic symbols)

4. To filter the list, type wildcards or expressions  on page 105 in the Filter box, and then click 
Apply.

Tip
To display all items in the library, type an asterisk (*) and click Apply.

5. Select one or more items in the list, and then click Export.

6. In the Library Export File dialog box, specify the folder, type the filename, and then click Save.

Results

• The Special Purpose settings of any die parts and flip chips are cleared.

• Die parts and flip chips having a family designation other than DIE and FLP lose their die part or 
flip chip special purpose and become normal parts.

• Any normal parts that have the DIE or FLP family designation are treated as die parts or flip chips 
in the previous PADS version.

102 SailWind Logic Guide



 
Managing Libraries and Library Data

Creating Library Reports

Creating Library Reports
You can create reports from the Library Manager to list any number of library objects. The Parts report 
can be configured to list the values of attributes that you choose to include in the report.

Creating a Report of the Parts in a Library
Creating a Report of Decals, Lines or Logic Symbols in a Library

Creating a Report of the Parts in a Library
From the Library Manager, you can generate a report about the parts in a single library or all libraries. The 
report (an ASCII file) lists each part and its associated attributes.

You can specify the attributes you want reported. Figure 1  and Figure 2  show example parts reports.

Procedure
1. Click the File > Library  menu item.

2. In the Library Manager Dialog Box, select a library from the Library list, or select All Libraries.

3. In the Filter area, click Parts. A list of parts in the library (or in all libraries) appears in the Part 
Types area.

Tip
To refine the list, use the filter field. Type a part name in the field or use wildcards (*) to 
specify a group of parts. Then click Apply.

4. When you have the list of parts you want to report on, click List to File.

5. In the Report Manager Dialog Box, specify the part attributes you want to include in the report.

a. In the Available attributes list, click an attribute to select it.

b. Click Include>>.

The attributes appear in the Selected attributes list.

To remove attributes from the Selected attributes list, select them and click <<Exclude.

6. (Optional) You can refine the list of parts to report on. In the Part Filter field, type a part name in the 
field or use wildcards (*) to specify a group of parts, and then click Apply.

7. Click Run.

8. In the Library List File dialog box, select a folder and file format for the report.

You can select either of two formats:

• Library List format (.lst): Information is formatted in columns for viewing or printing. (Figure 1).

• Comma-separated values format (.csv): format recognized by Microsoft®  Excel®  (Figure 2).
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9. Click Save.

10. In the Report Manager dialog box, click Close.

Results
The Report Manager generates the report and displays a link to it in the Output window. To view or print 
the report, click the link. Notepad opens and displays the report.

Figure 1. Parts Report in .lst Format

Figure 2. Parts Report in .csv  Format

Related Topics
Report Manager Dialog Box

Creating a Report of Decals, Lines or Logic Symbols in a Library

Managing Libraries and Library Data

Creating a Report of Decals, Lines or Logic 
Symbols in a Library
From the Library Manager, you can generate a report listing the decals, lines, or logic symbols in a single 
library. The report is an ASCII file listing each item’s name and the date and time the item was modified.
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Wildcards and Expressions

Procedure
1. Click the File > Library  menu item.

2. In the Library Manager Dialog Box, select a library from the Library list.

Restriction:
The List to File  button is unavailable for Decals, Lines, and Logic Symbols if you select All 
Libraries.

3. In the Filter area, click either the Decals, Lines, or Logic filter.

A list of corresponding items from the library appears in the dialog box (in the “PCB Decals,” “Line 
Items,” or “CAE Decals” area, depending on your filter selection).

Tip
To select one or more specific item, use the filter field. Type an item name in the field or 
use wildcards (*) to specify a group of items. Then click Apply.

4. When you have the list you want to report on, click List to File.

5. In the Library List File dialog box, specify a folder and filename for the report and click Save.

Results
Notepad appears, displaying a list of the item names and the date and time when each was last modified. 
You can print the list from Notepad.

Related Topics
Creating a Report of the Parts in a Library

Managing Libraries and Library Data

Wildcards and Expressions
You can use wildcards and expressions to filter the information that is displayed. This promotes rapid and 
precise browsing of library content.

The filter supports the wildcards and expressions listed in Table 13. Table 14  gives examples of wildcard 
usage.

Table  13. Wildcards and Expressions

Expression: Use to:

* Match any number of characters.

? Match any one character.

[set] Match any character in the specified set.
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Table  13. Wildcards and Expressions  (continued)

Expression: Use to:

Tip:  A set is composed of characters or a range of characters; for example, A-Z 
or 0-9 or a-z.

[!set] or [^set] Match any character not in the specified set.

\ Match a special syntactic character exactly, suppressing the special character's 
syntactic significance.
Tip:  The following characters need the \ before them: `[]*?!^-\'

Table  14. Usage Examples of Wildcards and Expressions

Expression: Results in all items that:

74* Start with 74: 7404, 74LS04, 74622.

74?? Start with 74 followed by any two characters: 7404, 74T2, 74TP.

74??08 Start with 74, followed by any two characters, and end with 08: 74LS08, 
74HC08, 744608.

*08 Start with any number of characters and end with 08: 2146108, 5408, 
54HCT08, 744608.

*08* Start with any number of characters, followed by 08, and end with any 
number of characters: 5408, 5408BE, 54HCT08AE, 74ABT08CE2, 
941M70839.

[57]* Start with 5 or 7 with any number of characters after: 54HCT244, 
5968BAE4, 74ACT44.

[5-7]* Start with 5, 6, or 7 followed by any number of characters: 54LS08, 
6225BE, 69TF77, 74ALS02.

[57]4HCT?? Start with 5 or 7, followed by 4HCT, and end with any two characters: 
54HCT04, 54HCT74, 74HCT27, 74HCT84.

74A[CH]* Start with 74A, followed by C or H, and end with any number of characters: 
74AC244, 74AHCT27.

74A[!C-H]* Start with 74A, followed by any character except the letters C through H, 
and end with any number of characters: 74ABT44, 74ALS244, 74ABF365.

[\\]*08 Start with the character \, followed by any number of characters, and end 
with 08: \LS08, \HCT08, \ABT08.

Library Search Order
The list of libraries in the Library Manager dialog box displays the library search order. When you have 
multiple libraries available, they are processed in their order in the library list whenever the libraries are 
searched.
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Library Search Order

The libraries are searched during the following procedures:

• Searching for library items using various dialogs

• Importing a schematic netlist into SailWind Layout

• Updating your design from the library

• Annotating SailWind Layout with new components from the schematic

You can change the search order of libraries using the Library List Dialog Box.

See also Setting the Library List Order.
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Chapter 7
Library Parts

The processes associated with creating, managing and editing library parts contain many levels of 
detail. You can use the Decal Editor to create CAE decals (schematic symbols) including the editing of 
gates, terminals, pins, pin numbers, sequence numbers, attribute labels, and then use the Part Editor to 
incorporate the data into part types.

Part Editor Operations
Object Selection Control in the Decal Editor
Changing and Updating Library Parts
Creating New Parts from Existing Parts
Save the Part/Decal to the Library
Selecting Multiple Objects in the Decal Editor
CAE Decals
Part Types

Part Editor Operations
Use the Part Editor to create and modify standard schematic symbols such as gates, resistors, 
capacitors, connectors, etc., and special symbols such as ground/power and off-page references. You 
also use the Part Editor to create new CAE decals, pin decals, and assign PCB decals, the physical 
representation of the part in a PCB design system.

You can access the Part Editor by clicking the Tools  > Part Editor  menu item, or clicking the Edit  button 
in the Library Manager dialog box.

Unneeded menu commands and toolbar buttons are removed or replaced with menu commands and 
toolbar buttons specific to creating and modifying parts.

A SailWind Logic part is comprised of the three elements shown in the following table:

Table  15. SailWind Logic Part Elements

Element Description

Part Type The electrical information for a part. This includes the logic family, CAE Decal 
assignment, part name, connection pins, gate swapping information, attributes, etc.
See also Modifying Electrical Information for a Part.

Logic or CAE 
Decal

The CAE decal is the logic symbol that appears on the schematic, for example, a NAND 
gate.
See also Creating a New CAE Decal.

PCB Decal The graphical representation of the part when it is drawn in the PCB design program. It 
is often referred to as the footprint. Assigning a PCB Decal is optional and only required 
if you are passing a netlist to SailWind Layout.
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• Changing and Updating Library Parts

• Creating Single Gate Parts

• Creating Multigate Parts

• Creating New Parts from Existing Parts

• Creating a New Connector

• Creating a New CAE Decal

• Creating a New Pin Decal

• Special Schematic Symbols
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Object Selection Control in the Decal Editor

Object Selection Control in the Decal Editor
You can control object selection using the preset filter settings, or you can use the Selection Filter dialog 
box.

Controlling Object Selection Using Preset Filter Settings
Controlling Object Selection Using the Selection Filter Dialog Box

Controlling Object Selection Using Preset Filter 
Settings
You can control object selection using the preset filter settings that are available from the right mouse 
button menu. This enables quick access for selecting terminals, labels, drafting items or anything.

Procedure
1. Right-click in the Decal Editor.

2. Click Select Terminals, Select Labels, or Select Drafting Items. To select all of these options, 
click Select Anything.

Controlling Object Selection Using the Selection 
Filter Dialog Box
You can control which objects you can select by using the Selection Filter dialog box. This provides quick 
access for selecting parts, gates, nets, pins, buses, connections, 2D lines, text and other design objects.

Procedure
1. Do one of the following:

• Click the Edit > Filter  menu item.

• Right-click in the workspace and click Filter.

• Right-click in the Decal Editor and click Filter.

The Selection Filter dialog box appears.

See alsoUsing the Selection Filter.

2. Select one or more of the items, for example: Pins, Labels, 2D Lines, or Text. To select all of 
these options, click Anything. To clear all of the options, click Nothing.

3. Click Close.

Related Topics
Selecting Multiple Objects in the Decal Editor
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Changing and Updating Library Parts
When you add a part to a schematic, SailWind Logic creates a copy of the library part and adds it to the 
schematic database. Thereafter, the schematic representation is uncoupled from the library. Modifying a 
part in the Part Editor will only affect the library entry of that part, not the current version of the part type in 
the schematic.

Related Topics
Modifying Parts

The Update From Library Function

Creating New Parts from Existing Parts
You can create a new part by adapting an existing part. Make a copy of an existing CAE decal if pins 
need to be added or deleted. Modifying an existing CAE Decal without first making a copy will modify all 
parts that use that decal.

Prerequisites

• Verify which CAE decal is referenced by the part you are going to copy.

• Modify that CAE decal and save it with a new name.

Procedure
1. In the Part Editor, click the File > Open  menu item, or click the Open  button on the toolbar.

2. In the Select Type of Editing Item Dialog Box, click CAE Decal and then click OK.

The Get Gate Decal from Library dialog box displays.

3. In the Items box, type a wildcard or expression  on page 105 to filter the symbols, and click Apply.

4. Click OK.

You enter the Decal Editor and the decal appears.

5. Modify the decal as required.

6. Click the File > Save As  menu item.

The Save CAE Decal to Library dialog box displays.

7. Type a name for the new CAE decal and select a library folder.

8. Click OK.

9. Click the File > Exit  menu item.
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Save the Part/Decal to the Library

Note:
Making a copy of the part uses the same process as making a copy of the CAE decal, 
except you select Part Type instead of selecting CAE Decal from the Select type of editing 
item dialog box.
• Change both the CAE decal and the electrical information, then save it as a new part.
• You can rename a modified decal that you accessed through the part type.

See also Saving Part Types.

Save the Part/Decal to the Library
From within the Part Editor, you can save a part/decal to the library. After adding the part to the library, 
you can then place it into a design.

Procedure
1. Click the File > Save As  menu item.

The Save Part and Gate Decals As dialog box appears.

2. Select a library folder for the new part. The default is C:\<install_folder>\<version>\Libraries.

3. Type a name for the new part or decal.

4. Click OK.

5. Click the File > Exit Part Editor  menu item.

Tip
A checking routine is executed when you save a part. Resolve all errors before exiting the 
Part Editor; parts with errors cannot be added to the schematic.

Selecting Multiple Objects in the Decal Editor
You can select multiple objects in the Decal Editor. This enables you to move, rotate of mirror multiple 
objects simultaneously.

Procedure
1. Use the Filter Selection to determine which objects you can select.

See also Object Selection Control in the Decal Editor.

2. Do one of the following:
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• Right-click in the Decal Editor and select a filter, or click Select All  to select all of the objects 
that are selected in the Filter Selection dialog box.

• Click and drag over the objects you want to select.

• Ctrl+click on each object you want to select.

Tip
When moving multiple objects in the Decal Editor, right-click to access the Rotate 90, X 
Mirror, and Y Mirror commands.
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CAE Decals
Use the CAE Decal Editor to create and edit CAE Decals, otherwise known as schematic symbols or logic 
decals.

Constructing the New CAE Decal
Using the Decal Wizard
Manually Construct the New Part
Creating a New CAE Decal
Creating Single Gate Parts
Creating Multigate Parts
Adding Terminals
Changing Objects in the Decal Editor
Setting a Pin Number
Setting a Pin Name
Setting a Pin Type
Setting Pin Swaps
Changing a Pin Number
Changing a Pin Name
Changing a Pin Decal
Changing Sequence Numbers
Attribute Labels
Creating Attribute Labels
Modifying Terminals
Setting the Origin for a Part
Getting Gate Decals From the Library
Assigning Pin Information to the CAE Decal
Saving a Modified Decal With a Different Name

Constructing the New CAE Decal
Using the Part Editor you can construct a new CAE decal by adding gates and defining the logic family.

Procedure
1. Click the Tools > Part Editor  menu item.

2. In the Part Editor, on the toolbar, click the Edit Electrical  button.

This displays the “Part Information for Part dialog box”  on page 134.

3. In the Part Information for Part dialog box, select the PCB Decals  tab to assign the PCB decal.

The pin count for the assigned PCB decal must be equal to or greater than the number in the 
electrical description.

4. Select the Gates  tab.
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5. Click Add, once for the each gate in the part.

The gates are listed alphanumerically in the Gates multicolumn list box.

6. Double-click on the CAE Decal column for a gate, and then select the Browse (…)  button.

The Assign Decal to Gate dialog box appears.

7. To filter the decals, type a wildcard or expression  on page 105 in the Filter box, and click Apply.

8. Click Assign. Click OK  when you finish assigning decals for the gate.

9. (Optional) Assign gate swapping information for the part.

Refer to the Gates Tab  on page 144 topic for additional information.

10. Repeat steps 5 through 8 for the other gates.

11. Click the Pins  tab to use Pin Count to indicate the number of pins in the part. Enter the number of 
pins for the entire package including signal pins, not for an individual gate.

12. On the General  tab, select a Logic Family and Prefix from the list and other electrical information 
as required.

See also Modifying Electrical Information for a Part.

13. Click OK.

Results
The Part Editor now displays the assigned CAE Decal outlines. Note that no pin information appears.

Using the Decal Wizard
Use the Decal Wizard dialog box to automatically create a new CAE decal. You must be in the Decal 
Editor mode of the Part Editor, and creating gate information, to use this feature.

Procedure
1. Click the Tools > Part Editor  menu item.

2. In the Part Editor, on the standard toolbar, click the New  button.

3. In the Select Type of Editing Item dialog box, click CAE Decal, and click OK.

You are now in the Decal Editor and ready to create a new CAE decal.

4. Click the Decal Editing Toolbar  button.

5. Click the CAE Decal Wizard  button.

6. To set the horizontal and vertical distance from the terminal connection point to the decal outline, 
type a value or use the arrows to indicate the pin length in the Pin Length area.

7. To set the horizontal and vertical distance between pins, type a value or use the arrows to specify 
the distance in the Pin Spacing area.

8. To set the width of the decal outline, type a value or use the arrows in the Min Width box.
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Manually Construct the New Part

Tip
Pin decals are moved left or right to accommodate the box width.

9. To set the minimum height of the decal outline, type a value or use the arrows in the Min Height 
box.

Tip
If you enter a value larger than needed to accommodate the number of input or output 
pins, space is added to the bottom of the decal.

10. In the Left Pins area, select the pin decals for the left, or input, side of the part from the Pin Decal 
list, and then type the number of pins in the Pin Count box or use arrows to indicate the pin count.

11. In the Right Pins area, select the pin decals for the right, or output, side of the part from the Pin 
Decal list, and then type the number of pins in the Pin Count box or use arrows to indicate the pin 
count.

12. In the Upper Pins area, select the pin decal to use for the upper pins, and then type the number of 
pins in the Pin Count box or use arrows to indicate the pin count.

13. In the Lower Pins area, select the pin decal to use for the lower pins, and then type the number of 
pins in the Pin Count box or use arrows to indicate the pin count.

14. Click OK.

Results
The Decal Wizard creates a rectangle of the correct size, adds the pins, and creates place holders for the 
sequence number, pin number, pin type, and swap information.

Tip
Use the Part Editor Drafting toolbar to modify the basic information created by the decal wizard. 
You can add additional terminals, change the pin decal, or change the pin sequence number.

Manually Construct the New Part
You can manually construct a new part for use in your design by creating the 2D line body shape, adding 
terminals, assigning pin numbers and pin names.

Procedure
1. Click the Tools > Part Editor  menu item.

2. In the Part Editor, on the Part Editor toolbar, click the New  button.

3. In the “Select type of editing” dialog box, click Part Type, and click OK.

4. On the Part Editor toolbar, click the Edit Graphics  button. When prompted, click OK  to confirm the 
creation of a new part.
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5. On the Part Editor toolbar, click the Decal Editing Toolbar  button to open the Symbol Editing 
toolbar.

6. Click the Create 2D Line  button, then construct the body of the decal.

Refer to the Creating 2D Line Items  topic for additional information.

7. Click the Add Terminal  button.

See also Adding Terminals.

8. Indicate the locations for the terminals.

9. Right-click and click Cancel  when finished adding terminals.

10. Click the Set Pin Number  button.

11. In the Set Pin Number dialog box, in the Start pin number area, type values in the Prefix and/or 
Suffix boxes.

A preview of pin numbers based on your input is displayed below the boxes.

Tip
Exceptions can be applied:
• Alphabetic and numeric values can be used in either box. For example, A1 or 1A.
• For a single numeric, use either Prefix or Suffix box, and void the other box.

12. In the Increment options area, choose what to increment by clicking either Increment prefix or 
Increment suffix.

13. In the Step value box, type a positive or negative number to increase or decrease the pin numbers 
with consecutive or stepped values.

14. If using alphanumerics, you can select the Use JEDEC pin numbering check box to ensure legal 
alphanumeric values are used.

15. Click OK.

16. Select each pin or pin text in ascending sequence to assign a number.

You can click twice on a pin to skip a number.

Note:
You can use the Change Pin Number  button to change a pin number if necessary.

17. Use the other options of the Symbol Editing toolbar to modify the pin numbers and add pin names, 
pin swapping information, pin type, etc.

18. On the File  menu, select Return to Part, and then click Yes  when the keep changes to gate 
message appears.
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Creating a New CAE Decal
Creating a CAE Decal follows the same basic steps as creating a new packaged part. Start by placing 
SailWind Logic directly into decal editing mode, and then create the new CAE decal.

Procedure
1. Click the Tools > Part Editor  menu item.

2. In the Part Editor, on the Part Editor toolbar, click the New  button.

3. In the Select Type of Editing Item Dialog Box, select CAE Decal.

4. Click OK. Four text entries are displayed in the working area
Table  16. CAE Decal Editing Mode - Text Entries In Working Area

Entry Description

REF The default space reserved for the reference designator in the schematic.

PART-TYPE The default location of the part type name in the schematic.

* Free Label 1 The default location for the first displayed attribute.

* Free Label 2 The default location for the second displayed attribute.

5. Construct the new CAE decal for the part manually or with SailWind-Logic’s Decal Wizard 
automatic part creation tool.

• Use the Decal Wizard  on page 116 to create the outline and add terminals.

• (Optional) Use the Part Editor Symbol Editing Toolbar to add additional terminals, change the 
pin decal, or change the pin sequence number.

• (Optional) Add additional attribute labels. See the Creating Attribute Labels  topic for more 
information.

6. Save the part  on page 113 to the library.

Creating Single Gate Parts
Single gate parts are parts that are represented by a single schematic symbol, such as an application-
specific integrated circuit. Perform the basic procedure for creating a single gate part in the Part Editor.

Creating a new part involves multiple steps, with dialog boxes and information windows to for assistance. 
See the referenced documentation in the steps that follow for additional information.

In the following steps, you create the CAE Decal before entering electrical information. This causes the 
part type and the CAE decal to share the same name. If you want to use an existing CAE decal instead of 
creating a new one, specify the electrical information first.

See also Creating Multigate Parts.
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Procedure
1. Click the Tools > Part Editor  menu item.

2. In the Part Editor, click the Edit > CAE Decal Editor  menu item, or on the Part Editor toolbar, click 
the Edit Graphics  button.

3. In the Select Gate Decal dialog box, enter a name for the decal and click OK  when prompted to 
create a decal for the new part.

Four text entries are displayed in the working area: REF is the default space reserved for the 
reference designator in the schematic. PART-TYPE is the default location of the part type name in 
the schematic. *Free Label 1 is the default location for the first displayed attribute. *Free Label 2 is 
the default location for the second displayed attribute.

See also Attribute Labels.

4. Construct the new CAE decal for the part manually  on page 117 or with the automatic part 
creation tool in the Decal Wizard  on page 116.

5. Within the Part Editor, if you created the CAE decal in step 4 using the Decal Wizard, use the 
Decal Editing Toolbar to modify the pin numbers created by the decal wizard and add pin names, 
gate swapping information, and so forth.

6. On the File  menu, select Complete.

7. Assign electrical information to the part.

a. On the Part Editor toolbar, click the Edit Electrical  button.

The “Part Information for Part”  on page 134 dialog box displays.

b. Set the pin count to indicate the total number of pins in the part.

This is mandatory if there are signal pins in the part that were not added when you created the 
CAE decal in the steps above.

(Optional) Click the Decals  tab to assign the PCB decal.

The pin count for the assigned PCB decal must be equal to or greater than the electrical 
description.

c. On the General  tab, select a Logic Family from the list.

See also Viewing and Setting General Part Information.

(Optional) Select the Pins  tab and assign power and ground signal information.

d. Select the Attributes  tab and assign bill of material and part list information.

e. Click OK.

The Part Editor displays the CAE Decal.

8. Save the part  on page 113 to the library.
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Creating Multigate Parts
Multigate parts are parts that use more than one symbol or gate to represent a complete part in the PCB 
design system, for example, a 7400. This topic discusses the basic procedure for creating a multigate part 
in SailWind Logic.

See the referenced documentation in the topics below for additional information.

The steps required to create a multigate part are as follows:

1. Construct the new CAE decal  on page 115 for the part.

2. Assigning Pin Information to the CAE Decal

3. Save the Part/Decal to the Library.

Adding Terminals
A terminal consists of a pin decal and a series of text strings that define the terminal's number, swap data, 
etc.

Procedure
1. On the Decal Editing Toolbar, click the Add Terminal  button.

2. In the Pin Decal Browse dialog box, select a decal, then click OK.

The pin decal attaches to the cursor.

3. Move the cursor into position and click to anchor the pin.

Before placing the terminal, you can use the popup menu to modify the orientation of the terminal 
and modify terminal information, including the pin number, pin name, pin type, and swap class.

After a terminal is placed, a new terminal, identical to the first, is attached to the cursor for 
placement.

If you defined a pin number or pin name, these are automatically incremented to the next number 
and name for the new terminal.

If you assigned pin type and swap class, the values are copied to the new terminal.

4. When finished, right-click and click Cancel.

Changing Objects in the Decal Editor
Depending upon the object type that you select, you can choose between a number of different methods 
to change one or more objects in the Decal Editor. These include such operations as query/modify, move, 
copy, delete and combine or explode.
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Procedure
1. Select the objects you want to modify.

See also Selecting Multiple Objects in the Decal Editor.

2. Right-click in the Decal Editor for editing options.

3. Refer to the following table to see which editing options are available, depending on the objects 
selected.

Table  17. Decal Editor - Editing Options Based on Selected Object

Objects Selected Menu Commands Available

Drafting Items Query/Modify, Move, Copy, and Delete. Explode and Combine are 
available when multiple objects are selected. (See Modifying Drafting 
Objects)

Labels Move

Terminals Query/Modify, Move, Copy, and Delete (See Modifying Terminals)

Combination Move is available for any combination of objects. Copy and Delete are 
available for all objects except labels.

Setting a Pin Number
Use Set Pin Number to assign pin numbers to several pins. The pin number is incremented each time you 
select a pin.

Procedure
1. On the Decal Editing toolbar, click the Set Pin Number  button.

2. In the Set pin number dialog box, in the Start pin number area, type values in the Prefix and/or 
Suffix boxes.

A preview of pin numbers based on your input is displayed below the boxes.

Tip
When entering pin numbers, observe the following:
• Alphabetic and numeric values can be used in either box. For example, A1 or 1A.
• For a single numeric, use either Prefix or Suffix box, and void the other box.

3. In the Increment options area, choose what to increment by clicking either Increment prefix or 
Increment suffix.

4. In the Step value box, type a positive or negative number to increase or decrease the pin numbers 
with consecutive or stepped values.

5. If using alphanumerics, you can select the “Use JEDEC pin numbering” check box to ensure legal 
alphanumeric values are used.

6. Click OK.
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7. Select each pin or pin text in ascending sequence to assign a number.

You can click twice on a pin to skip a number.

Use the Change Pin Number  button in the Editing Toolbar within the Part Editor to change a pin 
number if necessary.

8. Right-click and click Cancel  when finished.

Setting a Pin Name
Use Set Pin Name to add or change the name for several pins. Pin names label the function of a pin, for 
example, CLK, DATA0, and so forth. The suffix of the name increments each time you select a pin. This 
command does not check for duplicate naming conventions.

Precede the text with the backslash character (\) to add a bar over the text characters.

Procedure
1. On the Decal Editing toolbar, click the Set Pin Name  button.

2. Type the pin name in the information window.

3. Click OK.

4. Select each pin to assign names.

The pin name increments each time you click a pin, enabling you to assign pin names to a part 
sequentially (for example, D0, D1, D2, and so forth). To skip a particular pin name in the sequence, 
select the same pin until the desired pin name appears, then continue selecting other pins.

5. Right-click and click Cancel  when finished.

6. Use the Change Pin Name  button from the Part Editor Decal Editing toolbar to change the name 
of a single pin.
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Setting a Pin Type
Use Set Pin Type to change the type of pin the terminal represents, for example, load, source, and so on. 
You can choose between verb mode or object mode when performing this task.

Setting a Pin Type Using Verb Mode
Setting a Pin Type Using Object Mode

Setting a Pin Type Using Verb Mode
You can use verb mode to set pin types. Start the command and then select one or more objects to which 
you want to apply the command.

Procedure
1. On the Decal Editing toolbar, click the Set Pin Type  button.

The Pin Type information window appears.

2. Select a pin type from the dropdown list box

Table 18  lists the available pin types and their corresponding letters.

3. Select the pins to which to apply the pin type information.

The text string associated with the pin is modified to reflect the new pin type.

4. Repeat steps 2 and 3 if necessary.

5. Right-click and click the Cancel  popup menu item to exit the verb mode.

Setting a Pin Type Using Object Mode
You can use object mode to set pin types. Select one or more objects and then select the command you 
want to use to perform an action on them.

Procedure
1. Select the decal pins to which to apply the pin type information.

2. On the Decal Editing toolbar, click the Set Pin Type  button.

The Pin Type information window appears.

3. Select a pin type from the dropdown list box.

Table 18  lists the available pin types and their corresponding letters.

4. Click OK.

124 SailWind Logic Guide



 
Library Parts

Setting a Pin Type Using Object Mode

Table  18. Characters Used 
to Represent Pin Types

Letter Represents this pin type

B Bidirectional Pin

C Open Collector Pin

G Ground Pin

L Load Pin

O Or-Tieable Source Pin

P Power Pin

S Source Pin

T Tristate Pin

U Undefined

Z Terminator Pin
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Setting Pin Swaps
Use Set Pin Swap to define a swap class for a terminal. The PCB layout software uses swapping 
information for length minimization and routing optimization. The swap class is assigned by a numeric 
value. The number for classes is 0, if the pin is not to be swapped under any circumstances, and 1 
through 99. A pin can be swapped with any other pin within the gate that has the same swap class 
number.

Setting Pin Swaps Using Verb Mode
Setting Pin Swaps Using Object Mode

Setting Pin Swaps Using Verb Mode
You can set pin swaps using verb mode. Start the command and then select one or more objects to which 
you want to apply the command.

Procedure
1. On the Decal Editing toolbar, click the Set Pin Swap  button.

2. Type the number that identifies the swap class in the information window.

3. Click OK.

4. Select the pins to assign as this swap class.

5. Right-click and click the Cancel  popup menu item to exit the verb mode.

Setting Pin Swaps Using Object Mode
You can set pin swaps using object mode. Select one or more objects and then select the command you 
want to use to perform an action on them.

Procedure
1. Select the decal pins to assign as the swap class.

2. On the Decal Editing toolbar, click the Set Pin Swap  button.

3. Type the character that identifies the swap class in the information window.

4. Click OK.
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Changing a Pin Number
This command changes the number assigned to a pin. It does not check for duplicate numbering.

Tip
To assign numbers to several pins in an ascending sequence, use the Set Pin Number  button 
from the Editing Toolbar in the Part Editor.

Changing Pin Numbers Using Verb Mode
Changing Pin Numbers Using Object Mode

Changing Pin Numbers Using Verb Mode
You can change pin numbers using verb mode. Start the command and then select one or more objects 
to which you want to apply the command.

Procedure
1. On the Decal Editing toolbar, click the Change Pin Number  button.

2. Type the new number in the information window.

Tip
Alphanumeric pin numbers are valid.

3. Click OK.

4. Select the terminal requiring a new number.

5. Right-click and click the Cancel  popup menu item to exit verb mode.

Changing Pin Numbers Using Object Mode
You can change pin numbers using object mode. Select one or more objects and then select the 
command you want to use to perform an action on them.

Procedure
1. Select the decal terminal.

2. On the Decal Editing toolbar, click the Change Pin Number  button.

3. Type the new number in the information window.

Tip
Alphanumeric pin numbers are valid.

4. Click OK  to update the selected terminal.
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Changing a Pin Name
Changes the name assigned to a single pin. Pin names are used to label the function of a pin, for 
example, CLK, DATA0, and so on. This command does not check for duplicate naming conventions.

Precede the text with the back slash character (\) to add a bar over the text characters.

Tip
To assign names to several pins in an ascending sequence, use the Set Pin Name  button from 
the Editing Toolbar in the Part Editor.

Changing Pin Names Using Verb Mode
Changing Pin Names Using Object Mode

Changing Pin Names Using Verb Mode
You can change pin names using verb mode. Start the command and then select one or more objects to 
which you want to apply the command.

Procedure
1. On the Decal Editing toolbar, click the Change Pin Name  button.

2. Select the decal terminal requiring a new name.

3. Type the new name in the information window.

4. Click OK.

5. Right-click and click the Cancel  popup menu item to exit verb mode.

Changing Pin Names Using Object Mode
You can change pin names using object mode. Select one or more objects and then select the command 
you want to use to perform an action on them.

Procedure
1. Select the decal terminal.

2. On the Decal Editing toolbar, click the Change Pin Name  button.

3. Type the new name in the information window.

4. Click OK  to update the selected terminal.
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Changing a Pin Decal
You can select a different pin decal for existing terminals in your schematic symbol. This is especially 
useful when defining connector pin usage or when redefining a symbol in the library.

Changing Pin Decals Using Verb Mode
Changing Pin Decals Using Object Mode

Changing Pin Decals Using Verb Mode
You can change pin decals using verb mode. Start the command and then select one or more objects to 
which you want to apply the command.

Procedure
1. On the Decal Editing toolbar, click the Change Pin Decal  button. The Pin Decal Browse Dialog 

Box  appears.

2. Select the new pin decal from the list to add to the gate.

3. Click OK.

4. Select the terminals requiring new decals to complete the change.

5. Right-click and click the Cancel  popup menu item to exit the verb mode.

Changing Pin Decals Using Object Mode
You can change pin decals using object mode. Select one or more objects and then select the command 
you want to use to perform an action on them.

Procedure
1. Select one or more decal terminals.

2. Click the Change Pin Decal  button.

3. Select the in decal required from the list of pin decals.

4. Click OK  to update the selected terminals.

Changing Sequence Numbers
Use Change Sequence Number from the Part Editor Decal Editing Toolbar to change the sequence for 
pins in the part. The pin sequence number is used to set a corresponding number for the pins in alternate 
CAE decals. When you assign pin numbers with Set Pin Number or change a pin number with Change 
Pin Number, the same number is assigned to any alternate decals.
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Procedure
1. On the Decal Editing toolbar, click the Change Sequence Number  button.

2. Select the pin requiring a new sequence number.

3. Type the new sequence number in the information window.

4. Click OK.

Attribute Labels
Attribute Labels are placeholders for attributes within a CAE Decal. When you add an attribute to a part, it 
is placed in this reserved location. SailWind Logic lets you create an unlimited number of attribute labels.

See also Attributes Overview.

Use attribute labels to customize attribute locations in the design. You can create and place attribute 
labels so that when a part is added to a design, assigned attributes are less likely to exist where a 
connection or other design information exists. You can also specify a unique justification or orientation for 
the label.

Tip
When working with attribute labels, observe the following:
• If you add an attribute and do not have an available attribute label, the attribute is added just 

below the insertion point of the part. Additional attributes are added below the last one.
• Attribute labels do not display in the Schematic Editor or the Part Editor. You must be viewing 

a decal to view an attribute label. Use Display Colors to control the display of attribute labels 
when creating or edit a decal. See also Setting Display Colors.

• You can create an attribute label with a specific name; one that matches the actual attribute's 
name. This makes placement of specific attribute information easier. You can also use a 
generic attribute label name, or free label, for any attribute assigned to the part. The name used 
is *Free Label N, where N is the number of the labe

• As you add attributes, they are placed at either the location that matches the attribute name, if 
specified, or the first available free label location. See also Creating Attribute Labels.

Creating Attribute Labels
You can create attribute labels while editing or creating a CAE Decal.

Procedure
1. On the Decal Editing toolbar, click the Add Attribute Label  button.

2. Define the attribute label using one of the following methods:

• Type a name in the Attribute Name list box for the label that corresponds to an attribute.

• Select a name from the Attribute Name list box. When you select an attribute name, it is 
removed from the list box.
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• Select *Free Label to use a free label. When you Select Free Label, the number increments to 
the next available number.

• Select Browse Lib Attr  to open the Browse Library Attributes dialog box, select an attribute 
name from the list and then click OK.

3. (Optional) Set the text size, width, or justification.

4. Click OK.

See also Setting Display Colors.

Modifying Terminals
Use the Terminal Properties dialog box to view or modify the properties of the terminals selected in the 
Decal Editor.

Procedure
1. In the Decal Editor, right-click a decal terminal and click the Properties  popup menu item.

This opens the Terminal Properties dialog box.

2. To change the pin decal for all the terminals selected in the Decal Editor, click Change Pin Decal.

3. In the Pin Decal Browse dialog box, select a pin decal, and then click OK.

4. To change the terminal number, type the new value in the Number box.

If you select multiple terminals in the Decal Editor, this option is unavailable.

5. To change the terminal name, type the new name in the Name box.

If you select multiple terminals in the Decal Editor, this option is unavailable.

6. To change the swap class value, type a new value in the Swap class box.

If the values of the terminals differ, this text box is blank.

7. Click OK.

Setting the Origin for a Part
From within the Part Editor, use the Setup > Set Origin  menu item to specify a new origin for a CAE 
Decal. When you add a part in SailWind Logic, the point of insertion is determined by the origin of the 
decal. You can perform this task while creating or modifying a decal.

Procedure
1. Open a CAE Decal in the Decal Editor and click the Setup > Set Origin  menu item.

2. Indicate a new origin.

An information window with the new X,Y coordinate appears.

3. Click Yes  to accept the new origin.
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Related Topics
Creating a New CAE Decal

Getting Gate Decals From the Library
Use the “Get Gate Decal from Library” dialog box to open an existing CAE Decal in the Part Editor.

Procedure
1. In the Part Editor, click the Open  button.

2. In the “Select Type of Editing Item” dialog box, click CAE Decal and then click OK.

3. Type a wildcard or expression  on page 105 in the Items box to filter the symbols, and click Apply.

4. Select the part from the decals area.

5. Click OK. The selected decal displays.

Assigning Pin Information to the CAE Decal
You can view and modify pin information for a CAE decal in the Part Editor. You can also assign JEDEC 
pin numbering if your symbol requires you to use that standard.

Procedure
1. In the Part Editor, open a Part Type, and click the Edit Graphics  button.

2. In the Select Gate Decal dialog box, select a gate from the Gate list, or select a gate from the work 
area.

The decal displays in the CAE Decal Editor.

3. Click the Decal Editing Toolbar  button to display the Decal Editing Toolbar, then click the Set Pin 
Number  button.

4. In the “Set pin number” dialog box, in the “Start pin number” area, type values in the Prefix and/or 
Suffix boxes.

A preview of pin numbers based on your input is displayed below the boxes.

Tip
When specifying the pin numbers, note the following:
• Alphabetic and numeric values can be used in either box. For example, A1 or 1A.
• For a single numeric, use either Prefix or Suffix box, and void the other box.

5. In the Increment options area, choose what to increment by clicking either Increment prefix or 
Increment suffix.

6. In the Step value box, type a positive or negative number to increase or decrease the pin numbers 
with consecutive or stepped values.
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7. If using alphanumerics, select the “Use JEDEC pin numbering” check box if you want to ensure 
legal alphanumeric values are used.

8. Click OK.

9. Select each pin or pin text in ascending sequence to assign a number.

You can click twice on a pin to skip a number.

Use Change Pin Number  to change a pin number if necessary. Refer to the Terminal Toolbox 
topic for additional information.

The software assigns the same pin numbers to any alternate CAE decals.

10. Set other pin information such as pin type and pin swapping, as needed.

11. Right-click and click the Cancel  popup menu item to exit the process.

12. Repeat the steps for the other gates.

Saving a Modified Decal With a Different Name
If you modify a decal associated with a part type, use the Save Part and Gate Decals As dialog box to 
rename the decal. After modifying the decal, you can save it with a different name.

Procedure
1. Click the File > Return to Part  menu item, and then click Yes  to the “Returning to Part level - Keep 

changes to Gate?” prompt.

2. Click the File > Save As  menu item.

The “Save Part and Gate Decals As” dialog box appears.

3. Select the decal in the Name of Gate Decal multicolumn list box and click Edit.

4. Type a new name for the Decal and click OK.

5. Click Yes  to the “Part Type item exists. Overwrite item?” prompt to replace the current library part 
with the one containing the modified decal.

Related Topics
Saving Part Types

SailWind Logic Guide 133



Library Parts
Part Types  

Part Types
You use the Part Editor to work with part information. This is a collection of the electrical and 
attribute information that represents the physical characteristics of a part as opposed to the graphical 
representation contained in the CAE decal.

Modifying Electrical Information for a Part
Viewing and Setting General Part Information
Editing Logic Families
Assigning PCB Decals
Assigning Gates to Parts
Assigning CAE Decals to Gates
Part Information - Pins
Managing Attributes
Browsing Library Attributes
Part Information - Pin Mapping
Assigning Alternate Logic Decals for Connector Symbols
Saving Part Types
Library Management for Saved Part Types
Saving a Modified Part Type With a Different Name
Creating a New Connector
Browsing for Connectors
Creating a New Pin Decal
Editing Objects in the Decal Editor

Modifying Electrical Information for a Part
Use the Part Information dialog box to modify electrical information for a part. Electrical information 
includes the part statistics, the logic family, the PCB decal assignment, the CAE decal assignment, gate 
and signal pins, gate swapping information, and various other attributes.

You must identify the electrical or part type information, before assigning a CAE Decal to the part.

You access this information by clicking the Tools > Part Editor  menu item, and then, on the toolbar, click 
the Edit Electrical  button.

You can perform the following actions in the Part Information dialog box:

• Viewing and Setting General Part Information  - General  tab

• Assigning PCB Decals  to library parts - PCB Decals  tab

• Assigning Gates to Parts  - Gates  tab

• Part Information - Pins  tab

• Managing Attributes  - Attributes  tab
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• Part Information - Pin Mapping  tab

• Assigning Alternate Logic Decals for Connector Symbols  - Connector  tab

Related Topics
Managing Libraries and Library Data
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Viewing and Setting General Part Information
Use the General  tab in the Part Information dialog box to view part statistics and set family information.

Viewing Part Statistics
Setting the Logic Family
Setting General Part Information

Viewing Part Statistics
Information about the part you are creating or editing is listed under part statistic categories.

Table  19. Part Statistic Categories

Category Description

Pin Count Displays the total number of pins in the part. Includes gate pins, signal 
pins, and unused pins. If multiple decals are assigned with different pin 
counts, a range of smallest to largest decal pin counts is shown.

Decal Displays the name of the decal, as chosen on the PCB Decals tab.

Gate Count Displays how many gates exist in the part.

Signal Pin Count Displays the number of signal pins in the part.

Setting the Logic Family
You can set the logic family to define a component type and assign an alphanumeric Reference 
Designator (RefDes) prefix for part recognition in your design.

Note:
Beginning with PADS 9.0, die parts and flip chips are identified by the Special Purpose settings 
in the Part Type rather than by the DIE and FLP logic families. With this change, any reference 
designator (logic family) can be assigned to a die part or flip chip.

Procedure
1. In the Part Editor, click the Edit Electrical  button and in the Part Information for Part dialog box, 

click the General  tab.

2. To identify the logic family, select a logic family from the list in the Logic Family area.

When you select a logic family, the default reference designator prefix for this part appears next to 
Ref. Prefix.
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Tip
The default is UND, or undefined. If you leave the logic family undefined, the software 
prompts you for the reference designator prefix when you add a part. You can specify an 
alpha prefix or an alphanumeric prefix.

3. Alternatively, if you want to add, delete, and edit logic families and default reference designator 
prefixes, click Families.

The Logic Families dialog box opens.

a. Make your changes and then click OK  to return to the Part Information for Part dialog box.

b. Select the new or updated logic family from the list.

See also Editing Logic Families.

Setting General Part Information
You can set the general part information such as logical to physical pin mapping, special purpose part 
definitions and ECO registration for a part.

Procedure
1. In the Part Editor, click the Edit Electrical  button and in the Part Information for Part dialog box, 

click the General  tab.

2. Select the “Define mapping of Part Type pin numbers to PCB Decal” check box to activate the Pin 
Mapping  tab where you can map logical pin numbers to different physical pin numbers.

Restriction:
Note the following restrictions:
• The check box is unavailable after you add one or more alphanumeric decals to the part 

type. Remove the assigned alphanumeric decal to make the check box available. The 
check box also becomes available if you assign a numeric decal. However, you will still 
need to remove the alphanumeric decal from the list to make the part valid.

• You must assign a decal to use the Pin Mapping  tab.
• Only decals with sequential numerical pin numbers can be used with pin mapping.

3. Select the Special Purpose check box, then select the appropriate radio button to identify the part 
as one of the following types:

• Connector  — In contrast to other part types, connectors do not require a prefix list, or gate 
definitions.

Restriction:
When working with connectors, note the following restrictions:
• This check box is automatically selected when you create or modify connectors. It is 

unavailable if you open a part other than a connector.
• This check box is unavailable when the part already has gate or pin assignments.
• The Gate Decals  tab is unavailable when the Connector check box is selected.
• Some Pins  tab controls not applicable to connector parts are disabled.
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• Die Part  — See the following note.

• Flip Chip  — See the following note.

Note:
Beginning with PADS 9.0, die parts and flip chips are identified by the Special Purpose 
settings in the Part Type rather than by the DIE and FLP logic families. With this change, 
any reference designator (logic family) can be assigned to a die part or flip chip.

4. To enable a part to be passed between the design and schematic file for forward and backward 
annotation, click ECO Registered Part. By default, all existing part types in your design are ECO 
registered.

Tip
Typically, you do not select this check box for non-electrical parts. For example, if you 
create and add a mounting hole to your design in the layout software, you would not need 
the part (mounting hole) to pass back to your schematic when you perform a backward 
annotation of the design.

5. To apply the part information edits to other parts in the library, type prefixes and wildcards into the 
Prefix List box matching the names of the other parts to update.

Note:
Examples of prefix and wildcard usage:
• Question mark ? in a prefix acts as a wildcard for one character. The prefix “?4” is the 

equivalent of “54” or “74”.
• If you type “\02” as the suffix, the edits are applied to all parts ending in 02.

CAUTION:
The software applies the contents of the Prefix List box when you click OK  or Save As 
from other tabs in the Part Information dialog box.

6. Click the Check Part  button to check the part for missing or inconsistent information while the Part 
Information dialog box is open.

7. Click OK.
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Editing Logic Families
To add, delete, or modify logic family names and default reference designator prefixes, use the Logic 
Families dialog box.

Adding a Logic Family
Changing the Name or Prefix of a Logic Family
Deleting a Logic Family

Adding a Logic Family
If you are creating a new part for your design that requires a logic family definition that does not exist in 
the predefined list, you can add a new logic family to the database for use in current and future designs.

Procedure
1. In the Part Editor, open a Part Type, and click the Edit Electrical  button.

2. In the Part Information dialog box, click the General  tab and then click the Families  button.

3. In the Logic Families dialog box, click Add. A new entry opens in the Logic Families list.

4. In the Family text box, type the new logic family name.

5. Click in the Prefix text box, and type the prefix you want to use for the new family.

You can specify an alphabetic prefix or an alphanumeric prefix. The maximum length for the prefix 
is six characters. The last character must be an alphabetic character.

6. Click OK.

Changing the Name or Prefix of a Logic Family
If your design requirements require it, you can change the name or prefix of an existing logic family.

Procedure
1. In the Part Editor, open a Part Type, and click the Edit Electrical  button.

2. In the Part Information dialog box, click the General  tab and then click the Families  button.

3. In the Logic Families dialog box, select the logic family from the list.

4. In the Family text box, type the name of the new family.

5. In the Prefix text box, type the new prefix to associate with the new family.

6. Click OK.

Deleting a Logic Family
If your design requirements change, or you no longer need or support a particular logic family, you can 
delete a logic family.
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Procedure
1. In the Part Editor, open a Part Type, and click the Edit Electrical  button.

2. In the Part Information dialog box, click the General  tab and then click the Families  button.

3. In the Logic Families dialog box, select the logic family that you want to delete from the list.

4. Click the Delete  button.

5. Click OK.

Related Topics
Modifying Electrical Information for a Part
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Assigning PCB Decals
To assign decals, or footprints, to library parts, use the PCB Decals  tab in the Part Information dialog box. 
You must assign a decal before assigning gate information, signal pin names, or pin mapping to a part. 
The decal also specifies the number of pins in the part.

Assigning an Existing Decal
Assigning a New Decal
Unassigning a Decal
Changing the Default Decal
Resetting the Tab Data

Assigning an Existing Decal
There are situations where you might want to define more than one PCB decal to a part. This enables one 
symbol to represent different versions of a part that exist in different physical packages. You can assign 
up to sixteen PCB decals to a part.

Procedure
1. Open a Part Type.

2. On the toolbar in the Part Editor, click the Edit Electrical button and then, in the Part Information 
dialog box, click the PCB Decals  tab.

3. In the Library dropdown list, select the library from which you want to assign decals.

The available decals from the selected library appear in the Unassigned Decals list box.

4. To filter the contents of the Unassigned Decals list use any of the following:

a. Type Wildcards and Expressions  into the Filter box.

Tip
Type asterisk * in the Filter box to display all decals.

b. Type a number in the Pin Count box, and then click Apply.

Tip
Delete all numbers in the Pin Count box to display all decals. This box is always 
available as a filter to enable decals of differing pin counts to be assigned.

c. Click the “Show only Decals with pin numbers matching Part Type” check box to filter out 
decals that do not have pin numbers matching existing gate and signal pins on the Pins  tab, or 
the physical pin numbers on the Pin Mapping  tab.

5. Select a decal name from the Unassigned Decals list box.

6. Click Assign. The selected decal is assigned to the part and moved to the Assigned Decals list 
box.
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Tip
As a shortcut, double-click on a decal name to assign it to the part.

Restriction:
Note the following restrictions:
• You must assign a decal with enough pins for all the defined gate pins and signal pins on 

the Pins  tab.
• Only decals with sequential numerical pin numbers can be used with pin mapping.

7. To assign additional decals to the part, repeat Steps 4 and 5 above.

8. You can check the part for missing or inconsistent information while the Part Information dialog box 
is open. Click the Check Part button.

The software checks the assigned decals when you exit the tab (regardless of whether you click 
the Check Part  button) to ensure they contain physical pin numbers for all the gate and signal pins 
defined in the Pins  tab.

Assigning a New Decal
You can specify a decal that does not exist in the library yet, but may exist in another PCB designer’s 
library, or may be created later.

Procedure
1. Open a Part Type.

2. In the Part Editor, on the toolbar, click the Edit Electrical button and then in the Part Information 
dialog box, click the PCB Decals  tab.

3. Click Assign New.

4. In the New PCB Decal dialog box, type a name and click OK.

The name is added to the end of the Assigned Decals list.

Unassigning a Decal
As your design needs change, you may need to remove a current decal assignment so that you can 
reassign a different decal to a part.

Procedure
1. Open a Part Type.

2. In the Part Editor, on the toolbar, click the Edit Electrical button and then in the Part Information 
dialog box, click the PCB Decals  tab.

3. Select a decal name from the Assigned Decals list box.

4. Click Unassign.
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The decal is unassigned from the part, and moved to the Unassigned Decals list box.

Tip
As a shortcut, double-click on a decal name to remove it from the Assigned Decals list.

Changing the Default Decal
The first decal listed in the Assigned Decals list box is the default decal used when you add the part to 
Layout. You can make any decal in the Assigned Decals list the default decal by moving it to the top of the 
list.

Procedure
1. Open a Part Type.

2. In the Part Editor, on the toolbar, click the Edit Electrical  button and then in the Part Information 
dialog box, click the PCB Decals  tab.

3. In the Assigned Decals list, select the decal that you want to make the default.

4. Click Up  until the decal is at the top of the list.

The decal becomes the default decal.

Resetting the Tab Data
You may sometimes want to discard changes you have made in the current session with the PCB Decals 
tab, and return the tab’s data to its original state.

Procedure
1. Open a Part Type.

2. In the Part Editor, on the toolbar, click the Edit Electrical button and then in the Part Information 
dialog box, click the PCB Decals  tab.

3. Click Reset.

Tip
Clicking Reset  affects the current tab only.

Related Topics
Modifying Electrical Information for a Part

SailWind Logic Guide 143



Library Parts
Assigning Gates to Parts  

Assigning Gates to Parts
Use the Gates  tab to assign gate information to a part, including the number of gates, gate swap 
information, and CAE Decals for the part.

Note:
A space and a period (.) are illegal characters for pin names.

Gate Decal and Alternates
Gate and Pin Swap Information
Assigning Gates to a Part

Gate Decal and Alternates
For each gate, you can enter the CAE Decal name which is the name of the logic symbol that is used to 
display the part in the schematic. Alternate decal assignments must have the same number of pins. One 
primary and three alternate decals may be defined for each gate. Assigning a CAE Decal is optional in 
SailWind Layout, but required in SailWind Logic.

Gate and Pin Swap Information
If at least one decal is assigned to a part, you can enter or modify its gate information. This includes 
enabling or disabling swaps for gates within a part or between similar parts. This information lets SailWind 
Logic know which gates it can substitute for connection length minimization after placement.

To gate swap, assign a number to the gate on the Gates  tab. Gates with like numbers can swap within 
the part, or to other similar parts. A value of one (1) indicates that the gate is swappable with gates of 
the same part type in the schematic database. If a part contains more than one type of swappable gate, 
then identify the second type with the number 2, the third type with 3, etc. The number 0 indicates that no 
swapping can occur.

Assigning Gates to a Part
You can assign gates to a part.

Procedure
1. Open a Part Type, on the toolbar, click the Edit Electrical  button, and then click the Gates  tab.

2. To add a gate to the part, click Add.

The gate appears in the Gate list. The first gate is automatically designated A, the second gate B, 
and so forth.

When you select a gate, the Pins list shows the number of pins for the selected gate.

3. To swap gates with the same Swap ID number, select the gate click Edit, and then type a value 
between 1 and 100 in the Swap column.

To disable swap for the gate, type a value of 0.
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4. To define Logic decals for the gate, select the cell under CAE Decal 1 click Edit, and then type a 
decal name in the CAE Decal box or click the Browse  button to search for a decal from a library.

The Browse  button opens the Assign Decal to Gate dialog box.

Tip
You can define up to 4 alternates; you do not have to define alternates.

See also Assigning CAE Decals to Gates.

5. To remove the selected gate from the Gates list, click Delete.

The gates following the removed gate are automatically renamed in sequential order.

Tip
If you delete a gate, the pins information in the Pins  tab is reset. You can add a gate and 
move the pins from one gate to the other on the Pins  tab to retain pin information before 
you delete the gate.

6. To return the options on the tab to the original settings when the tab first appeared, click Reset. 
This resets only the current tab.

Gate pins are added on the Pins  tab.

See also Part Information - Pins.

Assigning CAE Decals to Gates
The Assign Decal to Gate dialog box is used to assign a decal to each of the gates in a part. Some parts 
may have multiple gates of different types, so you can assign individual specific decals to each of the 
gates.

Procedure
1. Open a Part Type, on the toolbar, click the Edit Electrical  button, and then click the Gates  tab.

2. Select the cell under CAE Decal 1 and click the Edit  button or double-click the cell under CAE 
Decal 1.

3. Type a decal name in the CAE Decal box or click the “...” Browse  button to search for a decal from 
a library.

The Browse  button opens the Assign Decal to Gate dialog box.

4. Select the library from which you want to assign decals.

The available decals from the selected library appear in the Unassigned Decals list box. The list 
changes according to the library you select.

5. To limit the items that appear in the Unassigned Decals list box, type a wildcard or expression  on 
page 105 in the Filter box and click Apply.

6. Select the decals you want to assign to the gate from the Unassigned Decals list and click Assign.
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Tip
When assigning decals, observe the following:
• The decal you select in the Unassigned Decals list box is displayed in the preview box.
• You can assign up to four decals. Assigned decals must have the same number of pins. 

The first decal is the default decal, the decal used when you add a part to the schematic.

7. To change the order, select the decal in the Assigned Decals list and click Up  or Down.

8. To remove a decal from the gate, select it from the Assigned Decals list and click Unassign.

9. To assign a decal name of a nonexistent decal in the library, click Assign New.

The Assign New Gate Decal dialog box appears.

Tip
You can specify a decal that does not exist in your library, but may exist in another 
designer’s library, or that you may create later.

10. Click OK  to apply your changes.
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Part Information - Pins
Use the Pins  tab in the Part Information dialog box to assign gate pins, signal pins, and unused pins to 
the part. Pin numbers added to the Pins  tab, must match those of the PCB Decal. Use the Pin Mapping 
tab to overlay logical (schematic) alphanumeric pin numbers onto the physical numeric PCB decal.

Tip
To undo all changes for this tab only, click Reset.

Adding One or More Pins to a Part
Editing Pin Data
Assigning a Signal Pin
Assigning an Unused Pin
Sorting Table Data
Renumbering Pins
Deleting Pins
Error Checking
Signal Pin Nets
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Adding One or More Pins to a Part
You can add pins to a part using several methods. You can add all pins automatically by assigning a 
decal. You can add a single pin to the part, add a series of pins, and paste pins from a database; or you 
can import pins using a comma separate value (CSV) file.

Adding a Single Pin
Adding a Series of Pins
Assigning a Decal
Pasting Pin Information
Importing Pins Using a CSV File

Adding a Single Pin
You can use the Pins  tab on the Part Information dialog box to add a single pin to a part.

Procedure
1. Open a Part Type, then, on the toolbar, click the Edit Electrical  button.

2. On the Pins  tab of the Part Information dialog box, click the Add Pin  button.

Note:
You must add a pin number to make the pin valid, and then change any other fields as 
needed.

If this is the first pin to be added, it takes the default of belonging to Gate-A. If pins already exist, 
the new pin takes the Pin Group of the currently selected pin.

Adding a Series of Pins
You can use the Pins  tab on the Part Information dialog box to add a series of pins to a part.

Procedure
1. Open a Part Type, on the toolbar, click the Edit Electrical  button, and then click the Pins  tab in the 

Part Information dialog box.

2. On the Pins  tab of the Part Information dialog box, click the Add Pins  button.

3. In the Add Pins dialog box, type the number of pins to add in the Number of pins box.

Tip
Total pins for the part can not exceed 32,767.

4. In the Start pin number area, type values in the Prefix and/or Suffix boxes.

A preview of pin numbers based on your input is displayed below the boxes.
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Tip
When entering pin numbers, observe the following:
• Alphabetic and numeric values can be used in either box. For example, A1 or 1A. If you 

type alphanumerics and the decal uses numerics, you must use the Pin Mapping  tab to 
map the alphanumerics onto the decal.

• For a single numeric, use either the Prefix or Suffix box, and void the other box.

5. In the Increment options area, choose what to increment by clicking either Increment prefix or 
Increment suffix.

6. In the Step value box, type a positive or negative number by which to increase or decrease the pin 
numbers with consecutive or stepped values.

7. If using alphanumerics, you can select the “Use JEDEC pin numbering” check box to ensure that 
legal alphanumeric values are used.

8. Click OK.

The new pins display in the list on the Pins  tab of the Part Information dialog box.

Assigning a Decal
When you assign a decal on the PCB Decals  tab, the pin numbers from the decal are automatically 
populated into the Pins  tab table. PCB Decal pin numbers can be alphanumeric or numeric and the pin 
numbers in the PCB Decal must match the pin numbers listed in the Pins  tab table.

Pasting Pin Information
You can copy selected table data from the Pins  tab or from Microsoft Excel and paste it into the Pins 
table. The selected cell in the table is the paste origin. Data is pasted below and to the right of the paste 
origin.

Procedure
1. Open a Part Type, on the toolbar, click the Edit Electrical  button, and then click the Pins  tab in the 

Part Information dialog box.

2. If you are copying from Excel, select data and use the Excel Copy command.

If you are copying from the Pins  tab, select data and click the Copy  button on the Pins  tab.

3. Click the Paste  button to paste the data into the table starting at the paste origin.

Restriction:
When the pasted data includes either Pin Group or Pin Number data, the software adds 
extra pin rows automatically, otherwise the paste will fail if the number of rows and columns 
in the pasted data does not match those available in the table below and to the right of the 
paste origin.

Importing Pins Using a CSV File
You can import data from a comma separated value file into a pins table.
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Procedure
1. Open a Part Type, on the toolbar, click the Edit Electrical  button, and then click the Pins  tab in the 

Part Information dialog box.

2. Click the Import CSV  button.

3. In the File Open dialog box, browse and select the CSV file.

4. Click Open  to begin the import.

The entire contents of the Pins  tab table is replaced with the data of the CSV file.

Note:
CSV field names must correspond to the column headers in the Pins  tab table. Only the 
first two characters of the header must match. For example, “Pi” for the Pin Group column. 
Gate or “Ga” are acceptable alternatives to the Pin Group header.

Tip
A sample CSV file is located in your \SailWind projects\Samples  folder.

Editing Pin Data
You can click a cell in the row of the pin you are editing to edit the cell contents, or select one or more 
cells of the same column and click the Edit  button.

Procedure
1. Open a Part Type, on the toolbar, click the Edit Electrical  button, and then click the Pins  tab in the 

Part Information dialog box.

2. Click the Pin Group cell and choose gate, signal pin, or unused pin from the list.

Gates listed in the Pin Group cell list are added using the Gates  tab. Signal pins require a signal 
name in the Name cell.

See Assigning a Signal Pin, Assigning an Unused Pin.

3. Click the Number cell and type a pin number for the pin.

The Number cell must contain at least 1 character and can contain up to 15 characters.

Note:
The pin number must match the PCB decal. For example, alphanumeric to alphanumeric.
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Tip
Pin numbers can be either numeric or alphanumeric. Prior to PADS2007, alphanumeric 
pin numbers were not legal on the PCB decal but overlaid the numeric decal numbers, 
and were stored within the Part Type. You can continue to keep numeric PCB decals and 
use the Pin Mapping  tab to overlay different pin numbers onto the numeric PCB decal pin 
numbers. See Part Information - Pin Mapping.

4. Click the Name cell and type a pin signal or function name. For example, “Clock” or “CLK.” A pin 
name is not required. The Name column is not used for unused pins.

Restriction:
Gate pin names can contain up to 40 characters, while signal pin names can contain up to 
47. All alphanumeric characters are accepted. In signal pin names, you cannot use special 
characters such as question marks ?, curly braces {}, asterisks *, periods ., commas , , or 
spaces. But in gate pin names, you can use any character except a space.

5. Click the Type cell and choose a pin type from the list.

The type column is only used with gate pins.

6. Click the Swap cell and type a swap number, or use the up/down arrows.

Tip
You swap pins within gates to uncross connections and facilitate routing. Pins with like 
numbers can swap within a gate. Type 0 to disable swapping.

7. Click the Sequence (Seq.) cell and type the gate sequence number. The sequence number 
determines the mapping of CAE gate pins to PCB decal pins. The sequence is automatically 
shared with alternate CAE decals. For example, the sequence number shows how pin numbers 
appear on the CAE gate decal; therefore, in Gate A, sequence number 1 could be pin 1, but in 
Gate B, sequence number 1 would be pin 4.

Note:
Exception: When editing pin data for connectors, only the Pin Group and Number columns 
are relevant. Data entered in other columns is rejected. Connectors do not have gates, so 
the Pin Group column just indicates whether a pin is a connector pin or an unused pin.

Assigning a Signal Pin
Assign signal names to implicit pins—pins which are not displayed on any gate in the schematic. 
Typically, ground and power pins are the only implicit pins. You are not required to use Signal Pins. 
Instead, you can add power and ground pins to a gate or create a separate gate for power and/or ground 
pins. For the parts in the libraries shipped with SailWind Logic, the standard ground signal name is GND. 
The standard power signal name is +5V.
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Assigning an Unused Pin
You can assign a pin to be an unused pin. An unused pin is a pin that is defined in a PCB decal but has 
no electrical function in the part type. The unused pin information is not saved in the part type, but is 
derived automatically based on the number of assigned gate and signal pins to the number of pins in the 
assigned PCB decal.

Sorting Table Data
You can sort the columns in a pins table in ascending order.

Procedure
1. Open a Part Type, on the toolbar, click the Edit Electrical  button, and then click the Pins  tab in the 

Part Information dialog box.

2. Double-click a column header to sort the column.

Renumbering Pins
You can renumber pins in a pins table on the Pins  tab of the Part Information dialog box. If required, you 
can use JEDEC pin numbering.

Procedure
1. Open a Part Type, on the toolbar, click the Edit Electrical  button, and then click the Pins  tab in the 

Part Information dialog box.

2. Select one or more cells in the Number column.

3. Click the Renumber  button. In the Renumber Pins dialog box, the Number of pins box displays the 
number of pins selected for renumbering.

4. In the Start pin number area, type values in the Prefix and/or Suffix boxes.

A preview of pin numbers based on your input is displayed below the boxes.

Tip
When entering pin numbers, observe the following:
• Alphabetic and numeric values can be used in either box. For example, A1 or 1A.
• For a single numeric, use either the Prefix or Suffix box, and void the other box.

5. In the Increment options area, choose what to increment by clicking either Increment prefix or 
Increment suffix.

6. In the Step value box, type a positive or negative number by which to increase or decrease the pin 
numbers with consecutive or stepped values.

7. If using alphanumerics, you can select the “Use JEDEC pin numbering” check box to ensure that 
legal alphanumeric values are used.

152 SailWind Logic Guide



 
Library Parts
Deleting Pins

8. Click OK  to apply your changes.

The renumbered pins display on the Pins  tab of the Part Information dialog box.

Deleting Pins
If you need to modify the part, you can delete pins in the Pin table on the Pins  tab.

Procedure
1. Open a Part Type, on the toolbar, click the Edit Electrical  button, and then click the Pins  tab in the 

Part Information dialog box.

2. Select one or more cells in the Pin column you want to delete and then click the Delete Pins 
button.

Error Checking
When you click Check Part, OK, or Save As, or when you click a different tab, validation occurs and 
checks are run for error conditions.

The following conditions are checked:

• Empty pin numbers, pin numbers with embedded spaces, duplicated Pin numbers or special 
characters such as question marks ?, curly braces {}, asterisks *, periods ., commas , , or spaces.

• Empty, duplicated, or non-sequential sequence numbers within a single gate.

• Non-empty Type cells for signal pins or unused pins, or empty Type cells for gate pins.

• Pin names with illegal characters for gate pins, net names with illegal characters for signal pins, 
empty name for signal pins. Blank pin names are permitted for gate pins.

• Empty pin swap for gate pins, non-empty pin swap for signal and unused pins. Pin swap values 
for gate pins outside of the range 0 to 100.

Signal Pin Nets
If signal pin nets are invisible, they do not belong to any particular sheet; therefore, they cannot be 
individually selected using the mouse.

See also Signal Pin Nets Dialog Box.
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Managing Attributes
Use the Attributes  tab in the Part Information dialog box to add an attribute to a part. A large number of 
predefined attribute types are available for selection.

See also “Attributes Overview”  on page 222.

Adding an Attribute
Modifying an Attribute
Pasting Attribute Information
Deleting an Attribute
Setting Default Attributes
Adding an Attribute From the Attribute Library
Resetting the Attribute List

Adding an Attribute
You can add attribute names and values to a part using the Part Editor.

Procedure
1. In the Part Editor, open a Part Type, and click the Edit Electrical  button.

2. In the Part Information dialog box, click the Attributes  tab.

3. Click Add.

4. Type an attribute name in the Attribute column.

5. Type an attribute value in the Value column.

6. Click OK  to assign the new attribute.

Modifying an Attribute
You can modify attribute names and values for a part using the Part Editor.

Procedure
1. In the Part Editor, open a Part Type, and click the Edit Electrical  button.

2. In the Part Information dialog box, click the Attributes  tab.

3. Double-click an attribute from the Attribute multi-column list box, or select the attribute and click 
Edit.
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4. Type a new attribute name or value in the appropriate text box.

Tip
Modifying attributes in the Attributes  tab modifies the attribute only in the part being 
edited. Use the Manage Schematic Attributes Dialog Box  and the Library Manager Dialog 
Box  to manage attributes design-wide or in all libraries.

Pasting Attribute Information
You can copy selected table data from the Attribute  tab or from Microsoft Excel and paste it into the 
Attributes table. The selected cell in the table is the paste origin. Data is pasted below and to the right of 
the paste origin.

Procedure
1. In Excel, select data and use the Copy  command in Excel, or on the Attributes  tab, select data 

and click the Attributes  tab Copy  button.

2. Click the Paste  button to paste the data into the table starting at the paste origin.

3. Click OK.

Deleting an Attribute
You can delete attribute names and values for a part using the Part Editor.

Procedure
1. In the Part Editor, open a Part Type, and click the Edit Electrical  button.

2. In the Part Information dialog box, click the Attributes  tab.

3. Select an attribute.

4. Click Delete.

5. Click OK.

Setting Default Attributes
You can save a set of attributes as default attributes to be added automatically each time a new part is 
created.

Procedure
1. In the Part Editor, open a Part Type, and click the Edit Electrical  button.

2. In the Part Information dialog box, click the Attributes  tab.

3. Add all desired default attributes to the list of attributes for a part.

4. Click Save As Default.
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Restriction:
Values are not saved along with the default attributes.

Tip
When the default attribute list is created, it is saved in a defaultattribute.txt  file that is 
shared between SailWind Logic and SailWind Layout.

5. Click OK.

Adding an Attribute From the Attribute Library
You can search through all of the other attribute lists in the library for attributes to add to your current list.

Procedure
1. In the Part Editor, open a Part Type, and click the Edit Electrical  button.

2. In the Part Information dialog box, click the Attributes  tab.

3. Click Browse Lib. Attr  to search for an attribute.

See also Browsing Library Attributes.

4. In the Browse Library Attributes dialog box, select an attribute group from the Group dropdown list 
to limit the display of attributes to only those of a particular group.

5. Locate the attribute you want to add from the list and double-click it or select it and click OK  to add 
it to the Attributes  tab in the Part Information dialog box.

6. Click OK  to close the Part Information dialog box.

Resetting the Attribute List
If you make changes to the attribute list and then later decide you do not want to keep them, you can 
reset the Attribute list for the current session back to the state it was in before the tab was accessed.

Procedure
1. In the Part Editor, open a Part Type, and click the Edit Electrical  button.

2. In the Part Information dialog box, click the Attributes  tab.

3. Click the Reset  button to undo all changes made in the current editing session (returns the 
attribute list to before the tab was accessed).

Restriction:
Only the current tab is reset.
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Browsing Library Attributes
You can browse and list all of the attribute names from libraries specified in the Library List dialog box.

Procedure
1. Click the Browse Lib. Attr  button to open the Browse Library Attributes dialog box.

2. In the Filter list, select a category of attributes to match your search.

Note:
Click Refresh  to update the Attributes in library list.

3. Select an attribute from the list.

4. Click OK.

Tip
The Attributes in library list includes part type and decal attributes.
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Part Information - Pin Mapping
Use the Pin Mapping  tab in the Part Information dialog box to overlay alphanumeric pin numbers onto 
numeric PCB decal pins. Prior to PADS 2007, alphanumeric pin numbers could not be saved in PCB 
decals.

Requirements:

• On the General  tab, select the “Define mapping of Part Type pin numbers to PCB Decal” check 
box to make the Pin Mapping  tab available.

• On the PCB Decals  tab, assign a decal with sequential numerical pin numbers to use the Pin 
Mapping  tab. The decal determines the number of pins in the part.

Tip
To undo all changes for this tab only, click Reset.

Mapping Alphanumeric Pin Numbers to Numeric Decals
Unmapping Pins
Checking the part

Mapping Alphanumeric Pin Numbers to Numeric Decals
You can use the Pin Mapping  tab to map alphanumeric pin numbers to numeric decals.

Prerequisites

• On the General  tab of the Part Information dialog box, select the “Define mapping of Part Type 
pin numbers to PCB Decal” check box to make the Pin Mapping  tab available.

• On the PCB Decals  tab, assign a decal with sequential numerical pin numbers to use the Pin 
Mapping  tab. The decal determines the number of pins in the part.

Procedure
1. Click the Pin Mapping  tab of the Part Information dialog box. In the decal list above the preview 

window, select the assigned decal to which you want to map alphanumeric pins.

2. Map the pins using one of the following methods:

• In the Unmapped Pins list, select one or more alphanumerics. Select one or the starting row in 
the Part Type column if you have a consecutive list to map. Click Map.

• Select a cell in the Part Type column and click the Edit  button, or simply double-click the cell.

• Select an alphanumeric in the Unmapped Pins list and double click the pin in the decal preview 
window to map the alphanumeric to the pin. The next row in the Unmapped Pins list becomes 
the next selected alphanumeric for mapping.
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• Click Copy Map  to copy both columns of the mapping table. Paste the mapping table into 
Excel. Make mass edits. Copy the data from Excel and click Paste Map  on the Pin Mapping 
tab.

Restriction:
Copy Map  and Paste Map  only work with the whole pin mapping table and not selective 
rows.

3. Repeat as necessary.

4. Click OK.

Unmapping Pins
You can use the Pin Mapping  tab to unmap pins from a decal.

Prerequisites

• On the General  tab of the Part Information dialog box, select the “Define mapping of Part Type 
pin numbers to PCB Decal” check box to make the Pin Mapping  tab available.

• On the PCB Decals  tab, assign a decal with sequential numerical pin numbers to use the Pin 
Mapping  tab. The decal determines the number of pins in the part.

Procedure
1. On the Pin Mapping  tab of the Part Information dialog box, select a Decal pin number.

2. Click Unmap.

Checking the part
After you have finished entering or editing part information, you can check to ensure the information 
entered in the Part Information dialog box is correct.

Procedure
Click the Check Part  button to check for missing or inconsistent information entered in the Part 
Information dialog box.

Assigning Alternate Logic Decals for Connector 
Symbols
Use the Connector  tab to define the alternate Logic decals to display in a schematic. Decals are referred 
to as Special Symbols. You can associate a logical Pin Type with each alternate so that you can have a 
graphical indication of the connector pin function in the schematic.
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Restriction:
The Connector  tab is available only when you open an existing connector or create a new 
connector.

Tip
Many users like to use a different symbol, or decal, to distinguish between input (Source) and 
output (Load) pins. You may define multiple symbols for each of the ten different pin types.

You can define Special Symbols, or connector decals, for different pin types in the part.

Procedure
1. Open a Part Type, click the Edit Electrical  button on the toolbar and then click the Connector  tab.

2. Click Add.

3. Type a Special Symbol or select one from a library by clicking the Browse  button.

The Browse  button opens the Browse for Special Symbols Dialog Box.

4. Double-click the new Pin Type entry, or select the new entry and click Edit.

5. Select a Pin Type from the Pin Type dropdown list.

6. If you want to remove the special symbol from the list, click Delete.

7. To return the options on the tab to the original settings when the tab first appeared, click Reset.

Tip
Reset  only resets the current tab.

Saving Part Types
After you finish defining or editing your Part Types, you can save them to the library for further use in the 
current and future design sessions.

Use the Save Part and Gate Decals As Dialog Box  to save part types to the library. You can also rename 
the associated decal during the save process. If you change the pin count or other information in the 
decal, this prevents other parts that use the same decal from being affected.

Tip
The Change Type option of the Part Properties dialog box will not update the schematic copy 
of the part with the modified version in the library if you decrease the number of pins in the 
associated decal.

160 SailWind Logic Guide



 
Library Parts

Library Management for Saved Part Types

Procedure
1. Click the File > Save As  menu item.

2. In the “Save Part and Gate Decals As” dialog box, type a name in the Name of Part text box.

3. Select a library location from the Library dropdown list box.

To change the name of the associated decal, select the decal from the CAE Decal column of the 
Names of Decals multicolumn list box and click Edit.

Type a new name for the decal.

4. ClickOK.

5. If the part type already exists, the message “Part Type item exists. Overwrite item Y/N?” appears. 
Click Yes  to overwrite the part or No  to cancel the save.

6. If you modified the part using Edit Part/Hierarchical Symbol to enter the Part Editor, the message 
“Update all parts of Part Type” appears. Click Yes  to update parts on the schematic with the 
revised library version or No  to leave the schematic version of the part unchanged.

Library Management for Saved Part Types
Knowing where parts are located can help you to better manage your library content. Part Type and 
decals are saved in specific locations so that they can be logically arranged and found when needed.

The library folder used for part types and associated decals is described below:

• Part type data is saved under the name and library chosen in the Save Part and Gate Decals As 
dialog box.

• Decals created when editing the part type are saved in the same library as the part type.

• Decals that are modified but not renamed are saved to the library from which they were opened.

• Renamed decals, whether modified or not, if unique across all libraries, are saved in the same 
library as the part type.

• Renamed decals that are not unique across all libraries display the overwrite warning prompt. If 
you click Yes  to overwrite an existing decal with the renamed decal, it replaces the library copy in 
its current library. If you answer No  to the overwrite prompt, you can select a different decal name 
and folder.

Related Topics
Save Part and Gate Decals As Dialog Box

Saving a Modified Decal With a Different Name

Saving a Modified Part Type With a Different Name
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Saving a Modified Part Type With a Different Name
If you modify a part type and want to keep the existing library copy, use the Save Part and Gate Decals 
As dialog box to rename the part. After modifying the electrical information you can save the modified 
part.

Procedure
1. Click the File > Save As  menu item.

The Save Part and Gate Decals As dialog box appears.

2. Type a new name for the part type in the Name of Part text box.

3. (Optional) Use the Library dropdown list box to specify a new library location.

See also Library Management for Saved Part Types, Saving a Modified Decal With a Different 
Name.

4. Click OK.

Related Topics
Saving Part Types

Creating a New Connector
Connectors differ from other parts in that a connector is typically shown as a number of individual pins, 
rather than a single complete part. When a connector is used on a schematic, the pin number rather than 
the reference designation is incremented, for example, P1-1, P1-2, P1-3, not P1, P2, P3.

Also, you can assign several CAE Decals to a connector for left and right side locations on the schematic 
and for alternate decals. The connectors supplied with SailWind Logic use the prefix CON in their name. 
You can open an existing connector to see how they are constructed.

Procedure
1. In the Part Editor, click the New  button.

2. In the Select type of editing item dialog box, select “Connector” and then click OK.

3. Click the Edit Electrical  button. The Part Information for Part -- New Connector dialog box  on 
page 134 displays.

4. On the Pins  tab, add pins.

For more information, see Part Information - Pins.

5. Select the Connector  tab.

6. Add the schematic symbols for the connector in the Special Symbols area.

See also Connector Tab  on page 159.

7. Select the PCB Decals  tab to assign PCB decals for the connector.

See also PCB Decals Tab  on page 141.
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8. Select the Attributes  tab to assign attribute information.

See the Managing Attributes  topic for more information.

9. Click OK  to close the Part Information dialog box. The connector symbols display in the Part Editor.

10. Click the File > Save As  menu item.

11. Enter a name and library folder location.

12. Click OK.

13. Click the File > Exit Part Editor  menu item.

Browsing for Connectors
Use the Browse for Connector dialog box to access the library and open an existing connector.

Procedure
1. Type a wildcard or expression  on page 105 in the Items box to filter the connectors, and click 

Apply.

2. Select a connector from the list.

3. Click OK. The connector decal(s) display in the Part Editor.

Related Topics
Creating a New Connector
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Creating a New Pin Decal
Pin Decals are used to represent the terminal pins on a part. You can make a copy of an existing pin 
decal and modify it or you can create a new pin decal.

Create a New Pin From an Existing Pin Decal
Create a New Pin Decal

Create a New Pin From an Existing Pin Decal
To save design time and promote reuse, you can create a new pin from an existing pin decal.

Procedure
1. In the Part Editor, click the Open  button.

2. In the Select Type of Editing Item Dialog Box, select “Pin Decal” and then click OK.

The Pin Decal Browse dialog box displays.

3. Select an existing pin decal from the Pins area.

The highlighted decal is displayed in the Picture area.

4. Click OK.

5. Modify the graphics for the decal and position the text strings as required.

6. Click the File > Save As  menu item.

The Save Item to Library dialog box displays.

7. Enter a name and library location for the new pin decal.

8. Click OK.

Create a New Pin Decal
When you create a new Pin Decal, SailWind Logic automatically creates the necessary text strings for 
the associated pin information. You only need to specify the 2D lines that represent the terminal pin, then 
reposition the text strings.

Procedure
1. In the Part Editor, click the New  button.

2. In the Select Type of Editing Item Dialog Box, select Pin Decal.

3. Click OK.

Four text entries are displayed in the working area:
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• #E is a placeholder for the pin number.

• PNAME is a placeholder for the pin name.

• NETNAME is a placeholder for the net name.

• #0:TYP=U SWP=0 are placeholders for the sequence number, pin type and swap class.

4. Use the Create 2D Line button in the Decal Editing toolbar to create the pin decal.

5. Reposition the text strings, if necessary.

6. Click the File > Save  menu item.

The Save Item to Library dialog box appears.

7. Enter a name and library location for the new pin decal.

8. Click OK.

Tip
To control which decals are displayed in the Pin Decal List, use the Pin List Manager

Editing Objects in the Decal Editor
The Decal Editor offers a flexible environment for editing your decals. You can create new parts, edit 
existing parts and also create derivative parts from existing parts.

To edit objects in the Decal Editor, refer to the following topics:

• Object Selection Control in the Decal Editor

• Selecting Multiple Objects in the Decal Editor

• Changing Objects in the Decal Editor

• Modifying Terminals
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Chapter 8
Special Schematic Symbols

Special Symbols in SailWind Logic include power symbols, ground symbols, and off-page reference 
symbols. SailWind Logic enables only one part definition in the library for Special Symbols. For this 
reason, the options for these types are grayed out and unavailable when you are in the Part Editor and 
you select File menu > New. You can only modify the existing symbols or add new symbols to the part 
definition.

Special Symbol Naming Conventions
Assigning Alternative Symbols for the Ground Part
Assigning Alternative Symbols for the Off-Page Part
Assigning Alternative Symbols for the Power Part
Creating New Special Symbols
Creating New Special Symbols From Existing Symbols
Updating Special Symbol Mappings
Management of Special Symbols in the Library

Special Symbol Naming Conventions
The special symbols in the SailWind Logic library use specific names or a unique naming prefix. This 
topic contains tables that provide definitions that can help you to locate a special symbol in the library.

Table  20. Off-Page Reference Symbols

Symbol Description

REFIN Off -page reference for left side

REFOUT Off -page reference for right side

Table  21. Power Symbols

Symbol Description

+ +5 volt and +12 volt symbols, arrow pointing up

- -5 volt and 12 volt symbols, arrow pointing down

BUBBLE +5 volt symbol with a circle

Y +5 volt symbol with a ‘Y’ shape

Table  22. Ground Symbols

Symbol Description

GND Standard ground

SailWind Logic Guide 167



Special Schematic Symbols
Assigning Alternative Symbols for the Ground Part  

Table  22. Ground Symbols  (continued)

Symbol Description

AGND Analog ground

CHGND Chassis ground

Assigning Alternative Symbols for the Ground 
Part
If your design requires the use of multiple ground symbols, use the Assign Alternatives for Ground Part 
dialog box to assign ground symbols.

Procedure
1. In the Part Editor, on the toolbar, click the Open  button.

2. In the Select Type of Editing Item Dialog Box, click Ground and then click OK.

The current symbols are displayed.

3. Click the Edit Electrical  button.

4. Click Add. This creates a new entry for the symbol.

Tip
To add a new ground symbol, follow the procedure in Creating New Special Symbols.

5. In the Special Symbol column, click the button to the right of the newly created text box.

The “Browse for Special Symbols dialog box”  on page 487 appears.

6. To filter the symbols, type a wildcard or expression  on page 105 in the Items box, and click Apply.

7. Select a symbol decal.

8. Click OK.

9. In the Assign Alternatives for Ground Part Dialog Box, select the text box under Pin Type.

10. Click Edit.

11. Select a pin type from the dropdown list box.

This is normally set to Ground.

12. Select and edit the text box for the Signal Name.

13. Click OK.
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Assigning Alternative Symbols for the 
Off-Page Part
If your design requires the use of multiple different off-page symbols, use the Assign Alternatives for Off-
Page Part dialog box to assign additional off-page reference symbols.

Note:
See “Special Schematic Symbols”  on page 167 for additional information on the creation and 
use of special schematic symbols.

Procedure
1. In the Part Editor, on the toolbar, click the Open  button.

2. In the Select Type of Editing Item Dialog Box  click Off-page and then click OK.

The current symbols are displayed.

3. Click the Edit Electrical  button.

4. Click Add.

This creates a new entry for the symbol.

Tip
To add a new off-page reference symbol, follow the procedure in Creating New Special 
Symbols.

5. In the Special Symbol column, click the button to the right of the newly created text box.

The Browse for Special Symbol dialog box  on page 487 appears.

6. To filter the symbols, type a wildcard or expression  on page 105 in the Items box, and click Apply.

7. Select a symbol decal.

8. Click OK.

9. In the Assign Alternatives for Off-Page Part Dialog Box, select the text box under Pin Type.

10. Click Edit.

11. Select a pin type from the dropdown list box.

Tip
For left side off-page references, select Source, for right side, select Load.

12. Click OK.

SailWind Logic Guide 169



Special Schematic Symbols
Assigning Alternative Symbols for the Power Part  

Assigning Alternative Symbols for the Power 
Part
If your design requires the use of multiple different power symbols, use the Assign Alternatives for Power 
Part dialog box to assign additional power symbols.

Procedure
1. In the Part Editor, on the toolbar, click the Open  button.

2. In the Select Type of Editing Item Dialog Box, click Power, and then click OK.

The current symbols appear.

3. Click the Edit Electrical  button.

4. Click Add.

This creates a new entry for the symbol.

Tip
To add a new power symbol, follow the procedure in Creating New Special Symbols.

5. In the Special Symbol column, click the button to the right of the newly created text box.

The “Browse for Special Symbols dialog box”  on page 487 appears.

6. To filter the symbols, type a wildcard or expression  on page 105 in the Items box, and click Apply.

7. Select a symbol decal.

8. Click OK.

9. In the Assign Alternatives for Power Part Dialog Box, select the text box under Pin Type.

10. Click Edit.

11. Select a pin type from the dropdown list box.

This is normally set to Power.

12. Select and edit the text box for the Signal Name.

13. Click OK.

Creating New Special Symbols
Special symbols in SailWind Logic include power symbols, ground symbols, and off-page reference 
symbols. SailWind Logic enables only one part definition in the library for special symbols. For this 
reason, the options for these types are unavailable when you are in the Part Editor and you select the 
File > New  menu item.

See also Creating New Special Symbols From Existing Symbols.
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Procedure
1. In the Part Editor, click the Open  button.

2. In the Select Type of Editing Item Dialog Box, select the type of symbol to add: Off-page, Power, or 
Ground.

3. Click OK.

The currently defined symbols display for the chosen type.

4. Click the Edit > Part Type Editor  menu item, or on the toolbar, click the Edit Electrical  button.

The Assign Alternatives dialog box for the type of Special Symbol appears.

Refer to the following topics for additional information:

• Off-page symbols  — Refer to Assigning Alternative Symbols for the Off-Page Part.

• Power symbols  — Refer to Assigning Alternative Symbols for the Power Part.

• Ground symbols  — Refer to Assigning Alternative Symbols for the Ground Part.

5. Click Add. The software creates a new entry.

6. Type a name for the new symbol and enter the appropriate information.

Tip
For left side off-page references, select Source, for right side, select Load.

7. Click OK.

8. Click the Edit > CAE Decal Editor  menu item, or on the toolbar, click the CAE Decal Editor 
button.

The Select Pin Decal Dialog Box  appears.

9. Select the new symbol name and when prompted, click OK  to create the new symbol.

10. Click the Decal Editing Toolbar  button, click the Create 2D Line  button, and then right-click and 
use the available commands to create the symbol.

Tip
In the schematic, the net connection point will be the origin of the symbol.

11. Reposition the text strings as required.

12. Click the File > Return to Part  menu item, and when prompted, click Yes  to keep the gate 
changes.

The new symbol and existing symbols are displayed.

13. Click the File > Save  menu item.
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If the Save Part Type to Library Dialog Box  displays, accept the defaults and click OK.

14. Click the File > Exit Part Editor  menu item.

Tip
For SailWind Logic to recognize the new special symbol, perform the instructions in The 
Update From Library Function.

Creating New Special Symbols From Existing 
Symbols
Special symbols in SailWind Logic include power symbols, ground symbols, and off-page reference 
symbols. SailWind Logic enables only one part definition in the library for off-page reference symbols, so 
this option is unavailable when you click the New  button to create a new part. You can modify the existing 
symbols and/or add new symbols.

See also Creating New Special Symbols.

Procedure
1. Do one of the following:

• Copy an Existing Special Symbol

a. In the Library Manager (File > Library  menu item), click the Logic  button.

b. To filter the symbols, type a wildcard or expression  on page 105 in the Filter box, and click 
Apply.

See also Special Symbol Naming Conventions.

c. Click Copy. The Save CAE Decal to Library dialog box displays.

Tip
Copy  is unavailable if the Library list is set to All Libraries. (The library name is listed 
before the item in the CAE Decals list.) Double-click on the symbol to enter the library 
and then click Copy.

d. Type a name for the new special symbol.

e. Click OK.

• Modify an Existing Special Symbol

a. In the Library Manager, click the Logic  button.

b. To filter the symbols, type a wildcard or expression  on page 105 in the Items box and click 
Apply.

c. Select the symbol in the CAE Decals area.
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d. Click Edit.

Tip
Edit  is unavailable if the Library list is set to All Libraries. (The library name is listed 
before the item in the CAE Decals list.) Double-click on the symbol to enter the library 
and then click Edit.

e. Minimize the Library Manager dialog box or move it to one side.

f. Modify the graphics and rearrange the text strings as required.

g. Click the Save  button.

2. Close the Library Manager dialog box or use it for another operation.

Refer to the following topics for information on assigning the new decal as an alternate decal:
Table  23. Topic List Regarding Assigning New Decal as Alternate Decal

Alternate symbols Topic to see

Off-page symbols Assigning Alternative Symbols for the Off-Page Part

Power symbols Assigning Alternative Symbols for the Power Part

Ground symbols Assigning Alternative Symbols for the Ground Part

Updating Special Symbol Mappings
You can change the assignment or “mapping” of a special symbol using the Update from Library function. 
For example, you can assign a new ground symbol to both a common ground and an analog ground.

Procedure
1. Click the Tools > Update from Library  menu item.

2. In the Mode area of the Update From Library Dialog Box, choose “Update design from library.”

3. In the Items area, select one or more of the following check boxes:

• Off-page symbols

• Ground symbols

• Power symbols

4. Click OK.

5. In the Schematic Symbol column of the Remap Special Symbols Dialog Box, locate the power, 
ground, or off-page symbol that you want to re-map double-click on the corresponding Library 
Symbol box and then select the new symbol that you want to assign to the schematic symbol.
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Note:
Only symbols currently associated with the special symbols in your library appear in the 
Library Symbol dropdown list.

6. Repeat step 4 for every symbol you want to re-map.

7. Click OK.

SailWind Logic updates the symbols and generates the Update From Library report  on page 206.

The updated symbols appear in the “Mapped to” column of the report.

Management of Special Symbols in the Library
Special Symbols are those used to create off-page reference, power and ground symbols, and 
connectors. The default location of these special symbols is the C:\<install_folder>\<version>\Libraries.

Reinstalling the library will overwrite the common library files. If you modify a special symbol and want 
to keep the change, use Library/Export to transfer the symbol from the C:\<install_folder>\<version>
\Libraries  folder to the C:\<install_folder>\<version>\Libraries\usr  folder or to another library name.
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Chapter 9
Design and Editing Basics

A wide selection of methods are available for design editing and navigation. This enables a high level of 
flexibility for selecting, moving, duplicating, and deleting design objects. A robust selection filter allows 
precise selection of design objects individually and as groups. There are also operations available for 
finding design objects as well as a very powerful step and repeat function.

Design Operations
Modes of Operation
Selecting Objects
Controlling Selections
Filtering Object Selections
Using the Selection Filter
Selection List
Find Objects
Step and Repeat

Design Operations
When you start SailWind Logic or select New  from the File  menu, a drawing format is automatically 
added to the work area. The drawing format is the representation of the sheet on which you will begin to 
create your schematic design.

See Options Dialog Box, Design Category  for information about changing the default drawing format. Use 
Options to set the default working grid, display grid, text size, etc.

To add new design information:

• On the toolbar, click the Schematic Editing toolbar  button

• Add and edit parts from libraries

• Create hierarchical symbols

• Add connections

• Swap pins and reference designators

• Define bus structures

• Create and edit non-electrical information; text, charts, notes, etc.

Related Topics
Part Editor Operations
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Modes of Operation
You can use the different modes of operation to edit designs in SailWind Logic. These include verb mode 
and object mode. There are also multiple choices available for zooming to various areas of your design 
using your pointer device or keyboard commands. To accommodate repetitive operations, you can use 
duplicate mode, delete mode, or move mode

Editing Basics
Zooming
Using Duplicate Mode
Using Delete Mode
Using Move Mode
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Editing Basics

Editing Basics
Most design work involves editing the database—adding, modifying, and deleting items. This section 
describes the modes of operation in SailWind Logic that enable you to edit your designs.

SailWind Logic has two basic modes of operation: Object Select Mode (Select Object First), and Verb 
Mode (Select Command First). In addition to these operational modes, SailWind Logic has Zoom mode. 
Zooming  overrides all other modes until you specify another mode.

Verb Mode (Select Command First)
Object Select Mode (Select Object First)

Verb Mode (Select Command First)
Commands that operate on a selected object are considered verb commands. In Verb mode, select the 
mode, and then select the objects on which to perform the command.

Procedure
1. To put SailWind Logic in Verb mode, select one of the following commands from the standard 

toolbar.

• Using Duplicate Mode

• Using Move Mode

• Using Delete Mode

• Query Mode — (see Schematic Object Modification)

2. Then select an object. When you move the cursor off the toolbar, a small V appears on the cursor 
to show that SailWind Logic is in Verb mode.

3. To exit Verb mode, on the Schematic Editing toolbar, click the Select  button or press the Esc key.

Object Select Mode (Select Object First)
In Object Select mode, select the object, and then select a command to perform an action.

Procedure
1. Position the cursor over the object and click once.

The selected item highlights.

2. Select a command, using one of the following:
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• Right-click and click a command.

• Click a command from a menu.

• Click a button.
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Zooming

Zooming
The Zoom  button acts as a toggle. You can zoom in, out or to a specific area of the design.

Zooming In
Zooming Out
Specify the Zoom Area

Zooming In
You can zoom into the view to see more detail in your design.

Procedure
1. On the standard toolbar, click Zoom  to enter zoom mode.

2. Point to the new view center and click.

Zooming Out
You can zoom out from the current view to see more of the objects in your design.

Procedure
1. On the standard toolbar, click Zoom  to enter zoom mode.

2. Point to the new view center and right-click.

Specify the Zoom Area
To view a specific area of your design, you can drag a rectangle to specify the zoom area.

Procedure
1. On the standard toolbar, click the Zoom  button to enter zoom mode.

2. Press and hold the left button and drag diagonally upward to zoom in.

3. Press and hold the left button and drag diagonally downward to zoom out.

See also Creation of Groups.

Using Duplicate Mode
Use Duplicate Mode to replicate existing parts, text, and drafting objects. When you copy parts, SailWind 
Logic automatically increments the reference designator and gate modifier.
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Procedure
1. On the toolbar, click the Duplicate  mode button.

2. Select the item to copy.

A duplicate of the item follows the cursor movement.

3. (Optional) Depending on the available options for the selected item, you can adjust the orientation 
and other settings from the popup menu before placement. Position the item and indicate its 
location to complete the copy.

4. When you finish placing copies of this item, right-click and click the Cancel  popup menu item.

SailWind Logic remains in duplicate mode until you select another mode or the Select  button from 
the toolbar. You can also press the Esc key to exit the mode.

Related Topics
Schematic Parts

Non-Electrical Objects

Step and Repeat

Using Delete Mode
Use Delete mode to remove parts, connections, unconnected buses, text, drafting objects, and 
hierarchical symbols from the design. If you delete a part with connections, SailWind Logic also deletes 
the connections.

Tip
If you are in Object Select Mode (Select Object First), you can delete a part without deleting the 
connections.

Procedure
1. On the toolbar, click the Delete  mode button.

2. Select the object to delete.

SailWind Logic remains in Delete mode until you select another mode or the Select  button from 
the standard toolbar. You can also press the Esc key to exit the mode.

Using Move Mode
Use Move Mode to adjust the position of existing parts, connections, text, and drafting objects.

Procedure
1. On the toolbar, click the Move  mode button.

2. Select the object to move.
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Using Move Mode

The object follows the cursor movement.

Tip
(Optional) Depending on the available options for the selected object, you can adjust the 
orientation and other settings from the popup menu before placement. Position the object 
and indicate its location to complete the move.

SailWind Logic remains in move mode until you select another mode or the Select  button from the 
toolbar. You can also press the Esc key to exit the mode.
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Selecting Objects
You can select individual or multiple objects in your design. Selecting multiple objects enables you to 
apply a specific action to multiple objects simultaneously.

Note:
You can also search and select objects. For more information, see Searching for an Object by 
Typing Information.

Selecting One Object
Selecting Several Objects
Selecting All Objects in an Area
Selecting All Objects on a Sheet
Selecting an Object on All Sheets in a Schematic

Selecting One Object
To highlight or apply a command only to one object, you can select a single object in your design.

Procedure
Place the cursor over the object and click the left mouse button.

The object selects and highlights.

Any previously selected objects are deselected. If you click over empty space, all previously selected 
objects are deselected.

If you try to select an object in a dense or crowded area, use the Using the Selection Filter  to disable 
other items for selection.

To select invisible signal pin nets, which you cannot select by clicking on them, see the Signal Pin Nets 
topic.

Selecting Several Objects
To highlight or apply a command to multiple objects, you can select several objects in your design.

Procedure
Press and hold the Ctrl key while you select multiple items.

If you did not select an object previously, the software adds it to the set of selected objects.

If you selected the object previously, the software removes it from the set of selected objects.
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Selecting All Objects in an Area
To highlight or apply a command to all objects, you can select all of the objects in a particular area of the 
design.

Procedure
1. Hold the left mouse button down and drag a selection rectangle around one or more objects; start 

at one corner of the area and drag to the opposite diagonal corner.

2. When you release the button, the software selects all objects contained within the rectangle.

You can add additional objects to the selection or remove objects from the selection using Ctrl
+click.

Selecting All Objects on a Sheet
On the sheet you are viewing, you can select all objects of a particular type, depending on the Selection 
Filter you are using.

For example, you could select all nets or all gates on the sheet.

Procedure
To select all objects of a particular type on the sheet you are viewing, click the Edit > Select All on Sheet 
menu item, or press Ctrl+A.

Selecting an Object on All Sheets in a Schematic
Across the entire schematic, you can select all objects of a particular type, depending on the Selection 
Filter you are using. For example, you could select all nets or all gates on every sheet in the schematic.

Procedure
To select all objects of a particular type on every sheet in the schematic, click the Edit > Select All on 
Schematic  menu item, or press Shift + Ctrl + A.

Controlling Selections
Sometimes you cannot easily select the object you want because several objects exist at the same 
location. You can use the Selection Filter to specify specific object types so that only those items can be 
selected.

To control what information you select, use the Using the Selection Filter.

See also Selection List.
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Filtering Object Selections
There are three ways to filter the objects you select: the Selection toolbar buttons, the popup menu when 
nothing is selected, and the Selection Filter Dialog Box.

Filtering With the Selection Toolbar
Filtering With the Popup Menu
Filtering With the Selection Filter Dialog Box

Filtering With the Selection Toolbar
Use the Selection toolbar buttons to enable or disable object selection. This enables you to limit your 
selection to only specific object types.

Procedure
1. On the toolbar, click the Selection Toolbar  button.

2. On the Selection Filter toolbar, click the buttons for the objects for which you want to enable or 
disable selection.

Tip
You cannot use the Parts Filter and the Gates Filter at the same time.

Filtering With the Popup Menu
With nothing selected, you can use the popup menu that appears to set the selection filter to the desired 
object type.

Procedure
1. With nothing selected in the schematic, right-click to open the popup menu.

2. Select the object you want to filter from the list.

Filtering With the Selection Filter Dialog Box
You can use the Selection Filter dialog box to specify a specific filter. This enables very precise selection 
of objects by enabling only those object types that you want to select.

Procedure
1. Click the Edit > Filter  menu item.

2. Select the desired item or items for your filter.
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Using the Selection Filter
Use the Selection Filter dialog box to control which objects you can select. The Selection Filter offers the 
capability to set very precise filters enabling you to select anything, a very narrow subset of the available 
design objects, or nothing at all. You can use the Nothing selection to quickly reset the filter and then you 
can make a new filter selection.

Procedure
1. With nothing selected, right-click and click the Filter  popup menu item.

As an alternative, click the Edit > Filter  menu item.

2. In the Selection Filter dialog box, select the check box beside each design object that you want to 
turn on or off.

Click Anything  if you want to select the check boxes for all design objects or click Nothing  if you 
want to clear all check boxes.

3. Click Close.

Related Topics
Filtering Object Selections

Object Select Mode (Select Object First)
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Selection List
The Selection list provides an efficient means of searching and selecting particular objects in your design.

Searching for an Object by Typing Information
Selecting an Object With Area Selection

Searching for an Object by Typing Information
You can search for one or many objects by entering search criteria in the Selection List box of the 
Selection toolbar.

Restriction:
You must set the selection filter to enable selection of the object type being searched.

Procedure
1. On the Standard toolbar, click the Selection Toolbar  button.

2. In the list box of the Selection Filter toolbar, type information about the object.

For example, type the part name, gate name, part type name, net name, or pin name of the object 
you want, and then press the Enter key.

The workspace pans to the object and selects it.

Tip
When working with the Selection List, note the following:
◦ The Selection List supports Wildcards and Expressions.
◦ You can search for several objects by separating entries with commas.

See also Filtering Object Selections.

Selecting an Object With Area Selection
When you make an area selection, the Selection list on the Selection toolbar displays the selected objects 
and the sheet on which they are located. When multiple objects are selected, All in List appears in the list, 
making it easier for you to locate a particular object by just selecting the item, especially in a congested 
design.

Procedure
1. On the Standard toolbar, click the Selection Toolbar  button.

2. Click the Selection Filter toolbar buttons to include the object you want to locate.

See also Filtering Object Selections.

3. Make an area selection in the general area of the object you want to locate.
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Find Objects

4. Select the particular object from the Selection list on the Selection Filter toolbar.

If desired, select “All in List” to re-select all of the objects in the multiple selection.

5. Click the Next Object  or Previous Object  buttons to move the selection from one object to the 
next in the current multiple selection.

Tip
Other selection methods:
• To make multiple selections in the schematic, use Ctrl or Shift and click.
• To locate a very small object, zoom in on the current sheet, then select the object from 

the list.

Find Objects
You can search for objects in SailWind Logic using a number of different options. These include the 
modeless commands, the Selection Toolbar, the Selection Filter, and by controlling the view.

Table  24. Search for Objects in SailWind Logic Using These Options

Option Description

Modeless Commands 
and Keyboard Shortcuts 
on page 569

Use keystrokes to locate specific objects or types of objects.

Selection Toolbar Controls which types of objects you can select, locates specific objects 
from a multiple selection, or moves between sheets in the schematic.

Using the Selection Filter Controls types of objects you can select. Enables you to select the object 
you want even when several objects exist at the same location.

View Control Changes the perspective and size of the work area.

Step and Repeat
Use Step and Repeat to multiply objects as you place them during an add or duplicate operation. Step 
and Repeat is available in the Schematic Editor and the Decal Editor. In the Schematic Editor, the Step 
and Repeat command copies parts, connections, text, or drafting items. In the Decal Editor, the Step and 
Repeat command copies terminals, text, or drafting items.

Procedure
1. Select an object during an add or duplicate operation. While a dynamic object is attached to the 

cursor, right-click and click the Step and Repeat  popup menu item.

Tip
When adding a new object in the Schematic Editor, you must place the first object 
manually before you can use Step and Repeat.
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2. In the Step and Repeat dialog box, click the direction of placement for the array.

3. In the Count box, type the number of objects to place or click the arrow buttons.

4. In the Distance box, type the distance between objects or click the arrow buttons.

Tip
If you place a second object and then Step and Repeat, the spacing between the objects 
will become the default value in the Distance box and will repeat the pattern you have 
started.

5. Click the Preview  button to view the placement of the multiple objects based on the options you 
set. The placement of the objects is based on the location of the original object selected.

Tip
Zoom Mode is available during Step and Repeat.

6. After achieving the desired placement preview, click OK  to place the objects.

Results
After using Step and Repeat, the original dynamic object is still attached to the cursor. You can continue 
to add or duplicate using this object, or you can press the Esc key to end the operation.

When duplicating connections, only connections with valid start and end points remain after the Step 
and Repeat operation; even if invalid connections appear during the preview. A duplicated connection 
can start on a component pin or on another connection segment. A duplicated connection can end on a 
component pin, a connection segment, or a bus segment.

SailWind Logic automatically assigns new bus netnames to bus segment copies. The new netname 
is based on the original bus segment netname, plus one. For example, if you make a duplicate of bus 
segment D00, the duplicate is assigned the netname D01.

See also Working With Floating Connections.

If you manually place a duplicate within 0.5" of the original (in both X and Y directions), the next 
connection is placed at the same offset. Then press the Space Bar to place a new duplicate. You can 
continue to use this semi-automated Step and Repeat process to place subsequent duplicates.
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Chapter 10
Schematic Parts

Numerous methods are available for adding, swapping, saving, updating and controlling visibility of parts 
in your design. These operations can be performed on individual design objects, or groups of objects.

Adding Parts
Adding Connector Pins
Adding Single Gate Parts
Adding Multigate Parts
Controlling Text Visibility for a Part
Using Alternate Symbols
Swapping Reference Designators
Saving Part Types to a Library
The Update From Library Function
Deleting a Part
Deleting a Part and Its Connections
Cut, Copy, and Paste
Copy as Bitmap
Creation of Groups
Group Anchor Points
Management of Groups
Attributes Overview
Manage Attributes in a Schematic
Resistor Values Defined on Parts

Adding Parts
Use the Add Part from Library dialog box to load a part from a library into the current schematic drawing. 
SailWind Logic automatically assigns a reference designator when you add the part.

Refer to the Adding Single Gate Parts  and Adding Multigate Parts  topics for additional information.

Refer to the Using Duplicate Mode  topic for information on adding parts by making copies of parts that 
already exist in the schematic.

Procedure
1. On the Schematic Editing toolbar, click the Add Part  button.

2. Select a part in the Items list or select a part from the Part Name dropdown list box in the Add Part 
From Library Dialog Box.

Tip
Use the filter to locate the part. Use the wildcard convention, with or without leading 
characters, to expand or narrow the filter. Click Apply  to activate the filter.
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3. Click Add. The part attaches to and follows the cursor movement.

(Optional) You can rotate or mirror the item before you indicate its location. Right-click and click 
Rotate 90, X Mirror, and Y Mirror as often as needed to set the correct orientation of the item. Click 
Alternate  to place an alternate symbol, if available. Click Next Type  to select a different gate in the 
part, if available.

4. Click on the schematic to place the part; another instance attaches to the cursor automatically.

5. When you are done adding the part(s), right-click and click the Cancel  popup menu item or press 
the Esc key.

Related Topics
Using Alternate Symbols

Adding Connector Pins

Adding Connector Pins
Connector pins are special symbols within SailWind Logic libraries. You add them like multigate parts, 
whereby the pin number increments each time you add a connector symbol. SailWind Logic does not 
increment the reference designator until you use all the connector pins.

After adding one or more pins of a connector and establishing a reference designator, use Using 
Duplicate Mode  to add additional pins. This causes SailWind Logic to use the same reference designator 
for new pins.

Adding Single Gate Parts
Single gate parts are parts that are represented by a single schematic symbol. When you add the part 
to the schematic, unique reference designator assignment starts with the next available reference 
designator number.

The Adding Parts  section lists the step-by-step procedure.

You specify the reference designator prefix in the General tab  on page 136 of the Part information dialog 
box when you create a part.

Related Topics
Adding Multigate Parts

Adding Multigate Parts
Multigate parts are parts that consist of more than one symbol or gate to represent a complete part; for 
example, a 7400 which contains 4 gates. You can create parts that have multiple gates of a single type or 
multiple gates of different types.

When you add a new multigate part, the gate with the lowest set of pin numbers is used along with 
the next available reference designator and an alphanumeric suffix, or gate modifier. The reference 
designator and suffix are separated by the dash (-) character. For example, a 7400 added to a new 
schematic would use the gate with pins 1 through 3 and would be assigned as part U1-A. When you add 
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Controlling Text Visibility for a Part
additional gates of the same part, the next available gate and gate modifier is used, for example, the gate 
with pins 4 through 6 is added and assigned as U1-B.

SailWind Logic continually manages the packaging of gates in a schematic. If you delete, rename, or 
change the part type of a gate, SailWind Logic keeps track of these changes and fills in the gaps when a 
new gate is added.

Using Alphanumeric Prefixes
You can use any combination of letters and numbers in SailWind Logic to define a reference designator 
prefix.

You specify this prefix in the General tab  on page 136 of the Part information dialog box when you create 
a part.

If you specify a reference designator prefix that contains alphanumeric characters, SailWind Logic 
maintains this prefix for multigate parts. A prefix of U1A for a part containing four gates, when added to a 
design, would use reference designator assignments U1A-A, U1A-B, U1A-C, and U1A-D.

• “Adding Parts”  on page 189

• Adding Single Gate Parts

• Rename Gate

• Rename Part

• Modifying Parts

Controlling Text Visibility for a Part
Use the Part Text Visibility dialog box to control the display of text associated with the selected part. You 
can control the visibility of one part or all parts of the same type.

Procedure
1. Select a part, right-click and click the Visibility  popup menu item.

2. In the Attributes list, select the check boxes of attributes to display in the schematic.

3. In the “Item Visibility” area, select the check boxes to display the corresponding label, such as part 
type or pin numbers.

4. In the “Attribute Name Display” area, set the attribute name option. Display just the attribute value 
or display the attribute name and its value, for example, PCB DECAL=SO14.

• All Off  — Makes all attribute names invisible, displays only the value.

• No Change  — Keeps the current attribute name visibility settings.

• All On  — Displays all attribute names and their values.

5. In the “Apply Update to” area, set the selected part update options. This area is unavailable if you 
have selected more than one part on the schematic.
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• This Gate  — Updates the selected gate.

• This Part  — Updates a part or all associated gates of a part.

• All Parts This Type  — Updates all matching gates or parts in the design.

6. Click OK.

Tip
When using object mode selection  on page 177, with multiple parts selected, check boxes 
may be in an intermediate state (selected, yet you cannot edit them) because some 
selected parts have the check box selected and others have it cleared. You can select or 
clear the check box and update all selected parts.

Using Alternate Symbols
Some parts can be shown in the schematic with more than one representation. One example of this is the 
NAND gate, with its DeMorgan representation. A second example is the use of IEEE and ANSII symbol 
standards. Within SailWind Logic’s library, it is possible to define one primary and up to three alternate 
symbols for a part.

While placing the part in the schematic, the Alternate command enables you to select the version you 
want to use in the schematic.

Power symbols, ground symbols, and off-page reference symbols are also available as alternate symbols.

When you add a new part or duplicate an existing part, and you want the alternate representation, right-
click and click Alternate  before placing the part.

Procedure
Right-click and click the Alternate  popup menu item while in Duplicate or Move mode.
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Swapping Reference Designators

Swapping Reference Designators
To swap reference designators, you can use the Swap Ref. Des.  button on the Schematic Editing toolbar 
or Swap Ref. Des.  on the popup menu. If the reference designator prefixes of the selected parts are 
different, swapping also updates the reference designators of other parts in the package.

Swapping Reference Designators Using Verb Mode
Swapping Reference Designators by Selecting One Part at a Time
Swapping Reference Designators by Selecting Both Parts First

Swapping Reference Designators Using Verb Mode
You can swap reference designators using verb mode. Using verb mode enables you to initiate the 
command and then perform consecutive swap operations without having to restart the command each 
time.

Procedure
1. On the Schematic Editing toolbar, click the Swap Ref. Des.  button.

2. Select the first part.

3. Select the second part with which to swap reference designators. The software changes or swaps 
the reference designators on the selected parts.

Alternatively, to use the popup menu to swap reference designators, you can either select one part 
at a time or select both parts at once.

Swapping Reference Designators by Selecting One 
Part at a Time
You can swap reference designators by selecting one part at a time.

Procedure
1. Select the first component.

2. Right-click and click the Swap Ref. Des.  popup menu item.

3. Select another component to complete the swap.

Swapping Reference Designators by Selecting Both 
Parts First
You can swap reference designators by selecting both parts first, and then specifying the command.
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Procedure
1. Using Ctrl+click, select the component reference designators you want to swap.

2. Right-click and click the Swap Ref. Des.  popup menu item to complete the swap.
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Saving Part Types to a Library

Saving Part Types to a Library
You can save one part type, multiple part types, or all part types in a schematic to the library.

Saving One or More Part Types in the Schematic
Saving All of the Part Types in the Schematic
Saving Off-Page to Library

Saving One or More Part Types in the Schematic
You can save one or more part types to a library. Once saved to the library, these parts are available for 
use in the current design as well as future design sessions.

Procedure
1. Select one or more parts in the schematic.

2. Right-click and click the Save to Library  popup menu item.

The Save Part Types to Library Dialog Box  appears.

3. Select the library where you want to save the part types.

4. Click OK.

Saving All of the Part Types in the Schematic
You can save all of the part types in the schematic to a library. This enables you to quickly save all of the 
part types and make them available for the current and future design sessions.

Procedure
1. Right-click and click the Select Parts  popup menu item.

2. Right-click again and click the Select All on Schematic  popup menu item.

3. Right-click and click the Save to Library  popup menu item.

The Save Part Types to Library Dialog Box  appears.

4. Select the library where you want to save the part types.
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5. Click OK.

Tip
When saving part types, observe the following:
• If a part type or logic decal you are saving already exists in the library, a message box 

appears. Click Yes  to overwrite the part type or logic decal in the library. Click No  to save 
only those part types that do not already exist in the library. Click Cancel  to return to the 
Save Parts to Library dialog box without saving the part types to the library.

• When parts of the same type have attributes with the same values, the attribute names 
and values are saved in the library with the part type. When parts of the same type have 
different values for the same attribute name, only the attribute name with a blank value is 
saved to the library.

Saving Off-Page to Library
Use Save Off-page to Library to update the off-page, ground, or power symbols in the library with the 
current version(s) in the schematic.

Procedure
1. Click the Tools > Save Off-page to Library  menu item.

2. Select the symbol to update.

3. Click OK. The selected item is opened in the Part Editor.

4. Modify the symbols as required.

5. Click the File > Save  menu item.

6. Follow the prompts to replace the versions currently in the library and update the symbols in the 
schematic.

Related Topics
Special Schematic Symbols
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The Update From Library Function

The Update From Library Function
In SailWind Logic, when you add parts from the library to a schematic, a copy of the library content for 
the parts is written into the schematic. Over time, however, as updates are made to the library, the parts 
in the schematic can become out of sync with newer versions in the library. Use Update From Library to 
synchronize the parts in your design with the latest versions from the library.

Use Update from Library (UFL) to:

• Create a report of any part differences between the current schematic and the library.

• Update the schematic to reflect the current state of the library.

You can compare or update the following categories of items:

• Part types

• CAE decals

• Pin decals

• Ground symbols

• Power symbols

• Off-page symbols

You can compare or update:

• All of any or all of these categories.

• Selected part types, CAE decals, and pin decals. You cannot compare/update selected ground, 
power, or off-page symbols.

CAUTION:
Since the only link between library and schematic content for an item is the item’s name, 
updating can have unforeseen and unintended consequences. When part types or gates are 
replaced globally in a schematic, they are replaced without regard to any local editing of the item; 
edited instances of parts or gates are replaced with the common instance from the library. The 
undesirable consequences of such changes could range from minor, like a repositioned label, to 
catastrophic, like deleted pins or disconnected nets.

To prevent such unintended consequences, the update function always prompts you before updating any 
item in the schematic that has a newer timestamp than its counterpart in the library. To prepare yourself to 
respond to these prompts, before updating you should:
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1. Generate a comparison report (using the Generate comparison report button in the Update From 
Library dialog box).

2. In the comparison report, locate the status messages identifying items whose timestamps are 
newer than in the library.

3. Determine and write down what your response will be to each prompt when it occurs during the 
update.

You may also want to update a copy of the schematic, and check/test the updated copy for unwanted 
changes or behavior.

Undoing an Update
Updating a Schematic From the Library
Updating Selected Part Types From the Library
Updating Selected CAE Decals From the Library
Updating Selected Pin Decals From the Library
The Compare/Update Process
How to Read the Update Report

Undoing an Update
The update process creates an undo checkpoint before it begins the update. If after the update you 
determine that you want to reinstate the design to its previous state you can revert to the previous 
checkpoint.

You can undo any update (whether completed, canceled, or failed) to the last-saved checkpoint using the 
Edit > Undo  menu command.

Updating a Schematic From the Library
Information in your library can be subject to changes and updates. To ensure that the content in your 
design is in agreement with the latest updated library content, you can update a schematic with new 
versions of parts from the library.

You can update all items in any or all of these categories:

• Part types

• CAE decals

• Pin decals

• Ground symbols

• Power symbols

• Off-page symbols
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Updating Selected Part Types From the Library

Procedure
1. Click the Tools > Options  menu item, then click the Design category.

2. In the Options area, select or clear the “Allow overwriting of attribute values in design with blank 
values from library” check box as appropriate; click OK  to close the Options dialog box.

3. Click the File > Library  menu item, then click the Manage Lib. List  button.

4. Set the library list order that Update from Library will use when searching the libraries for items 
matching the items in the design. (See General Compare/Update Rules.) Click OK  then close the 
Library Manager dialog box.

5. Click the Tools > Update from Library  menu item.

6. Modify the settings in the Update From Library Dialog Box  as appropriate.

7. Click OK.

Tip
When the comparison or update operation is completed, the update report opens and a link 
to the report file displays in the Output Window.

Related Topics
The Compare/Update Process

How to Read the Update Report

Update From Library Dialog Box

Updating Selected Part Types From the Library

Updating Selected CAE Decals From the Library

Updating Selected Pin Decals From the Library

Updating Selected Part Types From the Library
As you make changes and updates to your library content, you may also need to selectively update parts 
in your design. You can select one or more parts and then update the part types of all  parts having the 
same part type(s) to synchronize with the latest version in the library.

Restrictions and Limitations
All parts having the same part type as a selected part are updated, but attributes are updated only for the 
parts actually selected.

Procedure
1. Click the Tools > Options  menu item, then click the Design  category.

2. In the Options area, select or clear the “Allow overwriting of attribute values in design with blank 
values from library” check box as appropriate and click OK.
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3. Click the File > Library  menu item, then click the Manage Lib. List  button.

4. Set the library list order that Update from Library will use when searching the libraries for items 
matching the items in the design. (See General Compare/Update Rules.) Click OK  then close the 
Library Manager dialog box.

5. In the Schematic Editor, with nothing selected, right-click and click the Select Parts  (or Select 
Gates) popup menu item.

6. Select the parts whose part types you want to compare/update.

Tip
If you want to update all but a few part types, select all the parts/gates, then in Step 8, 
clear the check boxes of the part types you do not want to update.

7. Right-click and click the Update > Part Type  popup menu item.

8. Modify the settings in the Update Selected Part Type From Library Dialog Box  as appropriate.

9. Click OK.

Results
When the comparison or update operation completes, the update report opens and a link to the report file 
displays in the Output Window.

Related Topics
The Compare/Update Process

How to Read the Update Report

Updating a Schematic From the Library

Updating Selected CAE Decals From the Library

Updating Selected Pin Decals From the Library

Updating Selected CAE Decals From the Library
You can select one or more parts, and then update the CAE decals of all parts that use the same decal(s).

Restrictions and Limitations
This procedure updates the pin decal assignments in the CAE decals, but does not update the pin decals 
themselves. Use one of the procedures in Updating Selected Pin Decals From the Library  to update the 
pin decals.

As a corollary, if, for instance, you update CAE decal X to use PINB instead of PINA, it uses the version 
of PINB geometry currently in the schematic. If the schematic does not have a PINB, it installs from the 
library.
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Procedure
1. Click the File > Library  menu item, then click the Manage Lib. List  button

2. Set the library list order that Update from Library uses when searching the libraries for items 
matching the items in the design. (See General Compare/Update Rules.) Click OK  then close the 
Library Manager.

3. In the Schematic Editor, with nothing selected, right-click and click the Select Parts  (or Select 
Gates) menu item.

4. Select the parts/gates whose CAE decals you want to compare/update.

Tip
If you want to update all but a few CAE decals, select all the parts/gates, then in Step 6 
clear the check boxes of the decals you do not want to update.

5. Right-click and click the Update > CAE Decal  menu item.

6. Modify the settings in the Update Selected CAE Decals From Library Dialog Box  as appropriate.

7. Click OK.

Results
When the comparison or update operation completes, the update report opens and a link to the report file 
displays in the Output Window.

Related Topics
The Compare/Update Process

How to Read the Update Report

Update Selected CAE Decals From Library Dialog Box

Updating a Schematic From the Library

Updating Selected Part Types From the Library

Updating Selected Pin Decals From the Library
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Updating Selected Pin Decals From the Library
You can update selected pin decals from the library using the Update from Library dialog box or directly 
from within the schematic editor.

Updating Selected Pin Decals Using the Update From Library Dialog Box
Updating Selected Pin Decals Using the Schematic Editor

Updating Selected Pin Decals Using the Update From 
Library Dialog Box
As you make changes and updates to the content in your library, you may need to synchronize pin decals 
in your design with the updated library content. You can use the Update From Library dialog box to update 
all instances of one or more selected pin decal(s).

Procedure
1. Click the File > Library  menu item, then click the Manage Lib. List  button

2. Set the library list order that Update from Library will use when searching the libraries for items 
matching the items in the design. (See General Compare/Update Rules.) Click OK  then close the 
Library Manager dialog box.

3. Click the Tools > Update from Library  menu item.

4. Select the Pin Decals check box, and select the decals you want to compare/update.

5. Click OK.

Results
When the comparison or update operation completes, the update report opens and a link to the report file 
displays in the Output Window.

Updating Selected Pin Decals Using the Schematic Editor
As you make changes to the content in your library, you may need to refresh your design content to 
reflect those updates. You can use the Update Selected Pin Decals from Library dialog box to select one 
or more pins, and update all instances of the pin decal(s) used by the selected pin(s).

Procedure
1. Click the File > Library  menu item, then click the Manage Lib. List  button.

2. Set the library list order that Update from Library will use when searching the libraries for items 
matching the items in the design. (See General Compare/Update Rules.) Click OK  then close the 
Library Manager dialog box.

3. In the Schematic Editor, with nothing selected, right-click and click the Select Pins  popup menu 
item.

4. Select the pins you want to compare/update.
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Tip
If you want to update all but a few pin decals, select all the parts/gates, then in Step 6 clear 
the check boxes of the decals you do not want to update.

5. Right-click and click the Update > Pin Decal  menu item.

6. Modify the settings in the Update Selected Pin Decals From Library Dialog Box  as appropriate.

7. Click OK.

Results
When the comparison or update operation completes, the update report opens and a link to the report file 
displays in the Output Window.

Related Topics
The Compare/Update Process

How to Read the Update Report

Update Selected Pin Decals From Library Dialog Box

Updating a Schematic From the Library

Updating Selected Part Types From the Library

Updating Selected CAE Decals From the Library

The Compare/Update Process
The update process begins with a comparison of the schematic content with the library content. When 
schematic content is found to be different from the library content, the schematic content is updated 
according to the options set in the Update From Library dialog box, and the results documented in the 
report file. The compare process is the same, except that the schematic is not updated.

General Compare/Update Rules
There are a number of rules that govern the compare/update process.

In comparing and updating, the following general rules apply for all items:

• Matching items  — For each item in the schematic, all available libraries are searched to 
find a matching named entry, and the first matching entry found is used. If no match is found, 
comparison of the item is skipped, and a “not found” entry is made in the report file.

Tip
Libraries are searched in the order shown in the Library List dialog box. You can use this 
dialog box to change the search order.
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• Timestamps  — Each item in the schematic and library has a timestamp. Schematics of 
PADS versions prior to 2005 SPac2 do not have timestamps. A comparison of the timestamps 
determines what is compared/updated, as follows:

◦ Timestamp in schematic is older  — If the timestamp in the schematic is older than the 
timestamp in the library, the item in the schematic is always compared/updated.

◦ Timestamps are the same  — If the timestamps in the library and schematic are the same, 
comparison/update of the item depends on the setting of the Include items with identical 
time stamp check box in the Update From Library Dialog Box. If this check box is cleared, 
no comparison/update is made; if the check box is selected, all items are compared/updated 
regardless of timestamps.

◦ Timestamp in schematic is newer  — If the timestamp in the schematic is newer than the 
timestamp in the library:

• When you are comparing, a status message is written to the report.

• When you are updating, a status message is written to the update report, and you are 
prompted to choose whether to update the schematic or not.

• What is updated  — When an item is updated, the content from the library replaces the entire 
content of the item in the schematic.

Skipped Updates
There are 3 situations in which the update of an item is skipped.

These situations are:

• When an item in the design is newer than the equivalent item in the library, and you reply No to 
the “<item>  in the schematic has a more recent time stamp than in the library. OK to overwrite the 
version in the schematic?” prompt.

• When a newer item in the library has fewer pins than the equivalent older item in the design.

• When the number of GND, POWER or OFF symbols in the library is fewer than the number of 
available symbols in the design.

Older Schematics

Schematics of PADS versions prior to 2005 SPac2 do not have timestamps. When one of these is 
opened, the timestamps on all part types, decals, pin decals, and off-page, power & ground symbols are 
set to zero. To determine if the content of the part types and decals in the schematic is in sync with the 
library, compare the schematic and library with the Hide identical results check box selected.

What is Compared

Many design objects are examined during the compare process.

The following table lists the content compared and reported for each item selected for comparison or 
update.
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Table  25. Compared and Reported Part Structures

Item Item Component What is Compared & Reported

Timestamps See “General Compare/Update Rules”  on page 203.

Part Type Logic Family, Number of gates, Number of connector pins, Number 
of Signal pins, List of attribute names

For each gate: Number of CAE Decals, CAE Decal names, Number of electrical 
pins on gate, Gate swap class.

For each gate pin: Pin number (alphanumeric if defined), Pin name, Pin type, Pin swap 
class

For each signal pin: Pin Number (alphanumeric if defined), Net name

For each attribute: Value string
Note:  There can be attributes in the library that are just 
placeholders, with blank values that must be set for each individual 
part in the schematic. Any attribute in the library with a blank 
value is considered to be such a placeholder, and updates of 
corresponding attributes in the schematic is controlled by the “Allow 
overwriting of attribute values in design with blank values from 
library” check box in the Options Dialog Box, Design Category.

PCB Decal assignment The part’s assigned PCB Decal name is on the list of PCB Decal 
alternates for the Library part type.
If it is not, a warning is written to the report, but the decal 
assignment is not updated.

PCB Decal pin count

For connectors: Number of pins in the PCB Decal assigned to each connector part 
is equal to the number of connector pins defined for the part type.

For normal parts: Number of pins in the PCB Decal assigned to each normal part is 
equal to or greater than the highest electrical pin number used in 
the gates defined for the Library part type.
Restriction:  Pin counts cannot be updated in the schematic. Pin 
count differences are flagged as warnings in the update report.

CAE Decals

Gate Decal details: Number of attribute labels, attribute label name, number of text, 
number of terminals.
Restrictions:

• CAE Decal graphics are not compared.

• Details of text items are not compared.

Terminal details: Pin decal name assigned to each terminal.
Restriction:  If terminal pin counts differ, the decal cannot be 
updated in the schematic separately from the part types.
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Table  25. Compared and Reported Part Structures  (continued)

Item Item Component What is Compared & Reported

Pin Decals Pin Decal name.
Update notes:

• Because default pin name and pin number label locations are 
“hard-wired” in the CAE decal when it is created, the locations of 
pin names and numbers in the schematic are unaffected when a 
Pin decal is updated.

• Pin decals do provide a default location for net names on the 
schematic, but the actual used net name locations are stored 
separately and therefore net name locations are not affected by 
an update.

Power & Ground
Symbols

Symbol name, type, Signal Pin name

Off-Page Symbols Symbol name, type

How to Read the Update Report
Every time you update a design from the library or generate a comparison report, Update from Library 
writes the results of the operation to a new UpdateReport.txt file in C:\SailWind Projects. You can use a 
text editor to open and review the content of this report and verify that the design objects are the intended 
versions.

The Update Report gives you information about the items you selected for comparison or update, such 
as:

• Whether the timestamp of an item in the design is older, newer, or the same as the item’s 
timestamp in the library.

• Whether the content of an item in the design is the same as or different from the item’s content in 
the library.

The report consists of 4 sections:

• Report header information  — General information about the report itself. Example: 

• Report Options  — A list of options selected for this operation in the Update from Library dialog 
box. Example:  

206 SailWind Logic Guide



 
Schematic Parts

How to Read the Update Report

• Report Summary  — A tabular listing of compared part types, CAE decals, off-page symbols, 
ground symbols, and power symbols, showing the comparison results and update status for the 
package as a whole. Example:  
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• Report Details  — Complete comparison and update details for all compared packages. 
Example:

Table 26  lists and describes the messages returned for compared/updated items in the Update Report.

Table  26. Update Report Messages

Message Report 
Section Refers to: Means

Cannot get CAE DECAL 
from Library!!!

Details CAE decal CAE decal exists in design 
but not in library.
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Table  26. Update Report Messages  (continued)

Message Report 
Section Refers to: Means

Cannot get GATE from 
Library!!!

Details Gate Gate exists in design but 
not in library.

Cannot get GATE from 
Library - Comparison 
Skipped

Details Gate Gate exists in design but 
not in library.

Cannot get PACKAGE 
from Library!!!

Details Package Package exists in design 
but not in library.

Cannot get PIN DECAL 
from Library!!!

Details Pin decal Pin decal exists in design 
but not in library.

CANCELLED Summary Item update Operation was canceled by 
user.

COMPARE CANCELLED Summary & 
Details

Compare operation Operation was canceled by 
user.

COMPARE ERROR Details Compare operation No items selected or 
item(s) unavailable.

COMPARE SKIPPED Details Compare operation Cannot compare because 
CAE decal terminal count 
differs in design and library.

COMPARE STOPPED! Details Compare operation Operation was canceled by 
user.

Compared items match Summary Item content All compared item content 
is the same in the design 
and the library.
The following items are not 
compared:

• CAE Decal graphics

• Details of CAE Decal 
text items

CONTENT UPDATED Details Item update status Content in the design 
updated with content from 
library.

Decal Count Mismatch Details CAE decal CAE decal terminal count 
in design differs from count 
in library.

Different Summary & 
Details

Item content Item content in design 
differs from content in 
library.
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Table  26. Update Report Messages  (continued)

Message Report 
Section Refers to: Means

Different timestamp Summary Pin Decal timestamp Timestamps in design and 
library differ.

FAILED Summary Item update status Update has failed due to an 
unspecified error.

In library: Not in design Details Item status Item in library not found in 
design.

Newer than library Summary & 
Details

Timestamp in design Timestamp in design newer 
than in library.

No CAE Decal found!!! Details CAE decal CAE Decals check box 
selected in dialog box but 
no CAE decal found in 
design.

No PIN Decal found or 
selected!!!

Details Pin decal Either:
• Pin decal selected in 

dialog box not found in 
design, or

• Pin decals check box 
selected but no pins 
selected.

Not assigned Details Gate pin Gate pin assigned in 
design is not assigned in 
library.

Not assigned in library part Details Compared item The PCB Decal assigned 
to the part in the design 
is not in the set of decals 
assigned to the part in the 
library.

Not in design Summary Off-page, PWR and GND 
symbols

The symbol exists in the 
library, but is not used in 
the design.

Not in library Details Compared item Item in design not found in 
library.

Older than library Summary & 
Details

Timestamp in design Timestamp in design older 
than in library.

Operation canceled by 
USER!!!

Details Update or Compare 
operation

Operation was canceled by 
user.

PERFORMED UNDO 
OPERATION

Details Update or Compare 
operation

Operation canceled by 
user.
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Table  26. Update Report Messages  (continued)

Message Report 
Section Refers to: Means

Same as library Summary &
Details

Timestamp in design
Item content in design

Timestamps in design and 
library are equal.
Item content is the same in 
design and library.

SKIPPED Summary Item update User has replied “No” 
to the “<item> in the 
schematic has a more 
recent time stamp than in 
the library.
OK to overwrite the version 
in the schematic?” prompt.

STOPPED Summary Item update Operation canceled by 
user.

UPDATE CANCELLED Details Item update Operation was canceled by 
user.

UPDATE FAILED Details Item update An error occurred in the 
update process and the 
update failed.

UPDATE MESSAGE Details Item update Explains cause of an 
Update failure.

UPDATE SKIPPED Details Item update User has replied “No” 
to the “<item> in the 
schematic has a more 
recent time stamp than in 
the library.
OK to overwrite the version 
in the schematic?” prompt.

UPDATE STOPPED! Details Item update Operation canceled by 
user.

WARNING Details PCB Decal PCB Decal in the library 
has fewer pins than in the 
design.

Related Topics

Related Topics
The Update From Library Function

The Compare/Update Process
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Deleting a Part
When deleting a part that is selected in object mode, you can choose to delete the part only, or the part 
and its connections.

Procedure
1. Select a part.

2. If you want to keep connections attached to the part, right-click and click the Preserve 
Connections  popup menu item to enable it. The Preserve Connections  option is enabled by 
default.

Tip
Preserve Connections  is enabled when a check mark appears next to it in the menu.

3. Right-click and click the Delete  popup menu item.

The software leaves the connections at their original locations.

Deleting a Part and Its Connections
If a design no longer requires a part, and you are not going to replace the part with a similar one (and 
therefore you do not need to preserve its connections), you can delete the part and its connections.

Procedure
1. Select a part.

2. If you want to remove connections attached to the part, right-click and click the Preserve 
Connections  popup menu item to disable it. The Preserve Connections  option is enabled by 
default.

Tip
Preserve Connections  is disabled when a check mark does not appear next to it in the 
menu.

3. Right-click and click the Delete  popup menu item.

The software deletes the part and its connections.

Related Topics
Object Select Mode (Select Object First)

Adding Off-Page References

Working With Floating Connections
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Cut, Copy, and Paste
In a manner similar to other standard applications, you can cut, copy and paste objects in your design.

• Use the Edit  menu items or the Ctrl+X, Ctrl+C, or Ctrl+P shortcuts.

• Connections that extend outside a selection are assigned off-page symbols at the break point.

• SailWind Logic only maintains one cut or copy in the paste buffer.

• You can paste into a new design.

Copy as Bitmap
The Copy as Bitmap command lets you define a rectangular area to copy graphics information to the 
paste buffer as a bitmap image. Once copied, you can, for example switch to Microsoft Word and use the 
Home > Paste  menu item to insert the bitmap into a document.

Procedure
1. Click the Edit > Copy as Bitmap  menu item.

2. Drag the cursor over the area to copy.

All items in the rectangle including the background, dot grid, color, etc., are copied.

3. Open the application in which to place the bitmap and use the Paste  command to place the image.
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Creation of Groups
A group is a collection of objects on the schematic. By default, connections that extend outside the group 
are clipped so they stop at the boundary used to define the group. Once you select a group, you can 
move it, copy it to the paste buffer, delete it, duplicate it, or save it to a file for use in another design.

Tip
A group differs from a combination, which consists only of 2D lines or 2D lines and text.

See also Combining 2D Lines and Text.

Creating a Group
Setting the Origin of Groups

Creating a Group
To perform an operation on multiple objects simultaneously, create a group and then move it, copy it to 
the paste buffer, delete it, duplicate it, or save it to a file for use in another design.

Restrictions and Limitations

• Certain group commands are available only if the group consists of mixed items. For example, 
the “Preserve by Boundary” popup menu item is unavailable if the group consists of components 
only.

Procedure
1. Set the selection filter to the objects you want to select.

See also Using the Selection Filter.

2. Area select the objects in the group.

As an alternative, you can use Ctrl+click to select all objects to include in the group.

The software highlights the included objects.

3. To preserve connections that extend outside the group boundary, right-click and click the Preserve 
by Boundary  popup menu item.

4. To preserve single pin nets that remain after you delete a part or bus, right-click and click the 
Preserve Connections  popup menu item.

5. As needed, Ctrl+click objects in the group to remove them, or Ctrl+click objects outside the group 
to add them to the group.

The software highlights the included objects.
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Setting the Origin of Groups
When you create a group, the software creates an origin automatically. The software uses this origin 
when moving or placing groups. You may want to change the origin when it is optimal to have the origin at 
a specific location.

Restrictions and Limitations
You must enable the Preserve by Boundary option and the boundary must be visible to set the origin. 
When the boundary is not visible, the group rotates around the center of the selection.

Procedure
1. Select the group.

2. Right-click and click the Set Origin  popup menu item.

A bullseye attaches to the pointer.

3. Move the cursor to the new origin and click to set it.

Related Topics
Management of Groups

Group Anchor Points
When duplicating or moving a group, SailWind Logic places the anchor point of the group at a pre-defined 
location.

Keep the following anchor point criteria in mind:
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• If you have enabled the “Preserve by boundary” feature, SailWind Logic anchors to a point on the 
design grid closest to the group’s origin.

Figure 3. Anchor Point with “Preserve by Boundary”
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• If you have not enabled the “Preserve by boundary” feature, SailWind Logic anchors to either 
a group object that lies on the design grid or—if no part of the group is on the design grid—it 
anchors to a group object that is closest to the origin.

Figure 4. Anchor Point with no “Preserve by Boundary”
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Management of Groups
Using a group, you can perform an operation on its contents as a single entity. Once you create a group, 
you can save it, delete it, move it, or reuse it.

Duplicating an Existing Group
Moving Groups
Deleting Groups
Saving Groups
Pasting Groups From a File
Automatic Connection When Pasting
Rotate or Mirror a Group

Duplicating an Existing Group
You can duplicate all of the items in a group that already exist on a schematic. When you duplicate a 
group of objects, reference designator names are assigned automatically.

Procedure
1. Select a group, right-click and click the Duplicate  popup menu item.

Note:
The anchor point of the duplicate group depends on certain conditions. For more 
information, see Group Anchor Points.

2. Move the cursor to the location for the duplicate, and click to place it.

3. Repeat the above step to create additional copies.

Tip
You can set SailWind Logic to display only the group’s outline during copy operations.

See also Creation of Groups.

Moving Groups
Using the Move command, you can move a group to any location on the sheet.
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Procedure
1. Select a group, right-click and click the Move  popup menu item.

Note:
As you move the group, its anchor point depends on certain conditions. For more 
information, see Group Anchor Points.

2. Move the cursor to the new group location and click to place it.

Tip
You can set SailWind Logic to display only the group’s outline during move operations.

See also Creation of Groups.

Deleting Groups
When deleting a group, you can choose to delete or retain the connections that are outside the group 
boundary.

Procedure
1. Select a group, right-click and click the Delete  popup menu item.

2. To preserve connections that extend outside the group boundary, right-click and click the Preserve 
by Boundary  popup menu item.

Tip
When preserving connections, note the following:
• Preserve by Boundary  must be checked to use this capability, otherwise, the feature is 

disabled.
• When you preserve connections outside the group boundary, the connections are 

automatically assigned off-page symbols upon deletion. Unnamed connections are 
uniquely named with a “$$$” prefix.

3. To preserve single pin nets that remain after you delete a part or bus, right-click and click the 
Preserve Connections  popup menu option.

See also Detach, Working With Floating Connections.

Saving Groups
You can save the contents of a group for use on other schematic sheets or a different design. Saved 
groups are stored in the \SailWind Projects  folder with a .grp  extension.
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Restrictions and Limitations

• The group must consist of mixed items. The “Save to File” command is not available if you select 
only components or other objects.

Procedure
1. Select a group, right-click and click the Save to File  popup menu item.

2. In the File Name area, type a name.

3. Click Save.

Pasting Groups From a File
You can save a group to a file so that you can use it again in the current or future designs. Use Paste 
from File to insert a group that was previously saved to a file.

When you paste a group into a sheet:

• Named nets retain their name, and unnamed nets are assigned default signal names.

• All parts are named with the next available reference designator names.

Tip
To control renaming of reference designators, use the “Preserve Reference Designators on Paste 
option” check box in the Options dialog box, Design category.

Procedure
1. Click the Edit > Paste from File  menu item.

2. In the Load Group File dialog box, select the group to paste.

3. Click Open. The group attaches to the cursor.

4. Move the pointer to the location for the group, and click to place it.

Tip
If the design contains parts with the same reference designation as those in the group, a 
report generates.

See also Preserving Reference Designators.

Automatic Connection When Pasting
When pasting a group from a file into your design, unconnected pins, unterminated wires, or bus 
segments in a group can connect automatically.

SailWind Logic Guide 221



Schematic Parts
Rotate or Mirror a Group  

• Unconnected pins connect automatically with unterminated wire ends or unconnected pins.

• Unterminated wire ends connect automatically to bus segments only if the unterminated wire is a 
named subnet of the bus.

Rotate or Mirror a Group
You can rotate or mirror a group while the group is selected. You can also rotate or mirror a group during 
a move.

Procedure
1. Select a group and right-click.

2. Click the Rotate 90, X Mirror, or Y Mirror  popup menu item.

Restriction:
The group must consist of mixed items. The commands are not available if only 
components are selected.

Related Topics
Creation of Groups

Attributes Overview
Attributes enable you to associate information with a schematic symbol. Attributes are made of two parts: 
an attribute name, and its corresponding value. For example, you can create an attribute named Part 
Description and assign its value as Hex Inverter.

You can create an attribute that is assigned to every part in the library, every part in the open design, a 
part type, or to only one part in the design.

• To add an attribute to all parts in a library, create the attribute in the Manage Library Attributes 
dialog box.

See also Managing Library Attributes.

• To add an attribute to every part in the open design, create the attribute in the Managing 
Schematic Attributes dialog box.

See also Manage Attributes in a Schematic.

• To add an attribute to a specific part, create the attribute using the Attributes  tab while editing the 
part.

See also Managing Attributes.

• To add an attribute to a part on the schematic without updating the part type, use the Part 
Attributes dialog box.
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See also Modifying Part Attributes  and Resistor Values Defined on Parts.

• To display attributes in the schematic after creating them, use the visibility controls.

See also Controlling Text Visibility for a Part.

• To create placeholders in CAE Decals so that attributes are placed in a predefined locations, use 
attribute labels.

See also Attribute Labels.
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Manage Attributes in a Schematic
Use the Manage Schematic Attributes dialog box to manage attributes at the schematic level. You can 
create a new attribute and automatically assign it to every part in your design. You can also rename an 
attribute in, or delete an attribute from, the schematic. All parts are automatically updated.

See also Attributes Overview.

Creating Attributes
Renaming Attributes
Deleting Attributes

Creating Attributes
You can create a new attribute and automatically assign it to every part in a design.

Procedure
1. Click the Edit > Attribute Manager  menu item.

2. In the Manage Schematic Attributes dialog box, click Add Attr.

3. In the Add New Attribute dialog box do one of the following:

• Type a name for the attribute in the Attribute Name text box.

• Click Browse Lib Attr  to select an attribute already defined in the library. Select an attribute 
name from this dialog box and then click OK.

4. Type a value for the attribute in the Attribute Value text box.

5. Click OK  to close the Add New Attribute dialog box.

6. Click Close  to close the Manage Schematic Attributes dialog box.

Renaming Attributes
You can rename an existing attribute and apply the change to each part in the design.

Procedure
1. Click the Edit > Attribute Manager  menu item.

2. In the Manage Schematic Attributes dialog box, select one or more attributes in the Attributes in 
Schematic list.

3. Click Add. The attributes are added to the Attributes Selected for Rename list.

4. Select the attribute in the New Name column and click Edit New Name.

5. In the Attribute Name text box, do one of the following:
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• Type a name for the attribute

• Click Browse Lib Attr  to select an attribute already defined in the library. Select an attribute 
name from this dialog box, and then click OK.

6. Click Rename Attrs  to rename the attribute and remove it from the Attributes Selected for Rename 
list box.

7. Click Close.

Tip
Click Remove  or Remove All  to place the selected attributes back into the Attributes in 
Schematic list and keep the current name.

Deleting Attributes
You can delete an attribute from all parts in the design:

Procedure
1. Click the Edit > Attribute Manager  menu item.

2. Select one or more attributes in the Attributes in Schematic list.

3. Click Delete Attrs  then click Yes  at the prompt.

4. Click Close.

Resistor Values Defined on Parts
Discrete parts such as resistors and capacitors are created with Value and Tolerance attributes. The value 
for these attributes is not defined in the part symbol, but is set when the part is added to the drawing.

Use the Part Attributes Dialog Box  on page 283 to modify these values.
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Chapter 11
Sheets

You can use sheets to logically partition your design. You can also add custom borders and fields to your 
sheets.

Editing Sheets
Creating a Custom Sheet Border
Adding a Field
Changing a Text String Into a Field
Managing Fields

Editing Sheets
Use the Sheets dialog box to edit the sheet set of the current schematic in the work area. Using Sheets 
enables you to add and delete sheets from the set and to modify sheet names and the numeric order of 
the set. You can create up to 1024 sheets.

Procedure
1. Click the Setup > Sheets  menu item.

2. Click a sheet in the Numbered Sheets list box, and then click View  to view it in the work area.

3. Click Add  to add a new sheet to the list.

The new sheet displays in the work area.

4. Click the new sheet in the Numbered Sheets list box, and then click Rename  to rename it.

Tip
Spaces are not valid characters in a sheet name.

5. If desired, perform any of the following additional operations from the Sheets dialog box:

• Click Delete  to remove a sheet from the list.

• Click Up  to change the numbering and position of the sheet. The sheet value changes as n-1.

• Click Down  to change the numbering and position of the sheet. The sheet value changes as n
+1.

Creating a Custom Sheet Border
You can create a custom sheet border with a title block using specialized text strings called fields. When 
you add fields to the title block of a sheet border, these fields are automatically propagated to each new 
sheet.
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Procedure
1. Draft the 2D line border. (See Creating 2D Line Items.)

2. Add fields to the 2D line object. (See Adding a Field.)

3. Save the object to the lines library. (See Adding Drafting Items to a Library.)

Adding a Field
Fields are used as placeholders for data that might change in a document. You can add fields to 
a schematic or any 2D line object. If you selected a 2D line object, the added field is automatically 
combined with it upon placement.

There are two types of fields: system and user. You cannot modify system fields; the value is derived from 
the system. User fields are custom fields you create. There are no limitations to the name or value strings 
of user fields. User fields are available only in the schematic in which they are created.

Procedure
1. Select nothing or a 2D line object, right-click and click the Add Field  popup menu item.

2. In the Name list, select a system field or type a custom field name.

3. In the Value box, type the value you want displayed.

Note that the Value box is unavailable for system fields since the value is derived from your 
system.

4. To place the field at a precise X,Y coordinate location, type the value in the X and Y boxes.

Tip
If this is blank when you click OK, the field attaches to the pointer until you click to indicate 
the location.

5. In the Rotation list, select the degree of rotation you want.

Tip
Rotation can be 0 or 90 degrees.

6. In the Size box, type the font size you want.

Stroke font sizes must be between 10 and 1000 mils; system font sizes must be between 1 and 72 
points.

7. For stroke font, in the Line Width box, type the line width.

8. For system fonts, select the font you want to use in the Font list.

You can also click a system font style you want applied: B  for Bold, I  for Italic, or U  for Underlined.

9. To set the Justification, click the Horizontal and Vertical options you want.

10. Click OK.
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Changing a Text String Into a Field

Related Topics
Combining 2D Lines and Text

Changing a Text String Into a Field
You can use the Make Field command to change an existing text string into a field.

Procedure
1. Select a text string, right-click and click Make Field.

2. In the Name list, type a field name or select a system field.

3. To place the field at a precise X,Y coordinate location, type the value in the X and Y boxes.

Tip
If this is blank when you click OK, the field attaches to the pointer until you click to indicate 
the location.

4. In the Rotation list, select the degree of rotation you want.

Tip
Rotation can be 0 or 90 degrees.

5. In the Size box, type the font size you want.

Stroke font sizes must be between 10 and 1000 mils; system font sizes must be between 1 and 72 
points.

6. For stroke font, in the Line Width box, type the line width.

7. For system fonts, select the font you want to use in the Font list.

You can also click a system font style you want applied: B  for Bold, I  for Italic, or U  for Underlined.

8. To set the Justification, click the Horizontal and Vertical options you want.

9. Click OK.
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Managing Fields
Use the Fields dialog box to manage multiple fields. You can manage the fields in the entire schematic or 
in a 2D line object.

Managing All Fields in the Schematic
Managing the Fields in a 2D Line Item

Managing All Fields in the Schematic
If you selected nothing, the software lists all of the fields used in your schematic. The System fields 
display in the System area, and the fields you defined display in the User area. You can manage only the 
User fields.

Procedure
1. Select nothing or a 2D line object, right-click and click the Fields  object.

2. In the User area, click Add.

3. Type a name in the Name column.

4. Type a value in the Value column.

5. To delete a field from the schematic, select the field name and click Delete.

Restriction:
You cannot delete a system field from the schematic.

6. To edit the name or value of a field, select the Name or Value you want to edit and click Edit.

Managing the Fields in a 2D Line Item
If you selected a 2D line object, the software lists all of the fields associated with the object. The System 
fields display in the System area, and the fields you defined display in the User area. You can delete 
System fields from the 2D line, but they are still available in the schematic.

Procedure
1. Select a 2D line item then right-click and click the Fields  popup menu item. This opens the Fields 

dialog box.

2. To delete a system field from the 2D line item, in the System area, select the field name and click 
Delete.

The system field is still available in the schematic.

3. To delete a user field from the 2D line item, in the User area, select the field name and click 
Delete.

The field is still available in the schematic.
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4. To edit the value of a user field, select the Value you want to edit and click Edit.

Restriction:
When editing a user field, note the following:
• You cannot edit the name of the user field.
• You cannot add a field for later use in a 2D line.
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Chapter 12
Non-Electrical Objects

A full complement of editing commands are available for working with non-electrical objects. Use 
the drafting commands to create lines, arcs, text, and all other items not generally associated with 
connectivity.

Creating 2D Line Items
Adding Text
Moving Text
Adding Circles
Adding Polygons or Paths
Adding Rectangles
Modifying 2D Line Items
Pulling Arcs
Combining 2D Lines and Text
Uncombining 2D Lines and Text
Exploding Combinations
Adding Drafting Items to a Library
Adding Drafting Items From a Library
Modifying Objects in a 2D Lines Library

Creating 2D Line Items
To add drafting objects such as polygons, circles, rectangles, paths, as well as, arcs to polygons or paths, 
click the Create 2D Line  button on the Schematic Editing toolbar. This changes the default popup menu 
to a specific popup menu for creating 2D line items.

Procedure
1. On the Schematic Editing toolbar, click the Create 2D Line  button.

2. Right-click and set one or more of the following values before you add the drafting object:
Table  27. Creating 2D Line Items - Options

Option Description

(Shape) Select to add a Polygon, Circle, Rectangle, or Path.

Width Specify a width value to override the default.

Orthogonal Adds segments in 90-degree increments.

Diagonal Adds segments in 45-degree increments.

Any Angle Adds segments at any angle.
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Adding Text
Free text is text not belonging to another object. All alpha, numeric, and special characters on the 
keyboard are valid. The maximum text string length is 72 characters including spaces.

To add multiple lines of text to a design, see Embedding a Text Document.

Procedure
1. On the Schematic Editing Toolbar, click the Create Text  button.

2. Type the text string you want.

To add a text entry with a bar over the characters, precede the text with the \ character. To place a 
bar over only a portion of text, enclose that section with the \ character.

For example, typing \READ\WRITE places a bar over READ.

3. To place the field at a precise X,Y coordinate location, type the value in the X and Y boxes.

Tip
If this is blank when you click OK, the field attaches to the pointer until you click to indicate 
the location.

4. In the Rotation box, select the degree of rotation from the Rotation list.

Rotation can be 0 or 90 degrees.

5. For stroke font, in the Line Width box, type the line width.

6. In the Size box, type the size (in mils for stroke font, in points for system fonts).

Tip
Type a stroke font size between 10 and 1000 mils or a system font size between 1 and 72 
points.

7. For system fonts, select the font you want to use.

You can also click a font style: B  for bold, I  for Italic, or U  for Underlined.

8. In the Justification area, set the horizontal and vertical justification of the text.

9. If you combined the selected text string with a drafting object, right-click the text string, click 
Properties, and then select Parent  to display the Drafting Properties dialog box to modify the 
drafting object.

10. Click OK.

Related Topics
Combining 2D Lines and Text
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Moving Text

Moving Text
When you add a part to the schematic, all of the text associated with the symbol (reference designator, 
part name, pin number, attributes, etc.) appears in a predefined location. You can move the text to make 
room for other parts or connections or to make the schematic more readable.

Restrictions and Limitations

• You can move a pin number a maximum of one inch from its pin terminal.

• If you select and move a visible net name, with snap to grid enabled, the new net name snaps to 
the Labels and Text grid.

To set the labels and text grid, use the General page in the Options dialog box. See “Options 
Dialog Box, General Category”  on page 595.

Procedure
1. On the Schematic Editing toolbar, click the Move  mode button.

2. Select the text string. It attaches to the cursor.

3. Move the cursor and indicate a new position for the text.

While moving text, you can modify the string using commands in the popup menu. The commands 
listed in the popup menu are based on the type of text being moved.

Adding Circles
You can use the 2D line drafting command to add circle drafting objects to your design.

Procedure
1. On the Schematic Editing toolbar, click Create 2D Line  then right-click and click the Circle  popup 

menu item.

2. Indicate the center point of the circle.

A circle outline follows the cursor movement.

3. Indicate the radius length to end the circle addition.

Adding Polygons or Paths
You can use the 2D drafting command to add polygons or paths (with or without arcs) to your design.

Procedure
1. On the Schematic Editing toolbar, click the Create 2D Line  button then right-click and click the 

Polygon  or Path  popup menu item.

2. Indicate the start point. A line follows the cursor movement.
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3. Move the cursor to the next corner and click again.

4. Continue adding corners in the same manner.

a. If you want to add an arc rather than a straight segment, right-click and click Add Arc.

b. To remove the last corner, press the backspace key or right-click and click the Del Corner 
popup menu item.

5. Double-click to end the addition.

Polygons automatically close; paths terminate at the last-defined corner.

Adding Rectangles
You can use the 2D drafting command to add rectangle drafting objects to your design.

Procedure
1. On the Schematic Editing toolbar, click the Create 2D Line  button, right-click and click the 

Rectangle  popup menu item.

2. Indicate one corner of the rectangle.

A box outline follows the cursor movement.

3. Indicate the diagonally opposite corner at which to end the rectangle.

Modifying 2D Line Items
You can use the Modify 2D Line  button to change drafting objects. This changes the default popup menu 
to a specific popup menu for modifying 2D line items.

Procedure
1. On the Schematic Editing toolbar, click the Modify 2D Line  button.

2. Select the line segment or corner to modify.

The object is placed in Move mode.

Use the popup menu to enable other 2D line modifications. If you select a segment, the following 
modification functions are available:

Table  28. Modify 2D Line Item Options

Option Description

Pull Arc Converts a segment or corner into an arc.

Split Divides a segment into two segments.

Del Segment Deletes the line segment at the pick point.

Width Changes the line width of the item.
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Pulling Arcs

Option Description

Filled Fills a closed polygon.

Solid Style and Dotted Style Changes the line style to a solid or a dashed line. You 
cannot specify dotted lines for circles or arcs.

Orthogonal Moves are made in 90-degree increments.

Diagonal Moves are made in 45-degree increments.

Any Angle Moves are made at any angle.

If you choose a corner, the popup menu uses most of the options as selected segments, plus the 
following:

Table  29. Modify 2D Line Item - Corner Option

Option Description

Del Corner Deletes the corner. A line segment is created between the 
corner’s original endpoints.

3. Reposition the cursor and indicate a new location for the item.

Pulling Arcs
Pull Arc moves the selected line segment to create an arc, as the cursor is moved. Horizontal lines 
move in the vertical direction. Vertical lines move in the horizontal direction. Diagonal lines move in all 
directions, unless anchored by a line at the end of the diagonal. If an existing arc is selected, its endpoints 
remain fixed and the arc chord follows the cursor.

Use the Pull Arc command to convert a drafting segment or corner into an arc. The starting points of the 
drafting segment become the start and stop angle for the new arc.

Procedure
1. On the Schematic Editing toolbar, click the Modify 2D Line  button.

2. Select the line for arc conversion.

3. Right-click and click the Pull Arc  popup menu item. An arc follows the cursor movement.

4. Click to indicate the end of the arc conversion.

Combining 2D Lines and Text
In SailWind Logic, combining is the process of merging two or more 2D line or text items into a single 
complex 2D line item. After you have combined them, you can manipulate the group (move, rotate, 
duplicate, and so forth) as a single item. This is useful for creating title blocks or other similar features.
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Restrictions and Limitations

• A combination can only include 2D lines or text. This differs from a group  on page 215, which is a 
collection of objects (which may or may not include 2D lines or text) on the schematic.

Procedure
Use one of the following:

• Using Object Mode

a. Select a 2D line or block of text.

b. Using Ctrl-click, continue to select items to combine.

c. Right-click and click the Combine  popup menu item.

The selected items are combined.

Tip
When you select a 2D line item from the combination for move, duplicate, etc., all items are 
selected for the operation. Selecting text first will not select the whole group.

• Using Verb Mode

a. On the Schematic Editing toolbar, click the Combine/Uncombine  button.

b. Right-click and click the Combine  popup menu item, then select a line item.

Tip
When combining 2D lines and text, always select the 2D line first, then select the text. If 
you try to select a text item before first selecting a 2D line, the message “No drawing item 
to add text to” displays.

c. Continue to select the items to combine. Selected line items change to the highlight color.

d. Right-click and click the Complete  popup menu item.

The selected items are combined.

e. Click the Select  button or press the Esc key to exit the Combine/Uncombine function.

Tip
Selecting a 2D line item in the combination for move, duplicate, and so on, selects all items 
for the operation. Selecting text first does not select the whole group.
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Uncombining 2D Lines and Text

Related Topics
Adding Text

Uncombining 2D Lines and Text

Exploding Combinations

Uncombining 2D Lines and Text
You can use the Uncombine command to remove individual objects from a combination.

Procedure
1. On the Schematic Editing toolbar, click the Combine/Uncombine  button, right-click and click the 

Uncombine  popup menu item.

2. Select the line or text item to remove.

3. Continue selecting items to remove as necessary.

4. Right-click and click the Complete  popup menu item or press the Esc key when you finish 
removing objects from the group.

The objects return to their original states and locations.

Related Topics
Exploding Combinations

Exploding Combinations
You can use the Explode command to separate all objects from a combination.

Procedure
Use one of the following:

• Using object mode:

a. Select a 2D line item from the group.

b. Right-click and click Explode.

The combination is no longer combined, and objects are separated.

Tip
In object mode, you can only explode a combination if it contains text items. Use the verb 
mode method (below) to explode a combination that does not have text items.

• Using verb mode:

SailWind Logic Guide 239



Non-Electrical Objects
Adding Drafting Items to a Library  

a. On the Schematic Editing toolbar, click the Combine/Uncombine  button.

b. Right-click and click the Explode  popup menu item and select the item to explode.

c. Right-click and click the Complete  popup menu item.

Adding Drafting Items to a Library
You can save a 2D line item or a complex 2D line item in the schematic to a lines library. This makes it 
available in the current or future design sessions.

Procedure
1. Select an item, right-click and click the Save to Library  popup menu item.

2. Type the item name and specify the library location in the Save to Library dialog box.

3. Click OK.

Adding Drafting Items From a Library
Use the Get Drafting Item from Library dialog box to load a 2D line item from the available libraries to the 
current schematic.

Procedure
1. On the Schematic Editing toolbar, click the Add 2D Line from Library  button.

2. In the Get Drafting Item from Library dialog box, select an item from the Drafting Items list.

If the list does not contain the item you need, use the filter to search the available libraries. Use 
the wildcard convention, with or without leading characters, to expand or narrow the filter. Click 
Apply  to activate the filter. SailWind Logic searches only active libraries with the Lines parameter 
checked for the 2D element.

3. Click OK. The item follows the cursor movement.

4. (Optional) You can rotate or mirror the item before you indicate its location. Right-click and click 
Rotate, Mirror X, or Mirror Y  as often as needed to set the correct orientation of the item.

5. Click to place the item.

Modifying Objects in a 2D Lines Library
To edit an object that is stored in a 2D Lines library, you must first bring that object into the design 
workspace, make the desired edits and then save it back into the library.
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Modifying Objects in a 2D Lines Library

Procedure
1. In the SailWind Logic workspace, on the Schematic Editing Toolbar, click the Add 2D Line from 

Library  button.

2. In the Get Drafting Item from Library dialog box, select the desired object from the Drafting Items 
list and click OK.

The item will attach to the cursor.

3. In the design workspace click a location to place the item.

4. Make the desired edits using the commands available on the Schematic Editing Toolbar and the 
right mouse button menus.

5. After you have completed the desired edits, select the objects that make up the drawing item, right 
click and choose Save to Library.

6. You can choose to either overwrite the item or save it as a new item.

Clicking OK  saves the 2D line object back into the 2D Lines library.

Tip
To save multiple objects that include lines and text, you must first select all the items, 
choose Combine  from the right mouse menu, and then choose Save to Library  from the 
right mouse button menu.
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Chapter 13
Connections

Connections are the heart of your design and enable you to capture and convey the interconnectivity of 
your design. SailWind Logic offers a robust selection of commands for working with adding, naming and 
connecting nets. You can fully connect you design objects, or use floating connections as placeholders for 
future design decisions. You can add, move split nets or segments. You can also swap pins on your parts 
as needed. There are also a powerful set of commands available for creating, editing, and managing 
buses.

Adding Connections
Naming a Connection
Net Attributes Overview
Creating Net Attributes
Default Attributes for Nets
Adding Power and Ground Connections
Working With Floating Connections
Editing Off-Page Symbol Sheet Numbers Per Line
Changing a Connection
Moving Connections
Splitting a Connection
Splitting Segments
Swapping Pins
Managing Buses
Deleting Connections
Detach

Adding Connections
When you add connections, they must have start and end points that are electrically meaningful. Start 
a connection on either a symbol pin or another connection. End a connection on a symbol pin, another 
connection, a bus, an off-page reference, or a ground or power symbol. SailWind Logic prevents you from 
starting or ending a connection just anywhere in the database unless you enable Floating Connections.

See also Working With Floating Connections.

Procedure
1. Click the Add Connection  button.

2. Indicate the starting point of the connection. The connection follows the cursor movement. Right-
click and click Angle  to specify diagonal segments in the connection.

3. Indicate corners as needed. Right-click and click Del Corner  to back up to the previous corner if 
necessary.

4. A connection cannot end in open space. Locate the cursor and double-click to end the connection.
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5. To end a connection with a power, ground, or off-page reference symbol, select the appropriate 
symbol from the popup menu during the last step of this procedure.

If you end the connection on a bus, see the remaining steps in the Adding Connections to Buses 
topic.

Tip
Special Symbols in SailWind Logic include power symbols, ground symbols, and off-page 
reference symbols. For more information, see Special Schematic Symbols.

Note:
When you end a connection at another connection, SailWind Logic places a tie dot at the 
junction. The resulting net name is the name of the added connection, not the existing 
connection, unless you assign a name to the existing connection.

6. To assign a fixed net name to a connection, you must first add the connection and then select a 
segment that is directly attached to a part type pin. Then, you can select the net, right-click and 
click Properties, and enter the new net name in the Net Properties  on page 289 dialog box.

Tip
If you select and move a visible net name, with snap to grid enabled, the new net name 
snaps to the Labels and Text grid. To set the labels and text grid, use the settings on 
the Tools > Options > General page. See “Options Dialog Box, General Category”  on 
page 595.

Related Topics
Adding Power and Ground Connections

Adding Off-Page References

Naming a Connection
When you add a connection, SailWind Logic automatically assigns a name with the format $$$nnnn, 
where nnnn is a random number. You can specify a different net name to replace the assigned name.

Procedure
1. Select a connection segment.

2. Right-click and click Properties.

3. Type a new net name in the Net Name box.
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Net Attributes Overview

Tip
The Net Name Label check box exhibits the following behaviors:
• The Net Name Label check box is only available when you select a connection segment 

that enters or exits a part.
• Clearing the Net Name Label check box removes the visible label. The net and all 

subnets retain the net name.

4. To place a bar over the net name, precede the text with the \ character. To place a bar over only a 
portion of text, enclose that section with the \ character.

For example, typing MAIN_\CLK\ places a bar over CLK.

Tip
The \ character factors into the 47 character limit for the net name.

Related Topics
Modifying Nets

Net Attributes Overview
Net attributes enable you to associate information with a single net or set of nets on the schematic. 
Attributes are made of two parts, an attribute name and its corresponding value.

If connecting to SailWind Layout, these attributes are passed along with the rest of the schematic.

Tip
When working with attributes, note the following:
• SailWind Layout checks a limited set of net attributes. See the Default Attributes for Nets  topic 

for more information.
• To assign attributes to signal pins, see the Signal Pin Nets  topic.

See also Creating Net Attributes.

Creating Net Attributes
You can create net attributes and assign them to specific nets. Once created, the attributes can be edited 
or deleted.

Procedure
1. Select a net, right-click and click Attributes.

2. In the Net Attributes dialog box, click Add  to add an attribute.

3. Click the Name column and type a new attribute name.

See also Default Attributes for Nets.
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4. Click the Value column and type an attribute value.

5. To remove the selected net attribute, click Delete.

6. To edit the selected name or value, click Edit.

7. Click OK.

Default Attributes for Nets
Refer to the Listing of Default Attributes for Nets table to determine which net attributes are checked by 
SailWind Layout for correct values and units.

Tip
Some values in the Description and use column are case-sensitive and must be written as such.

Table  30. Listing of Default Attributes for Nets

Attributes Type Description and Use

HyperLynx.Frequency Frequency (Measure) Lists the working frequency for nets in 
BoardSim simulations.
Range: 0 Hz-1000 GHz
Units: Hz kHz MHz GHz (case-sensitive)

HyperLynx.Duty Cycle Percentage (Measure) Lists the percent of time the signal is in high 
state. Used for BoardSim simulations.
Range: 0%-100%

HyperLynx Signal Type List Lists the signal type. Used in BoardSim 
simulations.
Values  (case-insensitive): One of, Clock, 
Strobe, Data, Address, Power Supply, Analog 
High Speed, Analog Low Speed, Do Not 
Analyze

HyperLynx.Default 
IC.Model

Free Text Lists the part model in the file used for 
BoardSim simulations.
Values: Text (model name)

HyperLynx.Default 
IC.Model File

Free Text Lists the part model file in the file used for 
BoardSim simulations.
Values: Text (filename)

HyperLynx.Default 
IC.Model Pin

Free Text Lists the specific pin for the model in the 
above attribute, if applicable. Used in 
BoardSim simulations.
Values: Text (pin name or number)

PowerGround Yes/No Identifies nets as Ground and Power nets.
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Adding Power and Ground Connections

Table  30. Listing of Default Attributes for Nets  (continued)

Attributes Type Description and Use

Values: Yes or No (case-insensitive)

Voltage Measure Describes the voltage of the net.
Range: -100kV-100kV
(-100,000-100,000V)
Units: nV uV mV V kV (case-sensitive)

DFT.Nail Count Per Net Number Indicates the ID of the probe in the test 
fixture.
Values: (integer) 0-2000 (all exact limits are 
allowed; for example, both 0 and 2000 are 
acceptable)

Adding Power and Ground Connections
When you connect a part to ground or power nets, the normal convention is to use a special symbol to 
represent the net. The ground symbol ties the connection to ground. The power symbol adds voltage to 
connections.

Procedure
1. Specify the connection as described in the Adding Connections  topic.

2. Right-click and click Ground  or Power. The symbol attaches to the connection and follows the 
cursor movement.

(Optional) You can rotate or mirror the symbol by choosing the appropriate command from 
the popup menu. You can also modify the symbol representation by right-clicking and clicking 
Alternate. Right-click and click Display PG Name to toggle the visibility of the net name for the 
power or ground symbol.

3. Locate the cursor and double-click to end the connection or right-click and click Complete.

4. You can create and store a number of ground symbols in the library, each with its own net name. 
To select the appropriate ground symbol, right-click and click Alternate.

Three symbols are available with the standard library. You can modify these or add additional 
symbols.

SailWind Logic assigns the net name associated with the ground symbol to the connection, (for 
example, GND, Chassis ground, Analog-ground, etc.).

5. For each alternate power symbol, there is a different signal name: +5V, +24V, etc. To select the 
appropriate signal name, click Alternate  while placing the symbol.

Tip
As you view the power or ground alternates in the working window, you can locate in the 
status bar the net name to which you want to tie the connection.
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Related Topics
Adding Connections

Using Alternate Symbols
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Working With Floating Connections
Floating Connections add another level of flexibility to designing your schematic. Enable Floating 
Connections and you can add a connection from a pin to a location where a part doesn't yet exist without 
requiring an off-page symbol. You can also begin a connection in empty space and connect it later. 
Unconnected nets are terminated with square markers.

Enabling Floating Connections
Disabling Floating Connections and Running the Connectivity Report
Adding Floating Connections
Editing Floating Connections
Duplicating Floating Connections
Creating Floating Connections When Deleting Objects
Attaching Objects to Floating Connections
Adding Off-Page References

Enabling Floating Connections
You can enable floating connections in your design. This enables you to create connections that are 
unterminated at one or both ends.

Procedure
1. Click the Tools  > Options  menu item, and then click the Design  category.

2. In the Parameters area, select the Allow Floating Connections check box to enable Floating 
Connections in the design.

Disabling Floating Connections and Running the 
Connectivity Report
You can disable floating connections in your design. Once you have finished creating a design with 
floating connections enabled, you can disable the floating connections and run a connectivity check on 
the design to assure that all connections have been properly terminated.

Procedure
1. Click the Tools  > Options  menu item, and then click the Design  category.

2. In the Parameters area, clear the Allow Floating Connections check box to disable Floating 
Connections in the design.

If Floating Connections exist in the design, a warning message appears.
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Note:
Warning:  Disabling Floating Connections does not remove them from the design. 
Disabling the preference only prevents additional Floating Connections from being created.
Floating Connections are undesirable on a finished schematic. A floating end should either 
be connected to a pin or terminated on an off-page symbol. Run the Connections Report to 
find the locations of Floating Connections in your design.

3. Click the File  > Report  menu item.

4. In the Reports dialog box, select the Connectivity check box.

5. Click OK  to create the report.

Tip
Multiple Floating Connections are easily selected for deletion. In the Search and Select box 
of the Selection Toolbar, type "dangling" to select all the Floating Connections.
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Adding Floating Connections
With the Floating Connections preference enabled, you can leave a connection dangling in space for a 
later connection. You can also start a connection in space in anticipation of a later connection. New parts 
and connection stubs added automatically through an ECO Import will receive Unconnected Markers 
instead of off-page symbols. Net stubs added through an ECO Import to existing parts will continue to 
receive off-page symbols.

Creating a Dangling Connection
Creating a Floating Connection

Creating a Dangling Connection
A dangling connection is tied to a design object at only one end in anticipation of it being connected at the 
other end at some future point in the design process.

Procedure
1. Start a connection on a pin.

2. Draw the connection.

3. To end the connection in space, double-click.

Alternatively, you can right-click and click End.

Creating a Floating Connection
A floating connection is not tied at either end. Use floating connections to add connections to your design 
as placeholders with the intent of completing the connections at some later time in the design process.

Procedure
1. To start a connection in space, double-click.

2. Draw the connection.

3. To end the connection in space, double-click.

Alternatively, you can right-click and click End.

Editing Floating Connections
You can add floating connections to your design and connect them at a later time. Once created, you can 
edit the floating connections in your design.

• Use Move mode or Add Connection mode to continue a connection from the Unconnected 
Marker.
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Duplicating Floating Connections
With the Floating Connections preference enabled, you can duplicate segments of connections and paste 
them in space. You are not required to paste them where they will make a pin to pin connection.

Procedure
1. Select a segment(s) of a connection.

2. Right-click and click Duplicate.

3. Position the cursor in the paste location and click.

See also Step and Repeat.

Creating Floating Connections When Deleting 
Objects
With the Floating Connections preference enabled, connections attached to deleted parts are terminated 
with Unconnected Markers instead of off-page symbols. When a bus is deleted, nets connected to the bus 
are also terminated with Unconnected Markers instead of off-page symbols.

Attaching Objects to Floating Connections
With the Floating Connections preference enabled, any component pins that touch a floating connection 
end will automatically connect. A pin that touches another component pin will automatically connect also. 
Move the components apart to make the connection visible.

Adding Off-Page References
To connect two pins on separate sheets of the schematic, or at opposite ends of the same sheet, without 
a graphical connection, use an off-page reference with identical net names.

Procedure
1. Specify the connection as described in the Adding Connections  topic.

2. Right-click and click Off-page.

The symbol attaches to the connection and follows the cursor movement.

The default decal with the right pin is defined as a source pin; the alternate decal with the left pin is 
defined as a load pin. This pin type orientation plays a role when you create a hierarchical symbol 
of the sheet. All off-page sources are on the left of the hierarchical symbol outline, and all loads are 
on the right. You can place the default or right-click and click Alternate.

(Optional) You can rotate or mirror the symbol by using the appropriate command.

3. Locate the cursor and double-click to end the connection or right-click and click Complete.

4. Type the net name in the dialog box and click OK.
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Editing Off-Page Symbol Sheet Numbers Per Line

The sheet number for the connecting symbol appears next to the off-page symbol if the “Show Off-
page Sheet Numbers” option is selected in the Options Dialog Box, Design Category.

Tip
If you display the off-sheet numbers, you can line them up or stack them by specifying 
Numbers per Line in the Tools > Options > Design category.

Editing Off-Page Symbol Sheet Numbers Per 
Line
The displayed sheet number next to an off-page reference is set by default to enable 5 sheet numbers to 
be listed in a single text string, separated by commas. You can use Properties mode to edit the number of 
off-page symbol sheet numbers per line.

For example, if set to one, and there are two sheets containing the same net, the sheets will be listed in 
two lines.

Procedure
1. Select the off-page reference text string.

2. On the Schematic Editing toolbar, click the Properties  button.

This displays an information dialog box.

3. Change the settings for sheet numbers per line.

4. Click OK.

See also Options Dialog Box, Design Category.

Changing a Connection
Use Move to change a connection from one endpoint to another, without deleting the rest of the 
connection.

Procedure
1. Select the connection at any point on the segment entering or exiting the part, or where it enters 

another connection.

2. Right-click and click Move.

The connection follows the cursor movement.

3. Right-click and click Angle to specify diagonal segments in the connection.

4. Indicate corners as needed or right-click and click Add Corner. Right-click and clickDel Corner  to 
back up to the previous corner if necessary.
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5. A connection cannot end in open space. Locate the cursor and double-click to end the connection 
or right-click and click Complete.

6. To end a connection with a power, ground, or off-page reference symbol, right-click and click the 
appropriate symbol during the last step of this procedure.

Related Topics
Adding Connections

Adding Power and Ground Connections

Adding Off-Page References

Moving Connections
When you move a part, existing part connections follow the part movement. After part repositioning, you 
might need to move connections to improve the flow.

You can reposition a connection segment that is not a connection endpoint, or you can reconnect a 
segment endpoint. Refer to the Changing a Connection  topic for information on disconnecting from a part 
or connection and reconnecting to another part or connection.

Related Topics
Working With Floating Connections

Splitting a Connection
You can split a connection to create new corners or a 90-degree turn.

Restrictions and Limitations
You can not split segments which enter or exit a part.

Procedure
1. Select a segment, right-click and click Move.

2. Right-click and click Split Segment. Move the cursor to define the segment length.

3. Right-click and click Swap Corner  to define the endpoint in the opposite direction.

4. Indicate the endpoint of the new segment to complete the split.

Splitting Segments
Split converts a line segment into two separate segments, joined by a third segment perpendicular to the 
original segment.

All line segments in a 2D line must have the same line width and style. If you need to create a 2D element 
with more than one line width or style, create two separate 2D lines and use the Combine command to 
join them.
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Splitting Segments

Procedure
1. On the Schematic Editing toolbar, click the Modify 2D Line  button.

2. Select the line to split.

3. Right-click and click Split. The new and divided segments follow the cursor movement.

You can right-click and click one of the following when splitting a segment:
Table  31. Splitting Segments Options

Option Description

Swap Corner Selects the other corner or line segment created by the split.

Del Corner Deletes the current corner.

Width Changes the line width of the item.

Solid Style and Dotted Style Changes the line style to a solid or a dashed line. You cannot 
specify dotted lines for circles or arcs.

Orthogonal Moves are made in 90-degree increments.

Diagonal Moves are made in 45-degree increments.

Any Angle Moves are made at any angle.

4. Indicate the endpoint of the new segment to complete the split.
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Swapping Pins
To swap two part pins, you can use the Swap Pins  button in the Schematic Editing toolbar or Swap Pins 
on the popup menu. SailWind Logic swaps the pin number, name, and terminal of the pins you select. You 
can also swap pins when you place a part using Mirror X and Mirror Y on the popup menu. This is often 
useful for improving the flow of the schematic.

Swapping Pins Using the Swap Pins Button in Verb Mode
Swapping Pins by Selecting One Pin at a Time
Swapping Pins by Selecting Both Pins First

Swapping Pins Using the Swap Pins Button in Verb 
Mode
You can swap pins using the Swap Pins  button. Using this method enables you to initiate the command 
and then make your pin selections to swap. You can continue to select pin pairs to swap until you cancel 
the command.

Procedure
1. On the Schematic Editing toolbar, click the Swap Pins  button.

2. Select the first pin number.

3. Select the pin number to swap with the first selected pin.

4. If the pin types you select do not match, the message “Warning, pin swap types don't match…” 
message appears. Click Yes  to continue. Click No  to cancel the swap.

Tip
The message “Keep connections tied to same electrical pin?” may also appear. Click 
Yes  to preserve the connections with the pin numbers. Click No  to reconnect to the 
renumbered pins.

To use the popup menu to swap pins, you can either select one pin at a time or select both pins at 
once:

Swapping Pins by Selecting One Pin at a Time
You can swap pins by selecting one pin at a time. This method enables you to select the first pin, initiate 
the command and then select the second pin. To create another pin swap, you would repeat the process.

Procedure
1. Select the first pin number.

2. Right-click and click Swap Pins.

3. Select another pin number to complete the swap.
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Swapping Pins by Selecting Both Pins First

4. If the pin types you select do not match, the message “Warning, pin swap types don't match…” 
message appears. Click Yes  to continue. Click No  to cancel the swap.

Tip
The message “Keep connections tied to same electrical pin?” may also appear. Click 
Yes  to preserve the connections with the pin numbers. Click No  to reconnect to the 
renumbered pins.

Swapping Pins by Selecting Both Pins First
You can swap pins by selecting both pins first. After you have selected both pins, you can initiate the 
command. To create another pin swap, you would repeat the process.

Procedure
1. Using Ctrl+click, select the pins you want to swap.

2. Right-click and click Swap Pins. If the message “Swap connected pin?” appears, click Yes  to 
continue. Click No  to cancel the swap.

3. If the pin types you select do not match, the message “Warning, pin swap types don't match…” 
message appears. Click Yes  to continue. Click No  to cancel the swap.

Tip
The message “Keep connections tied to same electrical pin?” may also appear. Click 
Yes  to preserve the connections with the pin numbers. Click No  to reconnect to the 
renumbered pins.
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Managing Buses
SailWind Logic enables you to create, name, edit, and delete buses in your design using a flexible array 
of available commands. Using the bus commands enables you to decrease the visual clutter in your 
design and accurately convey you design intent without having to graphically represent every net as a 
distinct line.

Choosing the Bus Type
Naming Buses
Adding Buses
Adding Connections to Buses
Adding Nets to a Mixed Net Bus
Extending Buses
Moving Bus Segments
Splitting Buses
Deleting Bus Segments
Deleting Buses

Choosing the Bus Type
There are two bus types: a bit format bus and a mixed bus. Choose the bus structure that can best 
visualize your design intent. The bit format bus will display sequential bus nets. The Mixed bus format will 
enable you to combine sequentially named bit format bus nets along with individual nets.

A bit format bus contains a series of nets with consecutive net names. For example, the bit format bus 
AD[0:4] contains nets AD0, AD1, AD2, AD3, and AD4.

A mixed net bus can contain one or more bit format buses in addition to individual nets that are not 
necessarily sequential. For example, a mixed net bus BUS1 can contain individual nets named RAS, 
CAS, and EN as well as the bit format bus AD[0:7].

Tip
The Bus Type you select determines which options appear in the Bus Name list. For example, if 
you select the Bit Format Bus Type, only bit format bus names appear in the Bus Name list.

Naming Buses
SailWind Logic defines a bus that appears on the same sheet, or any other sheet, with an identical name 
as the same bus.

Rules for naming bit format and mixed net buses differ as follows:

Naming a Bit Format Bus
The bit format bus name consists of two parts: the prefix and the bit range of the bus. The format 
is PREFIX[nn:mm] where nn is the lowest bit number and mm is the highest bit number. You can 
use leading zeros to determine the lowest bit number. For example DD[00:15] enables nets DD00, 
DD01,...DD15 to connect to the bus; whereas DD[0:15] enables nets DD0, DD1, DD2,...DD15.
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Adding Buses

The sheet number also displays with the bus name if the Show Off-Page Reference option is on the 
Options Dialog Box, Design Category.

The total bit format bus name - including the prefix, brackets and colon - cannot exceed 47 characters. 
The bit numbers must be in the range of 0 to 32767 and cannot contain alphabetic characters.

Naming a Mixed Net Bus

The mixed net bus name can contain up to 47 alphanumeric characters. The mixed format bus name 
cannot include a bit range suffix or spaces. You cannot create a bus name that is the same as a net 
name.

Adding Buses
You can add a bus to your design so that you can display a collection of related nets as a single entity.

Procedure
1. On the Schematic Editing toolbar, click the Add Bus  button.

2. Indicate the starting point. The bus follows the pointer movement.

3. Indicate bus corners as needed, or right-click and click Add Corner.

If you need to back up to the previous corner, right-click and click Del Corner.

4. Double-click to end the bus in open space or right-click and click Complete.

5. In the Add Bus dialog box, in the Bus Name box, type a new name for the bus, or select a bus 
name from the list.

Restriction:
The Rename area is available only in Query mode.

6. Select the Bus Type. The bus type determines which bus names appear in the Bus Name list.

7. Select the Add Bus Name Label check box to add the bus name as a label to the bus at the end of 
the bus closest to where you selected it.

Tip
When working with bus labels, observe the following:
• A bus can have two labels, one on each end.
• The check box is unavailable when the end of the selected bus has a label.
• A bus label is not required.
• To delete a bus label, select the label in the schematic and click the Delete  button on the 

standard toolbar.

8. If the bus is a mixed net bus, add the bus names in the Bus Nets area.

Tip
To rotate the text before you place it, right-click and click Rotate, then indicate the name 
location
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Adding Connections to Buses
When connecting to a bus, the connection must be perpendicular to the bus. SailWind Logic adds an 
angled bus-tap segment at the point of connection and gives the connection the next sequential net name 
in the bus.

Confirm or type the net name in the dialog box. The text follows the cursor movement. Position the text 
and indicate its location. To swap the bus tap angle, right-click and click Swap Angle.

Adding Nets to a Mixed Net Bus
Use the Bus Nets list in the Add Bus dialog box or the Bus Properties dialog box to add nets to a mixed 
net bus. The Bus Nets area is not available when the Bit Format bus type is selected.

Procedure
1. After you have added a bus, in the Add Bus dialog box, click Add  to add a new row in the Bus Nets 

list.

2. Type the bus prefix in the Name/Prefix text box.

Tip
Enter the names as follows:
• For a single net, type the net name.
• For a range of sequential nets, type the prefix for the sequence of nets.

3. In the Start text box, type the starting bit number for a sequence of nets.

4. In the End text box, type the ending bit number for a sequence of nets.

5. To add an individual net to the bus, type the net name in the Prefix/Name text box.

Do not type Start and End values for a single net that is not sequenced by bit number.

6. Click Edit  to modify a selected cell in the Bus Nets list.

7. Click Delete  to remove a net from the Bus nets list.

8. Click Down  to moves the selected row down one position in the Bus Nets list.

Tip
The order in which nets appear in the Bus Nets list box determines the default order for 
naming nets as they are connected to a bus.

9. Click Up  to move the selected row up one position in the Bus Nets list.

Extending Buses
If you need more room to fan out bus connections, or need to lengthen the path of an existing bus, you 
can extend a bus segment.
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Procedure
1. On the Schematic Editing toolbar, click the Extend Bus  button.

2. Select either endpoint of the bus.

The end segment follows the pointer movement.

3. Click to indicate corners as needed for the extension or right-click and click Add Corner.

4. Double-click to indicate the new endpoint or right-click and click Complete.

5. You cannot use the Extend Bus command to shorten a bus segment. To shorten a bus, delete the 
long segment, then use Extend Bus to redefine that segment, or alternately, you could use the 
Group command to shorten the bus segment.

See also Creation of Groups.

Moving Bus Segments
If you need to reposition a bus segment to accommodate additional edits to your schematic, you can 
move a bus segment.

Procedure
1. Select a bus segment, right-click and click Move.

2. Indicate the new location with the pointer and then click to place.

Splitting Buses
If you need to edit a bus, you can create new corners or a 90-degree turn in the bus.

Procedure
1. Click the Split Bus  button.

2. Select the bus segment. The new and divided segments follow the pointer movement.

3. Move the pointer to define the segment length. To define the endpoint in the opposite direction, 
right-click and click Swap Corner.

4. Indicate the endpoint of the new segment and click to complete the split.

Deleting Bus Segments
As your design progresses, if you determine that you no longer need a bus segment, you can remove a 
segment of the bus.
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Procedure
1. Select the bus segment.

2. Right-click and click Delete.

If the deletion splits the bus into two separate buses, the bus name appears, identifying any 
unnamed bus segments. Each bus retains the same properties.
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Deleting Buses
If you determine that you need to delete a bus that was selected in object mode, you can choose to delete 
the bus only or the bus and its connections.

See also Object Select Mode (Select Object First).

Delete a Bus Only
Delete a Bus and Its Connections

Delete a Bus Only
If you need to delete a bus, you have the option to delete a bus only and leave the connections intact.

Procedure
1. Select a bus.

2. If you want to keep connections attached to the bus, right-click and click Preserve Connections  to 
enable it.

Preserve Connections  is enabled by default.

Tip
Preserve Connections  is enabled when a check mark appears next to it in the menu.

3. Right-click and click Delete.

Connections are left at their original locations.

Delete a Bus and Its Connections
If you need to delete a bus, you have the option to delete a bus and its connections.

Procedure
1. Select a bus.

2. If you want to remove connections attached to the bus, right-click and click Preserve Connections 
to disable it.

Preserve Connections  is enabled by default.

Tip
Preserve Connections  is disabled when a check mark does not appear next to it in the 
menu.

3. Right-click and click Delete.

The bus and connections are deleted.

SailWind Logic Guide 263



Connections
Deleting Connections  

Deleting Connections
You can delete connections, but be aware that when the deleted connections are subnets, the results can 
differ.

• Select a connection, right-click and click Delete.

• When a subnet with a system assigned name is split into two subnets by deleting a connection, 
one of the subnets is automatically assigned a new system name.

• When a subnet with a user assigned name is split into two subnets by deleting a connection, both 
new subnets retain the user assigned name, even if there is no visible net name label.

• When subnets are joined and both have user assigned names, the user is prompted to select one 
of the names for the combined net, even if there are no visible net name labels.

• When a system named subnet is joined with a user named subnet, the combined subnet 
automatically inherits the user assigned name.

• When two system named subnets are joined, the combined subnet inherits the name of one of 
the subnets.

Related Topics
Splitting a Connection

Detach
Use the detach command to free a gate, part, group of components, or group selection from any attached 
nets.

Procedure
1. Make a selection.

2. Right-click and click Detach.

All nets are detached. Nets are given unconnected markers or off-page symbols, depending on the 
Floating Connections preference.

Note:
Warning:  A group selection with Preserve by Boundary enabled detaches nets at the 
boundary and not at net terminations. The Net is split into two instances. Named nets 
retain their original names on both sides of the split.
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Detach

Related Topics
Working With Floating Connections

Creation of Groups
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Chapter 14
Hierarchical Design

SailWind Logic supports hierarchical design where you can create symbols to represent entire sub-
schematics and show system interactivity at a higher level. You can create hierarchy from either the top 
down or the bottom up.

Hierarchical Design Overview
Creating a Top-Down Hierarchy
Creating a Bottom-Up Hierarchy
Pushing Into the Hierarchy
Popping Up the Hierarchy
Modifying a Hierarchical Symbol
Copying a Hierarchical Symbol
Deleting a Hierarchical Symbol

Hierarchical Design Overview
Using hierarchical design, you can create high-level symbols to represent complex sub-schematics, or 
repetitive elements in your design. You can create a hierarchy by using either the top down or the bottom 
up design strategy.

• Top down  — You define a hierarchical symbol and then the underlying logic.

• Bottom up  — You create a schematic, then define the hierarchical symbol for the schematic.

You can also assign or unassign hierarchical connections in the Hierarchical Component properties  on 
page 296 dialog box.

Level 0 is the top design level that contains the design contents. Numbered sheets from sheet 1 to 
1024 represent the design contents. A SailWind Logic design cannot exceed a total number of 1024 
hierarchical and numbered sheets.

You can navigate the hierarchy with the Push Hierarchy  on page 269 and Pop Hierarchy  on page 270
commands on the View  menu.

When a hierarchical symbol is copied, any existing underlying schematic content is also copied. SailWind 
Logic updates the reference designator names of the underlying symbols. There is a one-to-one 
correspondence between hierarchy symbols and a schematic sheet. The underlying logic for duplicated 
hierarchical symbols is stored as a unique sheet, and can be edited without affecting the logic of other 
hierarchical symbols. Even though you copy a hierarchical symbol, its underlying schematics can be 
completely different from the copied symbol’s underlying schematics.

Creating a Top-Down Hierarchy
In top-down design, you create a hierarchical symbol before the underlying schematic exists. This 
enables you to create the container object and then populate it with the lower level design elements. Pin 
names tie together signals between hierarchical levels.
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SailWind Logic ties together all instances of a common signal name, regardless of where they are found 
in the design, into a single connection net. You establish connectivity across the hierarchy by using the 
same signal name in the underlying logic.

Prerequisites

• Ensure that the off-page signals in the underlying schematic are consistent with the pin names in 
the hierarchical symbol.

Procedure
1. On the Schematic Editing toolbar, click the New Hierarchical Symbol  button.

2. In the Hierarchical Symbol Wizard Dialog Box, in the Hierarchical Sheet area, type the symbol 
name in the Sheet Name text box.

3. Select your preferred Pin Decal for both input and output pins from the appropriate dropdown list 
boxes.

4. Specify the Pin Count for both input and output pins.

The Preview area displays the symbol outline.

5. Click OK. The hierarchical symbol appears in the Part Editor  on page 109 window.

Tip
Because the symbol is a hierarchical one, it has no pin numbers. The pin name associated 
with pins of the hierarchical symbol identify the net name of the connection that is tied to 
the pin. All pins on a hierarchical symbol must have a pin name. You cannot complete the 
hierarchical symbol until you assign a name to each pin.

6. In the Part Editor, double-click each pin to open the Terminal Properties dialog box  on page 131
where you name the selected pin. You must name each pin of the symbol.

7. Click the File  > Complete  menu item.

This closes the Part Editor, and the new symbol attaches to the cursor.

8. Move the cursor to a desired location and click to place the symbol in the schematic.

9. You can navigate this hierarchy with the View  > Push Hierarchy, and View  > Pop Hierarchy 
menu commands.

Related Topics
Creating a Bottom-Up Hierarchy

Creating a Bottom-Up Hierarchy
In bottom-up design, you create a hierarchical symbol from an existing sheet that represents the 
underlying logic. This enables you to create the lower level design and then wrap it in the hierarchical 
symbol.
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Pushing Into the Hierarchy

SailWind Logic adds an input or output pin in the symbol for each off-page reference on the schematic 
sheet. SailWind Logic places off-page references with a pin type of Source on the left side of the 
hierarchical symbol, and off-page references with a pin type of Load on the right side. (Pin types for off-
page references are defined in the library under electrical.)

Procedure
1. Switch to the sheet to which you want to add the hierarchical symbol. If needed, add a new 

schematic sheet to the sheet set using the Setup  > Sheets  menu item.

2. On the Schematic Editing toolbar, click the New Hierarchical Symbol  button.

3. On the Hierarchical Symbol Wizard dialog box, select an existing sheet from the Sheet Number 
dropdown list box in the Hierarchical Sheet section.

4. Type a name for the symbol in the Sheet Name text box.

5. Select your preferred Pin Decal for both input and output pins from the appropriate dropdown list 
box.

The Preview area displays the symbol outline. The number of input/output pins on the symbol 
is automatically set from the number and type of off-sheet reference symbols on the underlying 
schematic sheet and the pin count boxes are unavailable for editing.

6. Click OK.

The hierarchical symbol appears in the Part Editor  on page 109 window. An input or output pin is 
located on the symbol to match each off-page reference on the underlying schematic sheet.

7. Click the File  > Complete  menu item.

This closes the Part Editor, and the new symbol attaches to the cursor.

8. Move the cursor to a desired location and click to place the symbol in the schematic.

9. You can navigate this hierarchy with the View  > Push Hierarchy  and View  > Pop Hierarchy  menu 
commands.

Related Topics
Creating a Top-Down Hierarchy

Pushing Into the Hierarchy
Use the Push Hierarchy command to look inside or push down into a hierarchical symbol to view the 
underlying logic.

Procedure
1. Click the View  > Push Hierarchy  menu item.

2. Select the hierarchical symbol.
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Alternatively, you can select the hierarchical symbol, right-click and click Push Hierarchy.

Tip
If there is no underlying schematic representation of the selected symbol, a blank sheet 
appears.

Popping Up the Hierarchy
Use the Pop Hierarchy command to replace the current sheet with its corresponding hierarchical symbol.

Procedure
In a hierarchical sub-schematic, click the View  > Pop Hierarchy  menu item.

Tip
In the Sheets list on the main toolbar, a sub-schematic is displayed with an indented icon.

Modifying a Hierarchical Symbol
Once created, you can modify a hierarchical symbol to add or subtract design detail.

Procedure
1. Select a hierarchical symbol, right-click and click Edit Hierarchical Symbol.

2. Modify the symbol in the Part Editor  on page 109.

3. Click the File  > Complete  menu item when you are finished with the changes.

Tip
If you add terminals to a hierarchical symbol, ensure that you give them pin names, 
and that the names also appear as off-page references in the sheet with the underlying 
schematic.

Related Topics
Hierarchical Symbol Wizard Dialog Box

Deleting a Hierarchical Symbol

Copying a Hierarchical Symbol
When you copy a hierarchical symbol, the sheets that the symbol references will also be copied and 
added as new sheets to the schematic. SailWind Logic assigns new reference designators to the part 
types in the copied sheets. If the referenced sheet also contains hierarchical symbols, then SailWind 
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Logic also copies the sheets referenced by those symbols, and so on, down the entire sub-tree of the 
hierarchy.

Procedure
1. Select the symbol in the design.

When you select a hierarchical symbol in copy mode, a warning prompt appears. If you click Yes 
in the prompt window, SailWind Logic copies the hierarchical symbol, and all directly or indirectly 
referenced sheets. If any numbered sheets are referenced, SailWind Logic assigns the copies new 
sheet numbers.

2. Ctrl+drag a copy.

3. In the warning prompt, click Yes.

The symbol copy attaches to the cursor.

4. Click the place the symbol.

Related Topics
Hierarchical Symbol Wizard Dialog Box

Modifying a Hierarchical Symbol

Deleting a Hierarchical Symbol

Deleting a Hierarchical Symbol
You can delete a hierarchical symbol, but use caution when performing the operation.

Procedure
1. On the Schematic Editing Toolbar, click the Delete  button.

2. When you select a hierarchical symbol in delete mode, the message “OK to delete sheets 
associated with the hierarchy - Warning: there is no Undo for this operation” appears. Be sure of 
your intent before confirming the command.

• If you click Yes, SailWind Logic deletes the hierarchical symbol and any associated sheets 
throughout the hierarchy.

• If you click No, and it is a hierarchical symbol without a sheet number, SailWind Logic assigns it 
the next unused sheet number and it becomes a normal, numbered sheet.
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Chapter 15
Schematic Object Modification

Changes and edits to your design objects are fully-supported in SailWind Logic. This includes the 
modification of drafting objects, fields, parts, reference designators, part attributes, labels, pins, and 
buses. You can modify individual instances of objects, or you can choose to update the library objects so 
that any modifications are available to your future design sessions.

Modifying Drafting Objects
Modifying Fields
Modifying Parts
Reference Designator Renumbering
Automatically Renumbering Reference Designators
Setting Reference Designators by Sheet in a New Schematic
Setting Reference Designators by Sheet in Completed Schematics
Modifying Part Attributes
Modifying Part Attribute Labels
Modifying Part Type Labels
Searching the Library for a Decal
Rename Part
Rename Gate
Modifying Reference Designator Labels
Modifying Pins
Modifying Pin Label Fonts
Modifying Nets
Modifying Net Name Labels
Modify Buses
Modifying Bus Name Labels
Modifying Off-Page Labels
Modifying Label Font Sizes
Modifying Text
Modifying Hierarchical Components

Modifying Drafting Objects
Use the Drafting Properties dialog box to modify the line width, style, and orientation of selected drafting 
objects.

Tip
Use the Schematic Editing toolbar to modify the shape of 2D lines.
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Procedure
1. Select a drafting object, right-click and click Properties.

2. In the Width box, type a new line width for the drafting object.

The width box lists the current line width of the selected drafting object.

Use the Line Widths  tab in the Options dialog box to change the default line width.

3. Select the Filled check box to create a filled shape from a selected polygon.

Restriction:
This option is unavailable for circles, paths, and if you used Pull Arc to modify the polygon.

4. In the Style area, select a line style option for the selected drafting object.

5. In the Rotation box, select the degree of rotation from the Rotation list.

Tip
When rotating objects, observe the following:
• Rotation can be 0 or 90 degrees.
• The point used when selecting the object is the also the point of rotation.

6. Select the Mirror by X or Mirror by Y check boxes to mirror the selected drafting object in the X 
(horizontal) or Y (vertical) direction.

Modifying Fields
Use the Field Properties dialog box to modify a field name or change its text size, orientation, or 
justification.

Procedure
1. Select a field, right-click and click Properties.

2. In the Field Properties dialog box, the Name box displays the selected Field string. Modify the 
existing string, select a new one, or type a new text string.

3. In the Value box, type the value you want displayed.

Note that the Value box is unavailable for system fields since the value is derived from your 
system.

4. To place the field at a precise X,Y coordinate location, type the value in the X and Y boxes.

Tip
If this is blank when you click OK, the field attaches to the pointer until you click to indicate 
the location.

5. In the Rotation list, select the degree of rotation you want.
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Rotation can be 0 or 90 degrees.

6. In the Size box, type the font size you want.

Stroke font sizes must be between 10 and 1000 mils; system font sizes must be between 1 and 72 
points.

7. For stroke font, in the Line Width box, type the line width.

8. For system fonts, select the font you want to use in the Font list.

You can also click a system font style you want applied: B  for Bold, I  for Italic, or U  for Underlined.

9. To set the Justification, click the Horizontal and Vertical options you want.

10. Click OK.
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Modifying Parts
Use the Part Properties dialog box to create and edit part attributes. You can also define signal pins and 
control the visibility of attributes assigned to the part.

Tip
This dialog box contains several sub-dialog boxes. Before using any of these sub-dialog boxes, 
changes made in open dialog box must be applied to the design.

Changing the Reference Designator
Changing the Part Type
Changing Part Information
Changing the Visibility of Text
Changing Part Attributes
Changing PCB Decals
Assigning Unused Pins as Signal Pins

Changing the Reference Designator
If you need to reassign gates in your design, you can change the reference designator of a selected gate.

Procedure
1. Select a part, right-click and click Properties.

2. In the Reference Designator area, click Rename Gate  to change the reference designator of the 
selected gate, type the new gate reference designator information and click OK.

3. Click Rename Part  to change the reference designator of the selected part, type the new part 
reference designator information and click OK.

Changing the Part Type
Use the Change Part Type dialog box to change the selected part(s) to a new part type. The new part 
type can be one that already exists in the schematic or in the parts library.

Procedure
1. Click the Tools  > Options  menu item, then click the Design  category.

2. Set the “Allow overwriting of attribute values in design with blank values from library” check box 
appropriately to allow or prevent overwriting of non-blank attribute values with blank (“placeholder”) 
values from the library.

3. Select a part or parts, right-click and click Properties.

4. In the Part Type area, click Change Type  to change the selected part(s) to a new part type.
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5. In the Change Part Type Dialog Box, use the Filter to limit your search results to a chosen library 
(or libraries) for a specific part or item name, or names that match a wildcard or expression  on 
page 105. Click Apply  to search the libraries and display the search results.

6. Use the Library dropdown list to select specific library directories or the All Libraries setting.

7. Type * to view all parts or items in the chosen libraries.

8. Scroll through the Parts list to find a part type.

Tip
When examining the parts list, note the following:
• The Parts list box displays the parts that matched the search filter settings.
• The decal of a selected part displays in the preview area to the left of the list box.

9. Set how attributes are updated in the Attributes area.

10. Set how parts are updated in the “Apply update to” area.

Tip
When updating parts, observe the following:
• You can update the part definition in the schematic with a modified version in the library. 

Select the same part name, then click All Parts This Type in the “Apply Update to” Area.
• If you change a part type to one with fewer pins, the connections going to the missing 

pins are not deleted. They are attached to automatically generated off-page symbols. 
You are notified of all disconnected pins.

Changing Part Information
As your design needs evolve, you can change part properties as required.

Procedure
1. Select a part, right-click and click Properties.

2. Click Statistics  to display gate and connection information for the selected part. This information is 
displayed in the default text editor so you can save the contents to a file.

3. Select a gate decal name from the Gate Decal list to change the gate decal of the selected gate or 
part to one of the predefined alternate decals.

Changing the Visibility of Text
You may decide to retain but turn off the visibility of certain text objects in your design. An example would 
be to turn off the display of the tolerance values for a family of components such as resistors where they 
all are assigned a default value.
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Procedure
1. Select a part, right-click and click Properties.

2. Click Visibility  to change the visibility of associated text.

See also Controlling Text Visibility for a Part.

Changing Part Attributes
As your design progresses, you may find it necessary to change or modify attributes. You can change the 
attributes by modifying the part properties.

Procedure
1. Select a part, right-click and click Properties.

2. Click Attributes  to assign or modify part attributes.

See also Modifying Part Attributes.

Changing PCB Decals
Use the PCB Decal Assignment dialog box to assign alternate PCB decals to schematic parts. Decal 
names are included in the netlist file to display the proper decal, or footprint, when the file is imported into 
the PCB design file. You can select a decal assigned as an alternate during part creation, override the 
decal with one from the library, or enter a name for an undefined decal you plan to create later in the PCB 
design.

Procedure
1. Select a part, right-click and click Properties.

2. Click PCB Decals  to assign alternate PCB decals.

3. In the PCB Decal Assignment dialog box, in the Assigned in Schematic box, type a new decal 
name for a decal you plan to create later in the PCB design.

Tip
The Assigned in Schematic box displays the name of the currently selected decal as it is 
assigned to the schematic from the current library.

4. Select the “No specific PCB Decal” check box to remove the assigned decal.

The default decal assigned to the part type is used when the netlist is imported to SailWind Layout; 
no decal assignment appears in the netlist.

5. In the Alternates in Library list, select a decal from the current part type definition in the library.

6. Click Assign  to assign the decal to the part.
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Tip
The preview window displays the currently selected decal.

7. Click the Browse  button to search a library for a decal.

See also Searching the Library for a Decal.

8. Set how parts are updated in the Apply update to area.

• This Part  — Only updates the selected part.

• All Parts This Type  — Updates all matching parts in the design with the new decal.

9. Click OK.

Assigning Unused Pins as Signal Pins
Use the Part Signal Pins dialog box to assign any unused pins as additional signal pins. When the part 
type is created and stored in the library, the standard power and ground pins for part types are defined.

Signal pins assigned during part creation cannot be modified through this dialog box. Instead, use the 
Assigning Signal Pin Names to Parts dialog box in the Library Manager.

Procedure
1. Select a part, right-click and click Properties.

2. Click Sig Pins.

The Part Signal Pins dialog box lists pins and their corresponding signal names. A signal pin is a 
pin that has a signal net (GND for example) assigned by a schematic capture program during part 
type creation.

See also “Part Information - Pins”  on page 147.

3. In the Part Signal Pins dialog box, select a pin in the Unused Pins list.

4. Click Add to add the unused pin to the Signal Pins list.

5. Assign a signal name in the Signal Pins area.

6. To modify the signal name of the pin, select the pin in the Signal Pins list and click Edit.

7. To move the pin to the Unused Pins list, select the pin in the Signal Pins list and then click 
Remove.

8. Set the update settings in the Apply update to area.

• This Part  — Updates the selected part only.

• All Parts This Type  — Updates all parts of the same type.

9. Click OK.
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Reference Designator Renumbering
Manually renumber single or automatically renumber reference designators in the schematic. SailWind 
Layout can renumber the reference designators automatically in a pattern, to optimize finding your parts 
on a manufactured printed circuit board. Once the parts are renumbered in SailWind Layout, you can 
synchronize the designs again by back annotating an .eco  file of the changed designators.

To manually renumber a reference designator in SailWind Logic, see Changing the Reference Designator.

To automatically renumber reference designators in SailWind Logic, see “Automatically Renumbering 
Reference Designators”  on page 280.

To automatically renumber the reference designators in SailWind Layout, see Changing the Reference 
Designators of Multiple Components in ECO Mode (Autorenumbering)  in the SailWind Layout Guide.

Automatically Renumbering Reference 
Designators
Renumber reference designators on a sheet by sheet basis with control over the starting value, 
increment, and pattern.

Procedure
1. On the Schematic Editing toolbar, click the Auto Renumber Parts  button

2. In the “Auto Renumber Parts Dialog Box”  on page 473, select the sheets to renumber.

3. Choose which reference designator prefixes to renumber.

4. If needed, set the Cell size to smaller cells. See the example below.

5. Set the Renumber settings for your situation.

6. Set the Precedence pattern.

7. Click OK.

An ECO file is automatically generated. If the Output window is open, a link to the file appears in 
the log. If the output window is closed, the ECO file opens in your default text editor.

8. If the board layout has already been started in SailWind Layout, you must import the ECO file 
to update the reference designators in SailWind Layout. This exact file must be used. Do not 
overwrite this file with a new one or generate an ECO file using the Compare/ECO Tools until 
SailWind Layout has been updated with the renumbering. In SailWind Layout, click the File  > 
Import  menu item. Browse for the .eco  file and import the changes.

Examples
The following graphic displays the result of a smaller cell size on the parts in the schematic. Cell borders 
have been drawn to illustrate how it works. The parts within the cells are renumbered in the Precedence 
pattern and then the cells also are processed in the same pattern.
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Setting Reference Designators by Sheet in a New Schematic

Figure 5. Cell Size Illustration

Setting Reference Designators by Sheet in a 
New Schematic
Set reference designator start values by sheet. If you will have multiple channels, each occupying one 
schematic sheet, and you want the reference designators to have predetermined ranges you can set a 
start value for designated sheets.

Procedure
1. Click the Setup  > Sheets  menu item.

2. In the “Sheets Dialog Box”  on page 717. Click the Add  button and add all the sheets for the 
multiple channels.

3. Name the schematic sheets.

4. In the RefDes Start Value column, for each channel sheet, type the starting value for reference 
designators of components added or copied and pasted to the schematic sheet.
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Setting Reference Designators by Sheet in 
Completed Schematics
Renumber reference designators in schematics that already have assigned reference designators.. 
If you will have multiple channels, each occupying one schematic sheet, and you want the reference 
designators to have predetermined ranges you can renumber them.

Prerequisites

• Determine which schematic sheets need to be renumbered and which reference designators 
should be renumbered on those sheets.

Procedure
1. On the Schematic Editing toolbar, click the Auto Renumber Parts  button.

2. In the “Auto Renumber Parts Dialog Box”  on page 473, select the sheets to renumber.

3. Choose which reference designator prefixes to renumber.

4. If needed, set the Cell size to smaller cells. See the example below.

5. Set a Start Value and Increment value.

6. Select the “Increment Start Value by Sheet” check box.

This sets the starting number to match the sheet number and not the order of the sheet in the list.

7. Set the Precedence pattern.

8. Click OK.

Examples
The following graphic displays the result of a smaller cell size on the parts in the schematic. Cell borders 
have been drawn to illustrate how it works. The parts within the cells are renumbered in the Precedence 
pattern and then the cells also are processed in the same pattern.
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Figure 6. Cell Size Illustration

Modifying Part Attributes
Use the Part Attributes dialog box to assign or modify part attributes, which is information about the part 
such as manufacturer and cost.

Procedure
1. Select a part, right-click and click Attributes.

2. To add an attribute to a part on the schematic, click Add.

3. In the Name column type a name or click Browse Lib Attr  to select an existing attribute name.

4. In the Value column, type a value for the attribute.

5. To edit a name or value in the Attributes list, select a name or value and click Edit  or double click a 
name or value.

6. To delete an attribute, select a name or value and click Delete.
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7. Set how parts are updated in the “Apply update to” area.

• This Part  — Only updates the selected part.

• All Parts This Type  — Updates all matching parts in the design.

Tip
Adding or changing attributes in a part at the schematic level does not update the part type 
(in the library). Edit the part in the Part Editor to update the library part.

Related Topics
Part Editor Operations

Attributes Overview

Modifying Part Attribute Labels
Use the Attribute Properties dialog box to provide text and font settings for one or more part attribute 
labels.

Procedure
1. Select nothing, right-click and click Select Documentation.

2. Select a part attribute label, right-click and click Properties.

3. In the Attribute Properties dialog box, type a new value for the attribute.

Tip
If you selected multiple attribute labels, you cannot change the value.

4. In the Rotation box, select the degree of rotation from the Rotation list.

Rotation can be 0 or 90 degrees.

5. In the Size box, type the size in mils for the height of the stroke font (from the top of the tallest 
character to the bottom of the lowest character), or in points for system fonts.

Tip
Type a stroke font size between 10 and 1000 mils or a system font size between 1 and 72 
points.

6. For stroke font, in the Line Width box, type the width of the line used to create the characters.

7. For system fonts, select the font you want to use.

You can also click a system font style you want applied: B  for bold, I  for Italic, or U  for Underlined.
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8. To set the Justification, click the Horizontal and Vertical options you want.

9. Click OK.

Modifying Part Type Labels
Use the Part Type Label Properties dialog box to provide text and font settings for one or more part type 
labels.

Procedure
1. Select nothing, right-click and clickSelect Documentation.

2. Select a part type label, right-click and click Properties.

3. In the Part Type Label Properties dialog box, click Change Type  if you want to change the part 
type.

See also Changing the Part Type.

4. In the Rotation box, select the degree of rotation from the Rotation list.

Rotation can be 0 or 90 degrees.

5. In the Size box, type the size in mils for the height of the stroke font (from the top of the tallest 
character to the bottom of the lowest character), or in points for system fonts.

Tip
Type a stroke font size between 10 and 1000 mils or a system font size between 1 and 72 
points.

6. For stroke font, in the Line Width box, type the width of the line used to create the characters.

7. For system fonts, select the font you want to use.

You can also click a system font style you want applied: B  for Bold, I  for Italic, or U  for Underlined.

8. To set the Justification, click the Horizontal and Vertical options you want.

9. Click OK.

Searching the Library for a Decal
Use the Get Decal from Library dialog box to search a library for a decal. You can use the filters to quickly 
narrow down your search parameters to find the exact part that you require.

Procedure
1. Select a part, right-click, click Properties, and then click the PCB Decals  button.

2. In the PCB Decal Assignment dialog box, click the Browse  button.
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3. In the Get Decal from Library dialog box, use Filter to limit your search results to a chosen library 
(or libraries) for a specific part or item name, or names that match a wildcard or expression  on 
page 105. Click Apply  to search the libraries and display the search results.

Tip
When searching, observe the following:
• Use the Library dropdown list to select specific library directories or the All Libraries 

setting.
• Type a prefix plus an asterisk in the Items text box. For example, type DIP* to view 

all decals that begin with DIP. Type an asterisk only to view all decals in the selected 
libraries. Type only*  to view all parts or items in the chosen libraries.

• Enter a value in the Pin Count text box to narrow the search further. Pin Count grays if 
a decal is already defined for the selected part. Pin Count is on if the No Specific PCB 
Decal is on in the PCB Decal Assignment dialog box.

4. Scroll through the Decals list box to find and select a decal.

Tip
Decals are displayed as follows:
• The Decals list box displays the decals that matched the search filter settings.
• The selected decal displays in the preview area to the left of the list box.

5. Click OK  to exit the dialog box.

You return to the PCB Decal Assignment dialog box.

Rename Part
Use Rename Part to change the reference designator for the selected part or gate. All gates are renamed 
if you change the reference designator of one gate of a multi-gated part. You are prevented from 
assigning an already used reference designator.

Procedure
1. Select a part, right-click and click Properties.

2. In the Part Properties dialog box, click Rename Part.

An information window displays.

3. Type the new part reference designator information.

4. ClickOK.

Rename Gate
Use Rename Gate to change the reference designator of the selected gate. You are prevented from 
assigning an already used reference designator or an unused gate of a part with a different part type.
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Procedure
1. Select a part, right-click and click Properties.

2. In the Part Properties dialog box, click Rename Gate.

An information window displays.

3. Type the new gate reference designator information.

4. ClickOK.

Modifying Reference Designator Labels
Use the Reference Designator Properties dialog box to view and modify label size and justification as well 
as text and font settings for one or more reference designator labels.

Procedure
1. Select nothing, right-click and click Select Documentation.

2. Select a reference designator label, right-click and click Properties.

3. In the Reference Designator Properties dialog box, in the Rename area, select Gate to rename just 
the single gate. Select Part to rename the entire part.

Tip
If you select a gate with only one part, Gate is unavailable.

4. In the Rotation box, select the degree of rotation from the Rotation list.

Rotation can be 0 or 90 degrees.

5. In the Size box, type the size in mils for the height of the stroke font (from the top of the tallest 
character to the bottom of the lowest character), or in points for system fonts.

Tip
Type a stroke font size between 10 and 1000 mils or a system font size between 1 and 72 
points.

6. For stroke font, in the Line Width box, type the width of the line used to create the characters.

7. For system fonts, select the font you want to use.

You can also click a font style you want applied: B  for Bold, I  for Italic, or U  for Underlined.

8. To set the Justification, click the Horizontal and Vertical options you want.

9. Click OK.
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Modifying Pins
Use the Pin Properties dialog box to view pin information, to modify parts and nets to which the selected 
pin is connected, and also to set font settings for pin number and pin name labels.

Procedure
1. Select a pin, right-click and click Properties.

2. In the Pin Properties dialog box, click the Part/Gate  button to change part or gate attribute 
information.

See also Modifying Parts.

3. Click the Net  button to modify the net name and attributes of a named net.

Tip
To modify the net name or attributes of a $$$ named net, use the Query Mode  button to 
select a net near a pin to change it from a $$$ named net.

See also Modifying Nets.

4. Click the Font  button to open the Pin Label Fonts dialog box where you set font preferences.

See also Modifying Pin Label Fonts.

5. Click OK.

Modifying Pin Label Fonts
To improve the legibility of your schematic, you can use the Pin Label Fonts dialog box to change the 
fonts of a pin label.

Procedure
1. Select a pin label, right-click and click Properties.

2. In the Pin area of the Pin Label Fonts dialog box, type the line width in the Line Width box for stoke 
font.

3. For stroke or system fonts, in the Size box, type the size  (in mils for stroke font, in points for 
system fonts).

Tip
Type a stroke font size between 10 and 1000 mils or a system font size between 1 and 72 
points.

4. For system fonts, select the font you want to use.

You can also click a font style if you want one: B  for bold, I  for italic, or U  for underlined.

5. Click OK.
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Modifying Nets
To rename a net or edit its attributes and values, you can use the Net Properties dialog box to access net 
specific properties.

Procedure
1. Select a net, right-click and click Properties.

Tip
Select the connection segment where it enters or exits a part. Selecting any other segment 
of the connection will not allow net name labels to be added.

2. Type a new name in the Net Name box or select an existing name from the list.

Tip
When working with net names, observe the following:
• If you select a name from the list, the message “Net <netname> already exists - OK 

to combine nets (Y/N)?” appears. Click Yes  to combine the nets, or click No  to enter a 
different net name.

• If you delete all visible net name labels, the net and all subnets retain the net name. Net 
names do not revert to a generated $$$nnnn system number. You must rename the net.

• If you attempt to combine a named and an unnamed net, the resulting net will always 
take the name of the named net. Any similar attribute names will always take their values 
from the named net.

• The Connectivity Report identifies subnets tied together without a visible net name by 
flagging them as missing an off-page symbol.

3. In the Rename area, click This Instance to apply the new net name to the selected connection or 
click All Instances to apply the new net name to all instances of this connection.

Tip
Selecting This Instance will cause the net to be split into two separate nets.

4. Select the Net Name Label check box to add a visible label to the selected net segment.

You must select the connection segment where it enters or exits a part, or the Net Name Label 
check box will be unavailable.

Tip
Clearing the Net Name Label check box removes the visible label. The net and all subnets 
retain the net name.

5. Click Statistics  to display connection information in the default text editor.

6. Click Attributes  to open the Net Attributes dialog box and modify the net attributes.

See also Creating Net Attributes.
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7. Click Rules  to open the Net Rules dialog box and modify the net rules.

See also Setting Up Net Rules.

8. Click OK.

The new net name is placed over the connection segment.

Tip
Use Using Move Mode  to adjust the placement of the net name text.

Modifying Net Name Labels
Use the Net Name Properties dialog box to provide or change text and font settings for one or more net 
name labels.

Procedure
1. Select nothing, right-click and click Select Documentation.

2. Select a net name label, right-click and click Properties.

3. Type a new name in the Net Name box or select an existing name from the list.

Tip
When working with net names, observe the following:
• If you select a name from the list, the message “Net <netname> already exists - OK 

to combine nets (Y/N)?” appears. Click Yes  to combine the nets, or click No  to enter a 
different net name.

• If you delete all visible net name labels, the net and all subnets retain the net name. Net 
names do not revert to a generated $$$nnnn system number. You must rename the net.

• If you attempt to combine a named and an unnamed net, the resulting net will always 
take the name of the named net. Any similar attribute names will always take their values 
from the named net.

• The Connectivity Report identifies subnets tied together without a visible net name by 
flagging them as Subnets with Missing Net Name.

4. In the Rename area, click This Instance to apply the new net name to the selected connection or 
click All Instances to apply the new net name to all instances of this connection.

Tip
Selecting This Instance will cause the current segment of the net to take the new net name 
and be split from the other instances.

5. In the Rotation box, select the degree of rotation from the Rotation list.

Rotation can be 0 or 90 degrees.

6. In the Size box, type the size in mils for the height of the stroke font (from the top of the tallest 
character to the bottom of the lowest character), or in points for system fonts.
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Tip
Type a stroke font size between 10 and 1000 mils or a system font size between 1 and 72 
points.

7. For stroke font, in the Line Width box, type the width of the line used to create the characters.

8. For system fonts, select the font you want to use.

You can also click a system font style you want applied: B  for Bold, I  for Italic, or U  for Underlined.

9. To set the Justification, click the Horizontal and Vertical options you want.

10. Click OK.
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Modify Buses
Use the Bus Properties dialog box to change the name of a bus or change the bus type.

Changing the Name of a Bus
Changing the Bus Type
Managing Bus Nets

Changing the Name of a Bus
As your design evolves, you may need to add or delete nets to or from a bus. Once you have made these 
modifications, you can change the name of a bus to reflect those changes.

Procedure
1. Select a bus, right-click and click Properties.

2. Type a new name for the bus in the Bus Name box or select an existing name from the list.

See also Naming Buses.

Tip
If you change the bit range for a bit format bus, the new bit range nn:mm must be equal 
to or greater than the old bit range. The signals attached to the bus will keep their old bit 
number, but take the new name.

3. In the Rename area, click This instance to apply the new bus name to the selected bus, or click All 
instances to apply the new bus name to all instances of this bus.

4. Select the Bus Name Label check box to add a visible label to the selected bus.

Changing the Bus Type
As your design evolves, you may find it necessary to change the type of a bus from a bit format bus to a 
mixed net bus or the other way around. You can use Properties to change the bus type.

Procedure
1. Select a bus, right-click and click Properties.

2. In the Bus Type area, click the bus type you want.

The Bus Type determines which bus names appear in the Bus Name list.
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Tip
If you change the bus type from bit format to mixed net bus, the bus name changes to just 
the prefix. The bus name prefix and bit range are added to the Bus Nets list box.

Restriction:
You can change a mixed net bus to a bit format bus only if all of the connected nets 
conform to the bit sequenced names, which you define in the Bus Name text box. Before 
you can change a mixed net bus to a bit format bus, you must delete the bus nets from the 
Bus Nets list box.

Managing Bus Nets
You may find it necessary to expand the range of a bus to include additional sequential nets. Use 
Properties to add sequential nets to a bus.

Restrictions and Limitations
The Bus Nets area is not available when the Bit Format bus type is selected.

Procedure
1. Select a bus, right-click and click Properties.

2. Click Add  to add a new row in the Bus Nets list.

3. Type the bus prefix in the Name/Prefix column.

Tip
Use the following naming conventions:
• For a single net, type the net name.
• For a range of sequential nets, type the prefix for the sequence of nets.

4. In the Start column, type the starting bit number for a sequence of nets.

5. In the End column, type the ending bit number for a sequence of nets.

Tip
To add an individual net to the bus, type the net name in the Prefix/Name column. Do not 
type Start and End values for a single net that is not sequenced by bit number.

6. Click Edit  to modify a selected cell in the Bus Nets list.

7. Click Delete  to remove a net from the Bus nets list.

8. Click Down  to move the selected row down one position in the Bus Nets list.
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Tip
The order in which nets appear in the Bus Nets list determines the default order for naming 
nets as they are connected to a bus.

9. Click Up  to move the selected row up one position in the Bus Nets list.

Related Topics
Managing Buses

Modifying Bus Name Labels

Modifying Bus Name Labels
Use the Bus Name Properties dialog box to provide or change text and font settings for one or more bus 
name labels.

Procedure
1. With nothing selected, right-click and click Select Documentation.

2. Select a bus name label, right-click and click Properties.

3. In the Bus Name Properties dialog box, click Bus  to open the Bus Properties dialog Box.

See also Modify Buses.

4. In the Rotation box, select the degree of rotation from the Rotation list.

Rotation can be 0 or 90 degrees.

5. In the Size box, type the size in mils for the height of the stroke font (from the top of the tallest 
character to the bottom of the lowest character), or in points for system fonts.

Tip
Type a stroke font size between 10 and 1000 mils or a system font size between 1 and 72 
points.

6. For stroke font, in the Line Width box, type the width of the line used to create the characters.

7. For system fonts, select the font you want to use.

You can also click a system font style you want applied: B  for Bold, I  for Italic, or U  for Underlined.

8. To set the Justification, click the Horizontal and Vertical options you want.

9. Click OK.

Tip
Font properties you specify in the Net Name Label Properties dialog box are also applied 
to the off-page reference label.
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Modifying Off-Page Labels
Use the Off Page Properties dialog box to set the maximum sheet numbers per line and the rotation 
settings for off page labels.

Procedure
1. Select an off-page label, right-click and click Properties.

2. In the Off-Page Properties Dialog Box, type the maximum sheet numbers allowed per line, from 0 
to 99.

3. In the Rotation box, select the degree of rotation from the Rotation list.

Rotation can be 0 or 90 degrees.

4. Click OK.

Modifying Label Font Sizes
New labels are created using a system default font size. You can’t change this default, but you can modify 
the font sizes of labels after they are created.

Procedure
1. Select the labels you want to change, right-click and click Properties.

Restriction:
All the labels selected must be of the same type; for example, all net name labels or all 
reference designator labels.

2. In the Properties dialog box, enter the new Size value.

Tip
Type a stroke font size between 10 and 1000 mils or a system font size between 1 and 72 
points.

3. Click OK.
Table  32. Related Topics

Attribute Properties Dialog Box Part Type Label Properties Dialog Box

Bus Name Properties Dialog Box Pin Label Fonts Dialog Box

Net Name Properties Dialog Box Reference Designator Properties Dialog Box
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Modifying Text
Use the Text Properties dialog box to modify free text or change its size, orientation or justification.

Procedure
1. Select text, right-click and click Properties.

2. In the Text Properties dialog box, the Text box displays the selected text string. Modify the existing 
text string, or type a new text string.

3. In the X,Y location boxes, type new values to move the text string to a specified location.

If you need to move text outside the sheet, you must move the text with the cursor instead.

4. In the Rotation box, select the degree of rotation from the Rotation list.

Rotation can be 0 or 90 degrees.

5. For stroke font, in the Line Width box, type the line width.

6. In the Size box, type the size  (in mils for stroke font, in points for system fonts).

Tip
Type a stroke font size between 10 and 1000 mils or a system font size between 1 and 72 
points.

7. For system fonts, select the font you want to use.

You can also click a font style: B  for bold, I  for Italic, or U  for Underlined.

8. In the Justification area, set the horizontal and vertical justification of the text.

9. If you combined the selected text string with a drafting object, click Parent  to display the Drafting 
Objects Properties dialog box to modify the drafting object.

10. Click OK.

Related Topics
Modifying Drafting Objects

Combining 2D Lines and Text

Modifying Hierarchical Components
When created and added to an existing sheet, hierarchical components cannot be accessed through 
the Sheet list in the toolbar unless the parent sheet is displayed. They are also excluded from the 
Sheet command in the Setup  menu. Use the Hierarchical Component Properties dialog box to assign a 
hierarchical component to the next available sheet number to make it accessible from the Sheet list when 
a sheet other than the parent sheet is displayed.

Use the Sheets command under the Setup  menu to modify the sheet name or the numeric order.

296 SailWind Logic Guide



 
Schematic Object Modification

Modifying Hierarchical Components

Procedure
1. Select a hierarchical component, right-click and click Properties.

2. In the Query Hierarchical Component dialog box, type a new name in the Name box to rename the 
hierarchical component.

3. Select the Visibility check box to the right of the Name box to display the name on top of the 
hierarchical component in the schematic.

4. Click Numbered to assign the hierarchical component the next available sheet number.

The assigned sheet number is displayed in the field above this option.

5. Click Un-numbered to remove a sheet number assignment from a hierarchical component.

6. In the Associated Sheet area, select the Visibility check box to display the sheet number in the 
schematic.

7. ClickOK.
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Chapter 16
Rules

As your design complexity increases, you can use design rules to control the interaction of various design 
objects with one another. Use design rules to specify clearances between design objects such as pads, 
coppers and traces. You can also specify design rules for nets, groups of nets, classes, and differential 
pairs. Use the Rules Report to review your settings. You can also import and export rules between your 
schematics and your PCB designs.

Rules Setup
Setting Up Clearance Rules
Same Net Matrix
Routing Rules
Setting Up High-Speed Rules
Setting Up Rules
Rules Hierarchy
Setting Up Default Rules
Setting Up Class Rules
Setting Up Net Rules
Setting Up Conditional Rules
Creating Differential Pairs
Differential Pair Layer Hierarchy
Creating a Rules Report
Import Rules from PCB
Export Rules to PCB

Rules Setup
Design Rules enable you to assign general routing constraints for your design, such as trace width and 
spacing. An option in the netlist lets you pass established design rules along with the connectivity and 
parts information to SailWind Layout.

To access and examine the Design Rules setup, click the Setup  > Design Rules  menu item.

Rule Categories
Design rules are separated into three categories:

• Setting Up Clearance Rules  — Specifies minimum allowable airgap between various object types 
in the design; trace to trace, via to trace, etc.

• Routing Rules  — Assigns or prohibits via types, specifies length minimization types, or allows or 
prohibits routing.

• Setting Up High-Speed Rules  — Specifies minimum and maximum parameters for advanced 
design rules such as parallelism, delay, capacitance, and others.
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Information for each category is entered and edited in a separate dialog box that you can access through 
the Design Rules command from the Setup  menu.

Setting Up Clearance Rules
Use the Clearance Rules dialog box to define the spacing permitted between objects. When objects are 
imported, the On-line DRC and Verify Design programs use these rules to check and report clearance 
violations.

Tip
You can use the Setting Up Conditional Rules  dialog box to save a clearance configuration as a 
set, to apply to a selected item only when it comes in contact with different level of the hierarchical 
order  on page 305.

Procedure
1. Click the Setup  > Design Rules  menu item, click a rule hierarchy, then click the Clearance  button.

2. In the Same Net area, define edge-to-edge clearance values between items that are in the same 
net:

• To define the minimum spacing between any two objects, type the value in the appropriate text 
box.

• To define the same spacing value for all text boxes in one matrix column, press the button 
above the column and type a value.

• To define the same spacing value for all text boxes in one matrix row, press the button in the left 
column and type a value.

• To define the same spacing value for all text boxes in the matrix, press the All  button and type a 
value.

Table  33. Clearance Rules - Same Net - Edge-to-Edge Clearance Options

Clearance Description

SMD to Via Minimum spacing between a surface mount pad and escape via.

SMD to Corner Minimum spacing between a surface mount pad and the first trace 
bend point.

Via to Via Minimum spacing between two vias in the same net.

Pad to Corner Minimum spacing between a through hole pad and the first trace bend 
point.

Trace to Corner Minimum spacing between a trace and the bend point of another trace; 
for example, when a trace splits at a T-junction and one of the two 
traces has a bend point.
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3. In the Trace Width area, type values in the text boxes to restrict the trace width to a range of 
values:

• In the Recommended box, type the width you want to assign to the trace when routing begins.

• In the Minimum and Maximum boxes, values are respected by routing routines that must use 
trace width to achieve some high-speed routing functions, such as impedance matching.

4. In the Clearance area, use the Clearance matrix to define edge-to-edge clearances between two 
object types:

• To define the minimum spacing between any two objects, type the value in the appropriate text 
box.

• To define the same spacing value for all text boxes in one matrix column, press the button 
above the column and type a value.

• To define the same spacing value for all text boxes in one matrix row, press the button in the left 
column and type a value.

• To define the same spacing value for all text boxes in the matrix, press the All  button and type a 
value.

5. In the Other area, optionally set other clearance values, which include:
Table  34. Clearance Rules - Other - Clearance Options

Clearance Description

Drill to Drill The minimum edge-to-edge spacing between two drill holes.

Body to Body The minimum edge-to-edge spacing between two component 
bodies.

6. Click OK, or optionally click Delete to remove this set of Clearance rules from your rules hierarchy.

Tip
You cannot delete the Default Clearance rules.

Same Net Matrix
Use the Same Net Matrix to define edge-to-edge clearance values between items that are in the same 
net.

• To define the minimum spacing between any two objects, type the value in the appropriate text 
box.

• To define the same spacing value for all text boxes in one matrix column, press the button above 
the column. Type a value and click OK.
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• To define the same spacing value for all text boxes in one matrix row, press the button in the left 
column. Type a value and click OK.

• To define the same spacing value for all text boxes in the matrix, press the All  button. Type a 
value and click OK.

Table  35. Same Net Matrix - Clearance Options

Clearance Description

SMD to Via Minimum spacing between a surface mount pad and escape via.

SMD to Corner Minimum spacing between a surface mount pad and the first trace bend 
point.

Via to Via Minimum spacing between two vias in the same net.

Pad to Corner Minimum spacing between a through hole pad and the first trace bend 
point.

Trace to Corner Minimum spacing between a trace and the bend point of another trace; for 
example, when a trace splits at a T-junction and one of the two traces has 
a bend point.

Routing Rules
Use the Routing Rules dialog box to specify rules for interactive and automatic routing. You can specify 
the default set of routing rules and routing rules for specific nets.

Setting Up High-Speed Rules
Use the Hi Speed Rules dialog box to define rules for Parallelism, Tandem, Shielding, Routed Length, 
Stub Length, Delay, Capacitance, Impedance, and Matched Length.

Tip
When working with high-speed rules, observe the following:
• When imported into SailWind, the EDC (Electrodynamic Checking) routine checks to see if 

rules are met correctly after routing (except shielding and matched length).
• You can use the Setting Up Conditional Rules  dialog box to save a high speed configuration 

as a set, or to apply for a selected item only when it comes in contact with different level of the 
hierarchical order  on page 305.

Procedure
1. Click the Setup  > Design Rules  menu item, click a rule level, then click the Hi Speed  button.

2. In the Parallelism area, type a value for length and gap in the parallelism boxes to restrict the 
distance that traces in different nets on the same layer can run together.
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3. Type a value for length and gap in the tandem boxes to restrict the distance that traces in different 
nets on different layers can run together.

Table  36. High-Speed Rule Options

Option Description

Parallelism Restricts the distance that traces in different nets on the same layer 
can run together.

Tandem Restricts the distance that traces in different nets on different layers 
can run together.

Tip
When configuring High-Speed Rule Options, observe these guidelines:
• These values determine the distance and standoff against the specific item and 

everything else in the design. To set a narrower check, use Setting Up Conditional Rules 
to define specific Source and Against items.

• Length defines the maximum allowable parallel/tandem distance.
• Gap defines the minimum gap between traces below which the parallel/tandem rules 

apply.

4. Click Aggressor to specify if a net is an aggressor, or source of interference, during parallel/tandem 
checks.

5. In the Rules area, type minimum and maximum values for:
Table  37. High-Speed Rules - Minimum/Maximum Values

Rule Description

Length Defines a minimum and maximum length.

Stub Length Specifies a maximum stub length. The stub length is the distance from a 
T-point to the end of the route.

Delay Defines a minimum and maximum delay time in nanoseconds.

Capacitance Defines a minimum and maximum capacitance in picofarads.

Impedance Defines a minimum and maximum impedance in ohms.

Tip
These text boxes restrict the trace width to a range of values. Recommended is the width 
you want to assign to the trace when routing begins. The Minimum and Maximum values 
are respected by routing routines which must use trace width to achieve some high-speed 
routing functions, such as impedance matching.

6. Some routers can arrange certain nets as shielding others if requested; the Net in the Use Net list 
box is routed up and down both sides of a selected net to provide protection from interference. In 
the Shielding area, click Shield  to invoke the shielding rules.
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Tip
When working with shielding, observe the following guidelines:
• You can only assign nets associated with plane layers in the Layer Definition dialog box 

to shield other nets. If there are no plane layers, the Shield area is grayed out.
• If your router supports shielding, you can specify the shield gap value and net to use as 

the shield in the Gap and Use Net text boxes.

7. (Optional) In the Matching area, select the Match Length check box to invoke the matching rule, 
and type a tolerance value.

Tip
When working with Length Matching, observe the following:
• Length Matching is a same length requirement parameter you can pass on to 

autorouters that support it.
• This rule specifies the maximum difference allowed between the shortest length and 

longest length in the matched length group.

8. Click OK, or click Delete to remove this set of High Speed rules from your rules hierarchy.

Tip
You cannot delete the Default High Speed rules.

Setting Up Rules
Use the Rules dialog box to enter item-to-item Clearance rules, routing guidelines, and values for the 
optional High Speed checking commands. You can also indicate the unit of measure for passing rules to 
SailWind Logic: mils, metric, or inches.

Procedure
1. Click the Setup  > Design Rules  menu item.

2. In the Units list box, select Mils, Metric, or Inches.

3. Select the rules hierarchy level for which you want to set or modify rules.

Tip
When you specify one of the hierarchical levels, you can access the Clearance, Routing, or 
High Speed forms.

4. Click the appropriate button to define rules for a particular level in the hierarchy.

5. (Optional) Click the Report  button to access the Rules Report dialog box where you can select a 
default report of a report for some or all of the rules you have defined.
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Rules Hierarchy
In the rules hierarchy, certain rules have precedence over other rules. For example, a net rule overrides a 
class rule, and a class rule overrides a default rule.

Table  38. Rule Hierarchy and Order of Precedence

Rules Precedence Description

Setting Up 
Default Rules

Least Rules that apply to an object if there are no other individually 
defined rules.

Setting Up 
Class Rules

Rules for a collection of nets, called a class, which needs 
identical rules.

Setting Up Net 
Rules

Highest Rules for a specific net.

Rules Hierarchy Order of Precedence
The complete order of precedence for all rules follows, from least to most specific. Default, 1, represents 
the lowest level of the hierarchy with the least amount of precedence. At the opposite end of the order 
is Net against Net with Level, which is the highest level of the hierarchy and has the highest possible 
precedence. It represents the most specific rule you can assign to an object in SailWind Logic.

1. Default

2. Default with Level

3. Class

4. Class with Level

5. Net

6. Net with Level

7. Class against Class

8. Class against Class with Level

9. Net against Class

10. Net against Class with Level

11. Net against Net

12. Net against Net with Level
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See also Setting Up Default Rules, Setting Up Class Rules, Setting Up Net Rules, Creating a Rules 
Report.

Setting Up Default Rules
Use the Default Rules dialog box to define rules which apply to all objects that are not included in any 
other rule definitions within the hierarchy.

Procedure
1. Click the Setup  > Design Rules  menu item, then click the Default  button.

2. To define default Clearance  on page 300, Routing  on page 302, or High Speed  on page 302
rules, click the appropriate button.

3. Click the Report  on page 310 button to produce a rules report.

Setting Up Class Rules
Use the Class Rules dialog box to define rules that apply to a collection of nets known as a net class and 
to multiple net classes.

Procedure
1. Click the Setup  > Design Rules  menu item, then click the Class  button.

2. In the Class Name list box, select a class name, or specify a new name for which you want to 
apply rules.

Tip
The Class list box defines net classes by name and parenthetically notes the rules that 
apply, if any, to the class.

3. In the Nets area, add or remove selected nets from the net class as follows:

• Select a class in the list box to display nets in the Available and Selected list boxes, or click the 
Add  button to create a new class.

• To assign nets to a class, select the net(s) in the Available list box and click Add.

Tip
A net can only belong to one net class. The Available list box only contains nets that do 
not belong to a net class.

4. To delete nets from the class, select the net(s) in the Selected list box and click Remove.

5. (Optional) Select a class name and click Rename  to change the class name for the selected class.

6. (Optional) Select the Show Classes with Rules check box to list only classes with at least one set 
of rule definitions.
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7. For each class, click the appropriate button to define Clearance, Routing, or High Speed rules for a 
net class.

Tip
When you select a class name, an icon appears below each rule type to indicate the 
hierarchy level where the rule is defined for that class. For example, a class with only 
Clearance rules defined would have a Class  icon below the Clearance  icon and Default 
icons below the Routing  and High Speed  icons.

8. In the corresponding Rules dialog box that displays, supply values for the rules you want to apply, 
and click OK  to return to the Class Rules dialog box.

9. When you have finished defining all class rules, click OK.

Setting Up Net Rules
Use the Net Rules dialog box to define rules that apply to a single net or multiple nets.

Procedure
1. Click the Setup  > Design Rules  menu item, the click the Net  button.

2. Select the net(s) for which you want to define Clearance  on page 300, Routing  on page 302, 
and High Speed  on page 302 rules.

Tip
When you select a net name, an icon appears below each rule type to indicate the 
hierarchy level where the rule is defined for that net. For example, a net with both 
Clearance and High Speed rules defined would have Net  icons below the Clearance  and 
Hi Speed  icons and a Default  icon below the Routing icon.

3. (Optional) Select the Show Nets with Rules check box to list only those nets with at least one set of 
rule definitions.

4. (Optional) Click the Report  button to view a rules report.

5. Click the Default  button to restore the net rules back to the default rules.

Setting Up Conditional Rules
Use the Conditional Rule Setup dialog box to apply a third overriding set of rules that apply only when the 
item meets other specific levels of the hierarchical order.

Once you set up Clearance rules for a group in the hierarchical order  on page 305, the rules are applied 
to all other objects.
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Tip
When working with conditional rules, use the following guidelines:
• You can use a layer as an against object, where rules you set for an object such as a net apply 

only when the net is routed on that layer.
• You can further refine this to use another net as an against object and specify a layer to which 

the rules to apply. If these two nets meet on this layer, they must adhere to this clearance. You 
define these relationships by making conditional rule sets.

Procedure
1. Click the Setup  > Design Rules  menu item, then click the Conditional Rules  button.

2. In the Source Rule Object area, select Classes, Nets, or All to specify both classes and nets. Then 
specify the object(s) against which the rule is checked.

3. In the Against Rule Object area, select Classes, Nets, or Layer, and then specify the object(s) 
against which the rule is checked.

Tip
Select Layer to use a layer as an against object or to apply an item-to-item rule on a 
specific layer.

4. (Optional) In the Define Conditional Objects area, in the Apply to Layer area, select a layer on 
which you want rules checked.

5. In the Existing Rule Sets list box, select the rule set to define the appropriate values for specific 
Clearance or High Speed definition of the selected rule set.

6. After you create a rule set, in the Current Rule Set area, define the Clearance or High Speed 
values.

7. Select Clearance to enter the minimum clearance gap you want the source and against items to 
maintain from each other, and then click Matrix  to enter more item-specific standoffs.

8. Select High Speed to enter clearance values for parallel and tandem checking  on page 302
for the condition. The source-against entries are used as the victim-aggressor designations for 
crosstalk conditions checking.

9. Click Create to compile the new rule set parameters and adds a description to the Existing Rule 
Sets list box, or click Delete  to removes the selected rule set from the Existing Rule Sets list box.

Related Topics
Setting Up Clearance Rules

Setting Up High-Speed Rules

Creating Differential Pairs
Identify nets or pin pairs that behave electrically as differential pairs and define rules for them. You can 
set different properties for differential pairs, which affects how they are routed. Differential pair properties 
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Creating Differential Pairs
determine the gap between the traces in the Controlled Gap Area, the minimum and maximum trace 
lengths, and how to respond to Obstacles in the controlled gap area.

Restrictions and Limitations
While you can define these rules in SailWind Logic, they are used only in SailWind Router.

Procedure
1. Click the Setup  > Design Rules  menu item, the click the Differential Pairs  button.

2. In the Available list, double-click the first net, and then double-click the second net.

Tip
Nets cannot exist in more than one differential pair. The Available list displays only nets 
that have not been assigned to a differential pair.

3. Click Add.

4. Type minimum trace length value in the Minimum box.

5. Type the maximum trace length value in the Maximum box.

6. In the Properties of the pair area, type Width and Gap values in the <All layers> row.

Restriction:
You cannot delete the <All layers> row.

7. To set the width and gap per layer, click Add, click in the Layer cell in the newly added row, and 
select the layer for which to set width and gap values. Then type Width and Gap values in the 
appropriate cells.

Note:
When working with differential pairs, observe the following guidelines:
• Setting the differential pair width and gap per layer enables you to better control 

impedance.
• The gap rule cancels any other rule defining a clearance between the differential pairs. 

Therefore, the gap is the minimal clearance and must be provided when possible.
• If you select multiple differential pairs, and a layer setting doesn't belong to all of the 

selected pairs, the Layer column will be unavailable.
• If you select multiple differential pairs that have the same layer setting, but the Width and 

Gap values do not match, the Width and Gap cells will appear empty. You can, however, 
type a new value, and the new will be applied to all selected differential pairs when you 
click OK  or Apply.

See also Differential Pair Layer Hierarchy.

8. Click Restrict layer changes during autorouting to force the pair to be routed on a single layer.

This setting does not restrict layer changes when routing interactively.

9. Click Allow pair to split around obstacles to allow routing around an obstacle in the controlled gap 
area by temporarily exceeding the pair routing gap.
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This setting applies to autorouting and does not restrict splitting around obstacles when routing 
interactively.

10. Type the maximum number of obstacles to route around in the Maximum number of obstacles box.

Tip
Obstacles in the start zone  or end zone  are not counted.

11. Type the maximum spacing allowed between traces around obstacles in the Maximum obstacle 
size box.

The size applies to the obstacle's longest horizontal or vertical dimension.

Tip
Obstacle size in the start zone or end zone is not checked.

12. Click OK.

Differential Pair Layer Hierarchy
You can assign differential pair width and gap values to layers and categories of layers; however, a layer 
may also fall into one or more categories. For example, Layer 2 may also be a plane layer, and an outer 
layer.

Therefore, the following hierarchy is followed to define which layer settings take priority:

1. All Layers

2. Plane Layers

3. Outer Layers

4. Inner Layers

5. Individual Layers

Tip
Individual Layers has highest priority.

Creating a Rules Report
Use the Rules Report dialog box to produce a report of some or all of the rules you have defined. By 
default, a complete report of all rules is reported.

310 SailWind Logic Guide



 
Rules

Import Rules from PCB

Procedure
Click the Setup  > Design Rules  menu item, the click the Report  button. You can produce reports for the 
following:

Table  39. Rules Report Types

Report Type Description

Rule types Displays the specified rules for the specified nets and classes. Click 
any combination of buttons, including Differential Pairs, to report net 
pairs.

Nets Displays the specified rules for every net or selected nets. Click All 
Nets or select specific nets in the list box.

Classes Displays the specified rules for every class or selected classes. Click 
All Classes or select specific net classes in the list box.

Output Click Rule Sets to display all rules in the current hierarchy that are 
unique from the default rules.
Click Rule Values to display all rules in the current hierarchy level, 
even if the values are the same as the default rules.

Default Rules Displays the default rules for the specified nets and classes.

Import Rules from PCB
Use the Design  Tab of SailWind Layout Link to read design rules from a specified SailWind ASCII file, 
including layer setups and layer counts, etc.

Procedure
1. Click the Tools  > SailWind Layout  menu item.

2. Click the Design  tab.

3. On the Design  tab, select the Compare Design Rules check box.

4. Click ECO from PCB.

The netlist in the current SailWind Logic schematic is compared to the part and netlist in the 
current SailWind Layout design and the schematic is updated.

Export Rules to PCB
Use the Design  Tab of SailWind Layout Link to export design rules to a specified SailWind ASCII file, 
including layer setups and layer counts, etc.

Procedure
1. Click the Tools  > SailWind Layout  menu item.

2. Click the Design  tab.
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3. On the Design  tab, select the Compare Design Rules check box.

4. Click ECO to PCB.

The netlist in the current SailWind Logic schematic is compared to the part and netlist in the 
current SailWind Layout design and the layout design is updated.
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Chapter 17
Reports

You can generate reports to view and analyze data related to your design. Available reports include 
unused pins, parts statistics, net statistics, limits, connectivity, and a bill of materials. Use these reports to 
examine and interpret your design status at any point in the design cycle.

Generating Reports
The Bill of Materials Report

Generating Reports
Use the Reports dialog box to produce any of six different types of reports on the current schematic. You 
can save these reports as text files on your hard disk or output them to a printer.

Procedure
1. Click the File  > Reports  menu item.

2. In the Reports Dialog Box, select each report you want to generate.

3. To specify or modify the report characteristics of the Bill of Materials report, click Setup.

See also The Bill of Materials Report.

4. Click OK.

The reports are generated and the dialog box closes.
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The Bill of Materials Report
The Bill of Materials report produces a user-configurable list of the parts contained in the current 
schematic. You can direct any part attribute in the schematic to a Bill of Materials report.

In the Bill of Materials Setup dialog box  on page 479 are three different tabs for controlling report 
characteristics from which to choose:

Setting Up the Bill of Materials Attributes
Setting Up the Bill of Materials Format
Setting Up the Bill of Materials Configuration

Setting Up the Bill of Materials Attributes
Use the Attributes  tab to modify the Attribute content, the corresponding column headings, and column 
width of the report.

The attribute order in the content list determines the column arrangement in the BOM report. There is a 
limit of 12 attributes in the Bill of Materials report.

Restrictions and Limitations
Including non-ECO-registered parts and non-electrical parts in the bill of materials is constrained. See 
Options Dialog Box, Design Category  for details.

Procedure
1. Click the File  > Reports  menu item.

2. In the Reports Dialog Box  select the Bill of Materials check box and then click Setup  to specify or 
modify the Bill of Materials report characteristics.

3. In the Bill of Materials Setup dialog box  on page 479, click the Attributes  tab.

4. To add a new attribute to the list, click Add  and select an attribute from the list in the Part Attribute 
column,

Tip
You can list up to twelve attribute names. Each attribute defines a column in the BOM 
report.

5. In the Field Header column, specify the column heading for each attribute in the report. You can 
specify any character except the colon ( : ).

6. In the Width column, type an integer between 1 and 200 that represents the number of characters 
across the column for each attribute in the report.

Tip
SailWind Logic reserves a space to separate columns. Therefore, the actual column width 
is one character less than the specified number.
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Setting Up the Bill of Materials Format

7. To move an attribute up a row, select the attribute to move and click Up.

8. To move an attribute down a row, select the attribute to move and click Down.

9. To edit an attribute, select the box to edit and click Edit.

Restriction:
You cannot edit the part attribute name, but you can select a new attribute to replace the 
one currently listed.

10. To remove an attribute from the report, select the row and click Remove.

11. To restore the default content from the .ini  file, click Reset.

12. Click OK.

Setting Up the Bill of Materials Format
Use the Format  tab to modify the output format of the Bill of Material report. This enables you to specify 
which fields to display and how the information will be displayed in the generated report.

The default settings originate from the .ini file.

Restrictions and Limitations
Including non-ECO-registered parts and non-electrical parts in the bill of materials is constrained. See 
Options Dialog Box, Design Category  for details.

Procedure
1. Click the File  > Reports  menu item.

2. In the Reports Dialog Box  select the Bill of Materials check box and then click Setup  to specify or 
modify the Bill of Materials report characteristics.

3. In the Bill of Materials Setup dialog box  on page 483, click the Format  tab.

4. Select the type of delimiter you want to distinguish the report columns.

• Separator  — places a vertical bar between report fields

• Tab  — separates columns with a tab spacing

• Comma  — places a comma character between report fields

• Custom  — specify any character as a delimiter

5. Type a report title in the Report Title box.

Tip
The variable %j is replaced by the filename and %d is replaced by the date.
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6. Select the Combine Value/Tolerance check box to combine the Value and Tolerance attributes of a 
part in the part name.

For example, the 1/4 watt resistor would have a part type name of R1/4W or R1/4W.4.7K,+/-5%. 
SailWind Logic evaluates parts that have either a different Value or Tolerance attribute as different 
part types.

7. In the Ref. Designator Separation Mode settings choose between giving each component a 
single line (Single Ref. Designator per line) or displaying the reference designators of identical 
components on one line (Multiple Ref. Designators per line).

If you choose multiple reference designators per line, you can also specify to compress ranges of 
reference designators and the delimiter between them.

8. Select an attribute in which to sort the report list in the Sort By list.

Tip
Select None to sort by Part Type.

9. Select the output file format from the File Format list.

10. To save report format settings for the current design to a specified file so you can create different 
format configurations for different designs, click Save As  and type a filename the Save Scheme 
dialog box.

SailWind Logic saves BOM format settings files in the \Settings  folder with a .bom  extension.

Tip
Click Delete  to remove the selected setting file from the list.

11. To restore the default content from the .ini  file, click Reset.

12. Click OK.

Setting Up the Bill of Materials Configuration
Use the BOM Config  tab to preview the Bill of Materials report format and copy any selected lines of the 
file to a Windows clipboard. You can also export the BOM report to a TXT/CSV file.

The default view orders the attributes by the sort field you specified on the Format  tab.

Restrictions and Limitations
Including non-ECO-registered parts and non-electrical parts in the bill of materials is constrained. See 
Options Dialog Box, Design Category  for details.

Procedure
1. Click the File  > Reports  menu item.

2. In the Reports Dialog Box  select the Bill of Materials check box and then click Setup  to specify or 
modify the Bill of Materials report characteristics.

3. In the Bill of Materials Setup dialog box, click the BOM Config  tab.
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Setting Up the Bill of Materials Configuration

4. To sort rows by an attribute other than the one you set on the Format  tab, click the heading area of 
the attribute you want to sort.

To sort the same column in reverse order, click again.

5. Copy any selected lines of the file to a Windows clipboard:

a. To include the column header information in the report, select the Include table header check 
box.

b. Select the rows you want to copy to the clipboard and click Copy.

Tip
Click Select All  to select the entire table.

6. Export to a TXT/CSV file.

a. To exclude any row in the report, select the NC checkbox.

b. Click Export, and choose the file type in the popup dialog box.

7. Click OK.
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Chapter 18
Working With SailWind Layout and SailWind 

Router
Using SailWind Logic, you can seamlessly exchange design data with SailWind Layoutand SailWind 
Router. This is a bi-directional process that enables you to forward annotate and back annotate your data 
to keep your design changes synchronized. You can also generate a differences report so that you can 
compare one design with another and highlight any differences.

Creation of a New PCB Layout from a SailWind Logic Design
Cross-Probe Between Sailwind Products
Forward Annotation From SailWind Logic to SailWind Layout
Backward Annotation From SailWind Layout to SailWind Logic
Backward Annotation Results
Contents of the Differences Report
ECO File Format
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Creation of a New PCB Layout from a SailWind 
Logic Design
There are two ways to create a new PCB design from a SailWind Logic design: you can use the SailWind 
Layout Link, or you can manually exchange a netlist between SailWind Logic and SailWind Layout.

• Method 1  — Use if you have both SailWind Logic and SailWind Layout on your computer, use 
the “Automatic Netlist Process Using the SailWind Layout Link”. This automated method is the 
simplest.

• Method 2  — Use if you don’t have both SailWind Logic and SailWind Layout on your computer, 
use the “Manual Netlist Process Between SailWind Logic and SailWind Layout”. This manual 
method requires you to manually export the netlist from SailWind Logic and then import it into 
SailWind Layout.

Automatic Netlist Process Using the SailWind Layout Link
Manual Netlist Process Between SailWind Logic and SailWind Layout
Interpreting and Resolving the Netlist Process Error Report

Automatic Netlist Process Using the SailWind 
Layout Link
If you have both SailWind Logic and SailWind Layout on your computer, you can automatically process a 
SailWind Logic netlist using the SailWind Layout Link. This automated method is the simplest.

Restrictions and Limitations

• Forward annotation of changes to an existing  design requires a different process. See Forward 
Annotation From SailWind Logic to SailWind Layout.

• Transferring non-ECO-registered parts and non-electrical parts is constrained by settings in the 
Options. See the Design Options  on page 591 for details.

Prerequisites
You must have both SailWind Logic and SailWind Layout on the same computer.

Procedure
1. Click the Tools  > SailWind Layout  menu item.

Tip
If SailWind Layout is not already open, the Connect to SailWind Layout Dialog Box 
appears. Click New  to start a new SailWind Layout session.

2. In the SailWind Layout Link dialog box, click the Preferences Tab  on page 620, then set the 
appropriate options.
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Manual Netlist Process Between SailWind Logic and SailWind Layout

3. On the Design Tab:  on page 614

a. If needed, select the Include Design Rules in Net list or the AI layout reference data  check 
box.

Tip
The AI layout reference data  item must be selected in order for the AI Intelligent 
Layout  feature to work in SailWind Layout.

b. Click the Send Net List  button.

Results
The import process sources all the part types and decals from the library and stacks the decals at the 
origin. You can then use the SailWind Layout Tools  > Disperse Components  menu item to spread out 
the components.

If an errors report file (ascii.err) is generated and errors are found in the netlist, see Interpreting and 
Resolving the Netlist Process Error Report  for more information.

Manual Netlist Process Between SailWind Logic 
and SailWind Layout
If you don’t have both SailWind Logic and SailWind Layout on your computer, you can manually process 
the netlist. This manual method requires you to manually export the netlist from SailWind Logic and then 
import it into SailWind Layout.

Restrictions and Limitations

• Forward annotation of changes to an existing design requires a different process. See Forward 
Annotation From SailWind Logic to SailWind Layout.

• Transferring non-ECO-registered parts and non-electrical parts is constrained by settings in the 
Options. See the Design Options  on page 591 for details.

Procedure
1. Click the Tools  > Layout Netlist  menu item.

2. To select a different filename or location for the netlist, in the Netlist to PCB dialog box, click 
Browse.

Tip
The default is the design filename with an .asc  extension, and is saved in the \SailWind 
Projects  folder.

3. In the Select Sheets area, select the sheets you want to include in the netlist.

4. Select the Include Subsheets check box to include any connections to hierarchical symbols in the 
netlist.
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5. Select the format you want from the Output Formats list.

6. Set the remaining dialog box options.

7. Click OK  to generate the netlist.

8. Import the netlist into SailWind Layout. For instructions, see the Creating a New PCB Design by 
Manually Importing the SailWind Logic Netlist  topic in the SailWind Layout Guide.

Results
The import process sources all the part types and decals from the library and stacks the decals at the 
origin. You can then use the Tools  > Disperse Components  menu item to spread out the components.

If an errors report file (ascii.err) is generated and errors are found in the netlist, see Interpreting and 
Resolving the Netlist Process Error Report  for more information.

Interpreting and Resolving the Netlist Process 
Error Report
If errors are found in the netlist import process, an errors report file (ascii.err) is generated, and the error 
report file is displayed in a Notepad window. No errors file is generated if no errors are found.

The following are reported in the errors report file:

• Library issues

• Single or zero pin nets

• Totally floating connections or subnets

• Unnamed dangling connections (one end floating)

• Power and Ground symbols used on nets whose name is different from the default name on the 
symbol

• Multiple subnet nets where one or more subnets is missing an off-page symbol

• Single subnet nets with an off-page symbol (lonely subnet warning)

• User named subnets that have no visible net name label

Procedure
1. In SailWind Layout, click the File  > New  menu item.

2. Click No  when you are prompted to save the design.

3. Add any missing components listed in the ascii.err  file to your library, either by adding a library 
which contains the missing components to your library list, or by creating the missing part types 
and decals. (See Adding Libraries to the Library List, Creating and Modifying Part Types, and 
Creating and Editing PCB Decals  in the SailWind Layout Guide  for instructions.)
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Interpreting and Resolving the Netlist Process Error Report

4. Resolve any other errors found in the ascii.err  file.

5. When all the errors have been resolved, repeat the procedure you used to pass the netlist from 
SailWind Logic to SailWind Layout.

Related Topics
Creation of a New PCB Layout from a SailWind Logic Design
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Cross-Probe Between Sailwind Products
You can cross-probe between SailWind Logic and SailWind Layout, or between SailWind Logic and 
SailWind Router, if the applications are on the same computer. You can cross-probe between only two 
applications at a time. In SailWind Logic, you can initiate cross-probing whether or not SailWind Layout or 
SailWind Router are open.

Through cross-probing, you can select items in both the schematic and design at the same time. For 
example, if you select objects in SailWind Layout (or SailWind Router), the object is automatically 
highlighted and centered in the SailWind Logic work area. For SailWind Logic and SailWind Layout only, 
cross-probing can also automate netlist comparisons and rules exports.

Cross-Probing With SailWind Layout
Cross-Probing With SailWind Router

Cross-Probing With SailWind Layout
Cross-probe with SailWind Layout to make simultaneous selections in both applications. Selecting an 
object in one of the programs will automatically select the same object in the other program.

Restrictions and Limitations

• The SailWind Logic selection filter  on page 712 should be set to parts, gates, nets, or pins 
before you select items in SailWind Logic.

• Some parts may not exist in both of the databases. Non-ECO-registered parts and non-electrical 
parts may have been constrained. See Options Dialog Box, Design Category  for details.

Procedure
1. Click the Tools  > SailWind Layout  menu item.

If SailWind Layout is not open, the Connect to SailWind Layout Dialog Box  appears. Do one of the 
following:

• Click New  to start a new SailWind Layout session with a new, untitled, design.

• Click Open  to start a new SailWind Layout session with an existing design. In the File Open 
dialog box, select a design file and click Open.

2. In the SailWind Layout Link Dialog Box, on the Selection  tab, select the Receive Selections check 
box to enable selections in SailWind Layout to be received in SailWind Logic.

You can now proceed with cross-probing with SailWind Layout.

Cross-Probing With SailWind Router
Cross-probe with SailWind Router to actively make simultaneous selections in both applications. 
Selecting an object in one of the programs will automatically select the same object in the other program.
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Cross-Probing With SailWind Router

Restrictions and Limitations

• The SailWind Logic selection filter  on page 712 should be set to parts, gates, nets, or pins 
before you select items in SailWind Logic.

• Some parts may not exist in both of the databases. Non-ECO-registered parts and non-electrical 
parts may have been constrained. See Options Dialog Box, Design Category  for details.

Procedure
1. Click the Tools  > SailWind Router  menu item.

If SailWind Router is not open, the Connect to SailWind Router Dialog Box  appears. Do one of the 
following:

• Click New  to start a new SailWind Router session with a new, untitled, design.

• Click Open  to start a new SailWind Router session with an existing design. In the File Open 
dialog box, select a design file and click Open.

2. On the SailWind Router Link Dialog Box, on the Selection  tab, select the Receive Selections 
check box to enable selections in SailWind Router to be received in SailWind Logic.

You can now proceed with cross-probing with SailWind Router.
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Forward Annotation From SailWind Logic to 
SailWind Layout
You can export your schematic changes “forward” (known as forward annotation) to an existing PCB 
layout. You can choose between any of the three methods to forward annotate design changes.

• Method 1  — If you have both SailWind Logic and SailWind Layout on your computer, use the 
“Automated Forward Annotation Process”. This automated method is the simplest and fastest.

• Method 2  — If SailWind Layout is on another computer and you want the layout designer to 
compare the designs to generate the ECO file, and import it into SailWind Layout use the process 
in “Generating the ECO File in SailWind Layout”. This method is somewhat quicker than Method 
3 since the Compare/ECO tool in SailWind Layout can automatically import the file after the 
designs are compared.

• Method 3  — If SailWind Layout is on another computer and you want to compare the designs 
to generate the ECO file within SailWind Logic and send it to the layout designer to import into 
SailWind Layout, use the process in “Generating the ECO File in SailWind Logic”.

Automated Forward Annotation Process
Generating the ECO File in SailWind Layout
Generating the ECO File in SailWind Logic
Forward Annotation Results

Automated Forward Annotation Process
If SailWind Logic and SailWind Layout are on the same computer, you can use the SailWind Layout Link 
dialog box to compare a newer schematic with an older PCB design and update the original design in 
Layout from the new design in Logic. You can also create a differences report.

Restrictions and Limitations

• If you are creating a new PCB by sending a netlist for the first time, see Creation of a New PCB 
Layout from a SailWind Logic Design.

• To avoid unexpected changes during forward annotation, consider comparing data before you 
forward-annotate.

• Transferring non-ECO-registered parts and non-electrical parts is constrained. See the override 
settings in the Options dialog box, Design Category  on page 591 for details.

• You cannot forward annotate changes to SailWind Router. SailWind Router does not import ECO 
files.

• During design comparison, a reuse definition is ignored and actual elements in the physical 
design reuse are used in the comparison.
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Generating the ECO File in SailWind Layout

Prerequisites
You must have both SailWind Logic and SailWind Layout on the same computer.

Procedure
1. Click the Tools  > SailWind Layout  menu item to open the SailWind Layout Link dialog box.

Tip
If SailWind Layout is not already open, the Connect to SailWind Layout Dialog Box 
appears. Click Open  to start a new SailWind Layout session with the original design. In the 
File Open dialog box, select the original design file and click Open.

2. (Optional) If you want to check the design differences before updating, click the Design Tab  on 
page 614, and then click the Compare PCB  button.

The two versions are compared and differences written to Logic.rep  in the \SailWind Projects 
folder. To see the report, click the logic.rep  link in the Output Window.

3. On the Preferences Tab  on page 620, then set the appropriate options.

4. On the ECO Names Tab  on page 618, set the appropriate options.

5. On the Design Tab:  on page 614

a. If needed, check the Compare Design Rules and Show Net List errors report check boxes.

b. Click the ECO To PCB  button to send the changes.

Tip
While the SailWind Layout Link dialog box is open, you can cross-probe. For more 
information see Cross-Probe Between Sailwind Products.

See “Forward Annotation Results”.

Generating the ECO File in SailWind Layout
You can create a netlist (.asc  file) and send it to the layout designer who can then generate an ECO file 
by comparing the designs, and then import the changes into SailWind Layout.

Restrictions and Limitations

• If you’re creating a new pcb by sending a netlist for the first time, see Creation of a New PCB 
Layout from a SailWind Logic Design.

• To avoid unexpected changes during forward annotation, consider comparing data before you 
forward-annotate.

• Transferring non-ECO-registered parts and non-electrical parts is constrained. See the override 
settings in the Options dialog box, Design Category  on page 591 for details.
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• You cannot forward annotate changes to SailWind Router. SailWind Router does not import ECO 
files.

• During design comparison, a reuse definition is ignored and actual elements in the physical 
design reuse are used in the comparison.

Procedure
1. Click the Tools  > Layout Netlist  menu item.

2. To select a different filename or location for the netlist, in the Netlist to PCB dialog box, click 
Browse.

Tip
The default is the design filename with an .asc  extension, and is saved in the \SailWind 
Projects folder.

3. In the Select Sheets area, select the sheets you want to include in the netlist.

4. Select the Include Subsheets check box to include any connections to hierarchical symbols in the 
netlist.

5. Select the format you want from the Output Formats list.

6. Set the remaining dialog box options.

7. Click OK  to generate the netlist.

8. Send the netlist to the layout designer.

For the continuation of this process, see Forward Annotating Using an ECO File Generated by 
SailWind Layout  in the SailWind Layout Guide.

See “Forward Annotation Results”.

Generating the ECO File in SailWind Logic
Use the Compare/ECO dialog box to compare the netlists for a newer schematic and an older PCB 
design and create an ECO (engineering change order) file for import into the PCB design. You can also 
create a differences report file.

Restrictions and Limitations

• If you’re creating a new pcb by sending a netlist for the first time, see Creation of a New PCB 
Layout from a SailWind Logic Design.

• To avoid unexpected changes during forward annotation, consider comparing data before you 
forward-annotate.

• Transferring non-ECO-registered parts and non-electrical parts is constrained. See the override 
settings in the Options dialog box, Design Category  on page 591 for details.
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• You cannot forward annotate changes to SailWind Router. SailWind Router does not import ECO 
files.

• During design comparison, a reuse definition is ignored and actual elements in the physical 
design reuse are used in the comparison.

Prerequisites
You must have the .asc  file exported from SailWind Layout, and have the schematic open in SailWind 
Logic.

Procedure
1. Click the Tools  > Compare/ECO  menu item.

2. In the Compare/ECO dialog box, click the Documents Tab  on page 505.

3. In the Original Design to Compare and Update area, browse for the previous netlist .asc file sent to 
SailWind Layout.

(Optional) You can acquire a new Layout .asc  file from SailWind Layout to generate the .eco  file of 
design differences.

Tip
As long as the PCB design hasn’t undergone engineering changes, the last .asc  file from 
SailWind Logic can be compared to the current design in SailWind Logic to generate 
the .eco  file of the engineering changes in the design. If the last exported .asc  file is lost, 
you can export an .asc file  from SailWind Layout to compare to the current schematic to 
generate the .eco  file that gets imported into SailWind Layout to update the PCB layout. 
The same effect is created by Generating the ECO File in SailWind Layout  and the process 
is semi-automated by automatically importing the .eco  file.

4. Click the Comparison Tab  on page 507, and select the options you want to use for design 
comparison.

5. (Optional) If you want to check the design differences before creating the ECO file:

a. Select the Generate Differences Report check box in the Documents  tab.

b. Clear the Generate ECO File check box.

c. Click Run.

The netlist and PCB files are compared and differences written to Logic.rep  in the \SailWind 
Projects  folder. To see the differences, click Show Report  in the Process Status dialog box.

6. Select the Generate ECO File check box, and verify the ECO Filename.

Tip
Give the file a unique name to avoid overwriting any existing ECO files.

7. Click Run.

Output files are written to the \SailWind Projects  folder.
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Tip
In addition to the files listed above, messages or errors that occur during comparison are 
also written to Logic_Session.log  and Logic.err  in the \SailWind Projects  folder.

8. Send the ECO file to the layout designer for import into SailWind Layout.

For the continuation of this process, see Forward Annotating by Importing an ECO File from 
SailWind Logic  in the SailWind Layout Guide.

See “Forward Annotation Results”.

Forward Annotation Results
The forward annotation process generates a group of files (even in the background during the automated 
forward annotation process). These include an ECO file, a differences report, ASCII netlist files, and 
(optionally) an error report.

Table  40. Forward Annotation Generated Files

<schematic_name>.eco The ECO file. Contains ECO commands that describe the 
changes needed to update the original design to match the new 
design. Generated when you select Generate ECO File from the 
Compare/ECO Tools Documents  tab. See “ECO File Format”  on 
page 342 for a description of this file.

Logic.rep The Differences Report file. Describes the differences between 
the “old” and the “new” compared files. Generated when you 
select Generate Differences Report from the Compare/ECO Tools 
Documents  tab. See “Contents of the Differences Report”  on 
page 340 for a description of this file.

ecogtmp0.asc  ecogtmp1.asc Temporary copy of the “old” netlist and a temporary copy of the “new” 
netlist.

ecogtmp[ 0|1 ].err Generated only if errors are found in the netlist. A link to this file is 
displayed in the Output Window.

In addition to the files listed above, messages or errors that occur during comparison are also written to 
logic_session.log  and logic.err  in the \SailWind Projects folder. The following are reported in the errors 
report file:

• Library issues

• Single or zero pin nets

• Totally floating connections or subnets

• Unnamed dangling connections (one end floating)

• Power and Ground symbols used on nets whose name is different from the default name on the 
symbol
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• Multiple subnet nets where one or more subnets is missing an off-page symbol

• Single subnet nets with an off-page symbol (lonely subnet warning)

• User named subnets that have no visible net name label

Related Topics
ECO File Format

Contents of the Differences Report
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Backward Annotation From SailWind Layout 
to SailWind Logic
You can export your PCB layout changes “back” (known as backward annotation) to the schematic. You 
can choose between the three methods to backward annotate design changes.

You can backward annotate part, gate, pin, net, and attribute changes. For details, see Backward 
Annotation Results.

• Method 1  — If you have both SailWind Logic and SailWind Layout on your computer, you can 
use the “Automated Backward Annotation Process”. While this automated method is the simplest 
and fastest, this method is not recommended because it generates its own .eco  file by design 
comparison. You should use Method 2 to record the .eco  file in SailWind Layout and manually 
import it into SailWind Layout for the best results. For more information, see Recorded Versus 
Generated ECO Files  in the SailWind Layout Guide.

• Method 2  — If SailWind Layout is on another computer and you want the layout designer to 
generate the ECO file, follow the process in “Creating the ECO File in SailWind Layout”. This is 
the most accurate method. You must manually import the .eco  file into the SailWind Logic design.

• Method 3  — If SailWind Layout is on another computer and you must compare the designs 
and generate the ECO file within SailWind Logic, follow the process in “Creating the ECO File 
in SailWind Logic”. This method is not recommended since you are generating the .eco  file by 
design comparison. You should use Method 2 to record the .eco  file in SailWind Layout and 
manually import it into SailWind Layout for the best results. For more information, see Recorded 
Versus Generated ECO Files  in the SailWind Layout Guide.

Automated Backward Annotation Process
Creating the ECO File in SailWind Layout
Creating the ECO File in SailWind Logic

Automated Backward Annotation Process
If SailWind Logic and SailWind Layout are on the same computer, you can use the SailWind Layout Link 
dialog box to compare a newer PCB design with an older schematic and update the older schematic from 
the newer PCB design. You can also create a differences report.

This method generates a new .eco  file and does not use a recorded .eco  file. Recording the exact 
changes in an .eco  file gives the best back annotation results. Use Method 2 for the best results. For 
more information, see Recorded Versus Generated ECO Files  in the SailWind Layout Guide.
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Restrictions and Limitations

• Transferring non-ECO-registered parts and non-electrical parts is constrained. See Options 
dialog box, Design Category  on page 591 for details.

• During design comparison, a reuse definition is ignored and actual elements in the physical 
design reuse are used in the comparison.

• You cannot perform backward annotation between SailWind Logic and SailWind Router because 
SailWind Router does not export ECO files.

Prerequisites
You must have the older schematic open in SailWind Logic, and the newer PCB design open in SailWind 
Layout.

Procedure
1. In SailWind Logic, click the Tools  > SailWind Layout  menu item to open the SailWind Layout Link 

dialog box.

Tip
If SailWind Layout is not open, the Connect to SailWind Layout Dialog Box  appears. Click 
Open  to open the PCB design you want to annotate from in SailWind Layout. In the File 
Open dialog box, select the .pcb  file and click Open.

2. (Optional) If you want to check the design differences before updating, click the Design Tab  on 
page 614, and then click the Compare PCB  button.

The two versions are compared and differences written to Logic.rep  in the \SailWind Projects 
folder. To see the report, click the logic.rep  link in the Output Window.

3. On the Preferences Tab  on page 620, set the appropriate options.

4. On the ECO Names Tab  on page 618, set the appropriate options.

5. On the Design Tab:  on page 614

a. If needed, check the Compare Design Rules and Show Net List errors report check boxes.

b. Click the ECO From PCB  button.

Creating the ECO File in SailWind Layout
Create the .eco  file of design changes using SailWind Layout and then import it into the SailWind Logic 
design. This enables you to synchronize changes done in SailWind Layout back to the schematic.

This procedure only documents recording the .eco  file as you made engineering changes to your design, 
which creates a before and after record of changes. Generating an .eco  file by comparing designs will 
be electrically correct, but it does not create a perfect before and after record of components that are 
identical in their part types and connections. For more information, see Recorded Versus Generated ECO 
Files  in the SailWind Layout Guide.
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If you neglected to record the .eco  changes and you must generate the .eco  file by comparing two 
designs, see Comparing Two Versions of a Design  in the SailWind Layout Guide.

Restrictions and Limitations

• Transferring non-ECO-registered parts and non-electrical parts is constrained. See Options 
dialog box, Design Category  on page 591 for details.

• During design comparison, a reuse definition is ignored and actual elements in the physical 
design reuse are used in the comparison.

• You cannot perform backward annotation between SailWind Logic and SailWind Router because 
SailWind Router does not export ECO files.

Procedure
1. Record the engineering/netlist changes in an .eco  file. For more details, see Recording ECO 

Changes  in the SailWind Layout Guide.

2. In SailWind Logic, click the Tools  > Options  menu item, then click the Design  category.

3. Set the “Allow overwriting of attribute values in design with blank values from library attributes” 
check box appropriately to allow or prevent overwriting of non-blank attribute values with blank 
(“placeholder”) values from the library.

4. With your design open in SailWind Logic, click the SailWind Logic File  > Import  menu item.

5. In the File Import dialog box, in the Files of Type: list, select ECO Files (*.eco).

6. Browse for and select the ECO file to import.

7. Click Open.

If no errors occur, the schematic is updated. If errors occur, the schematic is not updated, and the 
errors, along with a link to the ECO Import errors file, are written to the Output window.

Creating the ECO File in SailWind Logic
Acquire the layout design in an .asc  file format, compare it to the schematic design with the SailWind 
Logic Compare/ECO tools, and then import the .eco  file of design changes into the SailWind Logic 
schematic design.

This method generates a new .eco  file and does not use a recorded .eco  file. Recording the exact 
changes in an .eco  file gives the best back annotation results. Use Method 2 for the best results. For 
more information, see Recorded Versus Generated ECO Files  in the SailWind Layout Guide.
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Restrictions and Limitations

• Transferring non-ECO-registered parts and non-electrical parts is constrained. See Options 
dialog box, Design Category  on page 591 for details.

• During design comparison, a reuse definition is ignored and actual elements in the physical 
design reuse are used in the comparison.

• You cannot perform backward annotation between SailWind Logic and SailWind Router because 
SailWind Router does not export ECO files.

Prerequisites
You must have an .asc  file exported from SailWind Layout. For more details, see Exporting an ASCII File 
in the SailWind Layout Guide.

Procedure
1. In SailWind Logic, click the Tools  > Options  menu item, then click the Design  category.

2. Set the “Allow overwriting of attribute values in design with blank values from library attributes” 
check box appropriately to allow or prevent overwriting of non-blank attribute values with blank 
(“placeholder”) values from the library.

3. In SailWind Logic, click the Tools  > Compare/ECO  menu item.

4. In the Compare/ECO dialog box, click the Documents Tab  on page 505.

5. In the Original Design to Compare and Update area, select the Use Current Schematic Design 
check box.

6. In the New Schematic Design with Changes area, browse for the new .asc  file exported from 
SailWind Layout.

7. Click the Comparison Tab  on page 507, and select the options you want to use for design 
comparison.

8. (Optional) If you want to check the design differences before creating the ECO file:

a. Select the Generate Differences Report check box in the Documents  tab.

b. Clear the Generate ECO File check box.

c. Click Run.

The netlist and PCB files are compared and differences written to Logic.rep  in the \SailWind 
Projects  folder. To see the differences, click Show Report  in the Process Status dialog box.

9. Select the Generate ECO File check box, and verify the ECO Filename.

Tip
Give the file a unique name to avoid overwriting any existing ECO files.

10. Click Run.
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Output files are written to the \SailWind Projects  folder.

Tip
In addition to the files listed above, messages or errors that occur during comparison are 
also written to Logic_Session.log  and Logic.err in the \SailWind Projects  folder.

11. Click the SailWind Logic File  > Import  menu item.

12. In the File Import dialog box, in the Files of Type: list, select ECO Files (*.eco).

13. Browse for and select the ECO file to import.

14. Click Open.

If no errors occur, the schematic is updated. If errors occur, the schematic is not updated, and the 
errors, along with a link to the ECO Import errors file, are written to the Output window.

Related Topics
Backward Annotation Results
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Backward Annotation Results
Backward annotation is supported at multiple levels of design activity. You can use backward annotation 
to exchange design updates and changes to attributes, parts, gates, nets, and pins. Results are 
dependent upon the type of design object data that you are updating.

Attribute Level Backward Annotation
Part Level Backward Annotation
Gate Level Backward Annotation
Net Level Backward Annotation
Pin Level Backward Annotation

Attribute Level Backward Annotation
If you add, delete or modify attributes in SailWind Layout, you can backward annotate new attributes and 
deleted attributes.

New Attributes

• A new attribute in a part updates all parts of the same type. If the attribute name does not exist, it 
is added with the assigned value.

• An error is created if the part does not exist.

Tip
Unsupported attribute types, such as net or net class, are ignored.

Deleted Attributes

• Deleting an attribute for a part-type deletes the attribute on all parts of that type in the design.

• An error message is generated if the part or attribute name does not exist.

• If the attribute command specifies an object type not supported for general attributes, such as net 
or net class, the attribute command is ignored.

Related Topics
Creating the ECO File in SailWind Layout

Part Level Backward Annotation
You can backward annotate added parts, changed parts, deleted parts, and the reference designator 
name.
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Added Parts

• A new sheet is created and all new parts are added to the sheet. Parts are placed on a grid so 
that parts of a medium size do not overlap. No attempt is made to avoid overlapping of larger 
parts.

• An error message is generated if the reference designator of the newly added part already exists 
or if the part does not exist in the Library.

Tip
The part is not added to the schematic if the reference designator already exists.

• If the part contains Signal Pins, these pins are included in the add pin function. Backward 
annotation does not currently support signal pins so an error message is created.

Changed Parts

• If the changed part is a multigate part, all gates are updated to the new part type.

• An error message is generated if the new part does not exist in the design or in the Library, or if 
the gate or pin count is incompatible.

Deleted Parts

• If the deleted part is a multigate part, all gates are deleted.

• An error message is generated if the part is still connected to a net or the part does not exist.

Reference Designator Name

• If the part being renamed is a multigate part, all gates are updated.

• An error message is generated if the old reference designator does not exist.

Related Topics
Creating the ECO File in SailWind Layout

Gate Level Backward Annotation
If you swap gates in SailWind Layout to improve your routing, you can backward annotate the swapped 
gates to the schematic.

SailWind Logic creates an off-page symbol at each swapped gate. An error message is created if the gate 
does not exist.
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Related Topics
Creating the ECO File in SailWind Layout

Net Level Backward Annotation
You can backward annotate joined nets, nets created by splitting an existing net, and renamed nets.

Joined Nets

• The first net is renamed to be the same name as the second net.

Nets Created by Splitting an Existing Net

• A Delete Pin from Net operation is performed to remove them from the existing net, followed by 
an Add Pin to Net operation to add the pin to the new net.

Renaming Nets

• All subnets of the old net on all sheets are renamed. If any of the subnets contain Power or 
Ground symbols without netnames, netnames are added to these symbols.

• An error message is created if the new net already exists.

Related Topics
Creating the ECO File in SailWind Layout

Pin Level Backward Annotation
You can backward annotate swapped pins, pins added to a net, and pins disconnected from a net.

Swapped Pins

• SailWind Logic creates an off-page symbol at each swapped pin.

Pins Added to a Net

• A pin can be added only if it is not already connected to another net. If the pin is a gate pin (a 
visible terminal pin on the gate symbol), an off-page symbol is created.

• An error is created if pin is already connected or the pin is a signal pin already assigned to a net.
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Pins Disconnected From a Net

• If the pin is a gate pin, the connection is deleted if it connects to a tie-dot or off-page symbol. If 
the connection goes to another gate pin, the connection is broken and, an off-page symbol is 
added.

• This command generates an error message if the pin is not connected to the net in question.

Related Topics
Creating the ECO File in SailWind Layout

Contents of the Differences Report
When you compare two versions of a design (Tools  > Compare/ECO), you can create an output file that 
lists the differences between the two versions. The report file is named Logic.rep  and is written to the 
\SailWind Projects  folder.

Table  41. Sections of the Difference Report

Option Description

Part differences This section of the report includes the reference designator and the part type for 
both the old and new designs. Parts that exist only in the old design are listed under 
the New Design column as <none>. Parts that exist only in the new design are 
listed under the Old Design column as <none>. Parts that have identical reference 
designators and part types in both designs are not listed.

Net differences This section lists names of the nets that do not exist under two columns: New 
Design and Old Design. It lists the names of the nets that do not exist in one 
design or the other. It also lists the nets that match, but that have different names, 
including nets in the old design that have been split into multiple nets in the 
new design. A net split operation appears as pin differences. Nets are listed 
alphabetically under the Old Design column, except where multiple nets are 
combined, where they are listed in succession. Nets that do not exist in the old 
design are listed at the end of this section.

Unmatched net 
pins in old design

This section lists any connected pins in the old design that are missing or 
connected to other nets in the old design. These pins are deleted from nets during 
the ECO process. This list provides net names in the old design followed by 
unmatched pins in the net. If the net does not exist in the new design, all pins in the 
net are listed.

Unmatched 
net pins in new 
design

This section lists any connected pins in the new design that are missing or 
connected to other nets in the old design. These pins are added to nets during 
the ECO process. This list provides net names in the new design followed by 
unmatched pins in the net. If the net does not exist in the old design, all pins in the 
net are listed.

Attribute 
differences

This section of the report lists each object under the headings: Attribute Name, 
Old Value, and New Value. Subheadings, including object type, object name in old 
design, and object name in new design appear for each object in the list if different.
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Table  41. Sections of the Difference Report  (continued)

Option Description

Attribute differences are included only for objects that exist in both the old and new 
design. If an attribute is missing in either design, the value is listed as <no attr>. If 
the attribute exists, but has no value, it is listed as <no value>.

Rules differences This section reports each object or object pair that has rules differences. Each 
object or object pair has three columns of information (Object Type, Object Name, 
and Rule Type) and a subheading that lists Rule Name, Old Value, and New Value.
If a rule set is missing on an object in either the old or new design, then the old or 
new values of all missing rule entries are listed as <no rule>.
The following example shows a high-speed rule change for net $$$1963 that 
changes the maximum length and minimum impedance rules.

NET   $$$1963   HIGH_SPEED
MAX_LENGTH          50000        20000
MIN_IMPEDANCE       50.0         70.0 

Net class 
differences

This section reports the names of net classes that:
• Do not exist in one design or the other. (Classes that do not exist in the Original 

Design appear at the end of the section.)

• Match but have different names

Added class nets This section reports nets that are not in the Original Design and are added in the 
New Design. (The net class in the New Design has nets either not included in the 
Original Design or are included in different net classes in the Original Design.)
This section lists:

• Each net class that has added nets in the New Design and the names of the 
added nets

• All of the nets in the net class if the net class is new (does not exist in the 
Original Design)

Removed class 
nets

This section reports nets that are in the Original Design but have been removed 
from the New Design. (The net class in the Original Design has nets either not 
included in the New Design or included in different net classes in the New Design.)
This section lists:

• Each net class in the old design from which nets were removed and the names 
of those removed nets

• All of the nets in the net class if the net class does not exist in the New Design

Pin-pair group 
differences

This section lists pin-pair groups that:
• Do not exist in one design or the other. (Pin-pair groups that do not exist in the 

Original Design appear at the end of the section.)

• Match but have different names.

Removed group 
pin-pairs

This section reports pin-pairs that are in the Original Design but removed from the 
New Design. (The pin-pair group in the Original Design has pin-pairs either not 
included in the New Design or included in different groups in the New Design.)

SailWind Logic Guide 341



Working With SailWind Layout and SailWind Router
ECO File Format  

Table  41. Sections of the Difference Report  (continued)

Option Description

This section lists:
• Each group in the old design from which pin-pairs were removed and the names 

of its removed pin-pairs

• All of the pin-pairs in the group if the group does not exist in the New Design

Added group 
pin-pairs

This section reports pin-pairs in the New Design that are not in the Original Design. 
(The pin-pair group in the New Design has pin-pairs either not included in the 
Original Design or included in different groups in the Original Design.) An ECO 
operation adds these pin-pairs.
This section lists:

• Each group with added pin-pairs in the New Design and the names of added 
pin-pairs

• All of the pin-pairs in the group if the group is new (does not exist in the Original 
Design)

Related Topics
Compare/ECO Tools Dialog Box, Documents Tab

Compare/ECO Tools Dialog Box, Comparison Tab

ECO File Format
The format used is similar to PADS-format ASCII. Each type of data begins with a header line with a key 
word surrounded by asterisks (*).

The first line of the file is formatted:

*PADS-ECO*

The end of the file (EOF) entry is formatted:

*END*

Add remark lines with the entry:

*REMARK* remark information etc.

The following are the available ECO commands.

Add a Pin to the Net
The command starts with the format:

*NET*

A line indicating the net to which the pin is added follows this line:
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*SIGNAL* netname 10

where netname  is the net to add the pins to and 10 is the trace width to associate with the connections. If 
the net name does not currently exist in the design, it will be added. This is followed by the pin(s) to add 
to the net as shown below:

ref1.pin1 ref2.pin2
 

Add a Part

The command is formatted:

*PART*
 

The part entry line is formatted:

refdes parttype
 

where refdes  is the part reference name and parttype  is the part type name. When parts are added in the 
PCB, they will be placed at system origin of 0,0. If a board outline is present, the parts are instead placed 
at the lower left corner of its box.

Join Two Nets Together

The command starts with the format:

*JOINNET*
 

This is followed with the line indicating the nets to join:

OLDNET0 OLDNET1
 

where OLDNET0  and OLDNET1  are the names of the nets to combine. The new combined net uses the 
name of OLDNET1. A connection is added between the nets using two random pins in the selected nets. 
The trace width of the added connection is the same as that of a connection in the first net (OLDNET0).

Delete a Part

The command is formatted:

*DELPART*
 

The line is formatted:

refdes parttype
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where refdes  is the part reference name to delete and parttype  is the part type name. If all pins of the 
part to be deleted have not already been disconnected from the connection nets in the design, an error is 
reported.

Delete a Pin from a Net

The command starts with the format:

*DELPIN*
 

This is followed by a list of pins to delete from each net, in the form:

refdes.pinnumber signame
 

where refdes  is the part reference name, pinnumber  is the pin number to disconnect, and signame  is the 
net of which the pin is currently part.

Change a Component's Part Type

The command is formatted:

*CHGPART*
 

The change part line is formatted:

refdes oldparttype newparttype
 

where refdes  is the reference name of the part to change, oldparttype  is the old part type, and 
newparttype  is the new part type.

Split a Net into Two Nets

The command starts with the format:

*SPLITNET* SPLIT NET INTO TWO NEW NETS
 

Two lines follow, listing the new signal names and the pins:

*SIGNAL* oldsigname
ref1.pin1 ref2.pin2
*SIGNAL* newsigname1
ref3.pin3 ref4.pin4
 

where the pins following the *SIGNAL* statement are in the first net, and those following the second line 
are in the second net.

Rename a Part

The command is formatted:
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*RENPART*
 

The rename line is formatted:

oldrefdes newrefdes
 

where oldrefdes  is the old name and newrefdes  is the new name. To facilitate the renaming operation, 
duplicate name checking is not run until after all rename information has been read. This allows the above 
rename list to run without a conflict. If any error is encountered, no parts in the list are renamed.

Rename a Net

The command is formatted:

*RENNET* RENAME NET
 

The rename net entry line is formatted:

oldname newname
 

where oldname  is the old net name and newname  is the new net name.

Swap a Gate

The command is formatted:

*SWPGATE* GATE1 GATE2
 

Swap Pins

The command is formatted:

*SWPPINS* REFDES PIN1.PIN2
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Chapter 19
Plotting and Printing

Various options are available for plotting and printing your design output. You can choose to print your 
design on a printer connected to your computer or network for a quick visual design review. You can 
generate output to a pen plotter or a photo plotter. You can also generate an intelligent PDF file for 
sharing you design output electronically.

Setting Printing and Plotting Output Options
Previewing Your Output
Creating a PDF
Plotting Output
Setting Up a Pen Plotter
Adding a New Pen Plotter
Setting Up a Photo Plotter
Printing Output
Printing to PDF
Setting the Printer to Print to a File

Setting Printing and Plotting Output Options
Use the Options dialog box to set the output options for printing or plotting. Setting options enables you to 
set the position, orientation, and color of selected sheets and objects.

Procedure
1. In the Print or Plot dialog box, click Options.

2. In the Sheet Selections area in the Options dialog box, select the name of the available sheets to 
add to the Sheets to Print list, and click Add.

3. Select an Orientation angle and a Justification position for the output.

4. Type an offset value in the X Offset and Y Offset boxes.

Tip
When setting an offset. observe the following:
• You can only set offsets if you clicked something other than Scale to Fit and Centered in 

the Justification list.
• The print or plot location is calculated after the plot is rotated and scaled.

5. In the scaling boxes, type the plot size to actual size ratio.

Example: A 2 to 1 scaling results in a printout or plot that is twice the actual size.
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Tip
The Preview area graphically shows the position, orientation, justification, and scaling of 
the output.

6. In the Items area, select the check boxes for the items you want to include in your output.

7. In the Selected Color area, click a color tile, then in the Items area, click the tile to the right of the 
item to change its color.

8. Select the Plot Jobname check box to output the schematic name, time, and date.

9. Select the Print Window check box to print the displayed window.

10. Click OK  to return to the Print or Plot dialog box.

Previewing Your Output
You can use the Selections Preview dialog box to preview your options and output. This enables you to 
examine the output and determine if you need to make any changes before generating your final output 
files.

Procedure
1. Click the File  > Plot  or the File  > Print  menu item, then in the Plot or Print dialog box, click the 

Preview  button to open the Selections Preview dialog box and verify the settings for the selected 
sheets you want to print or plot.

2. In the Selections Preview dialog box, click Print  or Plot to send the output to the printer or plotter.

Tip
You can navigate within the Selections Preview dialog box using the following methods:
• Zoom into the Sheet or Extents of the selected sheet by clicking the appropriate buttons.
• Click the left mouse button in the preview window to zoom in at the cursor location. Click 

the right mouse button to zoom out.

Creating a PDF
You can create an intelligent PDF of your schematic, choosing which sheets you want to share and show 
to others in your organization. You can create the PDF in full-color or black and white, with hyperlinks to 
part attributes, and with search capabilities, making it easy to locate parts and nets. Once you locate a 
net, you can find other instances of it through the entire schematic, even when the net is on a different 
page. You can also create a black and white, non-searchable PDF of your schematic.

See also Printing to PDF.

Tip
Adobe® Acrobat® Distiller™ is not required on your system to create a PDF.
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Creating a PDF

Restrictions and Limitations
To search a PDF, you must substitute the Stroke font with a System font.

Procedure
1. Click the File  > Create PDF  menu item.

2. In the File Create PDF file dialog box, type the name of the PDF and then click Save.

Tip
The default name of the file is the name of the schematic with a PDF extension.

3. In the Create PDF dialog box, in the Sheets to PDF list, select the schematic sheets you do not 
want to include in the PDF, and then click Remove.

Tip
By default, all schematic sheets are selected for PDF creation.

4. To automatically open the resulting PDF, select the “View PDF after creation” check box.

5. To replace a stroke font in your schematic with a system font in the PDF, select the “Replace stroke 
font with” check box, and then select a font from the list.

Use the Font style buttons to add Bold, Italic, or Underline styles.

Restriction:
When replacing stroke fonts, the following restrictions apply:
• You can only search a PDF if you replace the Stroke font with a System font.
• There is no font size control. Text heights are already set for each text item in the design. 

The height will be converted to the nearest point size in the PDF.

6. To be able to view part attributes such as the reference designator and the part type in the PDF, 
select the “Create hyperlinks that will display part attributes” check box.

In the resulting PDF, you will see yellow boxes around each part. If you click inside the box, you will 
get a listing of the part attributes.

7. To enable finding the next instance of a net or bus in the PDF, select the “Create hyperlinks that will 
pan through nets” check box.

Restriction:
If the net name is not visible in the schematic, you will not be able to pan through the nets.

In the resulting PDF, you will see blue boxes around each net name and bus name. If you click 
inside the box, you will pan to the next instance of that net or bus.

8. To create hyperlinks on parts, net names, and buses without their yellow and blue boxes, clear the 
“Visible rectangle around objects with hyperlinks” check box.
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In the resulting PDF, the hyperlinks will be invisible.

9. In the Color Scheme area, click the scheme of your choice.

Tip
The colors used in the Color on Black or Color on White schemes are the same colors 
currently used in your schematic. The Black on White scheme shows all currently visible 
items in the schematic in black.

10. Click OK.

Plotting Output
After you have completed you design you can generate output for design review. You can output your 
designs to pen plotters or photo plotters.

Procedure
1. Click the File  > Plot  menu item.

2. Choose Pen Plot or Photo Plot.

3. Set up output options  on page 347.

4. Set up the pen plotter  on page 350 or photo plotter  on page 352.

5. Preview your output  on page 348.

6. Click Run.

Tip
The Plot dialog box displays the following information related to the plot configuration:
• The Summary area lists the numbered available sheets you can plot, and the items 

contained in the sheets.
• The File Prefix box lists the prefix name of the file you want to plot.

Related Topics
Printing to PDF

Setting the Printer to Print to a File

Printing Output

Setting Up a Pen Plotter
Before you can output your design to a pen plotter, specific options need to be configured so that the 
output is correctly reproduced by the plotting device. Use the Pen Plotter Setup dialog box to set various 
options for the plotter.
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Adding a New Pen Plotter

Procedure
1. Click the File  > Plot  menu item.

2. In the Plot dialog box, click Setup.

3. Type the number of pens (1-16) in your device, and type the pen line width in mils.

4. Select the Rotate Axis check box to reverse the X and Y axes of the design.

5. To assign colors, click a Selected Color tile, and then click a pen number in the Pen Colors area. 
Repeat this step for every pen listed.

6. Click a Plotting Size  button, or click Other  to define a custom size.

If you click Other, type the X and Y dimensions to use.

7. In the Device list, select the plotter device to use.

Adding a New Pen Plotter
Use the Pen Plotter Advanced Setup dialog box to add a new pen plotter to the list of available plotters.

Restrictions and Limitations

• You can also edit the data for an existing plotter, but only if it is a custom setup.

• You cannot modify the SailWind-supplied advanced plotter settings.

Procedure
1. Click the File  > Plot  menu item.

2. In the Plot dialog box, click the Setup  button.

3. In the Pen Plotter Setup dialog box, click the Advanced  button.

4. Type the name of a different pen plotter you want to use.

Exception: Do not reuse one of the existing, supplied device names.

5. In the device type list, select the interface language the plotter uses: HPGL or HGML.

6. Set the plotter resolution by providing a scaling ratio. Type a number in the Multiplier and Divisor 
boxes. The ratio defined is the scale factor to convert from mils (0.001 in) to plotter units.

Example: Most Hewlett-Packard plotters have a resolution of 0.025 mm or 1/40 mm. This means 
that a distance of one inch (1000 mils) is 1016 plotter units (25.4 X 40). So a ratio of 1016 to 1000 
would be defined. The ratio actually used is 254 to 250 which is the same as 1016 to 1000.

7. Select the Origin at Center check box if the origin of the plotter is at the center of the paper. Clear 
this check box if the origin is in the lower left corner or other location.

8. Click OK  to return to the Pen Plot Setup dialog box.

9. Click OK  to return to the Plot dialog box.
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Related Topics
Setting Up a Photo Plotter

Setting Up a Photo Plotter
Before you can output your design to a photo plotter, specific options need to be configured so that the 
output is correctly reproduced by the plotting device. Use the Photo Plotter Setup dialog box to define the 
aperture and other photo plotter options.

Procedure
1. Click the File  > Plot  menu item.

2. In the Plot dialog box, select Photo Plot, and then click the Setup  button.

3. To add a new D-code to the D-Code list, click Add, type a code, and click OK.

4. To delete a D-code, select a code in the D-Code list, and click Delete.

Alternatives:

• Click the Augment  button to automatically generate D-codes for items in the schematic file that 
are not in the current list.

• Click the Regenerate  button to clear the current D-code list and automatically add D-codes for 
all items in the schematic.

5. Set the shape for a selected D-code.

• Select the Same Aperture for Flashes/Lines check box to draw lines and flashed items with the 
same aperture. Round and square shapes for lines will be gray.

• If you clear this check box, then you can click either Flash (to set a flash aperture) or Line (to 
set a draw aperture).

• In the Width box, type a diameter for round shapes. This box is unavailable if a width is not 
appropriate for the specified shape.

6. In the Aperture Count box, type the maximum aperture count.

7. Select the Augment on-the-fly check box to add apertures to the D-code list when photo plots are 
run if any newly created lines were added to the schematic.

When you open the Photo Plotter Setup dialog box, the necessary apertures will be present.

8. In the Photo Plotter Setup dialog box, click the Advanced  button.

9. Click English for mils or Metric for millimeters.

10. To specify the precision of the output file coordinates, type the number of digits that should lead 
and trail the decimal point. Type the digits in the Leading and Trailing boxes.
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Printing Output

11. To set the coordinates for the output file, click Absolute for absolute coordinates, or click 
Incremental for relative coordinates.

12. Define how to handle zero suppression in the output file:

• Click None to retain leading and training zeros.

• Click Leading to suppress zeros before the decimal point.

• Click Trailing to suppress zeros after the decimal point.

13. Define how to draw arcs and circles:

• Click None if your photo plotter does not support circular interpolation. Arcs and circles are 
drawn as small straight-line segments.

• Click Quadrant if your photo plotter does not support full, 360-degree circular interpolation.

• Click Full if your photo plotter supports full, 360-degree circular interpolation.

14. To set the plotting size, click a Plotting size button, or click Other  to define a custom size.

If you click Other, type the X and Y dimensions to use.

15. Select the Suppress Repeated Coords check box to eliminate repeated coordinates from the 
output file.

16. Click OK  to return to the Photo Plotter Setup dialog box.

17. Click OK  to return to the Plot dialog box.

Related Topics
Setting Up a Pen Plotter

Printing Output
You can output your design to any standard printer that is connected to your system. Set up your print 
options as required by your installed printer driver.

Procedure
1. Click the File  > Print  menu item.

Note:
If you have previously set up your printer configuration options, then on the toolbar, click 
the Print  button to immediately print your design using the last saved print configuration.

2. Select the name of the printer to which you want to print.

3. Set up print options  on page 347.
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4. Click Network  to display the Connect to Printer dialog box.

5. Preview your output  on page 348.

6. Click OK  to send the output to the printer.

Related Topics
Printing to PDF

Setting the Printer to Print to a File

Printing to PDF
You can print your schematic sheets to a single PDF. The resulting PDF is a non-searchable, black and 
white image of your schematic.

To create a color PDF that is searchable, see the Creating a PDF  topic.

Restrictions and Limitations
You must have a PDF generator (such as Adobe PDF, Cute PDF, or Microsoft Print to PDF) installed 
before you can print to PDF.

Procedure
1. On the toolbar, click the Print  button.

2. In the Print dialog box, select your preferred PDF generator in the Printer name list.

3. Click OK.

Related Topics
Creating a PDF

Plotting Output

Printing Output

Setting the Printer to Print to a File
SailWind Logic supports PostScript printing to a file through the use of the Windows printer properties. 
Before you create a PostScript file, you must first set up the printer to print to a file.
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Setting the Printer to Print to a File

Procedure
1. Locate printer information based on your platform:

• For Windows 7 Professional, click Start, click Control Panel, then double-click Devices and 
Printers.

• For Windows 10, click Start, click the Settings  icon, click Devices, then click Printers and 
scanners.

2. Select the PostScript printer you want to use, then right-click and click Properties.

3. Click the Ports  tab.

4. In the Port column, select the Print to File check box.

Tip
This procedure works with local printers. If you are using network printers, you may not 
have access rights to select or change the port information.
The options on the Ports  tab may differ depending upon the specific version of your 
operating system.

5. ClickOK.

Related Topics
Printing to PDF

Plotting Output

Printing Output
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Chapter 20
Object Linking and Embedding

SailWind Logic object embedding capabilities enable design engineers to embed an object in a SailWind 
Logic design file and hold it within its framework. You can also embed a link to an outside object so that 
the linked object automatically updates each time you open the SailWind Logic database.

Restriction:
The insertion of SailWind Logic, Layout or Router files as OLE objects in other files (including 
other SailWind files) is not supported. Any SailWind Logic, Layout or Router file inserted in 
another file will not behave properly and cannot be edited within the “container” application (Visual 
Editing).

You can insert other files or other applications as linked or embedded objects within a SailWind Logic 
schematic. You can insert a Microsoft Word document, a Microsoft Excel spreadsheet containing a Bill of 
Materials, video or audio clips, and so forth. SailWind Logic does not need to understand the format of the 
inserted object; SailWind Logic communicates with the application that created the file and that source 
application tells SailWind Logic what information to display and how to display it.

Tip
You cannot insert or modify OLE linked or embedded objects in the Part Editor.

Insertion of OLE Objects in SailWind Logic
Embedding a Text Document
Turning Off the Display of OLE Objects
OLE Object Selection
Moving and Sizing OLE Objects
Changing an OLE Object's Icon or Label
Converting an OLE Object to Another Type
Edits of OLE Objects
OLE and Print/Plot
Deleting OLE Objects
Redraws of a Screen Containing OLE Objects
OLE and View Menu Commands
Changing the OLE Object Background Color
Saving OLE Objects
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Insertion of OLE Objects in SailWind Logic
When you insert an OLE object in a SailWind Logic schematic, you can choose to either embed it or link 
to it.

• An embedded object resides in the schematic, and can be accessed only from within SailWind 
Logic. An embedded Word object, for instance, can be opened and edited only from the 
schematic it resides in.

• A linked object resides on disk, and can be opened in its appropriate application either via 
SailWind Logic or directly from the disk. It is not copied permanently into the schematic, but is 
read in from disk each time the schematic is opened.  

Restriction:
Insertion of SailWind Logic, Layout or Router files as OLE objects in other files (including other 
SailWind files) is not supported. Any SailWind Logic, Layout or Router file inserted in another file 
will not behave properly and cannot be edited within the “container” application (Visual Editing).

There are three ways of inserting an OLE object in a SailWind Logic schematic:

• Insert a new (empty) embedded object, and then create the object's content. For instance, insert 
a new Word document, then edit it with Word from within the schematic.

• Insert a copy of an existing application or file as an embedded object. Embedded objects are not 
updated when the original file is updated.

• Insert a link to an existing application or file as a linked object. Linked objects are updated 
whenever the file they link to is updated.

The following sections of this topic describe how to insert OLE objects in a SailWind schematic:

Inserting a New Embedded OLE Object
Inserting an Existing File as an Embedded Object
Inserting an Existing File as a Linked Object

Inserting a New Embedded OLE Object
You can insert a new embedded OLE object in a SailWind Logic schematic. By embedding the object, it is 
not affected by changes made to an external source file.

Procedure
1. Click the Edit  > Insert New Object  menu item.

2. From the Insert Object dialog box, select Create New.

3. From the Object Type list box, select the type of OLE object you want to create.
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Inserting an Existing File as an Embedded Object

Tip
You can only create new OLE objects using applications that are installed and registered 
on your system and are OLE servers. Most OLE servers are Microsoft products, such as 
Word or Excel.

4. To display the new object in the schematic as an icon, check the Display As Icon check box.

The icon that will be displayed appears beneath the check box.

Uncheck the check box to display the entire object; for example, to display the actual Word 
document instead of a Word  icon.

5. Click OK. The application associated with the object type you selected opens, and you can edit  on 
page 364 the new object's content:

6. If the application is an OLE Linking and Embedding Server, it opens inside SailWind Logic, but 
runs in the background. The application's toolbar takes over SailWind Logic's toolbar. You can 
then work with the source application as you would if it was started outside SailWind Logic. This is 
called Visual Editing.

Click outside the object, and the SailWind Logic toolbar takes over again. You can continue to 
design in SailWind Logic. The application continues to run in the background; therefore, you can 
click on the object and work in the source application at any time.

If the application associated with the object is not an OLE Linking and Embedding Server, the 
application opens in a new window.

7. When you are finished editing, close the object. You can reopen the object at any time by double-
clicking on it.

Inserting an Existing File as an Embedded Object
An existing file inserted in a SailWind Logic schematic as an embedded object is a copy of the source file 
it is created from. It is not linked to the original source file, is not updated when the source file is changed, 
and can be accessed only from SailWind Logic.

Procedure
1. Click the Edit  > Insert New Object  menu item.

2. From the Insert Object dialog box, select Create from File.

3. In the File edit box, type the pathname of the file to insert, or click the Browse  button to search for 
the file.

4. Uncheck the Link checkbox to insert the OLE object as an embedded object.

5. To display the object as an icon in the schematic, check the Display As Icon check box.

The icon that will be displayed appears beneath the check box.

Uncheck the check box to display the entire object; for example, to display the actual Word 
document instead of a Word  icon.

6. Click OK. The object is inserted in the schematic.
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Inserting an Existing File as a Linked Object
An existing file inserted in a SailWind Logic schematic as a linked object is merely a link to the source file 
on the disk. The file is not copied permanently into the schematic, but is read in from disk each time the 
schematic is opened. It can be opened from within SailWind Logic, or directly from the disk.

Procedure
1. Click the Edit  > Insert New Object  menu item.

2. From the Insert Object dialog box, select Create from File.

3. In the File edit box, type the pathname of the file to insert, or click the Browse  button to search for 
the file.

4. Check the Link checkbox to insert the OLE object as an linked object.

5. To display the object as an icon in the schematic, check the Display As Icon check box.

The icon that will be displayed appears beneath the check box.

Uncheck the check box to display the entire object; for example, to display the actual Word 
document instead of a Word  icon.

6. Click OK. The object is inserted in the schematic.

Embedding a Text Document
Using OLE, you can embed a text document in your schematic to more quickly add multiple lines of text 
since the Create Text tool on the Schematic Editing Toolbar only allows single lines of text.

Embedding is recommended over linking since the embedded document will reside inside the .sch file 
and can’t get lost or accidentally deleted as an external file.

You can see a sample of this in the preview.sch sample design. See the Notes section on the lower left 
corner of sheet 1. Double-click the text to activate the Microsoft Word document.

Restrictions and Limitations

• OLE objects can only be printed. They cannot be plotted by a pen or photo plotter.

• OLE objects must be enabled in the print Options dialog box  on page 606 to appear in the 
printout, but they will never be visible when viewing the Print Preview.

• OLE objects can only be printed using a zero plot orientation.

Procedure
Follow the appropriate instructions in Insertion of OLE Objects in SailWind Logic.

Tip
You can resize the object within your design when the object is active for editing.
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Turning Off the Display of OLE Objects
SailWind Logic does not understand the format of an inserted object; it only communicates with the 
application that created the OLE linked or embedded object to display the information. If the application 
that created the linked or embedded OLE object is installed and registered on your system, then SailWind 
Logic calls upon that application to display the OLE object in SailWind Logic as it would appear in the 
source application. For example, a Word document can appear within SailWind Logic and the Word 
toolbars appear within SailWind Logic.

If the source application is not installed and registered on your system, then SailWind Logic can only 
display the inserted OLE object as an icon. It cannot open or display the OLE object as it would appear 
in the source application. SailWind Logic also displays the OLE object as an icon if the object is an 
application.

You may want to turn off the display of OLE objects when SailWind Logic contains many linked or 
embedded objects because the redraw speed can decrease. Redraw speed noticeably decreases if the 
OLE Linking and Embedding servers, or source applications, which actually display the OLE items are not 
optimized for remote display.

Procedure
1. Click the Tools  > Options  menu item, then in the Options dialog box, click the General  category.

2. Clear the Display OLE Objects check box.

See also Options Dialog Box, Design Category.

OLE Object Selection
Selection of OLE objects in SailWind Logic operates differently than selection of other objects such as 
pads, nets, components and so forth.

The differences are:

• You cannot select more than one OLE object at a time.

• You cannot use area select to select OLE objects.

• Commands apply to selected OLE objects only, even if you also select SailWind Logic objects. 
OLE objects have selection priority over SailWind Logic components.

• OLE objects are always on top; to select SailWind Logic items under an OLE object, you must 
move the OLE object.

When you click on an OLE object in SailWind Logic, it behaves like a non-text item in a Word file. that is, 
it becomes a rectangular area with sizing handles to indicate that it is selected. (Sizing handles are small, 
black squares that appear at the corners and along the sides of a rectangular area surrounding a selected 
object.)

Right-click a selected OLE object to access a shortcut menu that lists all commands that you can apply to 
the OLE object.
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Moving and Sizing OLE Objects
Move and resize OLE linked or embedded objects just as you resize non-text objects in Word.

Procedure
Select the object.

• To move the OLE object, click and hold the left mouse button. Move the cursor to move the object. 
Release the mouse button once the object is in the correct location.

• To size an OLE object, click and hold the left mouse button on one of the sizing handles. Move the 
cursor; the object changes size according to the cursor movements. Release the mouse button when 
the object is sized correctly.

Changing an OLE Object's Icon or Label
You can change the icon that represents an embedded or linked object in your schematic. You can also 
change the descriptive label that is displayed below the icon.

Procedure
1. Click on the object to select it.

2. Right click and select <object_type>  > Convert  to display the Convert Dialog Box.

3. Click the Change Icon  button to display the Change Icon dialog box.

4. In the Change Icon dialog box, click an Icon radio button to select the icon for the object:

5. Leave the Current radio button set if you want to keep the current icon but change the object's 
label.

6. Click the Default radio button to change to the default icon.

7. Click the From File radio button to select the new icon from a file. If no file is shown in the From 
File edit box, click the Browse  button to search for the file containing the icon you want to 
represent the object. Then click on the desired icon in the list box.

8. To change the object's label, edit it in the Label edit box.

9. Click OK  to return to the Convert dialog box.

10. In the Convert dialog box, click OK  to save your changes.

Converting an OLE Object to Another Type
You can change the file format of an inserted OLE object so that you can open it in the applications you 
use. You can change the format temporarily--for a single editing session, after which the object is saved in 
its original format--or permanently, so that the object is converted to--and saved in--the new format.
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Converting an OLE Object to Another Type

Procedure
1. Click on the object to select it.

2. Right click and select <object_type>  > Convert  to display the Convert Dialog Box.

3. In the Object Type list box, click the object type you want to convert the object to.

4. Click Convert to or Activate as to specify the conversion mode:

a. Click Convert to convert the object to the type selected in the Object Type box.

The object will be converted to the new object type, and saved.

b. Click Activate as to open the object as the type selected in the Object Type box.

After you activate and edit the object, it returns to the current type.

5. To display the inserted object in the schematic as an icon, check the Display As Icon check box.

The icon that will be displayed appears beneath the check box.

Uncheck the check box to display the entire object; for example, to display the actual Word 
document instead of a Word  icon.

Tip
If an object's source application is not registered on your system, then the object can be 
displayed only as an icon.

6. Click OK  to convert or activate the object.
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Edits of OLE Objects
You can perform a limited set of edits on an OLE linked or embedded object. These include copy, paste, 
delete, open, and convert OLE Objects.

• Cut, Copy, and Paste SailWind Logic OLE Objects

• Edit  > Delete All OLE Objects  — Enables you to remove all of the OLE objects in a design. The 
prompt, “All current OLE Linked and Embedded objects will be removed from this Design. Do you 
want to continue?”, appears.

• Edit OLE Links

• Open, Edit, Convert OLE Objects

• Editing an OLE Object’s Content in SailWind Logic

Cut, Copy, and Paste SailWind Logic OLE Objects
Edit OLE Links
Open, Edit, Convert OLE Objects
Editing an OLE Object’s Content in SailWind Logic

Cut, Copy, and Paste SailWind Logic OLE Objects
Editing an OLE linked or embedded object is similar to editing SailWind Logic objects. You can cut, copy, 
and paste OLE objects using the Cut, Copy, and Paste commands from the Edit  menu. You must select 
the OLE object before you can edit the object. You can copy objects from one sheet to another.

Tip
You cannot cut, copy, or paste OLE objects when in the Part Editor.

Procedure
1. Copy or cut the OLE object as follows:

a. Select the OLE object.

b. Click Edit  > Copy  menu item (to copy the object) or the Edit  > Cut  menu item (to cut the 
object).

2. Click the Edit  > Paste  menu item to paste the object.

3. Relocate the pasted object as necessary.

Related Topics
Open, Edit, Convert OLE Objects

Edit OLE Links
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Cut, Copy, and Paste SailWind Logic OLE Objects

Edits of OLE Objects

Editing an OLE Object’s Content in SailWind Logic
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Edit OLE Links
You can edit a linked OLE object's link to change the source file, break the link to the source file, specify 
update options or manually update the linked object.

• Change the object's source file (that is, link the object to a different file).

• Break the link with the source file, making the linked object an embedded object.

• Select the object’s update mode, that is, specify whether the object will be updated automatically 
(whenever the source file changes), or only when you execute an Update command.

• Manually update the linked object.

The following sections of this topic describe how to edit an object’s link:

Changing a Linked OLE Object's Source File
Breaking the Link to a Linked OLE Object's Source File
Setting the Update Mode For a Linked OLE Object
Manually Updating a Linked OLE Object

Changing a Linked OLE Object's Source File
If your design objectives change, you can change the source file that an object links to.

Procedure
1. Click the Edit  > Links  menu item.

2. From the list in the Links dialog box, select the object whose source file you want to change.

3. Click the Change Source  button.

4. In the Change Source dialog box, browse for and select the new source file for the object, and click 
Open.

The object is linked to the new source file.

Breaking the Link to a Linked OLE Object's Source File
If you no longer want to be linked to a source object, you can break the link to an object’s source file so 
that it will not automatically update when the source file changes.

Tip
Once an object's link has been broken, it cannot be reconnected.
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Setting the Update Mode For a Linked OLE Object

Procedure
1. Click the Edit  > Links  menu item.

2. From the list in the Links dialog box, select the object whose link you want to break.

3. Click the Break Link  button, and click Yes  in the popup that appears. The link is broken and the 
object becomes an embedded OLE object.

Tip
If the object whose link you broke is iconized, to view the object you must first convert  on 
page 362 it to a Picture object.

Setting the Update Mode For a Linked OLE Object
You can set the update mode for a linked OLE object and choose between automatic or manual updating.

Procedure
1. Click the Edit  > Links  menu item.

2. From the list in the Links dialog box, select the object whose update mode you want to set.

3. Click the Automatic or Manual radio button to set the update mode:

a. Click Automatic to have the object automatically updated when you open the SailWind Logic 
file, and whenever the source file changes.

b. Click Manual to have the object updated only when you execute an Update command for the 
object.

Manually Updating a Linked OLE Object
You can manually update a linked object whose update mode is set to Manual. (Objects set to Automatic 
update are automatically updated, so manually updating these objects has no effect.)

Procedure
1. Click the Edit  > Links  menu item.

2. From the list in the Links dialog box, select the object you want to update.

3. Click the Update Now  button; the object is updated.

Related Topics
Open, Edit, Convert OLE Objects

Cut, Copy, and Paste SailWind Logic OLE Objects

Editing an OLE Object’s Content in SailWind Logic
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Open, Edit, Convert OLE Objects
Once you insert an OLE object, the name of the object appears at the bottom of the Edit  menu. For 
example, if you insert a video clip, Video Clip Object appears at the bottom of the Edit  menu. If you 
highlight the Video Clip Object command, another menu appears listing all commands you can perform 
on the linked or embedded OLE object. For a Video Clip Object, you can click Play, Edit, or Open.

Tip
The commands that appear for each object depend on the object type; therefore, a Word object 
will not have the same options that a video clip has.

Some of the more common commands you will see relative to OLE objects are:

• Edit  — Use Edit to edit the linked or embedded OLE object in SailWind Logic. You can edit the 
object using all of the source application's commands and tools.

• Open  — Use Open to open the linked or embedded OLE object in the source application. You 
can then edit the object within the source application.

• Convert  — You can convert an OLE object to another object. You can also convert the OLE 
object from displaying as an icon to displaying the actual object; for example, the Word document 
instead of an icon. UseConvert to convert a linked or embedded OLE object to another type of 
object; for example, convert a Word document to a Word picture.

Tip
The object's source application determines what the object can be converted to.

Related Topics
Edit OLE Links

Edits of OLE Objects

Cut, Copy, and Paste SailWind Logic OLE Objects

Editing an OLE Object’s Content in SailWind Logic

Editing an OLE Object’s Content in SailWind Logic
You can edit an object’s content within SailWind Logic (known as in-place visual editing), or in a separate 
window. In either case, you edit its contents as you normally would using all of the source application's 
commands and tools.

In-place Visual Editing
Visual Editing occurs when the source application for a linked or embedded OLE object opens within 
SailWind Logic. You can also edit an OLE object by opening the source application and editing the object 
in the environment in which it was created.

To edit an object within SailWind Logic, double-click on the object.
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Click outside of the object to deactivate visual editing. Updates are automatically reflected in the object.

Restriction:
You cannot edit embedded SailWind programs within SailWind Logic with visual editing.

Tip
When choosing objects for in-place editing, the following exceptions may apply:
• Linked objects cannot be edited in-place: they open in a separate window for editing.
• If the container application does not support in-place visual editing, the object will open in a 

separate window.

Separate Window Editing

You can edit objects outside SailWind Logic, in a separate window. To edit an object outside SailWind 
Logic:

• Select the SailWind Logic object and click the Edit  > (Linked) Document Object  > Edit  menu 
item. You can also select the (Linked) Document Object  > Edit  menu item from the popup 
menu.

• Ctrl+double-click the OLE object to edit in the source application. The source application opens 
and you edit the object.

To update the object in SailWind Logic:

• Click the File  > Update Document  menu item. This forces a redraw of the object.

• Set a preference for SailWind Logic OLE objects in the “Options Dialog Box, General Category” 
on page 595. When you select the Update on Redraw check box, the object in the container 
application will update whenever you perform a redraw in the separate editing window.

For best performance clear this option.

To return to the container application, select the File  > Exit and Return to <host>  menu item.

Tip
If you want to save the object you edit in the separate window, you can click the File  > Save 
Copy As  menu item. The object is really a copy of the original, and this command lets you save 
this copy. You cannot open other files, create new files, or save original designs in the separate 
window.

Related Topics
Open, Edit, Convert OLE Objects

Edit OLE Links

Edits of OLE Objects

Cut, Copy, and Paste SailWind Logic OLE Objects
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OLE and Print/Plot
You can print OLE linked or embedded objects to any Windows-supported printer or plotter. You cannot 
photo plot or pen plot OLE objects. Also, OLE objects do not appear when previewing prints.

See also Plotting Output.

Related Topics
Setting Up a Pen Plotter

Setting Up a Photo Plotter

Printing Output

Deleting OLE Objects
If they are no longer needed in your design, you can delete OLE linked or embedded objects.

Procedure
1. Select the OLE object to delete.

2. Click the Edit  > Delete  menu item, or click the Delete key.

Tip
When you delete a sheet with OLE objects on it, all of the OLE objects are also deleted.

3. To delete all OLE objects in the design, click the Edit  > Delete All OLE Objects  menu item.

This enables you to remove all of the OLE objects in a design.

The prompt, “All current OLE Linked and Embedded objects will be removed from this Design. Do 
you want to continue?” appears.

Redraws of a Screen Containing OLE Objects
When SailWind Logic redraws, SailWind Logic components are redrawn first, then OLE linked or 
embedded objects are redrawn. OLE objects always redraw in the same order and always redraw after 
SailWind Logic objects; therefore, they always appear on top of SailWind Logic components.

You can also choose to update linked and embedded objects when you redraw the work area using the 
Redraw OLE Objects check box on the Options > Global  category. This option is grayed when no OLE 
objects exist.

OLE and View Menu Commands
You can use all of the View  menu commands with OLE linked or embedded objects; you can zoom into 
and zoom out of the objects.
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Changing the OLE Object Background Color
OLE linked or embedded objects are displayed with a solid white background. You may, in some cases, 
prefer to display the OLE object with a transparent background; for example, since a bitmap already 
contains a background, you may prefer to use a transparent background. If your object is a Word 
document, then you may prefer a white background because black text on a transparent background 
results in black on black, or an invisible object.

Procedure
1. Select the OLE object.

2. Right-click and click White Background to change the background color.

A check next to the command indicates that the object will use a white background.

Saving OLE Objects
Linked and embedded objects are automatically saved as part of the schematic when you save a 
SailWind Logic schematic. If you want to save OLE objects separately, use File  > Export  to save the 
objects in an .ole  file. You can then use File  > Import  to import the objects into other designs.

SailWind Logic .ole  files can be opened in other applications that understand the .ole  file format. For 
example, if you insert a Word document into SailWind Logic and then save the Word object, you can later 
open Word and open the Word documents stored in the SailWind Logic .ole  file.

Procedure
1. Click the File  > Export  menu item.

2. In the File Export dialog box,  select the location for the file from the Save in dropdown list.

3. In the File name edit box, type a name for the OLE file you are saving.

4. From the Save as type dropdown list box, select OLE Files (*.ole).

5. Type a name for the OLE file you are saving.

6. Click Save.
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Chapter 21
Using Advanced Procedures

SailWind Logic supports interaction with advanced procedures such as SPICE Simulation and Basic 
scripting. You can set up advanced SPICE design simulations to analyze your design behaviors, and use 
the Basic scripting to automate many repetitive design tasks. You can also view and manage your license 
file information.

Spice Simulation
Basic Scripting
Managing Licensed Options
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Spice Simulation
The Spice simulation in SailWind Logic enables you to set up and analyze your design using advanced 
procedures including setting up Spice Netlists, AC Analysis, DC Source Sweep Analysis, Transient 
Analysis, and applying attributes to your analog designs..

Analog Schematics for Simulation
Creating a SPICE Netlist
Setting Up AC Analysis
Setting Up DC Source Sweep Analysis
Setting Up the SPICE Netlister
Setting Up Transient Analysis
Apply Attributes to Your Analog Design
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Analog Schematics for Simulation
You can create analog schematics and generate netlists for SPICE Simulators. Add analog attributes with 
simulation values to parts and nets for SPICE simulation.

Several analog parts are supplied in the misc  library as examples. In addition, several examples of 
component simulation models are supplied in the Analog Models subfolder of the library.

Note:
Each SPICE model must have a separate .mod  file. A model file can have subcircuit sections, 
but multiple models cannot be stored in one file since there is no mechanism for the software to 
extract the different models from within the file.

Add SPICE Attributes to Library Parts Versus Schematic Parts
Adding SPICE Attributes to Schematic Parts or Nets

Add SPICE Attributes to Library Parts Versus Schematic 
Parts
You can add SPICE attributes to library parts instead of parts in the schematic. When you add attributes 
to schematic parts, you must add them each time you use the part. When you add attributes to parts in 
the library; however, you don't have to add them again.

See also Attributes Overview.

Adding SPICE Attributes to Schematic Parts or Nets
When you add attributes to schematic parts, you must add them each time you use the part. Consider 
adding the attributes to your library parts.

Procedure
1. Select a part or a net, right-click and click Attributes.

2. Add SPICE attributes to the part. You can also click Browse Lib. Attr.  to browse the Attribute 
Dictionary for SPICE attributes.

See also SPICE Netlist Attribute Glossary  in the SailWind Logic Command Reference.

Note:
Use the MODEL attribute to refer to component simulation models. Models take the device 
name with a .mod  extension. Models are searched in the SailWind installation folder, 
SailWind libraries folder, SailWind project folder, and finally the library list using the search 
order. Each SPICE model must have a separate .mod  file. A model file can have subcircuit 
sections, but multiple models cannot be stored in one file since there is no mechanism for 
the software to extract the different models from within the file.
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Related Topics
Creating a SPICE Netlist

Creating a SPICE Netlist
After you add parts (with SPICE attributes) to your schematic, or add SPICE attributes to existing parts, 
you can create a SPICE netlist in preparation for simulation.

Procedure
1. Click the Tools  > SPICE Netlist  menu item.

2. In the Output File Name box, use the default or type the path and name of the SPICE netlist file.

You can also use the Browse  button to search for a path.

3. In the Select Sheets area, select the sheets to include in the SPICE netlist. You can also use:

• Select All  — Selects all sheets in the Select Sheets box.

• Unselect All  — Clears all the selected sheets in the Select Sheets box.

Tip
Only complete schematic sheets can be simulated.

4. If the design is hierarchical, select the Include Subsheets check box to include any underlying 
hierarchy.

5. In the Output Formats box, select the target SPICE software.

6. Click Simulation Setup  to change or enable the default simulation values.

Tip
Your simulation values are saved for future SPICE netlisting.

See also Setting Up the SPICE Netlister.

7. Click OK  to create the SPICE netlist.

An output window displays the resulting netlist. All warnings, errors, and comments during 
netlisting are embedded in the final netlist. You can edit the netlist before starting simulation.

Related Topics
Analog Schematics for Simulation

Setting Up AC Analysis
As part of setting up your SPICE netlister, you can set options specifically for an AC analysis.
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Setting Up DC Source Sweep Analysis

Procedure
1. Click the Tools  > SPICE Netlist  menu item.

2. In the SPICEnet dialog box, click Simulation Setup.

3. In the Simulation Setup dialog box, click AC Analysis.

4. In the Interval area, type the number of points and then select your choice of variation: Decade, 
Octave, or Linear.

5. In the Frequency area, type a Starting and Ending frequency.

Tip
Your simulation setup values are saved for future SPICE netlisting.

For more information on AC Analysis, see the Help in your SPICE simulator.

Related Topics
Setting Up the SPICE Netlister

Setting Up DC Source Sweep Analysis
As part of setting up your SPICE netlister, you can set options specifically for a DC Sweep analysis.

Procedure
1. Click the Tools  > SPICE Netlist  menu item.

2. In the SPICEnet dialog box, click Simulation Setup.

3. On the Simulation Setup dialog box, click DC Sweep.

4. In the Source box, type the name of the voltage or current source.

5. In the Start box, type the starting voltage for the sweep.

6. In the Stop box, type the stopping voltage for the sweep.

7. In the Step box, type the incrementing values for the sweep.

Tip
Your simulation setup values are saved for future SPICE netlisting.

For more information on DC Source Sweep Analysis, see the Help in your SPICE simulator.

Related Topics
Setting Up the SPICE Netlister
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Setting Up the SPICE Netlister
After you add parts (with SPICE attributes) to your schematic, or add SPICE attributes to existing parts, 
you can create a SPICE netlist in preparation for simulation.

Procedure
1. Click the Tools  > SPICE Netlist  menu item.

2. In the SPICEnet dialog box, click Simulation Setup.

3. Select the check boxes beside any analyses you want to enable.

4. Click an analysis button to change default simulation values.

• AC Analysis  — Directs the SPICE simulator to perform frequency analyses

• DC Source Sweep Analysis  — Directs the SPICE simulator to perform operating point 
analyses at specified values

• Transient Analysis  — Directs the SPICE simulator to perform time analyses

• Operating Point  — Directs the SPICE simulator to determine the DC operating point of the 
circuit

Tip
Your simulation setup values are saved for future SPICE netlisting.

For more information on Simulation Setup, see the Help in your SPICE simulator.

Related Topics
Creating a SPICE Netlist

Setting Up AC Analysis

Setting Up DC Source Sweep Analysis

Setting Up Transient Analysis

Setting Up Transient Analysis
As part of setting up your SPICE netlister, you can set options specifically for a Transient analysis.

Procedure
1. Click the Tools  > SPICE Netlist  menu item.

2. On the Simulation Setup dialog box, click Transient. The Transient Analysis dialog box displays.

3. In the Data Step Time box, type the increment for the analysis.
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Apply Attributes to Your Analog Design

4. In the Total Analysis Time box, type the time to end the analysis.

5. In the Time to Start Recording Data box, type the time to start recording data from the analysis.

This is helpful if your simulation files become too large and you are not interested in data from the 
beginning of the analysis.

6. In the Maximum Time Step box, type a maximum time step value.

7. If you do not want SPICE to solve for the quiescent operating point before beginning the transient 
analysis, select the Use Initial Conditions check box.

If this option is enabled, SPICE uses the values specified using IC=... on the various elements as 
the initial transient condition and proceeds with the analysis.

Tip
Your simulation setup values are saved for future SPICE netlisting.

For more information on Transient Analysis, see the Help in your SPICE simulator.

Related Topics
Setting Up the SPICE Netlister

Apply Attributes to Your Analog Design
There is a list of attributes that you can apply to your analog design. Review the list and select those 
attributes that are relevant to your design intent.

Please see the “SPICE Netlist Attribute Glossary” in the SailWind Logic Command Reference.
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Basic Scripting
Basic is a simple scripting language. Like many Windows applications, such as Microsoft Word and Excel, 
SailWind applications include Basic capabilities to enable users to customize their applications using a 
standard scripting language.

Managing Scripts
Creation of Scripts
Run Scripts
Debug Scripts
Accessing Help on the Basic Language
Using the Basic Scripts Dialog Box
Manage the Sax Basic Engine
Basic Sample Scripts
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Managing Scripts
SailWind Logic offers a flexible number of options for managing scripts. You can open existing scripts, 
manage open scripts, edit scripts, edit user dialog boxes to enable user interaction, find automation 
statements, and watch variables. This gives you a high level of control over setting up and managing your 
scripts.

Opening an Existing Script
Manage Open Scripts
Editing a Script
Editing a User Dialog Box
Finding an Automation Statement
Watching a Variable

Opening an Existing Script
Scripts are created in and stored in script files that have a .bas  extension. The default location for .bas 
files is C:\SailWind Projects.

Procedure
1. Click the Tools  > Basic Scripts  > Basic Script Editor  menu item, then click the Open  button.

2. Select the script and then click Open.

You can have up to nine scripts open at the same time.

Note:
A selection of sample scripts is available in the C:\SailWind Projects\Samples\Scripts\Logic 
folder.

Manage Open Scripts
The commands on the Sheet  submenu provide script management methods. Since you can have up to 
nine scripts open at the same time, you can open #uses, close sheets, close multiple sheets, and choose 
scripts to view and edit.

Opening #uses Modules
#Uses modules are Basic scripts that are called from within other scripts. To open these secondary 
scripts:

• In the Basic Script Editor, right-click and select Sheet  > Open Uses.

The #uses modules called in the script appear as script sheets in the Basic Script Editor. They are 
assigned a numbered tab and you can edit or run them.

Closing an Open Script

• In the Basic Script Editor, right-click and select Sheet  > Close.
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Alternatively, you can double-click the script's numbered tab in the gutter.

Closing all Open Scripts

• In the Basic Script Editor, right-click and select Sheet  > Close All.

Viewing a Particular Script

If you have multiple scripts open, you can view a particular open script. You can have up to nine scripts 
open at the same time.

To view a particular script:

• Right-click and select Sheet. Then click the script you want to view from the list of open scripts on 
the submenu. Alternatively, you can click the script's numbered tab in the gutter.

Editing a Script
You can copy or cut selected text from the Basic Script Editor to the Clipboard. You can also paste a 
selection from the Clipboard into the text window. You can also paste text from the Clipboard into other 
applications.

Procedure
1. In the Basic Script Editor, select the text you want to copy or cut.

2. Right-click and click Edit  > Copy  or Cut.

3. Right-click and click Edit  > Paste  to paste the script text.

Your selection is pasted in the Output window at the insertion point.

As an alternative, you can click the Copy, Cut, and Paste  buttons on the Basic Script Editor 
toolbar.

Editing a User Dialog Box
A UserDialog is defined by a Begin Dialog...End Dialog block.

Procedure
1. In the Basic Script Editor, put your cursor in a UserDialog block of the script.

2. Click the Edit UserDialog  button.

See also Sax Basic Editor On Line Help  (C:\<install_folder>\<version>\Programs\sbe5_000.hlp)

Finding an Automation Statement
If you are working with a long script, you can search for particular statements.
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Watching a Variable

Procedure
1. In the Basic Script Editor, click the Object list and select an object type. The Object list shows all 

the objects for the current module. The (General) object groups all of the procedures that are not 
part of any specific object.

2. Click the Procedure list and select a bold procedure. The Procedure list shows all the procedures 
for the current object. Selecting a procedure that is bold locates the procedure in the script.

The statement appears in the Basic Script Editor.

Watching a Variable
Quick Watch shows the value of the expression under the cursor in the immediate window.

Procedure
Right-click and click Quick Watch.

As an alternative, in the Basic Script Editor, click the Quick Watch  button.

See also Sax Basic Editor Online Help.
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Creation of Scripts
You can create scripts to simplify redundant activities.

Creating a Script
Inserting an Automation Statement Using the Object and Procedure Lists
Inserting an Automation Statement Using the ActiveX Automation Members Dialog
Setting the Next Statement
Showing the Next Statement

Creating a Script
You can create a script using the Basic Script Editor.

Procedure
1. Click the Tools  > Basic Scripts  > Basic Script Editor  menu item.

In SailWind Layout and SailWind Logic, the SAX Basic Engine dialog box appears.

2. Click the New  button.

Inserting an Automation Statement Using the Object and 
Procedure Lists
Use the Object and Procedure lists to select and insert a statement. These lists contain the most 
commonly used statements.

Procedure
1. Click the Object list and click an object type. The Object list shows all the objects for the current 

module. The (General) object groups all of the procedures that are not part of any specific object.

2. Click the Procedure list and click a non-bold procedure to insert. The Procedure list shows all 
the procedures for the current object. Selecting a procedure that is not bold inserts the proper 
procedure definition for that procedure.

The statement appears at the bottom of the script.

Inserting an Automation Statement Using the ActiveX 
Automation Members Dialog
Use the ActiveX Automation Members dialog box to insert a statement from the extensive list provided.

Procedure
1. In the Basic Script Editor, right-click and click the Debug  > Browse  menu item.

2. Use the ActiveX Automation Members dialog box to select and insert a statement.
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This dialog box contains an extensive list of statements.

Tip
If the pointer is on any line in the script other than the bottom line, the line is overwritten.

Setting the Next Statement
You can force a particular line in a script to run next. You can only select statements in the current 
subroutine or function.

Procedure
1. In the Basic Script Editor, put your cursor on the line you want to run next.

2. Right-click and click the Debug  > Set Next Statement  menu item.

An instruction pointer appears next to the selected line. This line, and only this line, will run next. If 
you go to other parts of the script, you can return to this line by clicking Show Next Statement.

Showing the Next Statement
In the Basic Script Editor, you can navigate the right mouse button menu to initiate the Show Next 
Statement command.

Procedure
In the Basic Script Editor, right-click and click Debug  > Show Next Statement  menu item.

An instruction pointer indicates the next statement to run.

Tip
Pausing a running script or setting a statement to run next sets the next statement. You can locate 
the set statement from anywhere in the script.
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Run Scripts
You can run an existing script using Run. Run also resumes the playback of a paused script. When you 
run a script, you cannot use the mouse in the workspace.

Running a Script
Pausing a Running Script
Stopping a Running Script

Running a Script
You can run a script using the Macro command in the Basic Script Editor.

Procedure
1. In the Basic Script Editor, open a script file.

2. Right-click and click the Macro  > Run  menu item.

As an alternative, on the Basic Script Editor toolbar, click the Start/Resume  button.

Pausing a Running Script
When running a long script, you may need to pause it to perform some other design activity.

Procedure
1. In the Basic Script Editor, right-click and click the Macro  > Pause  menu item.

2. As an alternative, on the Basic Script Editor toolbar, click the Pause  button.

Tip
If you paused the script, you can also use Run, Step Over, or Step to Cursor  to resume 
running the script. Right-click and select Run  to resume running the script.

Stopping a Running Script
You can stop a running script at any time. However, you cannot resume running a script once you have 
stopped it. When you click Run, the script starts from the beginning.

Procedure
In the Basic Script Editor, right-click and click the Macro  > End  menu item.

As an alternative, on the Basic Script Editor toolbar, click the Stop  button.
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Debug Scripts
When running a script, you can run it step-by-step or to a certain location in the script. To perform these 
debugging tasks, insert breakpoints in the script at the points at which you want the script to stop.

Setting or Removing the Breakpoints
Debug the Scripts
Removing All Breakpoints in the Script
Correction of Run-Time Errors

Setting or Removing the Breakpoints
The ability to set or remove breakpoints is useful when you debug a script. If the Basic engine encounters 
a breakpoint when running a script, it pauses the script.

Procedure
1. Place the cursor on the line to which to add a breakpoint.

2. On the Basic Script Editor toolbar, click the Toggle Breakpoint  button.

As an alternative, in the Basic Editor, right-click and click the Debug  > Toggle Break  menu item.

This action inserts a breakpoint at the current cursor location. A breakpoint marker appears in the 
gutter area.

Note:
When the Basic engine encounters a breakpoint while running a script, it pauses the script. 
The next line in the script is marked with the instruction pointer.

Debug the Scripts
Once breakpoints are inserted, you can debug scripts using the Debug commands.

To run a single line of the script:

• On the Basic Script Editor toolbar, click the Step over  button.

To perform a subroutine call on the current line:

• On the Basic Script Editor toolbar, click the Step into  button.

As an alternative, in the Basic Script Editor, right-click and click the Debug  > Step Into  menu 
item.

To return from the subroutine to the point from which it was called:

• On the Basic Script Editor toolbar, click the Step out  button.

To run a script to a point:
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• In the Basic Script Editor, right-click and click the Debug  > Step to cursor  menu item.

To continue the execution from the current point:

• On the Basic Script Editor toolbar, click the Run  button.

As an alternative, in the Basic Script Editor, right-click and click the Macro  > Run  menu item.

Removing All Breakpoints in the Script
You have the option to remove all breakpoints instead of single breakpoints.

Procedure
In the Basic Script Editor, right-click and click the Debug  > Clear All Breaks  menu item.

This removes all breakpoints in the script.

Correction of Run-Time Errors
If run-time errors occur, the script debugger switches to step-by-step mode and displays a detailed 
message on the status bar. The instruction pointer is set on the line that produced the error. After fixing 
the error, you can resume running the script.

Accessing Help on the Basic Language
While writing or running scripts, you can access Help that provides information and a sample script using 
the Basic language statements.

Procedure
Select or click in an item in color in the edit area of the Basic Script Editor and then press F1.

Help appears for the current statement.

Using the Basic Scripts Dialog Box
The Basic Scripts dialog box provides easy access to your Basic scripts. From there you can edit and 
debug your scripts.

Procedure
1. Click the Tools  > Basic Scripts  menu item, then click Basic Scripts.

2. Select the script you want to manage.

3. To run the script, click Run.

Restriction:
You cannot run multiple scripts at the same time.
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Manage the Sax Basic Engine

Tip
If the selected script has an error during compilation, it automatically opens in the Basic 
Script editor for correction.

4. To edit the script, click Edit. The Sax Basic Engine dialog box appears.

See also Manage the Sax Basic Engine.

5. To add the script to the Basic Scripts  menu, click the In Menu check box.

6. To remove the script from the list, click Unload File.

7. To add a new script to the list, click Load File.

Tip
When loading scripts, note the following:
• You can load up to 32,767 scripts. Scripts are not compiled when they are loaded; they 

are compiled when you run them.
• The list of scripts you load into this dialog box is saved in the VBScripts.ini  file, so they 

load every time you open the Basic Scripts dialog box.

Related Topics
Basic Sample Scripts

Manage the Sax Basic Engine
The Sax Basic Engine dialog box provides access to the Sax Basic Engine Script editor. You can design, 
develop and edit scripts that add to, replace, enhance, or customize existing SailWind Logic features.

Scripts written in the Basic Script editor comply with all Microsoft requirements in terms of Visual Basic 
syntax; therefore, you can play these scripts in any other Visual Basic interpreter, such as Word or Excel. 
However, you cannot run all Basic scripts created outside of the Sax Basic Engine within the Sax Basic 
Engine because the Sax Basic Engine is a subset of Visual Basic. For example, you cannot run the 
Automation samples within the Sax Basic Engine.

• Click the Tools  > Basic Scripts  > Basic Script Editor  menu item, then click New  button.

See also Sax Basic Editor On-line Help.

There are four types of scripts: scripts, code modules, object modules, and class modules.

You can create a script that calls another script. For example, ScriptA can call ScriptB.

You can also create a script that runs a series of scripts, or a "master" script. For example:

'$Include: "scriptA.bas"
'$Include: "scriptB.bas"
'$Include: "scriptC.bas"
Sub Main
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 Call scriptA
 Call scriptB
 Call scriptC
End Sub

Editor Colors
The Basic Script Editor displays source code using different colors. The color is context-sensitive: when 
you place the cursor on the text and press F1, the correct help file opens to the correct help topic. 
For example, if the cursor is on a SailWind Logic Automation Object (purple) when you press F1, the 
Automation Server On-line Help appears.

Table  42. Basic Script Editor Color Representations

Color Represents

Blue Basic Keywords

Black User Variables

Cyan Basic Functions

Purple SailWind Logic Automation Objects or Members

Red Errors

Green Comments
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Basic Sample Scripts
To address common design scenarios, and to provide a starting point for the development of custom user 
scripts, SailWind Logic includes a collection of sample Basic scripts. All sample scripts are commented.

Basic Sample Scripts 00 Through 11
Basic Sample Scripts — RGL Reports
Basic Sample Scripts — Advanced

Basic Sample Scripts 00 Through 11
Samples 00 through 09 provide an overview of Basic if you don't have experience with Basic scripts. 
Samples 10 and 11 provide small SailWind Logic features that add, enhance, or customize a SailWind 
Logic feature.

These files are located in C:\<install_folder>\<version>\Samples\Scripts\Logic\tutorial.

Table  43. Basic Sample Script Listing

Script Filename Description

00
What is a Script.BAS

Empty script demonstrating what a Basic script is and how to 
define it.

01
Using a Message Box.BAS

Demonstrates how to display an OK dialog box.

02
Using a Variable.BAS

Demonstrates a Basic variable: how to assign a value and 
how to get its value.

03
Using a Basic Function.BAS

Demonstrates how to use a standard Basic function and 
display its result in a message box.

04
Using a SailWind Logic 
Function.BAS

Demonstrates Basic interaction with a SailWind Logic 
Automation function.

05
Using If and Then 
Statements.BAS

Demonstrates the If, Then statements.

06
Using a Custom Dialog1.BAS

Demonstrates a simple dialog box using the Basic dialog 
editor.

07
Using a Custom Dialog2.BAS

Demonstrates a standard dialog box using the Basic dialog 
box editor.

08
Using a Custom Dialog3.BAS

Demonstrates a complex dialog box using the Basic dialog 
box editor.
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Table  43. Basic Sample Script Listing  (continued)

Script Filename Description

09
Using it All Together.BAS

Provides a "real life" example. Lists all design files in the 
default files directory. Selecting a file from the list will open 
that file in SailWind Logic.

10
List Of Comps and Nets.BAS

Lists all components and nets.

11
Select by Pin Count.BAS

Enables you to enter a number of pins. All parts with that 
number of pins are selected.

Basic Sample Scripts — RGL Reports
Basic scripts are equivalent to existing RGL reports.

These files are located in C:\<install_folder>\<version>\Samples\Scripts\Logic\rgl samples.

Table  44. Basic Sample Scripts/RGL Reports Listing

Script Filename Description

RGL.BAS Contains a library of functions, which is used by the other scripts 
in this group; the scripts in this group must contain RGL.BAS to 
function.

Net Statistics.BAS Lists all nets in the schematic and identifies any questionable nets.

Part Statistics.BAS Lists all parts in the schematic.

Unused Gates.BAS Lists all unused gates in the schematic.

Unused Pins.BAS Lists all unused pins in the schematic.

Unused.BAS Lists all unused pins and gates in the schematic.

Basic Sample Scripts — Advanced
Advanced Basic script files are located in C:\<install_folder>\<version>\Samples\Scripts\Logic.

Table  45. Basic Sample Scripts/Advanced Listing

Script Filename Description

Add Part.BAS Adds a new gate to the schematic.

Alive Net List.BAS Creates a netlist in Excel, which enables you to cross-probe 
between SailWind Logic objects and the Excel cells containing the 
object names.

Bill of Materials.BAS Produces a bill of materials in a user-customizable format.
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Basic Sample Scripts — Advanced

Table  45. Basic Sample Scripts/Advanced Listing  (continued)

Script Filename Description

Modeless Attributes.BAS Generates a modeless dialog box, which you use to manage part 
attributes.

Modeless QM Part.BAS Generates a modeless dialog box, which you use to manage part 
and gate properties.

Modeless Visibility.BAS Generates a modeless dialog box, which you use to manage gate 
and attribute visibility.

SailWind Layout Net List 
Without Rules.BAS

Generates a netlist report in ASCII format.

SailWind Logic Script 
Wizard.BAS

Generates a Wizard dialog box, which you use to create a Basic 
report.

Sheet Hierarchy to 
Excel.BAS

Creates a sheet hierarchy report in Excel, which enables you to 
cross-probe between SailWind Logic objects and the Excel cells 
containing the object names.
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Managing Licensed Options
You can view and manage your licensed SailWind Logic options. You can view the available options for 
node-locked or floating licenses.

Viewing a License File or License Status
License File Definition

Viewing a License File or License Status
If you are using node-locked licensing, you can view the contents of a license file. If you are using floating 
licenses, you cannot view the actual license file, but you can view the status of the features associated 
with a server license.

Procedure
1. Click the Help  > Installed Options  menu item, then click the License File tab.

2. Select one of these methods to view the license file:

• For Node-locked Licenses  — To view a license file:

i. Select the license file that you want to view from your list of license files.

ii. Click View. The bottom portion of the screen displays the contents of the selected file.

• For Floating Licenses  — To view the status of the features associated with a server license:

i. Select the server license file for which you want to display feature status.

ii. Click Status. The feature usage information appears in the bottom portion of the screen.

Related Topics
Installed Options Dialog Box

License File Definition

License File Definition
This section describes the license file and the possible options enabled in it.

All installed options appear in the Installed Options Dialog Box  on page 394.

Options

FEATURE SailWindLogic paizieda \

394 SailWind Logic Guide



 
Using Advanced Procedures

License File Definition

Controls entry into the program and provides access to the basic SailWind Logic schematic functions. 
This feature is not listed on the Installed Options dialog.
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Chapter 22
Custom Interface

You can customize the interface of SailWind tools by customizing elements of the interface such as 
toolbars, menus, and shortcut keys or by customizing the way windows of the interface are displayed.

Customizing the SailWind Interface
Organizing Windows
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Customizing the SailWind Interface
You can customize the SailWind interface to suit your work style and design work. You can determine 
which toolbars are displayed, add items to toolbars and menus, and create custom toolbars, menus and 
shortcut keys.

To make customizations, use the Customize dialog box. You can invoke the dialog box in two ways:

• From the SailWind interface, click the Tools  > Customize  menu item. All customizations you 
make are applied to the main view of the SailWind tool.

• In a window of the interface (for example, the Output Window), right-click and select Customize. 
You customizations apply only to that window.

Your customizations are saved with your current workspace so that all of the changes you make to 
toolbars, menus, and shortcut keys are present when you work in that workspace again.

Customizing Toolbars
Creation of Custom Commands
Creating a Custom Menu
Adding Items to Toolbars and Menus
Moving Buttons on Toolbars
Moving Items on Menus
Removing Items From Toolbars and Menus
Customizing Shortcut Keys
Assigning Shortcut Keys to Macros
Creating a Command From a Macro and Adding it to a Menu
Customized Appearance of the Screen
Resizing the Sheets List
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Customizing Toolbars
Use the Toolbars and Menus  tab on the Customize dialog box (Tools  > Customize  > Toolbars and 
Menus  tab) to create custom toolbars and shortcut menus.

Tip
To create a custom main menu, use the Commands  tab on the Customize dialog box. See 
Creating a Custom Menu.

See also Moving Buttons on Toolbars.

Creating a Custom Toolbar
Showing or Hiding a Toolbar
Deleting a Custom Toolbar
Renaming a Custom Toolbar
Resetting Toolbars to Defaults

Creating a Custom Toolbar
To create a custom toolbar, you create a new empty toolbar and add items (commands) to it.

Procedure
1. Click the Tools  > Customize  menu item, then click the Toolbars and Menus  tab.

2. In the Toolbars box, click the New  button.

3. Type the name for the toolbar and click OK.

This results in the following:

◦ The new (empty) toolbar appears on the SailWind interface.

◦ TheToolbars and Menus  tab lists the new toolbar, showing it as selected and enabled for 
display (the check box to the left of its name is selected).

4. Drag the toolbar to the place on the SailWind interface where you want it.

5. To add items (commands) to your new toolbar, click the Commands  tab.

6. In the Categories list, select a menu or toolbar name to display commands specific to that menu or 
toolbar. Or select All Commands.

Restriction:
If you are working in a special mode in SailWind Layout or SailWind Logic (for example, 
the Decal Editor in SailWind Layout), some categories of commands are not available for 
customization.
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7. In the Commands list, select the command you want and drag it to the toolbar.

8. When you have finished adding commands, click Close.

Showing or Hiding a Toolbar
To increase space in the software interface, you can show the toolbars you need to use and hide others.

Procedure
1. Click the Tools  > Customize  menu item, then click the Toolbars and Menus  tab.

2. In the Toolbars list, select the toolbar.

3. To display the toolbar in the interface, select the check box to the left of its name. To hide the 
toolbar, clear the check box.

4. Click Close.

Tip
For information on other ways you can customize the appearance of toolbars and menus, 
see Customized Appearance of the Screen.

Deleting a Custom Toolbar
If you decide it is no longer needed, you can delete a custom toolbar (a toolbar you created).

Restrictions and Limitations
You cannot delete a system toolbar.

Procedure
1. Click the Tools  > Customize  menu item, then click the Toolbars and Menus  tab.

2. In the Toolbars list, select a custom toolbar. Then click the Delete  button.

Renaming a Custom Toolbar
After it has been created, you can rename a custom toolbar (a toolbar you created).

Restrictions and Limitations
You cannot rename a system toolbar.

Procedure
1. Click the Tools  > Customize  menu item, then click the Toolbars and Menus  tab.

2. In the Toolbars list, select a custom toolbar and click the Edit  button.

3. In the Toolbar Name dialog box, type the new name and click OK.
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Resetting Toolbars to Defaults

Resetting Toolbars to Defaults
If you decide changes you have made are no longer needed, you can reset one or all system toolbars to 
their default buttons.

Procedure
1. Click the Tools  > Customize  menu item, then click the Toolbars and Menus  tab.

2. In the Toolbars list, select the toolbar.

3. Click Reset.

Tip
To reset all system toolbars to defaults, click Reset All.

SailWind Logic Guide 401



Custom Interface
Creation of Custom Commands  

Creation of Custom Commands
Use the Commands  tab to create commands that you can then use as selections on menus or as buttons 
on toolbars and to create custom menus.

Creating a Custom Command
Defining Properties for a New Command
Editing a Custom Command
Deleting a Custom Command

Creating a Custom Command
You can create a custom command from a command that already exists as a menu item or toolbar button. 
To create this kind of command, you select an existing command on which to base your new command. 
Then you define the properties of your new command.

You can also create a custom command from a macro command file. See Creating a Command From a 
Macro and Adding it to a Menu.

Procedure
1. Click the Tools  > Customize  menu item, then click the Commands  tab.

2. In the Categories list, click a menu or toolbar name to display items (commands) specific to that 
menu or toolbar, or click All Commands.

Tip
If you made macro commands (on the Macro Files  tab) available as commands, the 
Categories list includes the Macro category and the Commands list includes the macros. 
For more information, see Creating a Command From a Macro and Adding it to a Menu.

3. In the Commands list, select the command on which you want to base your custom command, and 
then click the New  button.

4. In the Add Command dialog box, specify the properties of your new command:

a. In the Command name box, type the name of the command.

b. In the Description box, type a description of the custom command.

c. If an image was associated with the original command, select “Use Default Image” to use that 
same image with your custom command. Select “Select User-Defined Image” to use a different 
image, edit an image, or create a new image.

d. Click OK  to close the Add commands dialog box and return to the Customize dialog box.

5. If you are finished with all customizations, click Close.

Tip
To add the command to a toolbar or menu, click the command and drag it from the 
Commands list to the toolbar or menu.
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Defining Properties for a New Command
Once you create a new command, you can use the Commands  tab to set the properties for a new 
command.

Procedure
1. Click the Tools  > Customize  menu item, the click the Commands  tab.

2. In the Commands list, click New, then click the New  button.

The Add command dialog box opens.

3. In the Command name box, type the name of the new command.

4. (Optional) In the Based on box, type the name of the command on which the new command is 
based.

5. In the Description box, edit the command description, for example, to represent the argument 
values you added.

6. If an image was associated with the original command, do one of the following:

• Click “Use Default Image”.

• Click “Select User-defined Image”, then select a image, edit an image, or create a new one.

7. Click OK  to close the Add Command dialog box and return to the Customize dialog box.

Editing a Custom Command
You can edit only custom commands (commands you created). You cannot edit system commands.

Procedure
1. Click the Tools  > Customize  menu item, then click the Commands  tab.

2. In the Categories list, click a menu or toolbar name to display items (commands) specific to that 
menu or toolbar, or click All Commands.

3. In the Commands list, select a command and click the Edit  button.

4. In the Edit commands dialog box, change the properties of your custom command:

a. In the Command name box, type the name of the command.

b. In the Description box, type a description of the custom command.

c. If an image was associated with the original command, select “Use Default Image” to use that 
same image with your custom command. Choose “Select a User-Defined Image” to use a 
different image, edit an image, or create a new image.

d. Click OK  to close the Edit commands dialog box and return to the Customize dialog box.
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5. When you are finished with all customizations, click Close.

6. Click OK  to close the Edit commands dialog box and return to the Customize dialog.

Deleting a Custom Command
You can delete only custom commands (commands you created). You cannot delete system commands.

Procedure
1. Click the Tools  > Customize  menu item, then click the Commands  tab.

2. In the Categories list, click a menu or toolbar name to display items (commands) specific to that 
menu or toolbar, or click All Commands.

3. In the Commands list, select a command and click the Delete  button.

4. Click Close.

Related Topics
Adding Items to Toolbars and Menus

Resetting Toolbars to Defaults

Creating a Custom Menu
Create a custom menu, you first create a new empty menu and then add items (commands) to it:

Procedure
1. Click the Tools  > Customize  menu item, then click the Commands  tab.

2. In the Categories list, select New Menu.

3. In the Commands list, select New Menu and drag it to the location you want.

• To create a top-level menu, drag the new menu to the Menu Bar.

• To create a submenu, drag it over an existing menu name.

4. Click your new menu to select it. Then right-click and select Button Appearance.

5. In the Button text field, type the name for the menu and click OK.

Leave the Customize dialog box open.

6. To add items (commands) to your new menu, click the Commands  tab.

7. In the Categories list, select a menu or toolbar name to display commands specific to that menu or 
toolbar. Or select All Commands.
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Adding Items to Toolbars and Menus

Restriction:
If you are working in a special mode in SailWind Layout or SailWind Logic (for example, 
the Decal Editor in SailWind Layout), some categories of commands are not available for 
customization.

8. In the Commands list, select the command you want and drag it to the menu.

9. When you have finished adding commands, click Close.

Adding Items to Toolbars and Menus
If there are commands that you frequently use that are not on the standard toolbars and menus, or you 
want to include them on frequently-used toolbars and menus, you can add these items.

Procedure
1. Click the Tools  > Customize  menu item, then click the Commands  tab.

2. In the Categories list, select a toolbar or menu name to display commands specific to that menu or 
toolbar, or select All Commands.

Restriction:
If you are working in a special mode in SailWind Layout or SailWind Logic (for example, 
the Decal Editor in SailWind Layout), some categories of commands are not available for 
customization.

3. In the Commands list, select the command you want and drag it to the toolbar or menu.

Tip
To remove an item from a toolbar or menu (while the Customize dialog box is open), click 
the item and drag it outside the toolbar or menu.

4. When you have finished adding commands, click Close.

Related Topics
Moving Items on Menus

Moving Buttons on Toolbars
You can rearrange buttons on a toolbar. You can also move or copy a button from one toolbar to another.
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Procedure
1. Click the Tools  > Customize  menu item.

2. With the Customize dialog box is open, click the toolbar button and drag it to a new place on the 
same toolbar or to a different toolbar.

Tip
Instead of moving a button, you can copy it and move the copy. Press and hold the Ctrl key 
while dragging the button.

Moving Items on Menus
You can rearrange items on a menu. You can also move or copy an item from one menu to another.

Restrictions and Limitations
To move menu items, the Customize dialog box must be open.

Procedure
1. Click the Tools  > Customize  menu item.

2. In the main window of the SailWind application, display the menu containing the item you want to 
move.

3. Click the menu item and drag it to its new location on the same menu or to a different menu.

Tip
Instead of moving a menu item, you can copy it and move the copy. Press and hold the Ctrl 
key while dragging the item.

4. Click Close.

Related Topics
Adding Items to Toolbars and Menus

Resetting Toolbars to Defaults

Removing Items From Toolbars and Menus
If there are items that your do not use or want to appear, you can remove a menu item or toolbar button.

Procedure
1. Click the Tools  > Customize  menu item.

2. With the Customize dialog box is open, drag the item outside the toolbar or menu.
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Removing Items From Toolbars and Menus

3. Close the Customize dialog box.

Note that you can reset a toolbar or shortcut menu back to its default list of items. See Resetting 
Toolbars to Defaults.

Related Topics
Adding Items to Toolbars and Menus
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Customizing Shortcut Keys
You can create and customize shortcut keys by using the Keyboard and Mouse  tab of the Customize 
dialog box (Tools  menu > Customize  > Keyboard and Mouse  tab).

Creating a New Shortcut Key
Listing Shortcut Keys
Expressions in Shortcut Keys
Deleting a Shortcut Key
Resetting Default Shortcut Keys

Creating a New Shortcut Key
You create shortcuts that apply in any mode. Thus, the same shortcut key may have different functionality 
depending on the mode in which you are working.

Restrictions and Limitations
The first character may consist of the following, plus Alt, Ctrl, or Shift modifiers:

• All printable characters including Space and Tab

• All function keys

• Extended keys: Up, Down, Left, Right, Insert, Delete, Home, PageUp, PageDown, End

• Numerical keypad keys (when Num Lock is off): Up, Down, Left, Right, Insert, Home, PageUp, 
PageDown, Del, End, /, *, +, -

• Mouse pointer events: Click, Double-click, RotateForward, RotateBackward

Restriction:
Mouse pointer events cannot be combined with key sequences, although the Ctrl, Alt, and 
Shift modifiers are allowed.

Subsequent characters may consist of the following:

• Alphanumeric (a-z0-9)

Note:
There are some exceptions: Some combinations, like Alt+Tab, are intercepted by Windows and 
thus are not available.
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Listing Shortcut Keys

Procedure
1. Click the Tools  > Customize  menu item, then click the Keyboard and Mouse  tab.

2. In the Mode box, select the mode to which you want to apply the shortcut.

The available commands for that mode appear in the Commands box.

3. In the Commands box, select the command for which you want to create a new shortcut.

If a shortcut already exists, it appears in the Current shortcuts box.

Tip
To replace an existing shortcut, click Delete  to remove the existing shortcut, and create a 
new shortcut for the command.

4. Above the Current shortcuts box, click the New  button to open the Assign shortcut dialog box.

5. Select one of the following types of shortcut:

• To assign shortcut keys, select “Press new shortcut key(s)”, and then press the keys that you 
want to use.

Tip
As you enter the new shortcut, similar shortcuts appear in the Similar shortcuts assigned 
to other commands box. This helps you to avoid creating a new shortcut that conflicts 
with an existing shortcut.

• To create a mouse action, select “or select a pointer event”, and then select a combination of 
list box options, mouse button events, and modifier keys.

6. Click OK  to close the Assign shortcut dialog box.

The new shortcut appears in the Current shortcuts box on the Customize dialog box.

Listing Shortcut Keys
You can create a table of commands and the shortcuts assigned to them in an HTML file, letting you 
share the information over the Web with other members of the design team.

Procedure
1. Click the Tools  > Customize  menu item, then click the Keyboard and Mouse  tab.

2. Click Report  and then select or type the HTML filename, then click Save.

A hyperlink to the file appears in the Output window, under the Status  tab.

Expressions in Shortcut Keys
You can substitute a regular expression for characters in shortcut key command arguments.
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Table  46. Expressions in Shortcut Keys

Expression Use to

* Match any number of characters.

? Match any one character.

[set] Match any character in the specified set.

 Tip
A set is composed of characters or ranges.

A range has the form: Character Hyphen Character, such as A-Z or 0-9.
The minimum set of characters supported in a set consists of [0-9a-zA-Z_].

[!set] or [^set] Match any character not in the specified set.

\ To suppress the special syntactic significance of the characters ` [ ] * ? ! ^ - \ ' 
within a set, and to match the character exactly.

The following table shows examples of regular expressions used in command arguments using the 
preview.pcb design, see Table 47.

Table  47. Shortcut Key Expression Examples

Shortcut key Result

H A* Highlights all nets starting with A, such as A00, A01, A02.

H +?? Highlights all nets starting with +, having two digits or characters after 0, such as 
+5V.

H A?0 Highlights all nets starting with A, ending with 0, and with any character in 
between, such as A00 and A10.

H [C-D]* Highlights all nets starting with C or D, such as CLKIN, D00.

H [!C-D]* Highlights all nets not starting with C or D, such as A00, GND.

Deleting a Shortcut Key
Delete shortcuts you no longer want to use, or as the first step to changing an existing shortcut.

Procedure
1. Click the Tools  > Customize  menu item, then click the Keyboard and Mouse  tab.

2. In the Mode box, select the mode for the shortcut you want to delete.

The available commands for that mode appear in the Commands box.

3. In the Commands list, select the command whose shortcut you want to delete.
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Resetting Default Shortcut Keys

4. In the Current shortcuts list, select the shortcut you want to delete.

5. Click the Delete  button.

Resetting Default Shortcut Keys
If you have made modifications that you no longer require, you can restore all shortcut keys to the default 
settings.

Procedure
1. Click the Tools  > Customize  menu item, then click the Keyboard and Mouse  tab.

2. Click Reset All.

3. On the confirmation dialog box, click Yes.

Assigning Shortcut Keys to Macros
To simplify your design tasks, you can create a shortcut key that executes a macro.

Tip
To assign a macro to a shortcut key, the macro command file (.mcr) must already exist. You 
can create a macro by recording it in a SailWind tool or scripting it in Macro language. For more 
information, see Macros.

Procedure
1. Click the Tools  > Customize  menu item, then click the Macro Files  tab.

2. In the Macro Command Files area, click the New  button.

3. In the Open macro file dialog box, select the macro file you want, and then click Open.

The SailWind tool loads the macro and makes it available for use as a command (the check box to 
the left of the macro name is selected).

Tip
To close the macro file or make it unavailable in the Customize dialog box, clear the check 
box next to the macro name.

4. To assign the macro to a shortcut key, click the Keyboard and Mouse  tab.

5. In the Mode list, select All modes.

6. In the Commands area, double-click Macros to display a list of available macros, and then select 
the macro you want.

7. In the Current Shortcuts area, click the New  button.

The SailWind tool displays the Assign shortcut dialog box.
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8. Select one of the following types of shortcut:

• To assign shortcut keys, select “Press new shortcut key(s)”, and then press the keys that you 
want to use. For detailed information about rules and restrictions for creating shortcut keys, see 
the restrictions and limitations section of Creating a New Shortcut Key.

Tip
As you enter the new shortcut, similar shortcuts appear in the “Similar shortcuts assigned 
to other commands” box. This helps you to avoid creating a new shortcut that conflicts 
with an existing shortcut.

• To create a mouse action, select “or select a pointer event”, and then select a combination of 
list box options, mouse button events, and modifier keys.

9. Click OK  to close the Assign shortcut dialog box.

The new shortcut appears in the Current shortcuts box on the Customize dialog box.

Creating a Command From a Macro and Adding it 
to a Menu
You can create commands from macro files and add them to toolbars and menus.

Tip
To create a command from a macro command file or add it to a menu, the macro command file 
(.mcr) must already exist. You can create a macro by recording it in a SailWind tool or scripting it 
in Macro language. For more information, see Macros.

Procedure
1. Click the Tools  > Customize  menu item, then click the Macro Files  tab.

2. Click the New  button.

3. In the Open macro file dialog box, select the macro file you want to use as a command. Then click 
Open.

The SailWind tool loads the macro and makes it available for use as a command (the check box to 
the left of the macro name is selected).

Tip
To close the macro file, or make it unavailable in the Customize dialog box, clear the check 
box next to the macro name.

4. To add the macro to the menu, click the Commands  tab.

5. From the Categories list, select Macros.

6. In the Commands list, select the macro and drag it to the menu.
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7. When you finish adding macros, click Close.

Tip
You can use the same steps to add macros to shortcut menus and toolbars.

Related Topics
Adding Items to Toolbars and Menus

Customized Appearance of the Screen
You can customize the SailWind interface by toggling the appearance of tooltips, changing the button 
icon size, enabling personalized menus (shortened menus based on usage), changing the menu 
display, changing the Microsoft visual style of the windows and dialog boxes, and changing the interface 
language.

For more information, see “Customize Dialog Box, Options Tab”  on page 523.

Resizing the Sheets List
You can change the width of the Sheets list on the Standard toolbar of the Schematic Editor.

Procedure
1. In the Schematic Editor, click the Tools  > Customize  menu item.

2. On the Standard toolbar, select the Sheets list box.

3. Resize as needed.

4. Click Close.

Restriction:
You cannot use the Alt key to resize the Sheets list.
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Organizing Windows
You can customize the way windows appear in your workspace. Use the available options to show 
windows, hide windows, detach a window from the current view, attach a window to the current view, 
embed windows within other windows, and manage your windows tabs.

Showing Windows
Hidden Windows
Detaching Windows From the Current View
Attach Windows to the Current View
Embed Windows Within Other Windows
Managing Window Tabs

Showing Windows
When you first start the application, several windows display. You can show, hide, and automatically hide 
any of the windows in the application.

Procedure
On the View  menu, click the name of the window you want to show.

Your choices may include Navigation Window, Output Window, Project Explorer, Help Window, 
Spreadsheet, and Shortcut Dialog.
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Hidden Windows
When the application opens, several windows are open in addition to your workspace. You can close 
some of these windows or hide them automatically to maximize your design space.

Closing Windows
Hiding Windows Automatically

Closing Windows
If you do not want a particular window to appear in the workspace, you can hide windows by closing them 
manually.

Procedure
1. Move your pointer to the title bar of the window you want to hide.

2. Click the small downward pointing arrow  on the right side of the window's title bar.

3. In the resulting menu, click Hide.

The window closes.

Hiding Windows Automatically
You can also set a window to hide automatically so that it appears when you hover the pointer near it, and 
automatically minimizes when you move the pointer away from it.

Procedure
1. Move your pointer to the right side of the title bar in the window you want to hide.

2. Click the thumbtack  in the window's title bar.

The thumbtack picture changes to point sideways . A new bar appears on the side of the 
interface. The side on which the bar appears depends on the location of the window. For example, 
if the Project Explorer is located on the left side of the user interface, when you click the Auto Hide 
setting from the menu, the new bar appears on the left side of the interface.

The new bar contains a tab that has the same name as the window.

3. Hover over the tab in the new bar.

The window reappears, covering the application.

4. Move the pointer away from the window. The window minimizes to a tab.

Tip
To turn off the Auto Hide feature, hover over the tab in the new bar so the window 
reappears. Then repeat steps 1-2 in reverse.
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Detaching Windows From the Current View
You can detach a window from the current view. This is called floating. A floating window is not attached 
to the current view; instead, it hovers, blocking the view to anything below it.

Restrictions and Limitations
You cannot float a window that is currently set to hide automatically. Turn off the Auto Hide feature before 
floating a window.

Procedure
Double-click the window's title bar. The window detaches and you can move it to any part of the screen.

Tip
To undo the floating, see Attach Windows to the Current View.
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Attach Windows to the Current View
You can attach a window to the current view. This is called docking. A docked window is attached to the 
current view, and therefore does not block the view to anything below it. You can dock a window in its last 
docked location, or dock a window to a different location.

Docking to the Last Location
Docking to a New Location

Docking to the Last Location
If you have moved a window, you can use a title bar keystroke command to dock it to its last docked 
location.

Procedure
Double-click the window's title bar. The window reattaches to the interface.

Docking to a New Location
You can use a drag operation to dock a window to a new location.

Procedure
1. Using the title bar, drag the window.

When you start dragging the window, additional graphics appear in the user interface. At the edges 
of the user interface, arrows containing graphics appear, as shown in Figure 7:

Figure 7. Window Dragging Graphic

Tip
A similar group of arrows appears in a group near the center of the screen. Ignore that 
group of arrows for this procedure.

2. While dragging the window, hover over one of the arrows on the edge of the user interface. For 
example, hover over the arrow on the left side of the user interface.

A transparent colored block appears along the side of the user interface to which you are pointing. 
This block indicates where the window will be docked when you release the mouse button. For 
example, if you hover over the arrow on the left side of the user interface, a block appears along 
the left side of the screen, as shown in Figure 8.
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Figure 8. Docking a Window

3. Release the mouse button while hovering over the arrow that indicates where you want to dock the 
window.

The window docks to the user interface, and the other windows in the user interface resize.
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Embed Windows Within Other Windows
In addition to attaching a window to a side of the user interface, you can embed a window within another 
window, so that it shares the window space with the original window, or becomes a tab within the original 
window.

Two Windows Sharing One Window Space
Creating Tabs Within Windows

Two Windows Sharing One Window Space
Use a drag operation to embed a window and share another window's space.

Procedure
1. Using the title bar, drag a window into another window.

When you start dragging a window, additional graphics appear in the user interface. A group of 
arrows containing graphics appears in the center of the window you are dragging, as shown in 
Figure 9. Depending on the window you are dragging, the group of arrows may also have a tab 
graphic in the center.

Figure 9. Dragging a Window—Arrow Group

Tip
A similar group of arrows appears at the sides of the user interface. Ignore those arrows for 
this procedure.

2. While dragging the window, hover over one of the arrows. For example, hover over the left arrow.

A transparent colored block appears along the side of the window you are dragging, as shown 
in Figure 10. This block indicates where the window will be docked when you release the mouse 
button. For example, if you hover over the left arrow, a block appears along the left side of the 
Project Explorer.
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Figure 10. Dragging and Docking a Window

3. Release the mouse button while hovering over the arrow that indicates where you want to dock the 
window.

The window is embedded within another window, both sharing the space the original window 
occupied.

Tip
To maximize your workspace, try setting these embedded windows to hide automatically. 
Ctrl+click the thumbtack in one of the window's title bars, and all of the windows within the 
original window frame hide automatically.

Creating Tabs Within Windows
Embed a window and use the whole space by creating tabs.

Procedure
1. Using the title bar, drag a window into another window.

When you start dragging a window, additional graphics appear in the user interface. A group of 
arrows containing graphics appears in the center of the window you are dragging, as shown in 
Figure 11. Depending on the window you are dragging, the group of arrows may also have a tab 
graphic in the center.

Figure 11. Dragging and Docking a Window—Arrow Commands
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Tip
A similar group of arrows appears at the sides of the user interface. Ignore those arrows for 
this procedure.

2. While dragging the window, hover over the tab graphic.

A transparent colored block appears over the window you are dragging, as shown in Figure 12. 
This block indicates where the window will be docked when you release the mouse button. For 
example, if you hover over the tab in the Project Explorer window, a block appears over the Project 
Explorer.

Figure 12. Dragging a Window—Transparent Block

3. Release the mouse button while hovering over the tab.

The window is embedded as a tab within a window, as shown in Figure 13. You can click each tab 
to access each window.
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Figure 13. Window Embedded as a Tab

Tip
To maximize your workspace, try setting these embedded windows to hide automatically. 
Ctrl+click the thumbtack in one of the window's title bars, and all of the windows within the 
original window frame hide automatically.
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Managing Window Tabs
Some of the windows in the user interface contain tabs. However, you may decide you do not like the 
organization or grouping of the tabs. You can create additional tabs by embedding windows within other 
windows.

For more information, see “Embed Windows Within Other Windows”  on page 419

Rearranging Tabs in a Window
Moving Tabs Between Windows
Converting Tabs to Windows

Rearranging Tabs in a Window
You can only rearrange tabs that you created by embedding a window within one of the docking windows. 
You cannot rearrange regular tabs, such as those in the Output window.

Procedure
Drag the tab to a new position within the row of tabs.

Moving Tabs Between Windows
You can only move tabs that you have embedded in other windows. In windows that have tabs by default 
(such as the Output Window in SailWind Router), you cannot move the tabs. You can only rearrange 
them. For information on rearranging tabs, see the previous section.

See also “Embed Windows Within Other Windows”  on page 419.

Procedure
1. Drag the tab to a new window.

When you start dragging, the tab automatically behaves like a window.

2. Place the tab as you would a window.

See also “Organizing Windows”  on page 414.

Converting Tabs to Windows
You can use a drag operation to create a new window from a tab.

Procedure
1. Drag the tab.

When you start dragging, the tab automatically behaves like a window.

2. Release the mouse button. Make sure the pointer is not over any arrow graphics.

You now have a floating window.
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3. Place the tab as you would any floating window.

See also “Organizing Windows”  on page 414.
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Chapter 23
Crash Detection, BMW and BLT

If unexpected behaviors occur with the application, you can use crash detection to capture the crash 
event. You can then use the Basic Media Wizard and Basic Log Test tools to analyze the event and better 
understand the circumstances that may have caused the crash. You can capture all of this data into a log 
file that can be forwarded to SailWind Technical Support for further analysis and support.

Crash Detection
BMW and BLT
Session Log Files
Session Media Files
Replaying Session Playback Media With BLT
The /BMW Command Line Switch
Scripting and Macros

Crash Detection
The Error Detected dialog box opens at a crash and enables you to save a report of the SailWind 
environment as well as pertinent files into a compressed Dump File for troubleshooting.

This Error Detected dialog box is inaccessible unless the software crashes and crash detection is enabled 
in the software .ini  file.

Crash detection is controlled by the CrashDetection  switch in the.ini  file; it is turned off by default.

• If no CrashDetection  switch exists in the.ini  file or if, in the [General] section of the.ini  file, the 
switch exists with a value of 0 (zero), then crash detection is turned off. No report is created of the 
environment at the time of the crash.

• If the CrashDetection  switch exists in the [General] section of the.ini  file, or if the switch exists 
with a value of 1, then crashes are detected and the Error Detection dialog box appears.
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BMW and BLT
BMW (Basic Media Wizard) and BLT (Basic Log Test) are tools that you can use to record and play 
back SailWind Logic, SailWind Layout and SailWind Router sessions. They are particularly useful as a 
means of supplying information to SailWind Software Support engineers trying to identify and resolve any 
problematical behavior you may encounter.

If you report problematical behavior for one of the SailWind tools to Technical Support, Tech Support 
engineers may ask you to use BMW to record session playback media documenting the actions that 
caused the problem. Tech support engineers can then replay the session with BLT to help them identify 
and resolve the problem.

Creation of Session Playback Media With BMW
Creating Session Playback Media for a Normal Session
Automatically Creating Session Playback Media for a Crashed Session
Manually Creating Session Playback Media for a Crashed Session

Creation of Session Playback Media With BMW
To create session playback media, BMW session logging must be enabled when the problem occurs. If 
session logging was not enabled when you encountered the problem, you must recreate the actions that 
caused the problem in a new session with session logging enabled.

Also, depending on whether the problem you want to document caused the SailWind tool to crash, you 
can create session playback media based on either the current or the immediately previous SailWind tool 
session.

The following table specifies which of the procedures described below you must use to create session 
playback media.

Was logging
enabled?

Did the SailWind
tool crash?

Then use this procedure.

Yes No Creating Session Playback Media for a Normal Session

No No Creating Session Playback Media for a Normal Session

Yes Yes Automatically Creating Session Playback Media for a Crashed 
Session

No Yes Manually Creating Session Playback Media for a Crashed 
Session

Creating Session Playback Media for a Normal 
Session
You can use the Basic Media Wizard (BMW) to create session playback media when the session you are 
recreating did not cause a SailWind tool crash.
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Automatically Creating Session Playback Media for a Crashed Session

Procedure
1. Start the SailWind tool, but do not open the file which you encountered the problematical behavior. 

(You must enable session logging before you open the file.)

2. Type the modeless command BMW ON  and press Enter to enable session logging.

Logging remains enabled for this and all future sessions until you disable it with the BMW OFF 
command.

3. Open the file in which you encountered the problematical behavior.

4. Perform the series of actions that produced the problematical behavior.

The series of actions, as well as changes to the board or to the configuration, are stored in the 
Session Log Files  for the current session.

5. Type BMW  (the modeless command) and press the Enter key.

6. In the Media Wizard dialog box, click “Create Media from Current Session”.

7. Type your initials in the User Initials box. (They are included in the playback media filenames to 
identify the files as yours.)

8. To delete all entries in the session log file between the first Open and the last Save command, click 
“Delete Actions Before Last Save”.

You can do this to eliminate any actions you may have performed before beginning the series 
of actions that produced the problematical behavior. This makes it easier for the Tech Support 
engineer to identify the problem.

9. Click OK  to create the Session Media Files.

Automatically Creating Session Playback Media for 
a Crashed Session
You can use the Basic Media Wizard (BMW) to create session playback media when the session you are 
recreating caused the SailWind tool to crash, and none of the listed restrictions applies.

Restrictions and Limitations

• This procedure works only if the previous (crashed) session started with BMW logging already 
enabled and logging remained enabled throughout the session.

• This procedure does not give useful results if any additional instance of the SailWind tool ran 
concurrently (for any period) with the previous (crashed) session.

Procedure
1. Start the SailWind tool, but do not  open the file which you encountered the problematic behavior. 

(You must  enable session logging before  you open the file.).

2. Type the modeless command BMW ON  and press the Enter key to enable session logging.

Logging remains enabled for this and all future sessions until you disable it with the BMW OFF 
command.
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3. Open the file in which you encountered the problematical behavior.

4. Perform the series of actions that produced the problematical behavior.

The series of actions, as well as changes to the board or to the configuration, are stored in the 
Session Log Files  for the current session.

5. After the crash, restart the SailWind tool.

A dialog box is displayed asking if you want to save media files for the crashed session. Click Yes 
to create the Session Media Files.

Manually Creating Session Playback Media for a 
Crashed Session
You can use the Basic Media Wizard (BMW) to manually create session playback media when the 
session you are recreating caused the SailWind tool to crash, and the automatic procedure cannot be 
used due to one of the restrictions listed in that section.

The automatic procedure is described in Automatically Creating Session Playback Media for a Crashed 
Session.

Procedure
1. Start the SailWind tool, but do not  open the file which you encountered the problematic behavior. 

(You must  enable session logging before  you open the file.).

2. Type the modeless command BMW ON  and press the Enter key to enable session logging.

Logging remains enabled for this and all future sessions until you disable it with the BMW OFF 
command.

3. Open the file in which you encountered the problematical behavior.

4. Perform the series of actions that produced the problematical behavior.

The series of actions, as well as changes to the board or to the configuration, are stored in the 
Session Log Files  for the current session.

5. After the crash, restart the SailWind tool.

6. Type BMW  (the Modeless command) and press Enter.

7. In the Media Wizard dialog box, click “Create Media from Previous Session”.

8. Type your initials in the User Initials box to identify your session playback media files.

9. Click OK  to create the Session Media Files.

Session Log Files
Whenever BMW session logging is enabled, two sets of session log files are maintained in the \SailWind 
Projects  folder. These logs record actions performed in the current session, and in the immediately 
previous session.

BMW names these files as follows:
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Session Media Files

Current Session Log Files Previous Session Log Files

<pads_tool>_Next.log <pads_tool>_NextBak.log

<pads_tool>_Next.reg <pads_tool>_NextBak.reg

<pads_tool>_Next.ini <pads_tool>_NextBak.ini

These files are dynamic; each time you start a session, the current session log files are renamed as the 
previous session log files, and new current session log files are created. The contents of the old previous 
session log files are lost.

Whenever you elect to create session media files for a session, the appropriate set of these log files is 
saved in a permanent location, as described in Session Media Files.

Tip
You may see a log file named <pads_tool>_Session.log  listed in the \SailWind Projects  folder. 
This file is unrelated to the session playback media created by BMW.

Session Media Files
Each time you create session playback media, BMW creates a new session media folder in the \SailWind 
Projects folder, and copies into it:

• The .pcb  or .sch  file for which you are recording the session

• The Session Log Files  for the session. BMW then renames these files based on the session 
media folder name.

The session media folder is named <month><day><initials><sequential letter>, where:

• <month><day> is the date.

• <initials> are letters you type in the Media Wizard dialog box to personalize the media files.

• <sequential letter> is a letter automatically assigned to sequence the directories created on a 
specific date.

Example:  \SailWind Projects\0530jsb  represents a session media folder created on May 30, using the 
initials js, and that was the second session media folder created on that day.

When creating the session playback media, the following files are written to the session media folder:

Replaying Session Playback Media With BLT
You can use BLT to replay session playback media created by BMW.
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Procedure
1. Type BLT  (the Modeless command) and press Enter.

2. Select the session playback media from the Media Directories list and click OK.

The session is replayed.

Tip
To personalize the media folder and session playback media filenames, select a media 
session from the Media Directories list, type the new name into the New name box, and 
then click Rename.

The /BMW Command Line Switch
You can use a command line switch in the startup options of the software if you want to automatically 
record every SailWind Layout session.

If you want BMW to automatically prompt you to create media from the previous session each time you 
start a SailWind tool, open the SailWind tool using the /BMW command line switch. Or use /BMW-xx 
(where xx  represents your initials, which are used in folder and filenames to identify them as yours).

When you use BMW as a command line option, it creates media of the previous session; use the BMW 
modeless command to create media of your current session.

Scripting and Macros
All scripting and macro documentation has been moved into a separate manual.

It can be found in the SailWind Logic Command Reference Manual.
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Chapter 24
SailWind Logic GUI Reference

The section contains information on all of the GUI elements in SailWind Logic.

AC Analysis Dialog Box
Add Attribute Label Dialog Box
Add Bus Dialog Box
Add/Edit Command Dialog Box
Add Field Dialog Box
Add Free Text Dialog Box
Add Net to Class Dialog Box
Add New Attribute Dialog Box
Add New Attribute to Library Dialog Box
Add Part From Library Dialog Box
Add Pins Dialog Box
Archiver Dialog Box
Archiver Additional Files Dialog Box
Archiver Libraries Dialog Box
ASCII Output Dialog Box
Assign Alternatives for Ground Part Dialog Box
Assign Alternatives for Off-Page Part Dialog Box
Assign Alternatives for Power Part Dialog Box
Assign Decal to Gate Dialog Box
Assign New Gate Decal Dialog Box
Assign New PCB Decal Dialog Box
Assign Shortcut Dialog Box
Attribute Properties Dialog Box
Auto Renumber Parts Dialog Box
Basic Script Editor
Basic Scripts Dialog Box
Bill of Materials Setup Dialog Box
Browse for Connectors Dialog Box
Browse for Special Symbols Dialog Box
Browse Library Attributes Dialog Box
Bus Name Properties Dialog Box
Bus Properties Dialog Box
CAE Decal Wizard Dialog Box
Capture a New View Dialog Box
Change Part Type Dialog Box
Check for Updates Dialog Box
Class Rules Dialog Box
Clearance Rules Dialog Box
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Compare/ECO Tools Dialog Box
Conditional Rule Setup Dialog Box
Connect to SailWind Layout Dialog Box
Connect to SailWind Router Dialog Box
Crash Detected Dialog Box
Create PDF Dialog Box
Customize Dialog Box
DC Source Sweep Analysis Dialog Box
Default Rules Dialog Box
Differential Pairs Dialog Box
Display Colors Dialog Box
Display Colors Dialog Box - Part Editor
Drafting Properties Dialog Box
Edit Button Image Dialog Box
Fields Dialog Box
Field Properties Dialog Box
Font Replacement Dialog Box
Fonts Dialog Box
Get Drafting Items From Library Dialog Box
Get Gate Decal From Library Dialog Box
Get PCB Decal From Library Dialog Box
Hierarchical Symbol Wizard Dialog Box
HiSpeed Rules Dialog Box
Installed Options Dialog Box
Library List Dialog Box
Library Manager Dialog Box
Log Test Dialog Box
Logic Families Dialog Box
Make Field Dialog Box
Manage Library Attributes Dialog Box
Manage Schematic Attributes Dialog Box
Media Wizard Dialog Box
Modeless Commands and Keyboard Shortcuts
Net Attributes Dialog Box
Net Name Properties Dialog Box
Net Properties Dialog Box
Net Rules Dialog Box
Netlist to PCB Dialog Box
Off-Page Properties Dialog Box
Options Dialog Box
Options Dialog Box - Part Editor, General Category
Options Dialog Box - Print/Plot
Output Window
SailWind Layout Link Dialog Box
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SailWind Router Link Dialog Box
SailWind Suite Configuration Dialog Box
Part Attributes Dialog Box
Part Information Dialog Box
Part Properties Dialog Box
Part Signal Pins Dialog Box
Part Text Visibility Dialog Box
Part Type Label Properties Dialog Box
Pen Plotter Advanced Setup Dialog Box
Pen Plotter Setup Dialog Box
PCB Decal Assignment Dialog Box
Photo Plotter Advanced Setup Dialog Box
Photo Plotter Setup Dialog Box
Pin Decal Browse Dialog Box
Pin Decal List Management Dialog Box
Pin Label Fonts Dialog Box
Pin Properties Dialog Box
Plot Dialog Box
Print Dialog Box
Project Explorer
Query Hierarchical Component Dialog Box
Reference Designator Properties Dialog Box
Remap Special Symbols Dialog Box
Rename Gate Dialog Box
Rename Part Dialog Box
Renumber Pins Dialog Box
Report Manager Dialog Box
Reports Dialog Box
Routing Rules Dialog Box
Rules Dialog Box
Rules Report Dialog Box
Save CAE Decal to Library Dialog Box
Save Configuration Dialog Box
Save Drafting Item to Library Dialog Box
Save Off-Page to Library Dialog Box
Save Part and Gate Decals As Dialog Box
Save Part Types to Library Dialog Box
Save Part Type to Library Dialog Box
Save PCB Decal to Library Dialog Box
Save View Dialog Box
Select Gate Decal Dialog Box
Select Pin Decal Dialog Box
Select Type of Editing Item Dialog Box
Selection Filter Dialog Box
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Selections Preview Dialog Box
Server Busy Dialog Box
Sheets Dialog Box
Signal Pin Nets Dialog Box
Simulation Setup Dialog Box
SPICEnet Dialog Box
Step and Repeat Dialog Box
Text Properties Dialog Box
Transient Analysis Dialog Box
Update From Library Dialog Box
Update Selected CAE Decals From Library Dialog Box
Update Selected Part Type From Library Dialog Box
Update Selected Pin Decals From Library Dialog Box
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AC Analysis Dialog Box

AC Analysis Dialog Box
To access: Tools  > SPICE Netlist  menu item > Simulation Setup  button > AC Analysis  button

Set options specifically for an AC analysis.

Note:
Pictures in this document are for reference only, to help users better understand the software 
operation. In the case of interface difference due to version changes, the interface of SailWind 
Logic in practice shall prevail.

Figure 14. AC Analysis Dialog Box

Objects
Table  48. AC Analysis Fields

Name Description

Interval area Specifies the number of points and the variation: Decade, Octave, 
or Linear.

Frequency Specifies the Starting and Ending frequencies.

Related Topics
Creating a SPICE Netlist

Setting Up AC Analysis
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Add Attribute Label Dialog Box
To access:

• Select a part > right-click > Edit Part  menu item > Edit Graphics button > select a gate > Decal 
Editing Toolbar  button > Add Attribute Label  button

• With nothing selected > Tools  > Part Editor  menu item > Edit Graphics button > Decal Editing 
Toolbar  button > Add Attribute Label  button

Use the Add Attribute Label dialog box to create attribute labels while editing or creating a CAE Decal.

Figure 15. Add Attribute Label Dialog Box

Objects
Table  49. Edit Attribute Label Fields

Name Description

Attribute Name list Lists all of the attributes available to you.

 Tip
You can type the attribute name or browse the Library 
Attributes.

Browse Lib. Attr.  button Opens the Browse Library Attributes Dialog Box.

Height Specifies the height of the text.

Width Specifies the width of the text.

Rotation Specifies the rotation of the text: 0 or 90 degrees.

Horizontal/Vertical Justification Specifies the horizontal (Right, Center, Left) justification and the 
vertical (Up, Center, Down) justification of the text.
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Related Topics
Creating Attribute Labels
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Add Bus Dialog Box
To access: Schematic Editing toolbar > Add Bus  button> click to indicate starting point > double-click to 
indicate ending point

Use the Add Bus dialog box to create attribute labels while editing or creating a CAE Decal.

Figure 16. Add Bus Dialog Box

Objects
Table  50. Add Bus Dialog Box Fields

Name Description

Bus Name Specifies the name of the bus. Select or type the name you want.

Rename area Specifies to rename this instance or all instances of the bus.

 Restriction:
Available only in query mode.

Bus Type area Specifies which bus names appear in the Bus Name list.
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Table  50. Add Bus Dialog Box Fields  (continued)

Name Description

Add Bus Name Label Select the Add Bus Name Label check box to add the bus name 
as a label to the bus at the end of the bus closest to where you 
selected it.

 Restriction:
The check box is unavailable when the end of the selected bus 
has a label.
 Tip

• A bus can have two labels, one on each end.
• A bus label is not required.
• To delete a bus label, select the label in the schematic and 

click the Delete  button on the standard toolbar.

Bus Nets table Lists the name or prefix of the bus net, the starting bit number for 
a sequence of nets, and the ending bit number for a sequence of 
nets.

 Restriction:
Available only if the bus is a mixed net bus.
 Tip

• For a single net, type the net name.

• For a range of sequential nets, type the prefix for the sequence 
of nets.

Add  button Adds a row to the Bus Nets table.

 Restriction:
Available only if the bus is a mixed net bus.

Edit  button Makes the selected row available for editing.

 Restriction:
Available only if the bus is a mixed net bus.

Delete  button Removes the selected row from the Bus Nets table.

 Restriction:
Available only if the bus is a mixed net bus.

Down/Up  buttons Moves the selected row up or down in the Bus Nets table.

 Restriction:
Available only if the bus is a mixed net bus.

Related Topics
Managing Buses
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Add/Edit Command Dialog Box
To access: Tools  > Customize  menu item > Commands  tab > select a command >New  or Edit  button

Use the Add Command dialog box to create commands that you can then use as selections on menus or 
as buttons on toolbars.

Figure 17. Add Command Dialog Box

Objects
Table  51. Add/Edit Dialog Box Fields

Name Description

Command name The name of the new command.

 Tip
Type an ampersand before the letter you want to use as the Alt 
keyboard shortcut.

Based on The command on which you want to base the new command.

Arguments Any arguments for the new command.

 Tip
Use a space to separate arguments. If an argument contains a 
space, enclose the argument in quotation marks (“”).
 Restriction:
SailWind Router only.

Description Lists what the new command does.

Use Default Image Use the recommended image.
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Table  51. Add/Edit Dialog Box Fields  (continued)

Name Description

Select User-defined Image Select or create your own image to associate with the new 
command.

New  button Open the Edit Button Image Dialog Box.

Edit  button Open a button in the Edit Button Image Dialog Box.

Related Topics
Creating a Custom Command

Creating a Custom Menu
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Add Field Dialog Box
To access: Select nothing or a 2D line object > right-click > Add Field  menu item

Use the Add Field dialog box to add a field to your schematic.

Figure 18. Add Field Dialog Box

Objects
Table  52. Add Field Dialog Box Fields

Name Description

Name list Type the name of a new field or select from a list of the fields 
available to you.

Value The value of the field.

 Restriction:
The Value box is unavailable for system fields since the value 
is derived from your system.

X/Y Type coordinates to place the field label in a specified location.
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Table  52. Add Field Dialog Box Fields  (continued)

Name Description

 Tip
Leave these blank to attach the field to your pointer and click to 
indicate the location.

Rotation Specifies the rotation of the text: 0 or 90 degrees.

Line Width Specifies the line width for stroke fonts only.

Size Specifies the size of the font.
Size (pts):  This is font size in points and appears for system fonts
Size (mils):  This is font character height and appears for stroke 
fonts. The size refers to the height of the tallest characters.

Font Style Enables you to change the font style to bold, italic, and underlined.

 Restriction:
System fonts only.

Font list The fonts available to you. This lists either stroke fonts or system 
fonts. You choose which type of font to use in the Fonts Dialog 
Box.

 Tip
• Select stroke font or a system font.
• For system fonts, you can also click a font style button, or 

any combination of styles: B  for bold, I  for italic, or U  for 
underlined.

Horizontal/Vertical Justification Specifies the horizontal (Right, Center, Left) justification and the 
vertical (Up, Center, Down) justification of the text.

Related Topics
Adding a Field
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Add Free Text Dialog Box
To access: Schematic Editing toolbar > Create Text  button

Use the Add Free Text dialog box to add free text (not belonging to another object).

Figure 19. Add Free Text Dialog Box

Objects
Table  53. Add Free Text Dialog Box Fields

Name Description

Text Type the text you want in the schematic.

X/Y Places the text in a specified location. Negative coordinates are 
not permitted. If you want to place text outside the sheet, you must 
move it there with the cursor.

 Tip
Leave these blank to attach the text to your pointer and click to 
indicate the location.

Rotation Specifies the rotation of the text: 0 or 90 degrees.

Line Width Specifies the line width for stroke fonts only.
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Table  53. Add Free Text Dialog Box Fields  (continued)

Name Description

Size Specifies the size of the font.
Size (pts):  This is font size in points and appears for system fonts
Size (mils):  This is font character height and appears for stroke 
fonts. The size refers to the height of the tallest characters.

Font Style Enables you to change the font style to bold, italic, and underlined.

 Restriction:
System fonts only.

Font list The fonts available to you. This lists either stroke fonts or system 
fonts. You choose which type of font to use in the Fonts Dialog 
Box.

 Tip
• Select stroke font or a system font.
• For system fonts, you can also click a font style button, or 

any combination of styles: B  for bold, I  for italic, or U  for 
underlined.

Horizontal/Vertical Justification Specifies the horizontal (Right, Center, Left) justification and the 
vertical (Up, Center, Down) justification of the text.

Related Topics
Adding Text
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Add Net to Class Dialog Box
To access: With nothing selected, right-click > Select Nets  > select one or more nets > right-click > Make 
Class  menu item

Use the Add Net to Class dialog box to create a new class or to add nets to an existing class.

Figure 20. Add Net to Class Dialog Box

Objects
Table  54. Add Net Class Dialog Box Fields

Name Description

Create New Class Specifies to create a new class using the selected net(s).

Add to Existing Class Specifies to add the selected net(s) to an existing class.

 Restriction:
This is unavailable if there are no existing classes.

Selected Nets Lists all of the nets you selected in the schematic.

Add to Class Specifies the name of the class. Type a new name or accept the 
default.

 Restriction:
This is unavailable if you select Add to Existing Class an only 
one class exists.

Existing Classes Lists all of the existing classes in the schematic.
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Add New Attribute Dialog Box
To access: Edit  > Attribute Manager  menu item > Add Attr  button

Use the Add New Attribute dialog box to set name and value properties when adding new attributes to the 
schematic.

Figure 21. Add New Attribute Dialog Box

Objects
Table  55. Add New Attribute Dialog Box Fields

Name Description

Browse Lib. Attr  button Opens the Browse Library Attributes Dialog Box.

Attribute Name The name of the new attribute.

Attribute Value The value of the new attribute.

Related Topics
Manage Attributes in a Schematic
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Add New Attribute to Library Dialog Box
To access: File  > Library  menu item > Library Manager dialog box > Attr Manager  button > Add Attr 
button

Use the Add New Attribute to Library dialog box to set name and value properties when adding new 
attributes to libraries.

Figure 22. Add New Attribute to Library Dialog Box

Objects
Table  56. Add New Attribute to Dialog Box Fields

Name Description

Browse Lib. Attr  button Opens the Browse Library Attributes Dialog Box.

Attribute Name The name of the new attribute.

Attribute Value The value of the new attribute.
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Add Part From Library Dialog Box
To access: Schematic Editing toolbar > Add Part  button

Use the Add Part from Library dialog box to load a part from a library into the current schematic drawing. 
SailWind Logic automatically assigns a reference designator when you add the part.

Figure 23. Add Part From Library Dialog Box

Objects
Table  57. Add Part From Library Dialog Box Fields

Name Description

Preview area Shows the selected item.

Items Lists the items in the selected library. The number of objects that 
appear depends on the filter settings.

Library list Specifies the library you want to use.

Items Narrows the search. You can use wildcards or expressions  on 
page 105. An asterisk (*) displays all parts in the list.

Apply  button Searches the library for the specified item.

Part Name list Select a recently used part.

 Tip
The sixteen most recently used parts are available in the Part 
Name dropdown list box. You can clear this buffer by removing 
the entries in the SailWindlogic.ini  file, under the [Last Added 
Parts] heading.
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Related Topics
Adding Parts
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Add Pins Dialog Box
To access:

• File  > Library  menu item > select a Library > Parts  button > New  button > on the Part Editor 
Toolbar click Edit Electrical  > Pins  tab > Add Pins  button

• File  > Library  menu item> select a Library > Parts  button > select a part > Edit  button > on the 
Part Editor Toolbar click Edit Electrical  > Pins  tab > Add Pins  button

Use the Add Pins dialog box to add pins to a part type.

Figure 24. Add Pins Dialog Box

Objects
Table  58. Add Pins Dialog Box Fields

Name Description

Number of pins Specifies the number of pins to add using the Add Pins dialog box.

Prefix The prefix you want for your pins.

 Tip
• Alphabetic and numeric values can be used. For example, 

A1 or 1A.
• For a single numeric, use either Prefix or Suffix box, and 

void the other box.

Suffix The suffix you want for your pins.
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Table  58. Add Pins Dialog Box Fields  (continued)

Name Description

 Tip
• Alphabetic and numeric values can be used. For example, 

A1 or 1A.
• For a single numeric, use either Prefix or Suffix box, and 

void the other box.

Pin numbers A preview of pin numbers based on your input in the Prefix and 
Suffix boxes.

Increment prefix/Increment suffix Indicates whether you want the prefix or the suffix to increment.

Step value A positive or negative number by which to increase or decrease 
the pin numbers with consecutive or stepped values.

Verify valid JEDEC pin numbering Ensures that legal alphanumeric values are used.
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Archiver Dialog Box
To access: File  > Archive  menu item

Use the Archiver dialog box to create archives of your schematics, designs, files and folders, and 
libraries.

Figure 25. Archiver Dialog Box

Objects
Table  59. Archiver Dialog Box Fields

Name Description

PCB Design Specifies the location and name of the PCB design you want to 
archive. To choose the file you want, type the location or click the 
Browse button.
Select Create PDF to create a PDF file of the PCB design.
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Table  59. Archiver Dialog Box Fields  (continued)

Name Description

Schematic Specifies the location and name of the schematic file you want to 
archive. This is automatically populated with the information from the 
current design. To change the design, or if no design was opened, type 
the location or click the Browse  button.
Specifies to create a PDF file of the schematic file.

 Restriction:
This is unavailable if the file you chose is different from the current 
design.

Add libraries Specifies that you want to include libraries in the archive.
• All  — Add all of your libraries to the archive.

• Select  — Add only the libraries you specify.

Click the Browse  button to open the Archiver Libraries Dialog Box.

Additional files Specifies that you want to include other files and folders in your 
archive. Click the Browse  button to open the Archiver Additional Files 
Dialog Box.

Target folder Specifies where you want the archive to be located. Type the path or 
click the Browse  button.
Requirement:  The target folder must be empty.

Compress using zip format Specifies to create a zip file. The file will be in the following format:

<project_name>YYYYMMDDHHMMSS.zip
 

Where YYYY is the year, MM is the month, DD is the day, HH is the 
hour - in military time, MM is the minute, and SS is the second of the 
exact time you created the file.

Related Topics
Archiving Your Schematic
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Archiver Additional Files Dialog Box
To access: File  > Archive  menu item > Additional Files check box > Browse  button

Use the Archiver: Additional dialog box to add files and folders to the schematic you want to archive.

Figure 26. Archiver Additional Files Dialog Box

Objects
Table  60. Archiver Additional Fields Dialog Box

Name Description

Additional files list Lists the files and folders you want to include in your archive.

Add File  button Opens the Additional File dialog box where you can select individual 
files you want to add to the Additional files list.

Add folder  button Opens the Browse for Folder dialog box where you can select an entire 
folder to add to the Additional files list.

Remove  button Removes the selected file or folder from the Additional files list.

Remove All  button Removes all of the files and folders from the Additional files list.

Related Topics
Archiving Your Schematic
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Archiver Libraries Dialog Box
To access: File  > Archive  menu item > Add libraries check box > Select > Browse  button

Use the Archiver: Libraries dialog box to add libraries to the schematic you want to archive.

Figure 27. Archiver Libraries Dialog Box

Objects
Table  61. Archiver Libraries Dialog Box Fields

Name Description

Available libraries Lists all of the libraries available for you to add to the archive.

 Restriction:
If your library is not listed in the Library Manager, it will not appear 
in this list.

Add >>  button Moves the selected library from the Available libraries list to the 
Selected libraries list.

<< Remove  button Moves the selected library from the Selected libraries list to the 
Available libraries list.

Add all >>  button Moves all of the libraries from the Available libraries list to the Selected 
libraries list.

<< Remove all  button Moves all of the libraries from the Selected libraries list to the Available 
libraries list.
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Archiver Libraries Dialog Box

Related Topics
Archiving Your Schematic
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ASCII Output Dialog Box
To access: File  > Export  menu item > type a filename > Save  button

Use the ASCII Output dialog box to select the sections you want to export to the ASCII file.

Figure 28. ASCII Output Dialog Box

Objects
Table  62. ASCII Output Dialog Box Fields

Name Description

Schematic Params Specifies to export the default system settings from the Options  tabs.

Sheet Params Specifies to export the specific sheet information such as window 
scale, centering, etc.

Text Specifies to export the free text together with location, level, and size.

Lines Specifies to export the 2D-line items.

Plot Params Specifies to export the information related to the CAM output settings 
and configurations generated using the Plot command.

Fields Specifies to export the fields used in the schematic and their values.

Decals Specifies to export the part decals and their contents.

Part Types Specifies to export the library part attributes such as manufacturer, 
cost, and notes.
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Table  62. ASCII Output Dialog Box Fields  (continued)

Name Description

Parts Specifies to export the parts used in the schematic and their reference 
designators.

Connections Specifies to export all connections on the schematic, including paths, 
tie-dots, and off-page flags.

Rules Specifies to export the clearance, routing, and others specified in 
Design Rules.

Select All  button Selects all items.

Unselect All  button Clears all items.

Output Version Specifies the version of the software you are using.

Filename Displays the location and name of the file.

 Tip
This was specified in the File Export dialog box.

Related Topics
Exporting to ASCII Output
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Assign Alternatives for Ground Part Dialog 
Box
To access: Tools  > Part Editor  menu item > Part Editor > Open  button > Ground > OK  button > Edit 
Electrical  button

Use the Assign Alternatives for Ground Part dialog box to assign or create additional ground symbols.

Note:
For additional information on the creation and use of special schematic symbols, see “Special 
Schematic Symbols”  on page 167.

Figure 29. Assign Alternatives for Ground Part Dialog Box

Objects
Table  63. Assign Alternatives For Ground Part Dialog Box Fields

Name Description

Picture Displays a picture of the selected Special Symbol.

Attribute table • Special Symbol  — The name of a connector pin decal for use 
in the schematic.

• Pin Type  — The function of the special symbol.

• Signal Name  — The name of the signal.

Opens the Browse for Special Symbols Dialog Box.
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Table  63. Assign Alternatives For Ground Part Dialog Box Fields  (continued)

Name Description

 Tip
This button is available only in the Special Symbols columns, 
and only when the cell is available for editing.

Edit  button Makes the selected cell available for editing.

 Tip
You can also double-click the cell to edit the contents.

Add  button Adds a new row at the bottom of the table.

Delete  button Removes the selected row.

Related Topics
Assigning Alternate Logic Decals for Connector Symbols

Special Schematic Symbols
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Assign Alternatives for Off-Page Part Dialog 
Box
To access: Tools  > Part Editor  menu item > Open  button > Off-page > OK  button > Edit Electrical 
button

Use the Assign Alternatives for Off-Page Part dialog box to assign or create additional off-page reference 
symbols.

Note:
For additional information on the creation and use of special schematic symbols, see “Special 
Schematic Symbols”  on page 167.

Figure 30. Assign Alternatives for Off-Page Part Dialog Box

Objects
Table  64. Assign Alternatives for Off-Page Part Dialog Box Fields

Name Description

Picture Displays a picture of the selected Special Symbol.

Attribute table • Special Symbol  — The name of a connector pin decal for use 
in the schematic.

• Pin Type  — The function of the special symbol.

Opens the Browse for Special Symbols Dialog Box.
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Table  64. Assign Alternatives for Off-Page Part Dialog Box Fields  (continued)

Name Description

 Tip
This button is available only in the Special Symbols columns, 
and only when the cell is available for editing.

Edit  button Makes the selected cell available for editing.

 Tip
You can also double-click the cell to edit the contents.

Add  button Adds a new row at the bottom of the table.

Delete  button Removes the selected row.

Related Topics
Assigning Alternative Symbols for the Off-Page Part

Special Schematic Symbols
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Assign Alternatives for Power Part Dialog Box
To access: Tools  > Part Editor  menu item > Open  button > Power > OK  button > Edit Electrical  button

Use the Assign Alternatives for Power Part dialog box to assign or create additional power symbols.

Note:
For additional information on the creation and use of special schematic symbols, see “Special 
Schematic Symbols”  on page 167.

Figure 31. Assign Alternatives for Power Part Dialog Box

Objects
Table  65. Assign Alternatives for Power Part Dialog Box Fields

Name Description

Picture Displays a picture of the selected Special Symbol.

Attribute table • Special Symbol  — The name of a connector pin decal for use 
in the schematic.

• Pin Type  — The function of the special symbol.

• Signal Name  — The name of the signal.

Opens the Browse for Special Symbols Dialog Box.

 Tip
This button is available only in the Special Symbols columns, 
and only when the cell is available for editing.
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Table  65. Assign Alternatives for Power Part Dialog Box Fields  (continued)

Name Description

Edit  button Makes the selected cell available for editing.

 Tip
You can also double-click the cell to edit the contents.

Add  button Adds a new row at the bottom of the table.

Delete  button Removes the selected row.

Related Topics
Assigning Alternative Symbols for the Power Part

Special Schematic Symbols
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Assign Decal to Gate Dialog Box
To access: Tools  > Part Editor  menu item > Edit Electrical  button > Gates  tab > (if a new part, click 
Add) > double-click a CAE Decal cell > Browse  button

Use the Assign Alternatives for Power Part dialog box to assign or create additional power symbols.

Figure 32. Assign Decal to Gate Dialog Box

Objects
Table  66. Assign Decal to Gate Dialog Box Fields

Name Description

Library list Lists all your available libraries. Filters the Unassigned Decals list 
to only the selected library.

Filter Searches the chosen library (or libraries) for a specific part or item 
name, or names that match a wildcard or expression  on page 105. 
Type * to view all parts or items in the chosen libraries. Click Apply 
to search the libraries and display the search results.

Preview area Displays the item selected in the Assigned Decals list.

Unassigned Decals list Lists all of the decals that are available to assign.

Assign New  button Opens the Assign New Gate Decal Dialog Box.

Assign >>  button Moves the decal from the Unassigned Decals list to the Assigned 
Decals list.

<< Unassign  button Moves the decal from the Assigned Decals list to the Unassigned 
Decals list.

Assigned Decals list Lists all of the decals that have been assigned.

466 SailWind Logic Guide



 
SailWind Logic GUI Reference

Assign Decal to Gate Dialog Box

Table  66. Assign Decal to Gate Dialog Box Fields  (continued)

Name Description

Up/Down  buttons Moves the selected decal up or down in the Assigned Decals list.

Related Topics
Assigning CAE Decals to Gates
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Assign New Gate Decal Dialog Box
To access: File  > Library  menu item > select a Library > Parts  button > select part > New  or Edit  button 
> on Part Editor Toolbar click Edit Electrical  > Gates  tab > (if new part click Add) > double-click CAE 
Decal cell > Browse  button > Assign New

Use the Assign New Gate dialog box to assign a new gate decal when it doesn’t yet exist in the Library.

Figure 33. Assign New Gate Decal Dialog Box

Objects
Table  67. Assign New Gate Decal Dialog Box Fields

Name Description

Text box Enter the name of the new gate decal you intend to add to the library.
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Assign New PCB Decal Dialog Box
To access: File  > Library  menu item > select a Library > Parts  button > select part > New  or Edit  button 
> on Part Editor Toolbar click Edit Electrical  > PCB Decals  tab > Assign New

Use the Assign New PCB Decal dialog box to assign a new PCB Decal when it doesn’t yet exist in the 
Library.

Figure 34. Assign New PCB Decal Dialog Box

Objects
Table  68. Assign New PCB Decal Dialog Box Fields

Name Description

Text box Enter the name of the new PCB decal you intend to add to the library.
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Assign Shortcut Dialog Box
To access: Tools  > Customize  menu item > Keyboard and Mouse  tab > select a mode > select a 
command folder > select a command > New  button

Create a new shortcut key using the Assign Shortcut dialog box.

Figure 35. Assign Shortcut Dialog Box

Objects
Table  69. Assign Shortcut Dialog Box Fields

Name Description

Press new shortcut key Type the shortcut you want to use.

Select a pointer event Set a pointer event shortcut

Similar shortcuts list Lists the shortcut keys already assigned to other commands.
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Attribute Properties Dialog Box
To access: Select a part attribute label > right-click > Properties  menu item

Use the Attribute Properties dialog box to provide text and font settings for one or more part attribute 
labels.

Figure 36. Attribute Properties Dialog Box

Objects
Table  70. Attribute Properties Dialog Box Fields

Name Description

Name The name of the selected attribute.

Value Specifies the label you want in the schematic.

Rotation Specifies the rotation of the label: 0 or 90 degrees.

Size Specifies the size of the font.
Size (pts):  This is font size in points and appears for system fonts
Size (mils):  This is font character height and appears for stroke 
fonts. The size refers to the height of the tallest characters.
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Table  70. Attribute Properties Dialog Box Fields  (continued)

Name Description

Line Width Specifies the line width for stroke fonts only.

Font list The fonts available to you. This lists either stroke fonts or system 
fonts.
You choose which type of font to use in the Fonts Dialog Box.

 Tip
• Select stroke font or a system font.
• For system fonts, you can also click a font style button, or 

any combination of styles: B  for bold, I  for italic, or U  for 
underlined.

Horizontal/Vertical Justification Specifies the horizontal (Right, Center, Left) justification and the 
vertical (Up, Center, Down) justification of the text.

Related Topics
Modifying Part Attribute Labels
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Auto Renumber Parts Dialog Box
To access: Schematic Editing toolbar > Auto Renumber Parts  button

Automatically renumber the reference designators on schematic sheets in a pattern. Choose the sheets, 
reference designator prefixes, pattern and numbering range.

Objects

Name Description

Sheets Choose which sheets to renumber.
Hierarchical sheets appear differently depending on whether they have been created 
from the top down or the bottom up.
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Name Description

• Bottom-up  — Sheets display at the primary level instead of being indented in the 
list. When using Increment Start Value by Sheet, the reference designators are 
renumbered on each sheet.

• Top-down  — Sheets are indented to show they are sub-sheets. When using 
Increment Start Value by Sheet, the sheets inherit the same base level number as 
the parent sheet.

Prefix List Choose which reference designator families to renumber. The list displays the total 
number of reference designators in brackets. The prefix types and totals update 
based on the sheets selected in the Sheets list.

Cell size Renumbering is applied according to the Precedence pattern within the cell area. 
Specify the size of cells in which to apply the renumbering pattern. Cells are arranged 
across the schematic area in selected Precedence pattern. For an illustration 
explaining cell size, see “Automatically Renumbering Reference Designators”  on 
page 280.

Renumber • Start Value  — The number to apply to the first of each type of renumbered 
reference designator.

• Increment  — The gap in numbers to apply to the reference designator numbers.

• Increment Start Value by Sheet  — Use the sheet number as the start number 
- the sheet number as shown in the Sheets Dialog Box  and not the order of the 
sheet in this dialog. For example, if the Start Value is 101, then sheet number 
1 will start with number 101, but sheet 2 will start with number 201. If used in 
combination with large start values, the reference designator numbers may quickly 
run into the software limit. For example, if the start value is set to 1000, and there 
are 40 schematic sheets, then reference designators on sheet 40 would start at 
40,000 - well over the limit of 32,766.

Start value and increment are applied to each reference designator family separately. 
For example, the schematic has the following components: C1, C2, C3, R1, R2. Start 
Value is 10 and Increment is 5. The result of renumbering is: C10, C15, C20, R10, 
R15.Parts on sheets are renumbered in the order of the sheets: first, parts from sheet 
number 1, then from sheet number 2 and so on. If a part belongs to more than one 
sheet, it gets renumbered on the selected sheet with the lowest number.

Precedence Specifies the pattern used to renumber parts within a cell area. Also specifies 
the pattern used for the application of cells to process over the schematic page. 
Renumbering is performed based upon the first pin of the symbol encountered in the 
given precedence direction.

Basic Script Editor
Basic is a simple scripting language. Like many Windows applications, such as Microsoft Word and Excel, 
SailWind applications include Basic capabilities to enable users to customize their applications using a 
standard scripting language.

You can use the Basic Script Editor to create, edit, run, and troubleshoot Basic scripts from SailWind 
applications. To open the editor:
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Basic Script Editor

• Tools  > Basic Scripts  > Basic Script Editor  menu item

Figure 37. Basic Script Editor
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Basic Scripts Dialog Box
To access: Tools  > Basic Scripts  > Basic Scripts  menu item

The Basic Scripts dialog box provides easy access to your Basic scripts.

Figure 38. Basic Scripts Dialog Box

Objects
Table  71. Basic Scripts Dialog Box Fields

Name Description

Basic Script List Lists the scripts available to you.

X  button Specifies to use the smaller dialog box vs. the entire dialog box.

 Tip
To use the smaller dialog box, select the script you want to run and 
press Enter.

In Menu Specifies to add the selected script to the Basic Scripts  menu.

Run  button Runs the selected script.

 Restriction:
You can not run multiple scripts at the same time.
 Tip
If the selected script has an error during compilation, it 
automatically opens in the Basic Script editor for correction.

Edit  button Opens the Sax Basic Engine dialog box with the selected script loaded.
See also Managing the Sax Basic Engine  on page 389
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Basic Scripts Dialog Box

Table  71. Basic Scripts Dialog Box Fields  (continued)

Name Description

Load File  button Adds a new script to the list.

 Tip
• You can load up to 32,767 scripts. Scripts are not compiled 

when they are loaded; they are compiled when you run them
• The list of scripts you load into this dialog box is saved in the 

VBScripts.ini  file, so they load every time you open the Basic 
Scripts dialog box.

Unload  button Removes the selected script from the list.

Description area Displays the location of the selected script.

Related Topics
Using the Basic Scripts Dialog Box
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Bill of Materials Setup Dialog Box
The Bill of Materials report produces a user-configurable list of the parts contained in the current 
schematic. You can direct any part attribute in the schematic to a Bill of Materials report.

Restriction:
Including non-ECO-registered parts and non-electrical parts in the bill of materials is constrained. 
See Options Dialog Box, Design Category  for details.

To access: File  > Reports  menu item > Setup  button

Bill of Materials Setup Dialog Box, Attributes Tab
Bill of Materials Setup Dialog Box, BOM Config Tab
Bill of Materials Setup Dialog Box, Format Tab
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Bill of Materials Setup Dialog Box, Attributes Tab
To access: File  > Reports  menu item > Setup  button > Attributes  tab

Use the Attributes  tab to modify the Attribute content, the corresponding column headings, and column 
width of the report. The attribute order in the content list determines the column arrangement in the BOM 
report. There is a limit of 12 attributes in the Bill of Materials report.

Figure 39. Attributes tab

Objects
Table  72. Bill of Materials Setup Dialog Box Fields

Name Description

Attribute table Specifies the attributes in, headings for, and width of the BOM 
report.

• Part Attribute column  — Specifies the attributes you want 
in the report. You can list up to twelve attribute names. Each 
attribute defines a column in the report.

• Field Header column  — Specifies the column heading for 
each attribute in the report. You can specify any character 
except the colon ( : ).

• Width column  — Specifies the number of characters across 
the column for each attribute in the report: 1 to 200.
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Table  72. Bill of Materials Setup Dialog Box Fields  (continued)

Name Description

Up  button Moves the selected row up by one.

 Tip
The attribute order in the content list determines the column 
arrangement in the BOM report.

Down  button Moves the selected row down by one.

 Tip
The attribute order in the content list determines the column 
arrangement in the BOM report.

Add  button Adds a row to the bottom of the table where you can select a new 
part attribute.

 Tip
You can list up to twelve attribute names. Each attribute defines 
a column in the BOM report.

Edit  button Makes the selected box editable.

 Restriction:
You cannot edit the part attribute name, but you can select a 
new attribute to replace the one currently listed.

Remove  button Removes the selected row from the table and therefore the 
attribute from the report.

Reset  button Restores the default content from the .ini file.

Related Topics
The Bill of Materials Report
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Bill of Materials Setup Dialog Box, BOM Config Tab
To access: File  > Reports  menu item > Setup  button > BOM Config  tab

Use the BOM Config  tab to preview the Bill of Materials report format and copy any selected lines of 
the file to a Windows clipboard. You can also specify rows to export to a TXT/CSV file. The default view 
orders the attributes by the sort field you specified on the Format  tab.

Figure 40. BOM Config Tab

Objects
Table  73. Bill of Materials Setup Dialog Box-BOM Config Fields

Name Description Remark

Report table Displays the BOM report in table format for you to select and copy 
any row or export to a CSV/TXT file. This table shows the data 
from the attributes you selected on the Attributes tab.

Select All  button Selects all rows in the table.

Copy  button Specifies to copy the row(s) you’ve selected to the Windows 
clipboard.

Include table header Specifies to copy the table header in addition to the row(s) you’ve 
selected.

Use these functionality buttons to specify what and how to copy 
selected rows to the Windows clipboard.

Export  button Exports the BOM report to a CSV/TXT file.
You can exclude the row(s) you don't want by checking the NC 
checkbox.

Combine Reference  button Specifies to include reference designators sharing identical Part 
Name in the same cell.

Use these functionality buttons to specify what and how to export 
allowable rows to a CSV/TXT file.
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Table  73. Bill of Materials Setup Dialog Box-BOM Config Fields  (continued)

Name Description Remark

Clear NC  button Specifies to clear all the NC checkboxes selected in the table.

Related Topics
The Bill of Materials Report

482 SailWind Logic Guide



 
SailWind Logic GUI Reference

Bill of Materials Setup Dialog Box, Format Tab

Bill of Materials Setup Dialog Box, Format Tab
To access: File  > Reports  menu item > Setup  button > Format  tab

Use the Format  tab to modify the output format of the Bill of Material report. The default settings originate 
from the .ini  file.

Objects
Table  74. Bill of Materials Setup Dialog Box-Format Tab Fields

Name Description

Delimiter area Specifies the type of delimiter you want to distinguish the report 
columns.

• None  — no delimiter used.

• Separator  — places a vertical bar between report fields.

• Tab  — separates columns with a tab spacing.
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Table  74. Bill of Materials Setup Dialog Box-Format Tab Fields  (continued)

Name Description

• Comma  — places a comma character between report fields.

• Custom  — specify any character as a delimiter.

File Format list Specifies the output file format.

Reset  button Restores the default content from the .ini  file.

Settings list Specifies to use a previously saved report format setting.

Save As  button Saves report format settings for the current design to a specified 
file so you can create different format configurations for different 
designs

Delete  button Removes the selected setting in the Settings list.

Format Options area

Report Title Specifies the title of the report.

Combine Value/Tolerance Specifies to combine the Value and Tolerance attributes of a part 
in the part name.
Example:  The 1/4 watt resistor would have a part type name of 
R1/4W or R1/4W.4.7K,+/-5%. SailWind Logic evaluates parts that 
have either a different Value or Tolerance attribute as different part 
types.

Ref. Designator Separation Mode • Single Ref. Designator per line  — Although some 
components are identical, display each component instance on 
a new line. This increases the BOM report size.

• Multiple Ref. Designator per line  — Combines identical 
component instances on one line and lists all reference 
designators based on the settings below:

• Compress Ranges  — Displays ranges of components 
with a dash between min and max value. For example, if 
components C1, C2, C3, and C4 are identical, they are 
displayed as C1-4. This can shorten the list of reference 
designators listed for a component type.

If you clear this check box, ranges are not compressed and 
individual reference designators are listed for the line entry. 
For example, C1,C2,C3,C4.

• Ref designator Delimiter  — Specify a single character 
to place between multiple reference designators. For 
example, use a comma for “C1,C2,C3”, or use an asterisk 
for “C1*C2*C3”. Although you can type multiple characters in 
this box, only the first character applies.

Sort By list Specifies the attribute in which to sort the report list.

 Tip
Select None to sort by Part Type.
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Bill of Materials Setup Dialog Box, Format Tab

Related Topics
The Bill of Materials Report
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Browse for Connectors Dialog Box
To access: Tools  > Part Editor  menu item > Open  button > select Connector > OK  button

Use the Browse for Connectors dialog box to browse a library and select a connector for editing from the 
library (or libraries) specified in the Library list.

Figure 41. Browse for Connectors Dialog Box

Objects
Table  75. Browse for Connectors Dialog Box Fields

Name Description

Preview area Shows the selected part.

Part Types Lists the items in the selected library. The number of objects that 
appear depends on the filter settings.

Library list Specifies the library you want to use.

Items Narrows the search. You can use wildcards or expressions  on 
page 105. An asterisk (*) displays all parts in the list.

Apply  button Searches the library for the specified item.

Related Topics
Browsing for Connectors
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Browse for Special Symbols Dialog Box
To access: Tools  > Part Editor  menu item > open an off-page part > Edit Electrical  button > double-click 
in a field in the Special Symbols column > Browse  button

Use the Browse For Special Symbols dialog box to access the library for decals you want to specify 
as Special Symbols. Special Symbols are those used to create off-page reference, power and ground 
symbols, and connectors.

Figure 42. Browse for Special Symbols Dialog Box

Objects
Table  76. Browse for Special Symbols Dialog Box Fields

Name Description

Preview area Shows the selected item.

Gate Decals Lists the items in the selected library. The number of objects that 
appear depends on the filter settings.

Library list Specifies the library you want to use.

Items Narrows the search. You can use wildcards or expressions  on 
page 105. An asterisk (*) displays all parts in the list.

Apply  button Searches the library for the specified item.

Related Topics
Assigning Alternative Symbols for the Ground Part

Assigning Alternative Symbols for the Off-Page Part
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Assigning Alternative Symbols for the Power Part

Assigning Alternate Logic Decals for Connector Symbols
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Browse Library Attributes Dialog Box
To access: Tools  > Part Editor  menu item > Edit Electrical  button > Attributes  tab > Browse Lib. Attr 
button

Use the Browse Library Attributes dialog box to browse and list all attribute names from libraries specified 
in the Library List dialog box.

Figure 43. Browse Library Attributes Dialog Box

Objects
Table  77. Browse Library Attributes Dialog Box Fields

Name Description

Attribute Displays the selected attribute.

Group Filters the attribute list. (Includes structured attributes.)

Refresh  button Manually updates the attribute list if you change the list of libraries in 
the Library Manager.

Related Topics
Browsing Library Attributes
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Bus Name Properties Dialog Box
To access: Select a bus name label > right-click > Properties  menu item

Use the Bus Name Properties dialog box to provide or change text and font settings for one or more bus 
name labels.

Figure 44. Bus Name Properties Dialog Box

Objects
Table  78. Bus Name Properties Dialog Box FIelds

Name Description

Name The name of the selected bus.

Bus  button Opens the Bus Properties Dialog Box.

Rotation Specifies the rotation of the label: 0 or 90 degrees.

Size Specifies the size of the font.
Size (pts):  This is font size in points and appears for system fonts
Size (mils):  This is font character height and appears for stroke 
fonts. The size refers to the height of the tallest characters.
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Bus Name Properties Dialog Box

Table  78. Bus Name Properties Dialog Box FIelds  (continued)

Name Description

Line Width Specifies the line width for stroke fonts only.

Font list The fonts available to you.

 Tip
• Select stroke font or a system font.
• For system fonts, you can also click a font style button, or 

any combination of styles: B  for bold, I  for italic, or U  for 
underlined.

Font Style Enables you to change the font style to bold, italic, and underlined.

 Restriction:
System fonts only.

Horizontal/Vertical Justification Specifies the horizontal (Right, Center, Left) justification and the 
vertical (Up, Center, Down) justification of the text.

Related Topics
Modifying Bus Name Labels
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Bus Properties Dialog Box
To access: Select a bus > right-click > Properties  menu item

Use the Bus Properties dialog box to change the name of the bus, change the bus type, and manage bus 
nets.

Figure 45. Bus Properties Dialog Box

Objects
Table  79. Bus Properties Dialog Box Fields

Name Description

Bus Name Specifies the name of the bus. Select or type the name you want.

Rename area Specifies to rename this instance or all instances of the bus.

Bus Type area Specifies which bus names appear in the Bus Name list.

Add Bus Name Label Select the Add Bus Name Label check box to add the bus name 
as a label to the bus at the end of the bus closest to where you 
selected it.
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Table  79. Bus Properties Dialog Box Fields  (continued)

Name Description

 Tip
• A bus can have two labels, one on each end.
• The check box is unavailable when the end of the selected 

bus has a label.
• A bus label is not required.
• To delete a bus label, select the label in the schematic and 

click the Delete  button on the standard toolbar.

Bus Nets table Lists the name or prefix of the bus net, the starting bit number for 
a sequence of nets, and the ending bit number for a sequence of 
nets.

 Restriction:
Available only if the bus is a mixed net bus.
 Tip

• For a single net, type the net name.
• For a range of sequential nets, type the prefix for the 

sequence of nets.

Add  button Adds a row to the Bus Nets table.

 Restriction:
Available only if the bus is a mixed net bus.

Edit  button Makes the selected row available for editing.

 Restriction:
Available only if the bus is a mixed net bus.

Delete  button Removes the selected row from the Bus Nets table.

 Restriction:
Available only if the bus is a mixed net bus.

Down/Up  buttons Moves the selected row up or down in the Bus Nets table.

 Restriction:
Available only if the bus is a mixed net bus.

Related Topics
Managing Buses

SailWind Logic Guide 493



SailWind Logic GUI Reference
CAE Decal Wizard Dialog Box  

CAE Decal Wizard Dialog Box
To access: Tools  > Part Editor  menu item > New  button > CAE Decal > OK  button > Decal Editing 
Toolbar  button > CAE Decal Wizard  button

Use the Decal Wizard dialog box to automatically create a new CAE decal. You must be in the Decal 
Editor mode of the Part Editor, and creating gate information, to use this feature.

Figure 46. CAE Decal Wizard Dialog Box

Objects
Table  80. CAE Decal Wizard Dialog Box contents

Name Description

Preview area Displays what the CAE decal looks like based on your settings.

Pin Length area Sets the horizontal and vertical distance from the terminal connection 
point to the decal outline.

Pin Spacing area Sets the horizontal and vertical distance between pins.

Box Parameters area Sets the width and height of the decal outline.

 Tip
• Pin decals are moved left or right to accommodate the box 

width.
• If you enter a value larger than needed to accommodate the 

number of input or output pins, space is added to the bottom of 
the decal.

Left Pins area Specifies the pin decal and pin count for the left, or input, side of the 
part.

• Pin Decal  — Specifies the pin decal to use for this side.

• Pin Count  — Specifies the number of pins to use on this side.

Right Pins area Specifies the pin decal and pin count for the right, or output, side of the 
part.

494 SailWind Logic Guide



 
SailWind Logic GUI Reference
CAE Decal Wizard Dialog Box

Table  80. CAE Decal Wizard Dialog Box contents  (continued)

Name Description

• Pin Decal  — Specifies the pin decal to use for this side.

• Pin Count  — Specifies the number of pins to use on this side.

Upper Pins area Specifies the pin decal and pin count for the upper side of the part.
• Pin Decal  — Specifies the pin decal to use for this side.

• Pin Count  — Specifies the number of pins to use on this side.

Lower Pins area Specifies the pin decal and pin count for the lower side of the part.
• Pin Decal  — Specifies the pin decal to use for this side.

• Pin Count  — Specifies the number of pins to use on this side.

Related Topics
Using the Decal Wizard
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Capture a New View Dialog Box
To access: View  > Save View  menu item > Capture  button

Use the Capture a New View dialog box to name the view you want to save.

Figure 47. Capture a New View Dialog Box

Objects
Table  81. Capture a New View Dialog Box contents

Name Description

Name Specifies the name you want for the view. View n  is the default name 
where n  is the next number available.

 Tip
You can create up to nine views. The view names appear at the 
bottom of the View  menu.

Related Topics
Saving and Restoring Views
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Change Part Type Dialog Box
To access: Select a part > right-click > Properties  > Change Type  button

Use the Change Part Type dialog box to change the selected part to a new part type. The new part type 
can be one that already exists in the schematic or in the parts library. If multiple parts are selected, all of 
the selected parts are changed.

Figure 48. Change Part Type Dialog Box

Objects
Table  82. Change Part Type Dialog Box Contents

Name Description

Picture area Displays the part selected in the Part Types list.

Part Types list Lists all of the part types according to the filter settings.

Update attributes common to 
design and library

Updates parts having common attributes with the attribute values 
contained in the new part.

Preserve attributes in design not 
present in library

Retains attributes that exist in the current part even though they do 
not exist in the new part.
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Table  82. Change Part Type Dialog Box Contents  (continued)

Name Description

Apply update to area Sets how parts are updated in the Apply update to area:
• This Gate  — Only updates the selected gate.

• Selected Gates  — Only updates the selected gates.
 Restriction:
Available only when multiple parts are selected.

• This Part  — Only updates a part or all associated gates of a 
part.

• Selected Parts  — Only updates a part or all associated gates 
of the selected parts.

 Restriction:
Available only when multiple parts are selected.

• All Parts This Type  — Updates all matching gates and/or parts 
in the design.

 Restriction:
Unavailable when multiple parts are selected.

 Tip
• You can update the part definition in the schematic with a 

modified version in the library. Select the same part name, 
then click All Parts This Type in the Apply Update to Area.

• If you change a part type to one with fewer pins, the 
connections going to the missing pins are not deleted. They 
are attached to automatically generated off-page symbols. 
You are notified of all disconnected pins.

Library list Specifies the library you want to use.

Items Narrows the search. You can use wildcards or expressions  on 
page 105. An asterisk (*) displays all parts in the list.

Apply  button Searches the library for the specified item.

Related Topics
Modifying Parts
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Check for Updates Dialog Box
To access: Help  > Check for Updates  menu item

Use the Check for Updates dialog box to manually check for a new version of SailWind, and to disable or 
enable automatic checks.

Figure 49. Check for Updates Dialog Box

Objects
Table  83. Check for Updates Dialog Box contents

Name Description

Check for Updates  button Manually checks for a new version of the SailWind software.

Disable “Check for Updates” 
functionality

Determines if SailWind automatically checks for a new version of the 
software.
Click to stop SailWind from automatically checking for a new version 
of the SailWind products; click to clear to have SailWind automatically 
check for a new version.

Related Topics
SailWind Updates
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Class Rules Dialog Box
To access: Setup  > Design Rules  menu item > Class  button

Use the Class Rules dialog box to define rules that apply to a collection of nets known as a net class and 
to multiple net classes.

Figure 50. Class Rules Dialog Box

Objects
Table  84. Class Rules Dialog Box Contents

Name Description

Class Name Specifies the class name for which you want to apply rules.

Class list Defines net classes by name and parenthetically notes the rules 
that apply, if any, to the class.

Show Classes with Rules Specifies to list only classes with at least one set of rule definitions.

Add  button Adds a new Class Name to the Class list.

Delete  button Removes the selected Class Name from the Class list.

Rename  button Renames the selected Class Name in the Class list.

 Tip
Select the name in the list, type the new name in the Class 
Name box and then click Rename.
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Table  84. Class Rules Dialog Box Contents  (continued)

Name Description

Clearance  button Opens the Clearance Rules Dialog Box.

Routing  button Opens the Routing Rules Dialog Box.

Hi Speed  button Opens the HiSpeed Rules Dialog Box.

Report  button Opens the Rules Report Dialog Box.

Available list Lists all of the available nets for this Class.

Add>>  button Moves the net from the Available list to the Selected list.

<<Remove  button Moves the net from the Selected list to the Available list.

Selected list Lists all of the selected nets for this Class.

Default  button Removes non-default rules from the selected nets, so that only 
default rules apply.
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Clearance Rules Dialog Box
To access: Setup  > Design Rules  menu item > a rule hierarchy button > Clearance  button

Use the Clearance Rules dialog box to define the spacing permitted between objects. When objects are 
imported, the On-line DRC and Verify Design programs use these rules to check and report clearance 
violations.

Figure 51. Clearance Rules Dialog Box

Objects
Table  85. Clearance Rules Dialog Box contents

Name Description

Same Net area Defines edge-to-edge clearance values between items that are in the 
same net.

 Tip
• To define the minimum spacing between any two objects, type 

the value in the corresponding text box.
• To define the same spacing value for all text boxes in one matrix 

column, press the button above the column. Type a value and 
click OK.

• To define the same spacing value for all text boxes in one matrix 
row, press the button in the left column. Type a value and click 
OK.

• To define the same spacing value for all text boxes in the matrix, 
press the All  button. Type a value and click OK.

See also Same Net Matrix

Trace Width area Specifies to restrict the trace width to a range of values.
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Clearance Rules Dialog Box

Table  85. Clearance Rules Dialog Box contents  (continued)

Name Description

 Tip
• In the Recommended box, type the width you want to assign to 

the trace when routing begins.
• In the Minimum and Maximum boxes, values are respected 

by routing routines that must use trace width to achieve some 
high-speed routing functions, such as impedance matching.

Clearance area Defines edge-to-edge clearances between two object types:
• To define the minimum spacing between any two objects, type the 

value in the appropriate text box.

• To define the same spacing value for all text boxes in one matrix 
column, press the button above the column and type a value.

• To define the same spacing value for all text boxes in one matrix 
row, press the button in the left column and type a value.

• To define the same spacing value for all text boxes in the matrix, 
press the All  button and type a value.

Other area Specifies other optional clearance values.
• Drill to Drill  — The minimum edge-to-edge spacing between two 

drill holes.

• Body to Body  — The minimum edge-to-edge spacing between two 
component bodies.

Delete  button Removes this set of Clearance rules from your rules hierarchy.

 Tip
You cannot delete the Default Clearance rules.

Related Topics
Setting Up Clearance Rules
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Compare/ECO Tools Dialog Box
When you compare two versions of a design, you can create an output file that lists the differences 
between the two versions. The report file is named Logic.rep  and is written to the \SailWind Projects 
folder.

Restriction:
Transferring non-ECO-registered parts and non-electrical parts is constrained. See Options 
Dialog Box, Design Category  for details.

To access: Tools  > Compare/ECO  menu item

Compare/ECO Tools Dialog Box, Documents Tab
Compare/ECO Tools Dialog Box, Comparison Tab
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Compare/ECO Tools Dialog Box, Documents Tab
To access: Tools  > Compare/ECO  menu item > Documents  tab

Use the Documents  tab to specify the design netlists to compare and the files to create.

Tip
You can compare designs in any of the following forms:
• Schematic in memory
• Binary schematic file (.sch)
• PADS-format ASCII file (.asc)

Restriction:
Transferring non-ECO-registered parts and non-electrical parts is constrained. See Options 
Dialog Box, Design Category  for details.

Figure 52. Compare/ECO Tools Dialog Box, Documents Tab
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Objects
Table  86. Compare/ECO Tools Dialog Box, Documents Tab Contents

Name Description

Original Schematic Design to 
Compare

Specify the design you want to update. Do one of the following:
• Select Use Current Schematic Design to use the schematic in 

memory as the original design.

• Clear Use Current Schematic Design, and then type or browse 
to the original design file. The original design file format can 
be binary (.sch) or PADS-format ASCII (.asc) output from the 
schematic or layout.

 Restriction:
The original design cannot have the same filename as the new 
design.

New Current Schematic Design Specify the design containing the changes you want to place into 
the original design. Do one of the following:

• Select Use Current Schematic Design to use the schematic in 
memory as the new design.

• Clear Use Current Schematic Design, and then type or browse 
to the new design file. The new design file format can be binary 
(.sch) or PADS-format ASCII (.asc) output from the schematic 
or layout.

 Restriction:
The new design cannot have the same filename as the original 
design.

Output Options Specifies to create a report file containing a description of the 
differences between the two design versions. This file is named 
Logic.rep  and is stored in the \SailWind Projects  folder.

Generate ECO File Specifies to create an ECO file. Type or browse to the ECO file. 
The ECO file contains ECO commands that describe the changes 
needed to update the original design to match the new design.

Related Topics
Forward Annotation From SailWind Logic to SailWind Layout

Backward Annotation From SailWind Layout to SailWind Logic

Contents of the Differences Report
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Compare/ECO Tools Dialog Box, Comparison Tab

Compare/ECO Tools Dialog Box, Comparison Tab
To access: Tools  > Compare/ECO  menu item> Comparison  tab

Use the Comparison  tab to specify the design elements to include in the design netlists comparison.

Restriction:
Transferring non-ECO-registered parts and non-electrical parts is constrained. See Options 
Dialog Box, Design Category  for details.

Figure 53. Compare/ECO Tools Dialog Box, Comparison Tab

Objects
Table  87. Compare/ECO Tools Dialog Box, Comparison Tab Contents

Name Description

Comparison Options area

Compare Part Attributes Comparison includes part attributes. Only part attributes are 
compared and updated or reported. Each part receives attributes 
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Table  87. Compare/ECO Tools Dialog Box, Comparison Tab Contents  (continued)

Name Description
from its corresponding Decal and Part Type, but modification is 
performed only at the part level.
SailWind Logic categorizes parts that have different attributes as 
different part types. Therefore, if you select Include Part Attributes 
when you generate the netlist, you must also select Compare Part 
Attributes when you perform an ECO comparison of that netlist. 
Otherwise the comparison considers the part types to be different 
and reports errors.

Compare Net Attributes Comparison includes net attributes.
SailWind Logic categorizes nets that have different attributes 
as different nets. Therefore, if you select Include Net Attributes 
when you generate the netlist, you must also select Compare Net 
Attributes when you perform an ECO comparison of that netlist. 
Otherwise the comparison considers the net types to be different 
and reports errors.

Compare PCB Decal Assignments Comparison includes PCB decal assignments.

Compare Design Rules Comparison includes design rules. Only Default, Net, and Net 
Class rules are compared. Rules on other objects in the original 
design are preserved where possible.

Name Comparison Options area

Compare Net Names and 
Reference Designators. Rename 
as Necessary

Compare differences using reference designators and net names.
Best used to minimize changes to routed traces. Selecting this 
option may result in the positional swapping of parts.

Compare Net Names and 
Reference Designators. Prefer 
to Add or Delete Parts Instead of 
Renaming

Compare differences using reference designators and net names 
on the basis that few reference designators have been renamed 
and nets have not been renamed.
Best used to minimize the positional swapping of parts, and the 
design disruption that may result.

Compare Connectivity and 
Topology (not names). Rename 
as necessary.

Compare differences without using reference designators or net 
names. Compare differences using pin names, part type names, 
and so on.
Best used to compare designs when parts and nets have been 
renamed and minimal interconnect changes have been performed.

Unused Pins Net Name area

Ignore the Unused Pins Net Select the check box and type the name of the unused pins net if 
you want the design comparison to exclude the unused pins net in 
the original design. The unused pins net contains pins that have no 
logical net association. An unused pins net may be created in the 
PCB design process.

 Restriction:
Specify a net name of 47 characters or less. Use any 
alphanumeric characters except curly braces {}. asterisks *, or 
spaces.
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Table  87. Compare/ECO Tools Dialog Box, Comparison Tab Contents  (continued)

Name Description

 Tip
If you clear this option and you update the PCB layout from 
SailWind Logic, the unused pins net may be deleted.

Related Topics
Forward Annotation From SailWind Logic to SailWind Layout

Backward Annotation From SailWind Layout to SailWind Logic

Contents of the Differences Report
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Conditional Rule Setup Dialog Box
To access: Setup  > Design Rules  menu item > Conditional Rules  button

Once you set up Clearance rules for a group in the hierarchical order, the rules are applied to all other 
objects. Use the Conditional Rule Setup dialog box to apply a third overriding set of rules that apply only 
when the item meets other specific levels of the hierarchical order.

Tip
When setting up conditional rules, observe the following:
• You can use a layer as an against object, where rules you set for an object such as a net apply 

only when the net is routed on that layer.
• You can further refine this to use another net as an against object and specify a layer to which 

the rules to apply. If these two nets meet on this layer, they must adhere to this clearance. You 
define these relationships by making conditional rule sets.

Figure 54. Conditional Rule Setup Dialog Box
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Conditional Rule Setup Dialog Box

Objects
Table  88. Conditional Rule Setup Dialog Box Contents

Name Description

Source Rule Object area Specifies the object you want to use to check rules. Choose 
Classes, Nets, or All.

Against Rule Object area Specifies which object to use to check the rules against. Choose 
Layer, Classes, or Nets.

Apply to Layer list Specifies the layer on which you want the rules to be checked.

Existing Rule Sets list Lists rule sets that have already been created.

Current Rule Set area

Clearance
Object to Object

Specifies the minimum clearance gap you want the source and 
against items to maintain from each other.

Matrix  button Opens the Clearance Rules Dialog Box.

High Speed Specifies the clearance values for parallel and tandem checking 
for the condition. The source-against entries are used as the 
victim-aggressor designations for crosstalk conditions checking.
For more information, see Setting Up High-Speed Rules.

Create  button Compile the new rule set parameters and adds a description to the 
Existing Rule Sets list box.

Delete  button Removes the selected rule set from the Existing Rule Sets list box
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Connect to SailWind Layout Dialog Box
To access: Tools  > SailWind Layout  menu item

Use the Connect to SailWind Layout dialog box to choose your connection to SailWind Layout. You can 
then gain access to the SailWind Layout Link dialog box.

Figure 55. Connect to SailWind Layout Dialog Box

Objects
Table  89. Connect to SailWind Layout Dialog Box Contents

Name Description

New  button Opens and connects SailWind Logic to a new session of SailWind Layout then 
opens the SailWind Layout Link Dialog Box.

 Tip
If there is a delay in launching and connecting to SailWind Layout, the Server 
Busy Dialog Box  may appear. Wait a short time or till SailWind Layout appears 
on your Windows Taskbar then click Retry.

Open  button Opens and connects to an existing design file in a new SailWind Layout session 
then opens the SailWind Layout Link Dialog Box.

 Tip
If a prompt window is open in SailWind Layout, the Server Busy Dialog Box 
may appear. Click the Switch To  button and take care of the prompt to enable 
SailWind Logic to connect to SailWind Layout.
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Connect to SailWind Router Dialog Box
To access: Tools  > SailWind Router  menu item

Use the Connect to SailWind Router dialog box to choose your connection to SailWind Router. You can 
then gain access to the SailWind Router Link dialog box.

Figure 56. Connect to SailWind Router Dialog Box

Objects
Table  90. Connect to SailWind Router Dialog Box Contents

Name Description

New  button Opens and connects SailWind Logic to a new session of SailWind Router then 
opens the SailWind Router Link Dialog Box.

 Tip
If there is a delay in launching and connecting to SailWind Router, the Server 
Busy Dialog Box  may appear. Wait a short time or till SailWind Router appears 
on your Windows Taskbar then click Retry.

Open  button Opens and connects to an existing design file in a new SailWind Router session 
then opens the SailWind Router Link Dialog Box.

 Tip
If a prompt window is open in SailWind Router, the Server Busy Dialog Box 
may appear. Click the Switch To  button and take care of the prompt to enable 
SailWind Logic to connect to SailWind Router.
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Crash Detected Dialog Box
To access: This dialog box is inaccessible unless the software crashes and crash detection is enabled in 
the software .ini  file.

The Crash Detected dialog box opens at a crash and enables you to save a report of the SailWind 
environment as well as pertinent files into a compressed SailWind Dump File for troubleshooting.

Objects
Table  91. Crash Detected Dialog Box Contents

Name Description

Comments box You can describe what you were doing when the error occurred 
or anything else you can think of that might help when 
investigating the crash.

Attach BMW data check box You can include BMW data and your project files. This will enable 
customer support to play back what you were doing in your 
design that led up to the crash. This check box is unavailable if 
the BMW feature is not enabled.
See also BMW and BLT.

Save  button You must click the Save  button if you want to create a report file. 
When you click the Save  button, you are prompted with a Save 
As dialog box. The file that is created is called a Dump File and is 
compressed in the .zip  format. This is the file that you must send 
to customer support. It will include the report, the BMW data and 
the project files.
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Create PDF Dialog Box
To access: File  > Create PDF  menu item > enter filename > Save

You can create an intelligent PDF of your schematic, choosing which sheets you want to share and show 
to others in your organization. You can create the PDF in full-color or black and white, with hyperlinks to 
part attributes, and with search capabilities, making it easy to locate parts and nets. Once you locate a 
net, you can find other instances of it through the entire schematic, even when the net is on a different 
page. You can also create a black and white, non-searchable PDF of your schematic.

Restriction:
To search a PDF, you must substitute the Stroke font with a System font.

Tip
Adobe® Acrobat® Distiller™ is not required on your system to create a PDF.
See also Printing to PDF.

Figure 57. Create PDF Dialog Box
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Objects
Table  92. Create PDF Dialog Box Contents

Name Description

Available list List all of the sheets available to you.

Add >>  Button Moves the selected sheet to the Sheets to PDF list.

Add All >>  Button Moves all sheets to the Sheets to PDF list.

<< Remove  button Moves the selected sheet to the Available list.

<< Remove All  Button Moves all sheets to the Available list.

Sheets to PDF list Lists the sheets you want to PDF.

View PDF after creation Specifies to open the PDF after it has been created.

Replace Stroke font with Specifies to replace the Stroke font with a system font. Select the font you 
want from the list. Use the Font style buttons to add Bold, Italic, or Underline 
styles.

 Restriction:
• You can only search a PDF if you replace the Stroke font with a 

System font.
• There is no font size control. Text heights are already set for each text 

item in the design. The height will be converted to the nearest point 
size in the PDF.

Create hyperlinks 
that will display part 
attributes

Specifies to create a listing of the part attributes as a hyperlink.

Create hyperlinks that 
will pan through nets

Specifies to create a link to pan to the next instance of that net or bus.

 Restriction:
If the net name is not visible in the schematic, you will not be able to pan 
through the nets.

Visible rectangle around 
objects with hyperlinks

Specifies to create all hyperlinks with visible boxes: yellow around the part 
attributes, blue around the net and bus names.

 Restriction:
This check box is only available when one of the two check boxes above 
it is clicked.

Color scheme area Specifies the color scheme you want to use.

 Tip
The colors used in the Color on Black or Color on White schemes are 
the same colors currently used in your schematic. The Black on White 
scheme shows all currently visible items in the schematic in black.
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Customize Dialog Box
Use the Commands  tab to add commands to menus or toolbars, or to create custom menus.

To access: Tools  > Customize  menu item

Customize Dialog Box, Commands Tab
Customize Dialog Box, Keyboard and Mouse Tab
Customize Dialog Box, Macro Files Tab
Customize Dialog Box, Options Tab
Customize Dialog Box, Toolbars and Menus Tab
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Customize Dialog Box, Commands Tab
To access: Tools  > Customize  menu item > Commands  tab

Use the Commands  tab to add commands to menus or toolbars, or to create custom menus.

Figure 58. Commands Tab

Objects
Table  93. Command Tab Contents

Name Description

Categories list Narrows down the list of commands.

Commands list List of commands available to add to a menu or toolbar.

Add a new command, delete a command you’ve added, or rename 
a command you’ve added.

Related Topics
Creating a Custom Command

Creating a Custom Menu

Defining Properties for a New Command
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Customize Dialog Box, Commands Tab

Editing a Custom Command

Adding Items to Toolbars and Menus
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Customize Dialog Box, Keyboard and Mouse Tab
To access: Tools  > Customize  menu item > Keyboard and Mouse  tab

Create and customize shortcut keys using the Keyboard and Mouse  tab of the Customize dialog box.

Figure 59. Keyboard and Mouse Tab

Objects
Table  94. Keyboard and Mouse Tab Contents

Name Description

Mode list Narrows down the list of commands.

Commands list The list of commands available for which to assign a shortcut.

Add a new command (opens the Add Command Dialog Box 
on page 440), delete a command you’ve added, or rename a 
command you’ve added (opens the Edit Command dialog box  on 
page 440).

Current shortcuts list The list of shortcuts assigned to the selected command.

Add a new shortcut (open the Assign Shortcut Dialog Box), or 
delete a shortcut you’ve added.

Description Lists what the selected command does.
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Customize Dialog Box, Keyboard and Mouse Tab

Table  94. Keyboard and Mouse Tab Contents  (continued)

Name Description

Reset All  button Sets the selected toolbar or shortcut menu to the default settings.

Report  button Saves a report of all current shortcut commands.
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Customize Dialog Box, Macro Files Tab
To access: Tools  > Customize  menu item > Macro Files  tab

Create commands from macro files and add them to toolbars and menus using the Macro Files  tab.

Tip
To create a command from a macro command file, the macro command file (.mcr) must already 
exist. You can create a macro by recording it in a SailWind tool or scripting it in Macro language. 
For more information, see “Macros”  on page 47.

Figure 60. Macro Files Tab

Objects
Table  95. Macro Files Tab Contents

Name Description

Macro Command Files list The list of macro files you have opened.

Add a macro to the list (opens the Open Macro dialog box), delete 
a macro from the list, or edit the location of a macro you’ve added.

Description Lists what the selected macro does.
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Customize Dialog Box, Options Tab
To access: Tools  > Customize  menu item > Options  tab

Customize the SailWind interface by changing the appearance of menus and toolbars using the Options 
tab of the Customize dialog box.

Figure 61. Options Tab

Objects
Table  96. Options Tab Contents

Name Description

Show ToolTips on toolbars Displays the button name over the toolbar button when you hover 
over it with your pointer.

Show shortcuts in ToolTips In addition to the name in the ToolTip, displays the shortcut for the 
button.

Large Icons Displays icons on the toolbar larger than the default size.

Menu animations list The type of animation for your menus: None, Unfold, Slide, or 
Fade.

Menu shadows Displays a shadow behind the menu.
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Table  96. Options Tab Contents  (continued)

Name Description

Wait until <Enter> before 
executing long shortcuts

Delays the execution of shortcut keys until you press Enter.

Show recent commands first Displays your recent menu command selections at the top of the 
list.

Show full menus after delay Displays the full menu after a slight pause.

Reset my usage data button Restores the default set of commands to the menus and toolbars.

 Tip
This option does not undo any explicit customizations you 
made.

Visual Style Sets the look and feel of your toolbars and title bars.

Interface Language Specifies the language for all dialog boxes and messages 
displayed: English, Chinese Simplified.

Related Topics
Customized Appearance of the Screen
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Customize Dialog Box, Toolbars and Menus Tab
To access: Tools  > Customize  menu item > Toolbars and Menus  tab

Use the Toolbars and Menus  tab on the Customize dialog box to create custom toolbars and shortcut 
menus.

Tip
To create a custom main menu, use the Commands  tab on the Customize dialog box. See 
Creating a Custom Menu.

Figure 62. Toolbars and Menus Tab

Objects
Table  97. Toolbars and Menus Tab Contents

Name Description

Toolbars list Specify which toolbars to display in the main window.

Add a new toolbar, delete a toolbar you’ve added, or rename a 
toolbar you’ve added.

Show text labels Shows the text label on the button in addition to the icon.

Select shortcut menus Specifies the shortcut menu you want to customize.
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Table  97. Toolbars and Menus Tab Contents  (continued)

Name Description

 Restriction:
SailWind Router only.

Reset  button Sets the selected toolbar or shortcut menu to the default settings.

Reset All  button Sets all toolbars or shortcut menus back to their default settings.

Related Topics
Customizing the SailWind Interface
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DC Source Sweep Analysis Dialog Box
To access: Tools  > SPICE Netlist  menu item > Simulation Setup  button> DC Sweep  button

Use the DC Source Sweep Analysis dialog box to set options specifically for a DC Sweep analysis.

Figure 63. DC Source Sweep Analysis Dialog Box

Objects
Table  98. DC Source Sweep Analysis Dialog Box Contents

Name Description

Source Specifies the name of the voltage or current source.

Start Specifies the starting voltage for the sweep.

End Specifies the stopping voltage for the sweep.

Step Specifies the incrementing values for the sweep.

Related Topics
Creating a SPICE Netlist

Setting Up DC Source Sweep Analysis
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Default Rules Dialog Box
To access: Setup  > Design Rules  menu item > Default  button

Use the Default Rules dialog box to define rules which apply to all objects that are not included in any 
other rule within the hierarchy.

Figure 64. Default Rules Dialog Box

Objects
Table  99. Default Rules Dialog Box Contents

Name Description

Clearance  button Opens the Clearance Rules Dialog Box.

Routing  button Opens the Routing Rules Dialog Box.

Hi Speed button Opens the HiSpeed Rules Dialog Box.

Report  button Opens the Rules Report Dialog Box.
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Differential Pairs Dialog Box
To access: Setup  > Design Rules  menu item > Differential Pairs  button

Use the Differential Pairs dialog box to identify nets or pin pairs that behave electrically as differential 
pairs, and to define differential pair design rules.

Figure 65. Differential Pairs Dialog Box

Objects
Table  100. Differential Pairs Dialog Box Contents

Name Description

Available list Lists nets that have not been assigned to a differential pair.
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Table  100. Differential Pairs Dialog Box Contents  (continued)

Name Description

Selected list Lists the nests that have been selected.

 Tip
Click Add  to move the selected nets to the Pairs list.

Select >>  button Moves the selected net to the Selected list.

<<Unselect  button Moves the net that was previously selected back to the Available 
list.

Add>>  button Moves the two nets in the Selected list to the Pairs list.

<<Remove  button Moves the two nets in the Pairs list to the Available list.

Pairs list Lists the differential pairs.

Trace length area Specifies the minimum and maximum trace length values.

Restrict layer changes during 
autorouting

Forces the pair to be routed on a single layer.

 Tip
This setting does not restrict layer changes when routing 
interactively.

Properties of the pair table Sets the width and gap per layer.

Add  button Adds a row to the Properties of the pair table.

Delete  button Removes the selected row from the Properties of the pair table.

Obstacles area Specifies to allow routing around an obstacle in the controlled gap 
area by temporarily exceeding the pair routing gap.

 Tip
This setting applies to autorouting and does not restrict splitting 
around obstacles when routing interactively.

Also specifies the maximum number of obstacles and the 
maximum obstacle size.

 Tip
Obstacles in the start zone  or end zone  are not counted.

Report  button Opens the Rules Report Dialog Box.
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Display Colors Dialog Box
To access: Setup  > Display Colors  menu item

Use the Display Colors Setup dialog box to Set display colors, save them, and restore them; Change the 
color palette; make objects visible; and make objects invisible.

Tip
Changes you make to the color configuration in the Display Colors Setup dialog box do not apply 
to disabled layers.

Figure 66. Display Colors Setup Dialog Box
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Objects
Table  101. Display Colors Setup Dialog Box Contents

Name Description

Selected Color area Select a color from the palette to assign to items on a layer. Once 
you select a color here, click the tile in the Color by Layer area of 
the item to which you want to assign the color.

Palette  button Opens the Color dialog box where you can choose to use new 
colors or customize colors you want to use.

Default Palette  button Reassigns all colors and settings to the default settings.

 Tip
You can change the default settings by saving a configuration 
and naming it default.

Misc area Apply a color to objects in the Misc area to change the color of that 
object in the workspace.

Titles area To make a text string visible in the part editor, select the check box 
beside the string type in the Titles area.

Configuration list The list of saved configurations.

Save  button Opens the Save Configuration Dialog Box.

Delete  button Removes the selected configuration from the Configuration list.

Related Topics
Display Colors Dialog Box - Part Editor

Setting Display Colors
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Display Colors Dialog Box - Part Editor
To access: In the Part Editor, Setup  > Display Colors  menu item

Use the Display Colors dialog box while in the Part Editor or the CAE Decal Editor to control the colors 
of objects and the working area. SailWind Logic saves the color settings for part editor items with the 
schematic. This dialog box is similar to the one used in the schematic editor, with check boxes to display 
text items.

Figure 67. Display Colors Dialog Box in the Part Editor

Objects
Table  102. Display Colors Dialog Box contents

Name Description

Selected Color Select a color in this area to apply to tiles in the Items area.

Palette  button Click to open the Color dialog box where you can specify new 
colors or customize colors that appear in the Selected Color area.

Default Palette  button Click Default Palette to restore the default color settings in the 
Selected Color area.

 Tip
Refer to the Microsoft Windows Help for more information 
about changing the Color Palette.

Background Apply a color to this color tile to change the background color or 
work area surface in the Part Editor workspace.
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Table  102. Display Colors Dialog Box contents  (continued)

Name Description

 Tip
• To make an item invisible, set it to the background color.
• The color selection for displaying items or making them 

invisible does not affect plotting of the schematic.

Selections Apply a color to this color tile to change the color of objects that 
you select in the workspace.

Items area Apply a color to objects in the Items area to change the color of 
that object in the workspace.

 Tip
Some of the items have a color setting in the Box column. Box 
indicates the color of the box that is drawn around the text item. 
This box serves two purposes: it indicates the exact size of the 
text item when it is plotted, thereby helping you avoid overlaps 
while moving the item; and it provides visibility of the text item 
at very small zoom levels.

Names area To make a text string visible in the part editor, select the check box 
beside the string type in the Names area.

 Restriction:
• This area is only available when editing a CAE decal, pin 

decal, or when editing the graphics of individual connector, 
or off-page type symbols.

• When editing a CAE decal - Sheet Number is unavailable.
• When editing a pin decal - Reference Designator, Part-Type 

Name, Attribute Labels, and Sheet Number are unavailable.
• When editing the pin decal of an off-page, power or ground 

symbol - only Netnames and Sheet Number are available.
• When editing the graphics of a single connector pin - only 

Ref Designator, Part-Type Name, and Attribute Labels are 
available.
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Drafting Properties Dialog Box
To access: Select a drafting object > right-click > Properties  menu item

Use the Drafting Properties dialog box to modify the line width, style, and orientation of selected drafting 
objects.

Figure 68. Drafting Properties Dialog Box

Objects
Table  103. Drafting Properties Dialog Box Contents

Field Description

Width Specifies the line width for the drafting object. The current line width of the 
selected drafting object is automatically displayed, change it if necessary.

 Tip
Use the Line Widths  tab in the Options dialog box to change the 
default line width.

Filled Specifies to create a filled shape from a selected polygon.

 Tip
This option is grayed for circles, paths, and if you used Pull Arc to 
modify the polygon.

Style area Specifies the line style option for the selected drafting object: Solid or 
Dotted.

Rotation Specifies the degree of rotation from the Rotation list.

 Tip
• Rotation can be 0 or 90 degrees.
• The point used when selecting the object is the also the point of 

rotation.

Mirror by X Specifies to mirror the selected drafting object in the X (horizontal) 
direction.

Mirror by Y Specifies to mirror the selected drafting object in the Y (vertical) direction.
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Related Topics
Modifying Drafting Objects
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Edit Button Image Dialog Box
To access: Tools  > Customize  menu item > Commands  tab > New  button > Select User-Defined Image 
> New  or Edit  button

Use the Edit Button Image dialog box to create or edit button icons.

Figure 69. Edit Button Image Dialog Box

Objects
Table  104. Edit Button Image Dialog Box Contents

Field Description

Colors area Select a color to use with the tools

Tools area Select a tool to draw/edit the picture or icon of the button
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Fields Dialog Box
To access: Select nothing or a 2D line object > right-click > Fields  menu item

Use the Fields dialog box to manage multiple fields. You can manage the fields in the entire schematic or 
in a 2D line object.

Figure 70. Fields Dialog Box

Objects
Table  105. Fields Dialog Box Contents

Field Description

System Displays the name and value for all system fields in the design.

Delete  button Removes the selected row.

 Restriction:
System fields can be deleted from 2D line items only.

User Displays the name and value for all user fields in the design

Add  button Inserts a row at the bottom of the list where you can add a new field.

Delete  button Removes the selected row.

Edit  button Makes the selected cell available for editing.
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Fields Dialog Box

Table  105. Fields Dialog Box Contents  (continued)

Field Description

 Tip
You can also double-click a cell to edit the contents.

Related Topics
Managing Fields
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Field Properties Dialog Box
To access: Select a field > right-click > Properties  menu item

Use the Field Properties dialog box to modify a field name or change its text size, orientation, or 
justification.

Figure 71. Field Properties Dialog Box

Objects
Table  106. Field Properties Dialog Box Contents

Name Description

Name The name of the field. Type a new or select an existing field name 
to change it.

Value Specifies the text you want in the schematic.

X/Y Type coordinates to place the text in a specified location.

Rotation Specifies the rotation of the text: 0 or 90 degrees.

Line Width Specifies the line width for stroke fonts only.
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Table  106. Field Properties Dialog Box Contents  (continued)

Name Description

Size Specifies the size of the font.
Size (pts):  This is font size in points and appears for system fonts
Size (mils):  This is font character height and appears for stroke 
fonts. The size refers to the height of the tallest characters.

Font Style Enables you to change the font style to bold, italic, and underlined.

 Restriction:
System fonts only.

Font list The fonts available to you. This lists either stroke fonts or system 
fonts. You choose which type of font to use in the Fonts Dialog 
Box.

 Tip
• Select stroke font or a system font.
• For system fonts, you can also click a font style button, or 

any combination of styles: B  for bold, I  for italic, or U  for 
underlined.

Horizontal/Vertical Justification Specifies the horizontal (Right, Center, Left) justification and the 
vertical (Up, Center, Down) justification of the text.

Related Topics
Modifying Fields

Add Field Dialog Box
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Font Replacement Dialog Box
To access: When you open a design created with fonts that are not installed on your system, the Font 
Replacement dialog box opens automatically.

Use the Font Replacement dialog box to manage how missing fonts are replaced in your design.

Tip
If the design uses fonts or character sets that are not installed on your system, empty boxes will 
appear where you expect to find text or symbols. Once the font replacement process completes, 
the symbols display properly.

Figure 72. Font Replacement Dialog Box

Objects
Table  107. Font Replacement Dialog Box Contents

Name Description

Mode Specifies the mode to replace this font.
• Automatic  — Specifies to replace the font automatically with 

the one selected by SailWind Layout.

• Manual  — Specifies to replace the font with one you select 
from the Replace with font list.

• Skip  — Specifies to preserve the original font.
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Table  107. Font Replacement Dialog Box Contents  (continued)

Name Description

Missing font The name of the font in this design that is missing from your 
system.

Replace with font If you chose Manual, lists the fonts available for you to replace the 
missing font.
If you chose Automatic, lists the font SailWind Layout chose to 
replace the missing font.

Tip
When replacing fonts, observe the following:
• You can select some fonts for automatic replacement, select others for manual replacement, 

and choose that other font replacements be skipped entirely.
• You can have a combination of stroke font and system fonts within the same design.
• You must set up fonts for each text string and/or label you create in your design. Once you set 

up fonts for a text string or label, you can then use the Properties dialog to apply a font and font 
characteristics to all objects that you select for modification with the Properties dialog box.

Restriction:
When working with fonts note the following restrictions:
• If the design uses fonts or character sets that are not installed on your system, a font 

substitution process begins automatically when the file is loaded. During this process, you are 
asked to choose fonts to substitute for those that are missing from your system.

• System font text is supported in RS274X Gerber format when Fill mode is on. System font text 
is output to Gerber format as a set of filled polygons.

• System fonts are not supported in the RS-274D CAM output format. If you attempt to use this 
format with system fonts, the program displays a warning message. If you proceed, system 
fonts will not be output. Instead, you should use the 274X format with system fonts.

• Type 1 fonts are not supported.

Related Topics
Managing Font Replacement
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Fonts Dialog Box
To access: Setup  > Fonts  menu item

Use the Fonts dialog box to set up or change the fonts to be used in your design.

Restriction:
If the schematic uses fonts or character sets that are not installed on your system, a font 
substitution process begins automatically when the file is loaded. During this process, you are 
asked to select fonts to substitute for those that are missing from your system.

Tip
If you want to change font sizes, see Modifying Part Type Labels.

Figure 73. Fonts Dialog Box

Objects
Table  108. Fonts Dialog Box Contents

Name Description

Font Style The fonts available to you:
• Stroke

• System

Default Font list Specifies the system font you want to use.

 Tip
You can also click a font style button, or any combination of 
styles: B  for bold, I  for italic, or U  for underlined.

Related Topics
Setting Fonts
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Get Drafting Items From Library Dialog Box
To access: Schematic Editing toolbar > Add 2D Line from Library  button

Use the Get Drafting Item from Library dialog box to load a 2D line item from the available libraries to the 
current schematic.

Figure 74. Get Drafting Items From Library Dialog Box

Objects
Table  109. Get Drafting Items From Library Dialog Box Contents

Field Description

Preview area Displays the selected gate decal

Drafting Items Lists the drafting items available based on the filter settings.

Library list Specifies the library you want to use.

Items Narrows the search. You can use wildcards or expressions  on page 105. 
An asterisk (*) displays all parts in the list.

Apply  button Searches the library for the specified item.

Related Topics
Adding Drafting Items From a Library
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Get Gate Decal From Library Dialog Box
To access: Tools  > Part Editor  menu item > Open  button > Select CAE Decal > OK  button

Use the Get Gate Decal from Library dialog box to open an existing CAE Decal in the Part Editor.

Figure 75. Get Gate Decals From Library Dialog Box

Objects
Table  110. Get Gate Decals From Library Dialog Box Contents

Field Description

Preview area Displays the selected gate decal

Gate Decals Lists the gate decals available based on the filter settings.

Library list Specifies the library you want to use.

Items Narrows the search. You can use wildcards or expressions  on page 105. 
An asterisk (*) displays all parts in the list.

Apply  button Searches the library for the specified item.

Related Topics
Getting Gate Decals From the Library
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Get PCB Decal From Library Dialog Box
To access: Select a part > right-click > Properties> PCB Decals button > Browse  button

Use the Get PCB Decal from Library dialog box to search a library for a PCB decal.

Figure 76. Get PCB Decal From Library Dialog Box

Objects
Table  111. Get PCB Decal From Library Dialog Box Contents

Name Description

Picture Area Displays the PCBdecal highlighted in the Decals area.

Decals Lists the available PCB decals in the selected library or all libraries.

Library list Lists the libraries available to you.

Filter Searches the chosen library (or libraries) for a specific part or item 
name, or names that match a wildcard or expression  on page 105. 
Use the Library dropdown list to select specific library directories 
or the All Libraries setting. Type * to view all parts or items in the 
chosen libraries. Click Apply  to search the libraries and display the 
search results.

Related Topics
Searching the Library for a Decal
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Hierarchical Symbol Wizard Dialog Box
To access: Schematic Editing toolbar > New Hierarchical Symbol  button

Use the Hierarchical Symbol Wizard dialog box to create a new hierarchical symbol in either a top-down 
or bottom-up design structure. The symbol creation methodology varies, depending on the structure you 
use.

Figure 77. Hierarchical Symbol Wizard Dialog Box

Objects
Table  112. Hierarchical Symbol Wizard Dialog Box Contents

Name Description

Preview Displays the symbol outline before the symbol appears in the Part Editor. 
Display is based on the current settings.

Pin Parameters area • Pin Length  — Sets the distance from the terminal connection point 
and the decal outline. This option does not adjust the length of the pin 
decal.

• Pin Spacing  — Specifies the spacing between adjacent pins.

Box Parameters area • Box Width  — Sets the width of the decal outline. Pin decals are 
moved left or right to accommodate the box width.

• Min Box Hgt.  — Sets the minimum height of the decal outline. If you 
enter a value larger than needed to accommodate the number of input 
or output pins, space is added to the bottom of the decal.

 Tip
Type values or use the arrow buttons.

Input Pins area • Pin Decal  — Specifies the type of pin decal.

• Pin Count  — Specifies the number of input pins for a hierarchical 
symbol of a new sheet during top-down design.

 Tip
Type values or use the arrow buttons.
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Table  112. Hierarchical Symbol Wizard Dialog Box Contents  (continued)

Name Description

Output Pins area • Pin Decal  — Specifies the type of pin decal.

• Pin Count  — Specifies the number of output pins for a hierarchical 
symbol of a new sheet during top-down design.

 Tip
Type values or use the arrow buttons.

Hierarchical Sheet area • Sheet Number  — Lists the sheets in the set or lists only the <New 
Sheet> option for top-down design.

 Restriction:
For bottom-up design, this list never displays the current sheet 
since you can place the symbol that represents the current sheet 
on the current sheet.

• Sheet-name  — Specifies the name of the hierarchical symbol.
 Restriction:

◦ Sheet Name has a maximum of 37 characters.
◦ You can only use the first 32 characters for the textual portion of 

the name, the remaining five are reserved for the numeric potion.

Related Topics
Creating a Top-Down Hierarchy

Creating a Bottom-Up Hierarchy
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HiSpeed Rules Dialog Box
To access: Setup  > Design Rules  menu item > a rule hierarchy button > HiSpeed  button

Use the HiSpeed Rules dialog box to define rules for Parallelism, Tandem, Shielding, Routed Length, 
Stub Length, Delay, Capacitance, Impedance, and Matched Length.

Tip
When working with HiSpeed Rules, observe the following:
• When imported into SailWind, the EDC (Electrodynamic Checking) routine checks to see if 

rules are met correctly after routing (except shielding and matched length).
• You can use the Conditional Rule Setup Dialog Box  to save a high speed configuration as 

a set, or to apply for a selected item only when it comes in contact with different level of the 
hierarchical order  on page 305.

Figure 78. HiSpeed Rules Dialog Box

Objects
Table  113. HiSpeed Rules Dialog Box contents

Name Description

Parallelism Restricts the distance that traces in different nets on the same layer 
can run together.

 Tip
• Length defines the maximum allowable parallel/tandem 

distance.
• Gap defines the minimum gap between traces below which the 

parallel/tandem rules apply.

Tandem Restricts the distance that traces in different nets on different layers 
can run together.
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Table  113. HiSpeed Rules Dialog Box contents  (continued)

Name Description

 Tip
• Length defines the maximum allowable parallel/tandem 

distance.
• Gap defines the minimum gap between traces below which the 

parallel/tandem rules apply.

Aggressor Specifies if a net is a source of interference, during parallel/tandem 
checks.

Rules area Specifies the minimum and maximum values for:
• Length  — Defines a minimum and maximum length.

• Stub Length  — Specifies a maximum stub length. The stub length 
is the distance from a T-point to the end of the route.

• Delay  — Defines a minimum and maximum delay time in 
nanoseconds.

• Capacitance  — Defines a minimum and maximum capacitance in 
picofarads.

• Impedance  — Defines a minimum and maximum impedance in 
ohms.

 Tip
These text boxes restrict the trace width to a range of values. 
Recommended is the width you want to assign to the trace when 
routing begins. The Minimum and Maximum values are respected 
by routing routines which must use trace width to achieve some 
high-speed routing functions, such as impedance matching.

Shield Specifies to arrange certain nets as shielding others; the Net in the 
Use Net list box is routed up and down both sides of a selected net to 
provide protection from interference.

 Tip
You can only assign nets associated with plane layers in the Layer 
Definition dialog box to shield other nets. If there are no plane 
layers, the Shield area is grayed out.

Gap Specifies the value of the shield gap.

Use Net Specifies the net to use as the shield.

Match Lengths Specifies that you want to use Length Matching.

Tolerance Specifies the maximum difference allowed between the shortest length 
and longest length in the matched length group.

Delete  button Removes this set of High Speed rules from your rules hierarchy.

 Tip
You cannot delete the Default High Speed rules.
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Related Topics
Setting Up High-Speed Rules
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Installed Options Dialog Box
To access: Help  > Installed Options  menu item > License File  tab

Use the License File  tab to select and then view license file information, either the actual license file (for 
node-locked licensing) or the feature usage status associated with a server license (for floating licensing).

Figure 79. Installed Options Dialog Box, License File Tab

Objects
Table  114. Installed Options Dialog Box, License File Tab contents

Name Description

License File Displays the location of the license file.

Source Displays the source of the license.

View  button Specifies to display the selected license file in the view area.
Exception: For Node-locked licenses only.

Status  button Specifies to display the selected feature usage information.
Exception: For Floating licenses only.

View area Displays the selected license file information after you click View 
(Node-locked license) or Status  (Floating license).

Suite Configuration button Opens the SailWind Suite Configuration Dialog Box.

 Restriction:
Available only with floating/server-based licenses, a mix of different 
SailWind Suites, or a mix of unbundled licenses and suites.
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Related Topics
Viewing a License File or License Status
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Library List Dialog Box
To access: File  > Library  menu item > Manage Lib. List button

When you add a part to the design, you retrieve information about that part from a library. The Library List 
dialog box contains a list of libraries to search. The libraries are searched in the order in which they are 
listed, beginning with the first library in the list.

Figure 80. Library List Dialog Box

Objects
Table  115. Library List Dialog Box Contents

Name Description

Library list The libraries currently listed in the Library Manager Library list.

Read Only A status indicator only; this box is always unavailable.

Shared Shares the library over the network. This enables more than one 
user to access the library file at the same time.

Allow Search Includes the library when performing operations that involves 
libraries, such as adding parts.

Add  button Adds a library to the Library list.

Remove  button Removes a library from the Library list.

Up/Down  buttons Moves the order of the libraries in the Library list.

Synchronize with SailWind Layout Specifies to push the library settings to SailWind Layout from 
SailWind Logic.
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Related Topics
Setting the Library List Order
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Library Manager Dialog Box
To access: File  > Library  menu item

Use the Library Manager to perform operations associated with editing and copying the contents of 
libraries.

Figure 81. Library Manager Dialog Box

Objects
Table  116. Library Manager Dialog Box Contents

Name Description

Library list The list of libraries available to you.

Create New Lib  button Opens the New Library window where you can specify a new 
library name and location.

Manage Lib. List  button Opens the Library List Dialog Box.

Attr Manager  button Opens the Manage Library Attributes Dialog Box.
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Table  116. Library Manager Dialog Box Contents  (continued)

Name Description

Preview area Shows the item selected in the Filter list.

Filter area Narrows down the Filter list by Decals, Parts, Lines, or Logic. You 
can further narrow the list using wildcards  on page 105 in the Filter 
box.

 Tip
Add an asterisk “*” to the box to display all items.

Filter list The results from your filter area selections.

New  button The action taken is dependent on the filter.
• Decals  — Opens the PCB Decal Editor on a new decal.

• Parts  — Opens the Part Information Dialog Box, Gates Tab  on 
an unnamed part.

• Lines  — Unavailable. There is no special library lines editor. 
Use drafting tools to create or edit lines and save them to the 
library.

• Logic  — Unavailable. Use SailWind Logic to create or edit CAE 
decals.

 Restriction:
This button is unavailable when the Library is set to (All 
Libraries).

See also Adding Items to a Library.

Edit  button The action taken is dependent on the filter.
• Decals  — Opens the PCB Decal Editor on the selected decal.

• Parts  — Opens the Part Information Dialog Box, Gates Tab  on 
the selected part.

• Lines  — Unavailable. There is no special library lines editor. 
Use drafting tools to create or edit lines and save them to the 
library.

• Logic  — Unavailable. Use SailWind Logic to create or edit CAE 
decals.

 Restriction:
This button is unavailable when the Library is set to (All 
Libraries).

See also Editing Items in a Library.

Delete  button Removes the selected item from the library.

 Restriction:
This button is unavailable when the Library is set to (All 
Libraries).

See also Deleting Items From a Library.

Copy  button Copies the selected item to another name or another library.
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Table  116. Library Manager Dialog Box Contents  (continued)

Name Description

 Restriction:
This button is unavailable when the Library is set to (All 
Libraries).

See also Copying a Library Item.

Import  button Import library data from an ASCII file. The file type is dependent on 
the filter.

 Restriction:
This button is unavailable when the Library is set to (All 
Libraries).

See also Importing Library Data.

Export  button Export library data to an ASCII file. The file type is dependent on 
the filter.

 Restriction:
This button is unavailable when the Library is set to (All 
Libraries).

See also Exporting Library Data.

List to File  button The action taken is dependent on the filter.
• Decals  — Generates a list of PCB Decals in a single library.

• Parts  — Generates a list of Parts in a single library or all 
libraries along with chosen attributes.

• Lines  — Generates a list of line items in a single library.

• Logic  — Generates a list of CAE decals or Logic symbols in a 
single library.

 Restriction:
When the Library is set to (All Libraries), this button is 
unavailable for all but Parts.

SailWind Logic Guide 559



SailWind Logic GUI Reference
Log Test Dialog Box  

Log Test Dialog Box
To access: type BLT > press Enter. If nothing happens, close SailWind Logic and restart it.

Use BLT to replay session playback media created by BMW.

Figure 82. Log Test Dialog Box

Objects
Table  117. Log Test Dialog Box contents

Name Description

Media Directories Lists the session playback media files.

New name Specifies to rename the selected media directory.

Rename  button Renames the selected media directory to the name in the New name 
box.

Related Topics
Replaying Session Playback Media With BLT
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Logic Families Dialog Box
To access: Tools  > Part Editor  menu item > Edit Electrical button > General  tab > Families  button

Use the Logic Families dialog box to add, delete, or modify logic family names and default reference 
designator prefixes.

Figure 83. Logic Families Dialog Box

Objects
Table  118. Logic Families Dialog Box Contents

Name Description

Family column Lists the logic family.

Prefix column Lists the prefix for the logic family

Add  button Adds a row to the table.

Edit  button Makes the selected field editable.

Delete  button removes the selected row.

Related Topics
Editing Logic Families
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Make Field Dialog Box
To access: Select a text string > right-click > Make Field  menu item

Use the Make Field dialog box to change an existing text string into a field.

Figure 84. Make Field Dialog Box

Objects
Table  119. Make Field Dialog Box Contents

Name Description

Name list Lists all of the fields available to you.

Value The value of the field.

 Restriction:
The Value box is unavailable for system fields since the value 
is derived from your system.

X/Y Type coordinates to place the field in a specified location.
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Table  119. Make Field Dialog Box Contents  (continued)

Name Description

 Tip
Leave these blank to attach the field to your pointer and click to 
indicate the location.

Rotation Specifies the rotation of the text: 0 or 90 degrees.

Line Width Specifies the line width for stroke fonts only.

Size Specifies the size of the font.
Size (pts):  This is font size in points and appears for system fonts
Size (mils):  This is font character height and appears for stroke 
fonts. The size refers to the height of the tallest characters.

Font Style Enables you to change the font style to bold, italic, and underlined.

 Restriction:
System fonts only.

Font list The fonts available to you. This lists either stroke fonts or system 
fonts. You choose which type of font to use in the Fonts Dialog 
Box.

 Tip
• Select stroke font or a system font.
• For system fonts, you can also click a font style button, or 

any combination of styles: B  for bold, I  for italic, or U  for 
underlined.

Horizontal/Vertical Justification Specifies the horizontal (Right, Center, Left) justification and the 
vertical (Up, Center, Down) justification of the text.

Related Topics
Changing a Text String Into a Field
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Manage Library Attributes Dialog Box
To access: File  > Library  menu item > Attr Manager  button

Use the Manage Library Attributes dialog box to list the attribute names in your libraries and to add an 
attribute to, rename an attribute in, or delete an attribute from, the library.

Figure 85. Manage Library Attributes Dialog Box

Objects
Table  120. Manage Library Attributes Dialog Box Contents

Name Description

Select Library list The list of libraries available to you.

Item Types list Filters the type of items in the Attributes in Library list.

Browse Lib. Attr  button Opens the Browse Library Attributes Dialog Box.

 Tip
This is available only when an attribute in the New Name 
column in the Attributes Selected for Rename list is selected.

Edit New Name  button Makes the selected attribute Name editable.

 Tip
This is available only when an attribute in the New Name 
column in the Attributes Selected for Rename list is selected.

Attributes in Library list The list of attributes in the selected library.

Add >>  button Adds the selected attribute to the Rename list.
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Table  120. Manage Library Attributes Dialog Box Contents  (continued)

Name Description

<< Remove  button Removes the selected attribute from the Rename list.

<< Remove All  button Removes all of the attributes from the Rename list.

Attributes Selected for Rename 
list

The list of attributes you’ve selected to rename.

Add Attr  button Opens the Add New Attribute to Library Dialog Box.

Delete Attrs  button Deletes the selected attribute from the selected library.

Rename Attrs  button Renames all of the attributes you gave a new name to in the 
selected library.

Related Topics
Managing Library Attributes
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Manage Schematic Attributes Dialog Box
To access: Edit  > Attribute Manager  menu item

Use the Manage Schematic Attributes dialog box to manage attributes at the schematic level. You can 
create a new attribute and automatically assign it to every part in your design. You can also rename an 
attribute in, or delete an attribute from, the schematic. All parts are automatically updated.

Figure 86. Manage Schematic Attributes Dialog Box

Objects
Table  121. Manage Schematic Attributes Dialog Box Contents

Name Description

Attributes in Schematic list The list of attributes in the schematic.

Add >>  button Adds the selected attribute to the Rename list.

<< Remove  button Removes the selected attribute from the Rename list.

<< Remove All  button Removes all of the attributes from the Rename list.

Attributes Selected for Rename 
list

The list of attributes you’ve selected to rename.

Browse Lib. Attr  button Opens the Browse Library Attributes Dialog Box.

Edit New Name  button Makes the selected attribute Name editable.

 Tip
This is available only when an attribute in the New Name 
column in the Attributes Selected for Rename list is selected.
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Table  121. Manage Schematic Attributes Dialog Box Contents  (continued)

Name Description

Add Attr  button Opens the Add New Attribute to Library Dialog Box.

Delete Attrs  button Deletes the selected attribute from the selected library.

Rename Attrs  button Renames all of the attributes you gave a new name to in the 
selected library.

Related Topics
Manage Attributes in a Schematic
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Media Wizard Dialog Box
To access: type BMW > press Enter

BMW (Basic Media Wizard) is a tool that you can use to record and play back SailWind Logic, SailWind 
Layout and SailWind Router sessions. It is particularly useful as a means of supplying information to 
SailWind Technical Support engineers trying to identify and resolve any problematical behavior you may 
encounter.

Figure 87. Media Wizard Dialog Box

Objects
Table  122. Media Wizard Dialog Box contents

Name Description

Media Wizard area Specifies what you want the Media Wizard to do:
• Create Media from Current Session  — Use this procedure when 

the session you are recreating did not cause a SailWind tool crash.

• Create Media from Previous Session  — Use this procedure when 
the session you are recreating caused the SailWind tool to crash, 
and the automatic procedure described in Automatically Creating 
Session Playback Media for a Crashed Session  cannot be used due 
to one of the restrictions listed in that section.

• Stop Logging  — Specifies to stop the Media Wizard from logging 
any further actions.

User Initials Specifies your initials. They are included in the playback media 
filenames to identify the files as yours.

Delete Actions Before Last 
Save

Specifies to delete all entries in the session log file between the first 
Open and the last Save command. You can do this to eliminate any 
actions you may have performed before beginning the series of actions 
that produced the problematical behavior. This makes it easier for the 
Tech Support engineer to identify the problem.

Related Topics
BMW and BLT
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Modeless Commands and Keyboard Shortcuts
You can set or change some settings and functions at any time using a code letter for the command, 
entering the new value, and clicking Enter. This is called a Modeless Command.

Modeless Commands usually apply to values that you change frequently during design. Use the 
Modeless Command G, for example, to change the grid setting. Type G, the new setting, and click Enter. 
Below is a summary of the Modeless Commands in SailWind Logic:

To show this help topic at any time while SailWind Logic is running, type ? and click Enter.

Tip
(X,Y) = coordinates; (s) = text; (n) = number.

Table  123. Modeless Command and Shortcut Key Table Conventions

Convention Description

< > A variable, or something you can type.

{ } An optional command argument.

click Click the left mouse button.

middle-click Click the middle mouse button or wheel.

right-click Click the right mouse button.

wheel forward Rotate the wheel forward, where the top of the wheel rotates 
away from your palm.

wheel back Rotate the wheel backward, where the top of the wheel rotates 
toward your palm.

Tip
Spaces have significance in modeless commands and shortcut keys. For example, SS W1 and S 
SW1 have different meanings. SS W1 means to search for and select W1, while S SW1 means to 
search for SW1.

Modeless Commands
The following is a complete list of all of the modeless commands:

Table  124. Modeless Commands for Grid Settings

Name Command Description

Global Grid Setting G<n> Sets the Design grid, for example G50.
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Table  124. Modeless Commands for Grid Settings  (continued)

Name Command Description

Dot Grid Setting GD<n> Sets the Displayed (Dot) grid, for example, 
GD100.

 

Table  125. Modeless Commands for 2D Line Angles

Name Command Description

Any Angle AA Any angle mode. Sets the line angle for drafting 
objects to Any angle (no angle restrictions).

Diagonal Angle AD Diagonal angle mode. Sets the line angle for 
drafting objects to Diagonal (45 degree angles 
only).

Orthogonal Angle AO Orthogonal angle mode. Sets the line angle 
for drafting objects to Orthogonal (90 degree 
angles only).

Table  126. Modeless Commands for Line Width Settings

Name Command Description

Set Minimum (Real) Display 
Width for Paths

R<width> Sets the minimum (Real) display width for 
paths.

Change Current Line Width W<width> Changes the current line width to the number 
<n> you enter, for example W 5.

Table  127. Modeless Commands for Searching

Name Command Description

Search Absolute S<x> <y> Search absolute. Moves the pointer to the 
specified X and Y coordinates, for example S 
1000 1000.

Search for Named Item 
(Pin/Part/Net)

S<string> Search for named item (pin, part or net), for 
example SU1.

Search Relative SR<x><y> Search relative. Moves the pointer by the 
specified X and Y offset, for example SR -100 
-50.

Search Relative X SRX<x> Search relative X at current Y. Moves the 
pointer by the specified X offset, for example 
SRX 300.

Search Relative Y SRY<y> Search relative Y at current X. Moves the 
pointer by the specified Y offset, for example 
SRY 400.

570 SailWind Logic Guide



 
SailWind Logic GUI Reference

Modeless Commands and Keyboard Shortcuts

Table  127. Modeless Commands for Searching  (continued)

Name Command Description

Absolute Move to <n>, Current 
Y

SX<x> Search absolute X at current Y. Moves the 
pointer to the specified X coordinate and the 
current Y coordinate, for example SX 300.

Absolute Move to <n>, Current 
X

SY<y> Search absolute Y at current X. Moves the 
pointer to the specified Y coordinate and the 
current X coordinate, for example SY 400

 

Table  128. Modeless Commands for Drafting Shape Control

Name Command Description

Circle shape draw mode. HC Sets drawing mode to circle shape.

Path shape draw mode. HH Sets drawing mode to path shape.

Polygon shape draw mode. HP Sets drawing mode to polygon shape.

Rectangle shape draw mode. HR Sets drawing mode to rectangle shape.

Table  129. Modeless Commands for Measurement

Name Command Description

Quick Measure Q Quick Measure with a dynamic ruler. Attaches 
a measurement line to the pointer and displays 
dx, dy, and hypotenuse information, depending 
on pointer movement.
Place the pointer at the starting point, then type 
the “q” modeless command. Drag the pointer 
to create a line between the start and end point 
of your measurement. Snaps to the design grid 
when the Snap to grid is on. Measurements 
are gridless when Grid Snap is off. Dynamically 
reports delta x, delta y and delta x,y in current 
design units.

Table  130. Modeless Commands for Hierarchical Design

Name Command Description

Hierarchical Push HI Invokes Hierarchical Push.

Hierarchical Pop HO Invokes Hierarchical Pop.
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Table  131. Modeless Commands for Undo/Redo

Name Command Description

Undo UN Undo

Redo RE Redo

Table  132. Miscellaneous Modeless Commands

Name Command Description

Open File <name> F<name> Open file <name>, where <name> is the path 
and name of the file to open (for example, F 
demo.eco).

Select Sheet Name or Number SH<sheet> Selects the sheet name or number you type, for 
example SH3.

Database Integrity Test I Runs the Database Integrity Test.

Help ? Show Help topic.

Table  133. Modeless Commands for Basic Media Wizard/Log Test

Command Description

Basic Log Test BLT Basic Log Test. Opens the Log Test Dialog 
Box. BLT finds and runs BMW session playback 
media.
See also Crash Detection, BMW and BLT.

Open Basic Media Wizard BMW Opens the Basic Media Wizard dialog box.
• BMW records session playback media 

for a problematic SailWind Logic session. 
It can create playback media based on 
your last SailWind Logic session or your 
current session. This playback media can be 
replayed using the BLT modeless command.

• BMW is also a command line option.

See also Crash Detection, BMW and BLT.

Start BMW Session Logging BMW ON Starts BMW session logging.

Stop BMW Session Logging BMW OFF Stops BMW session logging.

Function Keys

The following is a complete list of all of the function key command assignments:
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Table  134. Function Key Command Assignments

Function Key Description

F1 Open Help (context sensitive)

F2 Add Connection

F3 Unassigned

F4 Unassigned

F5 Unassigned

F6 Unassigned

F7 Unassigned

F8 Unassigned

F9 Unassigned

F10 Unassigned

F11 Unassigned

F12 Unassigned

Keypad Keys

The following is a complete list of all of the keypad key command assignments:

Table  135. Keypad Key Command Assignments

Keypad Keys Description

(Number Keys) with NumLock On

Keypad (0) Center the view using the pointer location

Keypad (1) Redraw

Keypad (2) Pans the workspace down one increment

Keypad (3) Zooms out at the pointer

Keypad (4) Pans the workspace left one increment

Keypad (5) Starts Zoom from center

Keypad (6) Pans the workspace right one increment

Keypad (7) Zoom to the Sheet

Keypad (8) Pans the workspace up one increment
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Table  135. Keypad Key Command Assignments  (continued)

Keypad Keys Description

Keypad (9) Zoom in at the pointer location

Keypad (.) Starts Zoom from corner (Zoom Mode only)

(Command Keys) with NumLock Off

Insert Centers the view using the pointer location

End Redraw

Down Arrow Moves the pointer down one design grid

Page Down Zooms out at the pointer

Left Arrow Moves the pointer left one design grid

Right Arrow Moves the pointer right one design grid

Home Zooms to the Sheet

Up Arrow Moves the pointer up one design grid

Page Up Zooms in at the pointer

Delete Delete the selected object

 

Shortcut Keys

For mouseless operation, use keyboard shortcuts to start commands for selected items and change some 
system settings. Following are the shortcut assignments for SailWind Logic: 

Table  136. Keyboard Shortcuts for Panning, Zooming and Navigation

Name Shortcut Keys Description

Zoom to Sheet <home> Zooms to sheet. Fits the sheet border into the 
workspace.

Zoom to Sheet Ctrl + B Zooms to sheet. Fits the sheet border into the 
workspace.

Zoom Extents Ctrl-Alt + E Zooms to extents. Fits all objects in the design 
into the workspace.

Zoom Area In/Out MMB (drag) Zooms area in or out. Drag pointer up to zoom 
in. Drag pointer down to zoom out.

Start Zoom from Corner Shift + MMB (Drag) Starts Zoom from Corner.
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Table  136. Keyboard Shortcuts for Panning, Zooming and Navigation  (continued)

Name Shortcut Keys Description

Zoom to Selection Alt + Z Zooms to selection. Fits the selected objects 
into the workspace.

Zoom Mode On/Off Ctrl + W Toggles Zoom Mode On/Off.

Center View (Using Pointer 
Location)

MMB Centers the view at the pointer.

Center View (Using Pointer 
Location)

<Insert> Centers the view at the pointer.

Zoom In at Pointer (Zoom 
Mode)

LMB Click Zooms in at the pointer (zoom mode).

Zoom Out at Pointer (Zoom 
Mode)

RMB Click Zooms out at the pointer (zoom mode).

Zoom In at Pointer (Zoom 
Mode)

<spacebar> Zooms in at the pointer (zoom mode).

Zoom In at Pointer <PgUp> Zooms in at the pointer.

Zoom Out at Pointer <PgDn> Zooms out at the pointer.

Zoom In at Pointer Ctrl + Wheel Fwd Zooms in at the pointer.

Zoom Out at Pointer Ctrl + Wheel Back Zooms out at the pointer.

Move Pointer Down (One 
Design Grid)

<Down Arrow> Pointer moves down one design grid.

Move Pointer Up (One Design 
Grid)

<Up Arrow> Pointer moves up one design grid.

Move Pointer Left (One Design 
Grid)

<Left Arrow> Pointer moves left one design grid.

Move Pointer Right (One 
Design Grid)

<Right Arrow> Pointer moves right one design grid.

Dynamic Panning Alt + MMB (Drag) Pans the sheet area below the pointer to the 
center of the workspace.

Pan Workspace Down (One 
Line)

Wheel Back Pans workspace down one line.

Pan Workspace Up (One Line) Wheel Fwd Pans workspace up one line.

Pan Workspace Right (One 
Line)

Shift + Wheel Back Pans workspace right one line.

Pan Workspace Left (One Line) Shift + Wheel Fwd Pans workspace left one line.
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Table  136. Keyboard Shortcuts for Panning, Zooming and Navigation  (continued)

Name Shortcut Keys Description

Pan Workspace Down (One 
Pixel)

Ctrl-Alt + Wheel 
Back

Pans workspace down one pixel.

Pan Workspace Up (One Pixel) Ctrl-Alt + Wheel 
Fwd

Pans workspace up one pixel.

Pan Workspace Right (One 
Pixel)

Alt-Shift + Wheel 
Back

Pans workspace right one pixel.

Pan Workspace Left (One 
Pixel)

Alt-Shift + Wheel 
Fwd

Pans workspace left one pixel.

 

Table  137. Keyboard Shortcuts for Selection

Name Shortcut Keys Description

Filter Ctrl-Alt + F Opens the Selection Filter.

Select LMB Click Selects an object.

Select <Spacebar> Selects an object.

Select All Ctrl + A Selects all objects on the current sheet based 
upon the selection filter choices.

Select All on Schematic Ctrl-Shift + A Selects all objects on the schematic based 
upon the selection filter choices.

Area Select LMB (Start Drag) Starts an area selection.

Area Complete LMB (End Drag) Completes an area selection.

Cancel Area Selection LMB (Cancel Drag) Cancels area selection.

Toggles/Multiple Selection Ctrl + LMB Click Toggles object selection or selects multiple 
objects.

Duplicate Ctrl + LMB (Drag) Duplicates selected object and attaches to 
pointer.

Table  138. Keyboard Shortcuts for File Operations

Name Shortcut Keys Description

Create New Design File (Blank) Ctrl + N Creates a new blank design file.

Open File (Design) Ctrl + O Opens a design file.

Print/plot Ctrl + P Print/plot
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Table  138. Keyboard Shortcuts for File Operations  (continued)

Name Shortcut Keys Description

Save (Quick Save) Ctrl + S Saves the design file

 

Table  139. Keyboard Shortcuts for Opening Menus and Dialog Boxes

Name Shortcut Keys Description

Open File Menu Alt + F Opens the File menu.

Open Edit Menu Alt + E Opens the Edit menu.

Open View Menu Alt + V Opens the View menu.

Open Setup Menu Alt + S Opens the Setup menu.

Open Tools Menu Alt + T Opens the Tools menu.

Open Help Menu Alt + H Opens the Help menu.

Open Shortcut Menu RMB Opens the Shortcut menu.

Toggle Menu Bar Ctrl-Alt + M Toggles the visibility of the Menu Bar.

Properties (Current Object) LMB DblClick Displays Properties for the currently selected 
object.

Properties (for Selected) Alt+<Enter> Displays Properties for the currently selected 
object.

Properties (for Selected) Ctrl + Q Displays Properties for the currently selected 
object.

Options Ctrl + <Enter> Opens the Options dialog box.

Options Ctrl-Alt + G Opens the Options dialog box.

Display Colors Ctrl-Alt + C Opens the Display Colors dialog box.

Status Window Ctrl-Alt + S Opens the Status Window.

Table  140. Keyboard Shortcuts for Placement Operations

Name Shortcut Keys Description

Move Selected Object(s) Ctrl + E Moves the selected object(s).

Rotate Selected (90) Ctrl + R Rotates the selected object (90 degrees).

Flip Selected on X Axis Ctrl + F X Mirror (flips selected object on X axis).
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Table  140. Keyboard Shortcuts for Placement Operations  (continued)

Name Shortcut Keys Description

Flip Selected on Y Axis Ctrl-Shift + F Y Mirror (flips selected object on Y axis)

Draw Group While in Move 
Group Mode

Ctrl-Shift + D Draw Group while in Move Group Mode.

Vertically Justify Text During 
Move

Ctrl-Shift + J Vertically justify text during move.

Horizontally Justify Text During 
Move

Ctrl + J Horizontally justify text during move.

Connect to Layout for 
Cross-Probing

Ctrl-Shift + O Connect to Layout for cross-probing.

Table  141. Keyboard Shortcuts for Connection Operations

Name Shortcut Keys Description

Add Corner LMB Click Adds a new connection corner.

Add Corner <Spacebar> Adds a new connection corner.

Backup <Backspace> Removes the last connection corner on a 
connection line or the last corner on a 2D line 
(in polygon or path drawing mode).

Complete Bus <Enter> Completes the bus.

Complete Bus LMB DblClick Completes the bus.

Rename Ctrl + L Rename.

Reset DxDy Crtl + <PgDn> Reset delta coordinates to measure from 
current position.

Add Ground Symbol Ctrl + <spacebar> Adds a Ground Symbol while in Add 
Connection mode.

Add Power Symbol Shift + <spacebar> Adds a Power Symbol while in Add Connection 
mode.

Add Off-page Symbol Alt + <spacebar> Add an Off-page Symbol while in Add 
Connection mode.

Cycle Alternate Gate Decals Ctrl + <Tab> Cycles through alternate gate decals.

 

578 SailWind Logic Guide



 
SailWind Logic GUI Reference

Modeless Commands and Keyboard Shortcuts

Table  142. Keyboard Shortcuts for Editing

Name Shortcut Keys Description

Cut Ctrl + X Cut

Copy Ctrl + C Copy

Paste Ctrl + V Paste

Redraw <End> Redraw

Redraw Ctrl + D Redraw

Delete <Delete> Delete

Cancel <Escape> Cancel

Redo Ctrl + Y Redo

Undo Ctrl + Z Undo

Table  143. Keyboard Shortcuts for Viewing

Name Shortcut Keys Description

Next View Alt + N Displays the next view.

Previous View Alt + P Displays the previous view.

Table  144. Mouse Button Substitutions

Name Shortcut Keys Description

Activate Right Click Popup 
Menu (Right Mouse Button)

M Activates the shortcut menu for the current 
mode. Same as right-click.

Left Mouse Click <Spacebar> Activates a left mouse button click (to add 
corners, select items, complete, etc.) at the 
current pointer location.
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Net Attributes Dialog Box
To access: Select a net > right-click > Attributes  menu item

Use the Net Attributes dialog box to associate information with a single net or set of nets on the 
schematic. Attributes are made of two parts, an attribute name and its corresponding value. If connecting 
to SailWind Layout, these attributes are passed along with the rest of the schematic.

Figure 88. Net Attributes Dialog Box

Objects
Table  145. Net Attributes Dialog Box

Name Description

Attributes table Lists the name and value of the net selected in the schematic.

Add  button Adds a new row below the selected row.

Delete  button Removes the selected row from the Attributes table.

Edit  button Makes the selected cell available for editing.

Related Topics
Creating Net Attributes
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Net Name Properties Dialog Box
To access: Select a net name label > right-click > Properties  menu item

Use the Net Name Properties dialog box to provide or change text and font settings for one or more net 
name labels.

Figure 89. Net Name Properties Dialog Box

Objects
Table  146. Net Name Properties Dialog Box Contents

Name Description

Net Name The name of the selected net.

Rename Specifies to rename the selected net name or all instances of the 
net name.

Rotation Specifies the rotation of the label: 0 or 90 degrees.

Size Specifies the size of the font.
Size (pts):  This is font size in points and appears for system fonts
Size (mils):  This is font character height and appears for stroke 
fonts. The size refers to the height of the tallest characters.
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Table  146. Net Name Properties Dialog Box Contents  (continued)

Name Description

Line Width Specifies the line width for stroke fonts only.

Font list The fonts available to you. This lists either stroke fonts or system 
fonts.
You choose which type of font to use in the Fonts Dialog Box.

 Tip
• Select stroke font or a system font.
• For system fonts, you can also click a font style button, or 

any combination of styles:B  for bold, I  for italic, or U  for 
underlined.

Horizontal/Vertical Justification Specifies the horizontal (Right, Center, Left) justification and the 
vertical (Up, Center, Down) justification of the text.

Related Topics
Modifying Part Type Labels
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Net Properties Dialog Box
To access: Select a net > right-click > Properties  menu item

Use the Net Properties dialog box to access net specific properties.

Figure 90. Net Properties Dialog Box

Objects
Table  147. Net Properties Dialog Box Contents

Name Description

Net Name The name of the selected net. Type or select one from the list to 
create a new one.

Rename area Specifies to rename the selected net or all instances of the net.

 Tip
Selecting This Instance will cause the net to be split into two 
separate nets.

Net Name Label Specifies to add a visible label to the selected net segment.

 Restriction:
You must select the connection segment where it enters 
or exits a part, or the Net Name Label check box will be 
unavailable.
 Tip
Clearing the Net Name Label check box removes the visible 
label. The net and all subnets retain the net name.

Statistics  button Displays connection information in your default text editor.
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Table  147. Net Properties Dialog Box Contents  (continued)

Name Description

Attributes  button Opens the Net Attributes Dialog Box.

Rules  button Opens the Net Rules Dialog Box.

Related Topics
Modifying Nets
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Net Rules Dialog Box
To access:

• Setup  > Design Rules  menu item > Net  button

• Select a net > right-click > Show Rules  menu item

• Select a net > right-click > Properties  > Rules  button

Use the Net Rules dialog box to define design rules that apply to nets.

Figure 91. Net Rules Dialog Box

Objects
Table  148. Net Rules Dialog Box

Name Description

Nets list Lists all nets in the design.

Show Nets with rules Specifies to show only nets that have rules.

Clearance  button Opens the Clearance Rules Dialog Box.

Routing  button Opens the Routing Rules Dialog Box.

HiSpeed  button Opens the HiSpeed Rules Dialog Box.

Report  button Opens the Rules Report Dialog Box.

Picture below rule button The picture below each type of rule button identifies which rules 
hierarchy level is used for that rule type. The meaning of the picture 
corresponds to the button in the Hierarchy area of the Rules dialog box. 
For example, if you select a class in the Class list and a green polygon 
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Table  148. Net Rules Dialog Box  (continued)

Name Description
appears below the Clearance  button, then the default values apply to 
the class.

Selected Lists the net(s) selected in the Nets list.

Default  button Removes non-default rules from the selected nets, so that only default 
rules apply.
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Netlist to PCB Dialog Box
To access: Tools  > Layout Netlist  menu item

Use the Netlist to PCB dialog box to create a netlist for import to SailWind Layout.

Tip
If you use both SailWind Logic and SailWind Layout on the same computer, there is a more 
automated method to pass the netlist. For more information, see the Send Net list  button on the 
SailWind Layout Link Dialog Box, Design Tab.

Restriction:
Transferring non-ECO-registered parts and non-electrical parts is constrained by settings in the 
Options. See Options Dialog Box, Design Category  on page 591 for details.

Figure 92. Netlist to PCB Dialog Box
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Objects
Table  149. Netlist to PCB Dialog Box Contents

Name Description

Output File Name Accept the default name, type, or browse to the location and name of the 
netlist (.asc) file you are creating.

Select Sheets area Specifies the schematic sheets to include in the netlist. You can use the 
Select All  and Unselect All buttons as shortcuts.

Include Subsheets Specifies to include any connections to hierarchical symbols in the netlist.

Output Formats Specifies to output netlists compatible with the latest or older database 
formats.

Include Design Rules Specifies to include design rules and trace width settings in the netlist.

Include Part Attributes Specifies to include part attributes in the netlist.

Include Net Attributes Specifies to include net attributes in the netlist

TIP: Run Connectivity 
Report to check for possible 
connectivity errors

To run the Connectivity Report, in SailWind Logic, click the File  > 
Reports  menu item. In the Reports Dialog Box, select the Connectivity 
check box and click OK.
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Off-Page Properties Dialog Box
To access: Select an off-sheet label > right-click> Properties  menu item

Use the Off-Page Properties dialog box to set the properties of off-sheet labels.

Figure 93. Off-Page Properties Dialog Box

Objects
Table  150. Off-Page Properties Dialog Box

Name Description

Maximum sheet numbers per 
line

Enter the maximum number of sheet numbers allowed per line.

Rotation Select 0 or 90 degrees.
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Options Dialog Box
Using the Options dialog box, you can preset options for commands in SailWind Logic, setting up how 
those SailWind Logic commands will work and overriding the default settings in the default.txt file. Setting 
options enables you to set up a working environment that suits your design and the way you work.

To access: Tools  > Options  menu item

Options Dialog Box, Design Category
Options Dialog Box, General Category
Options Dialog Box, Line Widths Category
Options Dialog Box, Text Category

590 SailWind Logic Guide



 
SailWind Logic GUI Reference

Options Dialog Box, Design Category

Options Dialog Box, Design Category
To access: Tools  > Options  menu item > Design  category

There are six categories of general options for the Schematic Editor; they are organized into six areas in 
the Design category labeled Parameters, Options, Sheet, Off-sheet Labels, Non-ECO-Registered Parts, 
and Non-Electrical Parts.

Figure 94. Options Dialog Box, Design

Objects
Table  151. Options Dialog Box, Design Category

Name Description

Parameters area

Tie Dot Diameter Specifies the diameter of tie dots. The value must be from 0 to 100.

Bus Angle Offset Defines the starting point distance from the bus for the bus tap. The 
value must be from 0 to 250.
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Table  151. Options Dialog Box, Design Category  (continued)

Name Description

 Tip
The bus tap joins connections to the bus.

Options area

Preserve Ref Des on Paste Specifies to use a group's current reference designator assignment 
when possible.

 Tip
Click to clear this check box to assign the pasted group's reference 
designators the first or next available number.

See also Preserving Reference Designators.

Allow Floating Connections Specifies to create connections without terminations.

 Tip
Click to clear this check box to prevent creating additional Floating 
Connections. Disabling the option does not remove existing 
Floating Connections.

See also Working With Floating Connections.

Allow Named Subnets without 
Labels

Specifies to allow deletion of net name labels in all cases except that of 
a power symbol connected to a net that overrides its default net name. 
When this box is checked, the current net name is not changed under 
any circumstances.
When this box is cleared, you cannot delete labels tied to bus rippers 
or off-page symbols. You can delete net labels tied to component pins; 
this causes the net to be renamed to a system-generated name, but 
only if both the following conditions apply:

• The net is not connected to a bus or off-page symbol.

• The deleted label was the only label on the net.

 Tip
It is possible to have a named subnet without a label even if the 
“Allow Named Subnets without Labels” check box is unchecked. 
If you change the name of a subnet with a system net name in the 
Net Properties dialog box, and click OK  without checking the Net 
Labels check box, the result will be a named subnet without a label.

Allow overwriting of attribute 
values in design with blank 
values from library

Specifies how design attribute values should be handled by operations 
that change design part types, such as Update From Library, Update 
Selected Part Type from Library, Change Type (in the Part Type 
Properties dialog), ECO Import, and automated operations.

• Select the check box to allow the value of an attribute in the design 
to be overwritten by a blank value from the library or other update 
source.

• Clear it to prevent overwriting these values.

Sheet area

Size list Specifies the size sheet you want.
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Table  151. Options Dialog Box, Design Category  (continued)

Name Description

Sheet border Specifies the current sheet boarder.

Choose  button Opens the Get Drafting Item from Library dialog box to change the 
sheet boarder.

 Tip
Be sure to select a sheet border that fits within the boundaries of 
the selected sheet size.

See also Adding Drafting Items From a Library.

Off-Sheet Labels area

Show Off-page Sheet 
Numbers

Displays sheet reference numbers that are adjacent to off-page 
reference symbols and bus names.

Separators Specifies the open and close characters you want to enclose sheet 
numbers. For example, "" {} or [] .

Numbers per Line Specifies how many sheet numbers to display per line. The value must 
be from 0 to 99. Depending on the value you specify, you can stack or 
line up the sheet number references.

 Tip
• This only applies when Show Off-page Sheet Numbers is 

selected.
• The sheet numbers appear on a line below the net name.

Non-ECO-Registered Parts area

Include in Netlist Specifies to include the part in the netlist.

 Tip
To include a part that is both non-ECO-registered and non-electrical 
in a netlist, select the check boxes in both Part areas.

Include in ECO to PCB Specifies to include a part in the ECO file that is forwarded to the PCB.

 Tip
To include a part that is both non-ECO-registered and non-electrical 
in a Forward ECO to PCB, select the check boxes in both Part 
areas.

Include in BOM report Specifies to include a part in the Bill of Materials (BOM) report.

 Tip
To include a part that is both non-ECO-registered and non-electrical 
in a BOM report, select the check boxes in both Part areas.

Non-Electrical Parts area

Include in Netlist Specifies to include the part in the netlist.
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Table  151. Options Dialog Box, Design Category  (continued)

Name Description

 Tip
To include a part that is both non-ECO-registered and non-electrical 
in a netlist, select the check boxes in both Part areas.

Include in ECO to PCB Specifies to include a part in the ECO file that is forwarded to the PCB.

 Tip
To include a part that is both non-ECO-registered and non-electrical 
in a Forward ECO to PCB, select the check boxes in both Part 
areas.

Include in BOM report Specifies to include a part in the Bill of Materials (BOM) report.

 Tip
To include a part that is both non-ECO-registered and non-electrical 
in a BOM report, select the check boxes in both Part areas.

Related Topics
Setting Schematic Editor Options
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Options Dialog Box, General Category
To access: Tools  > Options  menu item > General  category

There are six categories of general options for the Schematic Editor; they are organized into six areas 
in the General category labeled Display, Cursor, Grids, OLE objects, Text Encoding, and Automatic 
Backups.

Objects
Table  152. Options Dialog Box, General Category

Name Description

Display area

Keep view on window resize Specifies to maintain the area view of the design when you resize the 
SailWind Logic window, by automatically zooming in or out.

Minimum display width Specifies the minimum width, in current design units, of lines you want 
to draw at actual width. Lines smaller than this width are drawn only as 
centerlines to save memory and redraw time.

SailWind Logic Guide 595



SailWind Logic GUI Reference
Options Dialog Box, General Category  

Table  152. Options Dialog Box, General Category  (continued)

Name Description

 Tip
• Set this value to zero to display all lines at actual width.
• Larger values reduce redraw times.

Cursor area

Style list Specifies the cursor shape:
• Normal  — Arrow

• Small cross  — Small plus sign +

• Large cross  — Large plus sign +

• Full screen  — Full screen crosshair

 Tip
If you want the cursor resemble an x, select the Diagonal check 
box.

Grids area

Design Specifies a grid size for the Design grid which determines object 
placement. The value must be from 2 to 2000 and a multiple of 2 (for 
example, 2, 4, 50, 100).

Labels and Text Specifies a grid size for the Labels and text grid which determines 
placement of all labels, fields, names, attributes, and text. The value 
must be from 2 to 2000 and a multiple of 2 (for example, 2, 4, 50, 100).

Display Grid Specifies a grid size for the Display grid which is a visible guide for 
drawing lines, decals, connections, and more. The value must be from 
10 to 9998 and a multiple of 2 (for example, 2, 4, 50, 100).

 Tip
• The Display grid is independent of the system grid displayed on 

the status line.
• If the grid is not visible when the work area is redrawn, you 

probably have set an interval that is too small for display at all 
zoom levels. You will have to zoom in several times before the 
display grid becomes visible.

Snap to Grid Specifies to snap an item or object to the grid during editing.
See also Work Area and Grid Settings.

OLE Objects area

Display OLE objects Specifies to display linked and embedded objects in the work area.

 Tip
The OLE display settings affect SailWind Logic only when it is 
embedded in another application.

Update on redraw Specifies to update the SailWind Layout linked or embedded object in 
the container application.
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Table  152. Options Dialog Box, General Category  (continued)

Name Description

 Restriction:
This option applies only when you are editing the SailWind Logic 
object in a separate window and you click the Redraw  button in the 
separate window.
 Tip

• To increase performance, disable this option.
• The OLE display settings affect SailWind Logic only when it is 

embedded in another application.

Draw background Specifies to draw the SailWind Logic background color in the linked or 
embedded SailWind Logic object.

 Tip
When this option is disabled, the background of the SailWind Logic 
object is transparent and you can see through the object at the 
container application's background.

Text Encoding area

Text Encoding list Specifies the language encoding to use in text strings and labels 
displayed in the design screen.

 Tip
Encoding choices include those supported in the current localized 
version of SailWind Logic, plus any default encoding already in use 
in the design.

Example:  A letter with a 0x20 code displays as a Latin capitol letter 
A with a grave accent in a design using Western encoding, and as a 
Cyrillic capital letter A in a design with Cyrillic encoding.

 Restriction:
The default text encoding cannot be changed. It is automatically set 
by the Regional and Language settings of the operating system.

Automatic backups area

Interval Specifies the time in minutes between automatic backups to a file.

Number of backups Specifies the quantity (1-9) of different backup files to create.

 Tip
Backup files are named <filename>#.sch, where # is a sequential 
number. For example, logic1.sch, logic2.sch, and so on.

Backup File  button Changes the folder or name of the backup file

Use design name in backup 
file name

Specifies to use the design name instead of the product name as the 
file name.
Example:  preview_logic1.sch, preview_logic2.sch instead of 
logic1.sch, logic2.sch.

Create backup files in design 
directory

Specifies to place all of your backup files in the same directory as the 
design.
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Table  152. Options Dialog Box, General Category  (continued)

Name Description

 Tip
Click to clear if you want your backup files in one, common backup 
directory.

Related Topics
Setting Schematic Editor Options

Creating a Backup File
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Options Dialog Box, Line Widths Category
To access: Tools  > Options  menu item > Line Widths  category

Use the Line Widths category to change the size of line widths in the workspace.

Objects
Table  153. Options Dialog Box, Line Widths Category

Name Description

Type Lists the types of lines available in the schematic.

Width Specifies the width of the line type.

Edit  button Makes the Width column of the selected row editable.

Related Topics
Setting Line Widths
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Options Dialog Box, Text Category
To access: Tools  menu item > Text  category

The Text category differs depending on the selection you made in the Fonts dialog box: Stroke or System 
font.

Figure 95. Options Dialog Box, Text Page - System Font
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Options Dialog Box, Text Category

Figure 96. Options Dialog Box, Text Page - Stroke Font

Objects
Table  154. Options Dialog Box, Text Category

Name Description

Type Displays the type of font used in the schematic.

Font Specifies the system font used.

 Restriction:
System font only.

B Specifies if this font is bold. Click to make the font bold; click to clear to 
make it regular weight.

 Restriction:
System font only.

I Specifies if this font is italicized. Click to make the font italic; click to 
clear to make it regular.

 Restriction:
System font only.
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Table  154. Options Dialog Box, Text Category  (continued)

Name Description

U Specifies if this font is underlined. Click to underline the font; click to 
clear to make it regular.

 Restriction:
System font only.

Size Specifies the size of the font.

 Restriction:
System font only.

Width Specifies the width of the font.

 Restriction:
Stroke font only.

Edit  button Makes the selected field editable.

 Restriction:
You cannot edit fields in the Type column.
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Options Dialog Box - Part Editor, General 
Category
To access: While in the Schematic Editor, click the Tools  > Part Editor  menu item. In the Part Editor, click 
the Edit  > CAE Decal Editor  menu item. In the CAE Decal Editor, click the Tools  > Options menu item, 
then click the General  category.

There are four categories of general options for the Part Editor; they are organized into four areas on the 
General category labeled Display, Cursor, Grids, and Text Encoding.

Objects
Table  155. Options Dialog Box - Part Editor, General Category

Name Description

Display area

Keep view on window resize Specifies to maintain the area view of the design when you resize the 
SailWind Logic window, by automatically zooming in or out.
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Table  155. Options Dialog Box - Part Editor, General Category  (continued)

Name Description

Minimum display width Specifies the minimum width, in current design units, of lines you want 
to draw at actual width. Lines smaller than this width are drawn only as 
centerlines to save memory and redraw time.

 Tip
• Set this value to zero to display all lines at actual width.
• Larger values reduce redraw times.

Cursor area

Style list Specifies the cursor shape:
• Normal  — Arrow

• Small cross  — Small plus sign +

• Large cross  — Large plus sign +

• Full screen  — Full screen crosshair

 Tip
If you want the cursor to resemble an x, select the Diagonal check 
box.

Grids area

Design Specifies a grid size for the Design grid which determines object 
placement. The value must be from 2 to 2000 and a multiple of 2 (for 
example, 2, 4, 50, 100).

Labels and Text Specifies a grid size for the Labels and text grid which determines 
placement of all labels, fields, names, attributes, and text. The value 
must be from 2 to 2000 and a multiple of 2 (for example, 2, 4, 50, 100).

Display Grid Specifies a grid size for the Display grid which is a visible guide for 
drawing lines, decals, connections, and more. The value must be from 
10 to 9998 and a multiple of 2 (for example, 2, 4, 50, 100).

 Tip
• The Display grid is independent of the system grid displayed on 

the status line.
• If the grid is not visible when the work area is redrawn, you 

probably have set an interval that is too small for display at all 
zoom levels. You will have to zoom in several times before the 
display grid becomes visible.

Snap to Grid Specifies to snap an item or object to the grid during editing.
See also Work Area and Grid Settings.

Text Encoding area

Text Encoding list Specifies the language encoding to use in text strings and labels 
displayed in the design screen.
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Table  155. Options Dialog Box - Part Editor, General Category  (continued)

Name Description

 Tip
Encoding choices include those supported in the current localized 
version of SailWind Logic, plus any default encoding already in use 
in the design.

Example:  A letter with a 0x20 code displays as a Latin capitol letter 
A with a grave accent in a design using Western encoding, and as a 
Cyrillic capital letter A in a design with Cyrillic encoding.

Related Topics
Setting Part Editor Options
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Options Dialog Box - Print/Plot
To access:

• File  > Plot  menu item > Options  button

• File  > Print  menu item > Options  button

Use the Options dialog box to set the output options for printing or plotting. Setting options enables you to 
set the position, orientation, and color of selected sheets and objects.

Figure 97. Options Dialog Box - Print/Plot

Objects
Table  156. Options Dialog Box - Print/Plot

Name Description

Available list Lists the available sheets to print.

Add >>  button Moves the selected sheet to the Sheets to Print list.

Add All >>  button Moves all sheets to the Sheets to Print list.
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Table  156. Options Dialog Box - Print/Plot  (continued)

Name Description

<< Remove  button Moves the selected sheet to the Available list.

<< Remove All  button Moves all sheets to the Available list.

Sheet to Print list Lists off the sheets you want to print.

Items area Specifies the items you want to include in your output.

Color Selection area Specifies the color you want for the different items in the Items area.
Click a color tile, then in the Items area, click the tile to the right of the 
item to change its color.

Orientation Specifies the orientation angle for the output.

Justification Specifies the justification position for the output.

X/Y Offset Specifies the offset values.

 Tip
• You can only set offsets if you clicked something other than 

Scale to Fit and Centered in the Justification list.
• The print or plot location is calculated after the plot is rotated 

and scaled.

Scaling Specifies the type the plot size to actual size ratio.
Example:  A 2 to 1 scaling results in a printout or plot that is twice the 
actual size.

Preview area Graphically shows the position, orientation, justification, and scaling of 
the output.

Plot Job Name Specifies to output the schematic name, time, and date.

Plot Window Specifies to print the displayed window.

Preview  button Opens the Selections Preview Dialog Box.

Output Window
Use the Output window for displaying reports and session logs, macro editing and debugging, and custom 
programming and debugging, as well as CIS configuration.

To access: Click the Output Window  button.

The Output window is located in the lower left section of the display window. You can dock or float the 
Output window. You can also open or close the Output window.

The Output window has three tabs described below.
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Status Tab
The Status  tab displays information about the current session. It specifies the filename of the opened 
PCB file and the name of the test integrity file that is saved. It also reports routing statistics and messages 
when routing a board.

If the Status  tab is closed, and you get an error while autorouting - or performing other tasks - the Output 
window opens with the Status  tab active and the error appearing in red. The Output window reappears in 
its most recent state (floating or docked).

• Output Window button > Status tab

Macro Tab

You can edit, run, and debug macro scripts in the Macro  tab. You can open multiple macros and nest 
macros using the macro editor.

A macro is any combination of commands, keystrokes, and mouse clicks that you record to replay as a 
single action. You can record virtually any set of procedural steps for replay, thereby simplifying redundant 
activities, such as setting preferences and layer/display settings.

• Output Window  button > Macro  tab

CIS Tab
The CIS  tab provides a graphic interface to view part information in the database, to which you connect. 
You can select and add parts to the design, specify the part information to display, and export database 
configuration.

• Output Window  button > CIS  tab

Library Config Dialog Box

Part Manager Dialog Box
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Library Config Dialog Box

Library Config Dialog Box
To access: Output Window  > CIS  tab > New/Edit  button

Use the Library Config dialog box to specify the database from which to load part information and specifc 
part information displayed in the CIS  tab.

Figure 98. Library Config Dialog Box

Objects
Table  157. Library Config Dialog Box Contents

Name Description

ODBC DSN area:

ODBC DSN Selects the database from which to load part information from the 
drop-down list.

 Tip
SailWind StarterLibrary is connected by default.

ODBC Config Adds a new database.

 Tip
Click Update  to make the newly added database available.

Update Makes the newly added database available in the ODBC DSN 
drop-down list.

Database Tables area

To CIS Specifies database table(s) to display in the CIS  tab.
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Table  157. Library Config Dialog Box Contents  (continued)

Name Description

Table Name Displays all the table(s) in the selected database.

Table Configuration area

Field Name Lists all fields in the table selected on the left.

Field Type Specifies what type the table fields belong to from the drop-down list, 
wherein:

• Part_Type is mandatory, based on which to load data into the 
CIS tab. Besides, you can see schematic symbol and PCB decal 
assigned to the part type in the local libraries from the CIS preview 
window.

• Part_Number is mandatory, based on which to check whether part 
attribute values in design are identical with those in CIS.

• Category allows to show table structure hierarchically by 
subcategories in the CIS tab.

• All field types except Normal must be unique.

Field Alias Specifies the table heading for each field to display in the CIS  tab.
• Field aliases corresponding to Field Type "Part_Type" and 

"Part_Number" are defined by default, and no modification is 
allowed.

• If nothing is set, Field Name will be used instead.

Transfer to Design Specifies to add the Field Name to the part attributes. If yes, you 
can see it in the Part Attributes list by checking part properties in the 
design.

 Tip
When set, Field Alias will be used instead.

Visibility in CIS Specifies to display Field Name in the CIS  tab. When set, Field Alias 
will be used instead.

Key Reserved

Browsable Specifies to add hyperlinks to the field contents in the CIS  tab, which 
often links to such reference files as datasheets and drawings.

Property Checking Specifies attribute(s) to compare for consistency checking in the Part 
Manager Dialog Box.

 Tip
No checkbox selected means comparing all attributes by default.
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Part Manager Dialog Box

Part Manager Dialog Box
To access: Output Window  > CIS  tab > Part...  button

Use the Part Manager dialog box to compare part attributes in design with those in CIS for consistency 
checking. For the inconsistent attribute values, you can update from CIS with multiple options.

Figure 99. Part Manager Dialog Box

Objects
Table  158. Part Manager Dialog Box Contents

Name Description

Filter area • Specifies the search filter. Note that filtering by Component 
Name or Part Number is case-sensitive and no wildcard or 
expression is currently supported.

• Provides functionality buttons as follows:
• Filter: Used to activate the filter

• Clear: Used to reset the search filter settings

• Show Error Only: Used to show parts found with errors

Part Attribute Info. area Displays the search result.
For schematic parts whose attributes are not identical with those in 
CIS, they are highlighted in red.

Update the Selected  button Updates the incosistent attributes of the selected schematic part(s) 
from CIS.
Takes effect only on schematic parts found with "Attribute is not 
equal" error.

Update All  button Updates incosistent attributes of all schematic parts found with 
"Attribute is not equal" error from CIS.
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Table  158. Part Manager Dialog Box Contents  (continued)

Name Description

Refresh  button Manually updates the comparision result if you change part 
attributes in the design.

Comparision Results area Displays what assigned to the part attributes in design and CIS 
respectively, with differences highlighted in red. You can:

• Update the selected attribute: Right-click on the attribute cell 
and click the Update Selected Attribute From CIS popup menu 
item

• Update all attributes of the schematic part: Right-click and click 
the Update Selected Part From CIS popup menu item
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SailWind Layout Link Dialog Box
The SailWind Layout Link dialog box enables you to connect to SailWind Layout to automate sending 
the netlist and passing design change annotations, and cross-probe (receive and send selections). This 
feature also automates certain tasks for you, such as netlist comparisons and rules exports. Once you 
connect to SailWind Layout, you can select objects in SailWind Layout and the object is automatically 
selected and shown on its SailWind Logic schematic sheet (and vice versa).

See also Cross-Probe Between Sailwind Products.

The options you set in the SailWind Layout Link dialog box are saved to the registry. These options are 
restored the next time you open the SailWind Layout Link.

Note:
The exception is the selection made in the Sent Selection list on the Selection  tab, and the 
document pathname on the Document  tab.

SailWind Layout Link dialog box tabs:

SailWind Layout Link Dialog Box, Design Tab
SailWind Layout Link Dialog Box, Document Tab
SailWind Layout Link Dialog Box, ECO Names Tab
SailWind Layout Link Dialog Box, Preferences Tab
SailWind Layout Link Dialog Box, Selection Tab
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SailWind Layout Link Dialog Box, Design Tab
To access: Tools  > SailWind Layout  menu item > connect to SailWind Layout using the Connect to 
SailWind Layout Dialog Box  > Design  tab

Use the Design  tab of the SailWind Layout Link dialog box to export a netlist to SailWind Layout, 
compare the schematic to the layout design, or forward and backward annotate design data.

Objects
Table  159. SailWind Layout Link Dialog Box, Design Tab Contents

Name Description

Net list area

Send Netlist  button Exports a netlist from the current schematic to the current SailWind Layout 
design.
Results:

• If no errors are found in the netlist, SailWind Layout is updated.

• If errors are found in the netlist, the error report file is displayed in 
a Notepad window, a link to the error file is displayed in the Output 
Window, and you are asked whether you want to continue.

• If you click Yes, SailWind Layout is updated.

• If you click No, the operation is canceled and SailWind Layout is not 
updated.

Include Design Rules in 
Netlist check box

Select the check box to include design rules in the exported netlist.

 Tip
Before sending the netlist, run a connectivity report to check for possible 
connectivity errors. For information, see Reports Dialog Box.
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Table  159. SailWind Layout Link Dialog Box, Design Tab Contents  (continued)

Name Description

Compare/ECO area

Compare PCB  button Compares the netlist of the current SailWind Logic schematic to the netlist of 
the current SailWind Layout design.
Results:

• If no errors are found in either of the netlists, any differences are reported 
in the default text editor.

• If errors are found in either of the netlists, the error report file is displayed 
in a Notepad window, a link to the error file is displayed in the Output 
Window, and you are asked whether you want to continue.

• If you click Yes, the comparison operation continues.

• If you click No, the operation is canceled.

See also SailWind Layout Link Dialog Box, Preferences Tab, SailWind 
Layout Link Dialog Box, ECO Names Tab.

ECO To PCB  button Compares the netlist in the current SailWind Logic schematic to the part and 
netlist in the current SailWind Layout design.
Results:

• If no errors are found in either of the netlists, the SailWind Layout design 
is updated.

 Tip
Overwriting of non-blank attribute values with blank attribute values 
from the ECO file is allowed/prevented by the “Allow overwriting of 
attribute values in design with blank values from library” check box in 
the Design category  on page 591 of the Options dialog box.

• If errors are found in either of the netlists, the error report file is displayed 
in a Notepad window, a link to the error file is displayed in the Output 
Window, and you are asked whether you want to continue.

• If you click Yes, the SailWind Layout design is updated.

• If you click No, the operation is canceled, and SailWind Layout is not 
updated.

See also SailWind Layout Link Dialog Box, Preferences Tab, SailWind 
Layout Link Dialog Box, ECO Names Tab.

ECO From PCB  button Compares the netlist in the current SailWind Logic schematic to the part and 
netlist in the current SailWind Layout design.
Results:

• If no errors are found in either of the netlists, the SailWind Logic 
schematic is updated.

 Tip
Overwriting of non-blank attribute values with blank attribute values 
from the ECO file is allowed/prevented by the “Allow overwriting of 
attribute values in design with blank values from library attributes” 
check box in the Design category  on page 591 of the Options dialog 
box.
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Table  159. SailWind Layout Link Dialog Box, Design Tab Contents  (continued)

Name Description

• If errors are found in either of the netlists, the error report file is displayed 
in a Notepad window, a link to the error file is displayed in the Output 
Window, and you are asked whether you want to continue.

• If you click Yes, the SailWind Logic schematic is updated.

• If you click No, the operation is canceled, and SailWind Logic is not 
updated.

See also SailWind Layout Link Dialog Box, Preferences Tab, SailWind 
Layout Link Dialog Box, ECO Names Tab.

Compare Design Rules 
check box

Includes design rules in the comparison that occurs when you select 
Compare PCB, ECO to PCB, or ECO from PCB.

Show Net List errors 
report check box

Select the check box to open the Net List errors report once it has been 
generated. The filename is padsnet.err.

 Tip
If you clear the check box, you can still open the file from the link in the 
Output window.

AI layout reference data Select the check box in order for the AI Intelligent Layout  feature to work in 
SailWind Layout.

Disconnect  button Breaks the connection with SailWind Layout and closes the dialog box.

Related Topics
SailWind Layout Link Dialog Box
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SailWind Layout Link Dialog Box, Document Tab

SailWind Layout Link Dialog Box, Document Tab
To access: Tools  > SailWind Layout  menu item > connect to SailWind Layout using the Connect to 
SailWind Layout Dialog Box  > Document  tab

Use the Document  tab of the SailWind Layout Link dialog box to open and connect to a different design 
or a new design file within the current SailWind Layout session. The current design path and filename is 
listed at the top of this tab.

Figure 100. SailWind Layout Link Dialog Box, Document Tab

Objects
Table  160. SailWind Layout Link Dialog Box, Document Tab Contents

Name Description

Pathname field Displays the path and filename of the current SailWind Layout design.

New  button Creates a new file within the current SailWind Layout session. SailWind Logic 
automatically connects to this file.

 Tip
If the current SailWind Layout design has unsaved changes, a prompt 
window appears, asking, “Remote PCB document is modified - Do you 
want to save it?”.

Open  button Enables you to locate and open an existing SailWind Layout file. SailWind 
Logic automatically connects to this file.

 Tip
If the current SailWind Layout design has unsaved changes, a prompt 
window appears, asking, “Remote PCB document is modified - Do you 
want to save it?”.

Disconnect  button Breaks the connection with SailWind Layout and closes the dialog box.

Related Topics
SailWind Layout Link Dialog Box
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SailWind Layout Link Dialog Box, ECO Names Tab
To access: Tools  > SailWind Layout  menu item > connect to SailWind Layout using the Connect to 
SailWind Layout Dialog Box  > ECO Names  tab

Use the ECO Names tab of the SailWind Layout Link dialog box to manage options for the compare and 
ECO functions on the Design  tab.

Note:
See also Design tab  on page 614.

Figure 101. SailWind Layout Link Dialog Box, ECO Names Tab

Objects
Table  161. SailWind Layout Link Dialog Box, ECO Names Tab Contents

Name Description

Compare Names and Rename 
Nets and Parts as Necessary

Compare differences using reference designators and net names.

 Tip
• Best used to minimize changes to routed traces.
• Selecting this option may result in the positional swapping of 

parts.

Compare Names but Prefer 
Add/Delete Parts to Renaming

Compare differences using reference designators and net names 
on the basis that few reference designators have been renamed 
and nets have not been renamed.

 Tip
Best used to minimize the positional swapping of parts, and the 
design disruption that may result.

Compare Topology (not names). 
Rename as Necessary.

Compare differences without using reference designators or net 
names. Compare differences using pin names, part type names, 
and so on.
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SailWind Layout Link Dialog Box, ECO Names Tab

Table  161. SailWind Layout Link Dialog Box, ECO Names Tab Contents  (continued)

Name Description

 Tip
Best used to compare designs when parts and nets have 
been renamed, and minimal interconnect changes have been 
performed. For example, only an auto renumber has been 
performed on the design.

Disconnect  button Breaks the connection with SailWind Layout and closes the dialog 
box.

Related Topics
SailWind Layout Link Dialog Box
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SailWind Layout Link Dialog Box, Preferences Tab
To access: Tools  > SailWind Layout  menu item > connect to SailWind Layout using the Connect to 
SailWind Layout Dialog Box  > Preferences  tab

Use the Preferences  tab of the SailWind Layout Link dialog box to manage options for the compare and 
ECO functions on the Design  tab.

Note:
See also Design tab  on page 614.

Figure 102. SailWind Layout Link Dialog Box, Preferences Tab

Objects
Table  162. SailWind Layout Link Dialog Box, Preferences Tab Contents

Name Description

Ignore Unused Pins Net 
check box

Select to ignore the unused pins net in the original design and preserve the 
existing unused pins net in the design you're updating. \

 Tip
• If you clear this option, the unused pins net may be deleted.
• The unused pins net contains pins that have no logical net 

association.
• An unused pins net may be created by other software tools in the 

PCB design process.

Name box Type the name of the unused pins net.

 Restriction:
This box only becomes available if you select the Ignore Unused Pins 
Net check box.
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SailWind Layout Link Dialog Box, Preferences Tab

Table  162. SailWind Layout Link Dialog Box, Preferences Tab Contents  (continued)

Name Description

 Tip
• The maximum netname length is 47 characters.
• You can use any alphanumeric characters except curly braces { }, 

asterisks *, or spaces.
• The default name is NOT_CONNECTED.

Include Attributes area Parts  — Controls whether part attributes are included in the netlist.
SailWind Logic evaluates parts that have different attributes as different 
part types. Therefore, if you select Include Part Attributes when you 
generate the netlist, you must also select Include Part Attributes when you 
perform an ECO comparison. Otherwise the comparison considers the part 
types to be different and reports errors.
Nets  — Controls whether net attributes are included in the netlist.
SailWind Logic checks net names on the schematic against the SailWind 
Layout design. Therefore, if you select Include Net Attributes when you 
generate the netlist, you must also select Include Net Attributes when you 
perform an ECO comparison. Otherwise the comparison considers the net 
types to be different and reports errors.

Compare PCB Decal 
Assignments

Compares PCB decal assignments between the schematic and the design 
in SailWind Layout. Updates decal assignments in SailWind Layout.

Disconnect  button Breaks the connection with SailWind Layout and closes the dialog box.

SailWind Logic Guide 621



SailWind Logic GUI Reference
SailWind Layout Link Dialog Box, Selection Tab  

SailWind Layout Link Dialog Box, Selection Tab
To access: Tools  > SailWind Layout  menu item > connect to SailWind Layout using the Connect to 
SailWind Layout Dialog Box  > Selection  tab

Use the Selection  tab of the SailWind Layout Link dialog box to manage the selections sent to and 
received from SailWind Layout.

Figure 103. SailWind Layout Link Dialog Box, Selection Tab

Objects
Table  163. SailWind Layout Link Dialog Box, Selection Tab Contents

Name Description

Sent Selection list Contains a list of the objects currently selected in SailWind Logic.

Receive Selections 
check box

Select to enable the SailWind Logic to automatically locate the item 
corresponding to the SailWind Layout selection by changing schematic 
sheets and selecting the item in SailWind Logic.

Disconnect  button Breaks the connection with SailWind Layout and closes the dialog box.

Related Topics
SailWind Layout Link Dialog Box
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SailWind Router Link Dialog Box
You can link to and cross-probe with SailWind Router using the SailWind Router Link dialog box. 
This function enables you to receive and send selections and start a new SailWind Router session or 
document. Once you connect to SailWind Router, you can select objects in SailWind Router and the 
object is automatically selected and shown on its SailWind Logic schematic sheet (and vice versa).

See also “Cross-Probe Between Sailwind Products”  on page 324.

SailWind Router Link dialog box tabs:

SailWind Router Link Dialog Box, Document Tab
SailWind Router Link Dialog Box, Selection Tab
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SailWind Router Link Dialog Box, Document Tab
To access: Tools  > SailWind Router  menu item > connect to SailWind Router using the Connect to 
SailWind Router Dialog Box  > Document  tab

Use the Document  tab of the SailWind Router Link dialog box to open and connect to a different design 
or a new design file within the current SailWind Router session. The current design path and filename is 
listed at the top of this tab.

Figure 104. SailWind Router Link Dialog Box, Document Tab

Objects
Table  164. SailWind Router Link Dialog Box, Document Tab Contents

Name Description

Pathname field Displays the path and filename of the current SailWind Router design.

New  button Creates a new file within the current SailWind Router session. SailWind Logic 
automatically connects to this file.

 Tip
If the current SailWind Router design has unsaved changes, a prompt 
window appears, asking, “Remote PCB document is modified - Do you 
want to save it?”.

Open  button Enables you to locate and open an existing SailWind Router file. SailWind 
Logic automatically connects to this file.

 Tip
If the current SailWind Router design has unsaved changes, a prompt 
window appears, asking, “Remote PCB document is modified - Do you 
want to save it?”.

Disconnect  button Breaks the connection with SailWind Router and closes the dialog box.

Related Topics
SailWind Router Link Dialog Box
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SailWind Router Link Dialog Box, Selection Tab
To access: Tools  > SailWind Layout  menu item > connect to SailWind Router using the Connect to 
SailWind Router Dialog Box  > Selection  tab

Use the Selection  tab of the SailWind Router Link dialog box to manage the selections sent to and 
received from SailWind Router.

Figure 105. SailWind Router Link Dialog Box, Selection Tab

Objects
Table  165. SailWind Router Link Dialog Box, Selection Tab Contents

Name Description

Sent Selection list Contains a list of the objects currently selected in SailWind Logic.

Receive Selections 
check box

Select to enable the SailWind Logic to automatically locate the item 
corresponding to the SailWind Router selection by changing schematic 
sheets and selecting the item in SailWind Logic.

Disconnect  button Breaks the connection with SailWind Router and closes the dialog box.

Related Topics
SailWind Router Link Dialog Box
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SailWind Suite Configuration Dialog Box
To access:

• Help  > Installed Options  menu item > Suite Configuration  button

• Optional: Opens on program startup

Use the SailWind Suite Configuration dialog box to manage SailWind Suite (composite) licenses.

Objects

Field Description

Control suite license checkout and 
select from the following list

Enables the Suite License table for you to control checkouts.

Suite Name column Lists the name of the suite for which the license works.

License Feature column Lists the specific features available for each license.

License status column Lists the status of the licenses when you click the Check status 
button.

Check Status button Specifies to check the status of all licenses listed in the table and 
displays the status in the License status column.
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Field Description

Reset List button Specifies to reset the list of suite licenses to only those detected in 
your licensing environment.

Move up button Moves the selected license up one row.

Move down button Moves the selected license down one row.

Select all button Selects all of the listed licenses.

Select none button Deselects all of the listed licenses.

Show this dialog box on program 
startup

Specifies to open the SailWind Suite Configuration dialog box 
when SailWind Layout starts.

Automatically check license status 
on dialog box startup

Specifies to check the status of the licenses when you open the 
SailWind Suite Configuration dialog box.

SailWind Logic Guide 627



SailWind Logic GUI Reference
Part Attributes Dialog Box  

Part Attributes Dialog Box
To access: Select a part > right-click > Attributes  menu item

Use the Part Attributes dialog box to assign or modify part attributes, which is information about the part 
such as manufacturer and cost.

Tip
Adding or changing attributes in a part at the schematic level does not update the part type (in the 
library). Edit the part in the Part Editor to update the library part.

Figure 106. Part Attributes Dialog Box

Objects
Table  166. Part Attributes Dialog Box Contents

Name Description

Attributes table Lists the name and value of the attributes of the selected part.

Browse Lib Attr  button Opens the Browse Library Attributes Dialog Box.

Add  button Adds a row to the end of the Attributes table where you can add a 
new attribute.

Delete  button Removes the selected row from the Attributes table.

Edit  button Makes the selected cell available for editing.

Apply update to area Specifies how parts are updated:
• This Part  — Only updates the selected part.

• All Parts This Type  — Updates all matching parts in the 
design
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Part Attributes Dialog Box

Related Topics
Modifying Part Attributes
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Part Information Dialog Box
Use the part information dialog box to create or edit part types.

Part Information dialog box tabs:

Part Information Dialog Box, Attributes Tab
Part Information Dialog Box, Connector Tab
Part Information Dialog Box, Gates Tab
Part Information Dialog Box, General Tab
Part Information Dialog Box, PCB Decals Tab
Part Information Dialog Box, Pin Mapping Tab
Part Information Dialog Box, Pins Tab
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Part Information Dialog Box, Attributes Tab
To access: Tools  > Part Editor  menu item > Edit Electrical  button > Attributes  tab

Use the Attributes  tab of the Part Information dialog box to manage attributes for the selected part, and 
to define default attributes for new parts.

Figure 107. Part Information Dialog Box - Attributes Tab

Objects
Table  167. Part Information Dialog Box - Attributes Tab Contents

Name Description

Attribute table • Attribute column  — The name of the Attribute.

• Value column  — The value of the Attribute.

Save As Default  button Saves the current attribute list as the default for all new attributes.

 Tip
The Attribute name is saved, but not the Attribute value.

Reset  button Undoes all changes you made in the Attributes  tab.

Edit  button Makes the selected cell available for editing.
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Table  167. Part Information Dialog Box - Attributes Tab Contents  (continued)

Name Description

Result:  The attribute is edited for only the selected part. To 
manage attributes design-wide or in all libraries, use the Manage 
Library Attributes Dialog Box.

 Tip
You can also double-click a cell to edit its contents.

See also Managing Attributes.

Add  button Adds a new row for a new attribute at the bottom of the table.
Result:  The new attribute is added to the Part Type Level of the 
attribute hierarchy. For more information, see Attribute Hierarchy  in 
the SailWind Layout Guide.

 Tip
After you type the new attribute name, press the Tab key or 
double-click in the value field to type the value.

Delete  button Removes the selected row.

Copy  button Places the selected cell information in the paste buffer.

 Tip
You can also copy from Microsoft Excel.

Paste  button Pastes the information from the paste buffer. The selected cell in 
the table is the paste origin. Data is pasted below and to the right 
of the paste origin.

Browse Lib. Attr  button Opens the Browse Library Attributes Dialog Box  where you can 
browse for an existing library attribute.

Check Part  button Checks for missing or inconsistent information.

 Tip
Even if you don't click the Check Part  button, when you exit 
the tab, the assigned decals are checked to ensure that they 
contain physical pin numbers for all the gate and signal pins 
defined in the Pins  tab.

Related Topics
Managing Attributes
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Part Information Dialog Box, Connector Tab
To access: Tools  > Part Editor  menu item > Edit Electrical  button > Connector  tab

Use the Connector  tab to define the alternate Logic decals to display in a schematic. Decals are referred 
to as Special Symbols. You can associate a logical Pin Type with each alternate so that you can have a 
graphical indication of the connector pin function in the schematic.

Restriction:
The Connector  tab is available only when you open an existing connector or create a new 
connector.

Tip
Many users like to use a different symbol, or decal, to distinguish between input (Source) and 
output (Load) pins. You may define multiple symbols for each of the ten different pin types.

Figure 108. Part Information Dialog Box - Connector Tab
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Objects
Table  168. Part Information Dialog Box - Connector Tab Contents

Name Description

Picture Displays a picture of the selected Special Symbol.

Attribute table • Special Symbol  — The name of a connector pin decal for use in the 
schematic.

• Pin Type  — The function of the special symbol.

Opens the Browse for Special Symbols Dialog Box  where you can browse 
for a pin decal.

Reset  button Undoes all changes you made in the Connector  tab.

Edit  button Makes the selected cell available for editing.

 Tip
You can also double-click the cell to edit the contents.

Add  button Adds a new row at the bottom of the table.

Delete  button Removes the selected row.

Check Part  button Checks for missing or inconsistent information.

 Tip
Even if you don't click the Check Part  button, when you exit the tab, 
the assigned decals are checked to ensure that they contain physical 
pin numbers for all the gate and signal pins defined in the Pins  tab.

Related Topics
Assigning Alternate Logic Decals for Connector Symbols
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Part Information Dialog Box, Gates Tab
To access: Tools  > Part Editor  menu item > Edit Electrical  button > Gates  tab

Use the Gates  tab of the Part Information dialog box to assign gate information to a part, including the 
number of gates, gate swap information, and CAE Decals for the part.

Tip
A space and a period (.) are illegal characters for pin names.

Figure 109. Part Information Dialog Box - Gates Tab

Objects
Table  169. Part Information Dialog Box - Gates Tab Contents

Name Description

Preview area Shows the item selected in the Decal cell.

Reset  button Undoes all changes you made in the Gates  tab.

Edit  button Makes the selected cell available for editing. Also displays the 
Browse  button.
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Table  169. Part Information Dialog Box - Gates Tab Contents  (continued)

Name Description

Opens the Assign Decal to Gate Dialog Box.

 Tip
This button is available only in the CAE Decal columns, and 
only when the cell is available for editing.

Add  button Adds a new row with the next Gate letter at the bottom of the Gate 
table.

Delete  button Removes the selected row from the Gate table.

Gate table • Gate column  — Displays the letter of the gate.

• Pins column  — Displays the number of pins for the gate. Gate 
pins are added on the Pins  tab.

• Swap column  — Displays the swap ID from 0 to 100. To 
uncross connections and facilitate routing, gates with the same 
swap ID (except for 0) can be swapped within a part or with 
another part of the same type.

To disable swapping, type 0.

• CAE Decal N  column  — Displays the CAE Decal name. The 
decal listed for CAE Decal 1 is the default decal and is used 
when you add the part to the schematic. Additional decals are 
alternates. You can assign up to four CAE decals to a part.

 Tip
Double-click to Type a decal name or click the 
“...” (Browse) button to search for a decal from a library

Check Part  button Checks for missing or inconsistent information.

 Tip
Even if you don't click the Check Part  button, when you exit 
the tab, the assigned decals are checked to ensure that they 
contain physical pin numbers for all the gate and signal pins 
defined in the Pins  tab.

Related Topics
Assigning Gates to Parts
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Part Information Dialog Box, General Tab
To access: Tools  > Part Editor  menu item > Edit Electrical  button > General  tab

Use the General  tab of the Part Information dialog box to view part statistics and set family information.

Figure 110. Part Information Dialog Box - General Tab

Objects
Table  170. Part Information Dialog Box - General Tab Contents

Name Description

Part Statistics area

Pin Count Displays the total number of pins in the part. Includes gate pins, 
signal pins, and unused pins. If multiple decals are assigned with 
different pin counts, a range of smallest to largest decal pin counts 
is shown.

Decal Displays the name of the decal, as chosen on the PCB Decals  tab.

Gate Count Displays how many gates exist in the part.

Signal Pin Count Displays the number of signal pins in the part.
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Table  170. Part Information Dialog Box - General Tab Contents  (continued)

Name Description

Logic Family area

Logic Family list Specifies the Logic Family (reference designator prefix) to use for 
the part. You can also create a new logic family or edit the existing 
reference designator prefix designations by clicking the Families... 
button.

 Note:
Beginning with PADS 9.0, die parts and flip chips are no longer 
identified by their family designations (DIE or FLP), but instead 
by the Special Purpose settings on this tab. With this change, 
you can assign any reference designator (logic family) to a die 
part or flip chip without losing the special properties of these 
parts (such as the ability to move the part's substrate bond 
pads in the schematic).

Ref Prefix Displays the reference designator prefix for the selected logic 
family.

Families  button Opens the Logic Families dialog box  on page 561where you can 
add, edit, or delete a logic family.

Options area

Define mapping of Part Type pin 
numbers to PCB Decal

Activates the Pin Mapping  tab where you can map logical pin 
numbers to different physical pin numbers.

 Restriction:
• The check box is unavailable once you add one or more 

alphanumeric decals to the part type. Remove the assigned 
alphanumeric decal to make the check box available. 
The check box also becomes available if you assign a 
numeric decal. However, you will still need to remove the 
alphanumeric decal from the list to make the part valid.

• You must assign a decal to use the Pin Mapping  tab.
• Only decals with sequential numerical pin numbers can be 

used with pin mapping.

ECO Registered Part Enables a part to be passed between the design and schematic file 
for forward and backward annotation. By default, all existing part 
types in your design are ECO registered.

 Tip
Typically you do not select this check box for non-electrical 
parts. For example, if you create and add a mounting hole to 
your design in the layout software, you would not need the 
part (mounting hole) to pass back to your schematic when you 
perform a backward annotation of the design.

Prefix List Specifies to apply the part information edits to other parts in the 
library. Type the prefixes and wildcards that match the names of 
the other parts to update.
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Table  170. Part Information Dialog Box - General Tab Contents  (continued)

Name Description

 Note:
Examples:

• Question mark ? in a prefix acts as a wildcard for one 
character. The prefix “?4” is the equivalent of “54” or “74”.

• If you type “\02” as the suffix, the edits are applied to all 
parts ending in 02.

 Note:
Warning:  The contents of the Prefix List box are applied when 
you click OK  or Save As on other tabs in the Part Information 
dialog box.

Special Purpose Identifies the part as one of the following types:
• Connector  — In contrast to other part types, connectors do not 

require a prefix list, or gate definitions.
 Restriction:

◦ This check box is automatically selected when you create 
or modify connectors. It is unavailable if you open a part 
other than a connector.

◦ This check box is unavailable when the part already has 
gate or pin assignments.

◦ The Gate Decals  tab is unavailable when the Connector 
check box is selected.

◦ Some Pins  tab controls not applicable to connector parts 
are disabled.

• Die Part — See the following note.

• Flip Chip  — See the following note.

 Note:
Beginning with PADS 9.0, die parts and flip chips are identified 
by the Special Purpose settings in the Part Type rather than by 
the DIE and FLP logic families. With this change, any reference 
designator (logic family) can be assigned to a die part or flip 
chip.

Check Part  button Checks for missing or inconsistent information.

 Tip
Even if you don't click the Check Part  button, when you exit 
the tab, the assigned decals are checked to ensure that they 
contain physical pin numbers for all the gate and signal pins 
defined in the Pins  tab.

Related Topics
Viewing and Setting General Part Information
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Part Information Dialog Box, PCB Decals Tab
To access: Tools  > Part Editor  menu item > Edit Electrical button > PCB Decals  tab

Use the PCB Decals  tab of the Part Information dialog box to assign decals, or footprints, to library parts.

Figure 111. Part Information Dialog Box - PCB Decals Tab

Objects
Table  171. Part Information Dialog Box - PCB Decal Tab Contents

Name Description

Preview area Displays the item selected in the Assigned Decals list.

Library list Lists all your available libraries. Filters the Unassigned Decals list 
to only the selected library.

Filter Searches the chosen library (or libraries) for a specific part or item 
name, or names that match a wildcard or expression  on page 105. 
Type * to view all parts or items in the chosen libraries. Click Apply 
to search the libraries and display the search results.

Pin Count Narrows down your unassigned decals list by displaying only the 
decals with the specified number of pins.
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Table  171. Part Information Dialog Box - PCB Decal Tab Contents  (continued)

Name Description

 Tip
Delete all numbers in the Pin Count box to display all decals. 
This box is always available as a filter to enable decals of 
differing pin counts to be assigned.

Show only Decals with pin 
numbers matching Part Type

Filters out decals that do not have pin numbers matching existing 
gate and signal pins on the Pins  tab, or the physical pin numbers 
on the Pin Mapping  tab.

Unassigned Decals list Lists all of the available decals to assign to the part.

Assign >>  button Moves the selected decal from the Unassigned Decals list to the 
Assigned Decals list.

 Restriction:
• You must assign a decal with enough pins for all the defined 

gate pins and signal pins on the Pins  tab.
• Only decals with sequential numerical pin numbers can be 

used with pin mapping.

<< Unassign  button Moves the selected decal from the Assigned Decals list to the 
Unassigned Decals list.

Assigned Decals list Lists all assigned decals. Assigned PCB decals can have a 
different number of pins, but you must assign a decal with enough 
pins for all the defined gate pins and signal pins on the Pins  tab.
You can assign up to 16 PCB decals to a part.

 CAUTION:
Decals are switched to alternates using the Component 
Properties dialog box and can be changed outside of ECO 
mode. An .eco file created by the ECO toolbar will not contain 
decal changes to alternates.Use the Compare/ECO dialog box 
to create an .eco file that lists changes to alternate decals.
 Tip

• The decal at the top of the list is the default decal and is 
used when you add the part to the design.

• When you assign a decal, the pin numbers from the decal 
are automatically populated into the Pins  tab table. PCB 
Decal pin numbers can be alphanumeric or numeric and the 
pin numbers in the PCB Decal must match the pin numbers 
listed in the Pins  tab table.

Assign New  button Opens the New PCB Decal dialog box  on page 469where you can 
type the name for a decal that does not yet exist in a library. To use 
this part in a design, you must either acquire or create this decal.

 Restriction:
When you assign a decal that exists, it pre-populates the Pins 
tab  on page 645 with pin numbers. When you assign a new 
PCB decal, you must enter the pin numbers manually.

Up/Down  buttons Moves the selected Decal up or down.
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Table  171. Part Information Dialog Box - PCB Decal Tab Contents  (continued)

Name Description

Check Part button Checks for missing or inconsistent information.

 Tip
Even if you don't click the Check Part  button, when you exit 
the tab, the assigned decals are checked to ensure that they 
contain physical pin numbers for all the gate and signal pins 
defined in the Pins  tab.

Related Topics
Assigning PCB Decals
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Part Information Dialog Box, Pin Mapping Tab
To access: Tools  > Part Editor  menu item > Edit Electrical  button > General  tab. On the General  tab, 
select the “Define mapping of Part Type pin numbers to PCB Decal” check box to make the Pin Mapping 
tab available. On the PCB Decals  tab, assign a decal with sequential numerical pin numbers to use the 
Pin Mapping  tab. The decal determines the number of pins in the part.

Use the Pin Mapping  tab of the Part Information dialog box to overlay alphanumeric pin numbers onto 
numeric PCB decal pins. Prior to PADS 2007, alphanumeric pin numbers could not be saved in PCB 
decals.

Figure 112. Part Information Dialog Box - Pin Mapping Tab

Objects
Table  172. Part Information Dialog Box - Pin Mapping Tab Contents

Name Description

Decal list Lists the decals available to you for which you can map 
alphanumeric pins.

Reset  button Undoes all changes you made in the Pin Mapping  tab.

Unmapped Pins list Lists all unmapped pins available to map in the Mapping table.

Map >> button Moves the selected pin from the Unmapped pins list to the 
selected cell in the Mapping table.
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Table  172. Part Information Dialog Box - Pin Mapping Tab Contents  (continued)

Name Description

<< Unmap  button Moves the selected decal number from the Mapping table to the 
Unmapped Pins list.

Mapping table • Decal column  — The number of the Decal.

• Part Type column  — The value of the Attribute.

Edit  button Makes the selected cell available for editing.

 Tip
You can also double-click the cell to edit the contents.

Copy Map  button Places the map information into the paste buffer to paste into 
Microsoft Excel where you can make mass edits.

 Restriction:
Copy Map  only works with the whole pin mapping table and 
not selective rows.

Paste Map  button Pastes the map information from the paste buffer.

 Restriction:
Paste Map  only works with the whole pin mapping table and 
not selective rows.

Preview area Shows the item selected in the Decal list.
You can assign unmapped pins to decal pins by selecting the pins 
in the preview window. Select an alphanumeric in the Unmapped 
Pins list and double-click the pin in the decal preview window to 
map the alphanumeric to the pin. The next row in the Unmapped 
Pins list becomes the next selected alphanumeric for mapping.
In the preview window, you can click and drag to define a zoom 
box, or use Shift+click or Shift+right-click to zoom in or out by a 
factor of two. You can zoom in up to 16X the original scale. The 
preview window will only zoom out to fit the decal entirely in the 
view.

Check Part  button Checks for missing or inconsistent information.

 Tip
Even if you do not click the Check Part  button, when you exit 
the tab, the assigned decals are checked to ensure that they 
contain physical pin numbers for all the gate and signal pins 
defined in the Pins  tab.

Related Topics
Part Information - Pin Mapping
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Part Information Dialog Box, Pins Tab
To access: Tools  > Part Editor  menu item > Edit Electrical  button > Pins  tab

Use the Pins  tab of the Part Information dialog box to assign gate pins, signal pins, and unused pins to 
the part. Pin numbers added to the Pins  tab, must match those of the PCB Decal. Use the Pin Mapping 
tab to overlay logical (schematic) alphanumeric pin numbers onto the physical numeric PCB decal.

Objects

Name Description

Pins Table Double-click a column to sort the column by ascending order.

 Tip
Sorting by pin Sequence number or Pin Group has the same 
effect, it sorts by Pin Group and then by sequence number 
within each gate.

Pin Group column Select from Gate, Signal Pin, Connector Pin or Unused Pin.
• Gate Pins  — Assign to gates you’ve added to the part on the 

Gates tab  on page 635.

• Signal Pins  — Assign to implicit pins (pins which are not 
displayed on any gate in the schematic). Typically, ground and 
power pins are the only implicit pins. You are not required to 
use Signal Pins. Instead, you can add power and ground pins 
to a gate or create a separate gate for power and/or ground 
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Name Description
pins. For the parts in the libraries shipped with SailWind Logic, 
the standard ground signal name is GND. The standard power 
signal name is +5V.

• Connector Pins  — Assign to connector pins instead of using 
Gate pins. With a connector, every pin is its own gate in order 
to spread each connector pin throughout the schematic as 
needed, instead of having to create gates for each pin. You 
designate a part type as a connector on the General tab  on 
page 637.

• Unused Pins  — You can assign a pin to be an unused pin. An 
unused pin is a pin that is defined in a PCB decal but has no 
electrical function in the part type. The unused pin information 
is not saved in the part type, but is derived automatically based 
on the number of assigned gate and signal pins to the number 
of pins in the assigned PCB decal.

Number column Specifies the pin number for the pin.

 Note:
Requirement:  The pin number must match the PCB decal. For 
example, alphanumeric to alphanumeric.

Name column Specifies the pin signal or function name of the pin.

 Note:
Requirement:  The pin must have a name to be valid.

Type column Specifies the type of pin.

 Tip
This column is used with gate pins only.

Swap column Specifies an identical number between pins that can be swapped.

 Tip
Type 0 to disable swapping.

Seq. column Specifies the sequence number.

 Tip
The sequence number determines the mapping of CAE gate 
pins to PCB decal pins. The sequence is automatically shared 
with alternate CAE decals. For example, it shows how pin 
numbers appear on the CAE gate decal; therefore, in Gate A, 
sequence number 1 could be pin 1, but in Gate B, sequence 
number 1 would be pin 4.

Reset  button Undoes all changes you made in the Pins  tab.

Edit  button Makes the selected cell available for editing. Press Ctrl or Shift and 
click to select multiple cells from the same column, then click Edit 
to make the same changes to the selected cells. The action of the 
Edit  button depends on the cells you select:

• Pin Group column  — Opens the Update Pin Gate dialog box.

• Number column  — Opens the Renumber Pins dialog box.
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Name Description

• Name column  — Opens the Update Pin Name dialog box.

• Type column  — Opens the Update Pin Type dialog box.

• Swap column  — Opens the Update Pin Swap dialog box.

• Seq. column  — Not available for multiple cell edits.

Add Pin  button Adds a new row below the selected row. If it's the first pin to be 
added it takes the default of belonging to Gate-A. If pins already 
exist, the new pin takes the Pin Group of the currently selected pin.

 Note:
Requirement: You must add a pin number to make the pin 
valid.
 Tip

• You can add all pins automatically by adding a decal.
• To add a series of pins, click the Add Pins  button.
• To import pins using a comma separated value (.csv) file, 

click the Import CSV  button.

Add Pins  button Opens the Add Pins Dialog Box.

 Note:
Restriction:  Total pins for the part can not exceed 32,767 pins.
 Tip

• You can add all pins automatically by adding a decal.
• To add a single pin, click the Add Pin  button.
• To import pins using a comma separated value (.csv) file, 

click the Import CSV  button.

Delete Pins  button Removes the selected row.

Renumber  button Opens the Renumber Pins Dialog Box.

Copy  button Places the selected cell information in the paste buffer.

 Tip
You can also copy from Microsoft Excel.

Paste  button Pastes the information from the paste buffer. The selected cell in 
the table is the paste origin. Data is pasted below and to the right 
of the paste origin.

 Restriction:
When the pasted data includes either Pin Group or Pin Number 
data, extra pin rows are added automatically, otherwise the 
paste will fail if the number of rows and columns in the pasted 
data does not match those available in the table below and to 
the right of the paste origin.

Import CSV  button Opens the Library Import File dialog box where you select the .csv 
file to import.
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Name Description

 Tip
• The entire contents of the Pins  tab table is replaced with the 

data of the CSV file.
• CSV field names must correspond to the column headers 

in the Pins  tab table. Only the first two characters of the 
header must match. For example, “Pi” for the Pin Group 
column. Gate or “Ga” are acceptable alternatives to the Pin 
Group header.

• The sample Part_Pins_Template.csv  file is located in your 
\SailWind Projects\Samples  folder.

Check Part  button Checks for missing or inconsistent information.

 Tip
Even if you don't click the Check Part  button, when you exit 
the tab, the assigned decals are checked to ensure that they 
contain physical pin numbers for all the gate and signal pins 
defined in the Pins  tab.

Related Topics
Part Information - Pins
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Part Properties Dialog Box
To access: Select a part > right-click > Properties  menu item

Use the Part Properties dialog box to create and edit part attributes. You can also define signal pins and 
control the visibility of attributes assigned to the part.

Tip
This dialog box contains several sub-dialog boxes. Before using any of these sub-dialog boxes, 
changes made in open dialog box must be applied to the design.

Figure 113. Part Properties Dialog Box

Objects
Table  173. Part Properties Dialog Box Contents

Name Description

Reference Designator Displays the name of the reference of the selected part.

Rename Gate  button Opens the Rename Gate Dialog Box.

Rename Part  button Opens the Rename Part Dialog Box.

Part Type Displays the type of the selected part.
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Table  173. Part Properties Dialog Box Contents  (continued)

Name Description

Change Type  button Opens the Change Part Type Dialog Box.

Part Information area Displays the PCB Decal, pin count, Logic Family, if the part is ECO 
registered, the signal pin count, the gate count, and the number of 
unused pins.

Statistics  button Displays gate and connection information for the selected part. 
This information is displayed in the default text editor so you can 
save the contents to a file.

Gate Decal list Specifies the gate decal. Select a gate decal name from the Gate 
Decal list to change the gate decal of the selected gate or part to 
one of the predefined alternate decals

Visibility  button Opens the Part Text Visibility Dialog Box.

Attributes  button Opens the Part Attributes Dialog Box.

PCB Decals  button Opens the PCB Decal Assignment Dialog Box.

SigPins  button Opens the Part Signal Pins Dialog Box.

Related Topics
Modifying Parts
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Part Signal Pins Dialog Box
To access: Select a part > right-click > Properties  > SigPins button

Use the Part Signal Pins dialog box to assign any unused pins as additional signal pins. When the part 
type is created and stored in the library, the standard power and ground pins for part types are defined. 
Signal pins assigned during part creation cannot be modified through this dialog box. Instead, use the 
Assigning Signal Pin Names to Parts dialog box in the Library Manager.

Tip
The Part Signal Pins dialog box lists pins and their corresponding signal names. A signal pin is a 
pin that has a signal net (GND for example) assigned by a schematic capture program during part 
type creation.

Figure 114. Part Signal Pins Dialog Box

Objects
Table  174. Part Signal Pins Dialog Box Contents

Name Description

Unused Pins list Lists all of the unused pins for the selected part.

Add >>  button Adds the selected unused pin to the Signal Pins table

<< Remove  button Removes the selected Signal Pin to the Unused Pins list.

Edit  button Makes the selected cell available for editing.

Signal Pins table Lists the signal pin number and corresponding name.

Apply update to area Specifies how parts are updated:
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Table  174. Part Signal Pins Dialog Box Contents  (continued)

Name Description

• This Part  — Only updates the selected part.

• All Parts This Type  — Updates all matching parts in the 
design

Related Topics
Modifying Parts
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Part Text Visibility Dialog Box
To access: Select a part > right-click > Visibility  menu item

Use the Part Text Visibility dialog box to control the display of text associated with the selected part. You 
can control the visibility of one part or all parts of the same type.

Figure 115. Part Text Visibility Dialog Box

Objects
Table  175. Part Text Visibility Dialog Box Contents

Name Description

Item Visibility area Specifies the visibility of the items: click to make the item visible; 
click to clear to make the item invisible.

Attribute Name Display area Specifies the attribute name option. Display just the attribute's 
value or display the attribute name and its value.

• All Off  — Makes all attribute names invisible, displays only the 
value.

• No Change  — Keeps the current attribute name visibility 
settings.

• All On  — Displays all attribute names and their values.

Apply Update to area Specifies the selected part update options.
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Table  175. Part Text Visibility Dialog Box Contents  (continued)

Name Description

• This Gate  — Updates the selected gate.

• This Part  — Updates a part or all associated gates of a part.

• All Part This Type  — Updates all matching gates or parts in 
the design.

 Restriction:
This area is unavailable when more than one part is selected.

Attributes list Specifies the attributes you want to display in the schematic.

Related Topics
Controlling Text Visibility for a Part
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Part Type Label Properties Dialog Box
To access: Select a part type label > right-click > Properties  menu item

Use the Part Type Label Properties dialog box to provide text and font settings for one or more part type 
labels.

Figure 116. Part Type Label Properties Dialog Box

Objects
Table  176. Part Type Label Properties Dialog Box Contents

Name Description

Name The name of the selected attribute.

Change Type  button Opens the Change Part Type Dialog Box.

Rotation Specifies the rotation of the label: 0 or 90 degrees.

Size Specifies the size of the font.
Size (pts):  This is font size in points and appears for system fonts
Size (mils):  This is font character height and appears for stroke 
fonts. The size refers to the height of the tallest characters.
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Table  176. Part Type Label Properties Dialog Box Contents  (continued)

Name Description

Line Width Specifies the line width for stroke fonts only.

Font list The fonts available to you. This lists either stroke fonts or system 
fonts.
You choose which type of font to use in the Fonts Dialog Box.

 Tip
• Select stroke font or a system font.
• For system fonts, you can also click a font style button, or 

any combination of styles: B  for bold, I  for italic, or U  for 
underlined.

Horizontal/Vertical Justification Specifies the horizontal (Right, Center, Left) justification and the 
vertical (Up, Center, Down) justification of the text.

Related Topics
Modifying Part Type Labels
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Pen Plotter Advanced Setup Dialog Box
To access: File  > Plot  menu item > select Pen Plot > Setup  button > Advanced  button

Use the Pen Plotter Advanced Setup dialog box to add a new pen plotter to the list of available plotters.

Figure 117. Pen Plotter Advanced Setup Dialog Box

Objects
Table  177. Pen Plotter Advanced Setup Dialog Box Contents

Name Description

Plotter Device Name Specifies the name of a different pen plotter you want to use.

 Note:
Exception:  Do not reuse one of the existing, supplied device 
names.

Device Type list Specifies the interface language the plotter uses: HPGL or HGML.

Plotter Units area Specifies the plotter resolution as a scaling ratio using the numbers 
in the Multiplier and Divisor boxes. The ratio defined is the scale 
factor to convert from mils (0.001 in) to plotter units.

 Note:
Example:  Most Hewlett-Packard plotters have a resolution of 
0.025 mm or 1/40 mm. This means that a distance of one inch 
(1000 mils) is 1016 plotter units (25.4 X 40). So a ratio of 1016 
to 1000 would be defined. The ratio actually used is 254 to 250 
which is the same as 1016 to 1000.

Origin at Center Specifies that the origin of the plotter is at the center of the paper.

 Tip
Clear this check box if the origin is in the lower left corner or 
other location.

Related Topics
Pen Plotter Setup Dialog Box

SailWind Logic Guide 657



SailWind Logic GUI Reference
Pen Plotter Setup Dialog Box  

Pen Plotter Setup Dialog Box
To access: File  > Plot  menu item > select Pen Plot > Setup  button

Use the Pen Plotter Setup dialog box to set various options for the plotter.

Figure 118. Pen Plotter Setup Dialog Box

Objects
Table  178. Pen Plotter Setup Dialog Box Contents

Name Description

Number of Pens Specifies the number of pens (1-16) in your device.

Pen Line Width Specifies the pen line width in mils.

Rotate Axis Specifies to reverse the X and Y axes of the design.

Pen Colors Specifies the color of each pen.

 Tip
Select the color in the Selected Color area and then click the 
tile for each pen number in the Pen Colors area.

Selected Color The area where you select the color you want for each pen color.

Plotting size area Specifies the size of the plot. A through E and Other in inches; A4 
through A0 and Other in millimeters.

 Tip
If you click Other, specify the X and Y dimensions.

Device Specifies the Plotter device to use.
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Pen Plotter Setup Dialog Box

Table  178. Pen Plotter Setup Dialog Box Contents  (continued)

Name Description

Advanced  button Opens the Pen Plotter Advanced Setup Dialog Box.
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PCB Decal Assignment Dialog Box
To access: Select a part > right-click > Properties  > PCB Decals  button

Use the PCB Decal Assignment dialog box to assign alternate PCB decals to schematic parts. Decal 
names are included in the netlist file to display the proper decal, or footprint, when the file is imported into 
the PCB design file. You can select a decal assigned as an alternate during part creation, override the 
decal with one from the library, or enter a name for an undefined decal you plan to create later in the PCB 
design.

Figure 119. PCB Decal Assignment Dialog Box

Objects
Table  179. PCB Decal Assignment Dialog Box Contents

Name Description

Assigned in Schematic Displays the name of the currently selected decal as it is assigned 
to the schematic from the current library.

<< Assign  button Assigns the selected decal in the Alternate in Library list to the 
part.

Alternates in Library list Lists alternate decals in the library.

No specific PCB Decal Specifies to remove the assigned decal. The default decal 
assigned to the part type is used when the netlist is imported to 
SailWind Layout; no decal assignment appears in the netlist.

Browse  button Opens the Get PCB Decal From Library Dialog Box.

Picture area Displays the selected pin.

Apply update to area Specifies how parts are updated:
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PCB Decal Assignment Dialog Box

Table  179. PCB Decal Assignment Dialog Box Contents  (continued)

Name Description

• This Part  — Only updates the selected part.

• All Parts This Type  — Updates all matching parts in the 
design

Related Topics
Modifying Parts
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Photo Plotter Advanced Setup Dialog Box
To access: File  > Plot  menu item > select Photo Plot > Setup  button > Advanced  button

Use the Photo Plotter Setup dialog box to define the aperture and other photo plotter options.

Figure 120. Photo Plotter Advanced Setup Dialog Box

Objects
Table  180. Photo Plotter Advanced Setup Dialog Box Contents

Name Description

Units area Specifies the units to use:
• English  — mils

• Metric  — millimeters

Number of Digits area Specifies the precision of the output file coordinates:
• Leading — the number of digits that should lead the decimal 

point

• Trailing  — the number of digits that should trail the decimal 
point

Coordinates area Specifies the coordinates for the output file:
• Absolute  — absolute coordinates

• Incremental  — relative coordinates

Zero Suppress area Specifies how to handle zero suppression in the output file:
• None  — retains leading and training zeros

• Leading  — suppresses zeros before the decimal point

• Trailing  — suppresses zeros after the decimal point
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Table  180. Photo Plotter Advanced Setup Dialog Box Contents  (continued)

Name Description

Circular Interpolation area Specifies how to draw arcs and circles:
• None  — if your photo plotter does not support circular 

interpolation. Arcs and circles are drawn as small straight-line 
segments

• Quadrant  — if your photo plotter does not support full, 
360-degree circular interpolation

• Full  — if your photo plotter supports full, 360-degree circular 
interpolation

Plotting Size area Specifies the size of the plot. A  through E  and Other  in inches; A4 
through A0  and Other  in millimeters.

 Tip
If you click Other, specify the X and Y dimensions.

Suppress Repeated Coords Specifies to eliminate repeated coordinates from the output file.

Related Topics
Photo Plotter Setup Dialog Box
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Photo Plotter Setup Dialog Box
To access: File  > Plot  menu item > select Photo Plot > Setup  button

Use the Photo Plotter Advanced Setup dialog box to define the units for the photo plotter to use.

Figure 121. Photo Plotter Setup Dialog Box

Objects
Table  181. Photo Plotter Setup Dialog Box Contents

Name Description

D-Code list Lists the D-codes for the photo plotter.

Add  button Opens the CAM Question dialog box where you can name the new 
D-Code.

Delete  button Removes the selected code from the D-Code list.

Augment  button Automatically generates D-codes for items in the schematic file 
that are not in the current list.

Regenerate  button Clears the current D-code list and automatically adds D-codes for 
all items in the schematic.

Shape area Specifies the shape for a selected D-code:
• Flash  — sets a flash aperture.

• Line  — set a draw aperture.

Same Aperture for Flashes/Lines Specifies to draw lines and flashed items with the same aperture. 
Round and square shapes for lines will be gray.

Width Specifies the diameter for round shapes. This box is unavailable if 
a width is not appropriate for the specified shape.

Aperture Count Specifies the maximum aperture count.
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Table  181. Photo Plotter Setup Dialog Box Contents  (continued)

Name Description

Augment on-the-fly Specifies to add apertures to the D-code list when photo plots are 
run if any newly created lines were added to the schematic.

Advanced  button Opens the Photo Plotter Advanced Setup Dialog Box.
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Pin Decal Browse Dialog Box
To access: Tools  > Part Editor  menu item > Decal Editing Toolbar  button> Add Terminal  or Change 
Pin Decal  button

Use the Pin Decal Browse dialog box to add or change a terminal. A terminal consists of a pin decal and 
a series of text strings that define the terminal's number, swap data, etc.

Figure 122. Pin Decal Browse Dialog Box

Objects
Table  182. Pin Decal Browse Dialog Box Contents

Name Description

Picture area Displays the selected pin.

Pins list Displays the available pins.

Related Topics
Adding Terminals

Modifying Terminals
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Pin Decal List Management Dialog Box
To access: Tools  > Part Editor  menu item > Setup  > Pin List Manger  menu item

Use the Pin Decal List Management dialog box to control which decals are displayed in the Pin Decal List. 
The pin decal list contains the decals that can be used as terminal graphics when creating gate or part 
decals.

Figure 123. Pin Decal List Management Dialog Box

Objects
Table  183. Pin Decal List Management Box Contents

Name Description

Library list Lists the libraries available to you.

Filter Searches the chosen library (or libraries) for a specific part or item 
name, or names that match a wildcard or expression  on page 105. 
Use the Library dropdown list to select specific library directories 
or the All Libraries setting. Type * to view all parts or items in the 
chosen libraries. Click Apply  to search the libraries and display the 
search results.

Preview Area Displays the pin decal highlighted in the Unassigned Decals area 
or the Pin Decals area.

Unassigned Decals list Lists the available pin decals in the selected library or all libraries.

Assign>>  button Moves a decal from the Unassigned Decals list box to the Pin 
Decals list. Select a decal, then click Assign.

<<Unassign  button Moves a decal from the Pin Decals list box to the Unassigned 
Decals list box. Select a decal, then click Unassign.
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Table  183. Pin Decal List Management Box Contents  (continued)

Name Description

Pin Decals list Lists the pin decals that are displayed in the dialog boxes that 
access pin decals, for example, the Pin Decal Browse dialog box. 
You can display up to 100 pin decals.
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Pin Label Fonts Dialog Box
To access: Select a pin > right-click > Properties  menu item > Font  button

Use the Pin Label Fonts dialog box to change the fonts of a pin label.

Figure 124. Pin Label Fonts Dialog Box

Objects
Table  184. Pin Label Fonts Dialog Box Contents

Name Description

Pin Area

Size Specifies the size of the font.
Size (pts):  This is font size in points and appears for system fonts
Size (mils):  This is font character height and appears for stroke 
fonts. The size refers to the height of the tallest characters.

Line Width Specifies the line width for stroke fonts only.

SailWind Logic Guide 669



SailWind Logic GUI Reference
Pin Label Fonts Dialog Box  

Table  184. Pin Label Fonts Dialog Box Contents  (continued)

Name Description

Font list The fonts available to you. This lists either stroke fonts or system 
fonts.
You choose which type of font to use in the Fonts Dialog Box.

 Tip
• Select stroke font or a system font.
• For system fonts, you can also click a font style button, or 

any combination of styles: B  for bold, I  for italic, or U  for 
underlined.

Justification area Specifies the horizontal (Right, Center, Left) justification and the 
vertical (Up, Center, Down) justification of the text.

Name Area

Size Specifies the size of the font.
Size (pts):  This is font size in points and appears for system fonts
Size (mils):  This is font character height and appears for stroke 
fonts. The size refers to the height of the tallest characters.

Line Width Specifies the line width for stroke fonts only.

Font list The fonts available to you. This lists either stroke fonts or system 
fonts.
You choose which type of font to use in the Fonts Dialog Box.

 Tip
• Select stroke font or a system font.
• For system fonts, you can also click a font style button, or 

any combination of styles: B  for bold, I  for italic, or U  for 
underlined.
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Pin Label Fonts Dialog Box

Table  184. Pin Label Fonts Dialog Box Contents  (continued)

Name Description

Justification area Specifies the horizontal (Right, Center, Left) justification and the 
vertical (Up, Center, Down) justification of the text.

Related Topics
Modifying Pin Label Fonts
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Pin Properties Dialog Box
To access: Select a pin > right-click > Properties  menu item

Use the Pin Properties dialog box to view pin information, to modify parts and nets to which the selected 
pin is connected, and also to set font settings for pin number and pin name labels.

Figure 125. Pin Properties Dialog Box

Objects
Table  185. Pin Properties Dialog Box Contents

Name Description

Pin area Displays the information about the selected pin: Pin number, 
name, swap number, type, and the net.

Part area Displays the information about the part: reference designator and 
gate number.

Part/Gate  button Opens the Part Properties Dialog Box.

Net  button Opens the Net Properties Dialog Box.

Font  button Opens the Pin Label Fonts Dialog Box.

Related Topics
Modifying Pins
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Plot Dialog Box
To access: File  > Plot  menu item

You can output your designs to pen plotters or photo plotters.

Figure 126. Plot Dialog Box

Objects
Table  186. Plot Dialog Box Contents

Name Description

Summary Lists the numbered available sheets you can plot, and the items 
contained in the sheets.

Plot What area Specifies what to plot: Pen or Photo.

File Prefix Specifies the prefix name of the file you want to plot.

Options  button Opens the Options dialog box  on page 606.

Setup  button Depending on what you are plotting, opens the Pen Plotter Setup 
Dialog Box  or the Photo Plotter Setup Dialog Box.

Preview  button Opens the Selections Preview Dialog Box.

Run  button Runs the Plot with what you’ve set.
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Print Dialog Box
To access: File  > Print  menu item

A standard Microsoft Print dialog box with access to Print Preview and Options.

Objects

Object Description

Preview  button Opens the “Selections Preview Dialog Box”  on 
page 714.

Options  button Opens the “Options Dialog Box - Print/Plot”  on 
page 606.

Project Explorer
To open the Project Explorer, click the Project Explorer  button.

The Project Explorer shows a hierarchical structure for the objects in your design. It provides access to 
objects and rules. When you update your design, the hierarchical structure is automatically updated to 
reflect the changes you make.
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Project Explorer

Tip
The Hierarchical structure is available only when a design is open.

Restriction:
The Project Explorer is not available in the Part Editor.

Object Types
Objects in the Project Explorer are placed in object groups. Object groups are of two types: primary and 
secondary as shown in the following table.

Restriction:
Observe the following restrictions:
• You cannot remove or rename primary object groups.
• Modification of secondary group items is only available in SailWind Router.

Table  187. Object Groups and Subgroups

Primary Group Product 
Availability Secondary Group Description

schematic sheets SailWind Logic Sheet names Lists all parts on the sheet

Electrical layers Lists all electrical layers, including 
plane layers and routing layers

Layers SailWind Layout
SailWind Router

General layers Lists all other layers except 
electrical

Components SailWind Logic
SailWind Layout
SailWind Router

Lists all components and pin pairs

Part decals SailWind Router Lists all part decals in the design 
or all components that use the 
selected part decal

Nets SailWind Logic
SailWind Layout

Lists all nets in the design

Net classes Lists all nets belonging to net 
classes

Matched length net groups Lists all matched length net 
groups

Net objects SailWind Router

Nets Lists all nets in the design
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Table  187. Object Groups and Subgroups  (continued)

Primary Group Product 
Availability Secondary Group Description

Matched length pin pair 
groups

Lists all matched length pin pair 
groups

Pin pair groups Lists all nets belonging to pin pair 
groups (containing pin pair rules)

Conditional rules Lists all nets with conditional rules

Differential pairs Lists all differential pairs

Via types SailWind Router Lists the via types used in the 
design

CAE decals SailWind Logic Lists the CAE decals used in the 
design

PCB decals SailWind Logic
SailWind Layout

Lists the PCB decals used in the 
design
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Query Hierarchical Component Dialog Box
To access: Select a hierarchical component > right-click > Properties  menu item

Use the Hierarchical Component Properties dialog box to assign a hierarchical component to the next 
available sheet number to make it accessible from the Sheet list when a sheet other than the parent sheet 
is displayed. Use the Setup  > Sheets  menu item to modify the sheet name or the numeric order.

Figure 127. Query Hierarchical Component Dialog Box

Objects
Table  188. Query Hierarchical Component Dialog Box Contents

Name Description

Name The name of the selected component.

Visibility Specifies to display the name on top of the hierarchical component 
in the schematic.

No The assigned sheet number of the selected component.

Visibility Specifies to display the sheet number in the schematic.

Numbered Specifies to assign the hierarchical component the next available 
sheet number.

UnNumbered Specifies to remove a sheet number assignment from a 
hierarchical component.

Related Topics
Modifying Hierarchical Components
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Reference Designator Properties Dialog Box
To access: Select a part type label > right-click > Properties  menu item

Use the Reference Designator Properties dialog box to view and modify label size and justification as well 
as text and font settings for one or more reference designator labels.

Figure 128. Reference Designator Properties Dialog Box

Objects
Table  189. Reference Designator Properties Dialog Box Contents

Name Description

Reference Designator The name of the selected attribute.

Rename area Specifies to rename just the gate or the entire part.

Rotation Specifies the rotation of the label: 0 or 90 degrees.

Size Specifies the size of the font.
Size (pts):  This is font size in points and appears for system fonts
Size (mils):  This is font character height and appears for stroke 
fonts. The size refers to the height of the tallest characters.
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Table  189. Reference Designator Properties Dialog Box Contents  (continued)

Name Description

Line Width Specifies the line width for stroke fonts only.

Font list The fonts available to you. This lists either stroke fonts or system 
fonts.
You choose which type of font to use in the Fonts Dialog Box.

 Tip
• Select stroke font or a system font.
• For system fonts, you can also click a font style button, or 

any combination of styles: B  for bold, I  for italic, or U  for 
underlined.

Horizontal/Vertical Justification Specifies the horizontal (Right, Center, Left) justification and the 
vertical (Up, Center, Down) justification of the text.

Related Topics
Modifying Reference Designator Labels
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Remap Special Symbols Dialog Box
To access: Tools > Update from Library  menu item; then, in the Update from Library dialog box, choose 
the “Update design from library” option and select the Off-page symbols, Ground symbols, or the Power 
symbols check box.

Use the Remap Special Symbols dialog box to make updates to power, ground, or off-page schematic 
symbols in your design. You can use this dialog box to update your schematic symbols with changes in 
the library or assign a different library symbol to a schematic symbol in the design.

Note:
The specific signal name assigned to special symbols currently used within the schematic are not 
modified when performing the “Update from Library” function. For example, the signal name of 
a power symbol assigned to +5V is not modified in the schematic if updated with another power 
symbol that uses a different default signal name (such as +12V).

Figure 129. The Remap Special Symbols Dialog Box

Objects
Table  190. The Remap Special Symbols Dialog Box Options

Name Description

Schematic Symbol Displays the name power, ground, or off-page 
symbols currently associated with your design.
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Remap Special Symbols Dialog Box

Table  190. The Remap Special Symbols Dialog Box Options  (continued)

Name Description

Pin Type Displays the function of the pin associated with the 
symbol; for example, load, ground, or power.

Default Signal Name Displays the name of the signal currently 
associated with the symbol (as it originally existed 
in the library); for example, +5VCC, or AGND.
This name does not necessarily reflect the signal 
name used on specific instances of the symbol in 
the schematic.

Library Symbol The symbol mapped to the schematic 
symbol. SailWind Layout initially displays the 
best-matching symbol in this box, regardless of the 
current mapping.
You can change the mapping by double-clicking 
in the box to access a dropdown list of available 
symbols. You can assign the same library symbol 
to more than one schematic symbol.
Only symbols associated with your current library 
appear in the list.
The available library symbols in the dropdown list 
also depends on the pin type. For example, if the 
pin type is “ground,” only ground symbols appear 
in the list.
Any additional symbols not specifically mapped to 
existing symbols become updated to the design 
and available for use.

Related Topics
The Update From Library Function

Updating Special Symbol Mappings
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Rename Gate Dialog Box
To access: select a part > right-click > Properties  menu item > Rename Gate  button

Use the Rename Gate dialog box to change the reference designator of the selected gate.

Figure 130. Rename Gate Dialog Box

Objects
Table  191. Rename Gate Dialog Box Contents

Name Description

Text box Type the new gate reference designator information.

 Restriction:
You are prevented from assigning an already used reference designator or an 
unused gate of a part with a different part type.
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Rename Part Dialog Box

Rename Part Dialog Box
To access: select a part > right-click > Properties  menu item > Rename Part  button

Use the Rename Part dialog box to change the reference designator for the selected part or gate.

Figure 131. Rename Part Dialog Box

Objects
Table  192. Rename Part Dialog Box Contents

Name Description

Text box Type the new part reference designator information.

 Restriction:
• All gates are renamed if you change the reference designator of one gate of 

a multi-gated part.
• You are prevented from assigning an already used reference designator.
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Renumber Pins Dialog Box
To access: Tools  > Part Editor  menu item > Edit Electrical  button > Pins  tab > select pin(s) > 
Renumber  button

Use the Renumber Pins dialog box to renumber pins (terminals). You can renumber part type pins on the 
Pins  tab of the Part Information dialog box.

Figure 132. Renumber Pins Dialog Box

Objects
Table  193. Renumber Pins Dialog Box Contents

Name Description

Number of pins The number of pins available for renumbering.

Prefix/Suffix For a single pin number, use either Prefix or Suffix box, and void 
the other box. Use both boxes if you want to increment one of the 
values.
Alphabetic and numeric values can be used in either box.

Pin numbers A preview of pin numbers based on your prefix/suffix input.

Increment prefix Sets the prefix as the part of the pin number to increment.

Increment suffix Sets the suffix as the part of the pin number to increment.

Step value Sets the step value. Type a positive or negative number by which 
to increase or decrease the pin number with consecutive or 
stepped values.
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Table  193. Renumber Pins Dialog Box Contents  (continued)

Name Description

 Restriction:
Step value must be non-zero and be in the range -10 to +10. 
Zero would replicate a single pin number and is not allowed.

Verify valid JEDEC pin numbering If using alphanumerics, you can select the Verify valid JEDEC pin 
numbering check box to ensure that legal alphanumeric values are 
used.
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Report Manager Dialog Box
To access: File  > Library  menu item > Parts  button > select a part > List to File  button

Use the Report Manager dialog box to generate a report about the parts in a library. You can specify the 
parts and the attributes to include in the report.

Figure 133. Report Manager Dialog Box

Objects
Table  194. Report Manager Dialog Box

Field or Button Description

Available attributes All attributes of the part types in the selected library.
Click an attribute in the list of select it. (To select additional attributes, press 
CTRL and click each attribute.) Click Include >>  to include selected attributes 
in the report.

Selected attributes Attributes in the report.
Click an attribute in the list of select it. (To select additional attributes, 
press CTRL and click each attribute.) Click << Exclude  to remove selected 
attributes from the report.
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Table  194. Report Manager Dialog Box  (continued)

Field or Button Description

The order of attributes in the list is the order of columns in the report. Select 
an attribute and click Up  or Down  to change the order.

Include >>  button Includes the selected attributes in the report (moves the attributes to the 
Selected attributes list). Select one or more attributes on the Available 
attributes list and click Include >>.

<< Exclude  button Excludes the selected attributes from the report (moves the attributes from 
the Selected attributes list back to the Available attributes list).
Select one or more attributes on the Selected attributes list and click << 
Exclude.

Up / Down  buttons Moves a selected attribute up or down on the Selected attributes list. List 
order determines the order in which columns appear in the report.

Part Filter Specifies the part types to include in the report.
Type a part type name in the field or use wildcards (*) to specify a group of 
part types. For example:
* Specifies all part types in the library.
+5* Specifies all part types that begin with the characters +5, such as +5volt 
and +5LS07.

Apply  button Filters the part types.

Parts Lists part types included in the report (as determined by the Part Filter).

Run  button Generates the report and lets you save it either in lst for viewing or printing or 
in csv format for use with MS Excel.

Close  button Cancels the operation and closes the dialog box.

Related Topics
Creating a Report of the Parts in a Library

Creating a Report of Decals, Lines or Logic Symbols in a Library
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Reports Dialog Box
To access: File  > Reports  menu item

Use the Reports dialog box to produce any of six different types of reports on the current schematic. You 
can save these reports as text files on your hard disk or output them to a printer.

Figure 134. Reports Dialog Box

Objects
Table  195. Reports Dialog Box Contents

Name Description

Select Report Files for Output area — Select the report(s) you want to run.

Unused The Unused report has two parts - the Unused Gate List, followed by the 
Unused Pins List. Use this report for troubleshooting and to maximize part 
usage.

• Unused Gate List  — lists all part types with multiple gates and if there are 
any unused gates, it lists the specific gate(s) under the part type name. If 
there are no unused gates then it only lists the part type name.

• Unused Pins List  — lists parts with pins unused in the schematic. It lists 
the unused pins under the part type name. If there are no unused pins there 
will be no part types listed.

When you run this report, a link to the UnusedGatesPins.rep  appears in the 
Output Window. Click the link to open the report in your default text editor.

Part Statistics The Part Statistics report lists information about all parts in the schematic. The 
report includes the reference designator name and part type for each part in 
the schematic, and for each pin on the part, the pin type, sheet location, and 
signal name. Use this report to locate possible errors in the schematic.
When you run this report, a link to the PartStatistics.rep  appears in the Output 
Window. Click the link to open the report in your default text editor.

Net Statistics The Net Statistics report lists information for each net in the schematic. The 
report includes the reference designator name and pin number for all parts in 
the net. SailWind Logic flags possible errors (for example, nets with no inputs 
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Table  195. Reports Dialog Box Contents  (continued)

Name Description
or no outputs, nets with multiple outputs, etc.) for further examination. Use this 
report to locate possible errors in the schematic.
Error messages that can occur:

• Net has only one pin: a net going to an off-page flag not connected 
elsewhere.

• Net has no defined source: there is no pin in the net that has a pin type of S.

• Net has no defined loads: there is no pin in the net that has a pin type of L.

• Net has multiple sources- be sure they are tieable: the net has more than 1 
pin with the pin type S.

When you run this report, a link to the NetStatistics.rep  appears in the Output 
Window. Click the link to open the report in your default text editor.

Limits The Limits report indicates the maximum number of each SailWind Logic data 
item (parts, nets, text) your system will allow, as well as the current count 
of each of these items in the schematic. This limit varies depending on the 
amount of virtual memory that is available.
The report has two parts. The first is a list of items whose limits are common to 
the entire schematic. The second is a count, for each schematic sheet, of the 
items whose limits apply for each sheet.
You should periodically run a Limits report to ensure that you are not 
approaching the system’s limit for any item.
If you exceed the Maximum No. of Items for any item, you cannot continue 
adding those items to the schematic. The solution is to split the design into 
multiple schematics, run separate netlists for each schematic, then merge the 
netlists using a text editor.
When you run this report, a link to the DesignLimits.rep  appears in the Output 
Window. Click the link to open the report in your default text editor.

Connectivity The Connectivity report lists the X,Y coordinate location and sheet number of 
all off-page, ground, and power symbols in the schematic.

 Tip
Use the report to quickly locate an off-page symbol using the S (Search) 
modeless command.

An error message appears when a net contains only one off-page reference. 
Subnets tied together without a visible net name are identified by flagging them 
as missing an off-page symbol.
When you run this report, a link to the ConnectivityReport.rep  appears in the 
Output Window. Click the link to open the report in your default text editor.

Bill of Materials The Bill of Materials report produces a user-configurable list of the parts 
contained in the current schematic. You can direct any part attribute in the 
schematic to a Bill of Materials report.
When you run this report, a link to the BillOfMaterials.rep  appears in the Output 
Window. Click the link to open the report in your default text editor.

Setup  button Opens the Bill of Materials Setup dialog box  on page 479. See also Setting up 
the Bill of Materials Report  on page 314.
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Related Topics
Generating Reports
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Routing Rules Dialog Box
To access:

• Setup  > Design Rules  menu item > a rule hierarchy button) > Routing  button

• Select a net, right-click and click Show Rules, then click the Routing  button.

Use the Routing Rules dialog box to specify rules for interactive and automatic routing. You can specify 
the default set of routing rules and routing rules for specific nets.

Figure 135. Routing Rules Dialog Box

Objects
Table  196. Routing Rules Dialog Box Contents

Name Description

Topology Type Specify the topology type to determine the pin-to-pin order when 
routing the net or moving a part. When routing interactively, a 
ratsnest guides you as you route from pin to pin.
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Table  196. Routing Rules Dialog Box Contents  (continued)

Name Description

To specify the topology type, click one of the following options:
• Protected  — Do not change the order of the connectivity in the 

net.

Note that this option disables length minimization.

• Minimized  — Order the net by the shortest distance between 
pins. Net reorder or reconnect is permitted.

• Serial source  — Order the net in a series order from source 
pins to load pins to a terminator.

• Parallel source  — Same as "Serial source" except order the 
net with parallel branches for each source-to-load connection.

• Mid-driven  — Divide the net into two branches and order each 
branch in a source to load to terminator order.

Routing options

Via Vias can share copper with another object. 

 Restriction:
This rule is used only in SailWind Router, although you can 
define this rule in SailWind Logic, SailWind Layout, or SailWind 
Router.
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Table  196. Routing Rules Dialog Box Contents  (continued)

Name Description

Trace Traces can share copper with another object. 

 Restriction:
This rule is used only in SailWind Router, although you can 
define this rule in SailWind Logic, SailWind Layout, or SailWind 
Router.

Priority Assign priority from 0 to 100. Nets with higher priority are routed 
first.

 Restriction:
SailWind Router does not use the priority value. This rule 
applies only to SPECCTRA.

Auto Route Enables the autorouter to route nets.

Allow Ripup Unroute existing traces and reroute the nets.

 Tip
Enable this option to rip up traces while DRC Warn or Prevent 
is enabled.

Allow Shove Move unprotected traces aside to create room for new traces.

 Tip
Enable this option to shove traces while DRC Warn or Prevent 
is enabled.

Allow Shove Protected Move protected traces aside to make room for new traces.

Layer biasing

Available Layers Lists layers, not already in the Selected Layers list, that can be 
made available for routing.
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Table  196. Routing Rules Dialog Box Contents  (continued)

Name Description

Add >>  button Click to move a selected layer from the Available Layers list to the 
Selected layers list.

<< Remove  button Click to move a selected layer from the Selected Layers list to the 
Available layers list.

Selected layers Lists the layers, that have been selected from all the available 
design layers, to be available for routing.

Vias

Use Vias already defined in PCB 
Layout design

Select the check box to suppress the via biasing in SailWind Logic.
Clear the check box to specify via biasing for routing.

 Tip
• If vias exist in SailWind Logic that don’t exist in SailWind 

Layout, you are prompted to create those vias before 
importing the netlist into SailWind Layout.

• Since there is no Pad Stacks Properties facility for creating 
vias in SailWind Logic you can only specify the names of via 
and you must create those vias in SailWind Layout.

• Since only Default, Net, and Class rules are available in 
SailWind Logic, any control of vias at higher levels of the 
rules hierarchy must be done in SailWind Layout.

Available vias Lists the vias, not already in the Selected Vias list that are 
available for routing.

Via Definition  button Click to open the Via Setup dialog box to Add, Delete, or Rename 
vias available for routing. Since there is no Pad Stacks Properties 
facility for creating vias in SailWind Logic, any vias added must be 
created in SailWind Layout before importing the netlist in SailWind 
Layout.

Add >>  button Click to move a selected via from the Available Vias list to the 
Selected Vias list.

<< Remove  button Click to move a selected via from the Selected Vias list to the 
Available Vias list.

Selected Vias Lists the vias, that have been selected from all the available vias, 
to be available for routing.

Maximum number of vias

Unlimited vias Click to give the autorouter unrestricted use of vias during 
autorouting.

Maximum of Click to restrict the number of vias the autorouter can add to nets 
during autorouting. In the box, type the maximum number of vias 
between 0 and 50000. The autorouter considers this to be a hard 
rule. Interactive routing and design verification check this rule.
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Table  196. Routing Rules Dialog Box Contents  (continued)

Name Description

 Tip
An insufficient maximum number of vias might increase 
autorouting runtime and reduce completion rates.

Delete  button Click to remove the current set of routing rules from the rules 
hierarchy for the selected nets.

 Restriction:
The Delete  button is unavailable for the default set of routing 
rules. You cannot delete the Default Routing rules.
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Rules Dialog Box
To access: Setup  > Design Rules  menu item

Use the Rules dialog box to enter item-to-item Clearance rules, routing guidelines, and values for the 
optional High Speed checking commands. You can also indicate the unit of measure for passing rules to 
SailWind Logic: mils, metric, or inches.

Figure 136. Rules Dialog Box

Objects
Table  197. Rules Dialog Box Contents

Name Description

Default  button Opens the Default Rules Dialog Box.

Class  button Opens the Class Rules Dialog Box.

Net  button Opens the Net Rules Dialog Box.

Conditional Rules  button Opens the Conditional Rule Setup Dialog Box.

Differential Pairs  button Opens the Differential Pairs Dialog Box.

Report  button Opens the Rules Report Dialog Box.

Units  button Specifies the units you want: Mils, Metric, or Inches
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Rules Report Dialog Box
To access: Setup  > Design Rules  menu item > Report  button

Use the Rules Report dialog box to produce a report of some or all of the rules you have defined. By 
default, a complete report of all rules is reported.

Figure 137. Rules Report Dialog Box

Objects
Table  198. Rules Report Dialog Box Contents

Name Description

Rule Types area Displays the specified rules for the specified nets and classes. 
Click any combination of buttons, including Differential Pairs, to 
report net pairs.

Nets area Displays the specified rules for every net or selected nets. Click All 
Nets or select specific nets in the list box.

Classes area Displays the specified rules for every class or selected classes. 
Click All Classes or select specific net classes in the list box.

Default Rules Displays the default rules for the specified nets and classes.

Output area Specifies how you want your output.
• Rule Sets  — display all rules in the current hierarchy that are 

unique from the default rules.

• Rule Values  — display all rules in the current hierarchy level, 
even if the values are the same as the default rules.
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Related Topics
Creating a Rules Report
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Save CAE Decal to Library Dialog Box
To access: File  > Library  menu item > select a library > Logic  filter type > select a CAE decal > Copy 
button

Use the Save CAE Decal to Library dialog box to copy a CAE decal to another name or another library.

Figure 138. Save CAE Decal to Library Dialog Box

Objects
Table  199. Save CAE Decal to Library Dialog Box Content

Name Description

Library Select the library for the copied CAE decal.

Name of CAE Decal Type the name for the copied CAE decal.

Related Topics
Copying a Library Item
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Save Configuration Dialog Box
To access: Setup  > Display Colors  menu item > Save  button

Use the Save Configuration dialog box to save the color assignments and settings you’ve made in the 
Display Colors dialog box.

Figure 139. Save (color) configuration Dialog Box

Objects
Table  200. Save configuration Dialog Box Content

Name Description

Text box Type the name of the new color configuration. The name will appear in the 
Configuration list in the Display Colors Dialog Box.
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Save Drafting Item to Library Dialog Box
To access: Select an item > right-click > Save to Library  menu item

Use the Save Drafting Item to Library dialog box save 2D line items or complex 2D line item in the 
schematic to a library.

Figure 140. Save Drafting Item to Library Dialog Box

Objects
Table  201. Save Drafting Item to Library Dialog Box Contents

Name Description

Library list Specifies the library you to which you want to save the item.

Name of Item The name of the item you want to save in the selected library.

Related Topics
Adding Drafting Items to a Library
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Save Off-Page to Library Dialog Box
To access: Tools  > Save Off-page to Library  menu item

Use Save Off-page to Library to update the off-page, ground, or power symbols in the library with the 
current version(s) in the schematic.

Figure 141. Save Off-page to Library Dialog Box

Objects
Table  202. Save Off-page to Library Dialog Box Contents

Name Description

Item Type area Specifies the item you want to update in the library with the current 
version in the schematic.

Related Topics
Saving Off-Page to Library
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Save Part and Gate Decals As Dialog Box
To access: Tools  > Part Editor  menu item > (in the Part Editor) File  > Save as  menu item

The Save Part and Gate Decals As dialog box saves a new or modified part type to the library. You can 
also rename a modified decal to prevent other parts that use the same decal from being affected.

Figure 142. Save Part and Gate Decals As Dialog Box

Objects
Table  203. Save Part and Gate Decals As Dialog Box Contents

Name Description

Name of Part Defines the part type name in the library.

Library The library folder to which information is saved.

Name of Gate Decals Displays the name of decal and any alternate decals associated 
with the part type. Select a decal name and click Edit  to rename 
the decal.

Edit  button Makes the highlighted field in the table editable. You can also 
double click a text field to edit it.

Related Topics
Saving Part Types

SailWind Logic Guide 703



SailWind Logic GUI Reference
Save Part Types to Library Dialog Box  

Save Part Types to Library Dialog Box
To access: Select a part > right-click > Save to Library  menu item

Use the Save Part Types to Library dialog box to copy the part types of the schematic. If the original part 
type is deleted from the library, get another copy from the schematic.

Figure 143. Save Part Types to Library Dialog Box

Objects
Table  204. Save Part Types to Library Dialog Box Contents

Name Description

Part Types list The part(s) you selected in the schematic.

Select All  button Selects all of the items in the Part Types list.

Select Not in Lib  button Selects only those part types that are not currently saved in the 
library.

Unselect All  button Clears the selection of any or all part types in the Part Types list.

Library list Specifies the library you to which you want to save the part types.

Related Topics
Saving Part Types to a Library
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Save Part Type to Library Dialog Box
To access: File  > Library  menu item > select a library > Parts  filter type > select a part type > Copy 
button

Use the Save Part Type to Library dialog box to copy a Part Type to another name or another library.

Figure 144. Save Part Type to Library Dialog Box

Objects
Table  205. Save Part Type to Library Dialog Box Content

Name Description

Library Select the library for the copied part type.

Name of Part Type Type the name for the copied Part Type.

Related Topics
Copying a Library Item
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Save PCB Decal to Library Dialog Box
To access: File  > Library  menu item > select a library > Decal  filter type > select a PCB decal > Copy 
button

Use the Save PCB Decal to Library dialog box to copy a PCB decal to another name or another library.

Figure 145. Save PCB Decal to Library Dialog Box

Objects
Table  206. Save PCB Decal to Library Dialog Box Content

Name Description

Library Select the library for the copied PCB decal.

Name of PCB Decal Type the name for the copied PCB decal.

Related Topics
Copying a Library Item
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Save View Dialog Box
To access: View  > Save View  menu item

The Save View dialog box to save a work area view for easy restoration.

Figure 146. Save View Dialog Box

Objects
Table  207. Save View Dialog Box Contents

Name Description

View Name list The views you have already saved.

Preview area Shows you the location of the selected view in relation to the 
extents of the design.

Capture  button Opens the Capture a New View Dialog Box  where you can name 
the view you want to save.

 Tip
You can create up to nine views. The view names appear at the 
bottom of the View  menu.

Apply  button Applies the selected, previously saved view to the work area.

Delete  button Removes the selected view from the View Name list.

Related Topics
Saving and Restoring Views
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Select Gate Decal Dialog Box
To access: Tools  > Part Editor  menu item > open a part type > Edit Graphics  button

Use the Select Gate Decal dialog box to select the gate decal you want to use.

Figure 147. Select Gate Decal Dialog Box

Objects
Table  208. Sheets Decal Dialog Box Contents

Name Description

Gate list Lists the gates available to you.

Decal Displays the decal assigned to the selected gate.

Alternative Decals list Lists the alternative decals available.

Related Topics
Assigning Pin Information to the CAE Decal
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Select Pin Decal Dialog Box
To access: Tools  > Part Editor  menu item > open an Off-page type (Off-page, Power, or Ground) > Edit 
Graphics  button

Use the Select Pin Decal dialog box to access and create graphics for a new Special Symbol. This dialog 
box is displayed when you use the Extended Selection command from the popup menu to edit a gate for 
a Special Symbol.

Figure 148. Select Pin Decal Dialog Box

Objects
Table  209. Select Pin Decal Dialog Box Contents

Name Description

Pin Decal list Lists the Pin Decals available to you.

Related Topics
Creating New Special Symbols
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Select Type of Editing Item Dialog Box
To access: Tools  > Part Editor  menu item > New  or Open  button

Use the Select type of editing item dialog box to select the type of library item to create or modify.

Figure 149. Select Type of Editing Item Dialog Box

Objects
Table  210. Select Type of Editing Item Dialog Box Contents

Name Description

Part Type Click Part Type to create or modify an existing part.

Connector Click Connector to create or modify a connector.

CAE Decal Click CAE Decal to create or modify a new CAE decal.

Pin Decal Click Pin Decal to create or modify a pin decal, the information and 
appearance of a terminal pin. A number of different pin decals are 
provided.

Off-page Click Off-page to modify the off-page reference symbols. SailWind 
Logic allows only one part definition in the library for off-page 
reference symbols, so this option grays when you select the File 
> New  menu item. You can modify the existing symbols or add 
new symbols. Refer to the Special Symbols  on page 167 topic for 
additional information.

Power Click Power to modify an existing off-page reference symbol. 
SailWind Logic allows only one part definition in the library for 
power symbols, so this option grays when you select the File 
> New  menu item. You can modify the existing symbols or add 
new symbols. Refer to the Special Symbols  on page 167 topic for 
additional information.

Ground Click Ground to modify an existing off-page reference symbol. 
SailWind Logic allows only one part definition in the library for 
ground symbols, so this option grays when you click the File  > 
New  menu item. You can modify the existing symbols or add new 
symbols. Refer to the Special Symbols  on page 167 topic for 
additional information.
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Related Topics
Getting Gate Decals From the Library
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Selection Filter Dialog Box
To access:

• Edit  > Filter  menu item

• With nothing selected, right-click > Filter  menu item

Use the Selection Filter to specify which objects you can select. Select a check box to enable the object 
for selection or clear the check box to disable the object for selection.

Figure 150. Selection Filter Dialog Box

Objects
Table  211. Selection Filter Dialog Box Contents

Name Description

Design Items Specifies the design items you want to be able to select in the 
design.

Drafting Items Specifies the design items you want to be able to select in the 
design.

Anything  button Specifies that you want to select anything in the design.
Exception:  Clusters, unions, stitching vias, pin pairs, nets, and 
board outline shapes are not selected.

Nothing  button Specifies that you don’t want to select anything in the design.
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Selection Filter Dialog Box

Related Topics
Using the Selection Filter
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Selections Preview Dialog Box
To access:

• File  > Plot  menu item > Preview  button

• File  > Print  menu item > Preview  button

Use the Selections Preview dialog box to preview your options and output.

Figure 151. Selections Preview Dialog Box

Objects
Table  212. Selections Preview Dialog Box

Name Description

Sheet  button Displays the entire sheet in the window.

Extents  button Zooms to the extents on the sheet.

Selected Sheets list Specifies the sheet you want to preview.
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Table  212. Selections Preview Dialog Box  (continued)

Name Description

Options  button Opens the Options dialog box  on page 606.

Plot/Print  button Sends the output to the printer or plotter.

Preview area Graphically shows what you will print or plot.
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Server Busy Dialog Box
To access: There is no sure way to access this dialog box, but it may appear when you attempt to connect 
with one of the other SailWind software applications, for example, when you click one of the buttons in the 
Connect to SailWind Layout Dialog Box.

The Server Busy dialog box appears when you are launching another application from SailWind Logic 
and for some reason, the other application is slow to respond.

Figure 152. Server Busy Dialog Box

Objects
Table  213. Server Busy Dialog Box Contents

Name Description

Switch To  button Switches to the application being launched. This is typically required when 
a prompt window in the other application is waiting for your input before 
you can connect to it with SailWind Logic.

Retry  button Attempts to connect to the other application again. This is typically required 
when there has been a delay in launching the other application.

 Tip
Wait until you see the application appear in your Windows Taskbar 
then click Retry.
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Sheets Dialog Box
To access: Setup  > Sheets  menu item

Use the Sheets dialog box to edit the sheet set of the current schematic in the work area. Using Sheets 
enables you to add and delete sheets from the set and to modify sheet names and the numeric order of 
the set. You can create up to 1024 sheets.

Objects
Table  214. Sheets Dialog Box Contents

Name Description

Numbered Sheets table • Name  — Type a name for the schematic sheet.

• RefDes Start Value  — The minimum number to use for 
reference designators of new components or copied/pasted 
components. The first available number equal to or greater than 
this value is used.

The RefDes Start Value stays with the sheet if the order 
of sheets is changed. For more information, see “Setting 
Reference Designators by Sheet in a New Schematic”  on 
page 281

Bottom up hierarchy sheets are displayed but Top down hierarchy 
sheets are not displayed. If you need to renumber reference 
designators on a Top down sheet, see “Automatically Renumbering 
Reference Designators”  on page 280.
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Table  214. Sheets Dialog Box Contents  (continued)

Name Description

View  button Specifies to show the selected sheet in the view area.

Up/Down  buttons Moves the selected sheet up or down in the table.

 Tip
The sheet value changes as you move it up or down.

Rename  button Makes the selected cell available for editing.

 Tip
Spaces are not valid characters in a sheet name.

Add  button Adds a new sheet as a row to the bottom of the table.

Delete  button Removes the selected sheet.

Related Topics
Editing Sheets
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Signal Pin Nets Dialog Box
To access:

• Edit  > Select Signal Pin Nets  menu item

• With nothing selected > right-click > Select Signal Pin Nets  menu item

Use the Signal Pin Nets dialog box to help you find and select specific signal pins in the schematic.

Figure 153. Signal Pin Nets Dialog Box

Objects
Table  215. Signal Pin Nets Dialog Box Contents

Name Description

Select Nets list Selecting nets in this list box selects signal pin nets within the 
schematic across all components and sheets. Using the right-click 
menu, you can perform object mode commands on the selected 
signal pin nets.

Refresh  button Updates the list of signal pin nets (in the Select Nets list box) to 
include any recently created signal pin nets. For example, when 
you add part 7400 to an empty design, you create two signal pin 
nets: GND and +5V. Selecting Refresh  includes the new signal pin 
nets in the Select Nets list box.
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Simulation Setup Dialog Box
To access: Tools  > SPICE Netlist  menu item > Simulation Setup  button

After you add parts (with SPICE attributes) to your schematic, or add SPICE attributes to existing parts, 
you can create a SPICE netlist in preparation for simulation.

Figure 154. Simulation Setup Dialog Box

Objects
Table  216. Simulation Setup Dialog Box Contents

Name Description

AC Analysis  button Opens the AC Analysis Dialog Box.

DC Sweep  button Opens the DC Source Sweep Analysis Dialog Box.

Transient  button Opens the Transient Analysis Dialog Box.

Operating Point Directs the SPICE simulator to determine the DC operating point of 
the circuit.

Related Topics
Creating a SPICE Netlist
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SPICEnet Dialog Box
To access: Tools  > SPICE Netlist  menu item

After you add parts (with SPICE attributes) to your schematic, or add SPICE attributes to existing parts, 
you can create a SPICE netlist in preparation for simulation.

Figure 155. SPICEnet Dialog Box

Objects
Table  217. SPICEnet Dialog Box Contents

Name Description

Output File Name Specifies the path and name of the SPICE netlist file.

 Tip
Type the path or use the Browse  button to search for a path.

Select Sheets list Specifies the sheets to include in the SPICE netlist.

Select All  button Specifies to select all sheets in the Select Sheets list.

Unselect All  button Specifies to clear all the selected sheets in the Select Sheets list.

Simulation Setup  button Opens the Simulation Setup Dialog Box.

Include Subsheets Specifies to include any underlying hierarchy if the design is 
hierarchical.

Output Formats list Specifies the target SPICE software.

Related Topics
Creating a SPICE Netlist
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Step and Repeat Dialog Box
To access: Select an object during an add or duplicate operation > right-click > Step and Repeat  menu 
item. When adding a new object in the Schematic Editor, you must place the first object manually before 
you can use Step and Repeat.

Use Step and Repeat to multiply objects as you place them during an add or duplicate operation. Step 
and Repeat is available in the Schematic Editor and the Decal Editor. In the Schematic Editor the Step 
and Repeat command copies parts, connections, text, or drafting items. In the Decal Editor the Step and 
Repeat command copies terminals, text, or drafting items.

Figure 156. Step and Repeat Dialog Box

Objects
Table  218. Step and Repeat Dialog Box Contents

Name Description

Direction Specifies the direction of placement for the array.

Count Specifies the number of objects to place.

Distance Specifies the distance between objects.

 Tip
If you place a second object and then Step and Repeat, the 
spacing between the objects will become the default value in 
the Distance box and will repeat the pattern you've started.

Preview  button Displays the placement of the multiple objects based on the 
options you set. The placement of the objects is based on the 
location of the original object selected.

 Tip
Zoom Mode is available during Step and Repeat.

Related Topics
Step and Repeat
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Text Properties Dialog Box
To access: Select text > right-click > Properties  menu item

Use the Text Properties dialog box to edit the properties of free text in the design.

Figure 157. Text Properties Dialog Box

Objects
Table  219. Text Properties Dialog Box Contents

Name Description

Text Specifies the text that you are editing.

X/Y Type coordinates to place the text in a specified location. Negative 
coordinates are not permitted. If you want to place text outside the 
sheet, you must move it there with the cursor.

Rotation Specifies the rotation of the text: 0 or 90 degrees.

Line Width Specifies the line width for stroke fonts only.
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Table  219. Text Properties Dialog Box Contents  (continued)

Name Description

Size Specifies the size of the font.
Size (pts):  This is font size in points and appears for system fonts
Size (mils):  This is font character height and appears for stroke 
fonts. The size refers to the height of the tallest characters.

Font Style Enables you to change the font style to bold, italic, and underlined.

 Restriction:
System fonts only.

Font list The fonts available to you. This lists either stroke fonts or system 
fonts.
You choose which type of font to use in the Fonts Dialog Box.

 Tip
• Select stroke font or a system font.
• For system fonts, you can also click a font style button, or 

any combination of styles: B  for bold, I  for italic, or U  for 
underlined.

Horizontal/Vertical Justification Specifies the horizontal (Right, Center, Left) justification and the 
vertical (Up, Center, Down) justification of the text.

Parent  button Opens the Drafting Properties Dialog Box.

 Restriction:
Available only if the text had been combined with a drafting 
object.

Related Topics
Modifying Text

Add Free Text Dialog Box
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Transient Analysis Dialog Box
To access: Tools  > SPICE Netlist  menu item > Simulation Setup  button> Transient  button

Use the Transient Analysis dialog box to set options specifically for a Transient analysis.

Figure 158. Transient Analysis Dialog Box

Objects
Table  220. Transient Analysis Dialog Box Contents

Name Description

Data Step Time Specifies the increment for the analysis.

Total Analysis Time Specifies the time to end the analysis.

Time to Start Recording Data Specifies the time to start recording data from the analysis.

 Tip
Use this if your simulation files become too large and you are 
not interested in data from the beginning of the analysis.

Maximum Time Step Specifies the maximum time step value.

Use Initial Conditions (UIC) Specifies to use SPICE to solve for the quiescent operating 
point before beginning the transient analysis. SPICE uses the 
values specified using IC=... on the various elements as the initial 
transient condition and proceeds with the analysis.

Related Topics
Creating a SPICE Netlist

Setting Up Transient Analysis
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Update From Library Dialog Box
To access: Tools  > Update from Library  menu item

Use the Update from Library dialog box to update a schematic from the library, or to compare items in a 
schematic with those in the library.

Figure 159. Update From Library Dialog Box

Objects
Table  221. Update From Library Dialog Box Controls

Control Description

Mode area  — Choose compare or update mode.

Generate comparison report Select this check box to compare library and 
schematic items and generate a report file.
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Table  221. Update From Library Dialog Box Controls  (continued)

Control Description

Update design from library Select this check box to compare library and 
schematic items, update the schematic from the 
library, and generate a report file.

Include items with identical time stamp Timestamps are assigned and updated in the 
SailWind Logic Library routines, but it is possible 
for items with identical timestamps to have 
different content in the library and schematic if the 
item is edited outside the Library routines.
For example, if you export a schematic to an 
ASCII file, manually edit a part type in the ASCII 
file, and import the schematic back into SailWind 
Logic, the timestamp of the part type will be 
unchanged, but the content will be different.
Use this check box to specify whether to 
compare/update items whose timestamps are the 
same in the library and schematic.
Items with identical timestamps are not  compared 
or updated unless this check box is selected.

Report Filtering area  — Specify what you want to see in the report.

Summary and details
Summary only
Hide identical results

Select Summary and details or Summary only.
Select Hide identical results to see only the 
differences between library and design items in the 
report.

Items area  — Specify the items you want to compare or update.

Part types and attributes Select this check box to include part types and 
their attributes in the comparison or update.

 Tip
• Attributes don’t have timestamps, so they 

can’t be updated independently of their part 
types.

• If a schematic attribute’s corresponding 
attribute in the library is a placeholder 
attribute (with a blank value), it will be 
updated only if the “Allow overwriting of 
attribute values in design with blank values 
from library” check box in the Options 
Dialog Box, Design Category.

Preserve design attributes not found in library Use this check box to specify what you want to do 
with attributes that are found in the schematic but 
not in the library:

• Select the check box to keep these attributes in 
the updated parts.

• Clear it to remove them from the updated parts.
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Table  221. Update From Library Dialog Box Controls  (continued)

Control Description

Add new attributes not found in design Use this check box to specify what you want to do 
with attributes that are found in the library but not 
in the schematic.

• Select the check box to add these attributes to 
the updated parts.

• Clear it to not add them to the updated parts.

Update common attributes Use this check box to specify what you want to do 
with attributes that are found in both the schematic 
and the library.

• Select the check box to update the parts with 
the library versions.

• Clear it to leave the part attributes as they are 
(that is, do not update them).

Preserve design attribute properties
Visibility
Label location
Label properties

Select the attribute properties you want to 
preserve in the schematic when updating the 
attributes from the library.

CAE Decals Select this check box to include CAE decals in the 
comparison/update.

• If you want to update CAE decal assignments 
in the part types, you must also select Part 
types and attributes.

• Pin decals are updated as part of a CAE decal 
update, so when this check box is selected, Pin 
Decals is automatically selected also.

Pin Decals Select this check box to include pin decals in the 
comparison/update.

 Tip
• Only the decal is updated; pin names and 

numbers are not changed.
• Pin decals are updated as part of a CAE 

decal update, so when CAE Decals is 
selected, this check box is automatically 
selected and unavailable.

Select Pins Decals List This list is populated with check boxes 
representing each of the pins available for 
comparison or update. Enable the check box for 
each of the pins you want to compare or update.
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Table  221. Update From Library Dialog Box Controls  (continued)

Control Description

 Tip
Because all  pin decals are compared/updated 
as part of a CAE decal update, these check 
boxes are unavailable and ignored when CAE 
Decals is selected.

Off-page symbols Select this check box to include off-page symbols 
in the comparison/update. Selecting this check box 
opens the Remap Special Symbols Dialog Box.

 Restriction:
The off-page symbol update will fail if there is 
not at least one off-page symbol in the current 
schematic.

Ground symbols Select this check box to include ground symbols in 
the comparison/update. Selecting this check box 
opens the Update From Library Dialog Box.

 Restriction:
The ground symbol update will fail if there is 
not at least one ground symbol in the current 
schematic.

Power symbols Select this check box to include power symbols in 
the comparison/update. Selecting this check box 
opens the Update From Library Dialog Box.

 Restriction:
The power symbol update will fail if there is 
not at least one power symbol in the current 
schematic.

Related Topics
The Update From Library Function

How to Read the Update Report

The Compare/Update Process

Updating a Schematic From the Library
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Update Selected CAE Decals From Library 
Dialog Box
To access: Select a part > Right-click > Update  > CAE Decal  menu item

Use the Update Selected CAE Decals from Library dialog box to update selected CAE decals in a 
schematic from the library. All instances of the selected CAE decals are updated.

Figure 160. Update Selected CAE Decals From Library Dialog Box

Objects
Table  222. Update Selected CAE Decals From Library Dialog Box Controls

Control Description

Mode area  — Choose compare or update mode.

Generate comparison report Select this check box to compare library and 
design CAE decals and generate a report file.

Update design from library Select this check box to compare library and 
schematic CAE decals, update the schematic from 
the library, and generate a report file
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Table  222. Update Selected CAE Decals From Library Dialog Box Controls  (continued)

Control Description

 Tip
• This procedure updates the pin 

assignments in the selected CAE decals, 
but doesn’t update the pin decals 
themselves. Use one of the procedures 
in Updating Selected Pin Decals From 
the Library  to update the pin decals’ 
geometries.

• As a corollary, if, for instance, CAE decal 
X is updated to use PINB instead of PINA, 
it uses the version of PINB geometry 
currently in the schematic. If there is no 
PINB in the schematic, it is installed from 
the library.

Include items with identical time stamp Timestamps are assigned and updated in the 
SailWind Logic Library routines, but it is possible 
for items with identical timestamps to have 
different content in the library and schematic if the 
item is edited outside the Library routines.
For example, if you export a schematic to an 
ASCII file, manually edit a CAE decal in the 
ASCII file, and import the schematic back into 
SailWind Logic, the timestamp of the decal will be 
unchanged, but the content will be different.
Use this check box to specify whether to 
compare/update items whose timestamps are the 
same in the library and schematic.
Items with identical timestamps are not  compared 
or updated unless this check box is selected.

Select CAE Decals Area  — Specify which CAE decals to update.

Select CAE Decals List This list is populated with check boxes 
representing each of the selected CAE decals. 
Enable the check box for each of the CAE decals 
that you would like to update.

Report Filtering area  — Specify what you want to see in the report.

Summary and details
Summary only
Hide identical results

Select Summary and details or Summary only.
Select Hide identical results to see only the 
differences between library and schematic items in 
the report. This will shorten the report.

Related Topics
The Update From Library Function

How to Read the Update Report
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The Compare/Update Process

Updating Selected CAE Decals From the Library
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Update Selected Part Type From Library 
Dialog Box
To access: In the Schematic Editor, select the part types you want to compare/update. Right-click > 
Update  > Part Type  menu item

Use the Update Selected Part Type from Library dialog box to update selected parts in a schematic from 
the library, or to compare selected parts in a schematic with those in the library.

Objects
Table  223. Update Selected Part Type From Library Dialog Box Controls

Control Description

Mode area  — Choose compare or update mode.

Generate comparison report Select this check box to compare library and 
schematic part types and generate a report file.
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Table  223. Update Selected Part Type From Library Dialog Box Controls  (continued)

Control Description

Update design from library Select this check box to compare library and 
schematic part types, update the schematic from 
the library, and generate a report file.

 Restriction:
All parts having the same part type as a 
selected part are updated, but attributes are 
updated only for the parts actually selected.

Include items with identical time stamp Timestamps are assigned and updated in the 
SailWind Logic Library routines, but it is possible 
for items with identical timestamps to have 
different content in the library and schematic if the 
item is edited outside the Library routines.
For example, if you export a schematic to an 
ASCII file, manually edit a part type in the ASCII 
file, and import the schematic back into SailWind 
Logic, the timestamp of the part type will be 
unchanged, but the content will be different.
Use this check box to specify whether to 
compare/update items whose timestamps are the 
same in the library and schematic.
Items with identical timestamps are not  compared 
or updated unless this check box is selected.

Report Filtering area  — Specify what you want to see in the report.

Summary and details
Summary only
Hide identical results

Select Summary and details or Summary only.
Select Hide identical results to see only the 
differences between library and design items in the 
report. This will shorten the report.

Items area  — Specify the items you want to compare or update.

Part types and attributes Make sure that this check box is selected.

 Tip
• Attributes don’t have timestamps, so they 

can’t be updated independently of their part 
types.

• If a schematic attribute’s corresponding 
attribute in the library is a placeholder 
attribute (with a blank value), it will be 
updated only if the Allow overwriting of 
attribute values in design with blank values 
from library check box in the Options Dialog 
Box, Design Category.

Preserve design attributes not found in library Use this check box to specify what you want to do 
with attributes that are found in the schematic but 
not in the library:

• Select the check box to keep these attributes in 
the updated parts.
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Table  223. Update Selected Part Type From Library Dialog Box Controls  (continued)

Control Description

• Clear it to remove them from the updated parts.

Add new attributes not found in design Use this check box to specify what you want to do 
with attributes that are found in the library but not 
in the schematic.

• Select the check box to add these attributes to 
the updated parts.

• Clear it to not add them to the updated parts.

Update common attributes Use this check box to specify what you want to do 
with attributes that are found in both the schematic 
and the library.

• Select the check box to update the parts with 
the library versions.

• Clear it to leave the part attributes as they are 
(that is, do not update them).

Preserve design attribute properties
Visibility
Label location
Label properties

Select the attribute properties you want to 
preserve in the schematic when updating the 
attributes from the library.

Select Part Types Area  — Specify which part types to update.

Select part types list This list is populated with check boxes 
representing each of the selected part types. 
Enable the check box for each of the part types 
that you would like to update.

Related Topics
The Update From Library Function

How to Read the Update Report

The Compare/Update Process

Updating Selected Part Types From the Library
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Update Selected Pin Decals From Library 
Dialog Box
To access: Select a pin > Right-click > Update Pin Decal  menu item

Use the Update Selected Pin Decal from Library dialog box to update selected pin decals from the library, 
or to compare selected pin decals in a schematic with those in the library. All instances of the selected pin 
decals are updated.

Figure 161. Update Selected Pin Decals From Library Dialog Box

Objects
Table  224. Update Selected Pin Decals From Library Dialog Box Controls

Control Description

Mode area  — Choose compare or update mode.

Generate comparison report Select this check box to compare library and 
schematic pin decals and generate a report file.

Update design from library Select this check box to compare library and 
schematic pin decals, update the schematic from 
the library, and generate a report file.

Include items with identical time stamp Timestamps are assigned and updated in the 
SailWind Logic Library routines, but it is possible 
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Table  224. Update Selected Pin Decals From Library Dialog Box Controls  (continued)

Control Description
for items with identical timestamps to have 
different content in the library and schematic if the 
item is edited outside the Library routines.
For example, if you export a schematic to an 
ASCII file, manually edit a pin decal in the 
ASCII file, and import the schematic back into 
SailWind Logic, the timestamp of the decal will be 
unchanged, but the content will be different.
Use this check box to specify whether to 
compare/update items whose timestamps are the 
same in the library and schematic.
Items with identical timestamps are not  compared 
or updated unless this check box is selected.

Select Pin Decals Area  — Specify which pin decals to update.

Select Pin Decals List This list is populated with check boxes 
representing each of the selected pin decals. 
Enable the check box for each of the pin decals 
that you would like to update.

Report Filtering area  — Specify what you want to see in the report.

Summary and details
Summary only
Hide identical results

Select Summary and details or Summary only.
Select Hide identical results to see only the 
differences between library and schematic items in 
the report. This will shorten the report.

Related Topics
The Update From Library Function

How to Read the Update Report

The Compare/Update Process

Updating Selected Pin Decals From the Library
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Glossary
absolute coordinates

Coordinates of a location based upon their distance from the origin (coordinates 0,0) of the design 
area.

accelerator keys
Key sequences used to invoke commands and change system settings without using the mouse. 
Accelerator keys are called shortcut keys in the SailWind product documentation.

accessible nets
Nets for which you can define test points. DFT Audit analyzes all nets. If DFT Audit determines that 
test probes can access them, the nets are accessible (also called adaptable).

accordion
A trace pattern resembling a signal wave that adds length to traces. The trace patterns are 
contiguous and do not include layer changes.

accordion gap
The gap of an accordion sets the pitch between chords. The gap is a user-definable number 
multiplied by the same net trace-to-corner clearance.

If the same-net trace-to-corner distance equals zero, then Trace Width is used for the gap 
calculation.

See also accordion, amplitude, pair routing gap
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acid trap
An acid trap is a location where acid gets trapped in an area due to the surface tension of the 
etching. This acid causes over-etching, which hurts yield.

active component
The active substituted component in an assembly variant. Active means that this substitution of the 
component is used in the current variant.

See also default.asc

active layer
The design layer to which new information is added. You select the active layer by choosing the 
layer in the Layer list on the Standard Toolbar. You can also do this by using the L modeless 
command.

ACTM#
The 16-digit number found on your security key.

adaptable nets
See accessible nets

adhesive
A substance used to attach the bodies of devices to a PC board.

aggressor nets
When using the Electrodynamic Checking program (EDC), a net or pin pair that is considered a 
source of interference.

align
To reposition placed parts to match the alignment of another part.

alignment tool
A small, temporary marker at each location where dimensioning occurs.

alpha pins
Pins with descriptive letters that are substituted for pin numbers. For example, GND for the ground 
pin. Alphanumeric pin assignments are made in the Library Manager's part type editor.

alphanumeric pins
Pins with alphanumeric pin numbers. An alphanumeric name consists of a prefix and suffix. The 
prefix or the suffix can contain either alpha letters or numeric numbers. For example, A1, 1A, or 
even DATA07 (consists of the prefix “DATA” and the suffix “07”).

amplitude
The amplitude of an accordion sets the accordion height (for horizontal accordions) or accordion 
width (for vertical accordions). The amplitude is a user-definable number, multiplied by the same net 
trace-to-corner clearance.
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analog board

If the same-net trace-to-corner distance equals zero, then Trace Width is used for the amplitude 
calculation.

See also accordion, gap (accordion)

analog board
A board with mostly discrete components and minimal integrated circuits.

analog circuit
A design composed of discrete components such as capacitors, resistors, and diodes.

angstrom
1/10,000 of a micrometer (10-4um).

annotation (forward and backward)
Forward annotation refers to the process of updating the design file to match the schematic file. 
Backward annotation refers to updating the schematic file to match the design file.

annular pad
A pad shape that enables you to specify an inside and an outside diameter. This creates a donut 
shape because the inner hole was used to center the drill bit when boards were hand-drilled on a 
drill press. Though obsolete, the annular pad is still offered for special circumstances.

annular ring
The conductive pad material surrounding the hole. The annular ring radius = pad diameter-(finished 
hole size) / 2.

antipad
For plane layers, a slightly oversized pad diameter that plots as a clearance for through-hole pins 
that should not connect to the plane.

any-angle coupling trace
Part of a route that connects SBP fanouts to serpentine routes.

aperture
A uniquely shaped window or hole that is attached to an aperture wheel on a photoplotting machine.
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aperture table
A table that matches the line widths necessary to print your design with the plotter setup. SailWind 
Layout can prepare the table automatically, or you can prepare it manually.

Artwork for printed circuit manufacturing is created by exposing clear film to light that is passed 
though the aperture. Although the aperture wheel has been made obsolete by laser plotters, an 
aperture table is still necessary to drive laser plotters.

apl.dcr
A setup file for Novell network security.

application-specific integrated circuit
An IC designed to meet a specific customer requirement.

area select
A method for selecting an object or a group of objects. If you enable area select by clicking Filter on 
the Edit menu, a selection rectangle is created and all items within the rectangle are selected.

array
A group of items, such as bonding pads, that are arranged in rows and columns.

artwork
Clear film with darkened areas representing pads and connecting traces, and used for 
manufacturing a printed circuit board. Each layer of a design has its own unique artwork, such as 
silkscreen and solder mask.

.asc
The file extension used to identify a proprietary PADS-format ASCII file.

ASCII format
A translation format that uses ASCII text to define the PCB design. ASCII format is widely used 
to list the parts and connections in a design, to import and export design items, and to check the 
design for binary corruption.

ASIC
An acronym for application-specific integrated circuit.

assembly drawing
A final design document that provides the part name, type, and orientation for each device on a 
printed circuit board. An assembly drawing is used for assembly of the final product.

assembly variant
A specific manufacturing configuration of a PCB. Assembly variants specify which components 
are used, which are not used, and which are substituted with a different decal part type. Several 
assembly variants can exist for a single PCB.

associated net
See electrical net.
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associating component

associating component
A component through which an electrical net passes.

associating copper
Copper combined with the terminals in the PCB Decal Editor.

attribute groups
A group of structured attributes. For example, the DFT group includes the following attributes:

• DFT.Nail Count Per Net

• DFT.Nail Number

• DFT.Nail Diameter

attributes
Attributes contain information you have associated with an object in your design. Attributes contain 
the types of part information that can be included in the parts library description and exported to a 
parts list. Examples are part manufacturer, package type, order number, and so on.

Auto Dimensioning tab
The tab on the Options dialog box that determines the appearance of newly created dimensions.

automation
A way for heterogeneous applications to communicate with each other. SailWind products make 
some data, such as the database in use, and some functionality, such as opening files or selecting 
objects, available to other applications.

autorouter pass types
Pass types are part of an autorouting strategy that determines how the autorouter routes a design.

Pass Description

Center Places traces equidistant from component pins or vias and each other to evenly 
distribute any available space in the channel.

Fanout Places vias for inaccessible SMD component pins and routes from the vias to 
the pins.

Miters Converts all route corners of a specified angle to diagonal corners.

Optimize Analyzes each trace and tries to improve the quality of the route pattern by 
removing extra segments, reducing via usage, and shortening trace lengths.

Patterns Searches for groups of unrouted connections that can be completed using 
typical C routing patterns, Z routing patterns, and memory patterns and then 
routes them.

Route Sequentially routes each unroute until all connections are attempted.
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Pass Description

Test Point Analyzes the testability of the design, determines which nets require testing, 
adjusts the routes, and inserts test points to improve testability.

Tune Adjusts the length of length-controlled traces. The Tune pass tunes all routed 
traces with length rules, and automatically adjusts length-controlled traces to 
meet design rules.

axial lead
A connection pin that protrudes straight out from the component body and bends at 90 degrees for 
insertion into the PC board. An axial lead is usually associated with discrete components such as 
resistors, capacitors, or diodes.

back-annotate
Update a schematic file to match its design file.

ball bonding
A bonding technique that provides increased contact between a gold wire and a chip bond pad. This 
method uses thermal compression to melt gold wire to form a ball.

ball grid array
A packaging method that uses a substrate to interconnect one or more die to an array of solder 
alloy spheres.

base option
The Base Option, in Assembly Variants, contains all of the common components in all of the 
existing  variants; in other words, it contains a filtered database. If you uninstall or substitute 
components in a variant, they are removed from the Base Option. Therefore, the Base Option, 
because it contains only installed options, is also a subset of the raw database. You can use the 
Base Option to view all of the items in all of the variants, or the base of all variants.

The Base Option always exists; you cannot delete it.

base part
When making a union, the part type of the first selected part. Base parts can either be left in 
position and joined by secondary parts, or repositioned to imitate the first selected prototype part.

baseline dimensioning
A type of dimensioning in which a series of dimensions have a common start point, such as datum 
dimensioning.

basic units
A basic unit is the smallest unit of measurement in a SailWind database. All values in the database 
are stored in binary format basic unit and are converted to the current user units (mils, mm, or 
inches) for screen display. If you need to re-import the information to .pcb  format, export in basic 
units.

Conversions are:
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• 1 mil = 38100 basic units

• 1 millimeter = 1500000 basic units

BGA
An acronym for ball grid array.

BGA fanout
A single-segment fanout that connects BGA array pads to BGA vias. This single-segment fanout 
always ends in a via.

BGA/PGA decals
A full matrix decal for BGAs and PGAs, including staggered array patterns.

biased pin pair
A layer biased pin pair is any pin pair with a design rule specifying a layer bias to one or more, but 
not all, electrical routing layers.

blind via
A via that connects an outer layer to one or more inner layers, without passing through all other 
layers of a printed circuit board.

bmp
An image file that can be pasted into documents or other programs such as Microsoft Word. 
SailWind products use the Copy Bitmap command to capture these as screen images.

board markings
Designers usually include identification information on a board. These may include the board part 
number, the assembly part number, the company name, the product name, the revision level, the 
serial number, the copyright notice, an anti-static symbol, warning messages, UL labels, test labels 
and many other types of information. This information may be in ink on the silkscreen layers, in 
copper on the top and/or bottom layer or some combination of the two. These are typically referred 
to as board markings.

Add text to an electrical layer and it will be created in copper. Add text to a Fabrication, Assembly, 
and Documentation Layer and it will be created during the silkscreen process.

Use the Text command to add board markings to your design.

See also Adding Free Text

board outline
The actual shape of the printed circuit board, defined by line segments and arcs. The board outline 
is entered on layer 0 and displayed on all layers.

bonding pads
Metallization areas placed around the perimeter of the integrated circuit die, to which aluminum or 
gold wires connect the die to the component package.
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bounding rectangle
The smallest rectangle that encloses all nontext graphics on all layers.

breakpoint marker
A small brown dot in the Output window gutter that indicates a breakpoint in a script or macro.

bumped chip
A die or chip that has been specifically processed with buffer metals over the I/O pads, followed 
by an addition of solder or gold bumps to provide bonding areas for direct chip attachment onto a 
substrate.

buried via
A via that connects only inner layers.

bus
A series of connections that share a common use, such as memory array or data array, and are 
usually routed parallel to each other.

bus routing
Routing two or more pin pairs simultaneously and in close proximity to each other in neat, flowing 
patterns.

C routing pattern
A collection of routes that form a pattern resembling the letter C.  

CAD
An acronym for Computer-Aided Design or Computer-Aided Drafting.

CAE
An acronym for Computer-Aided Engineering.

CAE Decal
The graphical representation of schematic symbols in SailWind products.

CAM
An acronym for Computer-Aided Manufacturing.

746 SailWind Logic Guide



 
Glossary

CAM document

CAM document
A combination of plot type and output device you create and save with the design. For example, 
you can include "Silkscreen Top, Photoplot" and "Silkscreen Top, Laser Printer" on your CAM 
Documents List and run them selectively when needed.

CAMDir
The SailWindpcb.ini  file entry that enables you to specify the CAM master folder for creating CAM 
output.

capacitance
The ratio of charge within a trace that is a factor of the trace length and signal delay.

CBGA
An acronym for ceramic ball grid array.

CBP
An acronym for chip bond pad.

center pass
An autorouting pass that places traces equidistant from component pins or vias and each other to 
evenly distribute any available space in the channel.

CGA
An acronym for column grid array.

chamfered
A rectangle with the square corners cut off to create beveled edges on the corners.

chamfered path
A solid filled copper that, like a trace, acts as a conductor connecting pins and vias similar to a 
trace. But unlike a trace, which is created with a round aperture producing rounded outside corners, 
chamfered path copper allows for sharp specific outlines with a filled interior. When creating a 
chamfered path, you set options to create shapes with square or chamfered corners. The copper 
created by chamfered path has a Solid Copper property which overrides the Copper Hatch Grid and 
Drafting Line Width settings to make it a solid fill. Clearance rules for the chamfered path copper are 
also changed to match the clearance rules of a trace.

checking
Verifying the design meets previously defined rules, such as clearance and connectivity.

chip
An integrated circuit without packaging. A chip is also called a die.

chip bond pad
Interconnect areas on the die on which wire bonds are connected to the substrate.

chip carrier
A square or rectangular IC package, with I/O connections on four sides.
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chip on board
The packaging configuration in which a chip is bonded directly to a circuit board or substrate.

Chip Scale Package
A packaging configuration in which the dimension of the substrate is 1.2 times larger than the die.

chord
Half of an accordion.

See also accordion,amplitude, gap (accordion)

clam shell fixing
A test fixture that tests both the top and bottom side of the PCB.

class
A collection of nets with a common set of design rules.

clearance
The measured space between routed objects such as trace-to-trace, trace-to-pad, or pad-to-pad.

closed cluster
Clusters that you cannot delete or replace during automatic cluster creation.

cluster
In Cluster Placement, a group of parts that must be placed close to each other.

CMOS
An acronym for Complementary Metal Oxide Semiconductor.

COB
An acronym for Chip On Board.

coefficient of thermal expansion
A quantity used to determine the length change of a material due to temperature change. Thermal 
expansion differences between the die and substrate must be considered for quality assurance.
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collapse
To relocate the members of a cluster from their current placement to the center of the cluster.

column grid array
Similar to a ball grid array, but columns are used to improve the stresses of different thermal 
expansion between the board and the component.

Com port
Abbreviation for communications port. This port provides a connection between your computer and 
peripheral devices, such as plotters, modems, and other computers.

combine
Joining lines, or lines and text, together as one selectable object.

component side
The top or front side of a printed circuit board where devices are normally mounted.

composite fanout
A fanout from a pin that is common to two subnets. Often created by autorouting operations.

Composite fanouts provide access to component pins that may otherwise be inaccessible.

See also fanout, subnets

composite rule trace
A trace that is attached to a pin (typically an SMD) shared by two subnets. This type of trace is 
typically created by autorouting operations.

See also composite fanout, subnets

conditional rules
Rules placed on a signal that apply only if the signal is routed near another specified signal. 
Conditional rules are also known as against rules.

conductor
A material that causes heat or electrical current flow. For printed circuit design, a conductor is a 
piece of metal that connects pins of components together.

connected islands
A maximum set of subnet items already connected by a trace, copper unroute, or jumper.

See also subnets, subnet

connections
Points of connectivity, such as a pin pair or a net.

connector
A unique component used to connect a portion of a printed circuit board with other devices.
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Constraint Manager
The Constraint Manager is a separate application used to input rules for SailWind Layout instead of 
the rules dialogs within the SailWind Layout application. The Constraint Manager is only used in the 
integrated SailWind Designer project.

container application
An application that can incorporate embedded or linked items into its own documents. The 
documents managed by a container application must be able to store and display both OLE 
components, and data created by the application itself. A container application must also allow 
users to insert new items or edit existing items.

When you insert objects into a SailWind product, the SailWind product is the container application. 
When you insert a SailWind file into another application, the other application is the container 
application.

controlled gap area
The part of the differential pair where the traces are drawn routed in parallel and separated by the 
pair routing gap. The controlled gap zone area starts at the gathering point and ends at the split 
point.

See also gathering point, pair routing gap, split point

controlled gap length
For a differential pair, the ratio of the controlled gap area routing length to the overall routing length, 
in percentage.

See also differential pairs

controlled length net
A net that has length rules, or contains pin pairs that have length rules.

The following high-speed rules are net length rules:

• Minimum/maximum length

• Matched length

• Differential pairs

converting database
The process that converts a non-native file, such as an .asc  file or a .dxf  file, to a SailWind native 
format, or .pcb, file.
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copper connectivity
Means unroutes are always connected to a copper at some point in the copper outline. A copper 
outline can include arcs. The following graphic illustrates how copper connects to a net.

See also coppers, overlapping coppers

copper plane
A copper shape with insulation areas around traces and pins that pass through the copper, but are 
not attached or connected to the copper. Can be placed on any layer, except CAM plane layers.

coppers
Polygons on an electrical layer representing an area of the PCB to fill with metal.

When a copper is assigned to a net, it is joined to the net with a trace or via. Coppers are obstacles 
to net objects unless the copper and the net belong to the same net.

See also overlapping coppers, copper connectivity

copy route
The duplication of a trace or series of traces, using copy and paste.

corner
Point where a trace or line changes direction. The Selection Filter enables or disables picking 
geometric or route corners.

cost
Reduces usage of a layer. The higher the cost, the less a layer is used for routing.

cross-probing
Uses a link between SailWind programs to reflect, in one SailWind application, selections made in 
another SailWind application.

CSP
An acronym for chip scale package.

CTE
An acronym for coefficient of thermal expansion. It is also referred to as TCE.
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cutouts
A closed polygon in a copper, copper plane, or board outline. In copper or copper planes, a cutout 
results in an area absent of copper.

See also overlapping cutouts

cycle picking
To sequentially select objects in the vicinity of the selection point using the Tab key.

dangling route
Dangling routes are stubs or spurs off of traces that are not tied to any pin by a ratsnest. See also 
partial route.

database units
The use of mils, metric, or inches within a design.

datum dimensioning
A style of dimensioning in which all dimensions are measured from a common starting point. The 
origin extension line is marked as zero, with each dimension reflecting the measurement from that 
point.

See also Creating Baseline Dimensions

D-codes
Specific numbers assigned to photoplot machine apertures for program identification. D-CODES are 
included in the aperture table.

decal
The physical representation, or footprint, of a part.

decal copper
Open, closed, or associated copper produced within the physical representation of a component.

decal text
Documentation text produced within the physical representation of a component.

default component
The original component, before being replaced in the current assembly variant. The default 
component is always in the raw database, but not necessarily in the Base Option.

See also active component

default layer mode
A layer mode in which a design can consist of up to 30 electrical layers, or a combination of 
electrical and nonelectrical layers. You change from default layer mode to increased layer mode by 
clicking the Max Layers button in the Layers Setup dialog box.
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default.asc
The ASCII file accessed for new file creation. This file provides startup design information such as 
grid sizes, default colors, or other information.

defaults
Conditions or options that are set when the SailWind product starts.

delay
The time it takes for a signal to travel through a trace.

delete
To remove information from a design.

design area
The actual work area where a design is created.

design on the fly
To use ECO Operations to create a new design without first providing a netlist or parts list from 
schematic software. This can also be called design.

Design category
The Options category that controls design conditions, general routing conditions, and certain display 
and part movement method settings.

design rules
Established spacing and general routing constraints for electrical properties, or conductors, which 
are verified by clicking Verify Design from the Tools menu.

devicesn.dat
A file usually found in the C:\<install_folder>\<version>\Programs  folder that contains CAM 
printer and plotter driver data. This file must exist in the same folder specified by the UserDir 
SailWindpcb.ini  variable.

DFM
An acronym for Design for Manufacturing.

DFT Audit
DFT Audit analyzes every net for accessibility (adaptability) and creates a board report that 
identifies all inaccessible (non-adaptable) nets.

dice
The plural of die.

die
A single square or rectangular piece of semiconductor material into which a specific electrical circuit 
has been fabricated.

SailWind Logic Guide 753



Glossary
die bonding  

die bonding
To attach the semiconductor die to the package substrate with epoxy adhesives, gold eutectic, or 
solder alloy. It is also referred to as Die Attachment.

die flag
Metal shapes placed under a die for thermal management and/or electrical connection; also 
referred to as a flower pattern.

die side of CBP
The side of the die on which the CBP lies. Usually the die side of the CBP is the same as its fanout 
side, but in some cases more complex patterns of wire bond fanout may mean that the two sides 
are not the same.

Die Wizard
This feature creates die part definitions parametrically or imports the die description using GDSII or 
formatted ASCII files. The Die Wizard replaces Component IQ by providing die capture directly in 
the Advanced Packaging Toolkit layout editor. This eliminates the need to transfer .ciq  files.

dielectric
A non-conductor of current; an insulator.

dielectric constant
A value given for manufacturing materials, such as FR-4, to describe electrical characteristics.

differential pairs
A group of two nets or two pin pairs routed side-by-side and separated by the pair routing gap for 
as much of the overall length as practical. A differential pair typically transmits two electrical signals 
that are driven 180 degrees out of phase from each other.

See also pair routing gap

digital board
A board with mostly integrated circuits in proportion to the analog components.

DIP
An acronym for Dual In-line Package.

DisableCaching
A SailWindpcb.ini  file entry that, when set at 1, shuts off graphics optimization and, when set at 0, 
enables graphics optimization.

discrete device
A device that contains one circuit element. For example, a resistor or toggle switch.

disperse
A command that is active on several levels of Cluster Placement. When selected, it clears the board 
of all parts or clusters that are not glued down, and arranges them around the outside of the board 
outline according to decal type.
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dispersion routes
Partial routes, ending in vias, which tie surface mount components to plane layers.

do file
The SPECCTRA router ASCII setup file that contains user-defined router commands to initiate 
batch routing.

dock
To take an isolated application dataset and pull the changes within the dataset into the main design 
project. Any conflicts with the merged data must be manually resolved.

documentation layers
Layers higher than the electrical layers in a SailWind Layout database that contain text and lines to 
illustrate assembly, annotation, and provide instructions for manufacturing.

double-click
Two mouse clicks, in immediate succession, that usually initiate an edit action or complete the 
current action.

double-sided board
A printed circuit board made up of two routing layers, and which has no internal layers.

double-sided die
A die that has substrate bond pads on one side, and a BGA grid array on the other side. The two 
sides are connected through vias.

See also single-sided die

drafting operations
Any operation that involves adding nonelectrical information, not associated with placement or 
routing, to a design.

drawn pads
Photoplot pads, usually finger pads, that are produced by opening the aperture and moving the 
board, with the aperture remaining open, to produce a pad shape.

DRC
An acronym for Design Rules Check.

drill chart
A diagram, produced on a drill drawing, that shows drill symbols matched with drill hole sizes. This 
is also referred to as a drill legend.

drill oversize
A factor applied to plated through holes for DRC purposes to account for drill oversizing during the 
PCB fabrication process.
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drill pairs
Primarily for buried and blind vias, drill pairs define which layers are to be drilled and plated together 
during the fabrication process.

drill symbols
Unique symbols on a drill drawing plot that represent the various drill hole locations and sizes.

drill.dat
A user-definable ASCII file that determines settings for NC Drill output format options. This file must 
exist in the same folder specified by the UserDir variable in the SailWindpcb.ini.

DXF
An acronym for Data eXchange Format, a standard ASCII format for sharing graphics database files 
between different environments.

dxfset.dat
A file that contains the information for drill size and library name equivalents in basic units for the 
DXF Setup dialog box.

dynamic route
To create a route using the Dynamic Route tool, which automatically creates turns and pushes other 
routes aside to complete the connection.

ecad hint.map
A user-defined text file that you create, edit, and maintain. This file enables the replacement of 
approximated parts from SailWind Layout, with geometrically accurate components previously 
modeled in Pro/ENGINEER. This file must exist in either the current working folder or in the Pro/
ENGINEER software loadpoint\text folder.

ECO
An acronym for Engineering Change Order. This refers to a file with netlist changes that needs to be 
annotated to update either the schematic or layout that has become out of sync with the new design 
changes.

ECO mode
A mode that SailWind Layout enters when the ECO Toolbar is open. Changes that affect the 
connection list or parts list can be recorded in a file for backward annotation.

See also ECO

ECO Options
The setup choices available for the ECO output file in the ECO Options dialog box.

ECO registration of attributes
Only ECO-registered attributes, set on the Objects tab of the Attribute Properties dialog box, can be 
added, deleted, or changed during the ECO process. Via attributes are not registered attributes and 
cannot be added, deleted, or changed during the ECO process.

You can modify ECO-registered attributes only in ECO mode.
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Non-ECO-registered attributes are never recorded in an .eco  file during ECO operations.

To compare ECO-registered attributes, use the Compare Only ECO Registered Attributes option on 
the Comparison tab in the Compare/ECO Tools dialog box.

EDA
An acronym for Electronic Design Automation.

EDC
An acronym for Electrodynamic Checking.

edge
One side of a polygon.

edge die
The two or three rows of dice along the outer circumference of a wafer.

edges
The Selection Filter preference that enables or disables selection of geometric segments.

editing
Any action that modifies a design.

electrical layers
Layers enabled for routing that are checked by DRC.

electrical net
A series of nets connected by one or more components. Length, differential pair and matched 
length rules can be applied to an electrical net as though it were a single net.

embedded objects
An object, including all of its data and the information needed to manage the object, that is 
contained within the framework of, and is a part of, the container application document.

See also linked objects

EnableMacroLanguage
The SailWindpcb.ini  file entry that, when equal to one, enables loading of all macro parameters on 
startup and, when equal to zero, disables loading of macro parameters upon startup.

end component
A component having at least one pin which is a final pin of an electrical net.

end no via
The mode initiated in the routing shortcut menus that, while routing, ends a partial route without a 
via.
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end via
The mode initiated in the routing shortcut menus that, while routing, ends a partial route with a via.

end zone
The part of the differential pair between the split point and destination pins.

The labels in the above graphic correspond to routing that starts at the left-hand set of pins and 
ends at the right-hand set of pins. The label positions are reversed if the routing starts at the right-
hand set of pins.

See also differential pairs, split point

ending layer
The finishing layer for a drill pair or via definition. Enter information about ending layer in the Pad 
Stacks Properties dialog box.

engineering change order (ECO) operations
Any processes that modify the connection list or parts list.

entry angle
The angle at which a route enters a pad.

Esc
To use the Escape or Cancel keys to stop a current action.

estimated total length
The trace length monitor calculates estimated length as the combined total of routed length (Rt), 
plus the routed length for the entire net—including overlapping segments— (Nt), the unrouted 
length (U1) of the trace being routed, and includes half the Discrete length value of each connected 
pin of components that have a Discrete length assigned (not shown).

Overlapping segments are counted only once.

758 SailWind Logic Guide



 
Glossary

eutectic solder

See also routed length, unrouted length

eutectic solder
A tin/lead alloy (63% tin, 37% lead) that melts at optimum temperatures.

export
The translation command used to convert a design file into PADS-format ASCII or DXF.

extended rules
Clearance, routing, and high-speed rules consisting of classes (one or more nets), groups (one 
or more pin pairs), individual pin pairs, decals, components and differential pairs. Without the 
Extended Rules option, you can assign rules on the net level only.

extension lines
Lines extending from the points being measured.

extents
The limits of the x and y coordinate area that is occupied by all items within a design. This includes 
information external to the board outline, such as dimensions or fabrication notes.

Fabless
A semiconductor company that subcontracts wafer manufacturing because it does not have its own 
wafer manufacturing facility.

fabrication
With semiconductor manufacturing, the front-end process of making devices in semiconductor 
wafers only, not the package assembly or back-end stages.

fanout
A segment of trace or copper shape added to SMD pads to facilitate routing. A fanout typically 
consists of one or more trace segments connecting a component pad to a via, enabling the signal 
on an outer layer to connect to one or more internal signal layers or planes. A specialized repeated 
pattern is often necessary to break out multiple pads on the same component far enough from the 
component to enable easy routing.

Use fanouts to:

SailWind Logic Guide 759



Glossary
fanout pass  

• enable on-grid access by autorouters that cannot handle off-grid pads.

• make routing easier, and ensure connections are made.

• connect SMD pins to an inner plane layer using vias.

• connect an SMD pad to an inner signal layer where more routing space is available.

fanout pass
An autorouting pass that places vias for inaccessible SMD component pins and routes, from the 
vias to the pins.

fanout side of CBP
The side of the SBP Guide to which the CBP should be wire bonded. Usually the fanout side of the 
CBP is the same as its die side, but in some cases more complex patterns of wire bond fanout may 
mean that the two sides are not the same.

FCBGA
An acronym for flip chip ball grid array.

feature size
The smallest line width or spacing between lines or features on a semiconductor die.

feed-through hole
A drilled and plated hole that passes conductivity from one layer to another. This is also called a via.

fiducials
Fiducials are alignment marks, a type of target, used for calibration before placing objects.

There are at least three types of fiducials:

• Panel fiducials  — used for alignment and calibration of images on a multi-board panel.

• Board fiducials  — used align components on a specific board (on or off a panel). Fiducials 
are (typically) round solid targets placed near three corners of each board on each side 
of the board that will receive components. The pick and place system scans the board for 
these targets (shiny circles approximately .040" in diameter) and uses them to align the 
machine before it starts placing parts.

• Component (local) fiducials  — used for close tolerance placement of high pin-count 
components with fine pitch leads. The footprint (PCB decal) of a fine pitch component will 
typically contain two component fiducials at opposite corners of the footprint. This enables 
the pick and place machine to align the fine pitch component exactly on the footprint.

field upgrade
Programming options on your security key by entering in a key unlock code using plicense.exe or 
equivalent.

760 SailWind Logic Guide



 
Glossary

file sharing

file sharing
Multiple users accessing the same file or files through a network.

file.dir
The SailWindpcb.ini  file entry that specifies the default location of your design files.

filter
A settings dialog box within that controls which types of objects can be selected.

find
The SailWind command that locates, and optionally selects, an object or group of objects in the 
database.

finger pad
One of many long pads placed in a series to represent an edge connector.

finished hole size
The size of a drilled or routed hole after plating and/or solder reflow has been applied.

flashed pads
Pads produced on a photoplotter by opening the aperture momentarily, without moving the board, to 
produce a pad shape.

flat pack
A component package where the leads extend away from the component and remain on a parallel 
plane with the base of the component.

flip
The command that moves the selected items to the opposite side of the board.

flip chip
An IC designed for face-down mounting by means of controlled-collapse solder pillars on a device's 
I/O bonding pads.

floating license
A method of licensing where a central security server manages a pool of licenses for use by a large 
number of clients.

floating toolbars
Toolbars you can undock from the sides of the application window and place anywhere on screen.

flood
To fill a previously defined copper plane.

flower pattern
Metal shapes placed under a die for thermal management and/or electrical connection; also 
referred to as a die flag.
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A ceramic, surface-mounted hermetic package.

FlushUndoBeyondSize
The SailWindpcb.ini  file entry that determines the maximum size of the undo buffer before SailWind 
Layout removes previous commands from the undo buffer to make room for the current command. 
If adding the current command causes the undo buffer to exceed this maximum size, SailWind 
Layout removes previous commands until the undo buffer can store the current command.

follow route
The connections or pin pairs that are part of the bus routing, and which are routed following the 
guide route's path.

footprint
The arrangement of pads for a given part decal. For example, the footprint of a fourteen DIP is two 
rows of seven pads, spaced 100 mils in the Y direction, and 300 mils in the X direction.

forward-annotate
Update a design file using data from a schematic.

FR-4
An acronym for Fire Retardant Number Four, an epoxy-resin substrate material used in laminate 
applications.

free copper
Open or closed copper that is not associated to other copper or pads.

free disk space
The physical amount of space available on your hard drive that is available for use by programs.

gap (accordion)
The gap of an accordion sets the pitch between chords. The gap is a user-definable number 
multiplied by the same net trace-to-corner clearance.

If the same-net trace-to-corner distance equals zero, then Trace Width is used for the gap 
calculation.

See also accordion, amplitude, pair routing gap
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gate
An element of an electronic circuit whereby one or more signals are input, with one output being 
dependent on the state of the input(s) and the type of logic used to interpret the input.

Pin swapping involves exchanging like inputs

Gate swapping involves exchanging the entire element for a like element.

gate array
An IC consisting of a regular arrangement of gates that are interconnected to provide custom 
functions.

gathering point
The point near the source pins where differential pair traces can start to be routed together at the 
pair routing gap.

The labels in the above graphic correspond to routing that starts at the left-hand set of pins and 
ends at the right-hand set of pins. The label positions are reversed if the routing starts at the right-
hand set of pins.

See also differential pairs

GDI memory
Memory reserved for Windows devices and graphics.

Geometry.Height
This attribute is used to indicate the height of the part. The attribute enables SailWind Layout to 
prevent the component from being placed in an area of the PCB which is height restricted.

In SailWind Layout, you can set board height restrictions for the top and bottom layers in the 
Drafting Options  or area height restrictions using a Keepout area with a “Component height” 
restriction. This attribute is also passed from SailWind Layout to mechanical tools where it can be 
used in 3D simulations to determine whether the part will meet spatial requirements.

In addition to the value, use one of the following units:

• Use the quotation symbol " for inches. The SailWind Layout Attribute Dictionary specifies 
the following limits of acceptable values. Min=0.00000", Max=25.00000".

Example:  GEOMETRY.HEIGHT=3.26548"

• Use the abbreviation mil in upper or lower case. The SailWind Layout Attribute Dictionary 
specifies the following limits of acceptable values. Min=0.00mil, Max=25000.00mil

Example:  GEOMETRY.HEIGHT=12654.83mil
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• Use the abbreviation mm in upper or lower case. The SailWind Layout Attribute Dictionary 
specifies the following limits of acceptable values. Min=0.00000mm, Max=635.00000mm.

Example:  GEOMETRY.HEIGHT=123.21348mm

Gerber
The language used to drive a photoplot machine. This language is an ASCII file with instructions for 
selecting an aperture, moving the light source, and turning the light source on and off.

Global tab
Options tab that includes settings that affect an entire design, such as units of measurement and 
pointer size.

Glue
Anchors component(s) in their current location so they cannot be moved

grab bars
The two vertical or horizontal bars to the left or top of the window.

graphics cache
The SailWind setting used to optimize graphics. This is handled by the DisableCaching entry in the 
SailWindpcb.ini  and SailWindlogic.ini  files.

green dot
The status indicator located in the upper left corner of the workspace. It is green when the system 
is idle or ready for operation. It is red when the workspace cannot receive user input, such as when 
producing CAM drawings.

grid
A division of the workspace into measurement steps to facilitate accurate spacing between placed 
parts and routed lines. Also refers to the display; small white dots locating the measurement steps

ground plane
A design layer completely filled with copper, except for clearances around nonconnected pads and 
vias.

group
A collection of pin pairs that share common design rules.

grow
An cluster placement feature that adds additional parts to an existing cluster.

guard band
An octagonal shape that appears at the end of a trace during routing operations whenever the head 
of the trace meets a clearance obstacle that it cannot shove. The guard band only appears when 
online design rules are enabled.
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gui
An acronym for Graphical User Interface. The GUI includes such things as menus and commands 
that allow for interaction between the user and the software program.

guide route
A route segment that is used for the first connection and that is the lead for laying down two or more 
pin pairs simultaneously in neat flowing patterns.

hard rule
A rule that is always followed. See also soft rule, and Hard and Soft Rules.

hard breakout
Use of associated copper within a surface mount decal to simulate a dispersion route. The 
disadvantage to this method is that routing channels will possibly be blocked.

hatch
A copper fill pattern that uses horizontal and vertical lines at a specified width and spacing.

HDI
An acronym for High Density Interconnect.

heat dissipating component
While all components generate heat, these components generally have a published wattage 
rating. Care must be taken to ensure components or materials adjacent to these heat generating 
components do not exceed their max temperature ratings. If more than one of these components 
are used in a design, they should be spread out and should also be positioned to not impede 
airflow.

heat sink
An assembly that serves to dissipate, carry away, or radiate heat into the surrounding atmosphere.

high density interconnect
A class of packaging involving boards, substrates, and components using extremely small trace and 
spacing dimensions.

highlight
A user-defined color, usually white, used to denote that an object is selected.

high-speed checking
Using the Electrodynamic Checking utility. A simulator-type check that finds traces that may run 
parallel to each other close enough, and for a long enough distance, to cause cross talk.
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hole plating
A fabrication process where solder flows through a drilled hole to connect the pads on either side of 
the hole, to provide connectivity between two or more layers.

HPGL
An acronym for Hewlett Packard Graphics Language, a standard pen plotter interface language.

IC (Integrated Circuit)
An acronym for Integrated Circuit.

IDF
Intermediate Data Format. An industry standard format used for exchanging data between electrical 
and mechanical design systems.

IMAPS
An acronym for International Microelectronics and Packaging Society.

impedance
Resistance to the flow of current in a trace. Measured in ohms.

in circuit testing
An exhaustive and thorough test of a PCB in final production that tests nets and unused pins for 
such things as correct voltage, correct parts, or bridging. Test point placement is critical for in circuit 
testing.

inaccessible nets
Nets for which you cannot define test points. DFT Audit analyzes all nets. If DFT Audit determines 
that test probes cannot access them, the nets are inaccessible (also called non-adaptable).

INI file
An ASCII file, with the .ini  filename extension, that contains startup parameters.

An INI file for Windows might contain the following information: graphics drivers, mouse drivers, 
fonts, and so on.

An INI file for programs might contain the following information: folder structure, display colors, 
default editors, and so on.

inner layers
Design layers other than those on the top or bottom of a printer circuit board. Inner layers may be 
routing layers, plane layers, or a combination of both.

installed options
SailWind product features that you have bought and installed as part of the software package.

instruction pointer
A small yellow arrow in the Output window gutter that indicates the current line in a script or macro.
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insulator
A material used to inhibit heat or electrical properties, such as current flow.

integrated SailWind Designer project
A SailWind Designer to SailWind Layout project that uses a common database to share design 
information instead of using netlists to pass the design information between the software 
applications.

integrity check
A database check runs whenever a .job, .dxf, or .asc  file loads. You can also initiate an integrity 
check while you are working. Type the I modeless command, then press the Enter key.

intensity
A value assigned to objects such as vias to weigh decisions made during the autorouting process 
in SailWind Router. The higher the intensity, the less the item is used. For example, set a high 
intensity for via usage to minimize the amount of vias added to the design.

interconnect
A conductive connection between two or more circuit elements.

IPC
An acronym for Interprocess Communications within the SailWind product.

irregular trace length
Sections or segments of differential pair traces not routed at the pair routing gap.

See also differential pairs

islands
Small, isolated sections of copper plane that are not attached to anything.

JEDEC
An acronym for Joint Electron Device Engineering Council.

Joint Electron Device Engineering Council
JEDEC is the semiconductor engineering standardization body of the Electronic Industries Alliance, 
a trade association that represents all areas of the electronics industry.

jumper
A physical part used to cross over traces on most one layer PCB designs. Jumpers can be 0 Ohm 
resistors or wires stretched between jumper pads.

keepout areas
Areas that automatically ban objects. Depending on the keepout Properties, these areas may be set 
to prevent: placement of components, components that exceed a specified height, component drill 
holes, traces and copper, copper planes, vias and jumpers, and test points.
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keyview.exe
An executable file used to list the options programmed into your key. When you run keyview.exe, it 
creates a file named keyview.txt  that contains a listing of your key options.

label
A label is a display instance of a component or jumper attribute. If you want to make an attribute 
visible in the design, you must instantiate it as a label associated with a component or jumper. You 
can do this in the Design Editor or the Decal Editor. You can have multiple labels based on the 
same attribute. An attribute has two parts—a name, and a value. A label of an attribute can have 
one of four visibility settings—None, Value, Name and Value, and Full Name and Value.

Latium rules
Latium rules are for advanced functionality in SailWind Router. Some constraints that you can set 
in Layout are only used by SailWind Router. For examples, see the Tune/Diff Pairs options, Fanout 
Rules, Pad Entry Rules. The Latium checks include:

• component clearance rules

• component routing rules

• differential pair rules

• via at SMD rules

layer biased net
A layer biased net is any net with a design rule specifying a layer bias to one or more, but not all, 
electrical routing layers

layer pair
The assignment of two routing layers to switch between using the Layer Toggle command. On two 
layer boards, the toggle is automatically set between 1 (top) and 2 (bottom).

layer toggle
To switch between layer pairs while routing.

layers
A standard CAD database feature that separates graphical information into sheets of similar 
information such as dimensions, construction lines, or text. For PCB applications, this enables the 
various fabrication layers to be created and output separately.

layout-driven design
A PCB design process in which no schematic is created, and both the logical (netlist) and physical 
conformations of the board are defined in a layout tool. Also, a design created using this process. 
See also schematic-driven design.

Layout.rep
The error report file that is created by the database integrity test and which is written to the 
\SailWind Projects  folder.
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LCC
An acronym for Leadless Chip Carrier.

lead frame
A sheet metal framework that is etched to form an array of metal traces.

lead pitch
The sum of the lead width and lead spacing.

lead spacing
The distance between a component's adjacent leads.

Leadless Chip Carrier
(LCC) Ceramic IC package with no physical lead. There are only pads on the bottom of the package 
around the edges.

length matching
A same-length requirement where the entered value represents a minimum/maximum length 
tolerance for nets belonging to the same class.

length minimization
A routing feature that configures unroutes to the shortest available distances, or in a specific 
topology, to facilitate high speed routing.

LGA
An acronym for land grid array.

LibDir
The SailWindpcb.ini  file entry that specifies the location of your library files.

libraries
The collection of part types, part decals, and drawn items included with a SailWind product or 
created by the user.

Library Manager
The SailWind feature that provides access to, and allows for modifying, the library of parts.

linked objects
When an object is linked, a presentation of the object and link to the source is contained within the 
framework of, and is a part of, the container application  document. The object is linked to its source, 
and the source continues to physically reside wherever it was initially created. Therefore, the file 
that contains the object is smaller than if the object were and embedded object. See also embedded 
objects.

Whenever you open the file that contains the linked object, the object checks the source to see if it 
changed since you last saved the file. If the source changed, then the linked object automatically 
updates.
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LogCompressionMode
A SailWindpcb.ini  file entry that controls recorded mouse movements in a log file. When set to one, 
the default, recording of compressed mouse movement is enabled. When set to zero, recording of 
all mouse movement is enabled.

logic family
The assignment of an electrical type by name, such as CAP (capacitor) or RES (resistor), to 
indicate the appropriate reference designator prefix such as C or R.

LOGMode
A SailWindpcb.ini  file entry for online macro recording to a log file. When set to 0, the default, 
recording is disabled. When set to one, macro recording is enabled, and the next.log  file is created.

loop
A pin pair that contains a route that branches off the original route, then branches back into the 
same route to form a loop.

loop routing
Used to create a loop in an existing route.

LPT port
A parallel printer port, usually referred to as LPT1 or LPT2.

macro
Internal objects that are handled using the macro engine vocabularies, and may or may not have 
the automation interface.

Manhattan distance (delta x + delta y)
Used to approximate unrouted net length for BoardSim. Add a percentage multiplier to account for 
indirect routing paths.

masking
The inhibiting of electrical interference between two traces on different layers due to separation by a 
ground or power plane.

material condition
There are three material conditions when creating component decals. They are Maximum (providing 
the most robust solder joint), Nominal (providing a general purpose solder joint) and Minimum 
(providing the least possible solder joint for very dense designs).

MCM
An acronym for multichip module.

memory pattern
A collection of routes between memory devices that form a distinctly repeatable pattern.
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menufile.dat
The file containing the structure and text of all lists and shortcut menus. The menufile.dat  file must 
be located in the same folder as SailWindPCB.exe.

micrometer
One-millionth (10-6) of a meter; about 40 millionths of an inch. Micrometer is synonymous with 
micron.

micron
A term used for micrometer. One-millionth (10^-6) of a meter; 25.4 microns = 1 mil.

microvia
Vias that have a narrow drill hole. Because of their specific diameter to depth ratio, they are typically 
blind or buried vias and do not pass through many layers of the design.

minimum geometry
The smallest line width or spacing between lines or features on a semiconductor die.

miter
A diagonal segment or arc that replaces a corner.

miters pass
An autorouting pass that converts all 90 degree route corners to diagonal corners.

mixed plane layer
A plane layer that contains obstacles other than pads, such as routes, copper, or text.

modeless command
A command invoked through the keyboard. Commands include display options, design settings, 
and mouse click substitutions.

modify
To change information for a selected object.
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moiré
Target-shaped objects located in the corners of finished artwork that are used to properly align each 
layer to others for design verification and fabrication.

monolithic device
A device whose circuitry is completely contained on a single die or chip.

mounted side
The side of the printed circuit board, either front or back, on which components are mounted.

mounting holes
Many (but not all) boards have mounting holes. Mounting holes are typically located around the 
perimeter of a board (most often in the corners). They are drilled holes, used to mount a printed 
circuit board to the finished product (for example, a mother board mounted to the computer casing), 
or used to attach bolt-on components to the printed circuit board (for example, stiffeners and ejector 
tabs).

There are two types of mounting holes: plated and non-plated. Plated mounting holes have 
copper inside the hole and usually have a large annular ring of copper on both sides of the board 
connected by this copper cylinder (plating) inside the hole. These holes are typically connected to 
the GROUND bus or plane on the board and provide a method for grounding the board circuitry to 
the enclosure (for shielding purposes). The mounting hole ring diameter is usually slightly larger 
than the diameter of the head of the screw that will be used to fasten the board to the mounting 
device within the enclosure. Non-plated mounting holes are used for the same purpose, the only 
difference being that they are not internally plated and do not have a copper ring, therefore they are 
not used for grounding the board to the enclosure.

Plated mounting holes cannot be used as tooling holes as the thickness of the copper plating can 
vary and violate the close tolerance required by a tooling hole. Non-plated mounting holes can 
sometimes work double duty as tooling holes because there is no internal plating, therefore the 
tolerance of the hole size can be more closely controlled and fit within the requirements of a tooling 
hole.

Use the Decal Editor and the Pad Stacks dialog box to create tooling holes. Save the single-
terminal object as a part to the library for reuse.

See also Creating and Adding Board Mounting Holes  in the SailWind Layout User’s Guide and 
Reference Manual

multichip module
A package with multiple dice that is 20% or more silicon, has 100 or more I/O on a substrate, and 
four or more layers.

multilayer PC board
A design that contains routing and/or plane layers, in addition to those on the front and back side.

nail diameter
The diameter of the test probe.

NC drill
An abbreviation for numerical control drill. This technology involves producing an output file 
containing the x-y location and drill size for each hole, then feeding this information into a machine 
for automated hole drilling.
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negative
A photographically produced reverse image of a plane layer. This allows cleared areas, or airgaps, 
to be created using normal drawing techniques. When reversed, all areas not drawn for clearance 
become the actual planes.

nested embedding
Nested embedding occurs when you insert an object using OLE into another object. For example, 
inserting a SailWind Logic schematic into your SailWind Layout Design or inserting a Microsoft 
Word document into a schematic.

nested macros
Macros called from other macros.

net
All pin pairs composing one individual signal. Nets contain at least one subnet, but may contain 
more than one.

See also subnets

net class
A collection of nets with a common set of design rules.

net length rules
Rules that control a net's or pin pair's routing length.

The following high-speed rules are examples of net length rules: minimum/maximum length, 
matched length, and differential pairs.

The phrase controlled length net refers to nets that have length rules, or nets with pin pairs that 
have length rules.

net name
A specific name given to a net to describe its function; for example, GND, PWR, or DATA0.

The maximum net name length is 47 characters. You can use any alphanumeric characters except 
{ } * and space.

netlist
A point-to-point connection list for each signal in a design, providing the reference designator (part 
name) and pin number.

netlist file
A SailWind ASCII file containing all of the nets in a design, including all component pins that make 
up the nets. The file may also contain a list of all parts in a design, and/or the settings that control 
the substrate bond pad numbers and functions for newly created substrate bond pads.

netlist.fmt
The ASCII setup file for the report format that produces a netlist without pin information.
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network security
Use of one security key, programmed with multiple options, for network use with one or more 
systems at a time.

next.ini
A file produced in the C:\<install_folder>\<version>\Programs  folder when the SailWindpcb.ini  entry 
LOGMode is equal to one. The next.ini  file is a copy of your SailWindpcb.ini  file at the time next.log 
is written.

next.log
A file produced in the C:\<install_folder>\<version>\Programs  folder when the powerpcb.ini entry 
LOGMode is equal to one. The next.log  file records all activities within a SailWind Layout session so 
that they can be replayed to reproduce a series of steps or used to illustrate a problem.

node
A point along a trace where traces join other traces (T junction), where traces transition to other 
layers, or where traces end at pins, virtual pins, vias, or floating endpoints. Specifically, a node can 
be any pin, virtual pin, via, copper, trace junction, virtual point, or trace end.

See also virtual point

node-locked
A license for a specific Host ID.

non-ECO-registered parts
These parts are found in the schematic and layout design. Parts not selected as an ECO-
Registered Part on the General tab of the Part Information dialog box are non ECO registered parts.

• A schematic non-ECO-registered part is required in the schematic but has no place in the 
layout of the circuit board. For example, a chip socket shown in the schematic for inventory 
tracking in the bill of materials.

• A layout non-ECO-registered part is required in the layout design but has no place in the 
schematic. For example, a plated and grounded mounting hole.

non-electrical parts
Parts with no pins. For example, a mounting screw shown in the schematic for inventory tracking in 
the bill of materials.
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non-plated holes
Pads that are not reflowed with solder, usually reserved for mounting holes. Non-plated holes are 
not drilled with an oversize to accommodate the solder flow.

To determine plating status, in SailWind Layout, use the Pad Stacks Properties dialog box. In 
SailWind Router, use the Pad Stack tab in the Pin Properties dialog box.

nudge
A placement feature that relocates parts to make room for new parts being placed. Movement is 
based on previously defined clearance rules.

object
One discrete item in the design. For example, an object may be a route segment, a part, a drawing 
line, or a via.

object mode
Start a command by selecting one or more objects and then selecting the command to perform on 
them.

See also verb mode

obstacles
Objects that block routing, for example protected pins, vias, traces, keepouts, and board outlines.

odd pad shape
A pad that requires a special aperture, or plot sequence, to create. In SailWind Layout, in the Pad 
Stacks Properties dialog box, the odd shape setting should not be confused with trying to create a 
custom shaped pad which is accomplished by drawing copper in the decal and associating it to the 
pad.

offline plot
A plot that is sent to a file before it is copied to a printer or plotter for processing.

offset
The distance by which rectangular or oval pads are moved away from the electrical center of the 
pad stack.

offset pads
Rectangular or oval pads moved off the electrical center of the pad stack to facilitate identification/
selection, or for a special design consideration.

one pin nets
A net that contains only one pin. Also called single pin net. In SailWind products, a net must have a 
minimum of two pins.

online DRC
A SailWind feature that actively checks established-design rules during routing or placement 
operations.
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online plot
A plot sent directly to a printer or plot.

open cluster
Clusters that you can delete or replace during automatic cluster creation.

optimization
Rearranging placed parts and/or swapping pins and gates on parts to minimize trace lengths and 
reduce the number of vias required for routing.

optimize pass
An autorouting pass that analyzes each route and tries to improve the quality of the route pattern 
by removing extra segments, reducing via usage, and shortening routed trace lengths. This pass 
includes glossing and smoothing processes.

overlapping coppers
Overlapping coppers are combined into one copper area, with possible cutouts.

See also coppers, copper connectivity

overlapping cutouts
Overlapping cutouts are combined into one cutout area.
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See also cutouts

overlapping segments
Multiple trace segments stacked on top of one another on one layer.

package
The protective container for an electronic component with terminals to provide electrical access to 
the die components inside.

pad entry
The point where a trace entering or exiting a pin first crosses the edge of a pad.

pad entry angle
The command in SailWind Layout and Router that establishes the angle at which a trace enters a 
pad. This may be orthogonal (90 degrees), diagonal (45 degrees), or any angle.

pad function
The die signal name to which the component bond pad is connected.

pad number
The number of the component bond pad.

pad oversize
On plane layers, pads that are larger than normal, to generate proper clearances when the image of 
the pad is printed in a negative format.

Pad oversize is measured from the center of the pad, not the perimeter. For example, if you have a 
3 mil oversize, the measurement is actually1.5 mils in each direction from the center of the pad.

pad stacks
The combination of pads, drills, and pastes, for example, on a pin or via, for each layer of a design, 
stacked directly on top of one another.

pair routing gap
The fixed edge-to-edge clearance between the traces in the controlled gap area for a differential 
pair.

See also controlled gap area, differential pairs.

paired layer
The start and end layers used by the layer toggle command when changing layers while routing. It 
defines the default layers to use when you make layer changes.
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palette
A user-definable color chart in the Display Colors dialog box.

pan
Up and down or side-to-side movement of the screen without zoom or redraw. Use the scroll bars or 
postage stamp to pan.

panning
Moving the view horizontally or vertically without changing the size of the design on your screen.

parallel port
A printer port, usually referred to as LPT1 or LPT2.

parallelism
Traces on the same layer that are checked for running parallel to each other.

The traces are subject to crosstalk if they run parallel to each other too long and the gap between 
them is too short.

parasitic
An undesirable stray capacitance, inductive coupling, resistance leakage, or undesired transistor 
actions.

parent object
The object to which individual design elements, such as lines, arcs, or corners, belong.

part decal
The physical representation of a part, or footprint, assigned to the part type.

part list
An output listing of all parts belonging to the same design. This normally includes the reference 
designation, part name, and part type, and total number of each type.

part name
The text for each part that indicates the reference designator.

part outline width
The line width of 2D line shapes, created in the PCB Decal Editor, that represent silkscreen or 
documentation data within a part decal. The shapes do not include text, reference designators, or 
copper with the decal.

partial route
Partial routes are uncompleted routes where the ratsnest flightline is still visible. This occurs when 
you click End while routing or bus routing, or when you delete a trace segment. See also dangling 
route.
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partial via
A via that does not travel through all of the board's electrical layers. The blind via  and buried via  are 
both types of partial vias.

parts1.fmt
An ASCII part list format file for the report file generator that consists of a reference designator, part 
type, and logic type.

parts2.fmt
An ASCII part list format file for the report file generator that consists of a part type, reference 
designator, and part description.

paste
A substance used to attach each pin of a surface mount device to a PC board.

paste mask
An artwork layer with a paste location for all pads of surface mount components.

patterns pass
An autorouting pass that searches for, and routes, groups of unrouted connections that can be 
completed using a typical C routing pattern, Z routing pattern, and memory pattern.

PBGA
An acronym for plastic ball grid array.

PDF configuration
A set of PDF Configuration dialog box control settings. A PDF configuration can be saved as a .pdc 
file and reused to create PDF documents for multiple designs.

PGA
An acronym for pin grid array.

photoplotting
Using a machine to create printed circuit board fabrication artwork. The machine creates artwork by 
exposing clear film to light or by rasterizing an image onto clear film.

physical design reuse
A collection of design objects that you want to reuse, which are associated with one another. The 
collection of objects can be saved to a file.

physical design reuse elements
The objects that compose the reuse. They can include components, routes, vias, text items, and 
other elements.

pick and place
An automatic printed circuit board assembly machine, driven by outputting the part type, location, 
and orientation of suitable parts from a design.
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pin
The through-hole or surface mount terminal that represents a connection to a part. Pins are also 
referred to as pads in pad stacks.

pin array/pin grid array
A package with pins distributed over much or all of the bottom surface of the package in rows and 
columns.

For more information, see Decal Wizard Dialog Box, BGAPGA Tab.

See also pin types.

pin number
Within a component, the numeric or alphanumeric designation that distinguishes pins from each 
other.

In the Status bar, pins are identified using the following format:

Pin:[Component name].[Pin number].[Pin type]

For example:

Pin:Y1.N.Nonelectrical

See also pin types.

pin pair
The combination of a trace or unroute, and the pins on either side. A net can contain one or more 
pin pairs.

pin pair group
A collection of pin pairs that share common design rules.

pin type
A designation that indicates the electrical characteristics of the pin such as Source (S), Load (L), 
Terminator (Z), and Undefined (U). For example, U1.1.S may appear on the status bar.

pin types
Pins and pin pairs can be identified by one of the following pin types:

• Source

• Bidirectional

• Open Collector

• Or-Tieable Source

• Tristate
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placement check prints

• Load

• Terminator

• Power

• Ground

• Nonelectrical

Pin types make up the last portion of the pin identifier in the Status bar. For example:

Pin:U10.C.Open Collector

See also pin number

placement check prints
Generate a CAM Assembly drawing to make a placement check print.

After the PCB Designer receives a schematic and a netlist from an Engineer, they (typically) place 
the components onto the board in a manner that best suits the routing of the board. Sometimes, 
the placement better suits the intentions of the Board Designer than the Engineer, so before 
routing proceeds, the Engineer will request to see a set of Placement Check Prints. Placement 
Check Prints show the placement of all components on both sides of the board, so  the Engineer 
can review the locations and confirm the Designer has correctly placed the components. These 
Placement Check Prints typically require agreement from both the Designer and the Engineer 
before routing can proceed.

placement operations
Operations where parts are relocated or added to a design to optimize an existing placement.

plane hatch outline
The outline of a copper plane shape after it has been flooded to differentiate it from the plane pour 
outline  as originally drawn. When you draw the copper plane pour outline and then flood the shape, 
the outline often changes to accommodate the modeless command PO.

plane layers
A design layer where the entire surface is covered by copper, except for information not connected 
to the plane.

plane nets
Nets assigned to plane layers.

plane pour outline
The outline of a plane shape after it has been drawn to differentiate it from the plane hatch outline 
after it has been flooded. You can switch plane display modes using the shortcut modeless 
command PO.

plastic ball grid array
A surface mount package with an array of solder sphere-shaped interconnects arranged across the 
bottom surface of the package substrate.
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plastic leaded chip carrier
A common surface mount package with leads on all four sides, used as a socket for devices that 
cannot withstand the heat of the reflow process, and/or to allow for easy component replacement.

plated holes
Drilled holes that have copper covering the inside surface of the hole, and which are connected to a 
pad on each side. Plated holes pass connectivity from one layer to others.

plating tail
A route that connects BGA vias to a plating bar or bus bar.

PLCC
An acronym for plastic leaded chip carrier.

plicense.exe
The program used to verify and program your security key during a field upgrade process.

polar decal
A single-radius, circular pattern decal with through-hole pins.

polar SMD decal
A single-radius, circular pattern decal with SMD rectangular or finger pads.

polygon
A closed shape consisting of three or more line segments.

positive
An image of a plane layer where cleared areas, or airgaps, are created using normal drawing 
techniques. When reversed to create a negative, all areas not drawn for clearance become the 
actual planes.

power board
A board that is designed to control power to other circuit boards.

power plane
The plane layer where power supplied to the printed circuit board is dispersed to the proper pins of 
each component requiring a power source.

SailWindpcb.ini
The SailWind Layout initialization file for default settings.

powerpcb.mdb
The SailWind Layout message file that contains error messages, prompts, and other miscellaneous 
text strings. This file must be located in the same folder as SailWindPCB.exe.
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preferred routing direction
In the main GUI combo box, the Horizontal [H] or Vertical [V] designation next to a routing layer 
name. This designation indicates optimal direction for routing completion and can be set by the user 
or the system.

prepreg
A resin pre-impregnated sheet used to bond substrate laminate-pair layers together when a 
multilayer board is pressed together.

preset files
Library IQ files that enable you to save the preference settings you have established for a die 
design and use them in other designs. The Bond Pad Preferences files have a .pre  file extension.

preview of CBP assignments
A preview that displays the substrate bond pads and wire bonds created when component bond 
pads are assigned to rings. This preview appears in the work area when the Assign CBPs to Rings 
dialog box is active.

preview of SBP guides
A real-time preview that displays any changes made to the number, geometry, or location of SBP 
guides. This preview appears in the work area when the Wire Bond Wizard dialog box is active.

well as in the design in which you place the reuse.

See also private nets

primary component side
The mounted side of the board when using through-hole components. See also secondary 
component side

primary objects
Primary object groups in the Object View tab of the Project Explorer contain non-removable design 
elements shown in a high-level object hierarchy. Primary objects are:

• layers

• components

• part decals

• net objects (including nets and pin pairs)

• via types

private nets
Nets that are contained completely within a physical design reuse.

See also public nets
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probing
The testing of individual IC dice using very fine probes to temporarily connect each to a test 
computer to verify operation.

properties
A set of dialog boxes used to view or edit information about the selected object.

protect
Glues the routes and attached vias and prevents the autorouter from modifying them in any way.

protected routes
Traces that are placed in a protected state by Route Protection. This means that they cannot be 
moved or modified.

protected traces
Traces placed in a protected state (cannot be moved, or modified).

protected unroutes
Unrouted connections, or the unrouted portion of a partial route, that are placed in a protected state 
by the Route Protection feature. This means that they cannot be routed, moved, or modified.

public nets
Nets that are partially contained within a physical design reuse. Public nets exist in the reuse, as 
preferred routing direction

In the main GUI combo box, the Horizontal [H] or Vertical [V] designation next to a routing layer 
name. This designation indicates optimal direction for routing completion and can be set by the user 
or the system.

pulling an arc
Creating an arc from an existing line segment, where the diameter is derived from the line length.

QFP
An acronym for quad flat package - a surface mount IC with leads on each four sides.

quad
A square-shaped IC with pads on each of its four sides.

Quick Filter Settings
The shortcut menu selections available when no items are selected. These choices set the 
selection filter for commonly used tasks, enable quick access to the Find command, and Select All 
items as specified by the Selection Filter.

quick measure command
The Q modeless command  which attaches a measurement line to the pointer and displays dx, dy 
and hypotenuse information, depending on pointer movement.
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radial lead
A discrete part with pins that protrude straight down and do not extend beyond the perimeter of the 
component body. An example of this is a capacitor.

RAM
An acronym for Random Access Memory. The volatile (on chip rather than on disk) memory area 
available to the system for program operation.

range select
To select a series of geometric or route segments by first clicking on the start segment, then 
pressing and holding Shift and right-clicking on the end segment.

ratsnest
A term used to describe the display of all of the unrouted connections in a design. Also known as air 
lines or unroutes.

raw database
The raw database contains all components in the open database, regardless of assembly variants. 
When created, new assembly variants are based on the raw database, meaning that until you 
uninstall or substitute, a new assembly variant includes every component in the raw database.

read-only attribute
An attribute whose value cannot be changed in SailWind product dialog boxes. You can, however, 
modify attribute properties and the Attribute Dictionary entry, and can modify the attribute value in 
the library.

real width
To display traces at their specified width, as opposed to displaying them as one pixel centerlines.

real-time redraw
A feature that enables active regeneration of objects in the display any time the screen is redrawn. 
When you disable real-time redraw, regeneration occurs in the background, and the display is 
refreshed all at once after the background regeneration process is completed. Screen regeneration 
is quickest when real-time redraw is disabled.

record locking
Allowing two or more users to access the same library component at one time. However, only one 
user has access to save the component.

recover
Resolving an installation or operational issue, or salvaging a corrupt database by executing a 
specified series of steps.

redo
Repeats actions which have been undone.

redraw
Refreshes the display of the current screen image and the cursor.
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reference designator
An identification assigned to each of a design's parts to distinguish them from other parts of the 
same type when placed on the printed circuit board. A reference designator is usually in the form 
of a letter that represents the part type, followed by a number. For example, C2 may represent the 
second capacitor in the design. SailWind Layout permits you to renumber the reference designators 
in one of several specific patterns enabling you to quickly find a part among thousands on the 
manufactured board. The reshuffled numbers that are rearranged in SailWind Layout are backward 
annotated to the schematic software to keep the designs synchronized.

relative coordinates
Coordinates that are based on a start point instead of the system origin.

rename
To assign a different name to a part or net.

reroute
Specifying that a trace, or a portion of a trace, follow a path different than the one currently being 
taken.

restricted layer
Layers that are either disabled for routing or have been disallowed by layer biasing rules. When a 
layer is restricted, routing is not permitted on the layer. Layers can be restricted for specific objects, 
such as a net or a pin pair.

restricted via
A via that is not permitted for use in the Routing Rules  of SailWind Layout or Via Biasing properties 
in SailWind Router at any level of the rule hierarchy.

reuse
See preview of CBP assignments.

reuse definition
The master copy of the physical design reuse that is saved to a file. The saved version of the 
physical design reuse is the version you should use in other designs. All resulting instances of the 
physical design reuse are based on this file.

reuse type
A name that identifies the type of reuse being created. A reuse type is equivalent to a library part 
type.

ring geometry
The shape of the die flag ring. The following shapes, or ring geometries, are supported: rectangle, 
rounded rectangle, chamfered rectangle, and arced shape.

romansim.fnt
The default file that contains definitions for the graphics for the SailWind stroke font, used to display 
text in SailWind products when system fonts are not in use.
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rotate
The command that rotates by 90 degrees a component or object around its axis or selection point.

route
To create a metal etch trace of a specified width between pads.

route-completion target
This crosshair or bullseye symbol appears when routing from one pin of a pin pair to another pin or 
when rerouting a trace segment.

The partial target appears when you are overtop of an electrically compatible pin, but you have 
settings that are preventing you from routing to it - for example, the unroute of the pin pair you are 
routing is protected (you have selected the Protect Unroutes check box in the Pin Pair Properties).

route loops
A pin pair that contains a route that branches off the original route, then branches back into the 
same route to form a loop.

route pass
The autorouting pass that is the core pass that performs the majority of autorouting. During 
this pass, SailWind Router attempts to sequentially route each unroute until all connections are 
attempted. The Route pass contains serial, rip up and retry, push and shove, and touch and cross 
processes.

routed length
The trace length monitor calculates routed length as the cumulative length of the trace. Includes 
half the Discrete length value of each connected pin of components that have a Discrete length 
assigned. If you start routing from the endpoint of a partially routed trace, the routed length includes 
the partially routed trace length. If the trace has branches, then the length is calculated from the 
branch point.

See also estimated total length, unrouted length

routes
A series of traces that represents routed connectivity.

routing angle
The angle applied to adjacent segments as new corners are added to traces. For example, an 
orthogonal routing angle means adjacent segments will be created at 90-degree angles to each 
other.

routing order
The order in which the autorouter routes components, nets, and net classes.
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routing pass types
There are several pass types, each of which is designed to complete a specific task. Each pass 
may use more than one algorithm and may also perform a number of subpasses.

• center pass

• fanout

• miters pass

• optimize pass

• patterns pass

• route pass

• test point pass

• tune pass

routing strategy
The collective information SailWind Router uses to autoroute a design. This information includes 
which pass types SailWind Router should perform, whether to protect  the resulting traces, and what 
intensity  to assign to objects.

ru.cfg
A configuration file used by the nrus.exe program for Novell network security support.

rule values
The values of any item, regardless of its default rules or rules set assignments.

rules
An established set of conditions for a given net or design.

rules set
A specific set of user-assigned nondefault rules such as pin pair, groups, or classes.

same net checking
Checks clearances between objects along the same net, as specified in the Clearance Rules dialog 
box. Object to object checking includes:

• Pad edge to pad edge.

• Pad edge to inside corner of trace.

• SMD edge to pad edge.
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• SMD edge to inside corner of trace.

This check prevents solder bridging during board manufacturing caused by acute angles between 
conductive objects such as the acute angle between pad and trace shown below.

same net rules
Specifying conditional settings, such as spacing, for connections belonging to the same signal 
name or net, rather than against other nets.

SBP
An acronym for Substrate Bond Pad.

SBP fanout
A single-segment fanout that connects SBPs to any-angle coupling traces.

SBP guide
The virtual snap line along which substrate bond pads are aligned during wire bond fanout 
generation. Each SBP guide determines the alignment of the substrate bond pads that are 
associated with the SBP ring aligned with this SBP guide.

SBP ring
A set of substrate bond pads aligned along an SBP guide. A substrate bond pad belongs to the ring 
on which it is aligned. In creating a wire bond fanout, you assign each component bond pad to a 
specific SBP ring.

schematic-driven design
The “standard” PCB design process, in which a netlist is first created in a schematic tool, and then 
passed to a layout tool, where the parts are laid out on the board and the connections routed. See 
also layout-driven design.

scribe line or saw line
The separation between adjacent dies on the wafer. This path is used as the cutting area in sawing 
a wafer into the individual dies.

search
To locate specified information. One search method is to use the Find command.
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secondary component side
The side opposite the mounted side for through-hole components. This side is typically wave 
soldered.

See also primary component side

secondary objects
Secondary object groups break primary objects into a more detailed hierarchy. You can add 
individual items to and remove individual items from secondary groups. Secondary objects include:

• net class

• pin pair group

• conditional rule

• matched length net group

• matched length pin pair group

• differential pair

seed
A part used by Cluster Placement, during cluster building, to search outward for other parts to add 
to the cluster.

segment
A single drafting line, path, or trace, defined by a beginning x/y coordinate and an ending x/y 
coordinate.

segmentation fault
The termination of a SailWind product due to a system crash or illegal instruction executed.

Select All
The Edit menu command that lets you select all items of a type specified in the Selection Filter. This 
option is also accessible from the shortcut menu when nothing is selected.

select mode
Point to the object and click the left mouse button. Select the command to perform on the object.

selecting
To highlight an object for editing, moving, viewing properties, or deleting.

selection filter
The dialog box inhibiting or enabling the selection of specific items.
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serpentine route
A route that connects an any-angle coupling trace and a BGA pad, forming a snake-like pattern as it 
travels through the BGA.

session log
Information on the current session that appears in the Status tab of the Output window.

shape
The Selection Filter setting that enables or disables selection of an entire geometric object, not just 
its individual segments.

shared libraries
Libraries that can be accessed by more than one user across a network.

shielding
Specifying that one net be routed around another to provide protection from interference.

shortcut keys
A key sequence that starts a command directly from the keyboard and without navigating through 
menus.

shortcut menu
A menu listing the possible actions to perform, based on the selected object.

shoulder
The part of the differential pair trace between the source pin and the gathering point, or between the 
split point and the destination pin.

See also differential pairs, gathering point, split point.

signal
Voltage or current that is transferred between component pins by an electrical conductor.

signal pins
Pins that have a signal net, such as GND, assigned by the schematic capture program SailWind 
Logic during part type creation.

signal via
Via used to continue a signal from one layer to another.

silkscreen
An artwork layer containing the reference designator and component outline of all parts, used for 
the final board fabrication process.
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single-sided board
A design where all pads, routing, and parts are placed on one side of the board.

single-sided die
A die that has substrate bond pads and a BGA grid array on the same side of the die.

See also documentation layers

sizing handles
Small, black squares that appear at the corners and along the sides of a rectangular area that 
surrounds a selected nontext object.

sketch route
A SailWind Layout command that reroutes existing traces by enabling you to draw a new route path 
using the pointer.

slice
Another term for wafer.

slotted holes
Oval holes in a printed circuit board, which may be plated or non-plated.

SMD
An acronym for Surface Mounted Device: the pin of a component that is attached to the PCB only 
on an outer surface and does not require drilled holes for component mounting.

smoothing
A command that automatically removes unneeded corners and segments and centers trace 
patterns between route obstacles.

SMT
An acronym for Surface Mount Technology.

snap modes
Various modes, available during dimensioning, that force the pointer to pick points based on of the 
following parameters: intersection, any point on a line, any point in space, entire segments, the 
center point of an arc, and so on.

soft rule
A rule that is ignored if it alone prevents route completion. See also hard rule, and Hard and Soft 
Rules, in the SailWind Router User Guide.

SOIC
An acronym for Small-Outline Integrated Circuit.

solder
A metal alloy used to attach each pin of a device to a printed circuit board.
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solder dam
A small amount of solder mask used to limit molten solder from spreading further onto solderable 
conductors, in an area where solder mask is purposefully absent.

solder mask
The artwork layer for a nonconductive material that covers the entire board, except for pad 
locations. The solder mask provides a protective covering and prevents shorts during wave and 
reflow solder processes.

solder mask reliefs
Some components have large areas that need to dissipate heat. Others have large metallized areas 
(that are not pins) that need to be soldered to the board. To expose the copper area beneath these 
parts for soldering, the solder mask layer must have a cutout representing these areas. These 
cutouts are called solder mask reliefs. When the distance between pads of a fine pitch component 
is too small, the webs or fingers of solder mask between pads can break and wander on the board 
surface. To prevent this, a solder mask relief is applied to entire pad areas of a component. This is 
commonly called gang relief or a gang opening.

solder side
The back or bottom side of a printed circuit board. Solder side is named for the post assembly 
process, where the board is run through a special bath to solder all pins.

source
A pin type that indicates a signal radiating from the pin.

SPECCTRA
The product name for the Cadence Design Systems autorouter.

special symbols
Alternate decals that you specify as connectors. You can associate a logical pin type with each 
alternate to provide a graphical indication of the connector pin function in a schematic.

spider bonding
A method of connecting an integrated circuit die to its package leads. A lead frame is placed over 
the chip and all connections are made by just one operation of a bonding machine. TAB  methods 
use this approach to interconnection.

spin
The command that rotates a component or object around its axis or selection point.

split
The command that creates a new corner at the pick point of the selected trace, enabling it to be 
rerouted.

split plane
A solid copper plane layer divided into two or more sections to isolate electrical signals from each 
other.
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split point
The point near the destination pins where differential pair traces are no longer routed together and 
where the traces are routed individually to completion.

See also differential pairs, pair routing gap

ssiact.exe
A program used to recommend set statement settings to properly adjust port access times for a 
security key.

stackup
The metal and dielectric layers used to implement the body of a printed circuit board. A signal metal 
layer carries signal traces. A plane metal layer is tied to a DC voltage. A dielectric layer is made 
from non-conducting material and separates two metal layers or coats the board surface.

start zone
The part of the differential pair between the source pins and gathering point.

See also differential pairs, gathering point

starting layer
The first layer in a drill pair or via definition.

step-by-step mode
A mode in which the debugger runs a single line of code at a time.

stitching vias
Any SMD via, through-hole via, or partial via added to nets (on traces or within plane areas) in a 
repetitive manner. You can add these vias, also called free vias, for various purposes, including 
current and thermal needs. For example, you can place stitching vias in a plane area to provide 
conduction between two plane areas. You must assign stitching vias to a net, but they do not have 
to have traces attached to them.

strategy
A set of options that defines how a board should be autorouted.
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strong

strong
Places cluster members as close together as possible during placement operations. The minimum 
distance for placement is the same as the distance for part clearances in Design Rules.

structured attributes
Attributes that are related to each other by the prefix in their name. For example, the DFT attributes 
such as DFT.Nail Count Per Net, DFT.Nail Number, and DFT.Nail Diameter are structured attributes. 
Together, these structured attributes make an attribute group.

stub
A trace that enters another to create a T-junction. Stub lengths can be checked by the EDC 
program.

submicron
Dimensions smaller than one micron.

subnet
A collection of all traces and vias connecting two pins. Subnets are joined only through their 
common component pins and not through other nodes, such as a trace junctions, vias, or virtual 
points.

Subnets help to avoid errors or confusion caused when pin pairs of a net have unique, rather than 
common, design rules.

See also node, subnet, connected islands, virtual point.

Figure 162. One subnet in a net

subnets
If a net has at least one pin pair with a unique design rule, such as a trace width difference, the 
net is automatically divided into subnets. If two pin pairs having the same rules are separated by 
at least one pin pair with different rules, the pin pairs are considered separate subnets. Therefore, 
subnets are islands of pin pairs that form an unbroken fragment within the net, where each fragment 
has uniform rules.

See also differential pairs, differential pairs.

Figure 163. Multiple subnets in a net
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substrate
A material between copper laminate layers that comprise a laminate pair, or a laminate set in the 
case of completed multilayer boards.

substrate bond pads
Copper areas on the substrate to which a die's wire bonds are connected.

surface mount device
Pads are glued to the board rather than inserted.

swap file
The file created when a program runs out of RAM memory and writes memory to disk.

swapping
A placement optimization process that exchanges pins, gates, or entire parts.

The product .ini  file entry that specifies the path for the SailWind product configuration files.

system attribute
An attribute that is set by, used by, and critical to a SailWind product, an external program, or 
Automation script (such as Sax Basic). You cannot modify the properties of a system attribute or 
modify the Attribute Dictionary entry for a system attribute.

system toolbars
System toolbars are specific to the SailWind programs. They feature several system toolbars, such 
as standard, routing, selection filter.

SystemDir
The product .ini  file entry that specifies the path for the SailWind product configuration files.

T junction
A trace that branches into another.

TAB
An acronym for source.

tacks
Small, diamond-shaped objects that anchor traces to their current location. Tacks are automatically 
generated under certain conditions and may also be manually added to a selected trace.
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tandem traces

tandem traces
Traces on different layers that are checked for running parallel to each other.

The traces are subject to crosstalk if they run parallel to each other too long and the gap between 
them is too short.

Tape Automated Bonding (TAB)
A packaging method where silicon chips are joined to patterned metal traces, or leads, on polymer 
tape to form inner lead bonds which are attached to the next level of the assembly, typically a 
substrate or board.

Tape Ball Grid Array (TBGA)
A TAB packaging method in which tape automated bonding leads are replaced by a ball grid array.

TBGA
An acronym for Tape Ball Grid Array (TBGA).

teardrop
A triangle shape that provides a smooth transition from a trace to a pad.

tented vias
Vias that are covered by solder mask on both sides of the board to seal the hole and protect it from 
wave solder.

terminal
The electrical center of a pin, as defined in the part decal.

terminator
A pin type for high-speed circuit configurations that indicates a terminating resistor to match 
impedance of the trace. Terminators are used to reduce signal reflections that cause poor circuit 
performance.

test point
A test point is a group of objects that serve as a contact between the electrical element of the board 
and the probe of the testing device. A test point can also be a point on a node of a net, component 
pin, or via. Test points can also be a point on an unused component pin, such as a component pin 
that is not incorporated into any net.

When the via or pin is flagged as a test point, and Show Test Points is checked on the Routing tab 
of the Options dialog box, a down arrow symbol is drawn on the via or pad in the design:

test point pass
This autorouting pass analyzes the testability of the design, determines which nets require testing, 
adjusts the routes, and inserts test points to improve testability. You can select whether to add test 
points during routing or after routing.
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testpnts.fmt
An ASCII file containing information about test points, including the test point name, the signal 
name, and the x/y coordinates. The report file generator creates this file.

thermal
A multi-spoke connection of a through hole pin pad, via, or surface mount pad to a copper plane.

thermal compression bonding
A method of wire bonding that does not use an intermediary metal or melting, but rather the 
flow of materials resulting from the combination of heat and pressure. It is also referred to as 
thermocompression bonding.

thermal relief
A spoke-shaped pattern that connects a via or pin, in the same net as the copper plane, to the 
surrounding copper. Thermal reliefs provide good pin soldering by preventing heat from dissipating 
throughout the plane layer.

thermal via
Via used to dissipate heat from an area or component.

thick-film process
A hybrid microelectronic process where conductors, insulators, and passive components are 
screened from special pastes onto the substrate.

thin-film process
The use of deposited films of conductive or insulating material, which may be patterned to form 
electronic components and conductors on a substrate or used as insulation material between 
successive layers of components.

three-state check box
A three-state check box helps to identify the state of the check box in a collection of objects.

Check box Description

Cleared check box. The item or collection of items all have the check box in the 
cleared or unchecked state.

Selected check box. The item or collection of items all have the check box in the 
selected or checked state.

Indeterminate or mixed state check box. The collection of items have different 
states of the check box.

through holes
Although there are non-plated through holes, this term is used interchangeably with plated through 
holes. It indicates that the hole has internal plating. There are two basic types of components that 
can be placed on a circuit board: Surface Mount Technology (SMT) where the parts are soldered 
to the surface of the board, and through hole (TH) components, where the components have wire 
leads that are soldered into plated holes that go through the board (sometime written as thru-holes).
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through-hole via
A via that passes through all electrical layers of the PCB design (as opposed to a partial via).

This is sometimes also called a through via.

tooling holes
Every board requires at least two tooling holes that the blank board manufacturer uses for layer 
alignment purposes during the manufacturing process. If you do not include them in the design, 
the manufacturer will add them to the board. Tooling holes are typically .125" non-plated holes with 
a tolerance of +/-.002". If the board is so small that the tooling holes will not fit, the manufacturer 
will add them to an area outside of the board outline. (These would typically get removed after final 
assembly.) There are two types of tooling holes: board tooling holes and panel tooling holes. Most 
boards are manufactured by stepping and repeating the single board image onto a larger panel so 
that multiple boards can be processed on a single panel. So, the board tooling holes are used for 
alignment purposes for individual boards, while the panel tooling holes are used for alignment of the 
entire panel during the manufacturing and assembly processes.

Use the Decal Editor and the Pad Stacks dialog box to create tooling holes. Save the single-
terminal object as a part to the library for reuse.

See also Editing Pad Stacks

ToolTips
ToolTips appear below buttons and provide a command name or description for the buttons.

topology
The pattern of the trace and the order in which to connect pins in a net.

total length
The current routed length plus the total Manhattan length for remaining unroutes of the electrical net 
or pin pair. Includes half the Discrete length value of each connected pin of components that have a 
Discrete length assigned.

Total length is reported for pin pairs when all the following are true: length rules are defined for the 
pin pair, the electrical net is a high-speed net, and copper sharing is disabled.

If pin pair rules are reported, the estimated total length of the pin pair is shown; otherwise, total 
length for nets is reported.

trace
A line segment that represents physical etch. A trace can appear as a single pixel line or as a 
double line to indicate its actual width.

trace corner
The vertex at which two trace segments are joined. A trace corner can also be the endpoint of a 
partially routed trace. The trace segments may be in line.
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trace paths
A continuous sequence of trace segments in the same trace on the same layer. Paths start and end 
at nodes, and cannot pass through a node.

trace segment
One section of a trace. A trace segment has one starting point and one ending point. A trace 
segment can be arced.

Trace segments are contiguous when they are joined end to end, in one continuous path, and 
belong to the same trace.

transparent layers
The mode that displays layers in a see-through mode so you can view multiple objects stacked 
upon each another. This is the modeless command T.

TrueLayer
The default mode of operation in SailWind Layout whereby an object on a documentation layer 
moves with a component if the component is moved from one side of the board to the other. For 
example, when you place a component on the top layer of the board, the reference designator of 
that component is visible on the Silkscreen Top layer (the documentation layer associated with the 
top layer of the board). Moving the component to the bottom side of the board automatically moves 
the reference designator for the component to the Silkscreen bottom layer.
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TTL

TrueLayer also correctly plots paste masks of documentation-level pad shapes in CAM. The layer 
that the definitions move to is set in the Component Layer Associations dialog box.

By default, TrueLayer mode is enabled. To disable it, use the /NTL command-line switch. See 
Software Launch Options.

TTL
Acronym for Transistor-Transistor Logic.

tune pass
This autorouting pass adjusts the length of length-controlled traces. The pass examines trace 
lengths for only completely routed nets or pin pairs. The pass analyzes the current length of each 
net or pin pair if length rules and length control are enabled, based on the following conditions:

• If the cumulative length of the adjacent trace segments is within the range of minimum and 
maximum trace length, the tune pass skips the trace and does not adjust it.

• If the trace is longer than the maximum trace length, the tune pass rips it up and places it in 
a queue for routing.

• If the trace length is less than the minimum trace length, the tune pass changes the length 
by adding accordion patterns.

ultrasonic bonding
A wire bonding technique that uses ultrasonic energy and pressure to form the bond without heat.

underfill
Material injected under the die to ensure interconnect reliability against #unique_1408  mismatch 
between the die and the substrate in a flip chip  configuration.

undo
A command that enables you to remove the effects of the last command invoked.

undock
To isolate an application dataset from the main design project so it can be edited regardless of the 
network or the physical location of the dataset. The isolated dataset has no dependence on the 
main design project.

UndoMemorySize
The SailWindpcb.ini  file entry that limits the maximum size of the buffer that is used to store ECO 
operations for Undo.

unions
Parts assigned to each other in fixed relative positions using Cluster Placement. These positions 
are maintained whenever a union is moved in Cluster Placement. A common example is the 
relationship between bypass capacitors and ICs.

units of measure
A commonly used set of measurements.
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unroute
To convert a trace back into a connection.

unrouted length
The trace length monitor calculates unrouted length as the distance from the endpoint of the current 
trace segment (attached to the pointer) to its destination.

The unroute length calculation depends on the current routing angle:

Routing mode: The calculation:

Orthogonal Manhattan Length

Diagonal   The length of the shortest diagonal path between unroute ends

Any Angle Point-to-point distance

The unrouted length is recalculated as the unroute dynamically reconnects to connection points. 
The routing angle also effects this calculation.

See also routed length, estimated total length

unroutes
Thin, straight segments joining pins or coppers to indicate connectivity. Also called a link.

unused pins
Pins that are not connected to a net.

UserDir
An .ini  file setting that specifies the path for SailWind product configuration files.

verb mode
Start a command by attaching a command to the pointer and then selecting objects to which you 
apply the command.

You can enter verb mode by selecting a command when no objects are selected. A small V 
attaches to the pointer to show that the selected command is active. The command remains 
attached to the pointer until you cancel verb mode.

See also object mode

vertex
A single point in the work area, defined by x and y coordinates.

via
A drilled and plated hole that passes conductivity from one layer to another.

via pair
A pair of vias used to change the routing layer for a differential pair when routing the controlled gap 
area.

802 SailWind Logic Guide



 
Glossary
via type

See also via, differential pairs.

via type
A via or virtual pin padstack definition that is defined and named in SailWind Layout in the Pad 
Stacks Properties dialog box.

victim net
Nets that are interfered with by those tagged as aggressor nets during High-Speed or 
Electrodynamic Checking.

virtual memory
Writing memory areas to disk in the form of a swap file when RAM is filled. The size of the swap file 
is based on the free disk space or the limits imposed by the operating system.

virtual pin
A net object that, like a component pin, serves as a pin pair end, but uses the pad stack of a via. 
The pad stack can be through-hole or partial, or it can be a single-layer pad.

virtual point
A point along a trace segment that identifies a change in design rules, usually between trace rules 
and component rules. Virtual points are inserted into nets automatically when necessary, usually 
during autorouting operations. You cannot create, position, or otherwise edit a virtual point.

See also subnets

Visual Basic
Visual Basic is a scripting language developed by the Microsoft Corporation to enable users to 
customize applications using a standard scripting language.

visual editing
Visual Editing occurs when the source application for a linked or embedded OLE object opens 
within the container application.

wafer
A thin disk of semiconductor material (usually silicon) on which many separate chips can be 
fabricated.

wafer sort
The electrical testing of each die on the wafer  while still in wafer form.

WB
An acronym for wire bond.

wedge bonding
A form of thermal compression wire bonding where the bond shapes the wire into a wedge shape.

width
The thickness of a trace or line.
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wire bond
Fine wires, usually aluminum or gold, connecting the bonding pads on a die to the component 
package.

Wire Bond Editor
The Wire Bond Editor opens (explodes) a selected die part, so you can move, add, delete, and edit 
individual component bond pads and wire bonds in addition to substrate bond pads. You can also 
edit the die size.

wire bond fanout
A pattern of wires (typically gold) that arc out from component bond pads to substrate bond pads to 
provide connectivity between the die pins and the substrate package pins.

Wire Bond Wizard
A BGA toolbox feature that creates and places substrate bond pads and generates an automatic 
wire bond fanout between component bond pads and substrate bond pads.

wire bonder
The machine that connects wires between the chip bond pads and the substrate bond pads.

wire bonding
The process of electrically connecting a chip to the next level package with fine wires. The wires are 
either gold or aluminum.

workspace
The actual work area where a design is created.

yield
The ratio of the number of acceptable units to the maximum number possible.

Z routing pattern
A collection of routes that form a pattern resembling the letter Z.

zoom
Modifying the view to make objects appear larger or smaller. Zooming in or out affects the amount 
of what can be viewed in the work area.
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zoom

See also protect.
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Third-Party Information
Details on open source and third-party software that may be included with this product are available in the 
<your_software_installation_location>/ThirdParty  directory.
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