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Learning the User Interface Tutorial 
The SailWind Logic user interface is designed for ease-of-use and efficiency. SailWind Logic 
is designed to meet the needs of the power user, while keeping the beginner in mind. 

SailWind Logic's interface and interaction are similar to other Windows™ applications. You 

can interact with SailWind Logic using the keyboard, menus, toolbars, and shortcut menus. 

In this lesson: 

 Keyboard command shortcuts 

 Using the workspace 

 Panning and zooming 

 Selecting objects 

Preparation 

If it is not already running, start SailWind Logic, and click File > New. 

Keyboard command shortcuts 

You can use keyboard shortcuts to start commonly used commands or to set options. You will 
use some of the shortcuts throughout the tutorial. 

Keyboard shortcut types: 

Type of shortcut Description 

Modeless Commands Commands invoked through the keyboard. The available 
commands handle display options, design settings, and 
mouse click substitutions. 

Shortcut Keys Commands that change settings or execute commands 
without using the mouse. Windows shortcut keys, such 
as Alt+F to open the File menu, are also used. 

Using the workspace 

The default workspace measures 56 inches by 56 inches. The origin of the 
workspace, or 0,0 coordinate location, is represented by a large white marker. When 
you start SailWind Logic or open a new file, the origin is located at the lower-left 

corner of the sheet, at a medium magnification. The large white rectangle represents the area 
of the workspace occupied by the schematic sheet. For a size B schematic the area is 11 x 
17. For a size C sheet it is 17 x 22, and so on. 
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Pointer position display 

As you move the pointer around the workspace, its position, in absolute X,Y coordinates 
relative to the origin, appears on the Status Bar at the lower right corner of the screen. 
Throughout this tutorial you will refer to this coordinate data. 

1. Place the pointer over the origin point and note the 0,0 reading on the Status Bar. 

2. Move the pointer around the workspace and note how the X,Y coordinates change as the 
pointer position changes. 

Set the sheet size 

1. Tools menu > Options > Design tab. 

2. In the Sheet area, locate the Size list. Leave the current sheet size and click OK. 

Open a previously saved file 

To make it easier to view changes in magnification, open the file named preview.sch in the \ 
SailWind Projects\Samples folder. 

Tip: If you have made any changes to the previous design, a dialog box appears prompting 
you to save the old file. Click No. 

Panning and zooming 

Several methods exist for controlling the centering and magnification of a design. In this 
exercise, you are going to use the mouse. 

For two-button mouse operations, the Zoom icon enables and disables Zoom mode. Clicking 
Zoom from the View menu can also enable it. While in Zoom mode, the pointer changes to a 
magnifying glass. For three-button mouse operations, Zoom mode is always available using 
the middle mouse button.  

Tip: Because some manufacturers give the center mouse button a specific function, you may 
need to de-activate default mouse button functionality before you can use these features in 
SailWind Logic. Change mouse functionality using the Control Panel. 

Zoom in and out by placing the pointer at the center of the area and dragging in a specific 
direction. Pan and Zoom functions are also available using commands from the View menu, 
using the numeric keypad, and using the scroll bars. See SailWind Logic Help for more 
information on Pan and Zoom functions. 

Practice zooming 

The following procedure assumes you are using a two-button mouse, except where noted. 

1. Click the Zoom button  . 

Exception: If you are using a three-button mouse, skip this step. 
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2. Zoom in. 

a. Click and hold the left mouse button in the center of the area you want to magnify. 

Exception: If you are using a three-button mouse, click and hold the middle mouse button. 

b. Drag the pointer upward, moving the mouse away from you. A dynamic rectangle 
attaches to and moves with the pointer.  

c. When the rectangle encompasses the area you want to magnify, release the mouse 
button to complete the operation. 

3. Zoom out. Repeat Step 2, but drag the pointer downward, moving the mouse towards you. A 
static rectangle, representing the current workspace view, appears with a dynamic rectangle 
representing the new view of the workspace.  

4. Practice using Zoom mode to adjust the magnification.  

Tip: To re-establish the original view, click Sheet on the View menu. 

5. Click the Zoom button again to end Zoom mode. 
Exception: If you are using a three-button mouse, skip this step. 

Pan 

Position the pointer in the direction you want to pan and click the middle mouse button. The 
new view changes to make the location of the pointer the center of the view. 

Selecting objects 

When selecting parts, place the pointer on the outline of the part, and then click. Clicking 
inside the body of the part does not ensure selection, especially with larger parts. 

Selection Filter 

Since many types of objects make up a CAE Decal (schematic symbol) and many additional 
objects are found on a schematic sheet, a selection filter facilitates the selection of a single 
type of object. 

1. Resize your view to fit an area around component U2 and U4 as shown below. 
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2. Right-click and click Filter. 

Alternative: Press Ctrl+Alt+F to open the Selection Filter. 

3. In the Selection Filter click Anything. Notice that Parts and Nets are not selected but 
everything else is selected. 

4. Close the Selection Filter. 

5. On the schematic, click the connection segment attached to U4 pin 14. The whole net is not 
selected, just the one connection segment.  

6. Right-click and click Cancel to deselect the connection segment. 

7. Right-click and click Select Connections. Click and select the same connection segment. 
All connection segments leading to the tie dot are selected. Right-click and click Select Net 
Instance. All connection segments of this net instance are selected. Right-click and click 
Delete. The connection is deleted.  

You cannot delete individual connection segments. To delete nets or portions of nets you 
must select connections, net instances or an entire net and apply the delete command. 

Tips: 

 You can quickly change Selection Filter settings using the filter presets. With nothing 
selected in the design, right-click, and click one of the Select commands. 

 The Selection toolbar also contains buttons for Selection Filter settings. 

 Right click and click Cancel and Delete or use the Esc (cancel) and Delete buttons on 
the keyboard instead. 

8. Do not save a copy of the file. 

You completed the learning the user interface tutorial. 
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Creating Library Parts Tutorial 
You create the library elements that compose a part type in the SailWind library using the 
Library Manager and the PCB Decal Editor.  

In this lesson: 

 Understanding the SailWind part type 

 Creating a CAE decal 

 Creating a new part type 

Preparation 

If it is not already running, start SailWind Logic.  

Understanding the part type 

Before you can add a part to a schematic, it must exist as a part type in the library. A part type 
is composed of three elements: 

 The schematic symbol, or CAE decal as it is called in the library. 

 A component footprint, or PCB decal as it is called in the library. 

 Electrical parameters, such as pin numbers and gate assignments. 

An example of a part type is a 7404.  

Element Description 

Part type name: 7404 

CAE decal: INV (inverter) 

PCB decal: DIP14 (14 pin dual in line package) 

Electrical parameters: Six logical gates (A through F) using 12 of the 14 

pins with one power pin and one ground pin. 

 
You can create a part type in SailWind Logic or in SailWind Layout; however, you can only 
create a CAE decal in SailWind Logic, and a PCB decal in SailWind Layout. 

CAE decals 

Each part added to a schematic must have a CAE Decal to graphically represent the logical 
function of the part. While some parts are represented entirely with a single CAE decal, others 
are composed of multiple instances of the same CAE decal, such as part 7404, the multi-
gated inverter mentioned above. 

A CAE decal is composed of pin decals attached to terminals placed at intervals around a 
graphic symbol. This entity represents all or part of the device. The terminals can be assigned 
pin names to represent the logical function of the pin, such as IN, OUT, or VSS. All elements 
of a CAE decal are created in the Part Editor. 
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Creating a CAE decal 

In this exercise you will use the CAE Decal Wizard and other features to create a CAE decal 
for the 87C256 part type shown in the graphic below. 

 

Create a CAE decal 

1. Tools menu > Part Editor. 

2. On the Part Editor toolbar click the Edit Graphics button  , and then click OK to confirm 
the creation of a new CAE decal with a default name. 

Once you enter the CAE Decal Editor, several text labels and a CAE decal origin marker 
appear. 

Each of these labels are placeholders for CAE decal-related text objects. The position of these 
labels on the CAE decal determines where the CAE decal text object appears in the 
schematic. The origin marker serves as the origin for moving or positioning the CAE decal on 
the schematic. Select the labels and move them to where you want. 
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Label Placeholder 

REF The reference designator 

PART-TYPE The part type (7404, 74LS74, etc.) 

*Free Label 1 The first displayed part type attribute 

*Free Label 2 The other displayed part type attribute 
 
Tip: An attribute is a specific type of part information that can be included in the part's library 
description and exported to a parts list. Examples are part manufacturer, package type, and 
part number. 

Create CAE decals with the CAE Decal wizard 

1. Decal Editor Toolbar button  > CAE Decal Wizard button  

2. In the Box Parameters area, type 800 in the Min Width box. 

3. In the Left Pins area, select PIN as the Pin Decal, and type 19 in the Pin Count box. 

4. Type 0 in the Right Pins, Upper Pins, and Lower Pins - Pin Count boxes. 

5. Click OK to create the CAE Decal. 

You now have the beginning of a CAE decal. This process creates a CAE decal with 19 
terminals (the small X at the end of the pin decal) each having a PIN type pin decal. 

See also: SailWind Logic Help for details on the relationship between terminals and pin 
decals 

Add a new terminal 

At this stage, the CAE decal is not complete. You must add output pins and modify some of 
the symbols on the input pins. 

1. Add Terminal button  . 

2. Click the PIN decal from the Pins list, and click OK. 

3. With the new terminal attached to the pointer, right-click and click X Mirror. This mirrors the 
terminal on the X-axis, or horizontally. 

4. Position the terminal on the right side of the symbol, at X1000,Y1900, and click to place the 
terminal. 

Add new terminals with step and repeat 

After you add a terminal, SailWind Logic remains in Add terminal verb mode; the next new 
terminal attaches to the pointer. Instead of adding the next terminal as you did above, use the 
Step and Repeat feature to add several terminals quickly. 

1. With the next new terminal attached to the pointer, right-click and click Step and Repeat. 

2. Select Down as the Direction, type 7 in the pin Count box, and type 100 in the Distance box.  

3. Click OK. 

4. Right-click and click Cancel to exit the Add Terminal verb mode. 
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Modify terminals 

Now that you have added the output pins, use the other terminal commands to modify the 
input pin arrangement and complete the CAE decal. The input pins consist of 15 address 
inputs, 3 control inputs and one extra input pin. The pin decals for two of the control inputs 
need modification and you must remove the extra terminal. 

1. Change Pin Decal button  

2. In the Pin Decal Browse dialog box, click the PINB pin decal in the Pins list. 

3. Click OK. You are now in a pin decal assignment mode. Any terminal that you select is 
assigned the PINB pin decal. 

4. Select the two bottom input terminals on the left side of the part (terminals #18 and #19) to 
change the pin decal on both from PIN to PINB.  

5. Right-click and click Cancel to exit Change Pin Decal mode. 

6. Right-click and click Select Terminals. Select the fourth terminal from the bottom (terminal 
#16).  

7. Right-click and click Delete. The terminal numbers following terminal #16 are renumbered to 
accommodate the deletion. 

8. On the View menu, click Extents to fit the completed decal in the view. 

Alternative: Press Ctrl+Alt+E to view Extents. 

Assign pin numbers and pin names to a gate 

1. Set Pin Name button  . 

2. In the Start name of a terminal dialog box, type Q0 and click OK. 

3. Select the top-most output pin (on the right side of the component) to assign it pin name Q0. 

4. Select the output just below pin Q0 to assign it pin name Q1. 

5. Select the remaining output pins, in order, to assign the names Q2 
through Q7.  

6. Right-click and click Cancel to exit the current naming mode. 

7. Repeat steps 1 and 2, typing A0 in the Start Name dialog box, and clicking OK. 

8. Select the top-most input pin (on the left side of the component) to assign it pin name A0. 

9. Select the input pin just below the A0 pin to assign it pin name A1. 

10. Select the remaining input pins, in order, to assign the names A2 
through A14.  

11. Right-click and click Cancel to exit the current mode. 

 
Two of the remaining pins have logical NOT pin name labels (bars over the name). To create 
this type of text, use the \ character. Assign the remaining pin names. 

1. Right-click and click Select Terminals. Select the input pin below A14.  

2. Right-click and click Properties. 

3. In the Terminal Properties dialog box, in the Name box type \PGM\ / \CE being careful to not 
use spaces in the pin name.  
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4. Click OK.  

5. Click in empty space to deselect the terminal. The remaining pins will be assigned a pin 
name later in this tutorial. 

 

To finish defining the decal, set pin numbers for the terminals in the same manner as 
assigning pin names. 

1. On the Decal Editing Toolbar, click the Set Pin Number button  .  

2. In the Set Pin Numbers dialog box, accept the defaults and click OK.  

3. Select pins, in the order shown in the 87C256 graphic at the beginning of this tutorial. Stop 
after you assign a pin number to pin Q2 and proceed to the 
next step. 

4. Select pin Q3.  

Result: After you select pin Q3, it is assigned pin 14. Pin 14 was previously assigned as a 
signal pin for GND in the electrical parameters.  

5. To change Q3 pin number to 15, select pin Q3 a second time; it is assigned the next highest 
pin number. 

6. Select pin Q4 to assign it as 16.  

7. Continue assigning pin numbers to the remaining pins. 

If you assign the wrong pin number, click the Set Pin Number button again, enter the new 
number and click the terminal. 

Name the CAE decal and part type 

1. File menu > Return to Part. 

2. Click Yes to keep gate changes. 

3. On the File menu, click Save As.  

4. In the Save Part and Gate Decals As dialog box, double-click in the Name of Part box, and 
type 87C256.  

5. In the Names of Gate Decals box, double-click NEW_PART under the CAE Decal 1 column, 
and type 87C256.  

6. Switch the Library to \Libraries\preview. 

7. Click OK. Confirm the overwriting of the CAE decal if it already exists.  

8. Click OK to the warning of no assigned PCB Decal. Confirm the overwriting of the Part Type 
if it already exists. 

Creating a part type for the CAE decal 

Now you will add electrical properties to the 87C256 part type and assign it a PCB decal. 

Assign a family type 

The first step in creating a part type is to assign the family type for the part. 

1. Edit Electrical button > General tab. 
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2. In the Logic Family list, switch to TTL to assign it as the family type for the part type. This 
simply assigns a default reference designator prefix of U. 

Note: The Pin Count displays only 26 pins. 

Assign a PCB decal 

The next step in creating a part type is to assign the 87C256 CAE decal and assign a 28-pin 
PCB decal. 

1. PCB Decals tab. 

2. In the Library list, switch to the \Libraries\common library. 

3. Type so* in the Filter box, type 28 in the Pin Count box, and click Apply. 

4. Click the SO28 PCB decal, and click Assign to assign the PCB decal as the first (and only) 
PCB decal for the part type. This has also increased the Pin Count for the 87C256 part type. 

Update the pin settings 

1. Pins tab. 

2. Examine Gate A, the first (and only) gate of the part type. 

3. Scroll down the list of pins to Seq. number 17 and 18. These should be pins 22 and 1. 

4. For Seq. 17 (pin 22), double-click in the Name box, and type \OE. 
Press Enter. 

5. For Seq. 18 (pin 1), double-click in the Name box, and type VPP.  
Press Enter. 

Tip: If you want to use pin swap, terminator assignment, and topology tools in SailWind 
Layout, the Swap (pin swap) and Type (pin type) values for gates must be set. You can leave 
them as they are for this exercise. 

Assign signal pins 

Next, assign the standard power and ground pins. These are called signal pins 
in SailWind Logic. 

1. Scroll down the list of pins to the bottom. 

2. For pin 14, in the Pin Group column, click Unused Pin and change it to Signal Pin.  

3. Repeat for pin 28.  

4. Double-click in the Name box for pin 14, and type GND. 

5. Double-click in the Name box for pin 28, and type +5V. 

Add user-defined attributes 

Finally, you will add user-defined part type attributes. 

1. Attributes tab. 

2. Click Add. 

3. Click Browse Lib Attr. 
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4. In the Browse Library Attributes dialog box, click Description and click OK. 

5. Press Tab to switch to the Value cell, and type 32K X 8 BIT CMOS EPROM/LATCH. 

6. Click Add, click Browse Lib Attr again, and repeat the previous steps to add the following 
attributes and values: 

 

Attributes Values 

Cost (leave blank) 

Part Number 87C256 

Manufacturer #1 SIGNETICS 

Manufacturer #2 (leave blank) 

7. When you complete the addition of all attributes, click OK to complete the process of 
assigning electrical properties and close the Part Information dialog box. 

Save the part type to the library 

1. On the File menu, click Save. 

2. On the File menu, click Exit Part Editor to exit from the Part Editor and return to the 
Schematic Editor. 

Use the library manager 

You can edit existing part types in the library from the library manager dialog. 

1. File menu > Library. 

2. In the Library list, switch to the \Libraries\preview library. 

3. Click the Parts button.  

4. In the Part Types list, click 87C256. Notice the image in the preview window. It should be 
the CAE Decal that is associated with the Part Type. 

5. Click Edit to bring the part into the Part Editor. Close the Library Manager. 
You can now edit the part type, its CAE decal, and its electrical properties. 

6. On the File menu, click Exit Part Editor. 

7. Do not save a copy of the file. 

You completed the creating library parts tutorial. 
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Adding and Duplicating Parts Tutorial 
Typically, schematic entry requires many add, copy, or delete part operations.  

This lesson covers the following topics: 

 Adding parts 

 Deleting parts 

 Duplicating parts 

Preparation 

If it is not already running, start SailWind Logic and open the file named previewstart.sch in 
the \ SailWind Projects\Samples folder. 

Adding parts 

As you add parts, real-time component packaging is provided to automatically assign 
reference designators.  

Resize your view 

Before you begin, resize your view to fit an area around U1 and the B gate of U5, as shown in 
the following figure. 

 

Add a part 

Parts are added directly from the library to the schematic. In this exercise, you will add a new 
AM100415 part to the schematic using the Add Part command. 

1. Add Part button  . 

2. In the Add Part from Library dialog box, in the Filter area, select (All Libraries) in the Library 
list.  
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3. In the Items box, type AM100* and click Apply to perform a wildcard search of the libraries 
for all parts containing the first five characters, AM100. Results appear in the Items list. 

4. Select AM100415 from the list of parts. The part appears in the preview window.  

5. Click Add. The AM100415 part attaches to the pointer in the design area. 

6. In the Add Part from Library dialog box, click Close. 

Place the part 

Each time you add a new part it attaches to the pointer. Complete the part addition by 
positioning and placing it. For this exercise you need to place the part precisely. 

1. Position the part between R1 and U5B at X6500,Y7900. Use the coordinate display on the 
Status Bar as a guide. Do not use the D: (delta) coordinates. 

2. Click to place the part on the schematic. 

Tip: You can see that U3 is the reference designator for the part. Even though the last 
reference designator number used for prefix U was 7, it was determined that designator 
number 3 was unused. Unused numbers are automatically assigned before resuming the 
numbering sequence. 

3. Add more parts in an empty area of the design. When you finish placing symbols, press 
Esc. 

 

Gaps created by deleting or renumbering parts are automatically filled in to minimize part 
usage. When you add a multi-gated part, unused gates in existing parts are used before a 
new package is created. 

Deleting parts 

To remove any multiple instances of AM100415: 

1. Delete Mode button  . 

2. Select a duplicate of the AM100415 part. If you cannot delete the part, right-click and click 
Select Parts. 

Tip: For best results, place the pointer on the part outline when selecting. 

3. Repeat these steps to delete any additional parts you added, except U3.  

4. Right-click and click Cancel to exit Delete mode. 

Alternative:  Press Esc to cancel. 

5. On the View menu, click Redraw to refresh the workspace display. 

Alternative:  Press Ctrl+D to redraw. 

Duplicating parts 

You use the Duplicate command to duplicate parts on the schematic. 

1. Duplicate Mode button  . 
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2. Select U3 to add duplicates of the AMD part. Like the Add Part command, the part attaches 
to the pointer and you enter Move Part mode. 

3. Click to place several duplicates on the schematic. Right-click and click Cancel to exit 
duplicating U3. 

4. On the Design Toolbar, click the Select button to exit Duplicate Mode. 

Alternative:  Press Esc to exit the mode. 

5. Right-click and click Select Parts. Use Ctrl+click to select all additional parts you 
added except U3. Right-click and click Delete. 

Tip: You can apply changes to multiple objects. All parts selected in the above example, 
were deleted. Other options for multiple selected parts include attribute additions, attribute 
visibility changes, and saving to the library. The options available for multiple selections vary 
according to the types of objects selected. 

6. Do not save a copy of the file. 

You completed the adding and duplicating parts tutorial. 
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Adding Connections Tutorial 

In this lesson: 

 Adding interconnects 

 Modifying connections 

 Adding connections to power and ground 

 Adding connections across pages 

Preparation 

If it is not already running, start SailWind Logic and open the file named previewpart.sch in 
the \ SailWind Projects\Samples folder. 

Adding interconnects 

To interconnect parts, use the Add Connection command. Each new connection is 
automatically assigned a system-generated netname. 

Add Connection command 

Once you add a part, you add the interconnects to complete the schematic. To start a new 
connection, you will click on the end point of the pin. A connection line attaches to the pin and 
follows the pointer movement. 

1. Add Connection button  . 

2. Zoom into the area shown below. 
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3. Select pin number 1 on the right side of U3. 

4. With the end point of the new connection attached, move the pointer horizontally to the 
midpoint between U3 pin 1 and U5B pin 6. Click to add a new corner. 

5.  Move the pointer and notice how the end of the connection remains attached to the pointer 
and a 90-degree corner is dynamically added as you move in a diagonal direction. 

6. Click to add an additional corner above U5B. 

7. Remove the last corner you added by right-clicking and clicking Del Corner or by pressing 
Backspace. 

8. Position the pointer over U3 pin 15 and click to complete the connection. Right-click and 
click Cancel to exit the Add Connection mode. 

Modifying connections 

You can modify connections using either the Move or Delete commands. 

Move a connection 

Use the Move command to move the end point of the connection to another pin. 

1. Move Mode button  . 

2. With nothing selected, right-click and click Select Connections. 

3. Click at the midpoint of the connection segment attached to U3 pin 15. The connection pulls 
off pin 15 and the end of the connection attaches to the pointer as you enter Add 
Connection mode. 

Tip: If you select U3 or a corner of the segment instead of U3 pin 15, press Esc to Cancel 
and try your selection again.  

4. Move the path to U5B pin 6 and complete the connection.  

5. Click the Select button  on the toolbar to exit Move Mode. 

Delete a connection 

Use the Delete command to remove the connection. 

1. Right-click and click Select Connections. 

2. Select the connection between U3 pin 1 and U5B pin 6.  

3. Right-click and click Delete. 
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Connect U1 and U3 

Connect U3 to the other parts (in dashed lines) in the following graphic using the Add 
Connection, Move, and Delete commands described in the above procedures. 

 

Adding connections to power and ground 

You can connect to power or ground with the same Add Connection operations, but you will 
terminate the connection using a special symbol. The symbol represents a connection to the 
specified net. 

Create power and ground symbols in the Part Editor. Each symbol has a primary symbol and 
may optionally have several alternate symbols. In addition, you can associate each power or 
ground symbol (and its alternates) with a net and give each its own graphic symbol. This is 
useful when the schematic has many power or many ground nets. 

Add a power connection 

To complete the connections to U3, you must connect pin 15 of U3 to the +12V power net. 

1. Add Connection button  . 

2. Select pin number 15 on U3. 

3. Move the pointer horizontally and click to add a new corner. 

4. With the connection attached to the pointer, right-click and click Power. A power symbol 
attaches to the pointer. 
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Choose an alternate symbol 

To connect pin 15 to +12V, cycle through the alternate power symbols until you arrive at the 
+12V symbol. 

1. With the special symbol attached to the pointer, right-click and click Alternate, until the 
netname +12V appears in the Status Bar.  

Alternative: Press Ctrl+Tab. 

The pin connection also appears in the Status Bar. 

2. Click to complete the connection to +12V. 

Connect resistors R5 and R2 to ground and power 

There are also two resistors on the schematic requiring power and ground connections. 

1. Use the search modeless command s (search) to locate R5. Type sr5 and 
press Enter. 

2. Select pin number 2 on R5. A connection attaches to the pointer.  

3. Right-click and click Ground. A ground symbol attaches to the pointer.  

4. Position the symbol just below and to the right of R5 and click to complete 
the connection.  

5. Locate R2 by typing sr2 and pressing Enter. 

6. Select pin number 2 on R2. A connection attaches to the pointer.  

7. Before you add the connection to power, you must enable the display of the netname so it is 
visible when the power symbol is placed on the schematic. Right-click and click Display PG 
Name. 

8. Right-click and click Power to connect R2.2 to power.  

9. With the special symbol attached to the pointer, right-click and click Alternate, or press 
Ctrl+Tab repeatedly until the netname +5V appears in the Status Bar. 

10. Position the symbol directly above R2 and click to complete the connection. 

Adding connections across pages 

Off-page symbols are added to connections to make indirect connections between net 
instances on the same sheet or across multiple sheets. Off-page symbols are added in the 
same manner as power and ground symbols. 

In this section, you will add an off-page connection (in dashed lines in the graphic below). 
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1. Locate U7 by typing su7 and pressing Enter.  

2. Select pin number 1 on U7. 

3. Move the pointer horizontally and click to add a corner in the connection. Move the pointer 
up and to the right just above the U7 reference designator. 

4. Right-click and click Offpage. 

5. Right-click and click X Mirror. 

6. Click to place the off-page symbol, and 

7. In the Add Net Name dialog box, type 28MHZ, and click OK. 

8. Do not save a copy of the file. 

You completed the adding connections tutorial. 
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Adding Buses Tutorial 
Buses are used to quickly add connections for a collection of sequentially named nets, such 
as an address or data bus. 

In this lesson: 

 Creating and connecting a bus 

Preparation 

If it is not already running, start SailWind Logic and open the file named previewconnect.sch 
in the \ SailWind Projects\Samples folder. 

Creating and connecting a bus 

In the following sections you will add a bus and connect U7 to the bus (in dashed lines in the 
graphic below). Buses are used to streamline net connections in a schematic for easy 
readability. Nets that commonly connect from one component to another are "merged" into a 
bus to make viewing of schematic connections clearer. 

 

Create a bus 

Create new buses by using the Add Bus command. 

1. Click the Add Bus button  on the Design toolbar. 

2. Using the coordinate display on the Status Bar as a reference, position the pointer at X9400, 
Y4400. 

3. Position the pointer at X8100, Y6200 and double-click, or right-click and click Complete to 
complete the definition of the bus.  
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4. In the Add Bus dialog box, click Bit Format. 

5. In the Bus Name box, type D[00:07] to name the bus and click OK. The bus name label 
attaches to the pointer. 

6. Position the label just above the horizontal segment of the bus and click to place it.  

7. Right-click and click Cancel to exit Add Bus mode. 

Bus naming conventions 

The bus labeled in this exercise uses the Bit Format – a series of nets with consecutive net 
names. A Mixed Net bus type consists of individual nets that are not always sequential. It can 
even include a bit format bus along with other nets. Mixed Nets are added individually to the 
Bus Nets list in the Add Bus dialog box. A bit range for each net is optional. 

Connect to a bus 

Connect to a bus using the Add Connection command. 

1. Add Connection button  . 

2. Select pin number 12 on U7, and position the pointer over the vertical segment of the bus.  

3. Click to add a connection to the bus.  

4. In the Add Bus Net Name dialog box, click OK to accept the D00 net name. 

5. Right-click and click Move. 

6. Position the net name label over the connection, and click to place it. 

7. Repeat steps 3 and 4 to connect pin number 13 on U7 to D01.  

Result: The net name assignment automatically increments, and the position of the net 
name label is preserved.  

8. Click to accept the position of the D01 net name.  

9. Right-click and click Cancel to exit the Add Mode. 

Alternative: Press Esc. 

Use duplicate to step and repeat bus connections 

You can use the Duplicate command to step and repeat connections and speed the process 
of connecting to a bus. 

1. Duplicate Mode button  . 

2. Select the midpoint of the D01 connection you added.  

Result: A copy of the connection attaches to the pointer. 

3. Right-click and click Step and Repeat. 

4. In the Step and Repeat dialog box, select Down as the direction, type 6 in the Count box, 
and type 100 in the Distance box. 

5. Click OK to complete the connection of U7 to the data bus. 

6. Press Esc twice to cancel and exit first Duplicate Mode and then Add Connection Mode. 
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Rename a bus, subnet, or net 

You can rename a bus, subnets of a bus, or nets.  

1. Right-click > Select Anything > select a connection (or bus) segment > right-click > 
Properties. 

2. Change the name of the net or bus by typing a new name in the Net Name box or by 
switching to another net in the list.  

3. Choose a Rename option to set how the rename is applied to the selected connection. 
There are two options: 

 This Instance – affects only the selected connection 

 All Instances – every connection instance of the named net in 
the design 

4. Click OK to apply the rename. 

Tip: When you change a netname to a netname that already exists, you are prompted to 
confirm the combining of the nets. Click OK to combine the two nets into one net.  

5. Do not save a copy of the file. 

You completed the adding buses tutorial. 
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Editing Design Elements Tutorial 
You can change objects, including their placement and properties, at any time in the design 
cycle. 

In this lesson: 

 Modifying schematic data 

 Grouping objects 

Preparation 

If it is not already running, start SailWind Logic and open the file named previewbus.sch in 
the \ SailWind Projects\Samples folder. 

Modifying schematic data 

Use Properties mode to modify your data. You can modify text strings, bus names, reference 
designators, and most other types of data in your schematic. The properties feature is context 
sensitive; while you are in the Properties mode, select an object to view its properties. 

In the following sections you will use Properties mode to modify various design objects in the 
schematic. 

Rename a net 

1. With nothing selected, right-click and click Select Anything. 

2. Double-click the connection segment of the 28MHZ net connected to the off-page symbol 
(above U7). 

3. In the Net Properties dialog box, type 24MHZ in the Net 
Name box. 

4. Click OK. 

5. Because this net already exists, the message "Net <24MHZ> already exists - OK to combine 
nets?" appears. Click Yes to combine the nets. 

6. On the View menu, click Redraw to refresh the workspace display. 

Alternative:  Press Ctrl+D to redraw. 

Rename a part 

You can use similar operations for renaming nets to rename a part; you select a part and 
change its reference designator property. 

1. Right-click > Select Parts 

2. Search for R500 by typing sr500 and pressing Enter. Sheet 1 (Logic) is automatically 
changed to sheet 2 (Power) and the part is located. 

3. Zoom in around R500 and double-click R500. 
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Tip: If the selection filter had been set to Select Anything instead of Select Parts, double-
clicking the part would open the Part Properties dialog box and double-clicking the name 
label would open the Reference Designator Label Properties dialog box. 

4. In the Reference Designator area, click Rename Part. 

5. In the Rename Part dialog box, type C10, and click OK. R500 is renamed to C10.  

Change a part type 

The next step to updating the component change for the R500 part is to make it a capacitor. 
Use the Part Properties dialog box to change its part type to a capacitor. 

1. In Part Properties dialog box, in the Part Type area, click Change Type. 

2. In the Change Part Type dialog box, in the Filter area, in the Items box type cap12*.  

3. Switch the library list to All Libraries, and click Apply. All of the capacitors available in the 
libraries starting with cap12 appear in the Part Types list. 

4. In the Part Types list, click CAP1206 and in the Apply update to area click This Part. 

5. Click OK to change C10 to a 1206 style capacitor. 

6. Click Close to close the Part Properties dialog box. 

Tip: Notice the capacitor is not oriented properly. Part symbols are built with alternate 
horizontal and vertical versions. You change the properties for the part again to set the Gate 
Decal to one of the alternate presentations. 

Update the attribute values 

To change the capacitance of multiple capacitors, follow these steps. 

1. Click and drag a box around all of the capacitors including C10.  

2. Right-click and click Attributes. 

 In the Part Attributes dialog box, the Attributes area lists several Names and Values. 
Currently, the Value box next to the Value name contains ???.  

Tip: You may need to scroll down the list. 

3. Double-click in the ??? Value box to edit it. 

4. Type .1 uf in the Value box and press Enter. 

5. Click OK to complete the edit and automatically update all of the CAP1206 capacitors 
to .1 uf. 

 
To change all of the resistance values of a type of resistor, follow these steps. 

1. Search for R7 by typing sr7 and pressing Enter. 

2. Click to select the resistor symbol. 

3. Right-click and click Attributes.  

4. In the Part Attributes dialog box double-click in the ??? Value box next to the Value name 
and type 10K and press Enter. 

5. In the Apply Update To area, click All Parts This Type. 

6. Click OK to complete the edit and automatically update all resistors. 

7. Click Esc to deselect the resistor. 
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Grouping objects 

You can import and export groups of circuitry to and from other schematics. You can also 
group, duplicate, move, or delete blocks of circuitry within a schematic diagram. The first step 
is to define the group you'll work with. 

Caution: Do not save the design with any changes you make in the following exercise. 

1. Right-click > Select Anything 

2. Click and drag a selection area that encloses the items that you want to group. 

3. Right-click and click Duplicate to copy the defined group. The new duplicate attaches to the 
pointer. 

4. Move the duplicate to any position on this page of the schematic, and then click to place it. 

Tip: You can save the duplicate to a file for use in other schematics. Select a group of 
objects, right-click and click Save to File. To paste a group into a design, on the Edit menu, 
click Paste from File, and select the group file. 

5. Do not save a copy of the file. 

You completed the editing design elements tutorial. 

  



 

 

SailWind Logic Tutorial  29 

Assigning Constraints Tutorial 
Assigning constraints to your design allows you to easily control and verify critical design 
areas. Constraint types include clearance, routing, and high-speed rules that can be assigned 
to nets, layers, classes (collection of nets), groups (collection of pin pairs), or individual pin 
pairs. You can also assign a default set of design rules that apply to all objects not having a 
unique rule. 

In this lesson: 

 Establishing the layer arrangement for the PCB 

 Setting default clearance rules 

 Setting net clearance rules 

 Setting conditional rules 

Preparation 

If it is not already running, start SailWind Logic and open the file named previewchange.sch 
in the \ SailWind Projects\Samples folder. 

Establishing the layer arrangement for the PCB 

You can define layer arrangements for the PCB, including the number of layers, the nets 
associated with embedded plane layers, layer stackup, and layer thickness. 

The tutorial design is a four-layer PCB with two internal plane layers supporting multiple plane 
nets. In this section, you will define the layer arrangement for the tutorial design using the 
layer definition tools. 

Increase the number of layers 

When you first start a design, the default is a two-layer PCB. To change the number of layers: 

1. Setup menu > Layer Definition. 

2. In the Layers Setup dialog box, in the Electrical Layers area, click Modify. 

3. In the Modify Electrical Layer Count dialog box, type 4. 

4. Click OK to increase the number of layers from 2 to 4. 

5. In the Reassign Layers dialog box, click OK. 

Set layer arrangement and names 

Once you set the correct number of layers, assign the layer types for each layer and enter 
layer names. 

To set the first layer: 

1. In the Layers Setup dialog box, select Top in the list of layers.  
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2. In the Name box, type Primary Component Side.  

3. In the Electrical Layer Type area, click the Component layer type. 

4. In the Plane Type area, click No Plane. 

5. Set the Routing Direction to Vertical. 

To set the second layer: 

1. Select the second layer, Inner Layer 2, and rename it Ground Plane.  

2. In the Plane Type area, click CAM Plane. 

3. Click the Assign Nets button. 

4. In the Plane Layer Nets dialog box, in the All Nets list, scroll down, click net GND, and click 
Add to associate the net with the Ground Plane Layer. 

5. Click OK. 

6. Set the Routing Direction to Any. 

To set the third layer: 

1. Select the third layer, Inner Layer 3, and rename it Power Plane. 

2. In the Plane Type area, click Mixed Plane. 

3. Click the Assign Nets button. 

4. In the Plane Layer Nets dialog box, select nets +5V and +12V in the All Nets list, and click 
Add to associate the nets with the Power Plane Layer. 

5. Click OK.  

6. Set the Routing Direction to Any. 

To set the last layer: 

1. Select the fourth layer, Bottom, and rename it Secondary Component Side. 

2. In the Electrical Layer Type area, click the Component layer type. 

3. In the Plane Type area, click No Plane  

4. Set the Routing Direction to Horizontal. 

Set the layer stackup 

A typical layer stackup for a four-layer PCB is composed of a pair of copper clad fiberglass 
substrates, with an insulator/bonding material in between. The insulator/bonding material is 
typically a resin sheet that bonds the substrate pairs together when a multilayered board is 
manufactured. This bonding material is also known as Prepreg. 
Layer stackup: 
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Use the Layer Thickness dialog box to set the layer stackup values. 

1. In the Layers Setup dialog box, click Thickness. 

2. In the Layer Thickness dialog box, click Weight(oz) in the Copper Thickness Units area. 

3. In the Layer list, for the Primary Component Side, in the Thickness box double-click and 
type 2 to reflect that it has a copper weight of two ounces. 

Tip: 1 oz. of copper weight = .00135" of copper thickness. 

4. For the Ground Plane, in the Thickness box double-click and type 1 to reflect that it has a 
copper weight of one ounce. 

5. For the Power Plane, in the Thickness box double-click and type 1 to reflect that it has a 
copper weight of one ounce. 

6. For the Secondary Component Side, in the Thickness box, double-click and type 2 to 
reflect that it has a copper weight of two ounces. 

7. Double-click in the Substrate list box between Ground Plane and Power Plane and switch to 
Prepreg to establish this level as the insulator/ 
bonding layer. 

8. Double-click in the Thickness box for the Prepreg layer and type 35. 

Tip: The Dielectric Constant is a value given for manufacturing materials, such as FR-4, to 
describe electrical characteristics. 

13. Click OK to close the Layer Thickness dialog box. 

14. Click OK to close the Layer Setup dialog box. 

Setting default clearance rules 

You can define clearance, routing, and high-speed rules for each level of the design rule 
hierarchy. 

 

 

 

The Clearance area of the Clearance Rules dialog box contains a matrix of PCB design data. 
You can specify values for each or all data types in the matrix. 

1. Setup menu > Design Rules > Default button > Clearance button. 
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2. Set a global default clearance value by clicking All in the upper-left corner of the clearance 
matrix. 

3. In the Input Clearance Value dialog box, type 8 and click OK.  

Result: All matrix values change simultaneously. 

4. In the Trace Width area, type 6 in the Minimum box, type 8 in the Recommended box, and 
type 12 in the Maximum box. 

5. Type 12 in the Same Net and Other clearance text boxes, with the exception of Trace to Crn 
box. Set this box to 0. 

6. Click OK. 

Set the default routing rules 

To avoid routing on the plane layers, remove them from the selected routing layers as defined 
in the routing rules. The Layer Biasing area of the Routing Rules dialog box contains a list of 
selected routing layers. This list lets you specify which layers are permitted for routing. 

1. In the Rules dialog box, click the Routing button. 

2. In the Selected Layers list, select the Ground Plane and press and hold Ctrl and click 
Power Plane to add them to the selection.  

3. Click Remove to prevent routing on the plane layers. 

4. Click OK to close the Routing Rules dialog box. 

5. Click Close to close the Default Rules dialog box. 

Setting net clearance rules 

You can assign net-specific clearances that take precedence over the default rules previously 
entered. 

1. In the Rules dialog box, click the Net button. 

2. Scroll through the Nets list. Ctrl+click +5V, +12V, and GND. The three selected nets appear 
in the Selected listing under the rule type buttons. 

3. Click the Clearance button to set the same clearance rules for all three nets. 

4. Set a global default clearance value by clicking All in the upper-left corner of the clearance 
matrix. 

5. In the Input Clearance Value dialog box, type 10 as the global clearance and click OK. 

6. In the Trace Width area, type 10 in the Minimum box, type 12 in the Recommended box, 
and type 15 in the Maximum box.  

7. To complete the definition, click OK. 

8. Close the Net Rules dialog box. 
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Setting conditional rules 

When two nets require a specific clearance between each other (to avoid adverse affects on 
the circuitry), you must define a conditional rule. An example of a conditional rule might be the 
Underwriters Laboratories (UL) requirements of segregating primary, secondary, and ground 
nets when alternating current is directly connected to the PCB. You can assign conditional 
rules between most components of the design rule hierarchy. Conditional rules can exist 
between nets, nets and classes, classes and classes, nets and layers, and so on. 

To assign a net-to-net conditional rule: 

1. In the Rules dialog box, click the Conditional Rules button. 

2. Click Nets in the Source Rule Object area.  

Result: A list of nets appears in the Source Rule Object list. 

3. Select net +5V. 

4. In the Against Rule Object area, click Nets.  

Result: A list of nets appears in the Against Rule Object list. 

5. Select net +12V. 

6. Click Create to define the conditional rule. The new condition appears in the Existing Rule 
Sets area. 

7. In the Current Rule Set area, type 25 in the Object-to-Object box. 

8. Close all of the open dialog boxes. 

Result: The rule you just created will keep all objects pertaining to the +5V and +12V nets 
25 mils apart. 

9. Do not save a copy of the design. 

You completed the assigning constraints tutorial. 

  



 

 

34  SailWind Logic Tutorial 

Creating Reports Tutorial 
This lesson demonstrates report options available in SailWind Logic. 

In this lesson: 

 Checking a net statistics report 

 Outputting an unused gates and pins report 

 Compiling the bill of materials 

Preparation 

If it is not already running, start SailWind Logic and open the file named previewrules.sch in 
the \ SailWind Projects\Samples folder. 

Creating a net statistics report 

The Net Statistics report lists each net in the design. All pin connections for a net are listed 
and their status as sources, loads, or undefined pins. If pins are defined properly, this report 
can check the accuracy of a design by displaying questionable net connections. 

1. File menu > Reports. 

2. In the Reports dialog box, select the Net Statistics check box. 

3. Click OK. A link to the NetStatistics.rep report appears in the Output Window. Click the link 
to open the report in the default text editor. 

4. Examine the first net. The report indicates whether nets have a source and load. Nets 
marked [U-1] identify an undefined pin in this group. 

5. Close the report file. 

Outputting an unused gates and pins report 

The Unused report lists any unused gates of a part or unused pins. 

1. File menu > Reports. 

2. In the Reports dialog box, select the Unused check box, and clear the Net Statistics check 
box. 

3. Click OK. A link to the UnusedGatesPins.ref file appears in the Output Window. Examine 
and then close the report. 

Tips: 

 The Unused Gate List section of the report lists unused gates by part types.  

 The Unused Pins List section lists unused individual pins by part types.  

 To locate gates that should not appear as unused, use the S modeless command to search 
for parts by reference designator. 
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Compiling the bill of materials 

The Bill of Materials looks into the part type data for every part in the design and arranges the 
information in a parts list format. You can customize the format of the report by entering 
unique column headers and specifying column width: 

1. File menu > Reports. 

2. Click the Bill of Materials check box and clear the Unused check box. 

3. Click Setup. 

4. In the Bill of Materials Setup dialog box, click the Attributes tab. 

5. In the Field Header column, double-click Reference. 

6. Type Ref Des in the box and press Enter. 

7. In the Width column, double-click the value 15 next to the Part Name. 

8. Type 12 in the box for a new column width and press Enter. 

9. Click OK. 

10. Click OK in the Reports dialog box. A link to the BillOfMaterials.ref file appears in the Output 
Window. Click the link to open the report. Review the contents of the bill of materials report, 
then close the report. 

11. Do not save a copy of the file. 

You completed the creating reports tutorial. 
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Linking to SailWind Layout Tutorial 
There are two methods of forwarding SailWind Logic schematic data to SailWind Layout: 

 Create a netlist that SailWind Layout can read and import it into SailWind Layout 

 Use the SailWind Layout link to automatically manage the transfer of data between SailWind 
Logic and SailWind Layout. 

The SailWind Layout link automatically passes design data between SailWind Logic and 
SailWind Layout and is the preferred method for synchronizing schematic and PCB design 
databases. 

An additional benefit of the SailWind Layout link is inter-tool communication. Use this 
automation technology to cross-probe between linked applications. Cross-probing is having 
selections of nets, components, or pins made in one application result in the selection of the 
corresponding object in the linked application. 

SailWind Logic is OLE Automation enabled. This capability allows you to develop custom 
applications using Visual Basic, Microsoft Visual C++, or other tools to extract specific data 
from a SailWind Logic database. 

In this lesson: 

 Creating a netlist 

 Using the SailWind Layout Link 

Preparation 

If it is not already running, start SailWind Logic and open the file named preview.sch in the \ 
SailWind Projects\Samples folder. 

Requirement: This tutorial requires the sample libraries to be in their original search order. 
The preview library must precede the common library in the SailWind Layout search order or 
errors will result. 

Creating a netlist 

Creating a netlist is the basic method for passing schematic data into SailWind Layout to start 
the PCB design process. A netlist contains a list of the parts, their part types, and all of their 
net connections. Optionally, it can also include design rules and a layer stackup. 

To create the netlist: 

1. Tools menu > Layout Netlist. 

2. In the Netlist to PCB dialog box, accept the default settings and click OK to create the 
netlist. A link to the Preview.asc netlist file appears in the Output Window. Click the link to 
open the file in your default text editor. 

3. Review the content of the netlist file and close the file before proceeding to the next section. 
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Using the SailWind Layout Link 

You can cross-probe between SailWind Logic and SailWind Layout with the features of the 
SailWind Layout Link. Use this feature to perform schematic-driven placement or post-design 
reviews of the layout. 

1. Tools menu > SailWind Layout. 

2. In the Connect to SailWind Layout dialog box, click New to start a new SailWind Layout 
session. It may take a moment for SailWind Layout to start.  

3. Once SailWind Layout starts, the two applications are linked and cross-probing between 
SailWind Logic and SailWind Layout is enabled. The SailWind Layout Link dialog box also 
appears. Take a moment to rearrange the size and position of your SailWind Logic and 
SailWind Layout application windows so they each cover half of the screen. 

Tip: You may need to resize your views in SailWind Logic and SailWind Layout after 
rearranging the windows. Within each program, press Home to center the view in the 
rearranged windows. 

4. To reduce the setup required to use SailWind Layout, you will import a file containing some 
basic PCB elements required for the tutorial.  

a. In SailWind Layout, on the File menu, click Import.  

b. Locate and import the logic tutorial.asc file in the \ SailWind Projects\Samples folder. 

Send a netlist to SailWind Layout 

Use the SailWind Layout Link to automatically generate and send a netlist to SailWind Layout. 

 In the SailWind Layout Link dialog box, on the Design tab, click Send Netlist to generate a 
netlist from SailWind Logic and send it to SailWind Layout. After the process completes, all 
the components are positioned at the design origin, ready for placement. 

Tip: If a prompt appears asking “Schematic net list may have errors. Do you want to 
continue?”, click Yes. 

Schematic-driven placement 

Now that you have a SailWind Layout design with the parts and nets from the schematic, you 
will prepare the parts for placement. You will also put SailWind Layout in Move mode so part 
selections made in SailWind Logic result in movement of the selected part. 

In SailWind Layout 

Use the Disperse Components command to distribute the components around the outside of 
the board outline.  

1. On the Tools menu, click Disperse Components and click Yes to confirm the dispersion. 

2. Click the Board button  to fit the view to the board outline. 

 

Enable the move component verb mode. 
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1. On the toolbar, click the Design Toolbar button  to open the Design toolbar.  
 

2. On the Design toolbar, click the Move button  to place SailWind Layout in Move 
Component mode.  

In SailWind Logic 

Select the J1 component in SailWind Logic. 

1. On the Selection toolbar, click the Nothing filter button, then the Parts filter button  to 
place SailWind Logic in a mode that enables only component selections.  

2. Select any pin of the J1 connector on the left side of the Logic sheet of the schematic.  

3. Move your pointer to the SailWind Layout window. You are now moving J1 in SailWind 
Layout. 

In SailWind Layout 

Place the component in SailWind Layout. 

1. Right-click and click Flip Side.  

2. Position it at X1650,Y400 by typing S 1650 400 and pressing Enter. 

3. Press Spacebar to place J1. 

4. On the Design toolbar, click the Select button  to exit Move Mode  

Multiple selections in SailWind Logic 

You can also move multiple components sequentially by making group selections in SailWind 
Logic and applying the Move Sequential command in SailWind Layout 

In SailWind Logic 

Make a group selection in SailWind Logic. 

1. With nothing selected, position the pointer in the upper-left corner of the schematic, then 
click and drag the pointer toward the lower-right corner of the schematic. 

2. Release the mouse button when several components are enclosed in the selection 
rectangle. 

3. Once you complete the selection, the components corresponding to your selections in 
SailWind Logic are selected in SailWind Layout. 

In SailWind Layout 

Move the components in sequential order. 

1. Right-click and click Move Sequential.  

2. Click Yes to All.  
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3. Click to place the first component.  

Result: The next component attaches to your pointer and can be moved.  

4. Continue to place parts until no more components attach to the pointer. 

Layout-driven selections 

You can also drive selections in SailWind Logic from selections made in SailWind Layout.  

In SailWind Logic 

Enable SailWind Logic to receive selections made in SailWind Layout. 

1. In the SailWind Layout Link dialog box, click the Selection tab. 

2. Select the Receive Selections check box to enable SailWind Logic to receive selections 
made in SailWind Layout. 

In SailWind Layout 

Select the Y1 component in SailWind Layout. 

1. Use the search and select modeless command to locate and select oscillator Y1 by typing 
ssy1 and pressing Enter.  

Result: The Y1 component is selected in SailWind Layout and SailWind Logic. 

2. Search and select C3 by typing ssc3 and pressing Enter.  

This demonstrates how SailWind Logic responds to selections in SailWind Layout and 
automatically changes sheets to bring the part in view. 

3. Search and select U6 by typing ssu6 and pressing Enter.  

Since U6 is a multi-gated part, all gates of the part are selected in SailWind Logic. Each 
gate of the device is listed independently in the Search and Select box on the Selection 
toolbar. 

In SailWind Logic 

Choose a specific instance of U6. 

1. Scroll through the items in the Search and Select list on the Selection toolbar and click U6B.  
The selection changes to only U6B. This is how you manage selections of multi-gated parts 
in SailWind Logic. 

2. Do not save a copy of the file. 

3. Close the SailWind Layout Link dialog box and SailWind Layout without saving any 
changes. 

You completed the linking to SailWind Layout tutorial. 
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Updating a Schematic with Design Changes 
Tutorial 

In the typical engineering environment, design modifications are documented by an 
Engineering Change Order (ECO). Implementation of these changes in the design may 
require pin and gate swaps, part deletions or additions, net deletions or additions, renaming of 
components, renaming of nets, or part type changes. SailWind Layout provides tools to 
implement these modifications quickly and records them accurately for documentation and 
backward annotation to the schematic. 

ECO changes performed in SailWind Layout are recorded in an ASCII file with a *.eco 
extension. This file, in its native format, can be read into SailWind Logic to annotate the 
schematic with changes made in SailWind Layout. 

In this lesson: 

 Importing an ECO file 

 Compare Files and Export an ECO file 

Preparation 

If it is not already running, start SailWind Logic and open the file named preview.sch in the \ 
SailWind Projects\Samples folder. 

Importing an ECO file 

Examine a few of the reference designators in the schematic. Now import an 
.eco file. 

1. File menu > Import. 

2. Click No if the message "Save file before loading" appears. 

3. In the file type list, click ECO Files (*.eco). 

4. Select the previewassy.eco file in the \ SailWind Projects\Samples folder, and then click 
Open. 

 Result: All reference designators on the schematic are updated. The schematic is redrawn 
and a message informs you that the ECO process 
is complete.  

5. Click OK.  
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Compare files and export an ECO file 

You use the Compare/ECO command to compare schematic and design files and create an 

ECO file for updating SailWind Layout. 

1. Open the file named previeweco.sch. Do not save changes to the preview.sch file. An extra 
capacitor (C11) has been added to the 
tutorial design. 

2. On the Tools menu, click Compare/ECO. 

3. In the Compare/ECO dialog box, click the Documents tab. 

4. In the Original Schematic Design to Compare area, click Browse. Select the preview.sch 
design and click Open. 

5. In the Output Options area, click Browse. Set the output file to be named previeweco.eco in 
the \ SailWind Projects\Samples folder and click Save. 

6. Click Run. A link to the previeweco.eco file appears in the Output Window. Review and then 
close the file. One or more ecogtmp.err files may open providing information about the files 
being compared. You can close the files. 

7. Start SailWind Layout and open the file named preview.pcb located in the 
\ SailWind Projects\Samples folder.  

8. On the View menu, click Extents. 

9. On the File menu, click Import.  

10. In the file type list, click ECO Files (*.eco), select the previeweco.eco file in the \ SailWind 
Projects\Samples folder and click Open.  

11. Click OK. A new capacitor C11 will be located near the origin. 

12. Close SailWind Layout without saving any changes. 

Automatic Forward Annotation Using SailWind Layout 
Link 

You can use SailWind Layout Link to automatically forward annotate changes in your 
schematic to SailWind Layout with the click of a button. 

1. Open the file named previeweco.sch. Do not save changes to the preview.sch file. An extra 
capacitor (C11) has been added to the 
tutorial design. 

2. On the Tools menu, click SailWind Layout. 

Tip: If SailWind Layout is not already open, the Connect to SailWind Layout dialog box 
appears. Click Open to start a new SailWind Layout session with the original design. In the 
File Open dialog box, select the preview.pcb file and click Open. 

3. In the SailWind Layout Link dialog box, click the Design Tab. 

4. Optional: If you want to check the design differences before updating, click the Compare 
PCB button. The two versions are compared and differences written to logic.rep in the \ 
SailWind Projects folder. To see the report, click the logic.rep link in the Output Window. 

5. On the Design Tab: 
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a. If needed, check the Compare Design Rules and Show Net List errors report check 
boxes. 

b. Click the ECO To PCB button to send the changes. 

Tip: While the SailWind Layout Link dialog box is open, you can cross-probe.  

6. In SailWind Layout, a new capacitor C11 will be located near the origin. 

7. Close SailWind Layout without saving any changes. 

 

You completed the ECO tutorial. 

Printing and Plotting Schematics Tutorial 
This lesson demonstrates how to print schematics in SailWind Logic. 

In this lesson: 

 Choosing what appears in the printout 

 Setting plot orientation and printing 

Preparation 

If it is not already running, start SailWind Logic and open the file named preview.sch found in 
\ SailWind Projects\Samples. 

Choosing what appears in the printout 

All items in the plot of a schematic sheet can be enabled or disabled for printing. 

1. File menu > Print. 

2. In the Print dialog box, click Options.  

3. Ensure that both sheets in the design are in the Sheets to Print list. If not, click Add All. 
They are selected for plotting. 

4. Clear the Part Text check box. This removes the pin names from all the parts in the plot. 

Setting plot orientation and printing 

Check the plot orientation for optimal coverage of your printed page. In the Options dialog box, 
the Preview area displays the current orientation setting of your printer. The white area 
represents your page, while the blue box represents the schematic and how it will display on 
your printed sheet. 

1. In the Positioning group box, switch the Orientation options until the blue box best fits the 
sheet, and click OK. 

2. Set up your printer as usual and click OK.  

3. Do not save a copy of the file. 
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You completed the printing and plotting schematics tutorial. 

 

Managing Multiple Sheets Tutorial 
SailWind Logic offers many features to manage one page schematics or schematics with 
hundreds of pages. Use the sheet manger to add, delete, rename or change the order of 
sheets in a schematic. Create custom sheet borders and title blocks, store them in the library 
and add them automatically to each new sheet. 

To manage large nets distributed over several sheets, add off page references for each 
instance of a net. Use the hierarchical features of SailWind Logic to organize your schematics 
with hierarchical blocks. 

Use the copy, paste and save to file commands to copy and reuse portions of a schematic 
across pages or across different schematic designs. 

In this lesson: 

 Creating a custom sheet border 

 Adding a sheet 

 Sheet references 

 Copying a portion of a schematic 

 Hierarchical design 

Preparation 

If it is not already running, start SailWind Logic. 

Creating a custom sheet border 

When you start a new design, a default sheet border is added to each new schematic sheet. 
You have the option to create custom borders and title blocks and set them as the default 
border. 

Modify the default border 

1. File menu > New. 

2. Tools menu > Options > Design page. 

3. Ensure the Sheet Size is set to B and then click OK. 

4. Zoom into the title block in the lower right corner of the border.  

5. Right-click and click Select Documentation. 

6. In the Title box, click <Title>.  

7. Right-click and click Properties.  

8. In the Field Properties dialog box, type your company name in the Value box and click OK. 
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9. Click in empty space to deselect the company name. 

Save the customized border to the library 

You can save the border to the library for reuse. 

1. Right-click > Select Drafting Items. 

2. Select a segment of the border.  

Result: The whole border and title block are selected.  

3. Right-click and click Save to Library. 

4. In the Save Drafting Item to Library dialog box, switch the Library to the preview library. 

5. In the Name of Item box, type MYBORDER.  

6. Click OK. 

Set the default sheet border 

You can change the current default border to a custom border. 

1. Tools menu > Options > Design page. 

2. In the Sheet area, click Choose. 

3. In the Get Drafting Item from Library dialog box, in the filter area, switch the Library to the 
preview library. 

4. In the Drafting Items list, click the MYBORDER. 

5. Click OK to close the Get Drafting Item from Library dialog box. 

6. Click OK to close the Options dialog box. 

Adding a sheet 

Add, delete, and modify sheets and sheet location using the Sheets dialog box. 

To add a sheet: 

1. Setup menu > Sheets. 

2. Click Add to increase the sheets to two.  

3. Click Close to exit the Sheets dialog box. 

Tip: The Sheets dialog box contains buttons to move sheets Up and Down in the sheet order. 
A rename function also exists that renames sheets. 

4. Note how the custom border was automatically added to the new sheet. 

Tip: Setting a new default border affects only new sheets. It does not update the border of 
existing sheets. To change the sheet border on an existing sheet, delete the border and use 
the Add 2D Line from Library command on the Design toolbar to add a custom border. 
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Off page references 

A SailWind Logic schematic database contains all sheets of the schematic. This feature 
provides for automated insertion of page references for all nets connected with off page 
symbols. You add the references to schematic when the off page reference feature is enabled. 

Open a schematic 

1. Open the file named preview.sch found in \ SailWind Projects\Samples. 

2. Zoom into the upper left portion of the schematic around the A[00-14] bus. 

3. On the Tools menu, click Options. 

4. In the Off-Sheet Labels area, select the Show Off-page Sheet Numbers check box. 

5. Click OK. 

Result: A [1] appears under the A[00:14] bus name. This indicates that another instance of 
the bus is also located on page 1 of the schematic. 

Tip: You can create a report file that lists the locations of all nets in the design. On the File 
menu, click Reports, and select the Off-page check box. 

Copying a portion of a schematic 

You can copy and paste, or save to a file, a group of items for use on other sheets or other 
schematics. 

1. Right-click > Select Anything. 

2. Using area selection, create a selection box around U7 as shown below. 

 

3. Right-click and click Copy.  

4. In the Sheet list on the toolbar, select the Power schematic. 

5. Right-click and click Paste and then click to place the object.  

6. Zoom into the part and notice the nets on the left side have off-page symbols attached. 

7. Do not save a copy of the file. 
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Tip: You use the right-click > Save to File command to save a portion of the schematic to a 
file and later use the Paste from File command on the Edit menu to add to a schematic. 

Hierarchical design 

In hierarchical designs, basic block diagrams are used to represent interconnect between 
logical functions of a design. Typically, these block diagrams are shown on the first page of 
the schematic to aid in the navigation among various functions in the schematic. The logical 
blocks represent the underlying schematic for that portion of the design. 

In SailWind Logic you create and add logical blocks, called hierarchical symbols, and link 
them directly to a subset of the SailWind Logic schematic. 

Hierarchical design example: 

 

To create a hierarchical schematic in SailWind Logic, you either create the hierarchical 
symbols first using the Decal Wizard or select a sheet and automatically define a symbol to 
represent its content. See SailWind Logic Help for detailed steps in creating a hierarchical 
design. 

You completed the managing multiple sheets tutorial. 
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Designing for Analog Simulation Tutorial 
Analog parts require special analog attributes. The SPICE Netlist feature uses the analog 
attributes to build the SPICE netlist for the SPICE simulator. SPICE models can also be linked 
to parts to provide the SPICE netlister with required values. 

In this lesson: 

 Creating an RLC circuit 

 Creating an opamp circuit 

 Adding a model to the library 

Restriction 

This tutorial requires the SailWind SPICEnet licensing option. On the Help menu, click 
Installed Options to determine whether you can proceed..  

Preparation 

If it is not already running, start SailWind Logic. 

Creating an RLC circuit 

Build a resistor-inductor-capacitor circuit using analog parts. Add analog attributes to the parts 
for netlisting to a SPICE tool. 

Start a new schematic 

 Click the New button  . At the prompt, click No to saving the file. 

Add the spice library 

The parts for the design are located in the Spice library. Add the library to the Library 
manager. 

1. File menu > Library. 

2. In the Library Manager dialog box, click Manage Lib. List. 

3. In the Library List dialog box, click Add. 

4. In the Add Library dialog box, select the spice library and click Open. 

5. Select the spice library in the Library list, and click the Up button until the spice library is at 
the top of the list. 

6. Click OK. 

7. In the Library Manager dialog box, click Close. 
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Add the analog parts 

Begin building the RLC circuit by adding the required parts to the schematic. 

1. Add part button  . 

2. In the Add Part Type from Library dialog box, in the Filter area, ensure that the spice library 
is listed in the Library list and that the Items box contains a "*" to show all library items. Click 
Apply if any changes were made in the filter. 

3. Select the CAP0805 capacitor and then click Add.  

Circuit to be drawn 

 

4. Click to place the capacitor in the schematic.  

5. Press Esc to cancel adding additional capacitors. 

6. In the Add Part from Library dialog box, repeat steps 3-5 for the following Part Types. 

Part Type 

IND-MOLDED 

RES0805 

VOLTAGE_SUPPLY*  

*If prompted, use V for the alpha-prefix. 

7. When finished, click Close in the Add Part from Library dialog box. 

Add connections to the analog parts 

Connect all the components, using the picture in the previous section as a guide. 

1. Add Connection button  . 
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2. Select a pin to start your connections, click to create corners, and select a pin to complete 
your connections. 

3. Select the connection between the capacitor and the voltage supply. 

4. Drag to create the power stub, moving the pointer down. 

5. Right-click and click Ground. 

6. Click to place the ground symbol. 

7. Press Esc to exit Add Connection mode. 

Label the connections 

Label the connections between the components. Labels make the SPICE netlist easy to 
understand. 

1. Right-click and click Select Anything. 

2. Double-click the net between the power supply and the resistor. 

3. In the Net Properties dialog box, select the Net Name Label check box. 

4. Type INPUT in the Net Name box and then click OK. 

5. Repeat steps 2-4 for the remaining nets. Use the net names in the 
following table. 

Net Between the Net Name  

Resistor and inductor MID 

Inductor and capacitor OUT 

The ground connection is automatically labeled with the addition of the 
ground symbol. 

Review analog attributes 

Attributes are added to parts in the library or in the schematic. Examine the predefined SPICE 
attributes on the parts in the schematic. 

1. Right-click > Select Parts > select a part > right-click > Attributes. 

2. In the Part Attributes dialog box, examine the Sim.Analog.Order and Sim.Analog.Prefix 
attributes. All analog attributes contain the prefix Sim.Analog. 

3. Click OK to close the Part Attributes dialog box. 

Tip: A detailed list of the SPICE/Analog attributes can be found in Help. In the Topics tab of the 
Help, point to SPICE Netlist Attribute Glossary. 

Set up the netlister 

The SPICE Netlister creates a netlist format for several different SPICE tools. 

1. Tools menu > SPICE Netlist. 

2. In the SPICEnet dialog box, in the Select Sheets list area, select the Sheet 1 check box. 

3. In the Output Formats list, select the vendor format of the SPICE software you will use. 

4. Click Simulation Setup. 
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5. Select the AC Analysis check box. 

6. Click the AC Analysis button. 

7. Ensure the Interval is set to 10 points per Decade. 

8. Ensure the Frequency starts at 1Hz and ends at 1kHz, and then click OK. 

9. Click OK in the Simulation Setup dialog box. 

10. Click OK in the SPICEnet dialog box to create the netlist. 

Checking the netlist 

The netlist opens in the default text editor and can be viewed or edited before importing into 
SPICE software. 

1. Notice the parameters from the AC Analysis. 

2. Notice the connections and attribute values are listed beside the 
referenced parts. 

3. Do not save a copy of the file. 

Completing an opamp circuit 

Complete another common analog circuit – the opamp circuit. Add an opamp from the library 
and examine the SPICE netlist. 

Open the opamp circuit 

 Click the Open button  and open the file named opamp.sch in the \ SailWind 
Projects\Samples folder. 

Add the missing opamp 

1. Add Part button  . 

2. In the Add Part Type from Library dialog box, select the OP-471 part and then click Add. 

3. Position the part over the open-ended connections in the schematic and click to place the 
gate. 

4. Press Esc to cancel adding additional opamp gates. 

5. Click Close in the Add Part Type from Library dialog box. 

Add attribute values 

Add net name values to the analog attributes of the amp. 

1. With nothing selected > right-click > Select Parts. 

2. Select the U1-A part. 

3. Right-click and click Attributes. 

4. Double-click in the Value box of the Neg attribute. 

5. Type OP_VIN in the Value box. 
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6. Repeat steps 4 and 5 and use the following values for each attribute. 

Attribute Value 

Out VOUT 

Pos GND 

7. Click OK. 

Set up the netlister 

1. Tools menu > SPICE Netlist. 

2. In the SPICEnet dialog box, in the Select Sheets list, select the Sheet 1 check box. 

3. In the Output Formats list, select the vendor format of the SPICE software you will use. 

4. Click Simulation Setup. 

5. Select the Transient check box and clear all other check boxes.  

6. Click the Transient button.  

7. Ensure the following parameters exist. 

Parameter Value 

Data Step Time 1ms 

Total Analysis Time 10ms 

8. Select the Use Initial Conditions check box and then click OK. 

9. Click OK in the Simulation Setup dialog box. 

10. Click OK in the SPICEnet dialog box to create the netlist. 

Checking the netlist 

Check the netlist for errors. 

 Notice the line * Could not open data file lm741n.mod. 

Tip: The amp in the schematic refers to an analog model and there is no model file in the 
library. 

Adding a model to the library 

Add a SPICE model to the lm741 part in the library to provide the netlister with essential 
values for simulation. 

1. Using an Explorer window, navigate to your libraries folder.  
C:\<install_folder>\<version>\ Libraries\ 

2. Add a new folder entitled spice. 

3. In the spice folder, add a new folder entitled Analog Models. 

4. Copy the lm741n.mod file from the C:\ SailWind Projects\Samples folder and paste it into the 
Analog Models folder. 
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Run the SPICE Netlister 

Create an error free SPICE netlist with the added model in the library. 

1. Tools menu > SPICE Netlist. 

2. Ensure your settings haven't changed. 

3. Click OK in the SPICE Netlist dialog box to create the netlist. 

4. Click Yes to overwriting the existing file. 

5. Examine the netlist to see the additional SPICE model information. 

You completed the creating library parts tutorial. 
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