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Chapter 1
Autorouting QuickStart

Welcome to SailWind Router, a product containing an autorouter implemented on Latium technology.

Perform the following steps to get started quickly.

Alternatively, watch the SailWind Layout and SailWind Router Getting Started Videos for Netlist Projects 
or for all the advanced features in SailWind Router for placing and routing your design, see SailWind 
Router Introductory Videos for Netlist Projects.

Step 1 - Load a SailWind Layout File
Step 2 - Assign Default Design Properties
Step 3 - Assign Routing Options
Step 4 - Define a Strategy
Step 5 - Define a Routing Order
Step 6 - Autoroute the Design
Step 7 - Generate Reports

Step 1 - Load a SailWind Layout File
SailWind Router reads and writes native SailWind Layout design files.

Procedure

1. On the standard toolbar, click the Open  button. 

2. In the Files of type area, click PCB Design Files (*.pcb,*.bre).

3. Click the SailWind Layout design file you want and click Open. For example, open the file named 
previewplaced.pcb  in the \My Documents\SailWind Projects\Samples  folder. The file opens in 
SailWind Router.

4. If the file you load contains traces, delete all the traces using Unroute.

a. Right-click in the design area and click the Select Nets  popup menu item.

b. Right-click and click Select All. All nets are selected.

c. Right-click and click the Unroute  popup menu item.

Alternative: Press the Delete key.

Step 2 - Assign Default Design Properties
All design properties and design rules set in SailWind Layout transfer automatically to SailWind Router 
when you load a SailWind Layout file. You can, however, change them in SailWind Router.
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Procedure

1. On the standard toolbar, click the Properties  button. 

Note:
Ensure nothing is selected in the design when you click the Properties  button or the 
resulting dialog box displays properties of the selected object.

2. Assign properties using the tabs in the dialog box. See Table 1.

3. Click OK  to close the Properties dialog box. Access to some tabs may require optional features not 
available in your SailWind Router configuration.

Table  1. Properties Dialog Box—Tabs

Tab Use to

Clearance Assign default object to object clearances.

Same net Assign default same net object to object clearances.

Routing Assign default trace width, default ripup, and shove preferences.

Via Biasing Assign default via type bias.

Layer Biasing Assign default layer bias.

Test Points Assign default test point clearances and stub length.

Layers Enable layers and assign routing directions.

Grid Assign default grid values.

Fanout Assign parameters for fanning out from SMD pads.

Pad Entry Assign rules for how traces enter and exit pads.

Topology Assign trace topology preferences.

For more information on each tab, click Help  in the tab.

Step 3 - Assign Routing Options
All design and display options you set in SailWind Layout transfer automatically to SailWind Router. You 
can, however, change them in SailWind Router. Additionally, SailWind Router contains a few unique 
autoroute options.
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Autorouting QuickStart

Step 4 - Define a Strategy

Procedure

1. On the standard toolbar, click the Options  button. 

2. Assign autorouting options using the tabs in the dialog box. Access to some tabs may require 
optional features not available in your SailWind Router configuration.

Click the Help  button for more information about the features on each tab.

Step 4 - Define a Strategy
The autoroute function performs several autorouting operations serially. You can specify the operations 
and the order in which they are performed in SailWind Router by defining the autorouting strategy.

Procedure
1. Click the Tools > Options  menu item > Routing  category > Strategy  subcategory.

2. Select the check box in the Pass Type column for each pass that you want to include in the 
autorouting operation.

a. Select the corresponding Protect check box to preserve all routed traces after the pass is 
completed.

b. Select the corresponding Pause check box to pause autorouting immediately after the pass 
completes.

Step 5 - Define a Routing Order
You can define the order in which the autorouter routes all components and net objects for each pass 
type. This is called the routing order.

Procedure
1. Click the Tools > Options  menu item > Routing  category > Strategy  subcategory.

2. In the “Pass definition” area, click the row of a pass type name to select it for routing order setup.

3. In the “Routing order definition” area, click components or net objects from the left-hand list and 
click Selected  to move them to the Routing Order list (right-hand side).

4. Change the order of items in the Routing Order list by selecting items and clicking the Up  or Down 
button.

5. Click Delete  to remove an item from the list.

6. Click OK.

Step 6 - Autoroute the Design
Use the Routing toolbar to control the autorouter.
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Procedure

1. On the standard toolbar, click the Routing toolbar  button. 

Table 2  describes the buttons that appear in the Routing toolbar.
Table  2. Autorouter Controls

Button Control

Start Autorouting Begins the autorouting process.

Resume Autorouting Continues the autorouting process after you pause it.

Pause Autorouting Pauses or interrupts the autoroute process. The software 
resumes from the point where it paused when you click 
the Resume Autorouting button.

Stop Autorouting Halts the autorouting process. The software leaves any 
portions that have already been routed in place.

2. Click the Start Autorouting  button to begin autorouting the design.

Step 7 - Generate Reports
After the autorouting routine completes, it generates a routing report detailing the results. A link to the 
report appears in the Status  tab of the Output window.

Procedure
1. If the Output window is not already open, click the Output Window  button on the Standard toolbar. 

2. Click the link in the Status  tab to open the routing report. Additional reports can be generated 
at your request by clicking the File > Reports  menu item and then clicking either the Design, 
Testability, or Test Points  report category.
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Chapter 2
Interactive Routing QuickStart

If desired, you can route all or part of your design manually rather than using the autorouter process.

Perform the following steps to get started quickly.

Alternatively, watch the SailWind Layout and SailWind Router Getting Started Videos for Netlist Projects 
or for all the advanced features in SailWind Router for placing and routing your design, see SailWind 
Router Introductory Videos for Netlist Projects.

Restriction:
Access to some tabs or features may require options not available in your SailWind Router 
configuration

Step 1 - Open a SailWind Layout File
Step 2 - Set Default Design Properties
Step 3 - Route Interactively
Step 4 - Plow traces while routing interactively

Step 1 - Open a SailWind Layout File
SailWind Router reads and writes native SailWind Layout design files. Perform the following steps to load 
a SailWind Layout file.

Procedure

1. On the standard toolbar, click the Open  button. 

2. In the Files of type list, select PCB Design Files (*.pcb,*.bre).

3. Click the SailWind Layout design file you want and then click Open. For example, open the file 
named previewplaced.pcb  in the C:\SailWind Projects\Samples  folder. The file opens in SailWind 
Router.

4. If the file you load contains traces, delete all the traces using Unroute.

a. Right-click in the design area and click the Select Nets  popup menu item.

b. Right-click and click the Select All  popup menu item. All nets are selected.

c. Right-click and click the Unroute  popup menu item.

Alternative: Press the Delete key.

SailWind Router Guide 23



Interactive Routing QuickStart
Step 2 - Set Default Design Properties  

Step 2 - Set Default Design Properties
All design properties and design rules set in SailWind Layout transfer automatically to SailWind Router, 
although you can change them in SailWind Router. SailWind Router also has some additional unique 
properties.

Procedure

1. On the standard toolbar, click the Properties  button. 

2. Assign properties using the tabs in the dialog box. See Table 3.

3. Click OK  to close the Properties dialog box. Access to some tabs or features may require options 
not available in your SailWind Router configuration.

Table  3. Design Properties Tabs

Tab Use to

Clearance Assign default object to object clearances.

Same net Assign default same net object to object clearances.

Routing Assign default trace width, default ripup, and shove preferences.

Via Biasing Assign default via type bias.

Layer Biasing Assign default layer bias.

Test Points Assign default test point clearances and stub length.

Layers Enable layers, set their costs, and assign their routing directions.

Grid Assign default grid values.

Fanout Assign parameters for fanning out from SMD pads.

Pad Entry Assign rules for how traces enter and exit pads.

Topology Assign trace topology preferences.

4. For more information on each tab, click Help  in the tab.
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Step 3 - Route Interactively

Step 3 - Route Interactively
Interactive routing allows you to choose the desired route manually. You can set the level of automatic 
software input during interactive routing by setting certain options and enabling certain features 
beforehand.

Setting interactive routing options
Interactive routing

Setting interactive routing options
Set your design options before routing interactively.

You can change the options as desired; however, the following procedure provides recommended starting 
settings.

Procedure
1. Click the Tools > Options  menu item > Routing  category > General  subcategory.

2. In the “Routing angle” area, select the angle you prefer (Orthogonal, Diagonal, or Any angle).

3. In the Interactive routing area, clear the “Dynamically route” check box.

Tip
When routing interactively, one segment is added at a time. When you click the 
Dynamically route check box, multiple segments and corners are added as you move the 
pointer.

4. In the Plower area, select the “Turn on plower” check box. Specific software configurations have 
the ability to push and shove traces while interactively adding traces. This is done by turning on the 
plower. The plower will be used in a later step. The plower pushes and shoves traces aside to help 
you route.

5. Click the “Plow with pointer” option. This allows you to plow without having to click to engage the 
plower.

6. Click Real-time plowing. This plows immediately without having to guide the trace to an open area.

7. Review the other settings in the Interactive routing area and on the other tabs of the Options dialog 
box.

Note:
On the Colors  tab, ensure the “Connection” color is set to a visible color.

8. Click OK.
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Interactive routing  

Interactive routing
SailWind Router can route your connections intelligently, responding to obstacles in the path and 
adjusting the route accordingly to ensure design rules are met.

Procedure
1. Right-click and click the Select Unroutes/Pins  popup menu item.

2. Select an unroute or pin in the workspace.

3. Right-click and click the Interactive route  popup menu item.

Alternative: Press the F3 key.

4. Move the pointer and click to create each corner in the trace.

Tip
When you select the Dynamically route check box (in the Options dialog box > Routing 
category > General  subcategory), you do not need to click to add corners. Corners and 
segments are automatically added.

5. Click on the object where you want to complete the trace when a single or double circle is visible 
over the completion point.

Alternative: When the pointer is near the object at which you want to complete the trace, right-click 
and click the Complete  popup menu item.

Step 4 - Plow traces while routing interactively
With the plower enabled, the interactive router clears a path for the trace you are routing while 
maintaining existing connections.

Procedure
1. Select an unroute or pin, right-click and click Interactive route. While routing, note that if you 

attempt to cross another trace, or get closer than the minimum trace-to-trace clearance, the other 
trace shoves aside to maintain the minimum clearance.

2. While routing a trace, right-click and notice your plower options. Experiment with the plower 
options. See Table 4.

3. Complete the connection. While routing, you can temporarily change plower settings to complete a 
trace.

Table  4. Plower Options

Command Use to

Push Trace Behind Allow traces to be pushed behind the pointer as you 
interactively route

No Plowing Turn off plowing for the trace in progress
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Step 4 - Plow traces while routing interactively

Command Use to

Plow After Click Reroute obstacles after you click a corner. If you select Plow 
After Click, it only plows after you click to enter a corner or a 
via.

Plow with Pointer Reroute obstacles as you move the pointer

Rip Up Obstructing Traces Unroute obstacles

SailWind Router Guide 27



Interactive Routing QuickStart
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Chapter 3
Preparing a Design

Your design must meet certain requirements before you import it into SailWind Router. After carefully 
preparing your design for import and ensuring it meets all the prerequisites, you can import it using a 
synchronization process for switching back and forth between SailWind Layout and SailWind Router.

Advanced Features in SailWind Router
Prerequisites for Opening a Design in SailWind Router
Synchronization Mode

Advanced Features in SailWind Router
SailWind Router provides advanced features that enable you to perform routing, placement, and design 
rule checking at a level of detail beyond that of SailWind Layout.

Tip
Alternatively, you can watch videos of the advanced features in SailWind Router for placing and 
routing your design. See SailWind Router Introductory Videos for Netlist Projects.

SailWind Router includes the following advanced features.

• Unique component placement grid  — Having components on a separate grid allows you to use 
another grid with a different resolution simultaneously for routing the design.

• Visual design rule checking while placing components  — Visual indicators, such as markers 
for clearance violations, appear while placing components. A description of each error appears 
simultaneously in the Spreadsheet window, providing quick viewing during placement.

• Advanced design rule checking  — While performing design rule checks, you can specify which 
design items to check and what action you want SailWind Router to take for any violations or 
errors it encounters (such as ignore them). With design rule checking enabled, you can also 
pause when errors appear during actions such as routing or component placement. You can 
examine such errors in detail in the Spreadsheet window, allowing you to modify your design 
when necessary.

• Advanced routing capabilities  — SailWind Router provides additional routing tools not 
available in SailWind Layout. For example, you can implement design rules for specialty design 
features such as differential pairs, accordions, and fanouts. Other capabilities include the 
following:

◦ Tuning

◦ Pad centering

◦ Visual design rule checking indicators while routing
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Advanced Features in SailWind Router  

◦ Automatic test point additions

◦ Net scheduling

◦ Trace plowing

• Customization of Keepout fill  — Typically, keepouts created in SailWind Layout appear hatched 
in SailWind Router. If desired, you can change the fill pattern of your keepouts using the extended 
keepout fill options in SailWind Router to distinguish them from copper, fills, and other plane 
areas. You can access fill pattern settings for both keepouts and copper, fills, and planes in the 
Options dialog box > Global  category > General  subcategory.

• Dynamic copper healing  — Flooded copper in copper planes adjusts automatically to changes 
made within the shape. You do not need to flood the shape to see updates to clearances in the 
fill. For example, if you move a component, the copper floods to the required clearances around 
its new position immediately. You can enable the dynamic copper healing feature in the Options 
dialog box > Flooding  category.

• Navigation window  — This window provides an alternate view of the workspace while 
navigating your design:

◦ Displays a magnified view of the design when nothing is selected

◦ Displays cross sectional details when a pin or via is selected

◦ Magnifies the view of any component selected in the design

◦ Magnifies the view of any net objected selected in the design

◦ Monitors and displays the routed length of any length-controlled net during interactive routing

The Navigation window features command buttons that let you show, hide, or zoom in and out 
from various design features (such as traces or components) from the view in the Navigation 
window.

• Spreadsheet window  — This window lets you view and modify design object properties or 
cross probe design rule checking violations flagged in the design. For example, design rule 
violation details appear in the Error  tab of the window. You can thus view design error details as 
they occur while routing or placing components, allowing you to make design modifications as 
necessary.

• Autorouting capability  — You can choose to perform batch autorouting and you can also select 
individual nets, components, or pin pairs for selective autorouting.
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Prerequisites for Opening a Design in SailWind Router

◦ For batch autorouting, determine your strategy first. For example, route or plan to route 
denser components (such as BGAs) before routing other components.

Tip
Even if you are planning to manually route your design, you can use the autorouter 
to make a “first pass” at the design to determine the tightest channels and most 
problematic areas.

◦ For selective autorouting, select a component or net, then right-click and choose one of the 
manual routing options (Route, Fanout, Optimize, Tune, or Center). For best results, protect 
the routes when finished to ensure they remain unchanged during any subsequent batch 
autorouting.

Related Topics
Spreadsheet Window

Options Dialog Box, Global Category, General Subcategory

Options Dialog Box, Flooding Category

Prerequisites for Opening a Design in 
SailWind Router
You must complete a number of prerequisite tasks prior to bringing a design into the SailWind Router 
workspace. Your particular design may or may not require some tasks.

Requirements
You must complete these tasks in SailWind Layout prior to opening the design in SailWind Router:

• Create the board outline

• Define the layer structure of the board including the number of layers and their functional 
assignments (as a minimum you need to define component mounting layer(s), routing layer(s), 
and if they are required - power/ground planes)

• Define any keepouts:

◦ Placement (including component height restrictions)

◦ Component drill

◦ Trace and copper

◦ Copper planes

◦ Via and jumper
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◦ Test points

◦ Accordions

• Import the design netlist from your schematic tool

• Define the padstacks for all of the vias that you will be using to route the board (standard, micro/
laser, blind, and/or buried)

• Define any coppers/copper cutouts, copper planes/copper plane cutouts, hatch areas (Note: 
Router sees hatch outline differently than pour outlines)

• Disperse the components

• Define any Reuse elements required by the design (functionality not available in SailWind Router)

• Create any component unions that may be required

• Check to be sure you have assigned the geometry.height attribute to components if you will be 
using any component height keepout restrictions

Recommendations
Though it is not a prerequisite to perform the following tasks before opening a design in SailWind Router, 
if you eventually need any of these design features, keep in mind that you can only complete them in 
SailWind Layout:

• Create any cutouts or slots in the board outline

• Define additional items in the layer structure of the board such as silkscreen, paste mask, solder 
mask, drill, assembly, or any other specific-use layers

• Add any non-ECO registered components such as tooling holes, mounting holes, fiducials, heat 
sinks, and hardware (optional, if used)

• Create any 2D line items required such as title block, board markings (text on board), graphic 
elements, solder mask reliefs (copper on SM layer), company logos, and other items that your 
company standards require
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Synchronization Mode

Synchronization Mode
Synchronization mode links SailWind Layout and SailWind Router. As you work in SailWind Router, 
changes you make also appear in SailWind Layout; as you work in SailWind Layout, the changes appear 
in SailWind Router. When you are in Synchronization mode, you can instantly switch between the two 
programs, but you are restricted in what you can do in the inactive program.

If you perform an unsupported command or change an unsupported option, the inactive program 
becomes unsynchronized.

Note:
You must and then restart SailWind Layout before Synchronization mode takes effect.

Despite synchronizing with SailWind Router, you must actively switch back to SailWind Layout in order to 
work on your design in SailWind Layout.

You can still use automation; however, most Automation methods will not return any valuable results and 
will not make any changes in the database.

Enabling Synchronization Mode
Sending a Design to SailWind Router in Synchronization Mode
Switching to SailWind Layout
Unsupported Actions in Synchronization Mode
Resynchronizing When the Design Becomes Unsynchronized
Exiting Synchronization Mode

Enabling Synchronization Mode
Synchronization mode links SailWind Layout and SailWind Router so that the design appears in both 
programs simultaneously, enabling you to work in either tool without closing the design in one program 
first.

CAUTION:
Synchronization mode can only be set from SailWind Layout and must be initiated prior to trying 
to send a design to SailWind Router.

Procedure
1. In SailWind Layout, click the Tools  > Options  menu item.

2. In the Options dialog box, click the Global  category, Synchronization  subcategory.

3. In the Layout and Router Synchronization area, select the Enable check box.

Switching to SailWind Router automatically places the design inside SailWind Layout in DRC Off 
mode (the DRC mode in SailWind Router is not affected); therefore, you may want to select the 
“Restore DRC Mode on return” check box. This setting restores the DRC mode that existed before 
switching to SailWind Router when you switch back to SailWind Layout. Depending on the size of 
your design, restoring the DRC mode may take a few minutes.
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4. To receive a warning that your design is being placed into DRC Off mode when you switch to 
Synchronization mode, click “Warn about switching to DRC Off mode” (this check box is not 
available if you select the “Restore DRC mode on return” check box in step 3).

5. Click OK.

6. Restart SailWind Layout.

Sending a Design to SailWind Router in 
Synchronization Mode
Use Synchronization mode to transfer your design to SailWind Router while keeping the design open in 
SailWind Layout.

Procedure
1. Enable Synchronization mode as described in “Enabling Synchronization Mode”  on page 33.

2. Switch to SailWind Router using one of the following:

• On the Standard Toolbar, click the Route  button. 

• Click the Tools > SailWind Router  menu item, and in the SailWind Router Link dialog box, 
select an Action and click Proceed.

Results
SailWind Router opens and loads your design.

Related Topics
Exiting Synchronization Mode

Resynchronizing When the Design Becomes Unsynchronized

Unsupported Actions in Synchronization Mode

Switching to SailWind Layout
You can quickly move your design from SailWind Router back into the SailWind Layout environment.

Procedure

1. On the main toolbar, click the Layout  button. 

2. SailWind Layout opens and your design is loaded.

Tip
To switch back to SailWind Router, click the Route  button on the main toolbar in SailWind 
Layout.
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Unsupported Actions in Synchronization Mode
Synchronization mode does not support some commands and options. If you perform one of these 
commands, or change one of the options, SailWind Layout and SailWind Router become unsynchronized.

Unsupported commands

• Changing a drafting object: copper, copper planes, text, 2D lines, keepouts, labels, board 
outlines, and dimensioning. However, you can move a component that has drafting objects 
attached to it without causing the programs to become unsynchronized.

• Changing rules

• Changing padstacks or layer definitions

• Importing ASCII files (or any other import)

• Verifying the design

• Changing reuses and clusters

• ECO or BGA operations

• Updating from the library

• Using the Decal Editor

• Inserting an OLE object

• Any operation that clears the Undo buffer including Autorouting and large group moves

Unsupported option changes

• Design For Fabrication (DFF)

• Design for Test (DFT)

• Verify Design

• Drafting

• Split/Mixed Plane

• Thermals
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• ECO Options

• Via Patterns

Related Topics
Resynchronizing When the Design Becomes Unsynchronized

Resynchronizing When the Design Becomes 
Unsynchronized
If you perform an unsupported command or change an unsupported option, the inactive program 
becomes unsynchronized. The status bar displays the synchronization status - Active, Inactive, or Out of 
sync. You must resynchronize the design in SailWind Layout or SailWind Router.

Procedure
To re-synchronize the two programs:

• If SailWind Router is “Active” and SailWind Layout is “Out of sync”, on the main toolbar in SailWind 
Router, click the Layout  button.

• If SailWind Layout is “Active” and SailWind Router is “Out of sync”, on the main toolbar in SailWind 
Layout, click the Route  button.

Note:
To turn off the display of licensing warnings when switching between SailWind Layout and 
SailWind Router, type the following text into the SailWindRouter.ini  file (you do not need to restart 
SailWind Router afterward):

[Security]
DisplayWarnings=0

Results
The previously out of sync program is updated with the latest design changes and becomes the active 
program.

Related Topics
Unsupported Actions in Synchronization Mode

Exiting Synchronization Mode
You can exit Synchronization mode at any time after making design changes.
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Exiting Synchronization Mode

Procedure
1. Determine which application you would like to continue working in.

2. To exit Synchronization mode, close the other application.

In Synchronization mode, the Layout  button (on the SailWind Router Standard Toolbar) does not 
send your design to SailWind Layout and then close SailWind Router; therefore, you must close 
the application manually. However, if one of the programs is out of sync, make sure you save 
your changes if you want to keep them. For example, if you want to continue working in SailWind 
Router, but no longer want to be in Synchronization mode, close SailWind Layout. When prompted, 
save your design.
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Chapter 4
File Operations

SailWind Router users can perform basic operations from within the software, including opening design 
files, scheduling automatic file backups, and archiving designs.

About Opening Files
Opening a File
Scheduling File Backups
Archiving Your Design
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About Opening Files
SailWind Router can open certain file types. Opening each file type, however, has associated limitations.

File Types
Text Fonts When Opening a File
Differential Pair Trace Width Settings When Opening a File
Layer Count for Security When Opening a File
T-Junctions When Opening a File
Subnet Conflicts When Opening a File

File Types
SailWind Router allows you to open SailWind Layout and PowerPCB or PowerBGA files. You can also 
open SailWind Router backup files.

SailWind Router supports the following file types:

• SailWind Layout 2005 (or later) .pcb  files

• PowerPCB and PowerBGA versions 3.5 (or later) .pcb  files

• SailWind Router backup (.bre) files

You cannot open a file that another user has open.

When you open a file, the software runs an integrity test to ensure the database is stable. The session log 
records the names and paths of the tested file and the test report as links.

Tip
Click the corresponding link in the sessions log if you want to reopen a file you worked on earlier 
in the session.

Note:
When you exit SailWind Router, all current settings (including the position and size of toolbars, 
dialog boxes, and windows) save to the Windows Registry. SailWind Router uses these saved 
settings the next time you run the program.

Related Topics
Testing Database Integrity

Text Fonts When Opening a File
When you open a .pcb  file in SailWind Router, any text that uses system fonts displays it with the same 
font, font size, and font style as in SailWind Layout.
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Differential Pair Trace Width Settings When Opening a File

If any text in the file uses fonts not installed on your computer, a message in the Status Window indicates 
that text using those fonts will be replaced by empty boxes. These boxes appear in the same size as the 
text they replace, so you can examine the empty boxes for clearances, even though you cannot view the 
actual text.

Differential Pair Trace Width Settings When 
Opening a File
You can set the width and gap for differential pair traces for all layers, or per layer. (For early versions, 
SailWind Router set the width and gap.)

For information on setting the width and gap per layer, see ““Setting Differential Pair Properties”  on 
page 184”.

For .pcb  files created prior to PADS2005 SPac2, SailWind Router sets a width and gap for each 
differential pair, as follows:

• Sets the width for all layers as the larger of the recommended widths for each member of the 
differential pair.

• Sets the gap assigned to the differential pair for all layers.

Layer Count for Security When Opening a File
When you open a file, SailWind Router checks the number of layers available for routing in your design 
against your security limits.

The following layers are counted as layers available for routing:

• CAM plane layers with routes

• Top and bottom layers with components

• Electrical layers

• Split/mixed plane layers

If your design has more layers available for routing than those for which you are licensed, all split/mixed 
plane layers without routing or components are disabled for autorouting. (You can view the disabled 
layers in the Layers  tab of the Design Properties dialog box.)

For example, assume your design is a six-layer board (four routing layers and two split/mixed layers 
without routing or components), and you have a four-layer license. When SailWind Router reads this 
design, it disables the split/mixed plane layers that have no routing or components. (Split/mixed plane 
layers with routing or components are not disabled.) The resulting layers available for routing count of four 
is within your security limits (a four-layer license), and the design can be routed.

To enable a disabled layer, you must obtain a higher layer count option in your license file. For floating 
security, you may be able to check out a higher limit. For node-locked licensing, you may need to 
purchase a new configuration. In either case, you must restart the program for the new settings to take 
effect.

SailWind Router Guide 41



File Operations
T-Junctions When Opening a File  

T-Junctions When Opening a File
When you open a SailWind Layout design in SailWind Router and the design violates the no trace sharing 
rule, SailWind Router disconnects the affecting trace, depending on the structure of the route pattern.

If no more than two pin pairs share the segments, SailWind Router establishes a rule boundary 
automatically to make the design comply with the program’s rules. “Rule boundaries”  on page 42
improve the management of these conflicts and eliminate the requirement to disconnect traces when 
opening a file.

Subnet Conflicts When Opening a File
When you open a design and this design has subnet overlaps, the nets with subnet conflicts convert 
to structures the program can manage. Subnet conflicts occur when a trace or via belongs to several 
subnets.

SailWind Router adds rule boundaries to avoid unrouting portions of a trace when pin pairs of a net share 
a single trace segment.

Figure 1. Rule Boundaries When Pin Pairs Share a Trace Segment

When pin pairs of the same net share two trace segments that converge at one point, the software 
creates two overlapping rule boundaries. Because the software cannot resolve this type of conflict, it 
disconnects some traces.

Figure 2  shows how the software disconnects such traces.
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Figure 2. Disconnected Traces

Opening a File
You can open SailWind Layout .pcb  design files and SailWind Router .bre backup files.

When you open a file:

• Design Rule Checking (DRC) is enabled, regardless of the setting in SailWind Layout.

• In-line trace corners are removed.

For more detailed information about opening files, and about processes that occur during opening, see 
““About Opening Files”  on page 40.”

Restrictions and Limitations
SailWind Router does not open .bre  files saved using a different SailWind Router version.

Procedure
On the standard toolbar, click the File > Open  menu item or click the Open  button on the main toolbar. 

Results
If SailWind Router discovers incompatibilities when importing an ASCII file created in a version prior to 
PADS 9.2, it displays a warning prompt and writes the incompatibilities to the ascii.err file.

Scheduling File Backups
You can schedule backups to occur automatically while a design is open for editing.
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Procedure
1. Click the Tools > Options  menu item > Global  category > Backups  subcategory.

2. In the Options Dialog Box, Global Category, Backups Subcategory, in the Interval box, type the 
time in minutes between backups.

3. In the Number of Backups box, type the maximum number of backups you want to keep.

When the number of backups reaches this limit, the oldest existing backup is deleted whenever a 
new backup is created.

Tip
This limit can specify the maximum number of backups for all designs, or the number of 
backups for each design. For more information, see the table “Table 88”  on page 438.

4. Select the “Use design name in backup file name” check box to use “<design name>_Router” 
instead of “Router” in the backup file name.

For example: <design_name>_Router_<date_time>.bre, instead of Router_<date_time>.bre

5. Select the “Create backup files in design directory” check box to place backup files in the same 
directory as the design.

6. Click OK.

Results
Backups will be saved according to settings made in this procedure, either in the design directory, or 
in the default Backup location specified in the “Options Dialog Box, Global Category, File Locations 
Subcategory”  on page 439. Also, a link to the saved backup is recorded in the session log that appears 
in the Status  tab of the Output window.

Related Topics
About Opening Files

Opening a File

Archiving Your Design
You can create a folder or a .zip  file that contains all of your design files and supporting files for archive 
purposes. The folder or zip file may include the design itself, a schematic file, libraries, and any additional 
files or folders you want to save.

Procedure
1. Open the design you want to archive.

2. Click the File > Archive  menu item.

3. Select the files and folders you want to archive (see “Archiver Dialog Box”  on page 389).

4. Click OK.
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Archiving Your Design

Results

• If you chose to not compress the files, SailWind Router archives the selected items in the target 
folder you specified.

• If you chose to compress the files, SailWind Router creates a .zip  file containing the selected 
items in the target folder you specified. The filename has the following format:

  <project_name>YYYYMMDDHHMMSS.zip
 

Where YYYY is the year, MM is the month, DD is the day, HH is the hour (using the 24-hour clock 
system), MM is the minute, and SS is the second of the time you created the file.

Related Topics
Archiver Dialog Box
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Chapter 5
Interface Elements

The SailWind Router interface provides standard Windows menus and buttons for accessing commands 
and settings.

Figure 3. SailWind Router User Interface
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Note:
Pictures in this document are for reference only, to help users better understand the software 
operation. In the case of interface difference due to version changes, the interface of SailWind 
Router in practice shall prevail.

• Title Bar — The application icon, document name, and application name appear in the title bar. 
Click the application icon to open the Windows-standard control menu, which contains commands 
for working with the application window. The document name changes to reflect the state of 
the current document. For example, when no design file is loaded "Untitled - SailWind Router" 
appears as the document name. When a design file is loaded, the path, the filename, and the file 
extension (.pcb or .bre) appear in the title bar.

• Menu Bar — The menu bar lists SailWind Router commands. The menus also show the 
appropriate command icons, access keys, and shortcuts. When a command ends with ellipses 
(...), additional information is needed to complete the command.

• Standard Toolbar  — The Standard toolbar contains commands that open and save designs, 
change the view, redraw the design, and access the toolboxes.

• Status Bar — The status bar contains status messages, cursor coordinates, and a system status 
indicator. When the system status indicator is green, the system is idle or ready for operation. 
When the system status indicator is red, the system cannot receive user input. The status 
bar also has a ToolTip that is a routing progress indicator. For more information see ““Routing 
Progress Indicator”  on page 277.”

• Synchronization Mode Indicator  — Indicates that SailWind Layout and SailWind Router are 
in Synchronization mode. Also indicates which program is the active one versus the inactive 
one or whether the inactive program is out of sync. Enable synchronization mode from SailWind 
Layout to make this indicator available. See “Enabling Synchronization Mode”  on page 33 for 
more information.

• Line Width— Displays the current line width setting.

• X,Y Coordinate— Displays the horizontal distance of the cursor from 0,0 as the x-coordinate and 
the vertical distance of the cursor from 0,0 as the y-coordinate. Also indicates the polar radius 
and the polar angle if you are using a polar grid.

• Units  — Displays the current units in the design: inches, mils, millimeters, or microns. All values 
in dialog boxes display in these units and values you enter are interpreted in these units. For 
information about setting the design units, see “Options Dialog Box, Global Category, General 
Subcategory”  on page 441.

Project Explorer
Output Window
Navigation Window
Spreadsheet Window
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Project Explorer
Project Explorer gives you a view of the objects in your design that is different from the view in the 
workspace. Instead of showing design objects in their places on the board, it lists them in a hierarchical 
alphabetized list. The Project Explorer view can make it easier to find and select objects.

Tip
To allow objects selected in the Project Explorer to also highlight in the workspace, right-click in 
the window and click Allow Selection. To zoom to the item you select in Project Explorer, right-
click and click Zoom to Selection.

Figure 4. Project Explorer

In the Project Explorer list, an asterisk in the top left corner of an object indicates that it has rules that 
are not the default rules. An asterisk in the bottom right corner of an object indicates that its secondary 
objects contain rules that are not the default rules.

When you change your design, the hierarchical list automatically updates to reflect the changes.

Project Explorer Objects
Project Explorer Operations
Splitting the Project Explorer View
Sorting Objects in Project Explorer
Creating a New Object in a Secondary Group
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Removing an Object From a Secondary Group
Renaming Secondary Group Elements

Project Explorer Objects
Design objects in Project Explorer are organized into primary groups  and secondary groups.

Table 5  shows the hierarchy of groups and objects.

Table  5. Hierarchy of Objects in Project Explorer

Primary Groups Secondary 
Groups Description

Electrical Layers Lists all layers enabled for routing, including plane layers 
and routing layers.

Layers

General Layers Lists all non-electrical layers, such as solder mask and 
silkscreen.

Components Lists all components and their corresponding pin pairs.

Part decals/PCB 
decals

Lists all part decals in the design or all components that 
use the selected part decal.

Net Classes Lists all nets belonging to net classes.

Matched Length 
Net Groups

Lists all net groups set up to have equal total net lengths.
You can create matched length net groups directly from 
within the Project Explorer. For more information, see 
Creating Matched Length Net Groups.

Nets Lists all nets in the design.

Electrical Nets Lists all electrical nets in the design.
An electrical net  is an array of nets jointed by discrete 
components. For more information, see Electrical Nets.

Matched length pin 
pair groups

Lists all pin pair groups set up to have equal total net 
lengths.
You can create matched length pin pair groups directly 
from within the Project Explorer. For more information, see 
Creating Matched Length Pin Pair Groups.

Pin pair groups Lists all nets belonging to pin pair groups (containing pin 
pair rules).

Conditional rules Lists all nets with conditional rules.

Net objects

Differential pairs Lists all nets assigned as differential pairs.
You can create differential pairs directly from within the 
Project Explorer. For more information, see Creating 
Differential Pairs.
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Table  5. Hierarchy of Objects in Project Explorer  (continued)

Primary Groups Secondary 
Groups Description

Via types Lists the via types used in the design.

Project Explorer Operations
Use the Project Explorer to create delet rename and sort secondary group objects (rules objects).

Operations on Primary Groups in Netlist Projects
All objects listed under the Layers, Components, Part Decals, Via Types, and Net Objects/Nets groups 
are netlist objects. Because SailWind Router is a non-ECO product and does not support netlist changes, 
you cannot delete, rename, move, or cut any of these objects. You can, however, copy objects from 
these groups to create new members of secondary groups. As an example, you cannot delete a net from 
the Nets group; but you can copy a net into the secondary group Net Classes to create a new net class 
containing this net.

Operations on Secondary Groups in Netlist Projects
With the exception of the Nets group, you can create new members in all the secondary groups under Net 
Objects, and you can edit all members of those groups to some degree.

To create a new member of a group, copy/paste or drag and drop appropriate objects into the group. For 
instance, to create a new net class, drag and drop one or more nets into the Net Classes group.

Tip
You can also create and name a new empty  member of the Net Classes, Matched Length Net 
Groups, Pin Pair Groups, and Matched Length Pin Pair Groups using the right-click > New 
command.

Table 6  lists the objects you can add to each of these secondary groups to create a new member of the 
group. Table 7  lists the operations you can perform on members of the groups.

Table  6. Objects You Can Add to Secondary Groups

Secondary Group Objects You Can Add

Net Classes Net

 Tip
You can drag and drop an electrical net into a net class, 
but this adds the individual nets of the electrical net to the 
net class, not the electrical net itself.

Electrical Nets Electrical net

Matched Length Net Groups Net class, net, electrical net

Pin Pair Groups Pin pair
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Table  6. Objects You Can Add to Secondary Groups  (continued)

Secondary Group Objects You Can Add

Conditional rule Net class, net, pin pair group, pin pair, and layer. For more 
information, see ““Conditional Rules”  on page 175.”

Matched Length Pin Pair Groups Pin pair group, pin pair

Differential pair Net, pin pair, electrical net

 Tip
A differential pair contains exactly two pin pairs, two nets, 
or two electrical nets.

Table  7. Operations on Members of Secondary Groups

Secondary Group Available Operations on Members

Net classes Copy/paste or drag and drop into group to create, new, 
rename, delete

Electrical Nets New, delete

Matched Length Net Groups Copy/paste or drag and drop into group to create, new, 
rename, delete

Pin Pair Groups Copy/paste or drag and drop into group to create, new, 
rename, delete

Conditional Rules Delete

 Tip
You cannot remove individual elements of a conditional 
rule.

Matched Length Pin Pair Groups Copy/paste or drag and drop into group to create, new, 
rename, delete

Differential Pairs Copy/paste or drag and drop into group to create, delete

 Tip
You cannot remove individual elements of a differential 
pair.

Splitting the Project Explorer View
You can split the view of Project Explorer to create a second instance of the tree. Splitting the view is 
useful when you repeatedly copy and paste or drag and drop objects into Net Objects subtrees; for 
example, when you copy nets to create a Net Class.

You can split the view horizontally or vertically. The vertical split displays more of the tree and requires 
less scrolling, while the horizontal split allows wider views of the tree and viewing full names of design 
objects without scrolling left and right, and without sacrificing design space.
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Figure 5. Project Explorer Split Views

Procedure
1. Position the pointer in the tree area of Project Explorer.

2. Right-click and click the Vertical Split  or the Horizontal Split  popup menu item.

Sorting Objects in Project Explorer
You can sort objects either alphabetically or by rules. Sorting by rules lists objects with rules at the top of 
the list.

Procedure
To sort the view by rules, right-click and click the Sort by Rules  popup menu item. To sort alphabetically 
again, click the Sort by Rules  popup menu item again.

Creating a New Object in a Secondary Group
With the exception of the Nets group, you can create new members in all the secondary groups under Net 
Objects. You can also edit all members of those groups to some degree.

Secondary groups include net classes, pin pair groups, conditional rules, matched length net groups, 
matched length pin pair groups, electrical nets, and differential pairs.

The following table provides a summary of methods for creating new members of secondary object 
groups.
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To create this... Perform these steps:

Net class Either:
• Drag and drop nets from primary object groups into the Net 

Class primary group. This action creates a new net class 
automatically that you can then name.

• Select the Net Class primary group. Right-click and click New. 
Name the net class, and then drag and drop nets into it.

 Tip
You can drag and drop an electrical net into a net class, but 
this adds the individual nets of the electrical net to the net 
class, not the electrical net itself.

For more information, see “Creating Net Classes”  on page 172.

Pin pair group Either:
• Drag and drop pin pairs from primary object groups into the Pin 

Pair Groups primary group. This action creates a new pin pair 
group automatically that you can then name.

• Select the Pin Pair Groups primary group. Right-click and click 
the New  popup menu item. Name the new group, and then 
drag and drop pin pairs into it.

For more information, see “Creating Pin Pair Groups”  on 
page 174.

Conditional rule Drag and drop net objects from primary object groups into the 
Conditional Rules primary group. This action creates a new 
conditional rule and name automatically.
For more information, see “Creating Conditional Rules”  on 
page 178.

Matched length net group Either:
• Drag and drop nets and/or electrical nets from primary object 

groups into the Matched Length Net Groups primary group. 
This action creates a new group automatically that you can 
then name.

• Select the Matched Length Net Groups primary group. 
Right-click and click the New  popup menu item. Name the 
group, and then drag and drop nets into it.

For more information, see “Creating Matched Length Net Groups” 
on page 179.

Matched length pin pair group Either:
• Drag and drop pin pairs from primary object groups into the 

Matched Length Pin Pair Groups primary group. This action 
creates a new group automatically that you can then name.

• Select the Matched Length Pin Pair Groups primary group. 
Right-click and click the New  popup menu item. Name the 
group, and then drag and drop nets and/or electrical nets into 
it.
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To create this... Perform these steps:

For more information, see “Creating Matched Length Pin Pair 
Groups”  on page 180.

Differential pair Select two nets in the Nets primary group, or two electrical nets in 
the Electrical Nets primary group, right-click, click the Copy  popup 
menu item, select the Differential Pairs primary group, right-click, 
and then click the Paste  popup menu item. This action creates a 
new differential pair automatically.
Alternative: Select two nets or two electrical nets in the design 
workspace, right-click, and then click the Make Differential Net or 
Make Differential Electrical Net  popup menu item.
For more information, see “Creating Differential Pairs”  on 
page 181.

Removing an Object From a Secondary Group
You can remove an object from Net Classes, Electrical Nets, Pin Pair Groups, Matched Length Net 
Groups, or Matched Length Pin Pair Groups.

You cannot remove individual objects from Differential Pairs and Conditional Rules.

Procedure
Right-click the object to remove and click the Delete  popup menu item.

Results
The objects are removed from the secondary group only; they are not  deleted from the design.

Renaming Secondary Group Elements
You can rename secondary group elements of Net Classes, Matched Length Net Groups, Matched 
Length Pin Pair Groups, and Pin Pair Groups.

You cannot rename an Electrical Net or Differential Pair Group.

Procedure
1. Right-click the secondary group name, and click the Rename  popup menu item.

2. Type a new name over the previous name, and press Enter.
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Output Window
Use the three tabs of the Output window to display reports and session logs, edit and debug macros, and 
do custom programming and debugging.

The Output window is located in the lower left section of the interface. You can dock or float the Output 
window. You can also open or close the Output window.

Status Tab
Macro Tab
Basic Tab
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Status Tab
To access: From the Standard toolbar, click the Output Window  button, and then choose the Status  tab.

Use this tab to record, display, and print session logs, report files, web pages, and to open program files.

Description
The Status  tab displays information about the current session. It specifies the filename of the opened 
PCB file and the name of the test integrity file that is saved. It also reports routing statistics and messages 
when routing a board.

If the Status  tab is closed, and you get an error while auto-routing (or performing other tasks), the Output 
window opens with the Status  tab active and the error appears in red. The Output window appears in its 
most recent state (floating or docked).

Objects

Object Description

Session log The session.log  file contains all program output for the current 
session, including names of open and saved files, integrity 
test results, routing statistics, and messages. SailWind Router 
constantly updates the session log during autorouting.
The session log presents types of information in different 
colors. Underlined items are links.

• Red — Errors

Green — Warnings

Black — Messages

Blue — Links to files, web pages, and database objects.

Navigation buttons Navigate through the pages of reports in the session log.

Filter  popup menu item Filter session log messages according to type:
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Object Description

• Error

• Warning

• Message

• Show all

Find  popup menu item Right-click and click the Find  popup menu item to search the 
session log contents.

Print  popup menu item Print the entire session log using the Print  popup menu item 
or print an individual report by right-clicking it and clicking the 
Print  popup menu item.

View  popup menu item Click any report to view it in detail.

Log to File  popup menu item Saves the session log for future reference.
If a session log file already exists, new information is 
appended. If a session log file does not exist, a new file is 
created. The default path (\SailWind Projects) for the session 
log file is set when you install the program. In SailWind Router, 
you can change the default filename and path in the “Options 
Dialog Box, Global Category, File Locations Subcategory”  on 
page 439.

 Note:
You can clear the session log display each time you open a 
file. Clearing the session log prevents you from accidentally 
viewing information from a previously opened file; however, 
it does not delete the log file.
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Macro Tab
You can edit, run, and debug macro scripts in the Macro  tab. You can open multiple macros and nest 
macros using the macro editor.

A macro is any combination of commands, keystrokes, and mouse clicks that you record to replay as a 
single action. You can record virtually any set of procedural steps for replay, thereby simplifying redundant 
activities, such as setting preferences and layer/display settings.

Figure 6. Macro Tab

Creating Macros
Managing Macros
Playing Back a Macro
Stopping a Playing Macro
Debugging Macro Scripts
Accessing Help on the Macro Language
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Creating Macros
You can create macros to execute often-performed actions. You can record a series of procedural steps 
for replay as a single action; you can also nest macros.

Tip
Dialog box actions are recorded as results rather than actions, so when you replay, you do not 
see the dialog boxes in the replay process. Because of this you cannot create a macro that stops 
on an open dialog box; it must follow through to some result or action. For example, you can 
create a macro that selects Open on the File menu, selects a file, and selects OK. The macro, 
when played back, opens a file.

Creating a New Macro
Mouse Movement Recording
Saving the Macro

Creating a New Macro
Set up a new macro for tasks that SailWind Router may perform frequently.

Procedure
1. Click the Output Window  button.

2. On the Macro  tab, click the New  button. New macros are given a name of Macro#, where # is a 
numeric sequence such as Macro1 or Macro2.

3. You can click the Compress mouse moves  and/or Relative mouse moves  buttons. See Mouse 
Movement Recording  for more information.

4. On the Macro  tab toolbar, click the Record  button.

5. Perform the keystrokes, commands, and mouse clicks to include in the macro.

6. On the Macro  tab toolbar, click the Stop  button.

Tip
You can also script a macro instead of recording mouse actions.

Mouse Movement Recording
You can record mouse movements in macros. You can record compressed or uncompressed mouse 
movements and relative or absolute movements.

Compress Mouse Mode— Compress mouse mode records only the start point and endpoint of a mouse 
movement. It does not record any of the intermediate coordinates between the start and end points. 
Compression is recommended under most circumstances because it significantly reduces the size of your 
macro file. Recording intermediate mouse movements increases the file size, but documents coordinate 
information if required for a special application.
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Relative Mouse Mode— Relative mouse mode records the start point and endpoint of a movement in 
incremental coordinates instead of absolute coordinates.

Saving the Macro
Save your macro after completing it.

Procedure
1. Click the Save  button.

2. In the standard Windows Save As dialog box, enter a filename, if desired, and click Save.
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Managing Macros
Read the following topics to learn more about managing macro files.

Opening an Existing Macro File
Viewing Multiple Open Macros
Editing a Macro
Saving the Macro Edits

Opening an Existing Macro File
SailWind Router stores the macros you create in (.mcr) files. You can use either the menus or the toolbar 
to open an existing macro file.

Tip
You can open multiple macros in the macro editor. The macro editor also supports nested macros.

Procedure
1. In the Output Window, click the Macro  tab.

2. Click the Open  button.

3. In the Open File dialog box, select the macro file to open and click Open.

Viewing Multiple Open Macros
You can open multiple macros in the macro editor and switch between them.

Procedure
Click the macro you want to view in the List of Open Macros area of the Macro  tab.

Figure 7. The Macro Tab
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Editing a Macro
You can copy or cut selected text to the Clipboard. After copying text to the Clipboard, you can then paste 
the selection into the text window or paste the text into other applications. You can also switch between 
open macros to edit multiple macros.

Procedure
1. Select the text you want to copy or cut.

2. Right-click in the Output window and click the Copy  or Cut  popup menu items.

3. Right-click in the Output window and click the Paste  button. You will see that your selection has 
been pasted in the Output window at the insertion point.

Saving the Macro Edits
When you have completed editing the macro, you must save it as described in the following procedure.

Procedure
1. Click the Save  button.

2. In the standard Windows Save As dialog box, enter a filename, if necessary, and click Save.

Playing Back a Macro
You can play back a macro after creating it. (When you play a macro, you cannot use the mouse in the 
workspace.)

Procedure
1. On the Macro  tab, click the Open  button and open a macro (.mcr) file. Recent macros can be 

found by clicking the Tools > Macros  menu item. Alternatively, you can right-click in the Macro  tab 
and click Run.

2. On the Macro  tab toolbar, click the Run  button.

Tip
Use the Pause  and Play  buttons in the Macro  tab toolbar to pause and play the running 
macro.

Stopping a Playing Macro
You can stop the playback of a macro at any time. However, you cannot resume the playback of the 
macro after stopping it. When you click Run, the macro starts from the beginning.

Procedure
Right-click and click the Stop  popup menu item.
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Debugging Macro Scripts
You can play back a macro by either running it step-by-step, or by allowing it to run to a certain point in 
the script. To perform these debugging tasks, insert breakpoints in the macro script at places where you 
want the macro to stop.

Setting and Removing Breakpoints
Debugging the Macro Scripts
Correcting Run-Time Errors

Setting and Removing Breakpoints
Set and remove breakpoints before debugging a macro. If the macro engine encounters a breakpoint 
during macro playback, it pauses the macro.

Procedure
1. Place the cursor on the line where you want to add a breakpoint.

2. Right-click in the Macro  tab and click the Toggle Break  popup menu item. This inserts a 
breakpoint at the current cursor location. A breakpoint marker appears in the gutter area. 
Alternatively, on the Macro  tab toolbar, click the Toggle Breakpoint  button.

Results
When the macro engine encounters a breakpoint while playing back a macro, it pauses the macro. It also 
marks the next line in the macro with the instruction pointer.

Debugging the Macro Scripts
You can debug your macros after inserting breakpoints.

Use the commands in the following table for debugging:

Table  8. Macro Script Debugging Commands

To Do This Perform These Steps

Play a single line of the macro. • Right-click in the Macro  tab and click the Step Over  popup 
menu item

or

• On the Macro  tab toolbar, click the Step over  button

Perform a subroutine call on the 
current line.

• Right-click in the Macro  tab and click the Step Into  popup 
menu item

or

• On the Macro  tab toolbar, click the Step into  button
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Table  8. Macro Script Debugging Commands  (continued)

To Do This Perform These Steps

Return from a subroutine to the 
point from which it was called.

• Right-click in the Macro  tab and click the Step Out  popup 
menu item

or

• On the Macro  tab toolbar, click the Step out  button

Play back a macro to a given 
point.

• Right-click in the Macro  tab and click the Step to Cursor 
popup menu item

or

• On the Macro  tab toolbar, click the Step to cursor  button

Continue the execution from the 
current point.

• Right click in the Macro  tab and click the Run  popup menu 
item

or

• On the Macro  tab toolbar, click the Run  button

Correcting Run-Time Errors
If run-time errors occur, the macro debugger switches to step-by-step mode and displays a detailed 
message on the status bar. The instruction pointer displays on the line that produced the error. After fixing 
the error, you can resume playback of the macro.

Accessing Help on the Macro Language
You can access Help on the macro language calls while scripting or running macros. Help topics provide 
term information and sample scripts.

Procedure
Click in the edit area of the Macro  tab and press the F1 key.
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Basic Tab
Use the Basic Script Editor in the Basic  tab to create, edit, run, and troubleshoot Basic scripts from 
SailWind applications.

Figure 8. Basic Tab

Managing Scripts
Creating Scripts
Running Scripts
Debugging Scripts
Accessing Help on the Basic Language
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Managing Scripts
You can open, edit, print, and save scripts directly from within SailWind Router.

Opening an Existing Script
Managing Open Scripts
Editing a Script
Editing a User Dialog Box
Finding an Automation Statement
Printing a Script
Saving a Script
Watching a Variable

Opening an Existing Script
Use the procedure that follows to open a script in SailWind Router. Scripts that SailWind Router can open 
have a .bas  extension. The default location for .bas  files is C:\SailWind Projects.

Tip
You can have up to nine scripts open at the same time.

Procedure
1. In the Basic Script Editor, click the Open  button.

2. In the Open Script window, select the script and then click Open.

Managing Open Scripts
The commands on the Sheet submenu provide script management commands. As you can have up to 
nine scripts open at the same time, you can open #uses, close sheets, close multiple sheets, and choose 
scripts to view and edit.

After you have inserted breakpoints in the script, you can debug it using the commands in the following 
table.

Table  9. Sheet Submenu Commands

To Do This Perform These Steps in the Basic Script Editor

Open a #uses module.
(#Uses modules are Basic 
scripts that are called from 
within other scripts.)

Right-click and click Sheet > Open Uses.
The #uses modules called in the script appear as script sheets in the 
Basic Script Editor. They are assigned a numbered tab and you can 
edit or run them.

Close an open script. • Right-click and click the Sheet >  Close  menu item

or

• Double-click the script’s numbered tab in the gutter

SailWind Router Guide 67



Interface Elements
Editing a Script  

Table  9. Sheet Submenu Commands  (continued)

To Do This Perform These Steps in the Basic Script Editor

Close all open scripts. Right-click and click the Sheet > Close All  popup menu item.

Select an open script to view.

 Tip
You can have up to nine 
scripts open at the same 
time

• Right-click and click the Sheet  popup menu item; then click the 
script you want to view from the list of open scripts on the submenu

or

• Click the script's numbered tab in the gutter.

Editing a Script
You can copy or cut selected text from the Basic Script Editor to the Clipboard and paste a selection from 
the Clipboard into the text window. You can also paste text from the Clipboard into other applications.

Procedure
1. In the Basic Script Editor, select the text you want to copy or cut.

2. Right-click and click the Copy  or the Cut  popup menu item.

3. Right-click and click the Paste  popup menu item to paste the script text. Your selection is pasted in 
the Output window at the insertion point.

Alternatively, you can click the Copy, Cut, and Paste buttons on the Basic Script Editor toolbar.

Editing a User Dialog Box
You can edit a user dialog graphically. A User Dialog is defined by a “Begin Dialog...End Dialog” block in a 
Basic script.

Procedure
1. In the Basic Script Editor, put your cursor in a User Dialog block of the script.

2. Click the Edit User Dialog  button. (This button is at the far right of the toolbar; you may need to 
expand the Output Window to see it.)

For more information, see the Sax Basic Editor Online Help  (C:\<install_folder>\<version>
\Programs\sbe5_000.hlp)

Finding an Automation Statement
If you are working with a long script, you can search for particular statements.

Procedure
1. In the Basic Script Editor, click the Object list and select an object type. The Object list shows all 

the objects for the current module. The (General) object groups all of the procedures that are not 
part of any specific object.

2. Click the Procedure list and select a bold procedure. The Procedure list shows all the procedures 
for the current object. Selecting a procedure that is bold locates the procedure in the script.
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Results
The statement appears in the Basic Script Editor.

Printing a Script
You can print a Basic script from within the Basic Script Editor.

Procedure
1. Open the script in the Basic Script Editor.

2. On the toolbar, click the Print  button.

Saving a Script
Keep your Basic scripts for future use by saving them.

Procedure
1. In the Basic Script Editor, click the Save  button.

2. Type a filename and then click Save.

Watching a Variable
Use Quick Watch to show the value of the expression under the cursor in the immediate window.

Procedure
1. Right-click and click the Quick Watch  popup menu item, or click the Quick Watch  button.

2. See also: Sax Basic Editor On Line Help  (C:\<install_folder>\<version>\Programs\sbe5_000.hlp).
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Creating Scripts
You can create scripts to execute often-performed actions in SailWind Router.

Creating a Script
Inserting an Automation Statement Using the Object and Procedure Lists
Inserting an Automation Statement Using the ActiveX Automation Members Dialog
Setting the Next Statement
Showing the Next Statement
Saving the Script

Creating a Script
You can write scripts for SailWind Router using the Basic Script Editor.

Procedure
1. Click the Tools > Basic Scripts > Basic Script Editor  menu item.

The Basic  tab opens in the Output window.

Note:
In SailWind Layout and SailWind Logic, the SAX Basic Engine dialog box appears.

2. Click the New  button.

Inserting an Automation Statement Using the Object and 
Procedure Lists
Use the Object and Procedure lists to select and insert a statement. These lists contain the most 
commonly used statements.

Procedure
1. Click the Object list and click an object type. The Object list shows all the objects for the current 

module. The (General) object groups all of the procedures that are not part of any specific object.

2. Click the Procedure list and click a non-bold procedure to insert. The Procedure list shows all 
the procedures for the current object. Selecting a procedure that is not bold inserts the proper 
procedure definition for that procedure.

Results
The statement appears at the bottom of the script.

Inserting an Automation Statement Using the ActiveX Automation 
Members Dialog
Use the Object and Procedure lists to select and insert a statement.
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CAUTION:
If the pointer is on any line in the script other than the bottom line, the line is overwritten.

Procedure
1. In the Basic Script Editor, right-click and click the Browse  popup menu item.

2. Use the ActiveX Automation Members dialog box to select and insert a statement. This dialog box 
contains an extensive list of statements.

Setting the Next Statement
You can force a particular line in a script to run next. (You can only select statements in the current 
subroutine or function.)

Procedure
1. In the Basic Script Editor, put your cursor on the line you want to run next.

2. Right-click and click the Set Next Statement  popup menu item.

Results
An instruction pointer appears next to the selected line. This line, and only this line, will run next. If you go 
to other parts of the script, you can return to this line by clicking Show Next Statement.

Showing the Next Statement
You can use the “Show Next Statement” feature in the Basic Script Editor to locate the next point in the 
script to run. This feature is especially useful during debugging operations.

Procedure
In the Basic Script Editor, right-click and click the Show Next Statement  popup menu item.

Results
An instruction pointer indicates the next statement to run. Pausing a running script or setting a statement 
to run next sets the next statement. You can locate the set statement from anywhere in the script.

Saving the Script
Store your scripts for future use by saving them from within the Basic Script Editor.

Procedure
1. In the Basic Script Editor, click the Save  button.

2. Type a file name and then click Save.
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Running Scripts
You can run an existing script using Run or resume the playback of a paused script. (When you run a 
script, you cannot use the mouse in the workspace.)

Running a Script
Pausing and Resuming a Running Script
Stopping a Running Script

Running a Script
Use the Basic Script Editor to open and run scripts.

Procedure
1. In the Basic Script Editor, open a script file.

2. Right-click and click the Run  popup menu item. Alternatively, on the Basic Script Editor toolbar, 
click the Run  button.

Pausing and Resuming a Running Script
When running a long script, you can pause it to perform some other design activity, and then resume it.

Procedure
1. In the Basic Script Editor, right-click and click the Pause  popup menu item. (Or click the Pause 

button in the toolbar.)

2. When you are ready to resume running the script, right-click in the Basic Script Editor and click the 
Run, Step Over, or Step to Cursor  button.

Stopping a Running Script
You can stop a running script at any time. However, you cannot resume running a script once you have 
stopped it. When you click Run, the script starts from the beginning.

Procedure
In the Basic Script Editor, right-click and click Stop.  (Or click the Stop  button in the toolbar.)
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Debugging Scripts
When running a script, you can run it step-by-step or to a certain location in the script. To perform these 
debugging tasks, insert breakpoints in the script at the points at which you want the script to stop.

Setting or Removing the Breakpoints
Debugging the Scripts—Commands
Correcting Run-time Errors

Setting or Removing the Breakpoints
The ability to set or remove breakpoints is useful when you debug a script. If the Basic engine encounters 
a breakpoint when running a script, it pauses the execution of the script. An instruction pointer marks the 
next line in the script.

Procedure
1. Place the cursor on the line where you want to add a breakpoint.

2. On the Basic Script Editor toolbar, click the Toggle Breakpoint  button. Alternatively, in the Basic 
Editor, right-click and click the Toggle Break  popup menu item.

Results
A breakpoint is inserted at the current cursor location. A breakpoint marker appears in the gutter area.

Debugging the Scripts—Commands
You can begin debugging a script after you have inserted breakpoints.

Debug your script using the following commands:

Table  10. Basic Script Debugging Commands

To Do This Perform These Steps in the Basic Script Editor

Run a single line of the script Click the Step over button on the toolbar.

Perform a subroutine call on 
the current line.

Click the Step into  button on the toolbar. (Or right-click in the edit area 
and click the Step into  popup menu item.)

Return from the subroutine 
to the point from which it was 
called.

Click the Step out  button on the toolbar.

Run a script to a given point. In the edit area, set the cursor on the line at which you want to pause, 
then right-click and click the Step to cursor  popup menu item

To continue the execution 
from the current point.

Click the Run  button on the toolbar. (Or right-click and click the Run 
popup menu item.)

Remove all breakpoints. In the edit area, right-click and click the Clear All Breaks  popup menu 
item.
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Correcting Run-time Errors
If run-time errors occur, the script debugger switches to step-by-step mode and displays a detailed 
message on the status bar. The instruction pointer appears on the line that produced the error. After fixing 
the error, you can resume running the script.

Accessing Help on the Basic Language
While writing or running scripts, you can access Help that provides information and a sample script using 
the Basic language statements.

Procedure
Select or click in an item in color in the edit area of the Basic Script Editor and then press the F1 key.

Results
Help appears for the current statement.

Navigation Window
Use the Navigation window to display a different view of the workspace, in which you can filter the items 
displayed and see information about objects selected in the workspace.

Figure 9. Navigation Window

The content of the Navigation window depends on what is selected in the workspace, as described in the 
following topics.

Nothing Selected
The view in the Navigation window is magnified, and centers on the location of the pointer in the 
workspace; when the pointer moves, the view in the Navigator window follows it.
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Pin or Via Selected
When you select a pin or via, the Navigation window displays a cross section of the object.(Figure 10). 
Information that appears includes:

• Pad sizes

• Thermal attachments

• Test point status

• Width

• Layers of attached traces

• Drill size

• Component or via name

The size of the substrates is proportional to their thickness, which is set in the SailWind Layout Setup 
Layers dialog box. The pad size reflects non-plane nets on any layers. For plane nets on CAM or split/
mixed layers, the antipad size or thermal pad (showing the inner diameter for a thermal pad) appears.

Figure 10. Pin/Via Cross-Section

Component Selected
When a component is selected, the navigation window zooms in on the selected component, (Figure 11). 
The navigation window shows the attached traces and fanouts as well as the component.
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Figure 11. A Selected Component in the Navigation Window

Net Selected
If a net object is selected, the navigation window zooms in on the selected net class, net, pin pair group, 
pin pair, electrical net, differential pair, or matched length group (Figure 12).

Figure 12. A Selected Net in the Navigation Window

When Routing Length-Controlled Objects, or Selecting and Placing 
Components
When interactively routing length-controlled objects (for example, matched length groups and differential 
pairs, nets, electrical nets, or pin pairs with length rules), the navigation window monitors the route length. 
It shows only those nets, electrical nets, or matched length groups that have length rules and are affected 
by the current operation.

The navigation window shows the same information if you select or place a component that has length-
controlled objects attached to it. Length-controlled objects appear in different colors (Figure 13).
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Figure 13. Length-Controlled Objects in the Navigation Window

For more information, refer to Monitoring Trace Length.

Navigation Window Commands
Use the Navigation window commands shown in the following table to control the display in the 
Navigation window.

Tip
You can also select these commands by right-clicking in the Navigation Window.

Table  11. Navigation Window Commands 

Button Command

Display components.

Display coppers and pours.

Display 2D lines.

Display text.

Display traces and vias.

Display unroutes.

Display all layers. When checked, all electrical layers appear. When not 
checked, the layers set in the shortcut menu appear.

 or F7
Swap views between the Navigation window and the workspace.

 Tip
You can also press the F7 key to do this.

 or F8
Lock the view displayed in the Navigation window. The view will not follow 
the pointer in the workspace.
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Table  11. Navigation Window Commands  (continued)

Button Command

 Tip
You can also press the F8 key to do this.

F5 Zoom in.

F6 Zoom out.

Related Topics
Pan, Zoom, and Scroll the Display
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Spreadsheet Window
Use the Spreadsheet Window to view and modify properties for all design objects. You can customize 
how information appears. You can also export the information to an HTML file, letting you share it over the 
Web with other members of the design team.

By default, the Spreadsheet window has the following tabs:

• Selected Object — Displays and changes information about design objects

• Errors  — View and organize errors and find the errors in the design. Use the Error  tab to view 
the type of error, the layer the error is on, the coordinates of the error, and the error description. 
These fields are for information only and cannot be modified. Also use the Error  tab to ignore an 
error.

• Net Length Monitor — Dynamically displays trace length values for net objects during interactive 
routing and route editing. Includes half the Discrete length value of each connected pin of 
components that have a Discrete length assigned.

• Electrical Net Length Monitor  — Dynamically displays trace length values for electrical net 
objects during interactive routing and route editing. Includes half the Discrete length value of each 
connected pin of components that have a Discrete length assigned.

Displaying the Spreadsheet Window
Spreadsheet Window Tab Content
Changing Design Data
Copying and Pasting To and From the Spreadsheet
Synchronizing a Tab with Project Explorer
Synchronizing a Tab with Workspace Selection
Organizing Spreadsheet Tabs
Spreadsheet Window Customization
Sorting the Spreadsheet
Printing a Spreadsheet Tab
Finding Items in the Spreadsheet Window
Filtering the Spreadsheet Window
Exporting a Spreadsheet
Using Spreadsheet Schemes (Formats)

Displaying the Spreadsheet Window
You can show or hide the Spreadsheet window.

Procedure
Click the Spreadsheet Window  button on the Standard toolbar to turn display of the Spreadsheet 
window on or off (or click the View > Spreadsheet Window  menu item).
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Spreadsheet Window Tab Content
You can use the “Display data for object type” drop-down list to specify what content the selected 
Spreadsheet  tab displays.

You can specify to display any one  of the following:

• Objects currently selected in Project Explorer

• Objects currently selected in the Workspace

• All objects of one  of the following object types:

◦ Components

◦ Decals

◦ Layers

◦ Net classes

◦ Nets

◦ Electrical nets

◦ Matched length pin pair groups

◦ Matched length net groups

◦ Pin pair groups

◦ Pin pairs

◦ Differential pairs

◦ Keepouts

◦ Via types

◦ Coppers

◦ Errors

◦ Jumpers
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Changing Design Data
You can change the values of some design properties, such as component location, trace width, and 
layer, from within the Spreadsheet window.

Note:
You can choose to allow SailWind Router to save your changes to the database automatically 
by clicking the Auto update data  button. Otherwise, you must click the Update data and apply 
changes  button each time you want to save your changes.

If you copy one cell, you can then paste the contents of that cell into a group of multiple cells. The group 
does not have to be contiguous.

Restrictions and Limitations
When pasting a group of cells, you must paste into an area that is smaller than the selection.

Procedure
1. In the spreadsheet, double-click on the cell whose value you want to change.

2. Type the new value in the cell then press the Enter key.

3. The change is saved to the database automatically if you have clicked the Auto update data 
button; otherwise, click the Update data and apply changes  button to save the change.

Related Topics
Copying and Pasting To and From the Spreadsheet
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Copying and Pasting To and From the Spreadsheet
You can copy selected cells in a Spreadsheet  tab to the Windows Clipboard in HTML table format. Then 
you can paste the information into Windows applications, such as Microsoft Word and Excel, following 
standard Windows procedures. You can also paste into another part of the tab or into a different tab. For 
example, you can copy a value (from an individual cell) to the clipboard, and then select a group of cells 
to which you want to paste this value.

Copying Spreadsheet Cells
Pasting Cells in the Spreadsheet
Pasting Cells into Another Windows Application

Copying Spreadsheet Cells
You can copy cells and paste them elsewhere in the spreadsheet.

Procedure
1. Select the cells that you want to copy.

Tip
When pasting a group of cells, you must paste into an area that is smaller than the 
selection.

2. Click the Copy  button.

Examples
You may want to copy a single value, for example a component's Y location, into multiple cells. This 
allows you to easily change the Y location of several components at one time.

Pasting Cells in the Spreadsheet
You can paste copied spreadsheet cells into other cells in the spreadsheet.

Restrictions and Limitations
You cannot delete a predefined scheme.

Procedure
1. Copy the cells you want to paste.

2. Click the tab into which you want to paste the cells.

3. Select the cells into which to paste the data.
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Tip
You can paste the contents of a single cell into multiple cells. The cells do not have to be 
contiguous.

Note:
When pasting a group of cells, you must paste into an area that is smaller than the 
selection.

4. Click the Paste  button.

Related Topics
Changing Design Data

Pasting Cells into Another Windows Application
You can copy information from cells in a spreadsheet and paste it into other applications such as a text 
editor.

Procedure
Open the application into which you want to paste the data, and paste as appropriate for that application.

Synchronizing a Tab with Project Explorer
Tabs synchronized with Project Explorer display the objects currently selected in Project Explorer.

Synchronization operates as follows:

• If you select a specific object type in the Project Explorer (such as Pin Pair), then all objects of 
that type are displayed in the Spreadsheet window.

• If you select certain objects such as specific nets, then only those objects are displayed.

• If you select objects of multiple types at the same time, no objects are displayed.

Procedure
In the Display data for object type dropdown list, select “Sync with Project Explorer”. (You may need to 
close the Output window and/or the Navigation window to see the dropdown list.)

Tip
To pause synchronization, select “Keep current objects” from the Display data for object type list. 
To resume synchronization, click “Sync with Project Explorer” again.
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Synchronizing a Tab with Workspace Selection
When you synchronize the selection tab of the Spreadsheet window with the workspace, the selection tab 
displays the objects selected in the workspace.

Restrictions and Limitations
If you select objects of multiple types at the same time, no objects are displayed.

Procedure
In the Display data for object type dropdown list, select “Sync with selection”. (You may need to close the 
Output window and/or the Navigation window to see the dropdown list.)

Tip
To pause synchronization, select “Keep current objects” from the Display data for object type 
dropdown list. To resume synchronization, click “Sync with Project Explorer” again.

Related Topics
Organizing Spreadsheet Tabs

Organizing Spreadsheet Tabs
Use the Column Organizer dialog box to select which columns appear in the selected tab and to change 
the display order of columns. You can also define a non-scrolling area.

Procedure
1. In the Spreadsheet window, click the Organize columns  button to open the Column Organizer 

dialog box. You may need to close the Output window and/or the Navigation window to see the 
button.

2. To add columns to the tab, in the Available columns box, select the columns you want to include, 
and click the right arrow button (>>) to move them to the Displayed columns box.

3. To remove columns from the tab, in the Displayed columns box, select the columns you want to 
remove, and click the left arrow button (<<) to move them to the Available Columns box.

4. To change the order of columns in the spreadsheet, in the Displayed columns box, select the 
column you want to move and click the down arrow button to move the column to the right in the 
spreadsheet or the up arrow button to move the column to the left.

5. To define a non-scrolling area, select “Lock position of columns when scrolling” check box. Enter 
the number of columns you want to define in the “Number of columns locked (from left)” box.

Tip
To remove the non scroll property, clear the “Lock position of columns when scrolling” 
check box.
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Spreadsheet Window Customization
You can change the appearance of the Spreadsheet window by adding, renaming, and removing tabs. 
You can also change the width of columns and align text.

Adding a Tab to the Spreadsheet Window
Renaming a Tab in the Spreadsheet Window
Removing a Tab from the Spreadsheet Window
Changing Column Width
Aligning Text

Adding a Tab to the Spreadsheet Window
You can display additional content in a spreadsheet by adding tabs.

Procedure
1. Right-click any tab on the Spreadsheet and click the Add Tab  popup menu item. A new tab 

appears to the right of existing tabs.

2. Double-click the title of the added tab and type the new name.

Renaming a Tab in the Spreadsheet Window
You can change the name of any tab in the spreadsheet.

Procedure
1. Right-click the tab you want to rename and click the Rename Tab  popup menu item.

2. Type the new name.

Removing a Tab from the Spreadsheet Window
You can delete any tab from the spreadsheet.

Procedure
Right-click the tab you want to remove and click the Delete Tab  popup menu item.

Changing Column Width
You can make the column width fit the text.
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Procedure
1. Select the columns you want to size.

2. Click the AutoFit to Contents  button. You may need to close the Output window and/or the 
Navigation window to see the button.

Tip
You can also double-click the right-hand separator of a column to auto-size it.

Aligning Text
You can align text to the left, center, or right-hand side of columns.

Procedure
1. Select the columns you want to align.

2. Click the proper alignment button for the type of alignment you want (“Align left,” “Center,” or 
“Align right”). You may need to close the Output window and/or the Navigation window to see the 
alignment buttons.

Sorting the Spreadsheet
Sort the spreadsheet to find the most important information quickly.

Procedure
1. Click the Define sort order  button. You may need to close the Output window and/or the 

Navigation window to see the button.

2. Double-click each column header in the sort order you want to create, starting with the most 
important column.

A number is placed in the column header to show the priority of that column in the sort order, and 
the spreadsheet is re-sorted to include that column.

Tip
Double-clicking the column again reverses the sort order for the column.

Printing a Spreadsheet Tab
If desired, you can print the contents of any tab in a spreadsheet.

Procedure
1. Click the tab you want to print.

2. Click the Print  button to print the tab using the current printer setup.
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Finding Items in the Spreadsheet Window
You can find items in Selection tabs by specifying search criteria in the Find dialog box. You can search 
on one condition, or create a more complex search containing multiple conditions.

Creating a Simple Search
Creating a Multiple-Condition Search

Creating a Simple Search
You can create a simple search expression by defining a single condition.

Procedure
1. In the Spreadsheet window, click the Find object  button. This opens the Find dialog box. (You may 

need to close the Output window and/or the Navigation window to see the Find object  button.)

2. If the Less  button appears in the Find dialog box, click it to collapse the lower portion of the dialog 
box. Only the simple search items remain.

3. Using the Property, Condition, and Value controls, specify the property you want to search on and 
the condition and value to test the property against.

Example:  If you want to find nets whose Routed Length property is less than 1.1, select Routed 
Length from the Property list, “Is less than” from the Condition list, and enter “1.1” in the Value box.

4. If you want to start the search from the bottom of the Spreadsheet, select the Backward Search 
check box.

5. Click Find  to find the first object and close the dialog box, or click Find Next  to search 
successively for multiple objects.

Related Topics
Find Dialog Box

Creating a Multiple-Condition Search
You can create a Boolean search expression that has multiple conditions.

Procedure
1. In the Spreadsheet window, click the Find object  button. This opens the Find dialog box. (You may 

need to close the Output window and/or the Navigation window to see the button.)

2. In the Find dialog box, if the More  button is available, click it to expand the dialog box.

3. Click the New  button to add the first filter condition to the filter expression.

4. Using the Property, Condition, and Value controls, specify the property you want to search on and 
the condition and value to test the property against.

Example:  If you want to find nets whose Routed Length property is less than 1.1, select Routed 
Length from the Property list, “Is less than” from the Condition list, and enter “1.1” in the Value box.
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5. Add another condition to the search expression, as follows

a. Click the New  button.

b. Select a Boolean operator.

c. Using the Property, Condition, and Value controls, specify the property you want to search on 
and the condition and value to test the property against.

6. If you have another condition to add, go to Step 5; otherwise continue with Step7.

7. If you want to start the search from the bottom of the Spreadsheet, select the Backward Search 
check box.

8. Click Find  to find the first object and close the dialog box, or Find Next  to search successively for 
multiple objects.

Related Topics
Find Dialog Box
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Filtering the Spreadsheet Window
You can filter information that appears in Selection tabs by creating a filtering expression in the Edit Filter 
dialog box then applying the filter by clicking the View filtered data  button. You can create a simple filter 
containing one condition, or create a more complex filter containing multiple conditions.

Tip
When you create a filter, it becomes part of the currently active scheme.

For more information, see “Edit Filter Dialog Box.”

Creating a Simple Filter
Creating a Multiple-Condition Filter

Creating a Simple Filter
Create a simple filtering expression with a single condition.

Procedure
1. In the Spreadsheet window, click the Define filter settings  button. This opens the “Edit filter” 

dialog box. (You may need to close the Output window and/or the Navigation window to see the 
button.)

2. In the Edit filter dialog box, if the Less  button is available, click it to collapse the lower portion of 
the dialog box.

3. Using the Property, Condition, and Value controls, specify the property you want to filter by and the 
condition and value to test the property against.

Example:  If you want to display nets whose Routed Length property is less than 1.1, select Routed 
Length from the Property list, “Is less than” from the Condition list, and enter “1.1” in the Value box.

4. Click OK  to save the filter.

Results
The filter is saved as part of the currently active scheme. To apply the new filter, click the View filtered 
data button.

Creating a Multiple-Condition Filter
Create a Boolean filter expression with multiple conditions.

Procedure
1. In the Spreadsheet window, click the Define filter settings  button. This opens the “Edit filter” 

dialog box. (You may need to close the Output window and/or the Navigation window to see the 
button.)

2. In the Edit filter dialog box, if the More  button is available, click it to expand the dialog box.
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3. Click the New  button to add the first search condition to the search expression.

4. Using the Property, Condition, and Value controls, specify the property you want to filter by and the 
condition and value to test the property against.

Example:  If you want to display nets whose Routed Length property is less than 1.1, select Routed 
Length from the Property list, “Is less than” from the Condition list, and enter “1.1” in the Value box.

5. Add another condition to the filter expression, as follows

a. Click the New  button.

b. Select a Boolean operator.

c. Using the Property, Condition, and Value controls, specify the property you want to filter by and 
the condition and value to test the property against.

6. If you have another condition to add, return to Step 5; otherwise continue with Step7.

7. Click OK  to save the filter.

Results
The filter is saved as part of the currently active scheme. To apply the new filter, click the View filtered 
data  button.

Related Topics
Using Spreadsheet Schemes (Formats)

Find Dialog Box

Exporting a Spreadsheet
You can save data in HTML format to view with a Web browser or import into another Microsoft 
application such as Excel.

Procedure
1. Select the rows or columns you want to save.

Tip
If you do not select part of the spreadsheet, the entire spreadsheet is saved.

2. Click the Export to HTML file  button.

3. Specify the filename and location to which you want to save the file.

4. Click Save.
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Using Spreadsheet Schemes (Formats)
A scheme  saves the way you customize a tab in the Spreadsheet window. You can associate any number 
of schemes with each object type.

The program contains predefined schemes for each object type. You cannot delete a predefined scheme.

Creating a New Scheme
Deleting a Scheme
Changing to a Different Scheme

Creating a New Scheme
Create a new spreadsheet scheme to customize the appearance of your spreadsheet workspace.

Procedure
1. From the “Display data for object type” dropdown list, select the object type for which you want to 

create the scheme. You may need to expand the Spreadsheet window to see the list.

2. Use the Customize dialog box to customize your workspace; for example, your workspace, 
toolbars, menus, and shortcut keys.

For more information, see: “Customizing the Appearance of the Screen”  on page 565

3. Click the Create new scheme  button. SailWind Router creates the new scheme and saves it with 
the default name Scheme N  (where N is a number). If you do not want to use the default name, 
type a name for the new scheme in the Scheme dropdown list.

Deleting a Scheme
You can remove a scheme provided it is not one of the predefined schemes.

Restrictions and Limitations
You cannot delete a predefined scheme.

Procedure
1. From the Scheme dropdown list, select the scheme you want to delete.

2. Click the Delete the current scheme  button of the toolbar.

3. When prompted, click Yes.

Results
The selected scheme is deleted, and the current scheme becomes the predefined scheme for the object 
type.
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Changing to a Different Scheme
You can select another spreadsheet scheme from within the Spreadsheet window.

Procedure
1. In the Open Scheme list, select the scheme that you want to change.

2. To return to a previous scheme, click the Show Previous Scheme  button.

3. To advance to the next scheme on the list, click the Show Next Scheme  button.
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Chapter 6
Modeless Commands and Shortcut Keys

As an aid to increase your design session productivity, SailWind Router offers a broad array of modeless 
commands and shortcut keys to allow for quicker execution of common design tasks.

Modeless Commands
Shortcut Keys
Function Keys
Keypad Keys
Keyboard Shortcuts

Modeless Commands
You can set or change some settings and functions at any time by typing a code letter for the command, 
entering the new value, and clicking Enter. This is called a Modeless Command.

Modeless Commands usually apply to values that you change frequently during design. Use the 
Modeless Command G, for example, to change the grid setting by pressing the g key, typing the new 
setting, and pressing the Enter key.

Tip
(X,Y) = coordinates; (s) = text; (n) = number

The following table lists the conventions used in modeless commands and shortcut keys.

Table  12. Modeless Command and Shortcut Key Table Conventions

Convention Indicates

< > A variable, or something that you can type

{ } An optional command argument

click Click the left mouse button

middle-click Click the middle mouse button or wheel

right-click Click the right mouse button

wheel back Rotate the wheel backward, where the top of the wheel rotates away from your 
palm

wheel forward Rotate the wheel forward, where the top of the wheel rotates toward your palm
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Tip
Spaces have significance in modeless commands and shortcut keys. For example, SS W1 and 
S SW1 have different meanings. SS W1 means to search and select W1, while S SW1 means to 
search for SW1.

The following tables list all of the modeless commands:

Table  13. Modeless Commands for Setting the Design Units

Name Command Description

Set Design Units to Inches UI Sets the Design Units to inches in the Options 
dialog box > Global  category > General 
subcategory.

Set Design Units to Mils UM Sets the Design Units to mils (thousands of 
an inch) in the Options dialog box > Global 
category > General  subcategory.

Set Design Units to Millimeters 
(metric)

UMM Sets the Design Units to metric (millimeters) 
in the Options dialog box > Global  category > 
General  subcategory.

Set Design Units to Microns UUM Sets the Design Units to microns (metric) in 
the Options dialog box > Global  category > 
General  subcategory.

Table  14. Modeless Commands for Grid Settings

Name Command Description

Global Grid Setting (Except 
Display)

G<x> {<y>} Sets all grids  on page 491 (Routing, Test 
Point, Via, Fanout, Component), except the 
Displayed grid. The second parameter is 
optional. If you type one parameter, it applies 
the same value to both <x> and <y>. For 
example, G 25, G 8.3 or G 16-2/3, G 5 25.

Component Grid Setting GC <x> {<y>} Sets the Component grid  on page 491. The 
second parameter is optional. If you type one 
parameter, it applies the same value to both 
<x> and <y>. For example, GC 8-1/3, GC 25 
25, or GC 100.

Displayed (Dot) Grid Setting GD <x> {<y>} Sets the Displayed (Dot) grid  on page 491. 
The second parameter is optional. If you type 
one parameter, it applies the same value to 
both <x> and <y>. For example, GD 8-1/3, GD 
25 25, or GD 100.

Fanout Grid Setting GF <x> {<y>} Sets the Fanout grid  on page 491. The 
second parameter is optional. If you type one 
parameter, it applies the same value to both 
<x> and <y>. For example, GF 8-1/3, GF 25 25, 
or GF 100.
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Table  14. Modeless Commands for Grid Settings  (continued)

Name Command Description

Routing Grid Setting GR <x> {<y>} Sets the Routing grid  on page 491. The 
second parameter is optional. If you type one 
parameter, it applies the same value to both 
<x> and <y>. For example, GR 8-1/3, GR 25 
25, or GR 100.

Grid Snap On/Off (Routing Grid 
Only)

GS Toggles snap to the routing grid  on page 491
on or off.

Test Point Grid Setting GT <x> {<y>} Sets the Test point grid  on page 491. The 
second parameter is optional. If you type one 
parameter, it uses the same value for both <x> 
and <y>. For example, GT 8-1/3, GT 25 25, or 
GT 100.

Via Grid Setting GV <x> {<y>} Sets the Via grid  on page 491. The second 
parameter is optional. If you type one 
parameter, it uses the same value for both <x> 
and <y>. For example, GV 8-1/3, GV 25 25, or 
GV 100.

Grid Statistics (Hard) GGH Create the Hard Grid Statistics report. The 
report is displayed in the Output window.
Requirement:  You must select the “Snap 
Objects to Grid” check box for the Routing grid 
in order to see Off grid statistics in the report. 
Use the GS modeless command to quickly 
toggle this setting.
For more information, see Grid Statistics Report 
in ““Grid Rules”  on page 165.”

Grid Statistics (Medium) GGM Create the Medium Grid Statistics report. The 
report is displayed in the Output window.
Requirement:  You must select the “Snap 
Objects to Grid” check box for the Routing grid 
in order to see Off grid statistics in the report. 
Use the GS modeless command to quickly 
toggle this setting.
For more information, see Grid Statistics Report 
in ““Grid Rules”  on page 165”

Grid Statistics (Soft) GGS Create the Soft Grid Statistics report. The report 
is displayed in the Output window.
Requirement:  You must select the “Snap 
Objects to Grid” check box for the Routing grid 
in order to see Off grid statistics in the report. 
Use the GS modeless command to quickly 
toggle this setting.
For more information, see Grid Statistics Report 
in ““Grid Rules”  on page 165”
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Table  15. Modeless Commands for Line/Trace Angle Settings

Name Command Description

Any Angle AA Any angle mode. Sets the routing angle in 
the Options dialog box > Routing  category > 
General  subcategory to “Any angle” (no angle 
restrictions).

Diagonal Angle AD Diagonal angle mode. Sets the routing angle in 
the Options dialog box > Routing  category > 
General  subcategory to “Diagonal” (45 degree 
angles only).

Orthogonal Angle AO Orthogonal angle mode. Sets the routing angle 
in the Options dialog box > Routing  category 
> General  subcategory to “Orthogonal” (90 
degree angles only).

Table  16. Modeless Commands for Line/Trace Width Settings

Name Command Description

Reduce Display Width R <n> Sets the minimum display line width. Traces 
that have a width less than this value are not 
displayed at their true width, but are displayed 
at a single pixel width. This feature simplifies 
the selection of tiny trace segments.

Change Current Width to <n> W <n> Changes the current trace or line width to the 
number <n> you enter, for example W 5.

Table  17. Modeless Commands for DRC Settings

Name Command Description

Toggle DRC Mode On/Off DRC Toggles on-line DRC mode. Sets the On-line 
DRC  button on the DRC Toolbar on/off.

Suspend SUS Suspend. You can suspend (pause) the move 
or spin of a component to free the cursor to 
examine DRC issues on the Errors  tab of the 
Spreadsheet window. Press Esc to return to the 
move or spin mode.

Table  18. Modeless Commands for Searching

Name Command Description

Search Absolute S <x> <y> Search absolute. Moves the pointer to the 
specified X and Y coordinates, for example S 
1000 1000.

Search (supports regular 
expressions ?*[])

S <s> Search string. Moves pointer to the named 
object, for example S U3.10. You can substitute 
alphanumeric characters in the object name 
with the ? * and [] regular expression pattern 
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Table  18. Modeless Commands for Searching  (continued)

Name Command Description
operators. For examples, see “Expressions in 
Shortcut Keys”  on page 560.

Search Relative SR <x> <y> Search relative. Moves the pointer by the 
specified X and Y offset, for example SR -100 
-50.

Search Relative X SRX <x> Search relative X at current Y. Moves pointer by 
the specified X offset, for example SRX 300.

Search Relative Y SRY <y> Search relative Y at current X. Moves pointer by 
the specified Y offset, for example SRY 400.

Search and Select SS <s> Search and Select components by reference 
designator. Moves the pointer to the named 
object, then selects it, for example SS U10. 
You can also search and select more than 
one component by typing multiple entries, for 
example SS U10 U5 R6.
You can substitute alphanumeric characters 
in the object name with the ? * and [] regular 
expression pattern operators. For examples, 
see “Expressions in Shortcut Keys”  on 
page 560.

 Tip
Spaces may be important in modeless 
commands. For example, SS W1 and S 
SW1 have different meanings. SS W1 tells 
SailWind Layout to search and select W1, 
while S SW1 tells it to search for SW1.

Absolute Move to <n>, Current 
Y

SX <x> Search absolute X at current Y. Moves the 
pointer to the specified X coordinate and the 
current Y coordinate, for example SX 300.

Absolute Move to <n>, Current 
X

SY <y> Search absolute Y at current X. Moves the 
pointer to the specified Y coordinate and the 
current X coordinate, for example SY 400.

 

Table  19. Modeless Commands for Object Visibility

Name Command Description

Distinguish Protected Objects DP Distinguishes protected objects by displaying 
them in outline mode. Command toggles this 
mode on and off.

Distinguish Protected Objects 
On/Off

I Distinguishes protected objects by displaying 
them in outline mode. Command toggles this 
mode on and off.

SailWind Router Guide 97



Modeless Commands and Shortcut Keys
Modeless Commands  

Table  19. Modeless Commands for Object Visibility  (continued)

Name Command Description

 Tip
The shortcut dialog does not appear for 
this command, but the status of the change 
appears in the Status bar.

Outline Mode O Toggles between showing only object outlines 
or showing filled objects.

 Tip
The shortcut dialog does not appear for 
this command, but the status of the change 
appears in the Status bar.

Pin Number Display On/Off PN Toggles pin number display on/off.

 Tip
This command toggles the “Pin Num.” 
column check box in the Options dialog box 
> Colors  category.

Transparent Mode On/Off T Toggles Transparent mode on or off.

Unroute Display On/Off U Toggles Unroute display on or off.

Enable Color by Net Y Toggles the application of custom color to 
net pads, pins, vias, and—optionally—traces, 
according to the settings in the “View Nets 
Dialog Box”  on page 538.

 

Table  20. Modeless Commands for Net Name Visibility

Name Command Description

Toggle Visibility of Net Names NN Toggles the visibility of net names on pins, 
traces and/or vias based upon the individual 
settings of the NNP, NNT and NNV commands.
Tips:

• • This command toggles the “Net Nm.” 
check box in the Options dialog box > 
Colors  category.

• • When net name display is turned off 
with the NN command, no net names are 
displayed, irrespective of the NNP, NNT, 
and NNV settings.

• • When net name display is turned on with 
the NN command, net names are displayed 
or not displayed, according to the NNP, 
NNT, and NNV settings.

• • When the “Net Nm.” column check box is 
enabled, net name visibility is still restricted 
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Table  20. Modeless Commands for Net Name Visibility  (continued)

Name Command Description
by the color tiles on each layer and the 
“Show net names on Traces, Vias, Pins” 
check boxes. See also the NNP, NNT, and 
NNV modeless commands.

Toggle Display of Net Names 
on Pins

NNP Toggles the display of net names on pins on/off.

 Tip
This command toggles the Net names 
on...Pins check box in the Options dialog 
box > Colors  category.
 Restriction:
The display of net names also depends on 
the “Net Nm. column (visibility) check box 
and the presence of a non-background color 
tile on the layer in the Options dialog box > 
Colors  category.

Toggle Display of Net Names 
on Traces

NNT Toggles the display of net names on traces 
on/off.

 Tip
This command toggles the Net names 
on...Traces check box in the Options dialog 
box > Colors  category.
 Restriction:
The display of net names also depends on 
the “Net Nm. column (visibility) check box 
and the presence of a non-background color 
tile on the layer in the Options dialog box > 
Colors  category.

Toggle Display of Net Names 
on Vias

NNV Toggles the display of net names on vias on/off.

 Tip
This command toggles the Net names 
on...Vias check box in the Options dialog 
box > Colors  category.
 Restriction:
The display of net names also depends on 
the “Net Nm. column (visibility) check box 
and the presence of a non-background color 
tile on the layer in the Options dialog box > 
Colors  category.

 

Table  21. Modeless Commands for Layer Visibility (Quick Layer View)

Name Command Description

Quick Layer View Z With no command arguments, Z displays the 
initial layer view.
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Table  21. Modeless Commands for Layer Visibility (Quick Layer View)  (continued)

Name Command Description

Add or Remove Layer from 
Current Set of Displayed 
Layers

Z {+<layer>} 
{-<layer>}

Adds or removes a layer from the current set of 
displayed layers. For example:

• Z +O makes the outside layers visible, but 
does not change visibility of other layers.

• Z -O makes the outside layers invisible, but 
does not change visibility of other layers.

Z -2 +O makes invisible layer 2 and makes 
visible the outside layers.

View Only the Range of Layers 
You Type

Z <n-m> Allows you to restrict the display to a specified 
range of layers. For example, typing “Z 2-4” 
displays layers 2, 3, and 4. Do not enclose the 
range with square brackets.

View Only the Layers You Type Z <layer n> {<layer 
m> …}

Allows you to restrict the display to only the 
layers you type. For example, typing “Z 2 4 d” 
displays layers 2, 4, and the documentation 
layer.

View All layers Z * Displays all layers in the design.

 Restriction:
Z supports only the asterisk * regular 
expression.

View Items on Layer 0 Z 0 View only items that are visible on all layers. 
Items placed on Layer 0 are visible on all 
layers.

View the Active Layer Z A Displays the currently active layer. If the active 
layer is changed, it has no effect on the display.

View Only the Bottom Layer Z B Restricts the display to show the bottom layer 
only.

View Only the Current Layer Z C <-C> Changes the display to show the current layer 
only. If the active layer is changed, only the 
new current layer is displayed. Unlike Z A, it 
puts you in a continuous mode where all layers 
are hidden except the active layer. When you 
change layers, the new layer becomes visible 
and all other layers are hidden. Use Z -C to exit 
the mode.

View All Documentation Layers Z D Displays all documentation layers in the design.

View All Electrical Layers Z E Displays all electrical layers in the design.
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Table  21. Modeless Commands for Layer Visibility (Quick Layer View)  (continued)

Name Command Description

 Tip
You can also display an individual electrical 
layer (using Z C to make the current layer 
visible) and then switch the display to an 
adjacent electrical layer (using Alt+wheel 
backward or Alt+wheel forward), skipping 
any non-electrical layers.

View All Internal Layers Z I View all internal layers.

View Only the Outside Layers 
(Top and Bottom Layers)

Z O View only the outside layers, that is, the top and 
bottom layers.

View Only the Top Layer Z T View only the Top layer.

View Unrouted Connections 
(that are visible on all layers)

Z U Toggles the view of unrouted connections that 
are visible on all layers.

Restore a Quick Layer View 
Configuration

ZR <name> Restore a quick layer view configuration. For 
example, ZR L23 restores the configuration 
stored as L23.

 Tip
Type ZR and press Enter to see a list of all 
layer configurations created by ZS in this 
session.

See also ZS.

Save Current Set of Displayed 
Layers as a Quick Layer View 
Configuration

ZS <name> Saves the current set of displayed layers as a 
quick layer view configuration. For example, 
ZS L23 stores the current configuration as L23. 
The quick layer view configuration is available 
until you exit the program.
See also ZR.

 

Table  22. Modeless Commands for Layers

Name Command Description

Change the Current Layer to 
<n>

L <n> Sets the current layer to the number or name 
you enter, for example (L 2) or (L top).

Paired Layer Command PL <n1> <n2> Paired layers command, where<n1> and <n2> 
can be the layer number or name, for example, 
PL 1 2 or PL top bottom.Sets the Layer pair 
setting in the Options dialog box > Routing 
category General subcategory.
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Table  23. Modeless Commands for Vias

Name Command Description

Toggle Between End Via 
Modes

E Cycles the End Via mode between the following 
three settings:

• End No Via (where a trace ends in space)

• End Via (where a trace ends with a via)

• End Test Point (where a trace ends with a 
test point via

 Tip
The shortcut dialog does not appear for 
this command, but the status of the change 
appears in the Status bar.

Select Via Type V <name> Via type is set to the name you enter.

Automatic Via Selection VA Via type set to automatic via selection.

Via Guide Toggle VG Toggles Via guide on or off.

Use Partial Via VP Via type set to partial vias only.

Use Through Hole Via VT <name> Via type set to through-hole vias only.

Table  24. Modeless Commands for Highlighting

Name Command Description

Highlight Specific Net 
On/Off (supports regular 
expressions ?*[])

H {<net>} Net highlighting on or off. If you specify a net, 
you can substitute alphanumeric characters 
in the net name with the ? * and [] regular 
expression pattern operators. For examples, 
see “Expressions in Shortcut Keys”  on 
page 560.

Highlight Component Pads with 
Rules

HCR Highlights component pads with the current 
Highlighted object display  on page 441 setting 
to indicate that the component has component 
rules. Other indicators are displayed when 
using component rules. For more information, 
see “Creating Traces Using Component Rules” 
on page 308.

Highlight in Dim Color Mode 
On/Off

HD Highlight Dimming. Sets the Highlighted object 
display  on page 441 setting to Distinguish 
highlighted objects by Dimming other object 
colors.

Highlight in Gray Scale Mode 
On/Off

HG Highlight Graying. Sets the Highlighted object 
display  on page 441 setting to Distinguish 
highlighted objects by Graying other objects.

Highlight in Highlight Mode 
On/Off

HH Highlight Hatching. Sets the Highlighted object 
display  on page 441 setting to Distinguish 
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Table  24. Modeless Commands for Highlighting  (continued)

Name Command Description
highlighted objects by crosshatching the 
highlighted object.

Highlight On/Off (Current 
Object)

HO Toggles highlighting on or off for highlighted 
objects. Turns off the Highlighted object display 
on page 441 setting or turns it on using the 
last used setting. For example, objects receive 
highlighting when you use the Edit > Highlight 
command or when you route a net.

 

Table  25. Modeless Commands for Plower Settings

Name Command Description

Push Trace Behind Mode PB Toggles Push trace behind on or off 
(temporarily) for the current trace during 
interactive routing.

Plow After Click Mode PC Enables Plow after click mode (temporarily) for 
the current trace during interactive routing.

Plow With Pointer Mode PP Enables Plow with pointer mode (temporarily) 
for the current trace during interactive routing.

Rip Up Mode PR Enables Plower rip up mode (temporarily) for 
the current trace during interactive routing.

No Plowing PX Disables Plowing (temporarily) for the current 
trace during interactive routing.

 

Table  26. Modeless Command for Pour Outlines

Name Command Description

Pour Outline On/Off PO Pour outline on/off. This toggles the display 
mode of copper planes between pour outline 
and hatch outline.

Table  27. Modeless Commands for General Mode Settings

Name Command Description

Smooth Traces on Complete 
On/Off

SC Toggles Smooth Traces on Complete on or off.

Direction Guides DG Toggles the direction guides on or off when you 
move a trace segment. The direction guides 
are lines that radiate out from the pointer to 
indicate the direction in which you can proceed. 
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Table  27. Modeless Commands for General Mode Settings  (continued)

Name Command Description
The guides represent the routing angle in the 
Routing options  on page 450.

Table  28. Modeless Command for Measurement

Name Command Description

Quick Measure Q Quick measure with dynamic ruler. Attaches a 
measurement line to the pointer and displays 
dx, dy, and hypotenuse information, depending 
on pointer movement.
Place the pointer at the starting point, then 
type the “q” modeless command. Drag the 
pointer to create a line between the start and 
end point of your measurement. Snaps to 
the design grid when the Snap to grid is on. 
Measurements are gridless when Grid Snap 
is off. Dynamically reports delta x, delta y, 
and delta x,y in current design units. You can 
measure precise Euclidean distances between 
polar grids using this command.
For more information about using the Q 
shortcut key, see “Measuring Distance Between 
Objects”  on page 211.

 Tip
The shortcut dialog does not appear for 
this command, but the Status gives tips on 
usage.

Table  29. Miscellaneous Modeless Commands

Name Command Description

Move Sequential MS Move sequential. After selecting a 
predetermined set of components, use Move 
Sequential to sequentially place components 
on your pointer for placement in the design. For 
more information, see “Placing Components 
Sequentially”  on page 207.

Set Arc Radius RAD Arc radius set to the <radius> value, for 
example, RAD 45.

Table  30. Modeless Commands for the Basic Media Wizard/Log Test

Command Description

Basic Log Test BLT Basic Log Test. Opens the Log Test Dialog 
Box. BLT finds and runs BMW session playback 
media.
See also “Crash Detection”  on page 576
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Table  30. Modeless Commands for the Basic Media Wizard/Log Test  (continued)

Command Description

Open Basic Media Wizard BMW Opens the Basic Media Wizard dialog box.
• BMW records session playback media for 

a problematic SailWind Logic, SailWind 
Layout or SailWind Router session. It can 
create playback media based on your last 
SailWind session or your current session. 
This playback media can be replayed using 
the BLT modeless command.

• BMW is also a command line option.

See also “Crash Detection”  on page 576

Start BMW Session Logging BMW ON Starts BMW session logging.

Stop BMW Session Logging BMW OFF Stops BMW session logging.
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Shortcut Keys
Using shortcut keys, you can start commands directly from the keyboard or mouse without navigating 
through menus. You can use shortcut keys (shortcuts) to start commands, change system settings, or 
start macros. You can also create new shortcuts.

Shortcuts are context-sensitive and mode sensitive. For example, in normal mode, pressing Ctrl+A 
selects all selectable design objects. In interactive routing mode, however, pressing Ctrl+A adds an arc.

A shortcut is unavailable when its associated command cannot be started. For example, the shortcut for 
the SaveAs command is unavailable when no design is loaded.

Displaying Available Shortcuts
Starting Commands with Shortcuts
Using a Shortcut to Start a Command with Arguments
Using a Shortcut to Start a Customized System Command
Starting a Shortcut
Starting a Shortcut with Command Arguments

Displaying Available Shortcuts
SailWind Router provides a number of different methods that allow you to view your available shortcut 
choices.

The following table shows how to display the available shortcuts:

Table  31. How to Display Shortcuts

Source Contains How to display

Online help Standard shortcuts only See also ““Shortcut Keys”  on 
page 106”.

HTML report All shortcuts, which are sorted into 
general and mode-specific groups

See also ““Listing Available Shortcut 
Keys”  on page 560”.

Shortcut dialog box Standard and custom shortcuts 
available for the current mode

Open the Shortcut dialog box from 
the standard toolbar or from the View 
menu.

Starting Commands with Shortcuts
You can start commands by clicking on the workspace and typing the key sequence for the shortcut and 
any arguments it may have. As you type, the command may start immediately or shortcut dialog boxes 
may open to help you check the accuracy of the command argument or choose from similar shortcuts.

You can also start commands using mouse pointer events such as click and wheel rotation. However, you 
cannot create a shortcut that combines shortcut keys and mouse pointer events.

The program distinguishes between long and short shortcuts. A long shortcut consists of two or more 
keystrokes and possibly a combination of Ctrl, Alt, or Shift modifiers for the first keystroke. A short 
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Using a Shortcut to Start a Command with Arguments
shortcut consists of one keystroke, or a mouse pointer event, and possibly a combination of Ctrl, Alt, or 
Shift modifiers:

Table  32. Responses to Shortcuts

Response Why

Starts the command immediately. No 
shortcut-related dialog boxes open.

The shortcut has all of the following characteristics:
• No command arguments

• Short shortcut

• Not similar to other shortcuts

Opens the Shortcut dialog box where you 
can view the key sequence you are typing, 
shortcut information, and syntax, if available.

The shortcut has any of the following characteristics:
• One or more command arguments

• Long shortcut

• Similar to other shortcuts

Opens the Command Arguments dialog 
box, prompting you for required command 
arguments.

The shortcut cannot start the command until you 
provide the required command arguments.

Using a Shortcut to Start a Command with 
Arguments
You can use a shortcut to start the Change Layer command; then interactively supply the required layer 
number argument.

Procedure
1. Open a design.

2. Type L (lowercase), which is the standard shortcut for the Change Layer command.

The Command Arguments dialog box opens with “Set Layer” displayed in the text box.

3. Type the layer number in the text box and press Enter to change the layer.

Using a Shortcut to Start a Customized System 
Command
You can use a customized shortcut to start the Change Layer command and supply the layer number.

Procedure
1. “Create a custom shortcut”  on page 558 for the Change Layer command that includes a 

command argument value. For this example, assume that you have created a shortcut named L3 
that includes 3 as the command argument value.

2. Open a design.
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3. Type the key sequence L3, which is the custom shortcut you created in step 1.

The Shortcut dialog box opens with L3 displayed in the text box.

4. Press Enter to change the layer to 3.

Note:
For more information, refer to “Creating a New Shortcut Key”  on page 558 and “Listing 
Available Shortcut Keys”  on page 560.

Starting a Shortcut
The Shortcut dialog box displays the shortcut key sequence as you type, allowing you to check its 
accuracy before starting the shortcut. Shortcut information and syntax, if available, appear below the text 
box. Parentheses enclose optional arguments. Similar shortcuts are displayed in the Available commands 
and macros box; click More  to display the box.

Procedure
1. Start typing the shortcut; the Shortcuts dialog box opens automatically.

2. Do one of the following:

• Type the shortcut into the text box.

• Select the shortcut from the Available commands and macros box. To re-sort the contents of 
the Available commands and macro box, click a column header.

3. If needed, type space-delimited command arguments into the text box.

Tip
Use the wildcard character * to substitute for any number of characters, and use the 
wildcard character ? to substitute for one character. For example, to highlight all nets 
whose names start with the letter A, type H A*.

4. Press Enter.

Tip
To immediately start multiple-character shortcuts that do not have command arguments, 
clear the “Wait until <Enter> before executing long shortcuts” check box in the Customize 
dialog box (Tools > Customize  menu item, Options  tab).
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Note:
To define new shortcuts using the Customize dialog box, right-click over most areas on the 
Shortcut dialog box, click Customize, and then click the Keyboard and Mouse  tab.

Restriction:
If you opened the Shortcut dialog box by typing a shortcut, you cannot delete the initial 
character in the text box. To display all available shortcuts, open the Shortcut dialog box by 
clicking the Shortcut Dialog  button on the main toolbar.

Related Topics
Modeless Commands and Shortcut Keys

Shortcut Keys

Starting a Shortcut with Command Arguments
The Command Arguments dialog box displays the command arguments key sequence as you type, 
allowing you to check its accuracy before starting the shortcut. The Command Arguments dialog 
box opens automatically when you type a shortcut if you have not yet provided a required command 
argument.

Procedure
Type the space-delimited arguments into the text box and press Enter.

Note:
Shortcut information and syntax, when available, appear below the text box. Parentheses enclose 
optional arguments.

Tip
Use the wildcard character * to substitute for any number of characters, and use the wildcard 
character ? to substitute for one character.

Examples
To highlight all nets whose names start with the letter A, type the key sequence H A*.

Related Topics
Shortcut Keys

Modeless Commands and Shortcut Keys
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Function Keys
Function keys allow you to use the standard keyboard function keys to initiate specific operations.

The following table defines the function key command assignments:

Table  33. Function Key Command Assignments

Function Key Description

F1 Open Help (context sensitive)

F2 Unassigned

F3 Interactive Route (Dynamics Enabled)

F4 Layer Pair Toggle during routing.

 Note:
F4 no longer repeats the last command.

F5 Zoom In (Navigation Window)

F6 Zoom Out (Navigation Window)

F7 Swap Workspace and Navigation Window contents

F8 Lock View (Navigation Window)

F9 Autorouting, start

F10 Autorouting, resume

F11 Autorouting, pause

F12 Autorouting, stop

Keypad Keys
You can initiate specific commands using the numeric keypad keys on your keyboard.

The following table defines the keypad key command assignments.

Table  34. Keypad Key Command Assignments

Keypad Keys Description

(Number Keys) with NumLock On

Keypad (0) Center the view using the pointer location

Keypad (1) Redraw
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Table  34. Keypad Key Command Assignments  (continued)

Keypad Keys Description

Keypad (2) Pans the workspace down one increment

Keypad (3) Zooms out at the pointer

Keypad (4) Pans the workspace left one increment

Keypad (5) Starts Zoom from center (Num Lock only)

Keypad (6) Pans the workspace right one increment

Keypad (7) Zoom to the Board

Keypad (8) Pans the workspace up one increment

Keypad (9) Zoom in at the pointer location

Keypad (.) Starts Zoom from corner (Zoom mode only)

(Command Keys) with NumLock Off

Insert Centers the view using the pointer location

End Redraw

Down Arrow Moves the pointer down one design grid

Page Down Zooms out at the pointer

Left Arrow Moves the pointer left one design grid

Right Arrow Moves the pointer right one design grid

Home Zooms to the Board

Up Arrow Moves the pointer up one design grid

Page Up Zooms in at the pointer

Delete Delete the selected object

Keyboard Shortcuts
For menu-free operation, start commands using shortcut keys.

Tip
You can also create or change shortcut key assignments  on page 558.

The following tables list all of the keyboard shortcut commands.
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Table  35. Keyboard Shortcuts for Panning, Zooming, and Navigation

Name Shortcut Keys Description

Zoom to Board <Home> Zooms to the board. Fits the board outline into 
the workspace.

Zoom to Board Ctrl + B Zooms to the board. Fits the board outline into 
the workspace.

Zoom Extents Ctrl-Alt + E Zooms to extents. Fits all objects in the design 
into the workspace.

Zoom Area In/Out MMB (drag) Zooms area in or out. Drag pointer up to zoom 
in. Drag pointer down to zoom out.

Start Zoom from Corner Shift + MMB (Drag) Starts Zoom from Corner.

Zoom to Selection Alt + Z Zooms to selection. Fits the selected objects 
into the workspace.

Zoom Mode On/Off Ctrl + W Toggles Zoom Mode On/Off.

Center View (Using Pointer 
Location)

MMB Centers the view at the pointer.

Center View (Using Pointer 
Location)

<Insert> Centers the view at the pointer.

Zoom In at Pointer (Zoom 
Mode)

LMB Click Zooms in at the pointer (zoom mode).

Zoom Out at Pointer (Zoom 
Mode)

RMB Click Zooms out at the pointer (zoom mode).

Zoom In at Pointer (Zoom 
Mode)

<spacebar> Zooms in at the pointer (zoom mode).

Zoom In at Pointer <PgUp> Zooms in at the pointer.

Zoom Out at Pointer <PgDn> Zooms out at the pointer.

Zoom In at Pointer Ctrl + Wheel Fwd Zooms in at the pointer.

Zoom Out at Pointer Ctrl + Wheel Back Zooms out at the pointer.

Move Pointer Down (One 
Design Grid)

<Down Arrow> Pointer moves down one design grid.

Move Pointer Up (One Design 
Grid)

<Up Arrow> Pointer moves up one design grid.

Move Pointer Left (One Design 
Grid)

<Left Arrow> Pointer moves left one design grid.

Move Pointer Right (One 
Design Grid)

<Right Arrow> Pointer moves right one design grid.
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Table  35. Keyboard Shortcuts for Panning, Zooming, and Navigation  (continued)

Name Shortcut Keys Description

Dynamic Panning Alt + MMB (Drag) Pans the sheet area below the pointer to the 
center of the workspace.

Pan Workspace Down (One 
Line)

Wheel Back Pans workspace down one line.

Pan Workspace Up (One Line) Wheel Fwd Pans workspace up one line.

Pan Workspace Right (One 
Line)

Shift + Wheel Back Pans workspace right one line.

Pan Workspace Left (One Line) Shift + Wheel Fwd Pans workspace left one line.

Pan Workspace Down (One 
Pixel)

Ctrl-Alt + Wheel 
Back

Pans workspace down one pixel.

Pan Workspace Up (One Pixel) Ctrl-Alt + Wheel 
Fwd

Pans workspace up one pixel.

Pan Workspace Right (One 
Pixel)

Alt-Shift + Wheel 
Back

Pans workspace right one pixel.

Pan Workspace Left (One 
Pixel)

Alt-Shift + Wheel 
Fwd

Pans workspace left one pixel.

 

Table  36. Keyboard Shortcuts for Selection

Name Shortcut Keys Description

Select LMB Click Selects an object.

Select <Spacebar> Selects an object.

Select All Board Objects Ctrl + A Selects all objects in the design based upon the 
selection filter choices.

Area Select LMB (Start Drag) Starts an area selection.

Area Complete LMB (End Drag) Completes an area selection.

Cancel Area Selection LMB (Cancel Drag) Cancels an area selection.

Cycle Selection <Tab> Cycles the selection of adjacent objects within 
the pick radius.

Toggle Selection Ctrl + LMB Click Toggles object selection.

Toggle Area Selection Ctrl + LMB (Drag) Toggles an area selection
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Table  37. Keyboard Shortcuts for File Operations

Name Shortcut Keys Description

Create New Design File (Blank) Ctrl + N Creates a new blank design file.

Open File (Design) Ctrl + O Opens a design file.

Print/plot Ctrl + P Print/plot

Save (Quick Save) Ctrl + S Saves the design file

 

Table  38. Keyboard Shortcuts for Opening Menus and Dialog Boxes

Name Shortcut Keys Description

Open File Menu Alt + F Opens the File menu.

Open Edit Menu Alt + E Opens the Edit menu.

Open View Menu Alt + V Opens the View menu.

Open Setup Menu Alt + S Opens the Setup menu.

Open Tools Menu Alt + T Opens the Tools menu.

Open Help Menu Alt + H Opens the Help menu.

Open Shortcut Menu RMB Opens the Shortcut menu.

Properties (Current Object) LMB DblClick Displays Properties for the currently selected 
object.

Properties (for Selected) Alt+<Enter> Opens Properties dialog box for selected object 
or, if no object is selected, for the design.

Properties (for Selected) Ctrl + Q Opens Properties dialog box for selected object 
or, if no object is selected, for the design.

Options Ctrl + <Enter> Opens the Options dialog box.

Open Colors Category of the 
Options Dialog

Ctrl-Alt + C Opens the Colors category of the Options 
dialog box.

Open the Options Dialog (Last 
Viewed)

Ctrl-Alt + D Opens the last viewed category of the Options 
dialog box.

Open the Options Dialog (Last 
Viewed)

Ctrl-Alt + G Opens the last viewed category of the Options 
dialog box.

Open View Nets Dialog Ctrl-Alt + N Opens the View Nets dialog box.
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Table  39. Keyboard Shortcuts for Placement Operations

Name Shortcut Keys Description

Move Selected Object(s) Ctrl + E Moves the selected object(s).

Rotate Ctrl-Shift + R Rotates a component (90 degrees)

Rotate (During Move) <Tab> Rotates a component (during component move 
mode).

Rotate Component (90) Ctrl + R Rotates the selected components(90 degrees).

Spins Component Ctrl + I Spins a component.

Flip Side (Selected) Ctrl + F Flips an object to the opposite side of the 
board.

Flip Side (Component) Shift + F Flips a component to the opposite side of the 
board.

Table  40. Keyboard Shortcuts for Routing Operations

Name Shortcut Keys Description

Add Corner LMB Click Adds a corner (interactive routing).

Add Corner <Spacebar> Adds a corner (interactive routing).

Add Arc of Radius Alt + R Adds an arc of radius (interactive routing). Set 
the radius with the RAD shortcut.

Invert Arc Alt + I Inverts an arc (interactive routing).

Add Via (Interactive Routing) Shift + LMB Click Adds a via (interactive routing).

Add Arc (Interactive Route) Alt + A Adds an arc (interactive routing).

Backup <Backspace> Removes the last routed corner on a trace or 
the last corner on a 2D line (in polygon or path 
drawing mode).

Stretch Shift + S Stretch (interactive routing mode).

Complete LMB Click Complete (interactive routing) when pointer is 
near a valid completion point.

Complete LMB DblClick Complete (interactive routing) when pointer is 
near a valid completion point.

End (routing) Ctrl + LMB Click End (interactive routing).

Length Minimization Ctrl + M Runs length minimization.

Reset Length Monitor to 0 Crtl + <PgDn> Resets length monitor to zero (interactive 
routing).
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Table  40. Keyboard Shortcuts for Routing Operations  (continued)

Name Shortcut Keys Description

Length Monitor On/Off Ctrl + L Toggles the Length Monitor On/Off

Estimated Length Toggle (Pin 
Pair vs. Net)

Shift + E Toggles the display of the estimated length (Et) 
in the length monitor between pin pair length 
and net length.

Move Trace to Current Layer Ctrl + MMB Click Move trace to current layer.

Add Via While Routing Alt-Shift + LMB 
Click

Add via while routing.

Cycle Via Pattern (Diff Pairs) Ctrl + <Tab> Cycles through the via pair patterns, differential 
pair routing.

End Routing Ctrl-Alt + LMB 
Click

End Routing.

Previous Base Point Shift + <Tab> Previous Base Point.

Next Base Point Ctrl + Alt + <Tab> Next Base Point.

Accordion Beginning 
(Interactive Routing Mode)

Shift + A Begin an accordion, interactive routing mode.

End Accordion LMB DblClick Ends an accordion, interactive routing.

Dynamic Reconnect On/Off Shift + N Toggles Dynamic Reconnect on or off.

Dynamics Mode On/Off Shift + D Toggles Dynamics mode on or off, interactive 
routing.

Grid Snap On/Off (Routing Grid 
Only)

Alt + G Toggles snap to routing grid on or off.

Guard Bands On/Off Shift + G Toggles guard bands on or off.

Switch Rules Shift + R Switches rules.

Switch Trace (Route 
Separately Mode)

<Tab> Switches trace, route separately mode.

Show Length of Alternate Trace 
(Trace Length Monitor in Diff 
Pairs Mode)

<Tab> Shows the length of the alternate trace in the 
differential pair. Use this with the trace length 
monitor to check the length of each member of 
the differential pair.

Split Pair Around Obstacle (Diff 
Pairs Mode)

Shift + X Split pair around obstacle, routing differential 
pairs.

Route Separately (Diff Pairs 
Mode)

Shift + Z Routes separately, routing differential pairs.
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Table  41. Keyboard Shortcuts for Layer List Navigation

Name Shortcut Keys Description

Change Current Layer to 
Previous in List

Alt + <Up Arrow> Changes the current layer to previous in list.

Change Current Layer to Next 
in List

Alt + <Down 
Arrow>

Changes the current layer to next layer in list.

Change Current Layer to 
Previous in List

Alt + Wheel Back Changes the current layer to previous in list.

Change Current Layer to Next 
in List

Alt + Wheel Fwd Changes the current layer to previous in list.

Table  42. Keyboard Shortcuts for Protection of Objects

Name Shortcut Keys Description

Protect Objects Shift + P Protects objects.

Unprotect Objects Shift + U Unprotects objects

Table  43. Keyboard Shortcuts for DRC Operations

Name Shortcut Keys Description

DRC Setting Dialog Alt + D Opens the DRC Settings dialog box.

Explain Last Error Alt + X Explains the last DRC error (component move 
mode).

 

Table  44. Keyboard Shortcuts for Editing

Name Shortcut Keys Description

Cut Ctrl + X Cut

Copy Ctrl + C Copy.

Paste Ctrl + V Paste.

Redraw <End> Redraw.

Redraw Ctrl + D Redraw.

Delete <Delete> Unroute selected object.

Cancel <Escape> Cancels command.

Redo Ctrl + Y Redo.
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Table  44. Keyboard Shortcuts for Editing  (continued)

Name Shortcut Keys Description

Undo Ctrl + Z Undo.

Highlight Object Ctrl + H Highlights Object.

Unhighlight Ctrl + U Removes highlighting from current object.

Toggle Highlight Alt + LMB Click Highlighting on or off.

Area Highlight Alt + LMB (Drag) Highlights objects in the enclosed area.

Table  45. Keyboard Shortcuts for Viewing

Name Shortcut Keys Description

Next View Alt + N Displays the next view.

Previous View Alt + P Displays the previous view.

Previous View Ctrl + Alt + P Displays the previous view.

Table  46. Mouse Button Substitutions

Name Shortcut Keys Description

Activate Right Click Pop-up 
Menu (Right Mouse Button)

M Activates the shortcut menu for the current 
mode. Same as right-click.

Left Mouse Click <Spacebar> Activates a left mouse button click (to add 
corners, select items, complete, etc.) at the 
current pointer location.

Table  47. Miscellaneous Keyboard Shortcut Commands

Name Shortcut Keys Description

Check Clearance Toggle for 
Current Operation

Shift + C Checks clearance.

Database Integrity Test Shift + I Runs database integrity test.
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Chapter 7
View

SailWind Router provides controls for changing the display of a design, from changing display colors to 
scrolling and zooming across the details.

Setting Colors for the Design
Changing the Color Palette
Saving Color Schemes
Highlighting and Unhighlighting Design Objects
View Controls
Pan, Zoom, and Scroll the Display
Scrolling Through Layers Using the Wheel
Viewing by Layer Using the Layers List
Showing Previous or Next Views

Setting Colors for the Design
As you work on a design, you can customize display colors to make it easier to see objects as you place 
them.

Use the Colors category of the Options dialog box to perform the following tasks:

• Set and change the color of objects on a per-layer or per-object type basis.

• Make objects visible or invisible in the display (also on a per-layer or per-object type basis).

• Customize the palette of color selections.

• Save your custom color scheme. You can then switch among color schemes you commonly use 
to work with a design.

Procedure
1. Click the Tools > Options  menu item.

2. In the Options dialog box, click the Colors  on page 422 category.

3. Set the color(s) for design objects:
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a. To set the color for one object, in the Color selection area, click a color tile. Then in the Layers/
Object Types table, click the color tile for the object type in the correct layer row. (Visibility of 
the object must be enabled first by clicking the Visible check box for the corresponding row.)

Figure 14. Enabling Object Viewing

Tip
To change the palette of colors from which you can select, see ““Changing the Color 
Palette”  on page 121”.

b. To make all objects on a layer the same color, click the layer number to select the entire row, 
and then click the color tile in the Color selection area.

c. To make an object the same color on all layers, click the object name to select the entire 
column, and then click the color tile in the Color selection area.

d. To make an object type invisible, set its tile to the background color. You can make multiple 
objects invisible (for example, all objects on the same layer).

e. To copy a color definition from one row or column and paste it to another row or column:

i. Select the row or column with the color definition that you want to copy and press Ctrl+C.

ii. Select the row or column to which you want to paste the color definition.

iii. Press Ctrl+V.

4. Click OK.  The display reflects your color settings.

Results
When you save the design, SailWind Router stores the setting with design data.
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Changing the Color Palette

You can save display color settings you commonly use as you work on a design. See ““Saving Color 
Schemes”  on page 121”.

You can use modeless commands to toggle the display of pin numbers and net names. See ““Table 19” 
on page 97”.

Changing the Color Palette
You can change the colors that appear in the color palette.

Procedure
1. Click the Tools > Options  menu item.

2. In the Options dialog box, click the Colors  on page 422 category.

3. In the “Color selection” area, click the color tile that you want to change.

4. Click Custom.

5. In the Color dialog box, click the color value you want to use. You can also create a custom color. 
Refer to the Windows Help for more information on changing the Windows color palette.

6. Click OK  to return to the Display Colors Setup dialog box. You may need to click the selected color 
tile again to see the color change. The new color appears in the tile you selected.

7. Click OK  to close the Options dialog box.

Results
You can bring back the original color palette by clicking Default.

Related Topics
Setting Colors for the Design

Saving Color Schemes

Saving Color Schemes
You can save to file the color assignments you have specified in the Colors category of the Options dialog 
box.

Procedure
1. Click Tools > Options.

2. In the Options dialog box, click the Colors  on page 422 category.

3. Set the color assignments  on page 119 for the scheme.

4. In the Color scheme area, click Save As.

5. In the Save Scheme dialog box that appears, type the scheme name.
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Results
To use a previously saved configuration, select the configuration name from the “Color scheme name” list.

Related Topics
Setting Colors for the Design
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Highlighting and Unhighlighting Design 
Objects
You can highlight or clear the highlighting from objects in your design to distinguish them from other 
design objects. Highlights help you visually locate objects when working on a dense design.

You can set how highlighting is displayed using the “Distinguish highlighted objects by” list in the “Options 
Dialog Box, Global Category, General Subcategory”  on page 441.

Highlighting Objects
Unhighlighting Objects
Unhighlighting All Objects

Highlighting Objects
You can highlight one or more objects in the design.

Procedure
Press and hold the Alt key then select one or more objects. Alternatively, select an object then click the 
Edit > Highlight  menu item.

Tip
You can also use the HG, HD, and HH shortcut keys to highlight objects. See the “Table 24”  on 
page 102.

Unhighlighting Objects
Remove highlighting from one or more objects in the design.

Procedure
Press and hold Alt, and click the highlighted object or objects. Alternatively, select one or more highlighted 
objects then click the Edit > Unhighlight  menu item.

Unhighlighting All Objects
You can remove highlighting from all objects in the design with one command.

Procedure
Press and hold Alt, and click in an empty area of the design, or click the Edit > Unhighlight All.

Tip
You can also use the HG, HD, and HH shortcut keys to do this. See the “Table 24”  on page 102.
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View Controls
You can control which areas of a design are visible.

Use the commands in the following table to control the display in the workspace.

Table  48. Display Commands

Command Description

Zoom Moves closer to or farther from the design. Access this control through the main 
toolbar or the View menu.

View Board Fits the board outline into the workspace. Access this control through either the 
main toolbar or the View menu.

View Extents Fits the entire design, including objects outside the board outline, into the 
workspace. Access this control through either the main toolbar or the View 
menu.

View Selection Fits a selected object or area in the workspace. Access this control through the 
View menu.

Previous View Displays the previous view in the workspace. Access through the View menu.

Next View Displays the next view in the workspace. Access through the View menu.

Layer List Displays a specific layer on top of other layers. Access as a dropdown list on the 
main toolbar.

Controlling the View
Using the keys on the keypad located at the far right of most keyboards, you can control which part of the 
design is visible on the screen. NumLock can be on or off except where noted.

Table  49. View Commands

Keys Description

Home Fits the board into the workspace.

End Redraws the current view.

Arrows Pan the viewing window when NumLock is on. Move one-half the screen width in 
the direction of the arrow. With NumLock off, move by grid unit.

Page Up Zooms in centered at the pointer location.

Page Down Zooms out centered at the pointer location.

Ins Centers the view at the current pointer location, without zooming.

Use the vertical and horizontal scroll bars to pan the view vertically or horizontally.
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Pan, Zoom, and Scroll the Display

Displaying Selected Nets
Use the View Nets dialog box (accessible from the View menu) to select and view nets. The View Nets 
dialog box shows View details for selected nets. For each net, you can hide or show connections, routed 
paths, or unrouted paths. When you move nets into the View list box, you can specify color and show or 
hide various unroutes.

Viewing Nets by Color
Use the color palette to show a selected net in a specific color. When you assign a color to a net, the 
pads, vias, and connections on all layers appear in the assigned color. This makes it easier to identify 
nets when you split planes. Any net color assignments you make are saved when you save the design.

Pan, Zoom, and Scroll the Display
Use the mouse wheel to scroll, pan, and zoom the workspace display.

The following mouse/key combinations affect the display:

• Roll the mouse wheel to scroll the display up and down.

• Press and hold the Shift key while rolling the mouse wheel to pan left and right.

• Press and hold the CTRL key while rolling the mouse wheel to zoom in and out.
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Scrolling Through Layers Using the Wheel
If desired, you can press and hold Alt and roll the mouse wheel to scroll through layers of the design. Use 
this feature for previewing layers while routing interactively and for displaying individual electrical layers.

Previewing Layers While Interactively Routing
Displaying Individual Electrical Layers

Previewing Layers While Interactively Routing
The ability to preview layers during routing and trace editing helps you determine which layer has the 
most space for additional traces.

Procedure
1. While interactively routing, press Alt and roll the wheel button backward or forward.

2. Do one of the following:

• To transition layers at the current pointer location, press Shift and click. A via appears at the 
pointer location, allowing you to continue routing from that point on the layer you previewed.

• To move the trace in progress (from the last corner location), press Ctrl and click the middle 
mouse button. A via appears at the last corner location and moves the trace to the layer you 
previewed.

Displaying Individual Electrical Layers
You can cycle the display through the set of individual electrical layers. Switching the display to adjacent 
electrical layers skips over non-electrical layers and also renders all other layers invisible.

Procedure
1. Type the shortcut key Z C to make the current layer visible and make all other layers invisible. The 

current layer does not have to be an electrical layer.

2. To switch the display to an adjacent electrical layer, press Alt and roll the wheel button backward 
or forward. As an alternative, you can use Alt+Arrow up instead of Alt+wheel backward. You can 
use Alt+Arrow down instead of Alt+wheel forward. When you try to switch beyond the outermost 
electrical layer, the display loops back to the outermost electrical layer on the other side of the 
board.

Viewing by Layer Using the Layers List
SailWind Router provides a Layers list view to allow you to display a specific layer on top of other layers.
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Showing Previous or Next Views

Note:
The board outline, unroutes, thermal indicators, and test point indicators always appear on top of 
other objects, regardless of layer selection.

Procedure
1. On the standard toolbar, open the Layers list.

2. Click the layer you want to display on top.

Tip
If you select All Layers, layers appear from bottom to top.

Showing Previous or Next Views
Use Previous View and Next View to display previous and next views recorded by the program. Show 
Previous and Show Next work like multilevel undo and redo commands. You can save up to 100 views. 
When the view buffer is full, newer views replace the oldest views.

Procedure
To show the previous view, click the View > Show Previous  menu item. To show the next view, click the 
View > Show Next  menu item.
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Chapter 8
Undo, Redo, Repeat, Delete

Use the Undo, Redo, Repeat, and Delete commands to cancel or repeat your last operation on a design 
object. Undo and Redo clear all objects in the design before running. The Undo command updates 
graphics in the workspace and updates the Project Explorer.

An undo buffer contains recorded database changes. When the buffer is full, the oldest change is deleted.

New, Open, Save, Save As, Restore, and Autoroute clear the undo and redo buffer, and make Undo and 
Redo unavailable.

Use the Undo and Redo list boxes on the main toolbar to open the list of recent operations. Select 
the operations in the list you want to undo or redo. Use these commands to undo and redo your last 
command operation. Undo and Redo deselect all objects in the design before running.

Undoing a Command
Redoing a Command
Undoing Multiple Commands
Redoing Multiple Undos
Repeating Operations

Undoing a Command
Undo the last command on a selected object.

Procedure
Click the Edit > Undo  menu item, or click the Undo  button on the main toolbar.

Redoing a Command
Redo the last undo on a selected object

Procedure
Click the Edit > Redo  menu item, or click the Redo  button on the main toolbar.

Undoing Multiple Commands
You can undo multiple actions at one time.

Procedure
1. Click the arrow next to the Undo  button on the standard toolbar to see a list of the most recent 

actions you can undo.

2. Click the action you want to undo. When you undo an action, you also undo all actions above it in 
the list.
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Redoing Multiple Undos
You can redo multiple undos.

Procedure
1. Click the arrow next to the Redo  button on the standard toolbar to see a list of the most recent 

actions you can redo.

2. Click the action you want to redo. When you redo an action, you also redo all actions above it in 
the list.

Repeating Operations
You can repeat a series of operations, thus simplifying a repetitive sequence of steps.

Procedure
1. Select an object in the design.

2. Perform a command or series of commands.

3. Select another object.

4. On the standard toolbar, click the Repeat  button.

Alternatively, click the Edit > Repeat  menu item.

Examples
You want to unroute and re-fan out two or more components in your design. You also want to highlight the 
components. To do this:

1. Select one of the components.

2. Right-click and click the Unroute  popup menu item.

3. Right-click and click the Fanout  popup menu item.

4. Click the Edit > Highlight  menu item.

5. Select the next component.
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Repeating Operations

6. Click the Edit > Repeat  menu item.

7. Repeat steps 5 and 6 for any additional components.
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Chapter 9
Search and Selection

You can select design objects directly in the workspace, in Project Explorer, and in the Spreadsheet 
window.

Selection Modes
Selecting Objects
Selection Status on the Status Bar
Extending Selections
Select Part of an Object
Selecting a Trace Corner
Selecting a Trace Path
Filtering Selections
Cycling Through Selections

Selection Modes
You can execute a command on a design object in two ways: Select the object and then select the 
command (known as object mode), or select the command and then select the object (known as verb 
mode).

Object Mode
In object mode, you click an object to select it before choosing a command. After selecting the object, you 
choose a command using one of the following methods:

• Right-click and select a command from the shortcut menu.

• Select a command in a toolbar or from a menu.

Verb Mode
In verb mode, you select the command you want to execute from a toolbar or menu, then you click one 
or more objects on which you want to perform the command. Verb mode automatically sets the selection 
filter to items that respond to the active command. For example, if you are in Move Component verb 
mode, the selection filter changes to allow selection of components only. After moving one component, 
you can move another simply by selecting it.

Verb mode commands are also available on toolbars.

Selecting Objects
SailWind Router provides you with multiple ways of selecting a design object.

You can select a design object using one of the following methods:
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• Click directly on the object in the workspace.

• Click near it and use the Cycle  button to cycle through nearby objects.

• Use the Find Dialog Box  to locate it and select it.

• Click on the object in Project Explorer. (If necessary, right-click and click the Allow Selection 
popup menu item to enable selection of objects in the Project Explorer.)

• Use the Find Dialog Box, Spreadsheet Window  to locate it and select it.

When you select an object, all its elements are selected and highlighted. For example, when you select 
a component, all of its pins, copper, and text are also selected. Any previously selected objects are 
unselected.

If you double-click an object, it is selected and its properties dialog box appears. If you press Esc or right-
click and click Cancel, all objects are unselected.

You can set how selected objects appear on screen using the “Distinguish highlighted objects by” list in 
the Options dialog box > Global  category > General  on page 441 subcategory.

The table below summarizes the different ways to select objects.

Table  50. Object Selection Methods

To Select Action

Single object Click an object.

Objects in a rectangular area Starting at one corner of the area, click and hold the left mouse 
button, and drag to the diagonally opposite corner. Release the 
button.

All objects On the Selection Filter toolbar, click the Select All  button. You 
can also press Alt+A. Select All selects all objects according to 
the type enabled on the Selection Filter toolbar.

Series of objects Press Ctrl and click items to add or remove, in sequence.

Extended objects Press Shift and click to select objects related to selections. For 
example, if a pin is selected, and you Shift and click it, all other 
pins in the net are selected.

Objects in a dense or crowded 
area

Use the Selection Filter toolbar to prevent certain objects from 
being selected.

Part of objects Use the Selection Filter toolbar to select only part of objects, such 
as trace corners.

Trace paths Using the Path  button on the Selection Filter toolbar, click at the 
start of the path and then click at the end of the path.
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Selection Status on the Status Bar
When you select objects, the status bar shows which objects are selected.

For single selection, the following information appears:

[object type] [object name (if any)] [additional information]

For example:

Component: U1, Top

For multiple selections of the same things (for example, all nets), up to ten object names appear. For 
multiple selections of different things (for example, a mixture of nets and components), up to five object 
names appear for each type of object.

For errors, the selected error count is listed along with the error type for the last error in the selection.

Extending Selections
Pressing and holding the Shift key while clicking an object selects both the object and its associated 
items. Selected objects change to the color set for Selections in the Display  tab of the Options dialog 
box.

Table 51  summarizes the effect of clicking an object while holding the Shift key.

Table  51. Objects and their Associated Items

Object Shift and click selects

Component Component and all attached traces

Pin All pins in the net connected to the selected pin

Net All nets in the net class if the net is a part of a net class

Unroute, trace, pin pair, via Connected nets

Trace segment or corner Connected nets

Keepout, text, error No associated items

Copper, copper plane Connected nets

Restriction:
The following restrictions apply:
• You cannot select pin pairs and nets at the same time.
• You cannot Undo or Redo a selection.
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Select Part of an Object
You can select part of an object using special filters on the Selection Filter toolbar.

Note:
You can set how selected objects appear on screen using the “Distinguish highlighted objects by” 
list in the Global / General Options  on page 441.

Use the following Selection Filter commands to filter selections:

• Segments and corners— Selects trace segments and corners.

• Path— Selects a continuous portion of a trace. The trace path can start and end at any point 
along a continuous sequence of trace segments.

Selecting a Trace Corner
You can select a trace by a corner. Selecting a corner allows you to move or relocate it.

Procedure
1. Click the Tools > Options  menu item > Global  category > General  subcategory.

2. In the “Pointer settings” area, set the pick box size in the “Pick radius” box. Click OK.

3. On the Selection Filter toolbar, click the Segments and Corners  button.

4. Click the trace corner to select.

Tip
If you have short trace segments that are larger than the pick radius, either zoom in or 
cycle selections.

Selecting a Trace Path
If desired, you can select only a specific trace portion of a trace to move or edit it.

Procedure
1. On the Selection Filter toolbar View > Toolbars > Selection Filter Toolbar  menu item), click the 

Path  button.

2. Click the starting point of the path to select. The pointer changes to a path selection symbol that 
marks the start point of the path.
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Filtering Selections

3. Click the ending point of the path.

Tip
To deselect a path, press Esc. In SailWind Layout, you can right-click and click the Cancel 
popup menu item, which you cannot do in SailWind Router.

Filtering Selections
Use the Selection Filter toolbar buttons to set the objects you can select. You can also set the selection 
filter using the shortcut menu that appears when you right-click in the workspace with nothing selected.

Procedure
1. On the Selection Filter toolbar (View > Toolbars > Selection Filter Toolbar  menu item), click the 

Layers  button.

2. In the Selection Layers list (of the Selection Layers dialog box), select the check boxes for each 
layer that you want to be able to select in the design; clear a check box if you want to disable 
selection of a layer.

Alternatively, you can select the All electrical layers box at the top of the dialog box to enable all 
electrical layers for selection.

3. Click Close.

4. On the Selection Filter toolbar, click the buttons for the objects for which you want to enable or 
disable selection.

Restriction:
You cannot select pin pairs and nets at the same time.

Cycling Through Selections
If you are working in a densely populated area of a board, it may be difficult to select the correct object, 
even with the Selection Filter. You can cycle through all objects near a selected object, making it easier to 
select the correct object.

Procedure
1. Select an object near the object you want to select.

2. Press the Tab key.

Each time you press the Tab key, another object in the area is selected. If only one object is in the 
area, the Tab key has no effect
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Chapter 10
Electrical Nets

You can associate an array of nets joined by discrete components, creating an electrical net to which you 
can apply rules as you would to a single net. The length of an electrical net is the combined lengths of the 
nets and discrete components of which it is composed.

The following figure shows an example of an electrical net.

Figure 15. Electrical Net Components and Nets

Length, differential pair and matched length rules can apply to an electrical net as though it were a single 
net.

Electrical Net Creation and Modification
Deletion of Electrical Nets
Excluding Nets from Electrical Net Creation
Excluding Components from Electrical Net Creation
Canceling Electrical Net Creation by Nets
Canceling Electrical Net Creation by Components
Selecting Electrical Nets
Setting Electrical Net Properties
Creating a Matched Length Group of Electrical Nets
Creating a Differential Pair of Electrical Nets
Conditions Governing Electrical Net Creation
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Electrical Net Creation and Modification
You can create or modify electrical nets to meet your design requirements.

There are three ways to create and modify your electrical nets.

By default these methods are independent of each other (that is, you can use any of the methods by 
itself), because the commands/properties by which they interact are defaulted to allow you to choose 
one method to use, and ignore the others. Choosing one method and sticking with it is the simplest 
course. If you want to mix methods in your design, you must first understand how the methods interact, as 
described in “Conditions Governing Electrical Net Creation”  on page 151.

General Restrictions and Prerequisites
Creating Electrical Nets by Selecting the Nets
Creating Electrical Nets by Selecting the Components
Creating Electrical Nets Automatically by Refdes Prefix

General Restrictions and Prerequisites
Consider certain restrictions and prerequisites before creating electrical nets.

The following restrictions apply to all 3 electrical net creation methods:

• A plane net cannot be part of an electrical net.

• A net having more pins than the limit specified in the “Maximum non-plane-net pin count” field 
cannot be part of an electrical net.

Tip
Virtual pins are not included in a net’s pin count.

• An electrical net that would have more nets than the limit specified in the “Maximum net count per 
electrical net” field of the Electrical Nets dialog box is not created.

• Components through which an electrical net passes must be either discrete two-pin components, 
or multiple pin components that conform to the following conditions:

◦ All the pins must connect to a gate.

◦ Each gate must have exactly two pins.

No component that does not conform to these conditions can create an electrical net, that is, no 
electrical net can go through it.

The following prerequisite is recommended for all 3 electrical net creation methods.

Before you begin creating electrical nets, you should make sure that you set the “Maximum net count per 
electrical net” and “Maximum non-plane-net pin count” fields in the Electrical Nets  on page 409 dialog 
box appropriately for your design. These fields set limits on the number of nets allowed in an electrical 
net, and on the number of pins allowed in a single net included in an electrical net. If these values are set 
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Creating Electrical Nets by Selecting the Nets
inappropriately for your design, SailWind Router does not create electrical nets that it would otherwise 
create, or the software creates them differently than you expect, as follows:

• The software does not create an electrical net if the potential electrical net exceeds the 
“Maximum net count per electrical net” limit.

• If any net in the potential electrical net exceeds the “Maximum non-plane-net pin count” limit, the 
software may split the electrical net, truncate it, or not create it at all, depending on the location of 
the faulty net.

Tip
Virtual pins are not included in a net’s pin count.

For more information, see “Conditions Governing Electrical Net Creation”  on page 151.

Creating Electrical Nets by Selecting the Nets
Use this method if you want to create electrical nets by selecting nets.

Tip
Whenever you create, delete, or change electrical nets, the software regenerates all electrical 
nets in the design. Therefore, always verify that the results of an electrical nets operation are what 
you expect by reading the messages in the Output Window.

Procedure
1. In the workspace, select the nets you want to make into electrical nets.

2. Right-click and click the Create Electrical Net  popup menu item.

As an alternative, in the Net Properties dialog box, on the Electrical Net  tab, select the Create 
electrical net check box.

Results
The selected nets are made into an electrical net, and the Net Properties Create electrical net check box 
is selected for all the selected nets.

Are the results different from what you expected?

• SailWind Router may have split or truncated an expected electrical net, or not created it at all, 
because one or more of its nets or components did not conform to the General Restrictions and 
Prerequisites  for creating electrical nets.

• Some nets cannot be made into electrical nets; for example, two selected nets from opposite 
sides of the board will have the Create electrical net check box selected, but no electrical net will 
be created.

• Mixed-method restriction:  If a component to which one of the selected nets is attached has 
been excluded from electrical net creation, it cannot create an electrical net, that is, no electrical 

SailWind Router Guide 141



Electrical Nets
Creating Electrical Nets by Selecting the Components  

net can go through it. (A component or net is excluded from electrical net creation if its Create 
electrical net and “Allow electrical net creation...” check boxes are both cleared.)

For more information, see “Conditions Governing Electrical Net Creation”  on page 151.

Related Topics
Canceling Electrical Net Creation by Nets

Excluding Nets from Electrical Net Creation

Creating Electrical Nets by Selecting the 
Components
Use this method if you want to create electrical nets by selecting components to associate its connected 
nets.

Tip
Whenever you create, delete, or change electrical nets, SailWind Router regenerates all electrical 
nets in the design. Therefore, always verify that the results of an electrical nets operation are what 
you expect by reading the messages in the Output Window.

Procedure
1. In the workspace, select the components whose nets you want to make into electrical nets.

2. Right-click and click the Create Electrical Net  popup menu item.

As an alternative, in the Component Properties dialog box, on the Electrical Nets  tab, select the 
Create electrical net check box.

Results
The nets attached to the selected components are made into electrical nets, and the Component 
Properties “Create electrical net” property is set for all the selected components.

Are the results different from what you expected?

• SailWind Router may have split or truncated an expected electrical net, or not created it at all, 
because one or more of its nets or components did not conform to the General Restrictions and 
Prerequisites  for creating electrical nets.

• Mixed-method restriction:  If you have excluded a net that is attached to a selected component 
from electrical net creation, it cannot be included in an electrical net. (A component or net is 
excluded from electrical net creation if its Create electrical net nets and Allow electrical net 
creation... check boxes are both cleared.)

For more information, see “Conditions Governing Electrical Net Creation”  on page 151.

Related Topics
Excluding Components from Electrical Net Creation

Canceling Electrical Net Creation by Components

142 SailWind Router Guide



 
Electrical Nets

Creating Electrical Nets Automatically by Refdes Prefix

Creating Electrical Nets Automatically by Refdes 
Prefix
If you want to create electrical nets automatically, use this method to specify the refdes prefixes of any 
components through which the nets pass.

Tip
Whenever you create, delete, or change electrical nets, SailWind Router regenerates all electrical 
nets in the design. Therefore, always verify that the results of an electrical nets operation are 
expected by reading the messages in the Output Window.

Prerequisites
This procedure creates electrical nets for all components that have the specified refdes prefixes and 
conform to the General Restrictions and Prerequisites  for creating electrical nets. Ensure the refdes 
prefixes of any set of components you plan to group into electrical nets are unique.

Procedure
1. Click the Setup > Electrical Nets  menu item.

2. In the Maximum net count per electrical net box, type the maximum number of nets to be allowed 
in electrical nets.

3. In the Maximum non-plane-net pin count box, type the maximum number of pins allowed in nets 
belonging to electrical nets. Nets that have pin counts higher than this maximum are considered 
plane nets, and are not included in electrical nets.

Tip
Virtual pins are not included in a net’s pin count.

4. In the Discrete component prefixes area, enter the refdes prefixes of the components you want to 
be creating electrical nets.

Tip
The text entry field names are only for convenience; prefixes for any type of component 
can be entered in any field.

Results
When you click OK  or Apply, electrical nets regenerate based on the new or changed set of specified 
refdes prefixes.

Rules (min/max length, matched length groups, differential pairs) for electrical nets that are unchanged in 
the regeneration are kept. Electrical nets that are changed (including changes to the set of components 
they pass through), or deleted:
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• Lose their rules

• Are removed from matched length groups, and

• Diff pairs containing them are removed.

Are the results different from what you expected?

• SailWind Router might have split or truncated an expected electrical net, or not created it at all, 
because one or more of its nets or components did not conform to the General Restrictions and 
Prerequisites  for creating electrical nets.

• Mixed-method Restriction: If any of the selected components, or any net attached to a selected 
component, has been excluded from electrical net creation, it cannot be included in an electrical 
net. (SailWind Router excludes a component or net from electrical net creation if its “Create 
electrical net” and “Allow electrical net creation...” check boxes are both cleared.)

For more information, see “Conditions Governing Electrical Net Creation”  on page 151.

Related Topics
Deleting Electrical Nets Manually

Excluding Nets from Electrical Net Creation

Excluding Components from Electrical Net Creation
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Deletion of Electrical Nets
You can delete electrical nets manually or—if you created them automatically through the Electrical Nets 
dialog box—you can delete them automatically.

Deleting Electrical Nets Manually
Deleting Electrical Nets Automatically

Deleting Electrical Nets Manually
You can remove electrical nets manually from the workspace or from Project Explorer.

Tip
Deleting an electrical net does not delete physical nets.

Procedure
1. In Project Explorer or the workspace, select the electrical nets you want to delete.

2. Right-click and click either the Delete  or the Delete Electrical Net  popup menu item.

Results
The Create electrical net check box is cleared for all the physical nets of the selected electrical nets. If 
any physical nets have also been made into electrical nets by component (including by refdes prefix), for 
those nets the “Allow electrical net creation by component” check box is cleared as well.

Related Topics
Canceling Electrical Net Creation by Nets

Excluding Nets from Electrical Net Creation

Deleting Electrical Nets Automatically
You can “automatically” delete a group of electrical nets which you have created using the refdes prefix 
method.

Tip
Whenever you create, delete, or change electrical nets, SailWind Router regenerates all electrical 
nets in the design. So you should always verify that the results of an electrical nets operation are 
what you expected by reading the messages in the Output Window.
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Procedure
1. Choose the Setup > Electrical Nets  menu item.

2. Delete the refdes prefixes of the components that should not be creating electrical nets.

3. Click OK.

Results
The electrical nets created by components having the specified refdes prefix are deleted, split or 
truncated.

Are the results different from what you expected?

• Mixed-method restrictions:

◦ If a component having the deleted refdes prefix also has the Component Properties “Create 
electrical net” check box selected, the nets of that component remain in an electrical net.

◦ If a component having the deleted refdes prefix has the “Allow electrical net creation by 
refdes prefix and nets” check box selected, and both nets attached to a two-pin component 
(or to a single gate of a multiple-pin component) have the “Create electrical net” check box 
checked, those nets will remain in an electrical net.

For more information, see “Conditions Governing Electrical Net Creation”  on page 151.

Related Topics
General Restrictions and Prerequisites

Excluding Components from Electrical Net Creation

Excluding Nets from Electrical Net Creation
You can select physical nets for exclusion from any electrical net.

Tip
This procedure clears both the Net Properties “Create electrical net” check box and the “Allow 
electrical net creation by component” check box, removing the selected nets from any current 
electrical net and preventing electrical net creation by component (including by refdes prefix). For 
more information, see “Conditions Governing Electrical Net Creation”  on page 151.

CAUTION:
Whenever you create, delete, or change electrical nets, SailWind Router regenerates all electrical 
nets in the design. Therefore, always verify that the results of an electrical nets operation are 
expected by reading the messages in the Output Window.
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Procedure
1. In the workspace, select the net(s) you want to exclude from electrical net creation.

2. Right-click and click the Disable Electrical Net Creation  popup menu item.

As an alternative, in the Net Properties dialog box, on the Electrical Net  tab, clear both the “Create 
electrical net” and “Allow electrical net creation by components” check boxes.

Results
The selected nets are removed from existing electrical nets, and the Net Properties “Create electrical net” 
and “Allow electrical net creation by components” check boxes are cleared for all the selected nets.

Related Topics
Conditions Governing Electrical Net Creation

Canceling Electrical Net Creation by Nets

Excluding Components from Electrical Net Creation

Excluding Components from Electrical Net 
Creation
You can prevent an individual component from creating electrical nets—a component through which an 
electrical net passes. If you exclude a component that is not already part of an electrical net, it cannot 
become part of an electrical net created by net or by refdes prefix. In addition, if the component is already 
part of an electrical net, excluding it removes it from the electrical net.

Note:
This procedure clears both the Component Properties “Create electrical net” and “Allow electrical 
net creation...” check boxes, preventing the selected components from creating electrical nets. 
For more information, see “Conditions Governing Electrical Net Creation”  on page 151.

Tip
Whenever you create, delete, or change electrical nets, SailWind Router regenerates all electrical 
nets in the design. Therefore, always verify that the results of an electrical nets operation are 
expected by reading the messages in the Output Window.

Procedure
1. In the workspace, select the components you want to exclude from creating electrical nets.

2. Right-click and click the Disable Electrical Net Creation  popup menu item.

As an alternative, in the Component Properties dialog box, clear both the “Create electrical net” 
and “Allow electrical net creation by refdes prefix or by nets” check boxes.
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Results
The selected components are excluded from electrical net creation. If a component is part of an existing 
electrical net, it is removed, that is, the electrical net no longer goes through it. Removing a component 
from an electrical net splits, truncates, or deletes the electrical net, depending upon its configuration and 
the position of the removed component.

Are the results different from what you expected?

• Nets attached to the excluded component may still be made into electrical nets through other 
components.

Related Topics
Conditions Governing Electrical Net Creation

Excluding Nets from Electrical Net Creation

Canceling Electrical Net Creation by Nets
You can cancel or end the “electrical net creation by the net” method.

Tip
Whenever you create, delete, or change electrical nets, SailWind Router regenerates all electrical 
nets in the design. Therefore, always verify that the results of an electrical nets operation are 
expected by reading the messages in the Output Window.

Procedure
1. In the workspace or Project Explorer, select the nets you want to remove from electrical nets.

2. Right-click and click the Properties  popup menu item.

3. In the Electrical Nets tab, clear the Create electrical net check box.

Tip
If you want to exclude the nets from electrical net creation altogether, also clear the “Allow 
electrical net creation by components” check box.

Results
The selected nets are removed from existing electrical nets.

Are the results different from what you expected?

• Mixed-method restriction: Nets that are also made into electrical nets by the component and/or 
the refdes prefix method remain in electrical nets.

Related Topics
Conditions Governing Electrical Net Creation
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Canceling Electrical Net Creation by 
Components
Cancel the creation of an electrical net that is created by the components it passes through.

Tip
Whenever you create, delete, or change electrical nets, SailWind Router regenerates all electrical 
nets in the design. Therefore, always verify that the results of an electrical nets operation are what 
you expected by reading the messages in the Output Window.

Procedure
1. In the workspace or Project Explorer, select the components whose electrical net creation you want 

to cancel.

2. Right-click and choose the Properties  popup menu item.

3. In the Electrical Nets area, clear the “Create electrical net” check box.

Tip
If you want to exclude the components from electrical net creation by any method, also 
clear the “Allow electrical net creation by refdes prefix and by nets” check box.

Results
Electrical net creation by the selected component is canceled.

Are the results different from what you expected?

• Mixed-method restriction: Nets that conform to the following criteria remain in electrical nets 
throughout the selected components:

◦ The nets are attached to selected components, and

◦ The nets are also made into electrical nets by the net and/or the refdes prefix method

Selecting Electrical Nets
Use a popup menu item to select an electrical net. Selecting the electrical net also selects all physical 
nets in the electrical net.

Procedure
1. With nothing selected, right-click and click the Select Nets  popup menu item.

2. In the workspace, select one of the nets in the electrical net you want to select.
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3. Right-click and click the Select Electrical Net  popup menu item.

Tip
You can also select electrical nets in the Project Explorer.

Setting Electrical Net Properties
Use the Electrical Net Properties dialog box to set or modify electrical nets properties.

Procedure
1. Select the electrical nets whose properties you want to set.

2. Right-click and click the Properties  popup menu item.

3. In the Electrical Net Properties dialog box, make the appropriate settings in the Electrical Net  on 
page 411 and Length  on page 413 tabs, and click OK.

Creating a Matched Length Group of Electrical 
Nets
You can group electrical nets together to create a matched length group.

Procedure
1. Select the electrical nets  on page 149.

Tip
You can also select nets to add to the group.

2. Right-click and click the Make Matched Length Net Group  popup menu item.

3. As an alternative, in the Project Explorer, select the electrical nets and copy/paste or drag and drop 
them into a matched length net group, or into the Matched Length Net Groups group.

Creating a Differential Pair of Electrical Nets
You can select electrical nets and create a differential pair.

Procedure
1. Select the electrical nets  on page 149.

2. Right-click and click the Make Differential Electrical Net  popup menu item.

3. As an alternative, in the Project Explorer, select the electrical nets and copy/paste or drag and drop 
them into the Differential Pairs group.
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Conditions Governing Electrical Net Creation
A number of conditions regulate the creation of electrical nets.

Electrical net creation is controlled by the following dialog box settings:

• The “Create electrical net” and “Allow electrical net creation by components” check boxes in the 
Net Properties dialog box.

• The “Create electrical net” and “Allow electrical net creation by refdes prefix or by nets” check 
boxes in the Component Properties dialog box.

• Refdes prefixes you specify in the Electrical Nets dialog box.

• The “Maximum net count per electrical net” and “Maximum non-plane-net pin count” fields in the 
Electrical Nets dialog box.

Tip
Virtual pins are not included in the net pin count.

The default settings for these check boxes are:

• The “Create electrical net” nets check boxes, which create electrical nets, are cleared by default 
for all nets and components. So by default, no electrical nets created.

• The “Allow electrical net creation...” check boxes, which allow the selected net or component 
to be added to an electrical net by other methods, are selected by default for all nets and 
components. So by default, you create electrical nets by any of the three methods.

• The “Maximum net count per electrical net” default value is 5.

• The “Maximum non-plane-net pin count” default value is 25.

A discrete component and its attached nets become part of an electrical net only if the following 
conditions 1 and 2 are true:

1. You set the component and net properties to meet one of the following conditions:

◦ Component Properties “Create electrical net” is set and neither attached net is excluded from 
electrical net creation. (A component or net is excluded from electrical net creation if you clear 
its “Create electrical net” and “Allow electrical net creation...” check boxes.)

◦ Net Properties “Create electrical net” check box is selected for both nets and the component 
is not excluded from electrical net creation. (A component or net is excluded from electrical 
net creation if you clear its “Create electrical net” and “Allow electrical net creation...” check 
boxes.)
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◦ Component Properties “Allow electrical net creation...” check box is selected and no attached 
net is excluded from electrical net creation. Also the component’s refdes prefix is specified in 
the Electrical Nets dialog box. (A component or net is excluded from electrical net creation if 
you clear its “Create electrical net” and “Allow electrical net creation...” check boxes.)

2. The component, its nets, and the potential electrical net to which it will belong, all conform to the 
General Restrictions and Prerequisites  for creating electrical nets.
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Chapter 11
Set Up Rules

Design rules allow you to exercise precise control over your routing results. A wide range of settings 
let you specify simple clearances between design objects or expand the rules to include complex 
relationships between nets, classes groups, pin pairs, and layers.

Setting Design (Global and Default) Properties
Design Rules
Rules Hierarchy
Design Rules Passed from SailWind Layout
SailWind Layout Design Rules vs. SailWind Router Properties
Pin Pairs and Plane Nets
Same Net Rules
Pad Entry Rules
Topology Restrictions
Fanout Rules
Decal Rules
Error Rules
Clearance Rules
Setting Clearances
Grid Rules
Setting Grids
Setting Layer Biasing Rules
Setting Layer Rules
Setting the Via Types to Use on Specific Layers
Setting Object Properties
Creating Net Classes
Creating Pin Pair Groups
Conditional Rules
Creating Conditional Rules
Creating Matched Length Net Groups
Creating Matched Length Pin Pair Groups
Differential Pairs Rules
Creating Differential Pairs
Assigning the Same Rules to Multiple Differential Pairs
Differential Pair Layer Hierarchy
Setting Differential Pair Properties
Component Rules
Length Rules
Routing Rules
Working with Multiple Object Properties
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Setting Design (Global and Default) Properties
Use the Design Properties dialog box to view and modify the properties of your design when no object is 
selected. The Design Properties dialog box sets global rules properties.

Procedure
1. With nothing selected, click the Properties  button or right-click and click the Properties  popup 

menu item.

2. Click the design properties tab for the properties that you want to modify:

• Clearance  on page 468

• Fanout  on page 163

• Grid  on page 167

• Layer Biasing  on page 168

• Layers  on page 168

• Pad Entry  on page 504

• Routing  on page 189

• Same net  on page 519

• Test Points  on page 521

• Topology  on page 291

• Via Biasing  on page 169

3. Modify the properties on the tab as required.

4. Click another tab to continue setting properties.

5. When you are finished, click OK.

Related Topics
Setting Object Properties

Design Rules
Design rules allow you to assign constraints to your design objects. Assigning constraints allows you to 
control clearances between objects, assign vias to specific layers, control which layers will be used for 
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Rules Hierarchy
routing, set up complex relationships between objects (or groups of objects), and define numerous other 
design constraints.

Hard and Soft Rules
There are two kinds of design rules: hard  and soft. A hard rule is always followed, even if the result is an 
uncompleted route. A soft rule is ignored when it would result in an uncompleted route.

Most rules are permanently either hard or soft; a few rules are switchable—that is, they can be changed 
from hard to soft and back again.

Hard Rule Examples

• All clearance rules

• All via biasing rules

Soft Rule Examples

• Fanout rules

• Routing restrictions on component layers

Switchable Hard/Soft Rule Examples

• Length rules— Hardness/softness is controlled by the “Ignore length rules when required to 
complete traces” check box in the Tune  tab of the Options dialog box.

• Same net first corner rules— Hardness/softness is controlled by the “Ignore first corner rules to 
complete traces when required” check box in the Pad Entry  tab of the Design Properties dialog 
box.

Rules Hierarchy
Certain rules have priority over other rules. For example, a pin pair rule overrides a group rule, and a 
group rule overrides a net rule. This structure is known as the rules hierarchy.

Default rules, at level 1, have the lowest priority and represent the lowest level of the rules hierarchy. 
Electrical Net rules, at level 34, have the highest priority and represent the highest level of the rules 
hierarchy.

1. Default

2. Default with conditional layer rule

3. Class

4. Class with conditional layer rule

5. Net

6. Net with conditional layer rule
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7. Group

8. Group with conditional layer rule

9. Pin Pair

10. Pin Pair with conditional layer rule

11. Class against Class

12. Class against Class with conditional layer rule

13. Net against Class

14. Net against Class with conditional layer rule

15. Net against Net

16. Net against Net with conditional layer rule

17. Group against Class

18. Group against Class with conditional layer rule

19. Group against Net

20. Group against Net with conditional layer rule

21. Group against Group

22. Group against Group with conditional layer rule

23. Pin Pair against Class

24. Pin Pair against Class with conditional layer rule

25. Pin Pair against Net

26. Pin Pair against Net with conditional layer rule

27. Pin Pair against Group

28. Pin Pair against Group with conditional layer rule

29. Pin Pair against Pin Pair
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30. Pin Pair against Pin Pair with conditional layer rule

31. Decal

32. Component

33. Differential Pair

34. Electrical Net

Design Rules Passed from SailWind Layout
SailWind Layout passes most of the design rules in a design to SailWind Router. Upon completion of your 
routing session, SailWind Router passes the rules (and any modifications made to them) seamlessly back 
with the design to SailWind Layout.

With the exception of high-speed rules and rules on pin pairs of plane nets  on page 159, SailWind 
Router uses the same design rules as SailWind Layout (Table 52).

Table  52. SailWind Layout Rules Verified and Maintained in SailWind Router

Rule Maintained by: SailWind 
Layout

Maintained by: SailWind 
Router

Clearance Clearance Yes Yes

Body to body spacing Yes Yes

 Note:
Converted to 
“Minimum spacing 
between components” 
value

Same Net Yes Yes

Trace Width Yes Yes

Routing Length Minimization Yes Yes

Routing Options Yes Yes

Layer Biasing Yes Yes

Via Biasing Yes Yes

High-Speed Parallelism Yes (EDC) No

Shielding No No

High-speed Yes (EDC) No

Length Matching Yes (EDC) Yes
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Table  52. SailWind Layout Rules Verified and Maintained in SailWind Router  (continued)

Rule Maintained by: SailWind 
Layout

Maintained by: SailWind 
Router

Conditional All combinations Yes Yes

Differential Pairs All definitions No Yes

Test Point Probe to Trace Yes Yes

Probe to Pad Yes Yes

Test Point Grid Yes Yes

Assignment Yes Yes

SailWind Layout Design Rules vs. SailWind 
Router Properties
In SailWind Layout, you use Design Rules to assign constraints to your design objects. Such constraints 
include clearances, via assignments, layer assignments, and other complex design object relationships. 
SailWind Router supports most of these same rules; however, SailWind Router refers to them as 
Properties.

This table shows the location of specific Design Rules in SailWind Layout and the corresponding 
Properties location in SailWind Router.

Table  53. Design Rule Mapping between SailWind Layout and SailWind Router

SailWind Layout 
setting

SailWind Layout dialog 
box

SailWind Router 
setting

SailWind Router 
dialog box

Default Rules, 
Clearance Rules

Clearances Design Properties, 
Clearance  tab

Clearances

Default Rules, 
Clearance Rules: Body 
to body

Minimum spacing 
between components

Options, Fabrication 
category

Same Net Clearance Default Rules, 
Clearance Rules

Same Net Clearance Design Properties, 
Same Net  tab

Trace Width Default Rules, 
Clearance Rules

Trace Width Design Properties, 
Routing  tab

Topology Default Rules, Routing 
Rules

Topology Design Properties, 
Topology  tab

Routing Options Default Rules, Routing 
Rules

Route Options Design Properties, 
Routing  tab

Layer Biasing Default Rules, Routing 
Rules

Layer Biasing Design Properties, 
Layer Biasing  tab
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Pin Pairs and Plane Nets

Table  53. Design Rule Mapping between SailWind Layout and SailWind Router  (continued)

SailWind Layout 
setting

SailWind Layout dialog 
box

SailWind Router 
setting

SailWind Router 
dialog box

Vias Default Rules, Routing 
Rules

Via Biasing Design Properties, 
Via Biasing  tab

Maximum Number of 
Vias

Default Rules, Routing 
Rules

Maximum Number of 
Vias

Design Properties, 
Routing  tab

Test Point Audit DFT Audit, Properties Test Points Design Properties, 
Test Points  tab

Test Point Assignment DFT Audit, Assignment 
tab

Test Point Assignment Component 
Properties, Test 
Points  tab
Project Explorer, Via 
Type Properties, Test 
Points  tab

No Equivalent Layers Design Properties, 
Layers  tab

Grid Grids and Snap Options, 
Grids  tab

Grid Design Properties, 
Grid  tab

Pin Pairs and Plane Nets
SailWind Router does not allow Pin Pair rules or Pin Pair Group rules defined for Plane nets. These rules 
affect SailWind Router performance as they present a technically complex scenario.

If plane net pin pairs are assigned in SailWind Layout they are removed after the design is opened in 
SailWind Router. You cannot assign these rules in SailWind Router. In either case the following messages 
appear in the Output window:

• For plane net pin pair rules  — “Pin Pair rules cannot be assigned in plane nets.”

• For plane net pin pairs in a group  — “Pin Pairs cannot be included to Group in plane nets.”

For non-plane nets, the limit can be controlled in the SailWindRouter.ini  file by the following:

[General]
NonPowerNetMaxPinCount=50
 

With this setting, if a net has more than 50 pins, SailWind Router considers it to be a large net and does 
not support pin pair rules for it.

Same Net Rules
Same net rules specify the minimum spacing between items in a net.

SailWind Router Guide 159



Set Up Rules
Same Net Rules  

Some same net rules are permanently hard; you can make others hard or soft, using the “Ignore first 
corner rules to complete traces when required” check box in the Pad Entry  tab of the Design Properties 
dialog box. Table 54  and Figure 16  show the different rule types for items in the same net.

Table  54. Edge-to-edge Clearance Values that Apply to Items in the Same Net

Clearance rule Rule type Description

Pad-to-Corner Switchable hard/soft Minimum spacing between a non-SMD pad and 
the first trace bend point.

SMD-to-Corner Switchable hard/soft Minimum spacing between a surface mount pad 
and the first trace bend point.

SMD-to-Via Hard Minimum spacing between a surface mount pad 
and a via.

Trace-to-Corner Switchable hard/soft Minimum spacing between a segment and the 
bend point of an adjacent trace segment; for 
example, when a trace splits at a T-junction 
and one of the two traces has a bend point. 
Trace-to-corner also serves as a trace-to-trace 
rule.
The trace-to-corner rule is used for routing only 
and is not checked by design verification.

Via-to-Via Hard Minimum spacing between vias.

Figure 16. Same Net Rules

First Corner Rules
First corner rules determine how clearances are enforced on traces as they exit a pad or via.

There are three first corner rules:
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• Pad-to-corner(for through pins and vias),

• Trace-to-corner,

• SMD-to-corner

Pad-to-corner and SMD-to-corner rules prevent corners from being added to traces that enter or exit a 
pad at less than the minimum corner rules. The pad-to-corner or SMD-to-corner rules also prevent the 
trace from getting too close to the pad after the first corner is added. Figures Figure 17  and Figure 18 
show the first corner rules in SailWind Layout and SailWind Router.

Figure 17. First Corner Rule in SailWind Layout

Figure 18. First Corner Rule in SailWind Router

Trace-to-Corner Rule

The trace-to-corner rule is similar to the pad-to-corner rule and also serves as a trace-to-trace rule. During 
autorouting, SailWind Router violates this rule only to avoid an incomplete trace. You can repair such 
violations during Smooth or Optimize passes.

The software uses the trace-to-corner rule (Figure 19) for routing only; it does not check this rule during 
design verification.

Tip
For best results, include an Optimize pass each time you autoroute.
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Figure 19. Trace-to-Corner Rule

Pad Entry Rules
Pad entry is the point at which a trace entering or exiting a pin first crosses the edge of a pad. You can 
define the rules for pad entry in the design properties setup.

The quality of a pad entry is measured by the angle of the pad entry. A perfect pad entry has pad angles 
equal to, or greater than, 90 degrees. Figure 20  shows an unsatisfactory pad entry; the lower pad entry 
angle is greater than 90 degrees, but the upper pad entry angle is less than 90 degrees.

Figure 20. Unsatisfactory Pad Entry

Perfect pad entry is attempted on all traces entering pins and vias regardless of the pad shape. The pad 
entry controls let you choose pad exit types (any angle, side, or corner) and soft corner rules. For more 
information, see “Hard and Soft Rules”  on page 155.

SailWind Router uses different pad entries as required to complete traces (Figure 21). The software 
achieves best results when all pad entry types, including soft first corner rules, are permitted. The 
software makes poor or unsatisfactory pad entries only for the sake of trace completion.
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Topology Restrictions

Figure 21. Pad Entry Types

To maintain pin pair rules, SailWind Router does not share a pad entry or exit on nets with pin pair rules.

Topology Restrictions
Topology rules allow you to specify the net topology type and whether you want to allow multiple 
connections to vias and traces in your design.

Set topology rules from the Topology  tab of the properties setup dialog box. The following restrictions 
apply:

• The “Allow junctions on” settings are unavailable for all topology types except Minimized.

• The “Maximum stub length” setting is unavailable for the Minimized topology type.

Fanout Rules
Fanout rules specify the fanout type, via placement, and the multiple connection option for pins, SMDs, 
vias, and traces. You can give fanouts unlimited length, or you can specify a maximum length. Fanout 
rules are soft rules, meaning SailWind Router ignores them in circumstances where following them would 
result in one or more uncompleted routes.

Decal Rules
Decal rules specify routing, pad entry, same net, fanout, via biasing, and clearance rules for all 
components that use a particular decal.

Error Rules
Error rules specify whether to ignore an error during verification operations.

Clearance Rules
Clearance rules specify the minimum allowable air gap between object types in the design.
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Object types supported include:

• Traces

• Vias

• Through-hole pads

• Surface mount (SMD) pads

• Copper

• Drill holes

• Text

• Board

Other Clearance Rules
Additional clearances rules maintain clearances between component bodies and drill holes.

Table 55  summarizes other clearance rules.

Table  55. Other Clearance Rules Included

Rule Description

Minimum spacing between components The distance between the centerlines of the lines used 
to define the placement outline of each component. 
This includes auto-generated placement outlines 
and outlines derived from SailWind Layout Layer 20 
placement outlines.

 Note:
When a design is opened, this value populates 
with the “Body to body” Clearance Design Rule 
value from SailWind Layout.

Minimum spacing between holes Minimum edge-to-edge spacing between two drill 
holes

The rules in Table 55  appear on the Fabrication  tab of the Options dialog box.

Setting Clearances
View and modify minimum spacing clearances using the Clearance  tab of the properties setup dialog 
box.

If you selected an object, you are setting the clearance properties for that object. If you selected nothing, 
you are setting clearance properties for the entire design.
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Grid Rules

Procedure
1. Right-click and click the Properties  menu item; then click the Clearance  tab.

2. Type the clearance value in the box for the clearance to allow between the object listed in the row 
heading and the object listed in the column heading.

Tip
To set the same value for an entire row or column, click on a column heading, row heading, 
or All. Type a value and click OK to apply the value.

3. Click OK.

Related Topics
Setting Design (Global and Default) Properties

Properties Dialog Box, Same Net Tab

Creating Conditional Rules

Grid Rules
SailWind Router provides you with a number of different grid types to assist you during the placement, 
routing, and test point stages of your design.

SailWind Router uses the following five routing grids:

• Test point

• Via

• Fanout

• Component

• Routing

SailWind Router has two additional grids, the Displayed and Copper Hatch grids, which it does not use 
during routing.

Set the routing grid using Snap to Grid on the Grid  tab of the Design Properties dialog box. If you clear 
the Snap to Grid check box, grid settings are ignored.

The routing grid establishes the default routing grid for routing tasks other than components, test points, 
vias, and vias added during fanout operations (Figure 22).
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Figure 22. Default Routing Grid

A trace corner is on-grid if at least one of its coordinates is on the grid. A trace segment is on-grid if both 
of its end points are on the grid in the same plane. Figure 23  shows the routing grid for trace corners and 
trace segments.

Figure 23. Routing Grid for Traces

The rule to maintain on-grid trace corners is soft. If a trace corner cannot be placed on-grid, the corner is 
placed off-grid to complete the trace.

Grid Statistics Report
You can create a grid statistics report in the Output window to report on pins, vias, and trace segments 
that are on or off the grids.

You must select the Snap Objects to Grid check box for the Routing  on page 491grid before you create 
the grid statistics report. This is required to generate the Off-grid statistics in the report and to show the 
markers in the design on the locations of all the pins, vias, or trace segment endpoints that are off-grid 
according to the Hard/Soft rules. Markers disappear when the screen is redrawn.

Figure 24. Grid Statistics Off-Grid Marker

The Grid Statistics reports are run using the following Shortcut (Modeless) commands.

• GGS— Soft grid statistics: Trace segments are considered on-grid if one of the endpoints has 
one of either the X and Y coordinates on the Routing grid.

• GGM— Medium grid statistics.
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• GGH— Hard grid statistics: Trace segments are considered on-grid if one of the endpoints has 
both X and Y coordinates on the Routing grid.

Tip
The Snap value in the report always displays “Off” when the grid is set to 00000_00000 
regardless of the Snap Objects to Grid setting.

Sample Report

This is a sample of a Soft grid statistics report.

______Total_____On grid___Off grid___Snap_____Soft_Grid
Pin___00206__|___00030__|__00176___|__On___|_00050_00050
Via___00072__|___00000__|__00072___|__Off__|_00000_00000
Trace_00587__|___00151__|__00436___|__On___|_00050_00050 

Setting Grids
Use the Grid  tab to view and modify all grid settings in your design.

Set a grid to restrict placement of the routing objects to specific increments. The following table lists 
objects and their grid placement.

Table  56. Objects and Grid Placement

Object Is placed on this grid

Trace corners Routing

Vias, via pairs Via

Test points Test Points

A trace segment is considered “on grid” if at least one of its coordinates (X or Y) is on the grid. You do not 
have to place both coordinates on the grid.

If you select the Snap Objects to Grid box for a grid, then pointer movements snap to the grid. This 
prevents you from placing objects between grid points. For more information, see “Grid Rules”  on 
page 165.

Procedure
1. Open the Design Properties grid by right-clicking in the workspace (with nothing selected) and 

choosing the Properties  popup menu item.

2. Click the Grid  tab. In the grid settings table, type the value in each box to which you want to set the 
grid line spacing.

3. Select the “Snap Objects to Grid” check box to enable snap. Clear the check box to disable snap.

4. Click OK.
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Related Topics
Setting Design (Global and Default) Properties

Design Rules

Setting Layer Biasing Rules
Layer biasing rules specify whether SailWind Router can use a particular layer while routing.

Use the Layer Biasing  tab to restrict layers available for nets and pin pairs to certain layers for routing. 
Layer biasing provides an additional level of control over routing on layers.

For example: You want to route power and ground nets only on outer layers, and force the routing of other 
nets on internal layers. To accomplish this, with nothing selected, enable outer layers for routing in the 
general design properties, but disable outer layers in the Layer Biasing  tab. Then, in the Net Properties 
dialog box for the power and ground nets, enable the outer layers for routing in the Layer Biasing  tab.

If you selected an object, you are setting layer biasing properties for that object. If you selected nothing, 
you are setting layer biasing properties for the entire design.

Procedure
1. Right-click and click the Properties  popup menu item; then, in the properties dialog box, click the 

Layer Biasing  tab.

2. Select the Allow Routing check box to enable routing on a layer. Clear the check box to disable it.

3. Click OK.

Related Topics
Setting Design (Global and Default) Properties

Setting Layer Rules
Layer rules specify routing parameters for the specified layer. Only electrical layers display.

Use the Layers  tab to set routing parameters for a specific layer.

Procedure
1. With nothing selected in the workspace, right-click and click the Properties  popup menu item; 

then, in the properties dialog box, click the Layers  tab.

2. In the “Routing parameters for layers” area, select the Route check box to enable a layer for 
routing. Clear the check box to disable it.

3. Click in the Direction column for the layer and select the routing direction you want from the list.

4. Click in the Cost column for the layer and type a number 0 and 100 for the cost value.

The cost value specifies the level of usage for the layer during routing. A higher number specifies 
less  use of the layer.
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5. Click OK.

Restriction:
The Type column, which displays the layer type, can only be changed in SailWind Layout.

Related Topics
Setting Design (Global and Default) Properties

Setting the Via Types to Use on Specific 
Layers
Via biasing rules specify whether SailWind Router can use a particular via type while routing.

Use the Via Biasing  tab of the Properties dialog box to restrict the via types that SailWind Router uses 
while routing.

Restrictions and Limitations

• You cannot change the size of vias or add additional vias in SailWind Router. To change the 
size of a via or create new vias, open the design in SailWind Layout and use the Pad Stacks 
Properties dialog box  in SailWind Layout.

If you selected an object, you are setting via biasing properties for that object. If you selected nothing, you 
are setting via biasing properties for the entire design.

Procedure
1. Right-click and click the Properties  popup menu item; then, in Properties dialog box, click the Via 

Biasing  tab.

2. Select the Allow check box to enable SailWind Router to use the via for routing. Clear the check 
box to disable use of the via.

3. Click OK.

Related Topics
Setting Design (Global and Default) Properties

Setting Object Properties
Object properties allow you to specify design rules for all of the objects in your design. You can also 
construct complex relationships between groups of objects to accommodate your most demanding design 
constraints.
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Tip
The Changed Properties icon appears on the tab if the design properties differ from the properties 
of the selected object. The differing fields appear with a yellow background.

Procedure
1. Select an object then right-click and click the Properties  popup menu item.

The properties that appear in the resulting dialog box depend on the selected object. Properties set 
in this way affect the selected object only and not global settings. Table 57  lists the available tabs 
for each object type.

Table  57. Property Dialog Box — Available Tabs for Object Types

Object Available tabs

Component • Clearance  on page 468

• Component  on page 469

• Fanout  on page 486

• Pad Entry  on page 504

• Routing  on page 517

• Same Net  on page 519

• Test Points  on page 523

• Via Biasing  on page 532

Conditional rule • Clearance  on page 468

Copper Plane • Copper Plane  on page 475

• Flooding  on page 489

Part decal • Clearance  on page 468

• Component  on page 469

• Fanout  on page 486

• Pad Entry  on page 504

• Routing  on page 517

• Same Net  on page 519

• Via Biasing  on page 532

Differential pair • “Pair”  on page 184

Error • Error  on page 366

Keepout • Keepout  on page 495

Matched length group • Group  on page 493
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Object Available tabs

Net • Clearance  on page 468

• Layer Biasing  on page 497

• Length  on page 501

• Net  on page 502

• Routing  on page 517

• Same Net  on page 519

• Test Points  on page 521

• Topology  on page 524

• Via Biasing  on page 532

Net class • Clearance  on page 468

• Layer Biasing  on page 497

• Length  on page 501

• Routing  on page 517

• Same Net  on page 519

• Topology  on page 524

• Via Biasing  on page 532

Pin • Component  on page 469

• Drill  on page 480

• Pad Stack  on page 506

• Pin  on page 513

Pin pair • Clearance  on page 468

• Layer Biasing  on page 497

• Length  on page 501

• Routing  on page 517

• Via Biasing  on page 532

Pin pair group • Clearance  on page 468

• Layer Biasing  on page 497

• Length  on page 501

• Routing  on page 517

• Via Biasing  on page 532

Text • No properties  on page 169

Trace • Trace  on page 526

Trace corner • Trace Corner  on page 479
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Object Available tabs

Trace segment (path, or partial selection) • Trace Segment  on page 528

Unroute (connection) • No properties  on page 169

Via • Via  on page 530

• Pad Stack  on page 508

• Drill  on page 482

Via type • Pad Stack  on page 508

• Drill  on page 482

• Test Points  on page 523

Some selected objects may not have properties. For example, an unroute. In this case the 
message “No properties available” appears. If multiple object types are selected, the message 
“Multiple selection” appears.

2. Click a tab and make modifications as appropriate.

3. To clear the current rules for the selected object, click the Delete Level  button. The next rules level 
in the hierarchy is applied to the object. The object's hierarchy level appears in the Rule level box.

Tip
The Delete Level  button is unavailable if design rules are used.

4. Click OK.

Related Topics
Setting Design (Global and Default) Properties

Working with Multiple Object Properties

Set Up Rules

Creating Net Classes
Create net classes and assign Properties (Rules) by selecting nets in the Project Explorer and/or in the 
design workspace.
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Video

Procedure
1. Use one of the following methods, or a combination, to select the nets for the net class:

• Using the Project Explorer— Use the list of net names in the Project Explorer to select the 
nets.

Tip
You might find it useful to split the Project Explorer  on page 52 for tasks like this.

i. In the Project Explorer, expand the Net Objects list and then expand the Nets list.

ii. In the list of nets, select one or more nets to add to the net class. You can add more nets to 
the class later or delete nets from the class if needed.

iii. Right-click and click Copy, or drag your selection from the list of nets and then right-click 
and click Paste, or drop them on the Net Classes list.

• Using the Workspace— Use the pointer to select nets in your design.

i. In the design, select one or more nets to add to the net class. You can add more nets to the 
class later or delete nets from the class if needed.

ii. Right-click and click the Make Class  popup menu item.

2. In the Project Explorer, expand the Net Objects list and then expand the Net Classes list. The Net 
Classes list expands to reveal a new Class<n>, for example, Class1.

3. Rename the class if desired to make the name more significant.

a. Click to select the new class.

b. Click the text name of the selected class. The text is selected for renaming.

c. Rename the class and press the Enter key.

4. Right-click in the Project Explorer and make sure the Allow Selection setting is checked. Selecting 
the class in the Project Explorer also needs to simultaneously select the nets in the design area in 
order to open the Properties of the new class.
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5. Place the pointer over the new class name, right-click and click the Properties  popup menu item.

6. In the Net Class Properties dialog box, set unique properties for the class. For each tab in the 
dialog box, you can click the Help  button to get details for each setting.

Creating Pin Pair Groups
Create groups of pin pairs and assign Properties (Rules) by selecting pin pairs in the Project Explorer 
and/or in the design workspace.

Restrictions and Limitations
Plane nets cannot be added to Pin Pair Groups. For more information, see “Pin Pairs and Plane Nets.”

Procedure
1. Use one of the following methods, or a combination, to select the pin pairs for the pin pair group:

• Using the Project Explorer— Use the lists of pin pairs of nets in the Project Explorer to select 
the pin pairs.

Tip
You might find it useful to split the Project Explorer  on page 52 for tasks like this.

i. In the Project Explorer, expand the Net Objects list and then expand the Nets list. You must 
expand an individual net to view the pin pairs of the net.

ii. Select one or more pin pairs to add to the pin pair group. You can add more pin pairs to the 
group later or delete pin pairs from the group if needed.

iii. Right-click and click the Copy  popup menu item, or drag your selection from the lists of pin 
pairs and then right-click and click the Paste  popup menu item. You can also drop them on 
the Pin Pair Groups list.

• Using the Workspace— Use the pointer to select pin pairs in your design.

i. In the design, select one or more pin pairs to add to the pin pair group. You can add more 
pin pairs to the group later or delete pin pairs from the group if needed.

ii. Right-click and click the Make Pin Pair Group  popup menu item.

2. In the Project Explorer, expand the Net Objects list and then expand the Pin Pair Groups list. Pin 
Pair Groups expands to reveal a new Group<n>, for example, Group1.

3. Rename the group if desired to make the name more significant.

a. Click to select the new group.

b. Click the text name of the selected group. The text is selected for renaming.

c. Rename the group and press Enter.
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4. Right-click in the Project Explorer and make sure the Allow Selection setting is checked. Selecting 
the group in the Project Explorer also needs to select the pin pairs in the design area in order to 
open the Properties of the new group.

5. Place the pointer over the new group name, right-click and click the Properties  popup menu item.

6. In the Pin Pair Group Properties dialog box, set unique properties for the group. For each tab in the 
dialog box, you can click the Help  button to get details for each setting.

Conditional Rules
Conditional rules extend basic rule assignments and provide more control over complex designs. For 
example, you could set a conditional rule for a net, which comes into effect only if the net is adjacent to 
a specific net. Conditional rules have some additional restrictions, which make them different from other 
rules.

Conditional rule names are not user-definable. An automatic naming process is used for conditional rules. 
For more information, see Table 59  on page 178.

You must specify a set of objects before you can create a conditional rule.

The following lists the conditional rules that you can create and describes how to create them.

• Default clearance and trace width rules on a specific layer  — Copy or drag the specific 
electrical layer and paste or drop it on Conditional Rules in the Project Explorer.

• Class clearance and trace width rules on a specific layer  — Copy or drag the net class and 
specific electrical layer and paste or drop them on Conditional Rules in the Project Explorer.

• Net clearance and trace width rules on a specific layer  — Copy or drag the net and specific 
electrical layer and paste or drop them on Conditional Rules in the Project Explorer.

• Group clearance and trace width rules on a specific layer  — Copy or drag the pin pair group 
and specific electrical layer and paste or drop them on Conditional Rules in the Project Explorer.

• Pin Pair clearance and trace width rules on a specific layer  — Copy or drag the pin pair and 
specific electrical layer and paste or drop them on Conditional Rules in the Project Explorer.

• Class against Class rules  — Copy or drag the two net classes and paste or drop them on 
Conditional Rules in the Project Explorer.

• Class against Class rules on a specific layer  — Copy or drag the two net classes and specific 
electrical layer and paste or drop them on Conditional Rules in the Project Explorer.

• Net against Class rules  — Copy or drag the net and net class and paste or drop them on 
Conditional Rules in the Project Explorer.

• Net against Class rules on a specific layer  — Copy or drag the net, net class, and specific 
electrical layer and paste or drop them on Conditional Rules in the Project Explorer.

• Net against Net rules  — Copy or drag the two nets and paste or drop them on Conditional Rules 
in the Project Explorer.
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• Net against Net rules on a specific layer  — Copy or drag the two nets, and specific electrical 
layer and paste or drop them on Conditional Rules in the Project Explorer.

• Group against Class rules  — Copy or drag the pin pair group and net class and paste or drop 
them on Conditional Rules in the Project Explorer.

• Group against Class rules on a specific layer  — Copy or drag the pin pair group, net class, 
and specific electrical layer, and paste or drop them on Conditional Rules in the Project Explorer.

• Group against Net rules  — Copy or drag the pin pair group and net and paste or drop them on 
Conditional Rules in the Project Explorer.

• Group against Net rules on a specific layer  — Copy or drag the pin pair group, net, and 
specific electrical layer, and paste or drop them on Conditional Rules in the Project Explorer.

• Group against Group rules  — Copy or drag the two pin pair groups and paste or drop them on 
Conditional Rules in the Project Explorer.

• Group against Group rules on a specific layer  — Copy or drag the two pin pair groups, and 
specific electrical layer, and paste or drop them on Conditional Rules in the Project Explorer.

• Pin Pair against Class rules  — Copy or drag the pin pair and net class and paste or drop them 
on Conditional Rules in the Project Explorer.

• Pin Pair against Class rules on a specific layer  — Copy or drag the pin pair, net class, and 
specific electrical layer, and paste or drop them on Conditional Rules in the Project Explorer.

• Pin Pair against Net rules  — Copy or drag the pin pair and net and paste or drop them on 
Conditional Rules in the Project Explorer.

• Pin Pair against Net rules on a specific layer  — Copy or drag the pin pair, net, and specific 
electrical layer, and paste or drop them on Conditional Rules in the Project Explorer.

• Pin Pair against Group rules  — Copy or drag the pin pair and pin pair group and paste or drop 
them on Conditional Rules in the Project Explorer.

• Pin Pair against Group rules on a specific layer  — Copy or drag the pin pair, pin pair group, 
and specific electrical layer and paste or drop them on Conditional Rules in the Project Explorer.

• Pin Pair against Pin Pair rules  — Copy or drag the two pin pairs and paste or drop them on 
Conditional Rules in the Project Explorer.

• Pin Pair against Pin Pair rules on a specific layer  — Copy or drag the two pin pairs, and 
specific electrical layer and paste or drop them on Conditional Rules in the Project Explorer.

Conditional Rules Objects
You can create conditional rules using drag and drop or copy and paste operations in the project explorer. 
You must first select the objects that you want included in the conditional rule.
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Table  58. Objects You Can Add to the Conditional Rule Group to Create a New Rule

First 
Object

Second 
Object

Third 
Object Resulting Rule Automatic Naming Example

Layer All: All (Layer) All: All (Top)

Layer Class Class: All (Layer) CLS1: All (Bottom)

Layer Net Net: All (Layer) +5V: All (Bottom)

Layer Group Group: All (Layer) GRP1: All (Bottom)

Layer Pin Pair Pin Pair: All (Layer) R1.1-U1.2: All (Bottom)

Class Class Class: Class (All Layers) CLS1: CLS2 (All Layers)

Class Class Layer Class: Class (Layer) CLS1: CLS2 (Top)

Class Net Class: Net (All Layers) CLS1: +5V (All Layers)

Class Net Layer Class: Net (Layer) CLS1: +5V (Top)

Class Group Class: Group (All Layers) CLS1: GRP1 (All Layers)

Class Group Layer Class: Group (Layer) CLS1: GRP1 (Top)

Class Pin Pair Class: Pin Pair (All Layers) CLS1: R1.1-U1.1 (All Layers)

Class Pin Pair Layer Class: Pin Pair (All Layers) CLS1: R1.1-U1.1 (Top)

Net Net Net: (All Layers) GND: +5V (All Layers)

Net Net Layer Net: (Layer) GND: +5V (Top)

Net Group Net: Group (All Layers) GND: GRP1 (All Layers)

Net Group Layer Net: Group (Layer) GND: GRP1 (Top)

Net Pin Pair Net: Pin Pair (All Layers) GND: R1.1-U1.1 (All Layers)

Net Pin Pair Layer Net: Pin Pair (All Layers) GND: R1.1-U1.1 (Top)

Group Group Group: Group (All Layers) GND: GRP1 (All Layers)

Group Group Layer Group: Group (Layer) GND: GRP1 (Top)

Group Pin Pair Group: Pin Pair (All Layers) GRP1: R1.1-U1.1 (All Layers)

Group Pin Pair Layer Group: Pin Pair (All Layers) GRP1: R1.1-U1.1 (Top)

Pin Pair Pin Pair Pin Pair: Pin Pair (All Layers) R2.1-R3.1: R1.1-U1.1 (All 
Layers)

Pin Pair Pin Pair Layer Pin Pair: Pin Pair (All Layers) R2.1-R3.1: R1.1-U1.1 (Top)
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Conditional Rules Automatic Naming
Because you cannot define names for conditional rules, automatic naming differentiates one rule from 
another.

As shown in Table 59, automatic names consist of the names of objects in the rule and the name of the 
layer for which the rule applies. Automatic names appear both in the Object View  tab and in the captions 
of the Properties dialog box for the conditional rule.

Table  59. Automatic Conditional Rule Naming

Rule Automatic Name

Net +5V against Net GND on Layer Top +5V : GND (Top)

All Objects against All Objects on Layer Bottom All : All (Bottom)

Net Class GROUND against Pin Pair R1.1 - U10.2 on 
all layers

GROUND : R1.1-U10.2 (All Layers)

Conditional Rule Objects Modification

You cannot modify the objects assigned to a conditional rule. You must delete conditional rules 
completely, and then recreate the conditional rule for the new set of objects.

Creating Conditional Rules
Create conditional groups Properties (Rules) by selecting items in the Project Explorer and copying them 
to Conditional Rules.

Procedure
1. In the Project Explorer, select the items you need to make up the conditional rule. For specific 

information, see “Conditional Rules”  on page 175.

Tip
You might find it useful to split the Project Explorer  on page 52 for tasks like this.

2. Right-click and click copy, or drag your selection and then right-click and click Paste, or drop it on 
Conditional Rules. You cannot change the objects assigned to a conditional rule; you must delete 
the conditional rule, and then recreate the conditional rule for the new set of objects.

3. In the Project Explorer, expand Net Objects  and then expand Conditional Rules.

4. Conditional Rules expands to reveal a new condition in the format of Source:Against (Layer), for 
example, +12V:+5V (Top Layer).

5. Place the pointer over the new conditional rule, right-click and click the Properties  popup menu 
item.

6. In the Conditional rule dialog box, set unique properties for the condition.
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Related Topics
Setting Clearances

Creating Matched Length Net Groups
Create matched length net groups and assign Properties (Rules) by selecting nets in the Project Explorer 
and/or in the design workspace.

Procedure
1. Use one of the following methods, or a combination, to select the nets for the matched length net 

group:

• Using the Project Explorer— Select from the list of nets in the Project Explorer.

Tip
You might find it useful to split the Project Explorer  on page 52 for this task.

i. In the Project Explorer, expand the Net Objects list and then expand the Nets list.

ii. In the list of nets, select one or more nets to add to the matched length net group. You can 
add more nets to the group later or delete nets from it if needed.

iii. Right-click and click the Copy  popup menu item, or drag your selection from the list of nets 
and then right-click and click the Paste  popup menu item, or drop them onto the Matched 
Length Net Groups list.

• Using the Workspace— Use the pointer to select nets in your design.

i. In the design, select one or more nets to add to the matched length net group. You can add 
more nets to the group later or delete nets from the group if needed.

ii. Right-click and click the Make Matched Length Net Groups  popup menu item.

2. In the Project Explorer, expand the Net Objects list and then expand the Matched Length Net 
Groups list. Matched Length Net Groups expands to reveal a new MLNetGroup<n>, for example, 
MLNetGroup1.

3. Rename the group if desired to make the name more significant.

a. Click to select the new group.

b. Click the text name of the selected group. The text is selected for renaming.

c. Rename the group and press Enter.

4. Right-click in the Project Explorer and make sure the Allow Selection setting is checked. Selecting 
the group in the Project Explorer also needs to select the nets in the design area to open the 
properties of the new group.
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5. Place the pointer over the new group name, right-click and click the Properties  popup menu item.

6. In the Matched Length Group Properties dialog box, set unique properties for the group:

a. Type a value in the Tolerance box to set the difference between the shortest member and 
longest member of the group.

b. Select the “Restrict length” check box to restrict the length of the group. Unlike SailWind 
Layout, this program counts overlapping trace segments in the trace length calculation.

i. Type the minimum value in the Minimum length box.

ii. Type the maximum value in the Maximum length box.

7. Click OK.

Related Topics
Monitoring Trace Length

Creating Matched Length Pin Pair Groups
Create matched length pin pair groups and assign Properties (Rules) by selecting pin pairs in the Project 
Explorer and/or in the design workspace.

Procedure
1. Use one of the following methods, or a combination, to select the pin pairs for the matched length 

pin pair group:

• Using the Project Explorer—Use the lists of pin pairs of nets in the Project Explorer to select 
the pin pairs.

Tip
You might find it useful to split the Project Explorer  on page 52 for tasks like this.

i. In the Project Explorer, expand the Net Objects list and then expand the Nets list. You must 
expand an individual net to view the pin pairs of the net.

ii. Select one or more pin pairs to add to the matched length pin pair group. You can add more 
pin pairs to the group later or delete pin pairs from the group if needed.

iii. Right-click and click Copy, or drag your selection from the lists of pin pairs and then right-
click and click Paste, or drop them onto the Matched Length Pin Pair Groups list.

• Using the Workspace—Use the pointer to select pin pairs in your design.

180 SailWind Router Guide



 
Set Up Rules

Differential Pairs Rules

i. In the design, select one or more pin pairs to add to the matched length pin pair group. You 
can add more pin pairs to the group later or delete pin pairs from the group if needed.

ii. Right-click and click Make Matched Length Pin Pair Group.

2. In the Project Explorer, expand the Net Objects list and then expand the Matched Length Pin Pair 
Groups list. Matched Length Pin Pair Groups expands to reveal a new MLPinPairGroup<n>, for 
example, MLPinPairGroup1.

3. Rename the group if desired to make the name more significant.

a. Click to select the new group.

b. Click the text name of the selected group. The text is selected for renaming.

c. Rename the group and press Enter.

4. Right-click in the Project Explorer and make sure the Allow Selection setting is checked. Selecting 
a pin pair group in the Project Explorer must also select the pin pairs in the design area to open the 
properties of the new group.

5. Place the pointer over the new group name, right-click and click Properties.

6. In the Matched Length Group Properties dialog box, set unique properties for the group.

a. To set the difference between the shortest member and longest member of the group, type a 
value in the Tolerance box.

b. Select the “Restrict length” check box to restrict the length of the group. Unlike SailWind 
Layout, this program counts overlapping trace segments in the trace length calculation.

i. Type the minimum value in the Minimum length box.

ii. Type the maximum value in the Maximum length box.

7. Click OK.

Related Topics
Monitoring Trace Length

Differential Pairs Rules
Differential pair rules assign length, gap parameters, and obstacle handling to selected pairs of nets, 
electrical nets, or pin pairs. When setting up your design rules, you can pair two nets or two pin pairs and 
define rules related to the pair. If desired, you can use differential pair rules to also restrict a layer change.

Creating Differential Pairs
Create Differential Pairs of nets or pin pairs and assign Properties (Rules) by selecting nets or pin pairs in 
the Project Explorer and/or in the design workspace.
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Procedure
1. Use one of the following methods, or a combination, to select the nets or pin pairs for the matched 

length pin pair group:

• Using the Project Explorer  — Use the nets or lists of pin pairs of nets in the Project Explorer 
to select the pin pairs.

Tip
You might find it useful to split the Project Explorer  on page 52 for tasks like this.

i. In the Project Explorer, expand the Net Objects list and then expand the Nets list. Expand 
an individual net to view its pin pairs.

ii. Select either two nets or two pin pairs to add to the differential pair.

iii. Right-click and click the Copy  popup menu item, or drag your selection from the list of nets 
or lists of pin pairs and then right-click and click the Paste  popup menu item, or drop them 
onto the Differential Pairs list.

• Using the Workspace  — Use the pointer to select nets or pin pairs in your design.

i. In the design, select two nets or two pin pairs to make up the differential pair.

ii. Right-click and click the Make Differential Net  or the Make Differential Pin Pair  popup 
menu item.

2. In the Project Explorer, expand  the Net Objects list and then expand the Differential Pairs list. 
The Differential Pairs list expands to reveal a new Net<->Net or Pin Pair<->Pin Pair. For example, 
CLK1<->CLK2.

3. Right-click in the Project Explorer and make sure the Allow Selection setting is checked. Selecting 
a differential pair in the Project Explorer must also select the nets or pin pairs in the design area to 
open the properties of the differential pair.

4. Place the pointer over the new differential pair, right-click and click the Properties  popup menu 
item.

5. In the “Differential Pair Properties Dialog Box, Pair Tab”  on page 511, set unique properties for 
the pair. For specific instructions, see “Setting Differential Pair Properties”  on page 184.

6. Click OK.

Related Topics
Differential Pair Layer Hierarchy
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Assigning the Same Rules to Multiple 
Differential Pairs
Set the Properties (rules) of multiple pin pairs at the same time.

Procedure
1. In the Project Explorer, expand the Net Objects list and then expand the Differential Pairs list.

2. Right-click in the Project Explorer and make sure the Allow Selection setting is checked. Selecting 
differential pairs in the Project Explorer must also select the nets or pin pairs in the design area to 
open the properties of the differential pair.

3. Use Shift or Ctrl to select multiple differential pairs.

4. Place the pointer over one of the differential pairs, right-click and click Properties.

5. In the “Differential Pair Properties Dialog Box, Pair Tab”  on page 511, set unique properties for 
the pair. For specific instructions, see “Setting Differential Pair Properties”  on page 184.

Some existing settings may be unique to individual differential pairs. If some values appear blank, 
it is because the values are different between the various differential pairs. If you leave the value 
blank, the original unique value will be retained for each differential pair. If you overwrite the value, 
then all differential pairs inherit that value.

The <All Layers> is always displayed as a grayed text. However, if a specific layer appears in the 
list, but it displays with grayed text, it indicates that some differential pairs call out that specific layer 
while others do not.

A check box that is neither selected nor cleared but shows a filled blue square indicates that some 
differential pairs have the box checked and others do not. Leaving the check box in this filled blue 
state retains the unique settings on the Differential Pairs. Clearing or selecting the check box 
disables or assigns that state to all the selected differential pairs.

6. Click OK.

Related Topics
Creating Differential Pairs

Differential Pair Layer Hierarchy
You can assign differential pair width and gap values to layers and categories of layers; however, a layer 
may also fall into one or more categories.

For example, Layer 2 may also be a plane layer, and an outer layer. Therefore, the following hierarchy is 
followed to define which layer settings take priority:

1. All Layers

2. Plane Layers

3. Outer Layers
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4. Inner Layers

5. Individual Layers

Tip
Individual Layers has highest priority.

Setting Differential Pair Properties
Use the Pair  tab of the Differential Pair Properties dialog box to set the gap, trace width, length, and 
obstacle handling for differential pairs.

You can set different properties for differential pairs, which affects their routing, whether you are routing 
interactively, autorouting, or editing traces. Differential pair properties determine the gap between the 
traces in the controlled gap area, the minimum and maximum trace lengths and widths, and obstacle 
behavior in the controlled gap area.

Figure 25. Controlled Gap Area

Tip
When creating differential pairs, the following should be noted:
• SailWind Router routes differential pairs using the default trace width value from the Differential 

Pair Properties dialog box.
• Setting the differential pair width and gap per layer allows you to better control impedance.

Procedure
1. Select a differential pair then right-click and click the Properties  popup menu item; then click the 

Pair  tab.

2. In the “Set trace width and gap for the pair by layer” area, type Width and Gap values in the <All 
layers> row.

Restriction:
You cannot delete the <All layers> row.

3. To set the width and gap per layer, click Add, click in the Layer cell in the newly added row, 
and select the layer for which to set width and gap values. Then type Width and Gap values in 
the appropriate cells. The gap rule overrides any other rule defining a clearance between the 
differential pair members. Therefore, the gap is the minimal clearance and must be provided when 
possible.
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Setting Differential Pair Properties

Note:
If you select multiple differential pairs, and a layer setting does not belong to all of the 
selected pairs, the Layer box is unavailable for that layer. If you type a new value, it applies 
to the differential pairs that have this layer setting only.

Tip
Keep the following tips in mind:
• If you select multiple differential pairs that have the same layer setting, but the Width and 

Gap values do not match, the Width and Gap cells will appear empty. You can, however, 
type a new value, and the new value will be applied to all selected differential pairs when 
you click OK  or Apply.

• You can also set the Width and Gap values using the Spreadsheet window, sorted for 
differential pairs. The spreadsheet will show the width and gap value set for <All layers>. 
If a specific layer has a unique setting, an asterisk appears next to the width or gap 
value.

For more information, see Differential Pair Layer Hierarchy.

4. Type the minimum length value in the Minimum box. Type the maximum length value in the 
Maximum box.

Tip
You can lengthen the differential pair by adding an accordion.

5. Select the “Restrict layer changes during autorouting” check box to force routing of the pair on a 
single layer. (This setting does not restrict layer changes when routing interactively.)

6. Select the “Allow pair to split around obstacles” check box to temporarily exceed the pair routing 
gap. This setting applies to autorouting and does not restrict splitting around obstacles when 
routing interactively.

7. Type the maximum number of obstacles to route around in the Maximum number of obstacles box.

Note:
SailWind Router does not count obstacles in the start zone or end zone. This is the zone 
between the connection point and the shoulder of the differential pair.

8. Type the maximum spacing allowed between traces around obstacles in the Maximum obstacle 
size box. The size applies to the obstacle’s longest horizontal or vertical dimension.

Note:
SailWind Router does not check the obstacle size in the start zone or end zone. This is the 
zone between the connection point and the shoulder of the differential pair.

9. Click OK.
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Related Topics
Setting Object Properties

Creating a New Object in a Secondary Group

Component Rules
To provide improved control over the trace width for fine pitch parts or densely populated BGAs, you 
can specify trace width rules at the component level resulting in different trace width rules within the 
component boundary.

You can also set pad entry, fanout, clearance, via biasing, and same net rules at the component level. 
The pad entry and fanout rules are applied to all pins in the component.

Component clearance rules are based on pin clearances and other component-specific design rules. 
SailWind Router creates a boundary automatically to indicate where component rules start and stop.

SailWind Router often assigns boundaries at vias and trace vertices. The software automatically 
determines boundary locations when it autoroutes traces; however, when interactively routing, you can 
define when to start and stop using component rules.

When a component rule is in use, it applies to trace objects between the rule boundary and a component 
pin. If a trace passes under a component but does not connect to the component, the software does not 
check it against the component’s clearance rules.

Rule boundaries (Figure 26) also have an effect on trace editing (for more information, refer to "“Creating 
Traces Using Component Rules”  on page 308").

Figure 26. Rule Boundaries

Via biasing rules apply to the first and last vias connecting to the component. When routing, SailWind 
Router starts at one pin and follows a path to the next pin in the chain. Therefore, the software assigns 
a non-component rule via type to the first and last vias along the trace path. If this creates a spacing 
violation, then the software uses a component rule via type instead.
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Tip
Exception: A unique situation exists where the component boundary is not calculated solely upon 
the design rules. For example, in SailWind Router, you exit a fine pitch BGA using a narrow trace 
width, but the trace does not automatically exit component rules at the edge of the component 
boundary. You decide when to use the Switch Rules command to exit component rules to change 
to a larger trace width according to the most relevant rule from the design hierarchy. In this case, 
you can extend the component rules far from the component and outside of the calculated area of 
the component boundary.

SailWind Layout does not understand these extended Component Rules and it may lose extended 
boundary locations. However, if you do not edit the design in SailWind Layout and you reopen it in 
SailWind Router, the extended boundary locations likely recalculate correctly.

Also, in SailWind Router, if you change the component rules after extending the component rules with a 
trace, the recalculated component boundary will correspond to the new component rules and may differ 
from the old boundary - creating an invisible split in the trace. When the design is opened in SailWind 
Layout, this location becomes a tack.

Length Rules
Length rules specify the minimum and maximum trace length. You can specify length rules for a net, 
electrical net, or pin pair, and matched trace lengths for two or more nets, electrical nets, or pin pairs.

You can make length rules hard or soft by using the “Ignore length rules when required to complete 
traces” check box in the Tune  tab of the Options dialog box. See Hard and Soft Rules.

You can assign length rules to nets and pin pairs at many levels of the hierarchy. This includes assigning 
the following:

• Net rules at the net and class rule levels

• Pin pair rules at the group and pin pair rule levels

• Net or pin pair length rules to members of a differential pair

• Length rules to electrical nets

• Matched length rules at the net, class, electrical net, group, and pin pair rule levels by grouping 
these objects into matched length groups

• Matched length net groups can contain mixtures of nets, electrical nets, and net classes

For more information, see “Rules Hierarchy”  on page 155.

Calculating Length
The delta between end points of a segment is the length of a trace segment.

For example, a horizontal segment having a common Y coordinate for both end points but having a 
difference of one inch in the X coordinate for the end points has a trace length of one inch (Figure 27).
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Figure 27. Calculating Trace Segment Length

SailWind Router calculates the length of a collection of trace segments, a pin pair, or a net by totaling the 
length of all trace segments, including the portions embedded within pads or vias (Figure 28). The total 
trace length calculation includes trace segments that overlap pads or vias.

Tip
Unlike SailWind Layout, SailWind Router counts overlapping trace segments in the trace length 
calculation.

Figure 28. Calculating Total Length

Matched Length
Matched length is defined as two or more nets, electrical nets, or pin pairs having equal total net lengths. 
Matched length is typically specified with a tolerance.

Figure 29  shows two different nets with a matched length, even though the trace pattern is slightly 
different.
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Routing Rules

Figure 29. Matched Lengths

Routing Rules
Routing rules specify trace width allowances and what should happen during autorouting operations.

A SailWind Router feature automatically reduces trace width to the pad, provided the trace width is within 
the minimum and maximum width rules (Figure 30). The routing rules for the trace must have a minimum 
width equal to or less than the width of the pad; otherwise SailWind Router does not use the feature and 
does not complete the trace.

Figure 30. Routing With and Without Minimum Width Specification

Working with Multiple Object Properties
You can assign or edit the design properties of multiple design objects simultaneously. Simultaneous 
editing reduces assignment tasks and aids in providing the same settings to multiple objects.

Procedure
1. Select two or more objects of the same type (for example, two nets or two components).

2. Right-click and click the Properties  popup menu item.

SailWind Router Guide 189



Set Up Rules
Working with Multiple Object Properties  

Results
If multiple object types are selected, the No Properties dialog box appears. Multiple object type selection 
is not supported.

If multiple objects are selected, the dialog box controls behave differently, depending on the status of the 
objects selected.

For example, if you select a pin that serves as a test point, and another pin that does not (mixed 
selection), the state of the “Serve as test point” check box is dimmed with a check mark.

Table  60. Multiple Objects— Dialog Box Behavior

Control Type and Status State Allowed actions

Check box — Cannot set 
(database restrictions)

Dimmed Non-modifiable

Check box —Mixed Dimmed with check mark All on or All off

Check box — All on Check mark All off

Check box — All off Clear All on

Box — Cannot set (database 
restrictions)

Dimmed Non-modifiable

Box — Cannot set (all read-only) Dimmed Non-modifiable

Box — All the same Same value Editable value

Box — Mixed No value Clear - editable

Static text — All the same Same value Non-modifiable

Static text — Not all the same Object count provided Non-modifiable

Preview — All the same Same view Non-modifiable

Preview — Not all the same Dimmed Non-modifiable

Related Topics
Properties Dialog Box, No Properties Tab

Setting Object Properties
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Chapter 12
Turn on Design Rule Checking

Design Rule Checking (DRC) checks for design rule violations during interactive routing, route 
editing, and placement editing. When you enable DRC, SailWind Router checks your design for errors 
continuously, based on the defined design rules.

When you open a file in SailWind Router, it uses the existing status of DRC and not the setting from 
SailWind Layout. You can use the DRC Filter toolbar to enable or disable DRC for individual design rules 
(clearance, trace width, same net, placement, and length). The DRC Filter Toolbar reflects the settings in 
the Design Rule Checking dialog box.

When DRC is off, the software does not perform checks for violations, but it does not permit subnet 
violations. Traces between subnets may cross but they cannot join at the intersection. Layer Biasing and 
Via Biasing violations are not permitted when DRC is off. Autorouting always operates as though DRC is 
enabled and allows no errors.

Setting Design Rule Checking
Component Spacing
Checking DRC Errors During Operations

Setting Design Rule Checking
You can set DRC options from the Design Rule Checking dialog box.

Tip
If the items on the DRC toolbar are not available (and are grayed out), click the DRC On/Off 
(DRC)  button on the DRC toolbar to enable the ability to select and edit the specific DRC 
checking options. Once you have enabled the DRC editing capability, you can use the toolbar 
buttons to enable and disable specific DRC checks.

Procedure
1. Click the Tools > DRC Settings  menu item, or click the DRC Filter  toolbar button then click the 

DRC Settings  button (on the DRC Filter toolbar).

2. In the Design Rule Checking dialog box, in the Enable column, select the check box for each 
design rule you want to check.

3. In the Error Response column, click the cell of the design rule for which you want to set an error 
response. Select the appropriate response for how you want SailWind Router to handle design rule 
violations when it encounters them during interactive routing, trace editing, and placement editing 
operations.

For more information on the DRC error response behaviors, see “Design Rule Checking Dialog 
Box”  on page 405.

4. Click Close.
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Results
The desired design rule options are set, and the DRC Filter toolbar is updated with the same information.

Component Spacing
SailWind Router provides automated features to ensure adequate spacing between components.

Spacing Basics
The software places components using the units of the Design grid when you enable the “snap to grid” 
setting.

The software prevents components from overlapping if both of the following conditions are met:

• On the Tools > Options  menu item, Fabrication  category, you have set up a value for “Minimum 
spacing between components” in the Component assembly area

• On the DRC Toolbar, you have enabled Placement DRC (design rule checking), and in the DRC 
Setup dialog box, you have set Placement to Prevent Errors mode

Auto-generated Component Outlines

The body of a component is the furthest extent of any decal object. Upon loading the design, if the 
system does not detect a component placement outline on Layer 20, it auto-generates an outline that 
encompasses all objects contained within the decal. The DRC function uses this visible outline to 
establish a reference component boundary.

In the preceding illustration, the “Minimum spacing between components” value applies in all cases when 
Placement DRC is enabled.
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Component Spacing

Note:
SailWind Router supports separate Clearance DRC checking. If Clearance DRC checking is 
enabled during a Placement DRC operation, the system performs both checks simultaneously. 
If the TH or SMD pads of a component encounter other TH or SMD pads of another component, 
and the placement outlines of the components do not violate the “Minimum spacing between 
components” value, then the system uses the Pad to Pad, SMD to SMD, or Pad to SMD rule.

The “Minimum spacing between components” value applies to the auto-generated outline representing 
the furthest extent of any decal object on the following layers:

• Component layer (top or bottom)

• Associated silkscreen layer for component layer (silkscreen top or bottom)

• Layer 0 (All layers).

There is only one “Minimum spacing between components” value that must apply to all components.

Advanced Spacing

While a single “Minimum spacing between components” value may suit many of your components, you 
may have many parts that require extra spacing for the pick and place process, or for rework.

You can create a custom clearance outline in the decal on Layer 20. The software uses this larger outline 
during the placement process to create more spacing around components. The extra, larger outline is 
often called a component courtyard or nudge outline. The “Minimum spacing between components” value 
applies between Layer 20 outlines.

Tip
In extended layers mode, Layer 20 becomes Layer 120.

Spacing Verification

If you are unsure if components have been placed outside of the design rules that you have set up, run 
a Clearance design verification check. Be sure that all aspects of your components, including the color 
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for Top Plc. and Bot. Plc. objects are visible since the Clearance Placement Outline check only verifies 
objects that are visible and within view during its checking routine.

When setting up the Clearance check in the Tools > Options  menu item, in the Design Verification 
category, ensure that you have selected the check box for “Placement outline” to check for the “Minimum 
spacing between components” value between the placement outlines.

Checking DRC Errors During Operations
Certain operations may be unsuccessful—such as manual routing and component placement—if they 
violate design rules. If you encounter an error, you can choose to suspend the operation and view the 
DRC errors.

Procedure
1. Right-click and click the Explain Last Error  popup menu item.

Alternatively, on the Suspend toolbar, click the Explain  button. 

2. Click an error in the Error Type column in the Spreadsheet Window to display the DRC error 
message in the status bar and highlight the error location in the workspace.

3. Right-click and click the Cancel  popup menu item to resume the command or click the Continue 
with Errors  popup menu item to continue the operation despite the DRC violation.

Related Topics
Design Rule Checking and Interactive Routing

Setting Design Rule Checking
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Chapter 13
Place Components

SailWind Router provides a comprehensive selection of placement commands that allow very precise 
positioning of components. SailWind Router also has commands that allow you to move, flip, rotate, and 
spin components during or after initial placement.

Placing Components
Component Placement Rules
Placing Components and DRC
Setting Fabrication Rules to Control Placement
Adding Keepouts
Moving Routed Components
Setting the Placement Origin
Placing Members of a Component Group
Moving Components
Placing Components Sequentially
Manipulating Components
Measuring Distance Between Objects

Placing Components
Use placement commands to move components on a board.

SailWind Router’s component placement commands differ slightly from those in SailWind Layout. 
Familiarize yourself with the placement rules and options to fully understand placement commands and 
results.

You can modify component placement manually or you can edit component properties. To manually place 
a component or component group, you use a combination of pointer operations and Move, Spin, Rotate, 
and Flip commands. To edit a component or component group's placement, you modify the X/Y location, 
rotation, or layer properties in the Component  tab of the Component Properties dialog box.

The component's origin snaps to the Placement grid during placement operations except in the following 
cases:

• You place the component using the Spin command.

• You place the component by editing its X/Y or rotation properties.

• You clear the Snap check box for the Placement grid on the Grid  tab of the Design Properties 
dialog box.

You can move components after you set options and preferences defining how you want to move them 
and how you want to perform DRC. You can also spin components, rotate them by 90 degrees, or flip 
them to the other side of the board.

Use the Placement toolbar to activate placement commands.
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Tip
Placement commands are also available in Object mode from the shortcut menu when you right-
click over a selected component.

In general, the placement commands behave like SailWind Layout placement commands. The following 
list summarizes the main placement behaviors that are different in this program:

• Set an origin for a component or component group.

• Spin, rotate, and flip a component group as a whole, using one origin for the entire group.

• Rotate components counter-clockwise, regardless of the side of the board on which the 
component resides.

• Set the angular increment value for Spin.

• Reroute during placement.

• Prevented from moving unions, reuses, arrays, an arbitrary set of components and traces, 
coppers, texts, 2D-lines, or keepouts.

Tip
You can place a component by editing its properties. Modify the X/Y location, rotation, or 
layer properties in the Component  tab of the Component Properties dialog box.

Component Placement Rules
During placement operations, components adhere to specific rules that define clearances between design 
objects.

Clearance between two components is defined as the minimum distance between the component 
placement outlines. During placement operations, SailWind Router checks the clearance between a 
selected component and other components for the following object relationships:

• Component-to-component clearance

• Component-to-board outline clearance

• Component-to-board cutout outline clearance

The software takes measurements from the centerline of the line used to create the component 
placement outline to the following:
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• The centerline of another component placement outline

• The centerline of the board outline

• The centerline of a line defining a board cutout

Figure 31. Example Placement Outlines

The SailWind Layout Decal Editor enables you to use 2D lines to create a representation of the 
component placement outline on Layer 20. The software recognizes these placement outlines as follows:

• When a part is brought into a design in SailWind Layout, this outline converts from a group of 2D 
lines into a Placement Outline design object on Layer 20. Visibility is controlled by color tiles on 
Layer 20 in the Top/Bottom Object columns of the Display Colors dialog box.

• When the design opens in SailWind Router, the software recognizes this Placement Outline 
object on Layer 20 and converts it to a SailWind Router Placement Outline object whose visibility 
is controlled separately by color tiles in the Top Plc. or Bot. Plc. columns in the Options  menu 
item, Colors category. The Placement Outline design object visibility is no longer associated with 
Layer 20.

• If no Layer 20 Placement Outline is detected for a component, the system auto-generates an 
outline that encompasses all of the objects in the pcb decal. The software recognizes it as a 
SailWind Router Placement Outline object whose visibility is also controlled separately by color 
tiles in the Top Plc. or Bot. Plc. columns in the Options  menu item, Colors category.

• Placement Outline objects derived from Layer 20 Placement Outlines and auto-generated 
Placement Outline objects are treated equally in SailWind Router, and no distinctions are drawn 
between them by the DRC or Design Verification processes.

• The auto-generated SailWind Router Placement Outline design objects are temporary for the 
current design session. When the design returns to SailWind Layout, the software removes these 
design objects from the database. The visibility of any Layer 20 Placement Outline design objects 
revert back to control by Layer 20 in SailWind Layout.
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During placement operations, SailWind Router checks both the height of the selected component and 
the keepout height settings. If you place a component into a keepout, and the height of the component 
exceeds the height setting of the keepout, a placement DRC violation is reported.

Tip
Using the Layout Editor in SailWind Layout, you can set the geometry of a component height 
keepout on the primary component side, the secondary component side, or both sides of the 
board. You can edit the height of the keepout by editing its properties.

Placing Components and DRC
SailWind Router checks design rules between placed components and other objects but does not check 
design rules between objects on the placed component or component group. When you use Move or 
Spin, placement-only DRC violations appear highlighted before you complete the placement.

Tip
No design rule checking occurs for a component or component group that you place completely 
outside of the board outline. However, design rule checking does occur if you place the 
component or component group partly or entirely inside the board outline.

When a DRC violation occurs, the Error Response setting in the Design Rule Checking dialog box 
determines how the placement command completes and it reports the violation.

Table  61. Effects of Error Response Setting

Error response Placement response to DRC violation DRC violation reporting

Prevent The software rejects the new placement 
location and returns the component to its 
original location.
For Move and Spin the component 
remains attached to the pointer until you 
select an error-free location, suspend 
placement (to view DRC violations), or 
cancel placement.
For Rotate and Flip, the component 
briefly appears at the new location and 
then returns to the original position.

To view DRC violation reporting 
when the component remains 
attached to the pointer during 
Move or Spin, right-click and then 
click Explain Last Error. The 
spreadsheet window displays the 
DRC violations.
To view DRC violation reporting 
when the component returns to the 
original position during Rotate or 
Spin, click the Explain Last Error 
button on the Suspend toolbar. The 
spreadsheet window displays the 
DRC violations.

Explain Placement suspends to enter Display 
Last Error mode.

The spreadsheet window displays 
the DRC violations.

Warn Placement completes. The spreadsheet window displays 
the DRC violations.
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Tip
When more than one Error Response list setting is selected in the Design Rule Checking dialog 
box, the setting with the highest priority applies. “Prevent” has the highest priority and “Warn” has 
the lowest priority.

Setting Fabrication Rules to Control 
Placement
You can set the minimum spacing between components clearance value and the default component 
height limits.

Tip
You cannot place a component if its distance to another component is less than the “Minimum 
spacing between components” clearance value that you set in the Options  menu item, 
Fabrication category.

Tip
If you set a Geometry.Height attribute for a component in SailWind Layout, you cannot place the 
component in SailWind Router if the attribute value exceeds the height you set in the Options 
menu item, Fabrication category.

Procedure
1. Click the Tools > Options  menu item; then, in the Options dialog box, click the Fabrication 

category.

2. In the Component assembly area, specify placement rule settings.

3. Click OK  to accept the settings and close the Options dialog box.

Tip
To enable placement rule checking, on the DRC Filter Toolbar, select Placement, and then, 
in the Design Rule Checking dialog box, set the desired response action.

Related Topics
Placing Components

Adding Keepouts
You can add keepout areas to your design to define areas where design objects cannot be placed. You 
can create keepout areas using closed polygons (with or without arcs), circles, or rectangles. The current 
angle mode and design grid settings determine the placement of the lines.
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Keepout areas you create in SailWind Router transfer with the design when you open it in SailWind 
Layout.

Procedure

1. Click the Drafting Operations  toolbar button. 

2. On the Drafting Operations toolbar, click the Keepout button. 

3. Create one of the following shapes for the keepout area:

• Creating a Polygon Drafting Object

• Creating a Circle Drafting Object

• Creating a Rectangle Drafting Object

4. In the “Keepout Properties dialog box”  on page 495 that appears, specify the layer where you 
want to place the keepout area and the restrictions that you want to apply.

Restriction:
When you choose layer assignments, if a restriction is not available for that layer, its 
corresponding check box is unavailable. For example, if you choose a non-placement 
layer, the Placement check box is not available.

5. Click OK.

The software creates the keepout. If you create other keepouts, they use the restrictions you set 
here as the default.

Results
The keepout displays with the hatch filling selected in the Options dialog box > Global category > 
“General subcategory”  on page 441.

Related Topics
Properties Dialog Box, Keepout Tab

Moving Routed Components
SailWind Router manipulates the traces attached to the pins of a placed component according to the 
Move Fanouts and the Reroute Traces settings in the Placement  tab of the Options dialog box. When 
you enable the Move Fanout setting, SailWind Router places the traces and vias recognized as fanout 
with the component.

The following figure shows a selected component and its fanout.
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Figure 32. Fanout of a Selected Component

The “Move components with Fanout” setting has priority over the Reroute Mode setting. If you select 
the “Move components with Fanout” check box, the fanout traces and vias move with the component. In 
contrast, if you clear the check box, the fanout traces and vias are subject to the Reroute Mode setting.

If SailWind Router cannot route the nets free of DRC violations, and you set the Error Response setting 
in the Design Rule Checking dialog box to “Prevent” or “Explain,” it leaves the nets unrouted. However, if 
you set the Error Response setting to “Warn,” the software routes in a straight rat’s nest pattern any nets 
that it cannot otherwise reroute free of DRC violations.

Related Topics
Options Dialog Box, Placement Category

Setting the Placement Origin
You can change the placement origin for a component or component group.

Procedure
1. Click the Tools > Options  menu item; then, in the Options dialog box, click the Global category > 

General subcategory.

2. In the “Object movement” area, click the “Move object by” list and select “Origin.”

3. Click OK.

4. On the Placement toolbar, click the Select Mode  button.

5. Select the component or component group.

6. Right-click and click the Set Move Origin  popup menu item.

7. Move the pointer and click to set the new origin.

The origin you specify applies only for the current selection. When you make a new selection, the 
move origin reverts to its original location on the component.

If you do not specify a new origin, SailWind Router uses the original origin of the selected 
component. If you select a group of components, the software calculates the origin as the lower left 
of the selected group.
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8. Click Yes  to confirm the new origin or click No  to select another origin.

Tip
Set Move Origin is not available in Verb mode.

Related Topics
Placing Components

Placing Members of a Component Group
If you use the Move, Spin, Rotate, or Flip commands with a component group, the component group 
origin becomes the focal point for the placement operation while relative positions among members 
remain unchanged. In contrast, if you edit the component properties, the individual component origins 
become focus points for placement operations and the relative positions among members of the 
component group do change.

Figure 33  and Figure 34  show how the Rotate command places the members of a component group.

Figure 33. Default Component Group Origin and Initial Component Positions

Figure 34. Component Positions After the Rotate Command Has Completed

Figure 35  and Figure 36  show how setting the Orientation property places the members of a component 
group.
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Placing Members of a Component Group

Figure 35. Default Component Origins and Initial Component Positions

Figure 36. Component Positions after Setting 
Orientation Property for the Component Group to 90
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Moving Components
You can move components individually or as groups. SailWind Router provides several methods for 
moving components.

Tip
When the component is attached to the pointer, for all modes except drag and drop, you can right-
click to start another command, change component properties, or use shortcut keys to change the 
workspace view.

Moving Mode Description

Moving Components Using Object Mode Move a component by selecting it first and then 
choosing to move it.

Moving Components Using Verb Mode Move a component by choosing the Move mode and 
then selecting the component.

Moving Components Using Drag and Attach 
Mode

Move a component by dragging it with the mouse and 
clicking to place it.

Moving Components Using Drag and Drop 
Mode

Move a component by dragging it with the mouse and 
“dropping” it in place by releasing the mouse button.

Moving Components Using Object Mode
Move a component by selecting it first and then choosing to move it.

Prerequisites
Set the object move properties. For more information, see The Object Movement area of the Global / 
General Options  on page 441

Procedure
1. Select the components you want to move.

2. Right-click and click the Move  popup menu item. Alternatively, on the Placement Toolbar, click the 
Move Component  button.

3. Move the pointer to the new location and click to complete the move.

If DRC errors result from the new component location, and you set the DRC setting to Prevent in 
the Design Rule Checking dialog box, the Move command remains attached to the pointer. You 
can suspend the Move command to examine DRC errors. For more information, see “Checking 
DRC Errors During Operations”  on page 194

Moving Components Using Verb Mode
Move a component by choosing the Move mode and then selecting the component.
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Moving Components Using Drag and Attach Mode

Prerequisites
Set the object move properties. For more information, see The Object Movement area of the Global / 
General Options  on page 441

Procedure
1. On the Placement toolbar, click the Move Component  button.

2. Select the components you want to move.

3. Move the pointer to the new location and click to complete the move.

If DRC errors result from the new component location, and you set the DRC setting to Prevent in 
the Design Rule Checking dialog box, the Move command remains attached to the pointer. You 
can suspend the Move command to examine DRC errors. For more information, see “Checking 
DRC Errors During Operations”  on page 194

4. Repeat steps 4  and 5  as needed to move additional components.

5. Press the Esc key to exit Verb mode.

Moving Components Using Drag and Attach Mode
Move a component by dragging it with the mouse and clicking to place it.

Prerequisites
Set the object move properties. For more information, see The Object Movement area of the Global / 
General Options  on page 441

Procedure
1. Click the Tools > Options  menu item; then, in the Options dialog box, click the Global/General 

page.

2. In the “Object movement” area, click the “Drag object using” list and select “Drag and attach.”

3. Click OK.

4. Select the components you want to move.

5. Click and hold the left mouse button over the components, start dragging the components, and 
then release the left mouse button to attach the components to the pointer.

6. Move the pointer to the new location and click to complete the move.

If DRC errors result from the new component location, and you set the DRC setting to Prevent in 
the Design Rule Checking dialog box, the Move command remains attached to the pointer. You 
can suspend the Move command to examine DRC errors. For more information, see “Checking 
DRC Errors During Operations”  on page 194.

Moving Components Using Drag and Drop Mode
Move a component by dragging it with the mouse and “dropping” it in place by releasing the mouse 
button.
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Prerequisites
Set the object move properties. For more information, see The Object Movement area of the Global / 
General Options  on page 441.

Procedure
1. Click the Tools > Options  menu item; then, in the Options dialog box, click the Global / General 

page.

2. In the “Object movement” area, click the “Drag object using” list and select “Drag and drop.”

3. Click OK.

4. Select the components you want to move and release the left mouse button.

5. Click and hold the left mouse button over the components, then move the pointer to initiate a drag 
move.

6. Move the pointer to the new location and release the left mouse button to complete the move.

If DRC errors result from the new component location, and you set the DRC setting to Prevent in 
the Design Rule Checking dialog box, the Move command remains attached to the pointer. You 
can suspend the Move command to examine DRC errors. For more information, see “Checking 
DRC Errors During Operations”  on page 194.

Related Topics
Placing Components
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Placing Components Sequentially
Use the Move Sequential command to attach a set of selected components to your cursor one at a time 
for placement in the design.

There are two ways to move components sequentially:

Method Description

Placing Components Using 
the Find Dialog Box

Use the Find dialog box to select the components and also to apply the 
Move Sequential command.

Placing Components by 
Selecting Components in the 
Workspace

You select components in the working area and use a modeless 
command to apply the Move Sequential command.

Placing Components Using the Find Dialog Box
Use the Find dialog box to select the components and also to apply the Move Sequential command.

Procedure
1. Click the Edit > Find  menu item.

2. In the Find dialog box, set the “Find by” option to “Ref. Designator, Part Type,” or “Decal.”

Tip
Select multiple Ref. Des. prefixes, part types, or decals to expand the list of available 
components.

3. From the resulting list, select all the parts you want to move.

Tip
Use Shift+click for a range of components, or Ctrl+click for multiple components.

4. In the Action list, select “Move Sequential.”

5. Click OK.

6. In the prompt, “Proceed with next object? (value)” click one of the following options:

• Yes  to attach parts to the cursor successively, but prompt every time after a placement to allow 
you to skip over components if desired

• Yes to All  if the alphanumeric order of the selection is okay and you do not intend to skip over 
components.
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• No to skip this part, and go to the next.

• Cancel to abort the process. You return to the Find dialog box.

7. The first part attaches to the pointer for placement (parts attach to the pointer in ascending 
reference designator order). Click to place the component.

Tip
With a part attached to the pointer, you can right-click to access the Rotate 90, Spin mode, 
or Flip commands and also use modeless commands.

Note:
You can move a component by either its origin or midpoint, as set in the Global  category > 
General  subcategory of the Options dialog box.

Related Topics
Find Dialog Box

Options Dialog Box, Global Category, General Subcategory

Placing Components by Selecting Components in 
the Workspace
You select components in the working area and use a modeless command to apply the Move Sequential 
command.

Procedure
1. In the working area, with nothing selected, right-click and click the Select Components  popup 

menu item.

2. Using Ctrl+click, select all the parts you want to move.

Tip
The parts are attached to the pointer in the reverse order in which they are selected. The 
last component selected is the first one attached to the pointer.

3. Type the modeless command MS and then press Enter.

4. In the prompt, “Proceed with next object? (value)” click one of the following options:

• Yes  to attach parts to the cursor successively, but prompt every time after a placement to allow 
you to skip over components if desired

• Yes to All  if the alphanumeric order of the selection is okay and you do not intend to skip over 
components.

208 SailWind Router Guide



 
Place Components

Manipulating Components

• No to skip a part and go to the next.

• Cancel to abort the process. You return to the Find dialog box.

5. The first part is attached to the pointer for placement. Click to place the component.

Tip
With a part attached to the pointer, you can right-click to access the Rotate 90, Spin mode, 
or Flip commands, or use modeless commands.

Note:
You can move a component by either its origin or midpoint, as set in the General options 
on page 441.

Manipulating Components
You can rotate, spin, or flip a component from one side of the PCB to the other.

Procedure
Manipulate components using either the Object mode or the Verb mode as follows:

Mode Steps

Object mode 1. Select the component or component group to manipulate.

2. Right-click and click the Flip Side, Rotate 90, or Spin  popup 
menu item.

3. If you choose the Spin  popup menu item, move the pointer to the 
new location and release the left mouse button to complete the 
spin.

If a DRC error results from manipulating the component, and the 
DRC setting is set to “Prevent,” the component returns to its original 
position (or in the case of the Spin  popup menu item, remains 
attached to the cursor).

Verb mode 1. On the Placement toolbar, click the Flip Side, Rotate 90, or Spin 
button.

2. Click a component you want to manipulate.

3. (Spin button only) Click to indicate the new rotation angle to 
complete the component spin.

4. Press the Esc key to exit the Verb mode
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Related Topics
Placing Components

Checking DRC Errors During Operations
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Measuring Distance Between Objects
You can measure the distance between components to aid in accurate placement.

Use either of the following methods to measure the distance between objects:

Measuring Distance Between Objects Using In-Place Query
Measuring Distance Between Objects Using the Q Shortcut Key

Measuring Distance Between Objects Using 
In-Place Query
In-place Query allows you to measure the distance between components by selecting the objects.

Procedure

1. On the main toolbar, click the In-Place Query  button. 

2. Select an object.

3. Point to a second object.

The shortest distance between the objects appears, as shown in Figure 37

Figure 37. Distance Measured from the Via on the Left to the Via on the Right

Measuring Distance Between Objects Using the Q 
Shortcut Key
The Q shortcut key attaches a measurement line to the pointer and displays dx, dy, and hypotenuse 
information, depending on pointer movement. It snaps to the routing grid when Grid Snap is on. When 
Grid Snap is off, the Q shortcut key makes the measurements without the grid.

Procedure
1. Locate the pointer over the first object.

2. Press the q key and click Execute.

3. Locate the pointer over the second object to display the dx, dy, and hypotenuse (“d”) information.
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Tip
Click to restart the measurement.

Tip
Ctrl+click to attach a new measurement line to the current measurement line and to display 
the total length.

4. Press the Esc key to exit the measurement function.

Related Topics
Measuring Distance Between Objects Using In-Place Query
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Chapter 14
Virtual Pins

SailWind Router supports the use of virtual pins, which can act as nodes for adding pin pair start or end 
points.

The Virtual Pin
Virtual Pin Setup
Adding a Virtual Pin to a Net
Deleting a Virtual Pin
Protecting a Virtual Pin
Changing a Virtual Pin’s Via Type

The Virtual Pin
A virtual pin is like a component pin that you can add to a net. It becomes a start point and/or end point of 
one or more new pin pairs. This gives you increased (sub-pin-pair) control over the net. For example, you 
could use a virtual pin to create distinct matched length pin pairs out of the net’s branches.

Tip
You can also add virtual pins in SailWind Layout.

A virtual pin uses the pad stack of a via. The pad stack can be a through-hole type or partial, or it can be 
a single-layer pad. You add virtual pins nets. When you add a virtual pin to a net, the total number of pin 
pairs in the net increases by 1, as shown in this example:
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You can assign rules to pin pairs ending on virtual pins in the same way as to pin pairs ending on 
component pins.

In the display, virtual pins are identified with a marker that uses the color of the board outline.

Figure 38. Virtual Pin Marker
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Virtual Pin Setup

To work with virtual pins, you need the Advanced Rules license.

Virtual Pin Setup
Use SailWind Layout to set up the virtual pins in your design.

See Via Setup  in the SailWind Layout Guide for information on how to create, edit, and delete pad stacks 
for vias and virtual pins.

Adding a Virtual Pin to a Net
You can add a virtual pin to any net—unrouted, partially-routed, or wholly routed.

When you add a virtual pin to a net, it conforms to the following:

• If the virtual pin you are adding is the first virtual pin in the net, and the net has no pin pair rules 
and no routing—and has Minimized topology—the software creates the pin pairs between the 
new virtual pin and each component pin in the net in a “starburst” pattern (with the virtual pin in 
the center). This is the only case in which the software creates a starburst pattern.

Note that if you previously added a virtual pin to the net and deleted it, SailWind Router sets the 
net topology to Protected; so the virtual pin you are adding, even though it appears to be the first 
virtual pin in the net, connects only to the nearest component pin, not in a starburst pattern. You 
must reset the net topology to Minimized to create the starburst pattern with a central virtual pin.

• If the virtual pin you are adding is the first virtual pin in the net, and the net has pin pair rules, 
or routing, or a topology other than Minimized, the new virtual pin connects to the nearest 
component pin only. The software does not create a starburst pattern.

• If the virtual pin you are adding is not the first virtual pin in the net, it connects to the nearest 
virtual pin only. The software does not create a starburst pattern.

Tip
You cannot  create a starburst pattern by placing a virtual pin on a trace of a routed net.

Restrictions and Limitations

• You cannot add a virtual pin to a plane net.

Procedure
1. In the design area, select a net.

2. Right-click and click the Add Virtual Pin  popup menu item. The virtual pin appears on the pointer.

3. Click to place the new virtual pin. To stop adding virtual pins, right-click and click the Cancel  popup 
menu item.
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Results

• If you create a starburst pattern, the software generates the new pin pairs and sets the net 
topology to Protected. If you set your filter to Select Pin Pairs, you can select each connection. 
The status bar displays the connection to the virtual pin. Instead of a component and pin number 
(for example U2.8), it displays the instance of the virtual pin (for example VP2). The software 
uses the same format (VP<number>) in pin pair names, for example VP7—U2.1.

For information on setting design rules for the new pin pairs, see “Properties Dialog Box, Pin Pair 
Tab.”

• If you create a non-starburst configuration, or if you create a starburst configuration and want 
to reconfigure your pin pairs, you need to reschedule the net. See ““Rescheduling Nets”  on 
page 252” for more information.

Deleting a Virtual Pin
You can remove a virtual pin from a routed or unrouted connection.

Procedure
1. In the design area with nothing selected, right-click and click the Select Virtual Pins  popup menu 

item.

2. Select the virtual pin, right-click, and click the Delete  popup menu item.

Results

• If the deleted virtual pin has only one connection (routed or unrouted), the software deletes both 
the virtual pin and its connection.

• If the deleted virtual pin has two or more connections, all unrouted, the software deletes the 
virtual pin and makes new connections between the component pins and virtual pins to which it 
was connected.

• If the deleted virtual pin has two or more connections, some or all of which are routed:

◦ The software deletes the virtual pin and all its attached pin pairs.

◦ Routing (traces and vias) of the deleted pin pairs remains, and the software assigns it new pin 
pairs.

◦ If traces from different layers were attached to the deleted virtual pin, SailWind Router creates 
one or more zero-length unroutes between junctions on different layers.

◦ Unroutes might connect to junctions that replace the virtual pin.
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Protecting a Virtual Pin
You can control the protection of virtual pins through the “Protect; disallow editing” check box in the 
Virtual Pin  tab of the Virtual Pin Properties dialog box.

Tip
This check box is also toggled by the Protect  and Unprotect  commands in the virtual pin’s popup 
menu.

Procedure
1. In the design area, with nothing selected, right-click and click the Select Virtual Pins  popup menu 

item.

2. Select the virtual pin then right-click and click the Properties  popup menu item.

3. On the Virtual Pin  tab of the Virtual Pin Properties dialog box, select the “Protect; disallow editing” 
check box.

4. Click OK.

Changing a Virtual Pin’s Via Type
Change the type of via that a virtual pin uses through its Properties.

Restrictions and Limitations

• You cannot change a protected via unless you first unprotect it.

Procedure
1. Select the virtual pin, right-click and click the Properties  popup menu item.

2. On the Virtual Pin  tab of the Virtual Pin Properties dialog box, select the new via type from the 
Type list.

3. Click OK.

SailWind Router Guide 217



Virtual Pins
Changing a Virtual Pin’s Via Type  

218 SailWind Router Guide



 

 

 

Chapter 15
Copper Planes and Copper Shapes

SailWind Router provides tools for creating and customizing the shape of copper planes and copper 
shapes, including merging and subtracting shapes, creating arcs, and adding or deleting voids.

Any copper planes and shapes that you create or modify in SailWind Router transfer with the design 
when you open it in SailWind Layout.

Migration to Copper Planes
Set Drafting Options Before Creating a Drafting Object
Edge Precision of Drafting Shapes
Creating a Copper Shape
Creating a Copper Cut Out
Creating Nested Copper
Filling a Shape with Solid Copper
Creating a Copper Plane or Cut Out Manually
Creating a Polygon Drafting Object
Creating a Circle Drafting Object
Creating a Rectangle Drafting Object
Merge Shapes
Subtract Shapes
Cut Outs Absorbed by Copper
Self-Intersecting Polygons
Modification of Drafting Objects
Copper Voids
Creating Voids in Copper Planes
Deleting Voids in Copper Planes
Creating Nested Copper Planes
Selection of Drafting Objects

Migration to Copper Planes
Prior to the VX.2.4 release, PADS Layout used copper pours on “No Plane” layers and plane areas on 
“Split/mixed” layers. For all later releases, the software unifies copper pours and plane areas into “copper 
planes.” If you open a design saved in an earlier version, the software migrates or converts all copper 
pours and plane areas to copper planes and applies design rules accordingly. Certain clearance and 
connectivity changes in your design may result.

The following changes take place during the migration to copper planes:

• The “Replace unused pads with antipads” setting, found in the “Flooding Options”  on page 447, 
is extended to “No Plane” layers. With this setting enabled, all pads are removed on all internal 
“No Plane” and “Split/Mixed” layers unless the pin is connected to a trace or a copper plane on 
that layer. Prior to the PADS VX.2.4 release, unused pads were removed only from “Split/Mixed” 
layers.
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• Copper pours converted to copper planes are affected by the “Connect to copper plane with 
thermal” check box (in the Pin, or Via Properties dialog boxes). Prior to PADS VX.2.4, the setting 
applied only to plane areas on Split/Mixed layers. This means, for example, if you have disabled 
thermal connections for a pad or via by clearing the “Connect to copper plane with thermal” check 
box, the software removes the thermal connection to copper planes (old copper pours) on “No 
Plane” layers when you import the design into a newer release.

• You can apply custom thermals and custom antipads to copper planes on “No Plane” layers in 
addition to “Split/Mixed” layers. Prior to PADS VX.2.4, the custom thermals and antipads applied 
only to plane areas on “Split/Mixed” layers.

• Prior to PADS VX.2.4, a pin could receive a thermal connection to a plane area on a “Split/Mixed” 
layer even though a trace was connected to it. With later releases, any component pin with an 
attached trace does not receive a thermal connection if the “Add thermals to routed component 
pads” setting is disabled in the “Flooding Options”  on page 447. This was already the case 
for copper pours beginning with the PADS VX.2.3 release, and has been extended to copper 
planes on “Split/Mixed” layers in subsequent releases. Prior to PADS VX.2.3, a pin could receive 
a thermal connection to a copper pour even though a trace was connected and the “Add thermals 
to routed component pads” setting was disabled if an additional unrouted pin pair connection 
existed on the pin. Via pads will still receive thermal connections to copper planes regardless of 
the setting.

• One smoothing radius setting in the “Flooding Options”  on page 447 applies to all copper 
planes, regardless of the layer on which they reside. Previous releases had separate smoothing 
radius settings for copper pours and plane areas. The copper pours value from the flooding of 
an existing design is retained in VX.2.4 and later releases. It may be necessary to adjust the 
smoothing radius value if you experience connectivity errors in VX.2.4 that were not present in 
the prior version.

• The setting “Remove violating thermal spokes” is removed in SailWind Layout. All violating 
thermals spokes are removed by default. This is a hard-coded setting that cannot be modified.

• The modeless command “PO” toggles copper planes between pour outline and the flooded hatch 
display.

• When flooding drafting shapes, the copper floods to the inner edge of completed cut out outlines 
(not the centerline).
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Migration to Copper Planes

Figure 39. Cut Out Pour Boundary

• Beginning with PADS VX.2.6, the origin of the copper plane hatch grid is calculated from the 
lower left corner (if one exists or calculated if one does not exist) of the pre-flooded shape. If you 
used a hatched fill instead of a solid fill in a pre-VX.2.6 design, the hatch grid might not have the 
same origin and placement of the lines of the hatch grid. As a result, pins or vias that touched and 
connected to the hatch grid might not be connected. Other pins that did not touch or connect to 
the hatch grid might be in a position to connect.

The origin of the hatch grid pattern is defined by an imaginary box surrounding the extents of 
the copper plane shape. The extents box is reduced by ½ the line width of the copper plane 
shape and the hatch grid origin is placed in the lower left corner of the extents box. For a simple 
rectangular copper plane shape the hatch grid origin will be in the lower left corner of the shape. 
For more complex shapes, the lower left corner of the extents may be a point outside of the 
copper plane shape. This is not the origin of the copper plane shape, only the origin of the hatch 
pattern for the copper plane.

SailWind Router Guide 221



Copper Planes and Copper Shapes
Migration to Copper Planes  

Figure 40. Real Lower-Left Hatch Origin

222 SailWind Router Guide



 
Copper Planes and Copper Shapes

Set Drafting Options Before Creating a Drafting Object

Figure 41. Calculated Lower-Left Hatch Origin

Set Drafting Options Before Creating a 
Drafting Object
You can set various drafting options before you begin using the Drafting Operations Toolbar to add copper 
shapes, copper planes, cut outs, and voids.

Set Line Width
You can use one of the following methods to set the width of the lines in the drafting object you are 
creating:

• Type W<nn>, where <nn> is the width value.

• Click either the Copper, Copper Plane, or the Copper Plane Cutout  button:   
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Right-click and choose the Width > Set  popup menu item to type a new value.

• Set the default width value in the “Text and Lines options”  on page 462. (When you set the 
default line width in the Options dialog box, you can also enable the software to prompt you for a 
net to associate with any copper shape or copper plane you create.)

Set Layer Placement
Choose one of the following methods to select the layer for the placement of your drafting object:

• Before clicking any of the drafting buttons, type L<n>, where <n> is a layer number.

• Click either the Copper, Copper Plane, or the Copper Plane Cutout  button:   

Specify the layer using the Layer dropdown list on the Standard Toolbar.

Note:
You can change the layer of a drafting object after creating it by selecting the object and choosing 
a new layer from its Properties dialog box or by choosing a layer from the Layer dropdown list. All 
active segments of the drawing change to the new layer selection.

Set Corner Angle
Set the corner angle after clicking either the Copper, Keepout, Copper Plane, or the Copper Plane Cut 
Out  button.    

Before you begin drafting, right-click and choose either the Orthogonal, Diagonal, or Any Angle  popup 
menu item. If desired, you can right-click and switch angle settings at any time while drafting a shape. 
This capability allows you to change drafting angles multiple times for a single shape.

Edge Precision of Drafting Shapes
You often need to precisely control the edge of drafting shapes, as many factors contribute to that edge.

Line Width
The precision of edges is controlled by the line width used to create the shape. The default line width 
is set in the Text and Lines  category of the Options dialog box. However, you can change the line 
width prior to, or after creating your shape. Use a very narrow outline width to achieve a sharp corner or 
increase the value for more blunt corners. All corners are rounded with a radius equal to one half of the 
outline width.

Note:
In some cases, setting the line width too wide results in creation of a self-intersecting polygon. For 
more information, see “Self-Intersecting Polygons”  on page 237.
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Figure 42. Narrow Versus Wide Outline Width

Design and Hatch Grids

Lines are used to create the outline of the shape and are also used to create the fill inside electrical 
drafting items. Lines or outlines are placed on the design grid. Then shapes are filled using horizontal 
lines placed on the Hatch Grid.

Figure 43. Hatch Grid

Clearance Rules

If you are creating a copper plane and your drafting shape is near another object, the resulting poured 
outline could be displaced by the clearance rules of that object.
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Figure 44. Clearance Rule Effect on the Hatch Outline

Creating a Copper Shape
Copper is used to create heat sinks, shielding, and net bridges. You can assign nets to copper shapes.

Prerequisites

• Ensure you select a layer for placement of the copper. You cannot create a copper shape on all 
layers (layer number zero). If you need the same copper shape on many layers, copy the shape 
to other layers in SailWind Layout (SailWind Router does not provide copying capabilities).

Video
The following video demonstrates fundamental steps for creating and editing copper shapes.

Procedure

1. On the Drafting Operations toolbar, click the Copperbutton. 

2. Right-click and click a command to change the values of the drafting object as necessary.

3. Create the shape using one of the following:
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Creating a Copper Cut Out

• Creating a Circle Drafting Object

• Creating a Polygon Drafting Object

• Creating a Rectangle Drafting Object

4. After completing the shape, if you have selected the “Prompt for net name at completion of copper” 
check box in the Options dialog box (Text and Lines  category), the “Copper Properties dialog box” 
on page 471 displays. Make changes to the copper properties.

For example, you can assign a net by selecting the net name from the Net list. You can also 
specify the line width, the layer on which the copper is located, and whether or not the copper 
shape is solid (filled).

Note:
Select the “Solid” check box in the Copper Properties dialog box to enable or disable solid 
fill of the shape. If you clear the check box, whenever you enable copper or copper plane 
hatching to display, the copper drafting object fills according to the settings in the Global 
category > General  subcategory of the “Options dialog box”  on page 441.

5. Click OK  to close the Copper Properties dialog box.

6. Verify the resulting shape displays as expected.

• If the shape edges are not correct, see “Edge Precision of Drafting Shapes”  on page 224.

• If the shape needs to be modified, see “Drafting Object Properties”  on page 244.

• If you want to start over, see “Deleting a Drafting Segment or Object”  on page 245.

Creating a Copper Cut Out
Use copper cut outs to create voids inside copper shapes. Creating a cut out involves combining the fixed 
copper shape with the copper cut out.

SailWind Router does not provide a dedicated copper cut out button. Create cut outs by subtracting one 
copper shape from another.

Restrictions and Limitations

• A cut out does not create a void in the outline of the copper shape. Create the copper as a 
polygon shape to create features in the outline.

• You must be in Pour Outline mode (modeless command PO) to select or modify copper shapes.

Prerequisites

• You must put the cut out on the same layer as the copper.
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Procedure

1. On the Drafting Toolbar, click the Copper  button. 

2. “Create one or more cut out shapes”  on page 226 for the copper. You can create the cut out 
before the copper or the copper before the cut out.

3. Right-click and click the Select Shapes  popup menu item.

4. Select the copper shape where you want to create the cut out.

5. Click the Subtract Shapes  button. 

6. Select the shape that you want to use as the copper cut out. The software removes copper inside 
the selected cut out area.

7. Verify the resulting cut out displays as expected.

Creating Nested Copper
You can create a copper shape within another “outer” copper shape. You can do so by creating a copper 
cut out inside the outer shape, subtracting it from the outer shape, and then creating the new nested 
copper shape inside the copper cutout.

Figure 45. Example Nested Copper Shape
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Filling a Shape with Solid Copper

Prerequisites

• You must be in Pour Outline mode (modeless command PO) to modify or select copper shapes.

Procedure
1. In the outer copper shape, “create a copper cut out”  on page 227 of appropriate size and shape; 

then subtract it from the outer shape by clicking the Subtract Shapes  button.  See “Creating a 
Copper Cut Out”  on page 227 for more information on subtracting shapes.

2. Create the new nested copper shape  on page 226 within the copper cut out.

Results
The new nested copper shape displays inside the cut out of the outer shape.

Filling a Shape with Solid Copper
If desired, you can fill a shape with solid copper. The copper shape appears solid when you enable the 
Pour Outline mode (modeless command PO).

Procedure
1. Select a copper shape, right-click, and then click the Properties  popup menu item.

2. In the “Copper Properties dialog box”  on page 471, select the “Solid” check box.

If the check box is selected, whenever you enable the display of copper hatching, the copper 
shape displays as solid. When the check box  is cleared, and you enable hatching, the copper 
drafting object fills according to the settings in the Global  category > General  subcategory of the 
“Options dialog box”  on page 441.

Tip
Solid copper uses trace clearance rules.

Creating a Copper Plane or Cut Out Manually
Use a copper plane to create a copper area that avoids objects not connected to the net assigned to the 
copper plane and makes thermal connections to objects that are connected to that net.

Copper planes are insulated from traces or pins that do not share the net name. Flooded copper planes 
create isolation areas around non-connecting pins and traces automatically.

Use copper cut outs to create voids inside copper shapes. Creating a cut out involves combining the fixed 
copper shape with the copper cut out.
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Restrictions and Limitations

• A cut out does not create a void in the outline of the copper plane. See “Creating Voids in Copper 
Planes”  on page 246 for instructions on creating voids.

• If you create a copper plane cut out, you must put the cut out on the same layer as the copper 
plane.

Video
The following video demonstrates fundamental steps for creating and editing copper planes.

Procedure

1. On the Drafting Toolbar, click the Copper Plane  or the Copper Plane Cut Out  button.  

The add command for that object type attaches to your pointer.

2. Right-click and click a command to change the values of the drafting object. For more information, 
see Set Drafting Options Before Creating a Drafting Object.

3. Create the shape using one of the following methods:

• Creating a Polygon Drafting Object

• Creating a Circle Drafting Object

• Creating a Rectangle Drafting Object

4. In the “Copper Plane Properties dialog box”  on page 475 that appears, assign a net by selecting 
the net name in the Net list and any other appropriate changes to the copper plane properties. 
When you create a copper plane on a split/mixed layer, you can select the “Show plane nets only” 
check box to limit the nets to only those assigned to the split/mixed plane layer.

5. Click OK.

6. Review the resulting shape.
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• If the shape edges are not correct, see “Edge Precision of Drafting Shapes”  on page 224.

• If the shape needs to be modified, see “Drafting Object Properties”  on page 244.

• If you want to start over, see “Deleting a Drafting Segment or Object”  on page 245.

Creating a Polygon Drafting Object
Use the polygon drafting tool to draw the shape of a copper plane, void, or cut out.

Procedure
1. On the Drafting Toolbar, click the Copper, Keepout, Copper Plane, or the Copper Plane Cut Out 

button.    

The add command for that object type attaches to your pointer.

2. Right-click and choose the Polygon  popup menu item.

3. To start the drafting object and finish each segment or place each corner, use one of the following:

• Locate each coordinate with the pointer, and click to start and indicate consecutive corners.

• Type S<x> <y>, where <x> and <y> are the coordinate values for the starting point and 
consecutive corners; then click to draw the segment.

• Type SR<x> <y> if you want to specify relative coordinate values for each point and corner; 
then click to draw the segment.

Tip
Right-click and choose the Add Arc  popup menu item to add an arc instead of a straight-
line segment.

Note:
You can press the Backspace key to remove the last corner entered. You can also press 
Esc key to cancel the operation.

4. Double-click or right-click and choose the Complete  popup menu item to end the shape.

Related Topics
Creating a Copper Shape

Creating a Copper Plane or Cut Out Manually
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Creating a Circle Drafting Object
Use the Drafting Toolbar to create circular copper planes, voids, and cut outs.

Procedure
1. On the Drafting Toolbar, click the Copper, Keepout, Copper Plane, or the Copper Plane Cut Out 

button.    

The add command for that object type attaches to your pointer.

2. Right-click and choose the Circle  popup menu item.

3. Click to indicate the location of the circle’s center. Instead of using the pointer, you can type the 
coordinates using the following methods.

• Type S<x> <y>, where <x> and <y> are the coordinate values for the starting and ending point.

• Type SR<x> <y> if you want to specify relative coordinate values for the starting and ending 
point.

Tip
Press the Esc key to cancel the operation at any time.

4. Click or press the spacebar to indicate the circle’s radius to complete the circle definition.

Related Topics
Creating a Copper Shape

Creating a Copper Plane or Cut Out Manually

Creating a Rectangle Drafting Object
Use the Drafting Toolbar to create rectangular copper planes, voids, and cut outs.

Procedure
1. On the Drafting Toolbar, click the Copper, Keepout, Copper Plane, or the Copper Plane Cut Out 

button.    

The add command for that object type attaches to your pointer.

2. Right-click and choose the Rectangle  popup menu item.

3. Click to indicate one corner of the rectangle.

4. Click to indicate the location of the diagonally opposite corner.

5. As an alternative to using the pointer, you can you can type the coordinates using the following 
methods.

232 SailWind Router Guide



 
Copper Planes and Copper Shapes

Merge Shapes

• Type S<x> <y>, where <x> and <y> are the coordinate values for the starting and ending point.

• Type SR<x> <y> if you want to specify relative coordinate values for the starting and ending 
point.

Tip
Press the Esc key to cancel the operation.

Related Topics
Creating a Copper Shape

Creating a Copper Plane or Cut Out Manually

Merge Shapes
Merge Shapes is used to combine two or more shapes (coppers, copper planes, or copper plane cutouts) 
into a single merged shape. Each location where a shape intersects another shape results in a single 
shape that expands to include the additional shapes.

The shapes merge into a single shape, which inherits the properties (such as width, net name, and fill 
type) of the last shape selected. Additionally, if you merge a copper plane with a copper plane cutout, 
then the merged shape is of the same type of the last shape selected. For example, if you select the 
copper plane cutout last, the resulting merged shape is a copper plane cutout.

Prerequisites

• You must select two (or more) shapes before merging shapes.

• You must be in Pour Outline mode (modeless command PO) to select and modify copper shapes. 
Use the modeless PO command to toggle the setting.

• You cannot merge copper shapes with copper planes.

• The shapes need to reside on the same layer.

Note:
If two or more shapes are selected and they are assigned to different net names then the 
merge is not completed.

• The shapes need to intersect at one (or more) locations to merge.

• You cannot merge shapes if they belong to a physical design reuse.
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Procedure
1. Use Ctrl-click to select two or more existing shapes.

2. On the Drafting toolbar, click the Merge Shapes  button, or right-click and click the Merge Shapes 
popup menu item.

The selected shapes are merged into a single shape.

Related Topics
Creating a Copper Shape

Creating a Copper Plane or Cut Out Manually

Subtract Shapes

Subtract Shapes
Subtract Shapes is used to subtract one shape from another resulting in a single merged shape. This is 
not restricted to copper plane cutout shapes; a copper plane can be subtracted from a copper plane or a 
copper shape can be subtracted from another copper shape for ease of use.

Restrictions and Limitations

• A shape subtracted from another shape that completely severs the first shape results in two 
separate shapes.

• A shape completely within a plane which is subtracted is treated as a void and combined with the 
plane so that it moves with the plane (unlike a cutout which tracks separately). Subtracting the 
shape may not be the best choice in this case and it may be better to keep it as a cutout so the 
void shape can be more easily moved or copied. The copper plane will have an opening in the 
flooded shape either way.

• You must be in Pour Outline mode (modeless command PO) to select and modify copper shapes. 
Use the modeless PO command to toggle the setting.

• You cannot subtract a copper shape from a copper plane or a copper plane from a copper shape.

• You cannot subtract shapes if they belong to a physical design reuse.

• If subtracting a copper shape from another results in two or more separate copper shapes, each 
shape receives a new name and a new origin.

Prerequisites

• The shapes need to reside on the same layer.

• The shapes need to intersect.
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Cut Outs Absorbed by Copper

Procedure
1. Select a single copper, copper plane, or copper plane cutout shape.

2. On the Drafting toolbar, click the Subtract Shapes  button or right-click and click the Subtract 
Shapes  popup menu item.

The base shape (the shape from which you intend subtract another shape) displays with a colored 
dashed outline. Other shapes that are available for selection appear with a solid colored outline, 
while unavailable objects in the design change to gray scale, thus making it easy to discern 
between objects.

3. Select another single shape to subtract from the first shape.

The function does not allow multiple shapes to be selected as subtraction operations can result in 
different effects depending on the order of subtraction.

The selected shape is subtracted from the first shape. Repeat to subtract additional shapes as 
required.

4. When you have finished subtracting shapes press the Esc key or right-click and click the Cancel 
popup menu item to end the procedure.

Related Topics
Creating a Copper Shape

Creating a Copper Plane or Cut Out Manually

Merge Shapes

Cut Outs Absorbed by Copper
When you combine coppers and copper cut outs in SailWind Layout and take the design into SailWind 
Router, if any cut outs cross the copper outline after you, they are no longer cut outs. Instead, the 
software absorbs them into the copper shape.

In some cases, copper cut outs are completely enclosed within the confines of a copper shape. If the 
copper cut out extends beyond the boundaries of the copper shape, however, and you merge the cut 
out with the copper shape in SailWind Layout (by right-clicking and clicking the Combine  popup menu 
item), when you move the design over to SailWind Router, the software “absorbs” it into the outline of the 
copper shape.
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Figure 46. Absorbed Copper Cut Out

If the cut out completely divides a copper shape, two or more separate copper shapes may result in 
SailWind Router.

Figure 47. Subtracted Copper Cut Outs in SailWind Router

Certain other changes take place:
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Self-Intersecting Polygons

• If you completely cover a copper shape with a cut out then combine the two, taking the design 
into SailWind Router deletes the copper shape in its entirety.

• SailWind Router removes any copper cut outs that lie outside the boundary of a copper shape.

• If a copper shape has two or more overlapping cut outs within its boundaries, the copper cut outs 
merge into one shape when you move the design to SailWind Router.

The software generates a report automatically when you open the design, detailing any instances where 
the software absorbs one or more shapes during the subtraction process.

Note:
If SailWind Router is running in the foreground, the link to the report displays in the SailWind 
Router Output Window. If SailWind Router is running in the background (for example, during 
an autoroute routine or during Latium Design Verification), the link to the report displays in the 
SailWind Layout Output Window.

Self-Intersecting Polygons
A self-intersecting polygon occurs whenever a portion of a shape outline overlaps with another portion of 
the same shape. Giving a polygon a large outline width can cause the outline to overlap in some portions.

When drafting copper planes and shapes using polygons, you can set the outline line width in the Copper 
Plane Properties dialog box  on page 475. Choosing a narrow line width enables you to create shapes 
with greater accuracy in detailed areas, as shown in Figure 48.
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Figure 48. Close up of Shape Detail

You can set the line width as required for your design; however, as the width increases, the shape 
resolution decreases. Referring to the example in the preceding figure, as the outline line width of a 
copper shape increases, the outer edge of the lines remain in place and the inner edges expand inward. 
The result appears in Figure 49.
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Self-Intersecting Polygons

Figure 49. Shape Detail with Increased Line Width

If you set the outline line width too wide, the centerlines of two edge segments may overlap one another, 
resulting in a self-intersecting polygon.
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Figure 50. Overlapping Centerlines

Note:
The overlap is most visible when you turn on copper flooding.

Keep in mind that a self-intersecting polygon can occur with planes created from the board outline shape 
when the plane area shrinks by the clearance value. Similarly, a self-intersecting polygon can also occur 
when using the auto separate functionality because of the auto separate gap.
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Modification of Drafting Objects
After adding drafting objects to a design, you can move, edit, or delete them as your design needs 
change.

The following video demonstrates fundamental steps for modifying drafting objects.

Moving a Drafting Object
Modifying Drafting Object Segment Properties
Modifying Drafting Corner Properties
Setting the Origin of a Drafting Object
Drafting Object Properties
Pulling an Arc from a Drafting Segment/Corner
Deleting a Drafting Segment or Object

Moving a Drafting Object
You can move a whole drafting object while maintaining its shape.

Restrictions and Limitations

• You cannot modify, move, or delete a polygon that is part of a physical design reuse.

Procedure
1. Select the drafting object to move using one of the following methods:

Note:
You must turn off flooding before you can select a shape.

SailWind Router Guide 241

https://video.sw.siemens.com/embed/5fd30d2f-b900-4866-9f51-8c35eeb8be9e


Copper Planes and Copper Shapes
Modifying Drafting Object Segment Properties  

• With nothing selected, right-click and choose the Select Shapes  popup menu item; then click 
on a segment of the object. (The Select Shapes  selection filter setting is the best filter for 
selecting a drafting object.)

• Select a segment of the object, right-click, and then choose the Select Shape  popup menu 
item.

• Shift-click a segment of the object.

2. Right-click and choose the Move  popup menu item. Alternatively, you can drag the selected object, 
if allowed by your Drag moves setting  on page 441.

The shape attaches to the cursor by the Move preference setting  on page 441.

3. If you need to make additional changes to the drafting shape before you move it, right-click and 
choose the Rotate 90, Rotate Group 90, Spin, Flip Horizontal, or Flip Vertical  popup menu 
items.

4. Move the drafting object to its new location and click to place it.

Modifying Drafting Object Segment Properties
You can edit or change the properties of copper shape, keepout, copper plane, and copper plane cut out 
segments.

Procedure
1. Right-click and click Select Anything  as your selection filter.

2. Click a copper, keepout, copper plane, or copper cut out segment to select it.

3. Right-click and choose the Properties  popup menu item. The “Copper Segment dialog box”  on 
page 478, “Keepout Segment Properties dialog box”  on page 496, Copper Plane Segment 
dialog box, or the Copper Cut Out Segment Properties dialog box  on page 474 opens, displaying 
the drafting object type, coordinates, and dimensions.

Tip
Some of the options in this dialog box are unavailable if the segment is part of a physical 
design reuse.

4. Modify the segment coordinates and arc settings as desired; then click OK.

Modifying Drafting Corner Properties
You can edit or change the properties of drafting object corners, such as location.

Procedure
1. Right-click and click Select Anything  as your selection filter.

2. Select a corner of a drafting object, right-click, and then choose the Properties  popup menu item.
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Setting the Origin of a Drafting Object

3. In the X and Y boxes, type the X and Y location of the drafting corner.

4. Click OK.

Setting the Origin of a Drafting Object
You can set the origin of a drafting object to move it or place it.

Procedure
1. Select the whole drafting object.

Tip
Right-click an object and click the Select Shape  popup menu item or press the Shift key 
and click a segment to select the whole drafting object.

2. Right-click and click the Set Origin  popup menu item.

3. Click to set the new origin point. A message displays, prompting you to confirm the origin point.

4. Click Yes  to change the origin point or click No  to use the previous origin point.

5. Press the Esc key to exit the Set Origin mode.
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Drafting Object Properties
You can select and edit drafting shapes in pieces or as whole items. The properties you can modify 
depend on whether you select a corner of the drafting object, an edge of the drafting object, or the whole 
object.

Changing Line Widths
Changing Layers

Changing Line Widths
You can modify the line width of drafting object outlines and fill lines as applicable.

Procedure
1. Select a drafting item, right-click, and then choose the Properties  popup menu item.

2. Type a new line width value in the Width box of the Properties dialog box.

3. Click OK.

Changing Layers
You can change the layer on which the drafting object exists.

Procedure
1. Select a drafting item, right-click, and then choose the Properties  popup menu item.

2. Select a new layer from the “Located on layer” dropdown list of the Properties dialog box.

3. Click OK  The drafting item moves to the new layer.

Pulling an Arc from a Drafting Segment/Corner
Use the Pull Arc command to convert a drafting segment or corner into an arc. The starting points of the 
drafting segment become the start and stop angle for the new arc.

Procedure
1. Select a segment or corner, right-click, and then click Pull Arc.

2. The segment or corner attaches to your pointer and changes to an arc.

3. Click to indicate the new position for the arc.

Tip
You cannot modify, move, or delete a polygon that is part of a physical design reuse.
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Deleting a Drafting Segment or Object
If desired, you can delete drafting segments or objects from your design.

Procedure
1. Select the segment or object. See “Selection of Drafting Objects”  on page 249.

2. Choose one of the following to delete the segment or object:

• Press the Delete key

• Choose the Edit > Delete  menu item

• Right-click and choose the Delete  popup menu item.

Tip
You cannot modify, move, or delete a polygon that is part of a physical design reuse.

Copper Voids
Voids in copper planes represent gaps or missing areas in the copper fill. You can create and delete voids 
as necessary to accommodate any changes required to the copper plane.

A void is an integral part of the copper plane, and it behaves as part of the plane. If you move the plane, 
for example, the void moves with it. Conversely, a copper plane cut out is separate from the plane. 
Although you can select and move a cut out, you cannot move it by moving the copper plane.

Voids and cut outs appear the same when you flood the copper plane.

Figure 51. Voids in a Copper Plane Before and After Flooding
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You create a void in a copper plane by subtracting one enclosed polygon from within another. You can 
remove a void later by deleting it. For more information, see “Creating Voids in Copper Planes”  on 
page 246.

If you subtract a copper plane cutout from a copper plane, it becomes a void.

Creating Voids in Copper Planes
You can subtract a copper plane from another copper plane to create a void. You can also delete that void 
later if desired.

Prerequisites

• Place the software in copper plane outline mode by turning off copper plane hatching (using the 
Pour Outline (PO) command). If you do not turn off copper plane hatching, the shapes you create 
within a copper plane appear to be voids but the software treats them as cut outs instead.

Video
The following video demonstrates how to create copper planes and voids.

Procedure
1. Create the outline of the void by drawing another copper plane or cut out within the boundaries of 

the first copper plane. You can create a polygon, circle, or rectangle by right-clicking and choosing 
the desired shape from the popup menu.

Note:
You must draw the void within the boundaries of the first copper plane or the software 
cannot qualify it as a void.

a. In the Copper Plane Properties dialog box, ensure the shape of the intended void is on the 
same layer as the copper plane.

b. Click OK.

2. Press the Esc key to exit the copper plane drawing mode.

3. Click the outline of the copper plane to select it; then, on the Drafting Operations toolbar, click the 
Subtract Shapes  button. 

Alternatively, right-click and choose Subtract Shapes  from the popup menu item.
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Deleting Voids in Copper Planes

Either method places the software in shape subtraction mode, as indicated by a dashed line 
highlighting the copper plane.

4. Click the shape you want to use as the void. You can select more than one shape.

5. Press the Esc key to exit the shape subtraction mode when you are finished selecting shapes.

6. Enable copper plane hatching using the Pour Outline (PO) command and verify the void is formed 
properly.

Related Topics
Deleting Voids in Copper Planes

Deleting Voids in Copper Planes
You can remove voids from copper planes.

Prerequisites

• You have already created a void in a copper plane.

Procedure
1. Turn off the copper plane hatching using the Pour Outline (PO) command.

Note:
You must turn off copper plane hatching to select shape segments.

2. Select one or more segments of the void, and then right-click and choose the Delete Void  popup 
menu item.

Related Topics
Creating Voids in Copper Planes

Creating Nested Copper Planes
You can create a copper plane within another “outer” copper plane. You create a copper void inside the 
outer shape and then create the new nested copper plane inside the copper cut out.

Note:
You can alternatively create a distinct, nested shape by giving it a different flooding priority than 
the underlying copper plane. See “Options Dialog Box, Flooding Category”  on page 447.
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Procedure
1. In the outer copper shape, “create a copper void”  on page 246 of appropriate size and shape 

within the outer shape.

2. Create the new nested copper plane  on page 229 within the copper void.

Results
The new nested copper plane appears inside the void of the outer copper plane.
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Selection of Drafting Objects
Drafting objects are made up of the line segment outlines and sometimes fill. At times, you want to select 
a segment, and at other times, you need to select the whole outline.

Selecting Drafting Object Outlines
Selecting Whole Drafting Objects

Selecting Drafting Object Outlines
Select the outlines of a drafting object to move the outline and change the shape of the object.

Procedure
1. Right-click and choose the Select Anything  popup menu item.

2. Click the outline of the shape.

3. Right-click and choose a command from the popup menu to alter the segment as needed.

Selecting Whole Drafting Objects
Select the outlines of a drafting object to move the object or change its properties.

Note:
You must turn off copper flooding to select shapes and shape segments.

Use one of the following methods:

• With nothing selected, right-click, choose the Select Shapes  popup menu item, and then click the 
object.

• While in Select Anything mode, shift-click along the outline of the object.

• While in Select Anything mode, drag a selection box over the entire outline of the object.
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Chapter 16
Routing Setup

An important step before routing your design involves optimizing the topology and net distribution, and 
setting routing restrictions. Also important is defining how you want to add fanouts and test points to the 
design.

Routing Settings
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Routing Settings
SailWind Router offers a broad selection of setup options and constraints for configuring your design to 
achieve exceptional routing results.

Performing Length Minimization
Rescheduling Nets
Split/Mixed Plane Layer Setup
Routing on Split/Mixed Layers
Routing with Layer Restrictions
Routing with Restrictions on Component Layers
Routing on Restricted Component Layers Assigned as Split/Mixed Planes
Working with Advanced Vias
Working With Fanouts and Partial Vias
Setting and Tuning Length Constraints Options

Performing Length Minimization
Length minimization  examines the design and assesses the current topology settings of the nets. Using 
these settings, SailWind Router reorders the nets to establish the shortest length between each of the 
connection points.

Procedure
1. Click the Tools > Length Minimization  menu item.

2. Length minimization runs with the default topology type or the topology type you set on the 
Topology  tab of the Properties dialog box.

Related Topics
Properties Dialog Box, Topology Tab

Rescheduling Nets
Net rescheduling lets you change distribution of unroutes without using SailWind Layout ECO operations. 
You can move one end of an unroute from the current source pin or virtual pin to another pin. You can 
reschedule nets even if a net topology has a type of “Protected” as assigned in the Topology  tab of the 
Design Properties or Net Properties dialog boxes.

CAUTION:
The net must contain unroutes to reschedule it.

Restrictions and Limitations
You cannot reschedule the following unroutes:
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• Unroutes connected to copper planes or T-junctions.

• Unroutes that span subnets.

• Unroutes belonging to differential pairs. You can reschedule differential pairs only if an unroute 
exists in each pair member.

Procedure
1. Select an unroute then right-click and click the Reschedule  popup menu item.

Everything in the workspace dims except the unroutes, pins, virtual pins, and protected vias that 
are valid end points for rescheduling.

2. Point to the pin where you want to reconnect the unroute. You can reconnect to pins or protected 
vias if they belong to the subnet of the selected unroute and if the connection maintains net 
integrity.

When you find a valid connection point, the pointer graphic changes to a double-circle with a cross 
hair through it. In addition, a ToolTip appears informing you that the pin is available for connection
—or if not, why.

3. Click to complete the rescheduling.

4. When you complete rescheduling, the net automatically switches to a Protected topology type (on 
the Topology  tab of the Net Properties dialog box).

Tip
When you reschedule an unroute in a differential pair, a parallel rescheduling is performed 
in the other member of the pair. You can click Undo  on the standard toolbar to undo this 
parallel rescheduling.

Split/Mixed Plane Layer Setup
SailWind Router routes on split/mixed plane layers only if the layer has an open area not covered by a 
plane area.

Scenario 1
All nets assigned to the layer have a plane area polygon. Open space is available for routing on the layer.
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Scenario 2
No nets assigned to the layer have a plane area polygon. No open space is available for routing on 
the layer. The entire layer is reserved for plane areas. Pre-routing analysis posts the following warning 
to the Output window in this situation: “Split/mixed layers <named layers> have automatically created 
plane areas. SailWind Router will route only assigned nets on these layers. To correct the problem, use 
SailWind Layout to define plane area polygons.”

Scenario 3
Some nets, but not all, that are assigned to the layer have plane area polygons.  No open space is 
available for routing on the layer. The space without plane area polygons is reserved for plane area 
polygons of the nets assigned to the layer that do not yet have polygons. Pre-routing analysis posts 
the following warning to the Output window in this situation, “Split/mixed layers <named layers> have 
automatically created plane areas. SailWind Router will route only assigned nets on these layers. To 
correct the problem, use SailWind Layout to define plane area polygons.”
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Note:
Nets with polygons route to the plane area. The nets with no polygons route to the plane layer  as 
if the entire layer is one shared plane area. Therefore, a pin from a net with no polygon can be 
fanned out to a point inside a plane area polygon defined for another net. While nets will not short 
because the plane processing in SailWind Layout prevents it, this fanning out can lead to isolated 
thermals.

Scenario 4
Nets are assigned to the Split/Mixed plane layer and polygons exist on the layer, but the layer has been 
temporarily changed from a Split/Mixed layer to a Routing layer in SailWind Layout. The whole layer is 
available for routing. For instructions and tips, see “Routing on Split/Mixed Layers”  on page 256.
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Routing on Split/Mixed Layers
Plane areas on Split/Mixed Layers form obstacles to routing; therefore, you must take certain steps to 
permit routing on Split/Mixed layers.

Restrictions and Limitations

• Plane area polygons are obstacles to routing. Nets assigned to the layer without polygons flag 
the entire layer as a polygon. For more information see “Split/Mixed Plane Layer Setup”  on 
page 253.

• When you define a component layer as a split/mixed plane layer, the layer will be used for 
connecting SMD pins, through hole pins or vias.

Procedure
1. In the Design Properties, on the Layers  and Layer Biasing  tabs, enable the layers for routing.

2. To permit routing on the Split/Mixed plane layers, you must do one of the following:

a. Create plane area polygons for all nets assigned to the layer leaving open space for routing on 
the layer or plane area cutouts for the areas in which you want to permit routing.

b. Temporarily set the layer as a No Plane layer in the SailWind Layout, Layer Setup dialog:

i. On the Standard toolbar, click the Layout  button to open the design in SailWind Layout.

ii. Choose the Setup  > Layer Definition  menu item.

iii. Select the Split/Mixed layer and click the Assign Nets  button.

iv. Because the assigned nets will be lost, record the net names assigned to the layer and then 
close the Plane Layer Nets dialog box. Polygon shapes do not lose their net assignments.

v. In the Plane Type area, click No Plane and click OK.

vi. On the Standard toolbar click the Route  button to open the design in SailWind Router.

3. Route the design as required. If autorouting, it might be helpful to assign a high Cost to the Split/
Mixed layer to prefer routing on other layers when possible. You set the Cost value in the Design 
Properties on the Layers  tab.

4. If you followed instructions above to change the layer type to a No Plane layer, reverse that 
process:

a. Open the design in SailWind Layout to set the layer as a Split/Mixed layer.

b. Reassign the nets to the layer. The plane area polygon outlines automatically re-inherit the 
correct net name assignments.
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Routing with Layer Restrictions
A routing-restricted layer is any electrical (but non CAM) plane layer that you disable for routing. This 
includes a component mounting layer specified as a split/mixed plane.

You can define routing with layer restrictions in two ways:

• Define a layer bias design rule. This rule limits the layers upon which you can route traces for 
nets, net classes, groups, pin pairs, or all net objects, when it is assigned as a default routing 
rule.

• Restrict an electrical layer in the Layers  tab of the Design Properties dialog box.

Typically, you restrict a layer or bias net objects to avoid routing traces on specific layers. For example, 
you may want to disable the outer layers of the board and route traces mostly on internal layers to reduce 
the incidence of cross talk. You can assign layer bias rules to achieve the same result, but this limits the 
application to objects rather than restricting all routing from a specific layer in the design.

Related Topics
Setting Layer Biasing Rules

Setting Layer Rules

Routing with Restrictions on Component Layers
You can set up your design to impose layer restrictions that control which layers allow routing.

The following figure shows how this routing program would route a net containing only SMD pins with no 
layer restrictions, and how it would route the same net when you impose layer restrictions.

Figure 52. Possible Routing Patterns

When you impose a layer restriction that excludes routing from component layers, routing is not 
eliminated on the component layers completely. If the restriction is respected literally, SMD pins on the 
restricted component layer may remain unconnected. Therefore, restrictions are respected for component 
layers as a soft rule to allow routing to SMD pins.
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Routing on Restricted Component Layers Assigned 
as Split/Mixed Planes
If you choose to restrict routing on component layers designated as split/mixed planes, split/mixed plane 
area polygons are treated as obstacles. However, the program routes inside split/mixed plane area 
polygons on component layers to allow connections to SMD pins.

The following figure illustrates the principle:

Figure 53. Split/Mixed Plane with Space Available for Routing

Working with Advanced Vias
To support advanced via designs, SailWind Router routes within split plane areas on split/mixed plane 
layers. SailWind Router limits the trace length and routes only when blind or buried via configurations 
exist. Short traces route automatically between partial vias to complete routing of nets with partial vias on 
split/mixed planes.

When working with advanced vias:

• SailWind Router does not permit CAM planes routing layers for either autorouting or interactive 
routing operations.

• You can use assigned vias for routing only if these vias start or end on the split/mixed planes, but 
this does not guarantee that traces connecting the vias will be the shortest possible. Some other 
routing operations may adjust plane traces resulting in increased length.

Figure 54  shows an example design of three layers with an internal split/mixed plane layer. The design 
has only two blind vias that connect layer 1 to layer 2 and layer 2 to layer 3. The graphic on the left shows 
routing results without using partial vias and the graphic on the right shows routing results when partial 
vias are used. To achieve the best results, the router places a trace on the split/mixed plane layer.
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Figure 54. Three-Layer Design with a Split/Mixed Plane Layer

Working With Fanouts and Partial Vias
SailWind Router works well when you use through-vias during fanout operations. You can fan out SMD 
pins using a single through-via to provide access to the SMD on all layers.

With partial vias, however, SailWind Router does not produce proper fanouts. A single via is not sufficient 
for use with partial vias because only one via is added, spanning only a limited number of layers. To 
resolve the issue of limited access for fanout operations, the fanout autorouter pass adds more vias to 
enable access to all layers, except opposite layers.

For example, if the plane is on the second layer for a six-layer design, SailWind Router adds partial vias 
to connect the pin to the second layer and connect the second layer to all other layers except the last.

Figure 55. Six-Layer Design with Partial Vias

Tip
Any nets assigned to an internal plane layer are dispersed with partial vias, which does not add 
enough vias to connect to the plane layer.
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Setting and Tuning Length Constraints Options
SailWind Router offers sophisticated length tuning options that allow you to create length constraints for 
individual nets as well as classes, groups and differential pairs.

Setting Up Routing to Length Constraints
Setting up Differential Pairs Tuning Options

Setting Up Routing to Length Constraints
Use routing-to-length constraints to adjust the length of length-controlled traces. SailWind Router 
automatically maintains length-based design rules for nets, electrical nets, classes, pin pairs, groups, and 
differential pairs during autorouting according to the constraint settings you set in the Routing  category > 
Tune  subcategory of the Options dialog box. The software adjusts or rips up traces during the tune pass 
based on their compliance with minimum and maximum trace length rules. If necessary, SailWind Router 
increases net and pin pair lengths to satisfy length rules by introducing accordion patterns to the trace 
(during the tune pass).

Tip
You can set length rules in Class, Net, Electrical Net, Pin Pair, Differential Pair, and Matched 
Length Properties dialog boxes.

Procedure
1. Click the Tools >  Options  menu item; then, in the Options dialog box, click the Routing  category 

> Tune  subcategory.

2. In the Minimum amplitude box, type a number to specify the minimum height or width for any 
accordion pattern that SailWind Router uses.

3. In the Maximum amplitude box, type a number to specify the maximum height or width of any 
accordion pattern that SailWind Router uses.

4. In the Minimum gap box, type a number to define the distance between accordions.

5. In the Max hierarchy level box, type a number to specify how many steps SailWind Router uses to 
create accordions. For additional information, see “Maximum Hierarchy Level” in the Tune Pass.  on 
page 272

6. In the Miter ratio box, type a number to specify the miter ratio for accordion corners.

7. To use an arc instead of a diagonal segment in the accordion, click “Use arcs in miters.”

8. To determine how much extra length is added above the required matched length group tolerance 
(in percent of the tolerance), type a number in the Extra length added above required by matched 
length group tolerance box.

Tip
Example: If you type 0, the tuned net will be <Leader length - tolerance> length. If you type 
100, the net will get the same length as the group leader. The leader net is the net in the 
matched length group that has the longest length.
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9. If you need to complete traces that break length rules, click “Ignore length rules when required to 
complete traces.”

10. Click OK.

Related Topics
Add Length to Traces

Setting up Differential Pairs Tuning Options
Use the Differential Pairs area on the Routing  category > Tune  subcategory of the Options dialog box to 
control the use of differential pair accordions while tuning routing length.

Procedure
1. Click the Tools > Options  menu item; then in the Options dialog box, click the Routing  category > 

Tune  subcategory.

2. To use an accordion to make differential pairs the same length, select the “Add diff pair correction 
accordions when tuning” check box.

3. If you do not want to allow correction accordions where two traces go together at the gap, select 
the “Do not create correction accordions in gap portion” check box.

4. Select the “Create correction accordions only when length difference is greater than the matched 
length tolerance” check box if you want to restrict the software to creating differential pair 
accordions only in instances where the length difference is greater than the matched length.

5. Click OK.
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Chapter 17
Autorouting

Setting up a strategy of pass types and routing order ensures the best results when performing batch 
autorouting.

Creating a Prerouting Analysis Report
Autorouting Strategy
Autorouting Pass Types
Setting Up the Autorouting Strategy
Specifying the Passes to Route
Setting the Routing Order
Autorouting a Design
Pausing Autorouting
Resuming Autorouting
Stopping Autorouting
Routing Progress Indicator
Reporting Routing Results
Assigning Test Points During Autorouting
Autorouting Messages

Creating a Prerouting Analysis Report
The Prerouting Analysis report provides information about design properties that may impede autorouting, 
such as grid settings, nets that have a disabled routing status, or pin pairs that have a shove-protected 
status.

Procedure
1. Click the Tools > Pre-routing Analysis  menu item.

2. After the prerouting analysis finishes, review any errors or warnings that are sent to the Status  tab 
of the Output window.

Related Topics
Reporting Design Information

Autorouting Strategy
The autorouting strategy is a set of options that define how a board should be autorouted. A strategy 
contains several passes. You can autoroute the entire design using a strategy, or you can select 
components and route them one by one using a pass type.
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Note:
This section discusses autorouting the entire design and the pass types in the strategy. For more 
information on routing components one at a time, see Autorouting by Selection.

The autorouting strategy defines the sequential operations to perform during autorouting, including:

• Passes that the autorouter should run

• Pass types to run during autorouting

• Trace protection

• Pausing at the end of each pass

• Intensity of autorouting

• Order in which to autoroute components, nets, net classes, differential pairs, and matched length 
groups

You cannot save autorouting strategies. Set the strategy for each file you want to autoroute.

For more information, see ““Specifying the Passes to Route”  on page 274” and ““Setting the Routing 
Order”  on page 275.”
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Autorouting Pass Types
The strategy for autorouting contains several pass types. Each pass completes a specific task; it may also 
perform a number of subpasses.

• Prerouting Passes  — Use these passes only when necessary because they can hinder routing 
completion. The default strategy starts with the Route pass and skips these prerouting passes.

◦ Fanout pass  — Only for complicated or dense components, like BGAs. If you use the Fanout 
pass for the entire design, the resulting fanouts occupy too much space on the board. As a 
result, routing becomes more difficult, more vias are placed, more time is needed to route, 
and completion rates drop.

◦ Patterns pass  — Only for boards with extremely regular connections. You can also use this 
pass to create several versions of the design, for comparison.

• Postrouting Passes  — Center, Optimize, Miters, Test Point, and Tune are postrouting passes. 
The Intensity setting in the Strategy  tab significantly affects these passes. For more information, 
refer to ““Autorouting Strategy”  on page 263.”

Center Pass
Fanout Pass
Miters Pass
Optimize pass
Patterns Pass
Route Pass
Tune Pass

Center Pass
The center pass automatically places traces equidistant from the pads of adjacent component pins or vias 
to evenly distribute any available space in the channel. Centering does not violate design rules.

SailWind Router maintains differential pairs during centering. The shoulder portions of the differential pair, 
in the start and end zones, center as normal trace segments. The segments in the controlled gap portion 
center as one wide trace. Differential pairs that are split around obstacles do not center.

A channel is eligible for centering if a projected path from the pins or vias overlaps.
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Figure 56. Channels Eligible for Centering

To limit the number of channels to center, set a maximum channel width. Any channel larger than this 
width is not eligible for centering. Set the Maximum channel width on the Routing  tab of the Options 
dialog box.

The following are restrictions for the center pass:

• The Center pass only centers traces that are parallel to the channel orientation.

• The software centers traces by “stretching” the segments that are perpendicular to the channel. 
Trace centering does not take place if no perpendicular traces are available or if they do not have 
enough space to stretch.

• The Center pass does not add corners to achieve centering.

• The Center pass can only adjust traces that pass through a channel. It cannot adjust a nearby 
trace to accommodate centering.

• The Center pass does not adjust any angle trace segments.

• The Center pass does not maintain length rules or accordions. The Center pass adjusts trace 
segments that are part of accordions as regular trace segments; it does not preserve the 
accordion. However, it does not perform centering if it results in new errors.

For more information, refer to the Centering value in the ““Options Dialog Box, Routing Category, General 
Subcategory”  on page 450” and ““Autorouting Strategy”  on page 263.”

Fanout Pass
By performing the fanout pass, you shorten overall autorouting times and increase completion rates 
because this pass creates access to pins early in the process.

This pass places vias for inaccessible SMD component pins and routes from the vias to the pins. This 
pass locates all SMD pins in the design and routes a short trace, terminated with a via, from each pin. Set 
options for the fanout pass on the “Properties Dialog Box, Fanout Tab”  on page 486.
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Tip
Protect any fanouts you create to prevent post-fanout routing or editing operations from shoving 
or rerouting the fanout traces. These post-fanout operations ignore Fanout length settings in the 
Fanout  tab of the Properties dialog box.

The fanout pass includes two processes: preplaced fanouts and free fanouts.

Preplaced Fanouts
This process tries to place vias that obey the current minimum spacing rules and the via spacing you set. 
If the via placement violates a rule, SailWind Router does not place the via and does not create a fanout 
for the pin. After successfully placing vias, SailWind Router routes the fanout.

You can specify whether vias are placed on a fixed grid or spaced to accommodate one trace or two 
traces running between them. Set the spacing using the Via Spacing options in the Fanout  tab of the 
Properties dialog box.

You can also specify whether pins and vias are shared to complete the fanout. You can fanout a number 
of pins by interconnecting them to a single, common via. Set this sharing feature through the Sharing 
options in the Fanout  tab (of the Properties dialog box).

You can also customize the fanout pattern for vias to help avoid obstructions or unusable board areas. 
Set patterns in the Alignment list and Direction list in the Fanout  tab.

Figure 57. Customizing the Fanout Pattern

Free Fanouts
The free fanouts process completes fanouts that failed the prerouted fanouts process by searching for a 
path, using push and shove, and using “rip up” and “retry” features to make room for the fanout, as shown 
in the following figure. The free fanouts process ignores pattern settings to complete the fanout.
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Figure 58. Free Fanouts Process

Miters Pass
The miters pass converts all route corners of a specified angle to diagonal corners. You can set Miter 
options on the Routing  tab of the Options dialog box. Depending on the settings in the Routing  tab, you 
can convert a corner of any degree corner to a miter.

SailWind Router adds miters to trace corners only when space permits. If a miter creates spacing or first 
corner rule violations, the software skips the corner and does not add a miter.

If you choose to use arcs for miters, the software creates a miter using the following calculation: <trace 
width> / 2 X ratio

Small segments and clearance violations provide two reasons to use arcs as miters.

If a trace has small segments, and it is impossible to create miters that are large enough, SailWind Router 
creates an arc for the three segments:

If it is impossible to create an arc of the required size because of a clearance violation, the software does 
not perform any pushing and plowing or trace adjustment. It creates a smaller arc instead:
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Miters and Length Tuning
Tune operations assume traces are smoothed before you add accordions. If tuning is performed before 
the miter pass, the addition of miters changes the length of traces, potentially creating length violations. 
SailWind Router tries to add/remove length differences on the first parallel segments of modified traces or 
other traces belonging to the same net if it is required.

For differential pairs, miters can cause different violations on traces. In this case SailWind Router tries to 
adjust length of the controlled gap portion common for the both traces, as well as shoulders for each trace 
separately.

Optimize pass
The optimize pass analyzes each trace and tries to improve the quality of the route pattern by removing 
extra segments, reducing via usage, and shortening trace lengths. The optimize pass includes these 
processes: via minimize, glossing, and smoothing.

Via Minimize
The via minimize process reduces via usage in the design by ripping up existing traces and finding a new 
path that uses fewer vias, as shown in the following figure.

Table  62. Via Minimize Process

Before Minimize After Minimize

Glossing
The glossing process reduces the Manhattan Ratio for traces, as shown in the following figure.
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Table  63. Glossing Process

Before Glossing After Glossing

Smoothing
Smoothing removes unnecessary corners and segments in traces while maintaining the same path. 
Smoothing can also reduce length, which not only frees up room on the board for additional traces, but 
also helps meet and maintain pad entry and first corner rules.

The smoothing process does the following:

• Reduces the Manhattan ratio.

• Improves pad entryand trace junctions.

• Optimizestrace patterns without changing their topology.

• Eliminates same net trace crossings that push-and-shove processes can leave.

• Eliminates same net trace-to-corner violations by connecting the trace directly to the pin.

• Eliminates same net trace-to-trace violations.

Tip
Smoothing does not maintain length rules on length-controlled traces.

Table  64. Smoothing Process

Before smoothing After smoothing

For more information, refer to ““Interactive Routing Setup”  on page 291” and ““Trace Smoothing”  on 
page 351.”
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Patterns Pass
The patterns pass searches for groups of unrouted connections that it can complete using typical C 
routing patterns, Z routing patterns, and memory patterns. The patterns pass then routes them.

Figure 59. Patterns Pass

During the patterns pass, a bounding box surrounds the group of unroutes to pattern route. If enough 
space exists to create traces and obey clearance rules, SailWind Router creates the pattern. If obstacles 
appear within the bounding box or if the pattern violates rules, the pattern fails.

Figure 60. Bounding Box During a Patterns Pass

For C patterns, the pins that form the C pattern must align along the X-axis or Y-axis or the pattern fails.

Figure 61. C Patterns During a Patterns Pass

Route Pass
The route pass is the core pass, which performs the majority of autorouting. During this pass, SailWind 
Router tries to sequentially route each unroute until it has tried all connections. The route pass contains 
many processes -- serial, rip up and retry, push and shove, and touch and cross.
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The following table displays the Route pass processes.

Table  65. Route Pass Processes

Process Action

Serial Converts unroutes to traces by finding the shortest path around the 
obstacles between the end points of the unroute. No obstacles can exist in 
the path.
If a path is not found, SailWind Router skips the unroute.

Rip Up and Retry Increases completion rates by unrouting existing traces and finding new 
paths to create space for other traces.
If SailWind Router cannot find a a new path, it cancels the process and 
returns the trace to its original state.

Push and Shove Pushes traces aside to create room for new traces. The software performs 
this process together with the rip up and retry process.

Touch and Cross Eliminates touch and cross violations that are created by other autorouting 
operations that create or modify existing traces or patterns.
For example, the push and shove process may force a trace to “hop” over 
a pin, creating a cross violation for the trace exiting the pin. This process 
successively attempts to reroute the trace to eliminate the violation.
If the software cannot resolves a violation, it cancels the operation and 
returns the trace to its original state.

Tip
SailWind Router performs this process with all other passes and processes. It will not complete a 
trace with a violation. It either removes all violations or it cancels trace routing.

Tune Pass
The tune pass adjusts the length of length-controlled traces. The pass only examines trace lengths for 
completely routed nets, electrical nets, pin pairs, or differential pairs and analyzes the current length if you 
have enabled length rules and length control.

The tune pass makes adjustments based on the following conditions:

• If the cumulative length of the adjacent trace segments is within the range of minimum and 
maximum trace length, the tune pass skips the trace and does not adjust it.

• If the trace is longer than the maximum trace length, the tune pass rips it up and places it in a 
queue for routing.

• If the trace length is less than the minimum trace length, the tune pass changes the length by 
adding accordion patterns.

• If only one member of a differential pair meets the matched length group rule, the pair is 
considered mismatched and the tune pass adjusts the noncompliant member of the pair.
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• If the length delta between members of a differential pair is greater than 300 mils, the tune pass 
skips the pair, leaving it in its previous state (either unrouted or untuned).

Tip
When tuning a differential pair, SailWind Router adds small accordions in the Shoulder 
area of the shorter trace, without plowing or shoving obstacles. If the Shoulder areas 
cannot accommodate the small accordion, SailWind Router adds the accordion in the 
Controlled gap area, as close as possible to the Shoulder area.

Figure 62. Before and After Length Adjustment

Maximum Hierarchy Level
Length adjustments are created in stages. The first stage is a regular horizontal or vertical accordion. If 
this is still not enough length, the accordion direction is turned 90 degrees and an additional accordion is 
created. SailWind Router will continue adding the accordions at 90 degrees until the length adjustment is 
met, or until the maximum hierarchy level is met.

Regular Accordion Accordion with 90 degree 
accordion added

Accordion with a Maximum 
Hierarchy Level of 3

By default, Maximum Hierarchy Level values are set to 8 in designs created before PADS Router 9.0.

Setting Up the Autorouting Strategy
SailWind Router offers extreme flexibility in setting up an autorouting strategy. You can choose from 
a series of specific routing pass types to accomplish your desired autorouting tasks. You can also 
systematically set up your routing strategy to specify the order in which SailWind Router routes specific 
design objects.
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For example, you could set up a strategy to perform the following:

• Fanout specific high pin count components and protect the routes

• Fanout the rest of the components

• Route critical signals such as clocks

• Route the power nets

• Route all of the nets associated with a specific component

• Route the data bus on specific layers for return path control

• Route the address bus on specific layers for net distribution control

• Route the differential pairs nets on specific layers for impedance control

• Route the balance of miscellaneous nets on specific layers

You have complete control over the routing order, the routing pass intensity, and the ability to start, stop, 
pause, and inspect your routing results at any point in the process.

Specifying the Passes to Route
Use the Routing  category > Strategy  subcategory to specify which passes to run, the routing intensity to 
use, whether or not to protect the generated traces, and whether to pause after a pass completes.

Procedure
1. Click the Tools > Options  menu item; then, in the Options dialog box, click the Routing  category > 

Strategy  subcategory.

2. In the Pass column, select each pass type you want to run. You can run any combination of 
passes.

3. Select the “Protect” check box (In the Protect column of the table in the “Pass definition” area) if 
you want SailWind Router to protect any generated traces after performing the selected pass. For 
example, select the Protect check box for the Center pass type if you want SailWind Router to 
protect trace changes generated during the Center pass. (This protects traces and glues vias that 
are completed during the corresponding pass type.)

4. In the Pause column, select the pass check box if you want SailWind Router to pause routing after 
completing the corresponding pass.

5. In the Intensity column, select the appropriate intensity.

Intensity  determines the effort and time the router can spend on a pass. You cannot set an intensity 
for the Center pass.

6. Set the routing order  on page 275.
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7. Click OK.

8. After defining your strategy, click the Start Autorouting  button on the Routing toolbar to autoroute 
the design.

Results
If the Options dialog box is open, a check mark appears in the Done column for each pass that 
completes. The check marks remain in the Routing  category > Strategy  subcategory until you modify the 
autorouting strategy, or restart autorouting. This is a read-only column; you cannot manually mark a pass 
as complete.

The strategy is saved by default in the \SailWind Projects  folder.

Related Topics
Setting the Routing Order

Autorouting a Design

Autorouting Pass Types

Setting the Routing Order
Use the Routing order list to specify the order in which to autoroute components, nets, net classes, 
differential pairs, and matched length groups for the selected pass.

Restrictions and Limitations
Certain object types within the Routing order definition pane are not valid for routing order operations. The 
Selected  button is available only when components, nets, net classes, differential pairs, and matched 
length groups are selected either in the object view pane, in the design itself, or in the Routing order 
definition pane.

Procedure
1. Click the Tools > Options  menu item; then, in the Options dialog box, click the Routing  category > 

Strategy  subcategory.

2. In the Pass Type column (of the “Pass definition” table), click the pass type for which you want to 
set the routing order. The default routing order appears in the Routing Order box below the table.

3. To add items to the routing order, do any of the following:

• To add all nets associated with plane layers, click Plane Nets.

• To add all nets, click All Nets.

• To add individual nets, select the component or nets to add in the left pane (Routing order 
definition), and then click Selected.

• To remove all items from the Routing Order list, click Clear.

You can also add nets attached to components to the routing order, using the following:
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• Object View tab of the Project Explorer— You add nets from the Object View  tab in exactly 
the same way as you add them using the Routing order definition list.

• The work area— Make sure you make nets available for selection on the Selection Filter 
toolbar.

4. Use the Routing Order pane buttons to delete and move items.

5. Click OK.

Results
The routing strategy is saved in the \SailWind Projects  folder. When you autoroute the design, these 
settings are used. If the dialog box is open, a check mark appears in the Done column upon completion of 
each pass.

Related Topics
Autorouting Strategy

Autorouting a Design

Autorouting a Design
The Autoroute command starts the autorouter and begins performing the routing algorithms and passes 
you specify in the Options dialog box > Routing  category > Strategy  subcategory.

Restrictions and Limitations

• You cannot autoroute a design that has no board outline or has a board outline that is not a 
closed shape. Attempting to do so results in a “Cannot route design with open board outline” error 
message. Use SailWind Layout to create the board outline.

• If you choose to autoroute a design before you set a strategy  on page 263, a message appears 
prompting you to set a strategy.

• When you Autoroute a selected object, the All Nets setting in the routing order (set in the Options 
dialog box > Routing  category > Strategy  subcategory) is ignored.

Procedure
On the Routing toolbar, click the Start Autorouting  button or click the Tools > Autoroute >  Start  menu 
item. When you start autorouting or running pass types on selection, the program performs a prerouting 
analysis and reports any errors or warnings to the Status  tab of the Output window. If you want to correct 
any of the reported issues, you must first stop autorouting.

Pausing Autorouting
Use Pause to pause autorouting between passes to check—for example—on statistics and completion 
rates before continuing or canceling the autoroute. The Pause feature stops routing at the end of 
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the current subpass. SailWind Router stores the pass and point within the pass so you can resume 
autorouting from the point where you paused.

Procedure
1. On the standard toolbar, click the Routing toolbar  button.

2. Click the Pause  button.

Resuming Autorouting
Use Resume to start autorouting after pausing. Routing begins at the subpass where you paused. Use 
Stop to end autorouting.

Procedure
1. On the standard toolbar, click the Routing  button.

2. Click the Resume  button.

Stopping Autorouting
Use Stop  to end autorouting at any time. The Stop  button ends routing at the end of the current 
connection. SailWind Router then clears all of the Done check boxes in the Options dialog box > Routing 
category > Strategy  subcategory.

You cannot resume autorouting when you choose Stop. You can only start autorouting from the beginning 
of the strategy.

Procedure
1. On the standard toolbar, click the Routing  button.

2. Click the Stop  button.

Routing Progress Indicator
The status bar contains a routing progress indicator with a ToolTip that displays the completion rate of 
each pass and subpass the router performs. This helps you assess the effectiveness of the strategy and 
the settings you selected for routing.

Reporting Routing Results
When you autoroute your design by running a pass type or by starting an autorouting command, SailWind 
Router reports two types of messages: prerouting analysis messages and routing status messages. 
These messages appear in a routing report that lists prerouting messages, the name of the design, the 
number of passes, the pass types performed, and other statistics for each pass.

The routing report, RoutingReport.txt, is located in the \SailWind Projects  folder. A link to this file is 
automatically created in the Status  tab of the Output window. You can open and view the file by clicking 
the link on the Status  tab.
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Related Topics
Autorouting Strategy

Autorouting Messages

Assigning Test Points During Autorouting
You can create an accessible net during autorouting. This process enables test point placement during 
the autorouting “Route” pass. As it adds traces, the autorouter attempts to also add test points for each 
net using vias or component pins along the net. The via or pin acts as the test point for the net whenever 
someone inserts the PCB into the Automatic Test Equipment (ATE). Adding test points during autorouting 
sacrifices completion rates for accessibility.

Procedure
1. Click the Tools > Options  menu item; then in the Options dialog box, click the Test Points 

category.

2. Select the “Create test points during autorouting” check box. Set other testability options as 
needed. For more information, see “Options Dialog Box, Test Points Category”  on page 459.

3. Click OK.

4. On the Routing toolbar, click the Start  button. When you autoroute the design, SailWind Router 
uses the test point settings.

Tip
During test point placement, SailWind Router respects test point keepouts set in SailWind 
Layout.

Related Topics
Test Points Pass

Properties Dialog Box, Test Points Tab
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Autorouting Messages
When you autoroute your design (by either using an autorouting command or running a pass type), 
SailWind Router reports two types of messages: prerouting analysis and routing status.

When autorouting completes, or when you stop autorouting, SailWind Router creates a routing report that 
details the results of the autoroute. For more information, see Routing Report.

Prerouting Analysis
Routing Status
Routing Done
Routing Progress Indicator ToolTip
Routing Report

Prerouting Analysis
When you start autorouting, SailWind Router analyzes the design for problematic conditions that may 
affect or cancel routing. Related messages appear in the Status  tab of the Output window. These 
messages appear in the Routing Report only if the entire design is routed. To correct any of the reported 
issues, you must first stop routing.

Selection Dependency
As shown in the following table, the type of prerouting analysis depends on the current selection.

Table  66. Selection Dependency

Selection Analysis Scope Analysis Content

Nothing Whole design All

Net Net Thermal status
Potential plane nets
No routing settings
Via settings
Vias to planes

Pin Pair Pin pair Thermal status
No routing settings

Unroute Unroute with adjacent pins and vias Thermal status
No routing settings for owning net

Component Pin pairs connected to component pins Thermal status
No routing settings

Pin Pin pairs connected to the pin Thermal status
No routing settings
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Routing Status
When you start autorouting, the current routing status appears. These messages appear on the status bar 
and in the Status  tab of the Output window. Routing status messages appear in the session log under the 
heading “Batch Router Statistics.” Routing status messages update with each pass and subpass of the 
router.

For more information on the session log, see “Status Tab”  on page 57.

Center Pass Messages
The following is a center pass message, whose parts are explained in the following table.

Centering gate 264/1738 (HorDir, layer6)

Table  67. Parts of a Center Pass Message

Part of Message Description

gate Current gate being processed

Dir Direction of the current gate (Hor, Vert, or 135)

layer Layer of the current gate

Fanout Pass Messages
The following is a fanout pass message, whose parts are explained in the following table.

Pins 162 of 198 (82%) Duration 00:00:31 (+00:00:20)

Table  68. Parts of a Fanout Pass Message

Part of Message Description

Pins Number of pins fanned out, followed by the total number of pins selected for fanout, 
and the fanout completion percentage in parentheses.

Duration Amount of time the router spent on this pass, followed by the total time spent 
routing in parentheses.

Tip
SailWind Router reports individually the status of fanned out pins belonging to the same island. 
For example, if three pins belong to the same island (connected with each other by traces), 
SailWind Router fans out all three pins with one shared via during the fanout pass. In this case 
the message displays three pins fanned out (Pins 3 of 3 (100%) Vias 1 Duration 00:00:01 
(+00:00:01)).
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Patterns Pass Messages
The following is a patterns pass message, whose parts are explained in the following table.

Routed 15 Total 65 of 650 (10%) Vias 181 Duration 00:01:31 (+00:01:00) 

Table  69. Parts of a Patterns Pass Message

Part of 
Message Description

Routed Number of connections routed in this pass, followed by the total number of routed 
and unrouted connections in the design, and the pattern completion percentage in 
parentheses.

Vias Number of vias added during this pass.

Duration Amount of time the router spent on this pass, followed by the total time spent routing 
in parentheses.

Route Pass Messages
The following is a route pass message, whose parts are explained in the following table.

Routed 635 Total 650 of 650 (100%) Vias 481 Duration 00:06:41 (+00:05:10) 

Table  70. Parts of a Route Pass Message

Part of 
Message Description

Routed Number of connections routed in this pass, followed by the total number of routed 
connections in the design, and the routed connections completion percentage in 
parentheses.

Vias Total number of vias added during this pass.

Duration Amount of time the router spent on this pass, followed by the total time spent routing 
in parentheses.

Optimize Pass Messages
The following shows an optimize pass message, whose parts are explained in the following table.

Optimized 5% Vias 451 (-30) Trace length 66 (-5) inches Duration 00:07:41 
 (+00:01:00) 

Table  71. Parts of an Optimize Parts Message

Part of Message Description

Optimized Optimization completion percentage.
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Table  71. Parts of an Optimize Parts Message  (continued)

Part of Message Description

Vias Total number of vias in the design, followed by the number of vias reduced by 
optimization in parentheses.

Trace Length Total length of traces routed in this pass, followed by the total length of traces 
reduced by optimization in parentheses.

Duration Amount of time the router spent on this pass, followed by the total time spent 
routing in parentheses.

Tip
Inches are used for Mils and Inches settings. Meters are used for Microns and Metric settings.

Miters Pass Messages
The following shows a miters pass message, whose parts are explained in the following table.

Trace 15 of 172 Miters 20 Duration 00:08:52 (+00:01:11)

Table  72. Parts of a Miters Pass Message

Part of Message Description

Trace Total number of traces processed, followed by the total number of traces selected 
for mitering.

Miters Total number of miters added in this pass.

Duration Amount of time the router spent on this pass, followed by the total time spent 
routing in parentheses.

Test Point Pass Messages
The following shows a test point pass message, whose parts are explained in the following table.

Accessible nets 46 of 100 (46%) Duration 00:09:52 (+00:01:00)

Table  73. Parts of a Points Pass Message

Part of Message Description

Accessible Nets Number of nets made accessible in this pass, followed by the total number of 
nets with test point requirements in the design, and the test point completion 
in parentheses.

Duration Amount of time the router spent on this pass, followed by the total time spent 
routing in parentheses.
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Tune Pass Messages
The following shows a tune pass message, whose parts are explained in the following table.

Nets tuned 25 of 32 Pinpairs tuned 78 of 500 Duration 00:04:33 (+00:03:59)

Table  74. Parts of a Tune Pass Message

Part of Message Description

Nets tuned The number of nets tuned in this pass, followed by the total number of nets 
with length restrictions.

Pinpairs tuned The number of pin pairs tuned in this pass, followed by the total number of pin 
pairs with length restrictions.

Duration Total time the router spent routing, followed by the amount of time the router 
spent on this pass in parentheses.

 

Routing Done
SailWind Router displays a message in the status bar after finishing all passes.

The following message appears in the status bar after all passes finish:

Done> Unroutes 0 Routed 164 of 164 (100%) Vias 100 Duration 00:09:52

The following table explains the parts of the message:

Table  75. Parts of the Routing Done Message

Part of Message Description

Unroutes Total number of unroutes in the design.

Routed Total number of routed links, followed by the total number of routed and unrouted 
links in the design, and the routing completion percentage in parentheses.

Vias Total number of vias in the design.

Duration Amount of time the router spent on the pass, followed by the total time spent 
routing in parentheses.

Routing Progress Indicator ToolTip
The status bar also provides a progress indicator ToolTip that displays the completion rate of each pass 
and subpass the autorouter performs. Place the pointer over the status bar during autorouting to view the 
progress indicator ToolTip. This ToolTip helps determine the effectiveness of the strategy and your routing 
settings.
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The following is an example of the ToolTip message that appears when you place the pointer over the 
status bar. A ToolTip message can have the parts shown in Table 76.

Subpass 1 of 12 Attempting 15 of 100 Complete 10 (U1.1-Via) 

Table  76. Parts of the Tooltip Message

Part of Message Description

Subpass Subpass, followed by the total number of subpasses in the current pass.

Attempting Number of connections attempted in the current subpass, followed by the 
number of connections selected for the current subpass.

Complete Number of successful attempts in the current subpass, followed by the current 
connection in parentheses.

Routing Report
A routing report is automatically created when autorouting completes or when you stop autorouting. It 
lists the name of the design being routed, the number of passes, the pass types performed, and other 
statistics for each pass. The routing report, RoutingReport.txt, is located in \SailWind Projects. A link to 
this file appears automatically in the Status  tab of the Output window. You can open and view the file by 
clicking the link tab.

Tip
The prerouting analysis messages also appear in this report, but only if routing finishes. If you 
stop autorouting, the prerouting analysis messages do not appear in the report.

For more detailed information, see The Routing Report.
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Instead of batch autorouting named design objects, you can autoroute components and nets by selecting 
them in the design. The autorouter then routes them immediately.

You can select objects whose nets you want to autoroute, and instead of using the Strategy dialog box, 
you can use a command to run a pass type on the selection. These autorouting commands are available 
on the Routing toolbar and on the shortcut menu that appears when you right-click the selected object.

The pass type SailWind Router uses when running pass types on your selections is similar to the pass 
type set in the Strategy dialog box for batch autorouting. However, you cannot change the settings for this 
pass type, and the pass types are limited to the following:

• Route  — This lets you preroute objects in specific routing modes, such as routing a BGA in 
any-angle mode, and then protecting the routes before batch autorouting the design in diagonal 
mode. Follows options set in the Routing  tab of the Options dialog box.

• Fanout  — Fans out selected components before routing the rest of the board. Follows options 
set in the Fanout  tab of the Options dialog box.

• Optimize  — Uses the highest possible intensity, to let you interactively improve critical areas of 
the design after batch autorouting.

• Tune  — Adjusts the length of selected traces (including differential pairs) or traces attached to 
selected components to meet length rules.

• Center  — Places traces equidistant from the pads of adjacent component pins or vias to evenly 
distribute any available space in the channel.

Autorouting by Selection
Running Pass Types in Object Mode
Running Pass Types in Verb Mode
Centering Traces
Assigning Test Points After Autorouting

Autorouting by Selection
You can start autorouting after you set options and preferences defining how you want to route your 
design.

Procedure
1. On the standard toolbar, click the Routing  button or click the View > Toolbars > Routing Toolbar 

menu item.

2. Select the object to route.

3. Click the Route  button.
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Tip
SailWind Router routes the net or the net attached to the selected object by using the 
settings in the Options dialog box > Routing  category > Strategy  subcategory. You cannot 
route only a pin pair or link in this program; you must route the entire net.

Note:
When you start autorouting or running pass types on selection, the program performs a 
prerouting analysis and reports any errors or warnings to the Status  tab of the Output 
window. If you want to correct any of the reported issues, you must first stop autorouting.

Running Pass Types in Object Mode
You can run a pass type on a selection, independently of any strategy settings in the Options dialog box, 
while operating in Object mode.

Procedure
1. Select the component, pin, net, unroute, or trace on which you want to perform the pass type. The 

pass type is run on the selected net or the net connected to the selected component or pin.

2. Right-click and click one of the available pass types.
Table  77. Available Pass Types for Object Types

Object Pass Type

Component Route, Fanout, Optimize, Tune

Pin Route, Fanout, Optimize

Net Route, Optimize, Tune, Center

Unroute Route

Trace Center

Tip
When you run pass types, the program performs a prerouting analysis and reports any 
errors or warnings to the Status  tab of the Output window.

Related Topics
Running Pass Types in Verb Mode

Autorouting Messages
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Running Pass Types in Verb Mode
You can run a pass type on a selection, independent of any strategy settings in the Options dialog box, 
while operating in Verb mode.

Procedure
1. On the Routing toolbar, click the pass type button you want to use: Route  on page 271, Fanout  on 

page 266, Optimize  on page 269, Tune  on page 272, or Center  on page 265.

2. Select the component, pin, net, unroute, or trace on which you want to perform the pass type. The 
selection filter automatically updates, allowing you to select only an object to which the command 
applies.

3. Click the pass type button again or press the Esc key to exit Verb mode.

Tip
When you run pass types, a prerouting analysis runs and reports any errors or warnings to 
the Status  tab of the Output window.

Related Topics
Running Pass Types in Object Mode

Setting Up the Autorouting Strategy

Centering Traces
Center is a pass of the autorouter that you can run on selected traces. The center pass places the traces 
equidistant from the pads of adjacent component pins or vias to evenly distribute any available space in 
the channel. Centering does not violate design rules.

The following figure illustrates trace centering.

Figure 63. Centering Traces— Example

To limit the number of channels to center, set a maximum channel width. Any channel larger than this 
width is not eligible for centering. Set the Maximum channel width in the Options dialog box > Routing 
category > General  subcategory.
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Procedure
1. Select a trace.

2. Right-click and click the Center  popup menu item.

Assigning Test Points After Autorouting
This process adds test points (using the test point pass) to an already routed board. This process 
sacrifices accessibility for higher completion rates.

Procedure
1. Click the Tools > Options  menu item; then in the Options dialog box, click the Test Points  on 

page 459 category.

2. In the “Create test points” area, clear the “Create test points during autorouting” check box. Set 
other testability options as needed.

3. Click the Routing  category > Strategy  subcategory.

4. In the table of the “Pass definition” area, select the Pass check box for the Test Point pass type.

5. Click OK.

6. Click the Tools > Autoroute > Start  menu item.

You can use the Test Point pass with other pass types. Routing completes for the entire design and 
then SailWind Router adds test points.

Note:
Test point keepouts set in SailWind Layout are respected during test point placement.

Related Topics
Assigning Test Points During Autorouting

Properties Dialog Box, Test Points Tab (Component or Via Type)

Properties Dialog Box, Test Points Tab (Nets)

Selective Autorouting
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Manual Routing

Interactively create traces to control all aspects of the routing.

Interactive Routing Workflow
Interactive Routing Setup
Design Rule Checking and Interactive Routing
Interactive Routing
Creating Traces Using Component Rules
Ending Traces Using Component Rules
Routing to an SMD Pin
Routing from an SMD Pin
Routing From an SMD Pin on Restricted Layers
Following Shapes
Add Length to Traces
Miters
Corners
Arcs
Vias
Route to Coppers and Unroute Display
Differential Pairs
Changing Trace Properties While Routing

Interactive Routing Workflow
Using interactive routing, you create new traces or reroute existing traces. Traces patterns follow the path 
of the pointer, connecting one point to another. You can also add corners, vias, and other routing objects.

The following figure illustrates making a connection from one point to another with the pointer.

Figure 64. Interactive Routing Example
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Required Setup:

• Set design rules  on page 154 such as trace sharing and component entry.

• Set net topologies  on page 291.

• Set routing options  on page 291, such as dynamics, plowing, the routing angle, and so on.

• Choose whether to protect traces  on page 292.

• Set display options  on page 294 for routing.

• Choose whether to monitor trace length  on page 304.

Route Interactively:

1. Create a trace  on page 304.

2. End the trace  on page 306.

Add other routing elements:

• Add corners  on page 318.

• Add arcs  on page 321.

• Add vias  on page 326.

• Add test points  on page  .

• Add Length to Traces.

Related Topics
Interactive Routing Setup
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Interactive Routing Setup
Read the topics that follow to learn more about setting up interactive routing.

Setting Net Topology
Protected Objects
Display Options for Interactive Routing

Setting Net Topology
You can set different topology types for nets, which affects how they are routed whether you are routing 
interactively, autorouting, or editing traces. Topology types determine the order in which to connect pins in 
a net.

If you have nothing selected, the Design Properties dialog box appears, enabling you to set topology 
globally. If you selected a net or a net class, a specific properties dialog box appears, enabling you set 
topology for the selected net or nets.

Restrictions and Limitations

• The Topology  tab does not appear in the Pin, Via, Electrical Net, Pin Pair Group, and Pin Pair 
Properties dialog boxes.

Procedure
1. Right-click and click the Properties  popup menu item; then, in the Properties dialog box, click the 

Topology tab  on page 524.

2. Click the net topology type you want.

3. Click the types of junctions you want to allow.

4. In the “Maximum stub length” box, type the maximum value. A value of 0 means no stubs are 
allowed.

5. Click OK.
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Protected Objects
You can protect objects while interactively routing or trace editing. When you protect objects, you cannot 
plow, unroute, move, reroute, or otherwise edit them. Objects you can protect include trace segments, 
traces, vias, and test points.

SailWind Router automatically protects reuse objects and jumpers defined in SailWind Layout. It does not, 
however, protect unions.

Protecting Traces and Vias While Interactively Routing
Protecting Existing Objects
Unprotecting Existing Objects

Protecting Traces and Vias While Interactively Routing
You can protect traces and vias during interactive routing to prevent—for example—making inadvertent 
edits.

Procedure
1. Click the Tools > Options  menu item; then, in the Options dialog box, click the Routing  category > 

General  subcategory.

2. Before interactively routing, select the “Protect trace and vias when creating segments” check box.

As an alternative, while you are routing a trace, right-click and click the Protect Traces and Vias 
popup menu item. SailWind Router protects the current trace segment back to the last corner as 
well as any subsequent traces. The “Protect Traces and Vias” command only effects the current 
operation; it does not change the state of the check box in the Routing  category > General 
subcategory.

When you enable protection during interactive routing, SailWind Router protects objects as you 
create them. If you are not dynamically routing, SailWind Router protects trace segments when 
you click to add a corner. If you insert vias or test points while routing the trace, the software also 
protects them.

Tip
Select the “Distinguish protected traces and vias” box (Options dialog box > Global 
category > General subcategory) to show protected traces, nets, vias, and test points 
differently from unprotected objects. For example, this can show protected objects as 
outlines instead of filled traces. The display of traces changes after you finish routing, not 
as traces are added.

Results
To turn off protection: Right-click and click the Protect Traces and Vias  popup menu item again.

Protecting Existing Objects
Protect traces and vias after placing them.
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Unprotecting Existing Objects

Procedure
1. Select an object.

2. Right-click and click the Protect  popup menu item. As an alternative, on the Route Editing toolbar, 
click the Protect  button.

Unprotecting Existing Objects
You can remove the protection from (“unprotect”) traces and vias that have been protected previously.

Restrictions and Limitations
You cannot unprotect reuse members or jumper vias.

Procedure
1. Select an object.

2. Right-click and click the Unprotect  popup menu item. Alternatively, on the Route Editing toolbar, 
click the Unprotect  button.
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Display Options for Interactive Routing
Several features control how traces and obstacles appear in SailWind Router.

Dynamically Reconnecting
Showing Via Guides
Completion Points
Showing Clearances Around Obstacles
Showing Protected Objects
Showing Unroutes
Highlighting Nets

Dynamically Reconnecting
As you route, the unrouted portion of the trace dynamically reconnects to an end point in the net that is 
closest to the pointer. You can toggle the feature on and off.

Procedure
1. While interactively routing, right-click and click the Dynamic Reconnect  popup menu item.

2. Repeating this procedure toggles the feature to the opposite state.

Results

• Differential pairs do not reconnect dynamically. However, if you route differential pairs separately, 
the individual trace reconnects dynamically according to net order.

• Nets with Protected and High-speed topology types reconnect dynamically to preserve the 
specified routing order.

• Unroutes do not reconnect dynamically to allow routing of a specific connection.

Related Topics
Setting Net Topology

Showing Via Guides
You can display a via guide at the pointer to help you place vias. When the Via grid differs from the 
Routing grid, a via guide appears, showing you the closest available locations for vias. In addition, if you 
are snapping to the via grid, a small matrix appears showing other valid grid points.

You can toggle the via guide on and off.

Restrictions and Limitations
If the via grid is set to 0, the via guide does not appear.
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Completion Points

Procedure
Type “VG” and press the Enter key. This toggles the state of the via guides.

Completion Points
Graphics that appear at the pointer change automatically to indicate completion points. When the pointer 
nears a valid completion point, the pointer changes to a bullseye. In addition, when the pointer is close to 
the completion object, an outline of the object blinks.

You cannot turn this option on or off.

Showing Clearances Around Obstacles
You can graphically view the minimum clearance around obstacles. Transparent outlines, called guard 
bands, surround obstacles to the object being routed or edited. Guard bands show the minimum distance 
you must maintain between objects.

Procedure
1. Click the Tools > Options  menu item; then, in the Options dialog box, click the Global  category > 

General  subcategory.

2. Select the “Show guard bands on object” check box.

Tip
You can set the guard band color in the Colors page  on page 422 of the Options dialog 
box.

Showing Protected Objects
You can choose to show protected components, traces, vias, and test points differently from unprotected 
objects.

Procedure
1. Click the Tools > Options  menu item; then, in the Options dialog box, click the Global  category > 

General  subcategory.

2. Select the “Distinguish protected traces and vias” check box. As an alternative, use the “I” shortcut 
key.

Results
If traces appear as filled objects, protected traces appear as outlines only.

Showing Unroutes
You can choose to show unroutes at the default trace width.
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Procedure
1. Click the Tools > Options  menu item; then, in the Options dialog box, click the Global  category > 

General  subcategory.

2. Select the “Show unroutes at recommended width” check box. Otherwise unroutes appear as thin 
connection lines.

3. Click OK.

Results

• You can use the U  shortcut key to turn unroute visibility on and off. This shortcut key does not 
effect visibility of selected or highlighted unroutes.

• You can hide unroutes by matching the color of “Connection” to the “Background” color using the 
Colors page of the Options dialog box.

• You can use the View Nets dialog box to set unroute visibility either globally across the design or 
individually for selected unroutes.

Related Topics
View Controls

Highlighting Nets
You can highlight nets to make them easier to see in your design. You can use the highlighting options 
to change the way you view nets. If desired, you can also choose to view only the traces or nets you are 
routing.

Procedure
1. Click the Tools > Options  menu item; then in the Options dialog box, click the Global category > 

General subcategory.

2. In the Highlighted object display area  on page 441, in the “Distinguish highlighted objects by” list, 
choose “Dimming other object colors.” You can also use the H shortcut key to change this setting. 
For more information, see View Controls.

3. Click OK.

4. Select a net to highlight.

5. Click the Edit > Highlight  menu item. You can also use the Highlight column in the View Nets 
dialog box. You can also use the H  shortcut key with the net name to turn highlighting on and off for 
a net.

Related Topics
Highlighting and Unhighlighting Design Objects

Unhighlighting Objects

Setting Net Topology
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Design Rule Checking and Interactive Routing

Modeless Commands

View Nets Dialog Box

Design Rule Checking and Interactive Routing
Turn on design rule checking and set it to Prevent to avoid design rule violations during interactive 
routing, route editing, and placement editing operations.

When you enable clearance checking set it to “Prevent,” you generally cannot create a violation while 
moving the pointer because you cannot create or edit a routing object in a way that violates design rules. 
For example, if you attempt to route a trace between two pins, and the trace does not have enough 
clearance, the trace stops just before the clearance boundary of the pins. Clicking near the pins adds 
a corner at the last valid point before encountering an obstacle. Because the trace does not violate the 
clearance boundary, no violation occurs. However, placing vias while interactively routing can create 
violations. If placing a via creates a violation, the operation cancels without placing a via.

SailWind Router can also prevent violations that you might inadvertently create while editing object 
properties in one of the properties dialog boxes or in the spreadsheet window. For example, if you select 
a trace segment and change its width to a value that would not fit due to clearance violations, SailWind 
Router prevents the change.

Trace Sharing Rules
Trace sharing rules restrict the sharing of vias and traces. When sharing is restricted, you may not be able 
to route more than two traces to a single via. Set trace sharing rules in the “Allow junctions on” area on 
the Topology  tab of the Design Properties dialog box.

You can share SMD pins mounted on outer layers (on which routing is restricted), sharing a pin that 
otherwise cannot be shared. To provide access to the pin on the restricted layer, create a fanout of a short 
trace ending with a via. The trace connecting the SMD pin to the via becomes a subnet. A subnet joins 
to other portions of the net at the via without sharing the segment with any other portion of the nets. This 
fanout is called a composite fanout.

Figure 65. Trace Sharing Rules

Trace Width and Component Rules
SailWind Router uses the recommended trace width when starting from a pin or via. When routing from a 
trace segment, trace corner, or end point, the software uses the current width of the selected trace. When 
this size cannot be used (due to clearances, for example), SailWind Router uses the recommended trace 
width instead. If the recommended trace width is still too large, SailWind Router tries to use the pad width, 
or finally, the minimum trace width. This occurs only when you select the “Allow trace necking at pads” 
check box on the Routing  tab of the Options dialog box.
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SailWind Router uses component rules during routing as well. One of the component rules specifies a 
trace width per component. When both component rules and trace width rules are defined, the software 
uses the width rule from the component rules set.

When you exit a pin of a component with unique trace width rules, the component width rule is applied.

Set the Maximum, Recommended, and Minimum trace widths on the Routing  tab of the Design 
Properties, Net Properties, Pin Pair Properties, or Component Properties dialog boxes.

Same Net Rules and Corners
Same net corner rules determine how far from the edge of a pad you can place the first corner when 
routing a trace. These rules also represent the minimum distance between traces of the same net. You 
cannot add a corner too close to the edge of a component pin, via pad, or copper boundary unless you 
enable soft rules.

Set the same net rules on the Same Net  tab of the Design Properties dialog box. Set whether first corner 
rules are hard or soft with the Ignore first corner rules to complete traces when required check box in the 
Pad Entry  tab of the Design Properties or Component Properties dialog boxes.

Pad Entry Rules and Routing Interactively with Dynamics
When routing interactively with dynamics, any traces exiting a pad or copper respect the pad entry rules. 
If the “Dynamically route” check box is cleared, traces do not automatically maintain pad entry rules.

Pad entry rules define how traces enter and exit component pads and manage the quality of the trace 
pattern at pad and trace junctions. SailWind Router maintains pad entry rules for all routing angles and 
pad orientations.

Set pad entry rules on the Pad Entry  tab of the Properties dialog boxes for selected components.

Topology Rules
When routing a net with a Protected topology type, SailWind Router disables the dynamic reconnect 
features to preserve net order. You can only connect the net in the order defined by the pin pairs; 
however, you can connect at any point in the branch. For example, you can connect to any trace or 
via that is attached to the targeted connection pin. If you are routing a high-speed net, you can click to 
reconnect to the final destination.

For more information, refer to Setting Net Topology.

Editing Traces and Same Net Clearance Rules
Same net rules are verified after you complete an editing operation. With Same net Pad to Corner rules, 
only the first corner after the trace exits the pad is maintained. Same net Trace to Corner rules are not 
maintained.
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Interactive Routing
The interactive routing features let you route traces manually, by either clicking and entering a trace 
pattern with your pointer or automatically following the path drawn by the pointer.

For information on using design rules with interactive routing, see Design Rule Checking and Interactive 
Routing.

Trace Plowing
Interactive Routing with the Trace Length Monitor
Monitoring Trace Length
Creating Traces
Ending Traces

Trace Plowing
The plower moves existing traces and vias automatically as you route new traces.

Observe the following restrictions when plowing traces:

• You cannot plow vias that are set as protected test points.

• You cannot plow reuse objects.

• When you enable the plower the router attempts to plow objects. To allow the plowing of nets, 
select the “Shove traces to complete connections when required” check box (Routing  tab of the 
Design Properties, Pin Pair Properties, or Net Properties dialog boxes).

• To allow the plowing of protected objects, select the “Shove protected traces when required” 
check box (Routing  tab of the Design Properties, Pin Pair Properties, or Net Properties dialog 
boxes).

• SailWind Router dose not plow arcs as arcs. Instead, it interrupts the arc and adds trace 
segments to allow for the trace in progress.

Figure 66. Traces Before and After Plow

If the plowed traces encounter an immovable obstacle, like a protected via, the plowed traces “hop” over 
the obstacle. SailWind Router maintains clearance rules when traces hop over objects.

For more information, refer to “Interactive Routing Setup.”
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Figure 67. Traces are Obstacles to New Traces

Figure 68. Traces are Plowed to Make Room for New Traces

Plower Types
The following table shows the available plower types.

Table  78. Plower Types

Plower type Action

Plow with pointer Plows obstructions as the pointer moves towards them. This feature 
works best when you route with dynamics.

Plow with pointer has two modes:
• Real-time plowing— Plows obstacles immediately as the pointer 

passes them.

• Guided plowing— Plows obstacles after you define a potential path 
with the pointer and then reach an open area.
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Interactive Routing with the Trace Length Monitor

Table  78. Plower Types  (continued)

Plower type Action

Plow after corner click Plows obstructions only after you click to enter a corner. If no room 
exists to move the obstruction, you cannot enter a corner. Visually, the 
ending trace pattern is the same as with Plow with pointer movement.

 Tip
This feature works best when you route without dynamics.

Interactive Routing with the Trace Length Monitor
As you route traces interactively, the routed length and estimated total length appear near the pointer. The 
feature for displaying routed and estimated length is called the trace length monitor.

Figure 69. Routed Length and Estimated Total Length

Routing Traces with Length Rules
When routing traces with length rules, the trace length monitor shows the routed length, the minimum 
length rule, and the maximum length rule for the net, electrical net, or pin pair. A progress indicator bar 
also appears as shown in Figure 70.

Figure 70. Routing Traces with Length Rules

Calculating Length
The trace length monitor calculates estimated length as the combined total of routed and unrouted length 
of the trace being routed and includes half the Discrete length value of each connected pin of components 
that have a Discrete length assigned.
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Routed Length

The trace length monitor calculates routed length as the cumulative length of the trace. It includes half the 
Discrete length value of each connected pin of components that have a Discrete length assigned. If you 
start routing from the end point of a partially routed trace, the routed length includes the partially routed 
trace length. If the trace has branches, then the trace length monitor calculates the length from the branch 
point.

Unrouted Length

The trace length monitor calculates unrouted length as the distance from the end point of the current trace 
segment (attached to the pointer) to its destination. The unrouted length is recalculated as the unroute 
dynamically reconnects to connection points. The routing angle also effects this calculation.

Progress Indicator
For traces with length rules, the progress indicator displays the total estimated  length for either the current 
pin pair or the entire net, depending on the “Show Estimated Length of Pin Pair” setting in the Routing/
General options  on page 450. If you select this check box, the progress indicator shows the estimated 
length for the current pin pair. When you clear the check box, the indicator shows the estimated length 
for the entire net. Keep in mind this setting can affect whether or not the estimated length on the display 
appears to meet or violate length rules while routing from one pad to the next. Figure 72, for example, 
shows the progress indicator for the same net with the “Show Estimated Length of Pin Pair” check box 
both selected and cleared.

Figure 71. Calculated Length

Figure 72. The Progress Indicator with Different Settings

Monitor Display
As shown in the table below, the trace length monitor changes depending on what rules are set.

Table  79. Length Rules and Monitor Display

Length rule Information in report

Minimum/Maximum Length 
Rules

Shows the current routed length, the total length, the minimum net 
length rule, and whether it's applied at the net, electrical net, or pin pair 
level of the rules hierarchy.

Matched Length Rules Shows the current routed length, the total length, and the matching net 
length rule.
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Table  79. Length Rules and Monitor Display  (continued)

Length rule Information in report

Differential Pair Rules Shows the current routed length, the total estimated length, the 
minimum length rule, the maximum length rule, the gap rule, and 
whether it's a net, electrical net, or pin pair rule.

No Length Rules Shows the current routed length and the total estimated length

Colors Used in the Monitor

The Navigation Window  shows only those nets, electrical nets, or matched length groups that have length 
rules and are affected by the current operation. The Net Length Monitor  tab of the Spreadsheet window 
shows the nets, lengths, and rules in a table. The monitor, navigation window, and Length Monitor  tab 
show length in different colors. A colored bar moves across the monitor. In the navigation window, the 
nets appear in colors. In the Net Length Monitor  and Electrical Net Length Monitor  tabs, lengths in the 
Length columns appear in different colors. Each color has a special meaning.

Table  80. Trace Length Monitor Colors

Color Means the net length is

Yellow Below the minimum limit

Green Within the minimum and maximum limits

Dark Green Within 10% of the minimum or maximum limits

Red Over the maximum limit

Trace Length Display

You can monitor trace length in four places.

• At the pointer — Shows a graphic that monitors progress, routed length, estimated net or 
electrical net length, and any length rules. This information also appears on the status bar. The 
graphics that appear near the pointer change depending on whether the net, electrical net, or pin 
pair has length rules, rules other than the default, or if the rule is violated.

• In the Navigation window  — Shows only those nets, electrical nets, or matched length groups 
that have length rules and are affected by the current operation.

• In the Net Length Monitor tab of the Spreadsheet window  — Shows nets, lengths, rules 
routed length, unrouted length, estimated net length, and length rules. You can also change 
length rules here.

• In the Electrical Net Length Monitor tab of the Spreadsheet window  — Shows electrical nets, 
lengths, rules routed length, unrouted length, estimated net length, and length rules. You can also 
change length rules here.

Effects of the Tune Pass on Trace Length

During interactive routing and rerouting operations, the trace length monitor may show a length greater 
than the actual final length. You may perform pad entry corrections on traces after you finish routing 
(depending on your routing preferences). These operations may change trace length slightly.
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Monitoring Trace Length
You can monitor trace length when routing or editing traces. By monitoring trace length, you can ensure 
that traces meet length rules as you route. The trace length monitor at the pointer shows both the current 
routed trace length and the estimated total net or electrical net length.

Restrictions and Limitations
For differential pairs, the trace length monitor shows the length of one pair member at a time. Use the Tab 
key to switch between the pair members.

Procedure
1. Click the Tools > Options  menu item; then in the Options dialog box, click the Global  category > 

General  subcategory.

2. In the “Pointer settings” area, select the “Length monitor” check box.

3. To estimate the total length of the current pin pair (total length + unrouted length), select the 
“Show estimated length of pin pair” check box on the Routing  category > General  subcategory. 
Otherwise, the length monitor estimates the total length of the net or electrical net length (total net 
length + unrouted length).

Tip
You can reset the current length value in the trace length monitor to zero by pressing Ctrl
+Page Down while interactively routing.

4. Click OK. The estimated length appears next to the pointer when you begin actively routing a 
trace.

Creating Traces
Create traces by routing. Before routing, you must choose a starting point and initiate interactive routing. 
You can interactively route from copper polygons and net objects, such as a pins, virtual pins, vias, traces, 
trace segments, trace corners, T-junctions, unroutes, and end points of a trace.

For more information, see “Creating Differential Pair Traces”  on page 335.

Procedure
1. In the Layer list in the standard toolbar, choose the layer on which the objects to route exist. As 

an alternative, use the L shortcut key to select a layer. You cannot interactively route on restricted 
layers. Set layer restrictions on the Layers  tab or the Layer Biasing  tab of the Design Properties 
dialog box.

2. Select the unroute to route, or the object from which to route. You cannot select a copper segment. 
You can select only the entire copper polygon. The routing start point is near the selection point.

3. Start interactive routing by right-clicking and clicking the Interactive Route  popup menu item. 
Hatch outlines disappear automatically when you start interactive routing. SailWind Router also 
ignores stub length rules.
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4. If in step 2 you selected a pin that belongs to more than one pin pair, you can change the pin pair 
that is selected for interactive routing. To select a different pin pair to route, right-click and click the 
Switch Pin Pair  popup menu item.

5. Move the pointer in the direction you want to create a trace. For instructions to follow another 
shape with a trace, see “Following Shapes”  on page 311.

6. If necessary, add the following while routing:

• Corners  on page 318 — Required if you are routing without dynamics. Optional when you 
route dynamically. Corners typically change the direction of a trace.

• Vias  on page 326 — To change layers while routing.

• Test points  on page   — To make your design testable.

• “Arcs”  on page 321 — To create arc segments.

• Length  on page 312 — To meet length rules using accordions.

As you move the pointer, guard bands may appear, indicating obstacles.

7. To change the trace properties such as width and layer while interactively routing, see “Changing 
Trace Properties While Routing”  on page 340. The trace width may prevent you from routing 
between obstacles. If you selected the “Allow trace necking at pads” check box (Options dialog box 
> Routing  category > General  subcategory), you can automatically neck traces by clicking to add 
a corner. The trace width changes automatically to the minimum trace width. After you clear the 
obstacles, click again to return to the previous trace width.

8. End the trace as described in Ending Traces.
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Ending Traces
SailWind Router provides three ways to end a trace while interactively routing.

Note:
Differential pairs require some specific steps. For more information, see Ending Differential Pair 
Traces.

Completing a Trace Connection
Ending the Trace With a Via or Test Point
Ending the Trace Leaving it Incomplete

Completing a Trace Connection
When the pointer is near a valid completion point, the pointer changes to a double circle. During rerouting, 
the pointer changes to a single circle to indicate a valid completion point.

Procedure
Click on the object where you want to complete the trace when a single or double circle is visible over the 
completion point. As an alternative, when the pointer is near the object at which you want to complete the 
trace, right-click, and click the Complete  popup menu item.

Results
The trace completes, maintaining same net rules if possible. The trace width and length may also be 
adjusted. When you complete a trace, the autorouter passes may run automatically in the background; 
for example, if the object where you want to complete the trace is on another layer or far from the pointer. 
If a net has a length rule assigned, SailWind Router may add length automatically when you use the 
Complete  popup menu item.

• If you encounter difficulty using Complete, you may need to switch to component rules before 
clicking Complete.

• If DRC Prevent mode is enabled and you receive an error message while trying to complete a 
trace, or if an operation does not complete, right-click and click the Explain Last Error  menu 
item. DRC will explain the cause. Error markers appear if you have made them visible. If DRC 
Explain mode is enabled instead, the error is explained for you automatically and you can either 
accept the error (by right-clicking and clicking the Continue with Errors  menu item) or you can 
reject it (by pressing the Esc key or right-clicking and clicking the Cancel  popup menu item). For 
more information, see “Design Rule Checking Dialog Box”  on page 405.

• If you are using DRC Prevent or Explain mode for clearance checking, you can temporarily turn 
off clearance checking in order to complete a trace. While interactively routing, right-click and 
click the Check Clearance  popup menu item. You can then complete the trace, even if you 
are creating a clearance violation. With Check Clearance disabled, you can violate clearance 
boundaries and create clearance violations. When you click to complete an operation, error 
markers appear in the workspace at the location of each error and error messages appear in 
the spreadsheet window. You can continue with additional operations with Check Clearance 
disabled. To reactivate clearance checking during routing, you must right-click and click the 
Check Clearance  popup menu item again.
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• You can also disable or enable clearance checking during trace editing operations such as Move 
and Stretch. To temporarily disable clearance checking during these editing operations, right-click 
and click the Ignore Clearance  popup menu item. To reactivate clearance checking during trace 
editing, right-click and click the Ignore Clearance  popup menu item again. For more information, 
see “Edit Traces Using DRC Modes”  on page 346.

Related Topics
Autorouting by Selection

Ending the Trace With a Via or Test Point
You have the option of ending a trace with either a via or a test point.

Procedure
1. Right-click, choose the End Via Mode  popup menu item, then choose one of the following end via 

modes:

• End No Via  — End without a via.

• End Via  — End with a via of the current type, on the via grid, at the closest location to the 
pointer. Obstacles move to accommodate the via.

• End Test Point  — End with a via of the current test point type, on the test point grid, at the 
closest location to the pointer and assign it as a test point. Obstacles move to accommodate 
the via.

SailWind Router uses the end via mode you choose until you choose a new mode.

2. Press the Ctrl key and click to end the trace.

Results
When you end a trace, a smoothing pass runs automatically if the “Smooth traces on complete” check 
box is enabled in the Options dialog box > Routing  category > “General subcategory”  on page 450.

If you end a trace with a via or a test point while the pointer is over a trace from the same net on another 
layer, the via connects to that trace. Exceptions:

• The via does not connect to the trace if via sharing is disabled for the net, and if the number of 
traces attached to the via is greater than two.

• The via does not connect to the trace if the trace is from a different subnet. In this case, when 
possible, the trace is plowed to make room for the via.

Ending the Trace Leaving it Incomplete
You can choose to end the trace to complete it later.

Procedure
Right-click, and click the End  popup menu item. The end via mode must be set to End No Via.
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Results
If you click the End  popup menu item while the point is over a completion point, the trace is completed 
instead of ended.

When you end a trace, a smoothing pass will run automatically if you select the “Smooth traces on 
complete” check box on the Options Dialog Box, Routing Category, General Subcategory.

Related Topics
Creating Differential Pair Traces

Creating Traces Using Component Rules

Interactive Routing Workflow

Change Trace Width

Ending Differential Pair Traces

Routing to an SMD Pin

Routing from an SMD Pin

Vias

Autorouting by Selection

Edit Traces Using DRC Modes

Creating Traces Using Component Rules
If you start routing from a component, via, or trace segment with component rules, the component rules 
constrain the new trace. You can choose when to stop using component rules and start using trace rules 
for the creation of both traces and differential pairs.

Restrictions and Limitations

• When routing a differential pair from component pins, SailWind Router uses component rules 
automatically and you route the pair separately, just as if you clicked Route Separately.

• When routing a differential pair from fanout vias, SailWind Router uses trace rules and routes the 
pair together.

• When you route between component pins with differing component rules, you must create a small 
trace segment that uses trace rules between the two trace segments that use component rules.

• If you start routing from a trace segment or node that is part of a trace using component rules, the 
new trace uses component rules.

• If you start routing from a trace segment or node that is not using component rules, the new trace 
continues to use trace rules.
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• If you start routing from a trace segment or node that is part of a composite rule trace, the new 
trace uses the composite rules.

Note:
A composite rule trace is a trace that is attached to a pin that is shared by two subnets. For 
example, if a trace belongs to more than one pin pair with different rules, the trace uses 
composite rules, which is defined as the most restrictive common setting for each pin pair 
(if one pin pair has a clearance value of 12 and the other has a clearance value of 20, the 
trace inherits a composite clearance value of 20).

• If you start routing from a via that is part of a composite fanout, the new trace uses the composite 
rules. If you switch rules, the trace uses trace rules for one of the subnets attached to the via.

Procedure
1. Start interactive routing from a component pin or trace segment that has component rules. 

Component rules take effect automatically, and a “CR” graphic appears at the pointer to indicate 
component rules are active. The graphic also displays the reference designator of the component 
that owns the rules.

2. Right-click, and click the Switch Rules  popup menu item. The “CR” graphic is removed from the 
pointer, and a virtual point is added where the rule sets change. Trace rules are now active.

Related Topics
Ending Traces Using Component Rules

Ending Traces Using Component Rules
While routing interactively, you can switch to component rules to complete a trace.

Procedure
1. Right-click and click the Switch Rules  popup menu item to stop using trace rules and start using 

component rules. Component rules take effect automatically, and a “CR” graphic appears at the 
pointer to indicate component rules are active.

2. Complete the trace using one of the methods described in “Ending Traces”  on page 306. 
SailWind Router maintains component rules from the last corner that you added to the completion 
point. The last added corner becomes a virtual point.

Related Topics
Ending Differential Pair Traces

Creating Traces

Creating Traces Using Component Rules

Creating Differential Pair Traces
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Routing to an SMD Pin
You can route to an SMD pin and complete the routing with the placement of a via on the SMD pin.

Procedure
1. Set up SMD vias using the Same net  tab of the Design Properties dialog box or the Component 

Properties dialog box.

2. While interactively routing, point to the SMD pin on another layer where you want to end the trace, 
press Shift and click to add a via at the SMD pin. As an alternative, while interactively routing, point 
to the SMD pin on another layer where you want to end the trace and double-click. The Route 
autorouter pass completes the trace and adds a via at the SMD. Skip step 3.

3. Right-click and select a completion method from the popup menu.

Related Topics
Properties Dialog Box, Same Net Tab

Routing from an SMD Pin
You can interactively route from a surface mount component pin.

Procedure
1. Set up Vias at SMD options using the Same net  tab of the Design Properties dialog box or the 

Component Properties dialog box.

2. Interactively route from a component pin.

3. Add a via. A via of the current type appears at the SMD pin. For more information, see “Vias”  on 
page 324.

4. Continue routing.

Routing From an SMD Pin on Restricted 
Layers
You cannot interactively route from a surface mount component pin on a restricted layer. However, the 
Fanout autorouter pass will create a fanout for you.

Procedure
1. Set up Vias at SMD options using the Same net  tab of the Design Properties dialog box or the 

Component Properties dialog box.

2. Select the surface mount component or pin.
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3. Right-click and click the Fanout  popup menu item to run the Fanout autorouter pass on the 
selected component or pin. SailWind Router creates fanouts from the SMD, with vias at the end of 
the stubs based on your fanout settings.

4. Interactively route from the vias.

Following Shapes
Use Follow while interactively routing to easily create traces that follow other shapes (another trace, 
board outline, copper, or trace keepout).

Restrictions and Limitations
You cannot follow 2D Lines or objects on other layers.

Procedure
1. While interactively routing, right-click and click the Follow  popup menu item.

2. Click to select the object to follow. To ensure you select the correct object, move the pointer over 
the object; the object the trace will follow is highlighted.

3. Click to indicate where on the object you want to start the trace. While in Follow mode, you can still 
back up, and use arcs; however, all other Interactive Routing options are unavailable.

4. Move the pointer in the direction you want to place the trace.

5. Click to finish following the shape and continue with Interactive Routing.

Results
The new trace appears along the outline of the selected shape. SailWind Router follows all clearance 
rules; if there is an obstacle along the way, the new trace goes around it and then back to following the 
shape at the first opportunity.

Pre-existing elements in the design, especially traces and vias, remain untouched; Follow mode works as 
if you had protected all nets are protected and disabled the Plower. When the Follows process encounters 
a trace or via from another net, it routes the trace around the obstacle.
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Add Length to Traces
Use an accordion to add length to a trace or differential pair so that it meets length rules for the net, 
electrical net, or pin pair.

For more information about setting options for routing to length constraints, see “Options Dialog Box, 
Routing Category, General Subcategory.”

Adding Accordions at Default Amplitude
Adding Accordions with Custom Amplitude
Add Accordions to Existing Traces

Adding Accordions at Default Amplitude
You can add length to your traces by adding accordions.

Procedure
1. While interactively routing, right-click and click the Add Accordion  popup menu item.

2. Move the pointer in the direction you want to place the accordion. You can create accordions at 
any angle, depending on your routing angle.

An accordion appears based on Minimum amplitude and Minimum gap settings (Options Dialog 
Box, Routing Category, General Subcategory). The amplitude of the accordion centers on the 
trace, as shown below.

Figure 73. Adding an Accordion at Default Amplitude

The gap of the accordion is based on the Minimum gap setting (Options dialog box > Routing 
category > Tune  subcategory).

You can also add an accordion that uses the default amplitude, but does not center on the trace, 
as shown in below. Start the accordion, click to enter the first section, and move the pointer in the 
direction you want to place the accordion.

312 SailWind Router Guide



 
Manual Routing

Adding Accordions with Custom Amplitude

Figure 74. Adding a Non-centered Accordion

You can combine the accordion creation methods. For example, you can add an accordion that 
uses the default amplitude, and in one of the subsequent sections, click to redefine the amplitude. 
This is useful if you encounter an immovable obstacle.

3. Right-click and click the Complete Accordion  popup menu item to end the accordion and 
continue routing. As an alternative, double-click to end the accordion.

4. Protect your accordions after you add them to prevent the autorouter (or other editing operations) 
from removing or adjusting them.

Adding Accordions with Custom Amplitude
Insert accordions and adjust the amplitude of individual sections as required. Create accordions at any 
angle depending on your routing angle.

Procedure
1. While interactively routing, right-click and click the Add Accordion  popup menu item.

2. To define the amplitude, move the pointer to define the highest point of the accordion, right-click, 
and click the Add Section  popup menu item.

3. Move the pointer to define the lowest point of the accordion, right-click, and click Add Section.

Figure 75. Adding an Accordion with Custom Amplitude

4. Move the pointer in the direction you want to place the accordion.

5. Right-click and click the Complete Accordion  popup menu item to end the accordion and 
continue routing. As an alternative, double-click to end the accordion. The gap of the accordion 
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is based on the Minimum gap setting in the Options dialog box > Routing  category > Tune 
subcategory. You cannot adjust the gap while adding accordions.

6. Protect your accordions after you add them to prevent the autorouter (or other editing operations) 
from removing or adjusting them.
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Add Accordions to Existing Traces
You can add an accordion if the existing trace does not meet length requirements after completion.

When you add accordions to existing traces, you have two choices:

• You can add an accordion so that just enough length is added to meet net length rules  on 
page 315.

• You can specify which part of the trace  on page 315 to convert to an accordion.

Adding an Accordion to Meet Length Rules
Adding an Accordion in a Specified Area

Adding an Accordion to Meet Length Rules
You can add an accordion to a trace, increasing its routed length so that it meets your length rules.

Procedure
1. Select the trace, trace segment, or trace path to which to add an accordion.

Tip
If you select a differential pair segment in the shoulder area, you can add an accordion to 
a single member of the pair. If you select a differential pair segment in the controlled gap 
area, you must add the accordion to both members of the pair.

2. Right-click and click the Add Accordion  popup menu item. An accordion appears in the trace so 
that the net meets net length rules. SailWind Router generally adds the accordion to the middle of 
the selected trace or segment.

Adding an Accordion in a Specified Area
You can choose to specify which part of the trace to convert to an accordion.

Procedure
1. In the Selection Filter toolbar, click the Path  button to enable path selection.

2. Click on the trace or trace segment to specify the start of the accordion location.

3. Click again to specify the end of the accordion. If you specify a differential pair segment in the 
shoulder area, you can add an accordion to a single member of the pair. If you specify a differential 
pair segment in the controlled gap area, you must add the accordion to both members of the pair.

4. Right-click and click the Add Accordion  popup menu item. SailWind Router adds an accordion to 
the selected path within the trace or trace segment.
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Related Topics
Move Accordions

Deleting an Accordion

Monitoring Trace Length

Miters
Use miters to specify values for replacing a corner with a diagonal segment or arc.

The miter ratio value, set on the Routing  tab of the Options dialog box, specifies the miter ratio for 
accordion corners. SailWind Router calculates the radius using the following formula:

(<trace_width> / 2) x Ratio

If “Use arcs” in the Miters area on the Routing  tab is checked, the diagonal segment is replaced with an 
arc:

For example, if the trace width is 12 (set on the Trace Segment Properties dialog box), and you set the 
ratio to 1, the miter radius is 6 ((12 / 2) x 1 = 6). The miter segment length is about 8.49.

Accordions
When accordions use miters, the miter segment cannot be longer than the middle segment:

316 SailWind Router Guide



 
Manual Routing

Miters

If accordions use arcs instead, the middle segment may be completely removed:

Differential Pair Miters
When you choose to add miters to differential pairs, SailWind Router generates miters for both parallel 
traces but calculates the miter size for the smaller (inside) miter segment based on the miter ratio setting.

Obstacles
The Miter pass can create smaller miters if there are obstacles like pins or vias in the way.
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Corners
SailWind Router places corners at the location that is closest to the pointer that meets current routing grid 
settings and design rules. When you select the “Snap Objects to Grid” check box for the Routing grid (on 
the Grid  tab of the Design Properties dialog box), SailWind Router places corners on at least one grid 
coordinate.

The following figure illustrates corner placement on a grid.

Figure 76. On-grid Trace Corners 

When you place the first corner after exiting a pad, SailWind Router maintains first corner rules (Figure 
77) unless you select the “Ignore first corner rules” check box on the Pad Entry  tab of the Design 
Properties dialog box. This check box makes first corner rules soft.

Figure 77. First Corner Rule 

Adding Corners While Interactively Routing
Adding Corners to Existing Traces

Adding Corners While Interactively Routing
You can add corners when routing with or without dynamics.

Procedure
While interactively routing a trace, click to enter a corner. As an alternative, right-click and click the Add 
Corner  popup menu item. SailWind Router removes any trace loops and adds the corner. If you click 
the Add Corner  popup menu item when the end point of a trace is over a completion point, the trace 
completes.
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Tip
If you add a corner, and the trace encounters an immovable obstacle (for example a component 
pin), the last-entered trace corner moves automatically to a new position that allows the trace to 
pass the obstacle, as shown below. This happens only when you route without dynamics and the 
“Adjust trace segments around obstacles” check box is selected (Options dialog box > Routing 
category > General  subcategory).

Figure 78. Interactive Routing—Avoiding Obstacles 

When you dynamically route from an off-grid pad, SailWind Router adds corners at the point closest to the 
pointer and on the routing grid. When you route without dynamics from an off-grid pad, SailWind Router 
adds corners on a grid line, not at the grid intersection.

Pad entry settings are maintained when you route dynamically. Set pad entry on the Pad Entry  tab of the 
Design Properties dialog box or Component Properties dialog box.

Figure 79. Routing from an Off-grid Pad 

Adding Corners to Existing Traces
You can add corners to an existing trace if you have already routed a connection.

Procedure
1. Select a trace segment then right-click and click the Add Corner  popup menu item. Alternatively, 

on the Route Editing toolbar, click the Add Corner  button.

2. Move the pointer to the target location for the corner and click. A corner appears at the selection 
point. Grid lines also appear, indicating 45-degree angles from the end point of the trace. This 
makes it easier to place diagonal corners. When adding corners, SailWind Router does not smooth 
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adjacent segments, even if you have selected the “Smooth adjacent segments” check box (Options 
dialog box > Routing  category > General  subcategory).

Tip
Press and hold the Shift key while moving corners to temporarily override the current angle 
mode.

Related Topics
Moving Corners

Deleting Corners
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Arcs
When routing interactively, you can add a free-drawn arc, or an arc of specified radius. This feature is also 
available when routing differential pairs. While routing a differential pair in arc mode, you cannot use the 
following commands: Add Via, Add Test Point, Add Accordion, Complete, Layer Toggle, Layer, Switch 
Rules.

Adding a Free-drawn Arc
Adding an Arc of Specified Radius

Adding a Free-drawn Arc
Add a free-drawn arc to a single trace, a differential pair, or an individual trace of a differential pair.

Procedure
1. While routing, click to locate the start point of the arc.

Tip
Ensure you protect arcs after adding them, as autorouting operations and plowing in 
interactive routing may remove unprotected arcs. To protect arcs as you add them, select 
the “Protect traces and vias when creating segments” check box in the Options dialog box 
> Routing  category > General  subcategory. As an alternative, while interactively routing, 
right-click and click the Protect Traces and Vias  popup menu item.

2. Right-click and click the Arc > Add Arc  popup menu item.

3. Move the pointer to draw the arc.

4. Click again to end the arc.

Adding an Arc of Specified Radius
Add an arc of specified radius to a single trace, a differential pair, or an individual trace of a differential 
pair.

Restrictions and Limitations

• The end points of a fixed radius arc are restricted to those coincident with the routing angle and 
grid settings.

• You cannot create looping arcs. If you close the arc (make a circle), the circle is ignored and you 
continue to define the arc.
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• The current routing angle determines the chord increment for the arc, as shown below.

Figure 80. Interactive Routing— Adding Arcs

Procedure
1. If necessary, set the desired radius using the “RAD” modeless command. If you are jointly routing a 

differential pair, the radius defines the smaller (inside) arc.

Tip
Ensure you protect arcs after adding them as autorouting operations and plowing in 
interactive routing may remove unprotected arcs. To protect arcs as you add them, select 
the “Protect traces and vias when creating segments” check box in the Options dialog box 
> Routing  category > General  subcategory. Alternatively, while interactively routing, right-
click and click the Protect Traces and Vias  popup menu item.

2. Click to locate the start point of the arc.

3. Right-click, and click the Arc > Add Arc of Radius  popup menu item. The arc begins from the last 
entered corner, arc, or end point.

4. Move the pointer in the direction in which you want to create the arc. If you add an arc from a pad, 
or complete an arc at a pad, SailWind Router does not maintain pad entry and first corner rules.

5. Click to complete the arc and continue routing.
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Adding an Arc of Specified Radius

Related Topics
Moving Arcs

Deleting Arcs From Existing Traces

SailWind Router Guide 323



Manual Routing
Vias  

Vias
Add vias to route traces from the current layer to another layer in the design. The other layer then 
becomes the current layer. When you add a via, a via of the current type appears at a location that meets 
current via grid settings and design rules. SailWind Router plows movable obstacles to accommodate the 
new via.

If the DRC  on page 405 mode for clearances is set to Prevent, and plowing is enabled, SailWind Router 
moves obstacles, creating room for the via without violating design rules.

SailWind Router uses the current via type for the trace in progress, provided the via biasing rules (set on 
the Via Biasing  tab of the properties dialog boxes) allow it. If the current via type is not allowed for the 
trace, SailWind Router selects another valid via type. After using a new or different via, SailWind Router 
uses it for subsequent via additions.

When routing traces in the controlled gap area of a differential pair, SailWind Router adds vias on both 
traces. You cannot add vias while routing a differential pair in arc mode.

Via Mode
Setting the Via Type
Protecting Vias
Adding Vias on the Via Grid
Using Layer Change and Add Via to Change to a Specific Layer
Adding Vias While Interactively Routing
Adding Vias to Existing Traces
Adding Stitching Vias

Via Mode
The via mode determines what kind of via type to use when inserting vias.

SailWind Router selects vias based on several requirements, including:

• Which vias are allowed for the net or pin pair, as determined by via biasing rules.

• Which vias are legal for the layer change, according to the layer drill settings you set in the Pad 
Stacks Properties dialog box in SailWind Layout.

• If multiple vias qualify, which via has the smallest pad size but is also larger than the trace width.

Table  81. Setting or Changing the Via Mode

Modeless 
Command For this mode To limit the via type to

VA Automatic Automatic selection from a list of all available vias

VP Partial Partial via types that meet the requirements mentioned above

VT Through Through-hole via types that meet the requirements mentioned 
above
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Setting the Via Type
When you add a via, its via type becomes the current via type and SailWind Router continues to use it 
when you add subsequent vias. When adding subsequent vias, if SailWind Router cannot use the current 
via type, or if it conflicts with the via mode, the via type is changed to “undefined” and then automatically 
selected based on the current via mode (VA, VT, or VP).

When adding a via, SailWind Router follows the settings on the Via Biasing  tab of the following dialog 
boxes:

• Net Properties dialog box

• Pin Pair Properties dialog box

• Component Properties dialog box

Procedure
1. While routing a trace, right-click, choose the Via Type  popup menu item, and click a via type from 

the list; for example, STANDARDVIA. The list contains the current via type, followed by a list of 
allowable via types in the design, followed by via mode commands.

2. To choose a via type that is not visible in the list, click the Choose  popup menu item. The Choose 
options only appears on the menu if you have more than 12 available vias. The next via you add is 
of the new via type, if it meets via biasing rules and layer drill settings.

Results
If you have selected the “Turn on plower” check box (Options dialog box > Routing  category > General 
subcategory) and you change the via type of an existing via, SailWind Router may plow traces and other 
movable obstacles to make room for the new via type.

Related Topics
Vias

Protecting Vias
Protect traces and vias as you add them to your design. Routing operations cannot rip up or otherwise 
modify the vias.

Procedure
1. Click the Tools > Options  menu item; then, in the Options dialog box, click the Routing  category > 

General  subcategory.

2. Select the “Protect traces and vias when creating segments” check box. You can move protected 
vias if you select the “Shove protected traces when required” check box in the Routing  tab of the 
Design Properties dialog box.
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Adding Vias on the Via Grid
You can choose to add vias on a grid.

Procedure
1. With nothing selected in the design area, right-click and click the Properties  popup menu item; 

then in the Properties dialog box, click the Grid  tab.

2. Select the “Snap Objects to Grid” check box for the Via grid.

Tip
If you select the “Smooth adjacent segments” check box (Options dialog box > Routing 
category > General  subcategory), SailWind Router smooths trace segments adjacent to 
the via.

Using Layer Change and Add Via to Change to a 
Specific Layer
Add Via automatically switches to the other routing layer (in a two-layer design) or to the other layer in 
the layer pair (for multiple-layer design). If you are routing on an unpaired layer, Add Via switches to the 
lowest numbered layer in the paired layer setting.

You can set layer pairs in the Options dialog box > Routing  category > General  subcategory. You can 
also combine a layer change operation with the Add Via command to change to a specific layer.

Procedure
1. Before adding the via, press Alt while scrolling the wheel button on the mouse.

2. This allows you to scroll through layers in the design. When you reach the layer you want to 
change to, add a via as described in the following sections.

Related Topics
Scrolling Through Layers Using the Wheel

Adding Vias While Interactively Routing
You can add vias while you route a trace interactively.

Restrictions and Limitations
You cannot add vias while routing a differential pair in arc mode.

Procedure
While interactively routing, press the Shift key and click. As an alternative, right-click and click the Add 
Via  popup menu item.
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Adding Vias to Existing Traces
You can choose to add vias to a trace that you have already routed.

Restrictions and Limitations
You cannot add vias or test points to protected objects. You can, however, add a via to a trace corner if at 
least one of the segments in the corner is unprotected.

Procedure
Select an existing trace, trace segment, trace corner, or T-junction, right-click and click the Add Via  popup 
menu item. If adding a via to an existing trace changes a trace pattern, SailWind Router maintains first 
corner rules, which can result in changes to the trace pattern entering or exiting the via.

Adding Stitching Vias
You can also add vias to unroutes. Vias in unroutes are called stitching vias.

Procedure
1. Select an unroute, right-click, and click the Add Via  popup menu item.

Tip
Protect vias from being moved or ripped up by clicking the Tools > Options  menu item 
> Routing  category > / General  subcategory. Select the “Protect traces and vias when 
creating segments” check box. You can move protected vias if you select the “Shove 
protected traces when required” check box in the Routing  tab of the Design Properties 
dialog box.

2. Move the pointer to the via location, and click to place the via. A via appears connectedly directly 
to the net. In addition to maintaining via biasing rules, adding a via to an unroute also maintains 
component rules. If the components pins attached to the selected unroute have mismatched via 
biasing rules, the via type is ignored.

Related Topics
Ending Traces

Via Mode

Setting the Via Type

Setting the Via Pair Pattern

Moving Vias

Deleting Vias

Showing Via Guides
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Route to Coppers and Unroute Display
Both SailWind Layout and SailWind Router support routing to a copper. In some cases, however, 
SailWind Layout does not see that coppers are joined, and displays unroutes. In contrast, SailWind 
Router does not display unroutes and it does not add routes because it sees the objects as joined. 
SailWind Router's behavior saves in the routed design file where it can pass back to SailWind Layout.

To display the design’s unroutes again in SailWind Layout, perform a Length Minimization or modify the 
plane net routing in SailWind Layout.

SailWind Layout and SailWind Router exhibit this behavior in certain instances.

Connecting Through a Via
You can connect to a copper from a different layer through a via. In the figure below, the trace and the 
copper are on different layers. SailWind Router does not show an unroute because trace and copper 
are considered connected. SailWind Layout, however, shows an unroute because it does not consider a 
connection from another layer.

Table  82. Connecting to a Copper Through a Via From a Different Layer

SailWind Router does not show an unroute SailWind Layout shows an unroute

Connecting an Open or Closed Copper
You can connect an open copper with closed copper on the same layer in SailWind Router. In the figure 
below, the trace (open copper) is on the same layer as the copper (closed copper). SailWind Router does 
not show an unroute because open and closed coppers are considered connected. SailWind Layout, 
however, shows an unroute because it does not consider a connection between open and closed copper.

Table  83. Connecting an Open or Closed Copper

SailWind Router does not show an unroute SailWind Layout shows an unroute
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Differential Pairs
SailWind Router fully supports the implementation of differential pairs.

Differential Pair Principles
Creating Differential Pair Traces
Setting the Via Pair Pattern
Ending Differential Pair Traces
Splitting Differential Pair Traces

Differential Pair Principles
Differential pairs are traces that SailWind Router routes side-by-side, separated by a fixed routing gap for 
as much of the overall length as practical. Differential pairs typically transmit two electrical signals that are 
driven 180 degrees out of phase from each other. The fixed routing gap contributes to the specific and 
uniform impedance required by differential signaling.

SailWind Router respects differential pair objects created by SailWind Layout.

This section introduces the routing elements, characteristics, and routing steps unique to differential pair 
routing.

Differential Pair Routing Elements
The figure below illustrates the various differential pair routing elements and how they fit together. The 
table contains a description of each routing element.

Figure 81. Differential Pair Elements

Tip
The source pins, destination pins, start zone, and end zone labels in the preceding graphic 
correspond to routing that starts at the left-hand set of pins and ends at the right-hand set of pins 
(the label positions reverse if the routing starts at the right-hand set of pins).
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Table  84. Differential Pair Routing Elements

Routing element Description

Controlled gap area The part of the differential pair where the traces route in parallel, 
separated by the pair routing gap. The controlled gap area starts at the 
gathering point and ends at the split point.

Destination pins The completion points of the differential pair.

End zone The part of the differential pair between the split point and destination pins.

Gathering point The point near the source pins where differential pair traces start to route 
at the pair routing gap.

Pair routing gap The fixed edge-to-edge clearance between differential pair traces in the 
controlled gap area.

Shoulder The trace segment between the source pin and the gathering point, or 
between the split point and the destination pin.

Source pins The starting points of the differential pair.

Split point The point near the destination pins where differential pair traces no longer 
route at the pair routing gap and where the traces route separately to the 
destination pins.

Start zone The part of the differential pair between the source pins and gathering 
point.

A net may consist of differential pin pairs and non-differential pin pairs. The pair routing gap requirement 
does not apply to non-differential pin pairs.

Figure 82. Nets with Differential and Non-differential Pin Pairs

Defining Differential Pair Characteristics
Differential pairs typically route as impedance-matched traces, where each trace has the same specified 
impedance. The impedance is specified based on several factors and may depend on a particular IC 
manufacturer's recommendation or a standard imposed by the transmission medium through which the 
signals route; for example, LVDS and USB.

To yield differential pair routing with the desired impedance and signal propagation time, you supply the 
following differential pair properties to SailWind Router:

• Routing layer used to route the differential pair

• Pair routing gap
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• Trace width

• Minimum and maximum trace lengths

You can use a high-speed analysis tool to calculate the set of differential pair property values that yield 
the desired impedance. To perform the calculations, you supply to the analysis tool the following layer 
stackup information for the board:

• Sequence of routing, dielectric, and plane layers

• Thickness of each layer

• The dielectric constant for each dielectric layer

In addition, you should learn the smallest edge-to-edge trace gap that the selected printed circuit board 
vendor can accurately produce without incurring extra cost. In theory, the smaller the gap, the higher the 
impedance.

Suggested Differential Pair Routing Practices

Some routing practices can produce differential pairs with incorrect impedance values, unmatched signal 
propagation delays, or elevated electromagnetic interference (EMI) emissions. You can promote good 
differential pair performance by observing the following routing practices:

• Route the differential pair on one layer

• Avoid changing the trace width

• Maximize the percentage of the overall length that is routed at the pair routing gap

• Minimize shoulder lengths

• Match shoulder lengths

• Use the 45 degree routing angle

• Route differential pairs perpendicular to traces on adjacent routing layers if no plane layer 
separates the routing layers

Routing Differential Pairs
This section outlines the routing steps that are unique to routing differential pairs.

Routing From the Source Pins to the Gathering Point

The differential pair is routed from the source pins to the gathering point in as short a distance as practical 
while observing the design rules. The router also attempts to keep the differential pair traces together in 
the start zone. The gathering point can be set when the traces have sufficient clearance from source pins 
and other objects to be routed together at the pair routing gap.

This routing program attempts to match shoulder lengths. However the orientation of the routing relative 
to the source pins may produce unmatched shoulder lengths, as illustrated below.
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Figure 83. Differential Pair with Unmatched Shoulder Lengths

To allow the differential pair traces to exit high-density components, such as BGAs, SailWind Router can 
route around obstacles in the start zone and reduce the trace width to the minimum trace width. The 
router is allowed to split the differential pair around objects in the start zone, even if you do not allow 
routing the differential pair around objects in the controlled gap area.

When routing the start zone interactively, you can exercise a high degree of control over the shoulder 
routing path by entering the route separately mode and routing the individual traces to the gathering point. 
At the gathering point, you can exit the route separately mode and route the traces together.

Routing in the Controlled Gap Area

Between the gathering point and split point, the differential pair traces route together at the pair routing 
gap and at a constant trace width. During autorouting, the traces do not split around obstacles in the 
controlled gap area unless you specifically allow it. When routing interactively, you can always split 
around obstacles in the controlled gap area.

Routing from the Split Point to the Destination Pins

The differential pair routes from the split point to the destination pins in as short a distance as practical 
while observing the design rules set for the pair, such as minimum length. After setting the split point, the 
router routes the traces separately to the destination pins.

SailWind Router can route around obstacles in the end zone, just as it can when routing from the source 
pins to the gathering point.

Routing Around Obstacles

During autorouting, you can allow the differential pair to split around small obstacles in the controlled gap 
area by selecting the “Allow pair to split around obstacles” check box on the Differential Pair Properties 
dialog box. When routing interactively, you can always split around obstacles in the controlled gap area.

To prevent the pair from splitting too far apart or for too long a distance, you can also specify in the dialog 
box the maximum obstacle size and maximum obstacle quantity properties. Obstacles in the start zone or 
end zone are not counted against the maximum obstacle quantity you set.

Restricting Layer Changes

You can force SailWind Router to route the controlled gap area on one layer by selecting the “Restrict 
layer changes during autorouting” check box on the Differential Pair Properties dialog box. When you 
select this property, SailWind Router attempts to route the controlled gap area without vias and prevents 
you from interactively inserting vias into the controlled gap area.

To route the differential pair on one layer from a set of available layers, select the specific layers on 
the Layer Biasing  tab in the Net Properties dialog box. The autorouter selects a layer from the set of 
available layers and routes the differential pair only on the selected layer. For example if you specify a set 
of four available layers, the autorouter selects one of the four layers and routes the differential pair only 
on the selected layer.

To route the differential pair only on a specific layer when using the autorouter, select only that specific 
layer on the Layer Biasing  tab in the Net Properties dialog box.

332 SailWind Router Guide



 
Manual Routing

Differential Pair Principles

You can add fanout vias to the differential pair routing, even when you choose to restrict layer changes. 
This behavior allows you to connect the differential pair to high-density BGA pins at the same time you 
route the controlled gap area on one layer.

Figure 84. Differential Pair with Fanout Vias and No Routing Vias

Adding Via Pairs

To change layers for the differential pair, SailWind Router inserts a pair of vias using one of the patterns 
illustrated below. (The via pattern names are based on the orientation of the via pair axis relative to the 
axis of the routing as it approaches the via pair.) The patterns keep the vias in a close, symmetrical 
pattern, and minimize the length of the connecting stubs. The perpendicular pattern is the default pattern, 
offering the best symmetry.

Figure 85. Via Pair Patterns

Via pairs snap to the via grid when you enable this feature. The following illustration shows the via pair 
reaction to the via grid.
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Figure 86. Via Pair Reaction to Via Grid Setting

To add an individual via, route the traces separately. You can resume routing the traces together after 
placing both vias individually if both traces use the same routing layer. Or you can place the vias and 
complete the routing, and then you can interactively move the vias to the preferred locations.

Adding Length

To meet the differential pair's minimum length property, insert a symmetrical differential pair accordion 
into the controlled gap area. The autorouter can insert an accordion that meets the required length if the 
required space on the board is available, or you can interactively add an accordion.

Figure 87. Anatomy of a Differential Pair Accordion

For more information, refer to “Creating Differential Pair Traces” and “Ending Differential Pair Traces.”

Length Matching

If you run any autorouting operation or if you run the Tune pass type on a differential pair, the autorouter 
attempts to match the length of both pair members exactly. When possible, it adds length to the shorter 
pair member in the shoulder of the trace, without plowing or shoving obstacles.
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The autorouter adds length by adding small accordions to the shorter trace. The autorouter attempts 
to add the accordions to the shoulder areas first. If neither shoulder area can accommodate the small 
accordion, the autorouter adds the accordion in the controlled gap area, as close as possible to the 
shoulder area.

Creating Differential Pair Traces
Create differential pair traces by routing interactively. Before routing, you need to choose a starting point 
for the differential pair and initiate interactive routing.

To route single traces, see “Creating Traces”  on page 304.

Tip
You can add arcs while routing differential pairs.

Restrictions and Limitations
You cannot change the trace width while interactively routing differential pairs.

Procedure
1. On the main toolbar, click the Route Editing  button. On the Route Editing toolbar, click the 

Interactive Route  button; then select an unroute.

2. Define a differential pair either in SailWind Layout or in this program. For more information, see 
“Creating a New Object in a Secondary Group”  on page 53.

3. On the standard toolbar, in the Layer list, choose the layer where the objects that you want to route 
reside. You cannot interactively route on restricted layers. Set layer restrictions on the Layers  tab 
or the Layer Biasing  tab of the Design Properties dialog box.

4. With the differential pair selected, right-click and click the Interactive Route  popup menu item. You 
only need to select one of the unroutes in the differential pair. The traces route jointly. SailWind 
Router removes hatch outlines automatically when you start interactive routing.

5. Move the pointer to route the traces. As you move the pointer, guard bands may appear, indicating 
obstacles.

6. To route the traces individually, right-click and click the Route Separately  popup menu item. After 
routing the trace to the point you want, right-click and click the Switch Trace  popup menu item 
to route the other trace. After routing the other trace to the same point, right-click and click Route 
Separately  (popup menu item) again to resume routing the traces jointly. As an alternative, use the 
Tab key to switch between members of the differential pair.

7. Click to anchor the gathering point, and start routing the controlled gap area. You have reached a 
valid gathering point when the traces route together at the pair routing gap and—if enabled—guard 
bands highlight any obstructions.

8. If necessary, add the following while routing the controlled gap zone:

• Corners  on page 318 — Needed if you are routing without dynamics. Optional if routing with 
dynamics. Corners change the direction of a trace.

• “Arcs”  on page 321 — To create arc segments.
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• Splits  on page 340 — Allow the traces to pass around both sides of an obstacle by 
temporarily exceeding the pair routing gap.

• Via pairs  on page 336— To change layers while routing. To change via pair orientation, right-
click, choose the Via Pattern  popup menu item, and click the new via pattern.

• Test points  on page   — To make your design testable.

• Length  on page 312— To meet length rules.

9. To change layers while routing, right-click, choose the Layer  popup menu item, and click the layer 
on which you want to continue routing. To select a layer that is not listed, click the Choose  popup 
menu item. The trace segment, from the last corner, moves to the new layer. Alternatively, use 
Layer Toggle to switch to the other layer in the layer pair automatically. You can also scroll through 
layers using the wheel button on your mouse.

For more information, see “Scrolling Through Layers Using the Wheel”  on page 126.

If necessary, SailWind Router adds vias (of the current via type) or automatically removes them 
when you change layers. It does not remove vias that are also test points.

10. To change the routing angle while routing, right-click, choose the Routing Angle  popup menu 
item, and click the new angle.

11. End the trace as described in “Ending Differential Pair Traces”  on page 338.

Related Topics
Creating Matched Length Net Groups

Creating Matched Length Pin Pair Groups

Creating Traces

Creating Traces Using Component Rules

Ending Traces

Modeless Commands and Shortcut Keys

Setting the Via Pair Pattern

Setting the Via Pair Pattern
When you route differential pairs, the via pair pattern determines the orientation of the via pair axis 
relative to the axis of the routing as it approaches the via pair. You can choose to change the via pair 
pattern while routing interactively.
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Procedure
1. Right-click, choose the Via Pattern  popup memory item, and click the desired pattern.

2. A smoothing pass runs automatically after you change the via pair pattern. The following illustration 
shows the available via pair patterns:

Figure 88. Available Via Pair Patterns

Related Topics
Vias

Moving Vias

Deleting Vias
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Ending Differential Pair Traces
You can end differential pair traces in one of three ways while routing interactively.

Completing Diff Pair Trace Connections
Ending the Diff Pair Traces With a Via Pair or Test Point Pair
Ending the Diff Pair Traces Leaving Them Incomplete

Completing Diff Pair Trace Connections
SailWind Router offers specialized commands for completing differential pair traces.

Restrictions and Limitations
You cannot use the Complete command to complete traces while routing a differential pair in arc mode.

Procedure
1. When you near the completion point, right-click and click the Route Separately  popup menu 

item to route an individual trace to the destination pin. When you are using Route Separately, 
the pointer changes to a double circle when the pointer is near a valid completion point. During 
rerouting, the pointer changes to a single circle to indicate a valid completion point.

Alternatively, when the pointer is near the object at which you want to complete the trace, right-
click and click the Complete  menu item, or double-click.

2. Click on the object where you want to complete the trace.

3. To route the other trace first, right-click and click the Switch Trace  popup menu item. As an 
alternative, use the Tab shortcut key to switch traces. When the first differential pair trace is 
completed, the other trace is automatically selected for completion.

Results
If you have enabled Design Rule Checking (DRC) Prevent mode and you receive an error message while 
trying to complete a trace, or if an operation does not complete, right-click and click the Explain Last 
Error  popup menu item. The DRC explains the cause. Error markers appear if you have made them 
visible. If you have enabled DRC Explain mode instead, the DRC explains the error automatically and you 
can either accept the error (right-click and click the Continue with Errors  popup menu item) or you can 
reject it (press the Esc key or right-click and click the Cancel  popup menu item).

If you are using DRC Prevent or Explain mode for clearance checking, you can temporarily turn off 
clearance checking in order to complete a trace. To do so, while routing, right-click and click the Check 
Clearance  popup menu item. You can then complete the trace, even if you are creating a clearance 
violation. With clearance checking disabled, you can violate clearance boundaries and create clearance 
violations. When you click to complete an operation, error markers appear in the workspace at the 
location of each error, and error messages appear in the spreadsheet window. You can continue with 
additional operations with clearance checking disabled. To reactivate clearance checking during routing, 
right-click and click the Check Clearance  popup menu item.

Restriction:
You can only use DRC with interactive routing, trace editing, and placement editing operations.
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Ending the Diff Pair Traces With a Via Pair or Test Point 
Pair
You can choose to end traces with a via pair or test point pair.

Restrictions and Limitations
You cannot end any trace with a via or test point if the current trace segment is an arc. If you end a trace 
while in an arc, the trace ends with no via or test point, regardless of the End Via mode setting.

Procedure
1. Right-click, choose the End Via Mode  popup menu item, and click one of the following end via 

modes:

• End No Via  — End without a via pair.

• End Via  — End with a via pair of the current type, on the via grid, at the closest location to the 
pointer. Obstacles move to accommodate the via pair.

• End Test Point  — End with a via pair of the current test point type, on the test point grid, at 
the closest location to the pointer; however, the via pair is also a test point. Obstacles move to 
accommodate the via pair.

SailWind Router uses the end via mode you choose until you choose a new mode.

2. Press Ctrl+click to end the trace with a via or test point, or right-click and click the End  popup 
menu item.

Ending the Diff Pair Traces Leaving Them Incomplete
You can choose to end the traces at an intermediate location and finish routing them later.

Procedure
1. Right-click and click the End  popup menu item. Unless you are ending from an arc, you must set 

the end via mode to End No Via. (When ending from an arc, traces automatically end with no vias 
or test points.)

2. If you click End  (popup menu item) while the point is over a completion point, the traces completed 
instead of end.

3. When you end the traces, a smoothing pass runs automatically if you select the Smooth traces on 
complete box on the Options Dialog Box, Routing Category, General Subcategory.

Related Topics
Ending Traces Using Component Rules

Creating Differential Pair Traces

Creating Traces Using Component Rules

Moving Vias
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Deleting Vias

Autorouting by Selection

Splitting Differential Pair Traces
When routing a differential pair in the controlled gap area, you can split the traces to route them around 
an obstacle. You might split differential pair traces when you cannot route both traces together around an 
obstacle. SailWind Router always enables splitting in the start zone and end zone.

Restrictions and Limitations
Differential pairs can split around only small obstructions, such as through vias and through pins.

Procedure
1. While routing interactively, right-click and click the Split Trace Segments  popup menu item.

2. The next click completes the split operation, allowing you to continue interactively routing the 
differential pair.

Related Topics
Creating Differential Pair Traces

Changing Trace Properties While Routing
If necessary, you can change trace properties while interactively routing.

Procedure
1. To change layers while routing, right-click, choose the Layer  popup menu item, and select the 

layer on which to continue routing. The trace segment, from the last corner or from the beginning of 
the trace, moves to the new layer.

To choose a layer that is not listed, click the Choose  popup menu item.

Alternatively, right-click and click the Layer Toggle  popup menu item to switch to the other layer in 
the layer pair. You can also scroll through layers using Alt+wheel button.

For more information, see “Scrolling Through Layers Using the Wheel”  on page 126.

If necessary, the software adds or removes vias (of the current via type) automatically when you 
change layers. The software does not remove vias if they are also test points.

2. To change the width of the traces while routing, right-click, choose the Width  popup menu item, 
and click a width. To enter a width that is not listed, click Set  (popup menu item).

For more information, see “Change Trace Width”  on page 353.

3. To change the routing angle while routing, right-click, choose the Routing Angle  popup menu 
item, and click the desired angle.

4. To change between dynamic routing and manual routing, right-click and click the Dynamically 
Route  popup menu item. A check mark next to this option indicates it is enabled.
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5. To temporarily change plower settings to complete a trace, right-click and choose one of the 
following:

• Push Trace Behind  — Allows the plower to push traces behind the pointer as you interactively 
route.

• No Plowing  — Turns off plowing for the trace in progress.

• Plow After Click  — Reroutes obstacles after you add a corner or via. If you select Plow After 
Click, it only plows after you enter a corner or a via.

• Plow with Pointer  — Reroutes obstacles as you move the pointer. As an alternative, press 
and hold the Alt key while routing to temporarily switch between real-time plowing and guided 
plowing with the pointer. When using guided plowing, the potential path appears in green, but 
turns to yellow if the path encounters immovable objects. If your current trace colors are green 
or yellow, SailWind Router uses white and red instead.

• Rip Up Obstructing Traces  — Unroutes obstacles.
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Chapter 20
Manual Editing

SailWind Router provides you with tools for editing traces manually after adding them to your design.

Setting Up Trace Editing
Changing the Routing Angle Mode
Edit Traces Using DRC Modes
Stretch Traces and Arcs
Reroute Traces
Trace Smoothing
Change Trace Width
Converting a Trace to an Arc
Moving Trace Objects
Moving Traces to Other Layers
Move Accordions
Deleting an Accordion
Moving Arcs
Deleting Arcs From Existing Traces
Moving Corners
Deleting Corners
Move Test Points
Deleting Test Points
Deleting Test Point Vias
Moving Vias
Deleting Vias
Deleting a Trace While Interactively Routing
Deleting Existing Traces or Parts of Traces
Unrouting Nets and Trace Segments
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Setting Up Trace Editing
After you complete routing a design, you may want to edit traces or areas of the board. Before you start to 
edit the traces, set up editing options that help control trace editing.

For more information, see Options Dialog Box, Routing Category, General Subcategory.

Tip
You cannot edit protected objects, elements of physical design reuses, or jumpers.

Showing Clearances Around Obstacles
Plowing Traces
Remove Overlapping Segments

Showing Clearances Around Obstacles
You can view the minimum clearance around obstacles with transparent, colored outlines that surround 
them on the display. These outlines, called guard bands, point out obstacles to objects as you route or 
edit them. Guard bands also show the minimum distance you must maintain between objects.

Procedure
1. Choose the Tools > Options  menu item; then, in the Options dialog box, click the Global  category 

> General  subcategory.

2. In the “Display settings” area, select the “Show guard bands on object” check box.

Plowing Traces
If desired, you can enable SailWind Router to push and shove other traces while you make edits.

Procedure
1. Choose the Tools > Options  menu item; then, in the Options dialog box, click the Routing 

category > General  subcategory.

2. In the Plower area, select the “Turn on plower” check box. SailWind Router maintains the Plower 
settings automatically during editing operations. For more information, see “Interactive Routing 
Setup”  on page 291.

Remove Overlapping Segments
If you create an overlapping segment when editing a trace, SailWind Router automatically removes the 
overlap.

The following figure illustrates this principle:
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Figure 89. Overlapping Segments Removed

Changing the Routing Angle Mode
Editing operations automatically maintain the current routing angle. However, you can change the routing 
angle mode temporarily while editing a trace corner.

For example, if you add or move a segment corner, and the routing angle mode is Diagonal, the selected 
segment corner moves on a diagonal grid, and adjacent traces move in correspondence, as shown in the 
following figure.

Figure 90. Editing Traces— Routing Angle Mode

If desired, you can temporarily change the routing angle mode to Orthogonal to make an edit.

Restrictions and Limitations
SailWind Router does not maintain the routing angle when adding or moving a corner.

Procedure
1. Select a trace segment corner for editing, right-click, and choose the Move  popup menu item.

2. While moving the corner, right-click and choose the Routing Angle  popup menu option, then click 
the angle mode you want to use. As an alternative, use the AO, AD, or AA shortcut keys.
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3. To temporarily change the routing angle, while editing, press Shift. This overrides the current 
routing angle. If you are in Orthogonal or Diagonal mode, you switch to Any Angle. If you are in 
Any Angle mode, you switch to Diagonal. When you release the Shift key, you return to the original 
routing angle mode.

Edit Traces Using DRC Modes
Editing operations automatically maintain current DRC settings. For example, if the DRC mode is set to 
Prevent, and an attempt to complete an editing operation creates a violation, you cannot complete the 
editing operation.

You can use three temporary DRC modes to help complete editing operations. During editing operations, 
you can access temporary DRC modes by use of a right-click menu.

The temporary DRC modes available for editing operations are as follows:

• Ignore Clearance  — Temporarily disables clearance checking, which may make it possible to 
complete an editing operation.

• Check Clearance During Move — Checks clearance during editing. This option is mutually 
exclusive with the Check Clearance By Click mode.

• Check Clearance By Click  — Checks clearance after you click to complete the editing 
operation; for example, when you click to indicate the new location of a moved trace. This option 
is mutually exclusive with the Check Clearance During Move mode.

In addition, you can right-click and choose the Explain Last Error  popup menu item for additional 
information on any errors you encounter.

Related Topics
Setting Design Rule Checking
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Stretch Traces and Arcs
The Stretch command shrinks and stretches trace objects, including arcs, trace segments, trace paths, 
and trace corners. SailWind Router pushes and shoves movable obstacles during stretch operations 
if you select the “Turn on plower” check box (Options dialog box > Routing  category > General 
subcategory).

SailWind Router removes hatch outlines when you stretch traces.

When you stretch trace corners, the corners convert to miters, as shown in below.

Figure 91. Stretching Trace Corners

Note:
If a selected trace corner is also a virtual point, you cannot stretch the corner.

Stretching Trace Objects
Stretching Arcs

Stretching Trace Objects
You can stretch traces or traces segments.

Restrictions and Limitations
You cannot stretch a corner that has arcs attached to it.

Procedure
1. Select an object then right-click and click either Stretch  or Stretch Adjacent Segments  popup 

menu item.

Restriction:
The Stretch Adjacent Segments option appears only if you select a trace corner to move.

2. You can stretch trace segments or trace corners. Move the pointer to the new location and click to 
complete the stretch.

Stretching Arcs
You can stretch arcs or trace corners into arcs.
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Procedure
1. Select an object then right-click and click the Stretch Arc  popup menu item.

2. Move the pointer to the new location for the arc and click to complete the stretch. As a 
recommended practice, protect traces containing arcs before stretching them, as stretching a trace 
segment attached to an arc may remove arc corners.
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Reroute Traces
You can change the pattern of an existing trace, or create a new pattern for a trace, a trace segment, or 
an unroute.

SailWind Router automatically removes hatch outlines when you reroute traces.

Rerouting with Interactive Routing
Rerouting with Quick Route
Rerouting with Split

Rerouting with Interactive Routing
You can choose to reroute a trace interactively as one of the many editing options in SailWind Router.

Procedure
1. Select the trace, via, trace corner, or trace segment to reroute at the point from which you want to 

start rerouting.

2. Reroute the trace, creating a new trace as described in “Creating Traces”  on page 304. If you have 
trouble completing the trace, check the following:

• Trace sharing settings of the net to which you are routing in the “Allow junctions on” area 
(Topology  tab of the Net Properties or Design Properties dialog box). If you disable the sharing 
settings, you may not be able to complete the trace.

• The “Allow loops when rerouting” check box (Options dialog box > Routing  category > General 
subcategory).

3. Double-click along another point in the same trace or net to complete the reroute. SailWind Router 
removes loops in the trace unless you select the “Allow Loops when Rerouting” check box (Options 
dialog box > Routing  category > General  subcategory). Clicking Complete  when rerouting a 
previously complete trace has no effect. For more information, see “Design Rule Checking and 
Interactive Routing”  on page 297.

Rerouting with Quick Route
The Quick Route feature lets you reroute a trace by defining a new trace pattern and then smoothing it. 
The Quick Route feature is useful when you make changes that result in a new path around an obstacle.

If you select the “Smooth traces on complete” check box in the Options dialog box > Routing  category 
> General  subcategory, the newly rerouted trace pattern is automatically smoothed upon completion. 
However, if the new trace pattern does not differ widely from the original pattern, the smoothed trace is 
likely to resemble the original. For this reason, Quick Route is most useful when creating a new path 
around an obstacle. An example of Quick Route rerouting appears in the following figure.
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Figure 92. Quick Route Rerouting

Quick Route uses the push away feature. Traces are pushed away from obstacles regardless of whether 
you selected the “Push segments away from obstacles” box (Options dialog box > Routing  category > 
General  subcategory).

Procedure
1. Select a trace then right-click and click the Quick Route  popup menu item. Alternatively, on the 

Route Editing toolbar, click the Quick Route  button.

2. Move the pointer in the direction of the new trace pattern. You cannot change the layer of the trace 
or add vias while using Quick Route.

3. Click to enter any corners as you redefine the trace pattern.

4. When you get near the completion point, right-click and click the Complete  menu item.

Rerouting with Split
Split divides trace segments into multiple segments by adding corners. The same segments or paths 
remain selected so you can add more corners.

You can split trace segments or trace paths.

Procedure
1. Select an object, right-click and click the Split Trace Segments  popup menu item.

2. Click to indicate new corners.

3. Double-click when you finish redefining the trace pattern.
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Trace Smoothing
Smooth trace patterns to remove unnecessary corners or reduce length. Trace smoothing frees up room 
on the board for additional traces and helps meet and maintain pad entry and first corner rules.

Smoothing is a single layer glossing operation. Smooth traces does not remove vias.

Smoothing converts arcs to line segments. Protect arcs before smoothing traces that contain arcs.

Smoothing Traces While Routing or Rerouting
Smoothing Traces While Plowing
Smoothing Existing Traces

Smoothing Traces While Routing or Rerouting
You can choose to smooth traces as the routing process completes them.

Procedure
1. Click the Tools > Options  menu item; then in the Options dialog box, click the Routing  category > 

General  subcategory.

2. Select the “Smooth traces on complete” check box then click OK. Smoothing occurs as you 
complete traces during either interactive routing or editing.

Smoothing Traces While Plowing
You can smooth obstructing traces as they are shoved during editing operations.

Procedure
1. Click the Tools > Options  menu item; then in the Options dialog box, click the Routing  category > 

General  subcategory.

2. In the “Plower” area, select the “Plow traces smoothly” check box.

Figure 93. Plowing— Smoothing Traces

Related Topics
Interactive Routing Setup
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Smoothing Existing Traces
You can smooth traces, trace segments, trace paths, and differential pair traces.

Procedure
1. Select a trace then right-click and click the Smooth Trace Pattern  popup menu item.

2. If you select a differential pair, right-click and click the Diff Pair Smooth  popup menu item. When 
smoothing differential pairs, select the entire differential pair. If you only select one of the traces 
in the pair, the single trace may be smoothed if the matching trace in the pair is not found, thus 
invalidating the differential pair.
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Change Trace Width
You can change the width of traces both while interactively routing and after traces are complete. For 
example, you can change the width of a trace if its current width is an obstacle to completing the trace. By 
using a smaller trace width, you can complete the trace without violating design rules.

Restriction:
You cannot change the width of differential pair traces when routing in the controlled gap area.

Changing Trace Width While Routing Interactively
Changing the Width of Existing Traces

Changing Trace Width While Routing Interactively
If necessary, you can change the width of a trace while routing interactively. You can either select a new 
trace width from a list or type a specific width.

Procedure
1. While routing, right-click, choose the Width  popup menu item, and either click a width or click Set 

to type a width.

Alternatively, press the W key during interactive routing to specify a width to apply. The list of 
widths that appears includes the last widths set using the W shortcut key, and the minimum, 
recommended, and maximum widths (according to design rules).

While routing with a reduced width, an indicator appears at the pointer. This indicator shows you 
when you can return to the previous trace width.

2. Click to continue routing the trace at the previous trace width.

3. If you are plowing while routing, objects move out of the way to accommodate a larger trace width.

Changing the Width of Existing Traces
You can change the width of traces, trace segments, trace paths, nets, and pin pairs.

Procedure
1. Select a trace that has a widths that you want to change.

2. Right-click, choose the Width  popup menu item, and click either a width from the list or click Set  to 
type a width. This list contains the recently used widths followed by the minimum, recommended, 
and maximum trace widths.

Alternatively, click a trace and press the W key to apply a specific width.

Results
If the plower is enabled, movable trace objects move to accommodate the new width.
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Converting a Trace to an Arc
You can convert the existing traces and trace corners to arcs. You can also change the radius of an arc.

Converting Existing Traces to Arcs
Converting Corners to Arcs
Changing the Radius of an Arc

Converting Existing Traces to Arcs
You can convert existing traces, trace segments, and trace paths to arcs.

Procedure
1. Select a trace segment then right-click and click the Create/Modify Arc  popup menu item.

2. Move the pointer to define the radius of the arc.

3. Click to complete the arc. Alternatively, right-click and click the Finish  popup menu item.

Converting Corners to Arcs
You can convert a corner to an arc by using the Stretch Arc command. The Stretch Arc command 
converts any trace segment that has convergent adjacent segments. You can create an arc with end 
points that are not tangent to adjacent segments. Adjacent segments stretch but retain their current angle. 
Using Stretch Arc automatically disables the “Push segments away from obstacles” check box (Options 
dialog box > Routing  category > General  subcategory).

Restrictions and Limitations

• You cannot use Stretch Arc on segments with vias at the end points.

• You cannot use Stretch Arc on segments that have an arc or a partially routed trace as an end 
point.

Procedure
1. Select a corner then right-click and click the Stretch Arc  popup menu item.

2. Move the pointer to stretch the arc to the correct location.

3. Click to create the arc.

Changing the Radius of an Arc
You can adjust the radius of an existing arc. When modifying an existing arc, you cannot change the end 
points of the arc segment; they are fixed.
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Procedure
1. Select an arc then right-click and click the Create/Modify Arc  popup menu item.

2. Move the pointer to define the radius of the arc. You can also return the arc to a trace segment.

3. Click to complete the arc.

Moving Trace Objects
You can move trace objects, including trace segments, corners, T-junctions, vias, trace end points, and 
arcs. When you move a T-junction or a via, SailWind Router maintains pad entry rules, regardless of 
design rules or DRC modes.

If you select the “Smooth adjacent segments” check box (Options dialog box > Routing  category > 
General  subcategory), SailWind Router smooths adjacent trace segments as you move any trace object, 
except corners. When you move corners, it does not smooth adjacent segments.

When you move trace segments, adjacent segments do not move. Instead, SailWind Router adds new 
segments.

Figure 94. Moving Trace Segments

Procedure
1. Select a trace object then right-click and click the Move  menu item.

Tip
Unlike SailWind Layout, SailWind Router maintains the angle mode.

2. To change the routing angle mode, right-click and choose the Routing Angle  popup menu item; 
then click Orthogonal, Diagonal, or Any Angle.

Alternatively, use the AO, AD, or AA shortcut keys.

3. Move the pointer to the new location for the object, and click to complete the move.

Related Topics
Moving Arcs

Deleting Arcs From Existing Traces
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Moving Corners

Deleting Corners

Moving Vias

Deleting Vias

Moving Traces to Other Layers

Options Dialog Box, Global Category, General Subcategory

Moving Traces to Other Layers
You can move traces, trace segments, nets, paths, and pin pairs to other layers. When you select pin 
pairs or nets, all trace segments in the pin pair or net move to the new layer, regardless of their current 
layer. The same is true when you move multiple trace segments. If necessary, SailWind Router adds or 
removes vias of the current via type automatically when you change layers. SailWind Router does not, 
however, remove protected vias or vias set up as test points.

Restrictions and Limitations
You cannot move a protected trace or any portion of the protected trace.

Procedure
1. Select the objects to move.

Tip
Before changing layers, press Alt while scrolling the wheel button on the mouse to preview 
layers.

2. Right-click, choose the Layer  popup menu item, and click to select a layer from the list or click 
Choose  to move to a layer that does not appear in the list.

The list contains the most recently visited, valid layers followed by other valid layers. If selected 
objects have conflicting layer biasing rules, invalid layers are not presented. If plowing is enabled, 
movable trace objects on the new layer are plowed to accommodate the new trace segments.

Results
When moving traces to other layers while the DRC mode  on page 405 is set to Prevent:

• SailWind Router adjusts trace widths to support conditional rules on the new layer.

• Layer changes are cancel automatically if the layer change results in DRC violations.

Related Topics
Scrolling Through Layers Using the Wheel

Moving Trace Objects

356 SailWind Router Guide



 
Manual Editing

Move Accordions

Move Accordions
SailWind Router does not treat accordions as objects in the database; it treats them as a collection of 
trace segments. You can therefore move the trace segments, not the entire accordion.

For more information, see “Moving Trace Objects.”

Deleting an Accordion
You can remove accordions while interactively routing the same way that you delete traces.

Procedure
While routing interactively, right-click and click the Cancel  popup menu item or press the Esc key. While 
adding accordions, you can remove sections of the accordions by right-clicking and clicking the Backup 
popup menu item or pressing the Backspace key. If you click Backup  after you complete the accordion, 
SailWind Router removes the entire accordion.

Related Topics
Add Length to Traces

Moving Arcs
When you move an arc, it does not modify the current shape; it modifies the position only.

Procedure
1. Click on an arc then right-click and click the Move  popup menu item. Alternatively, on the Route 

Editing toolbar, click the Move  button.

2. To change the routing angle mode, right-click and choose the Routing Angle  popup menu item; 
then click Orthogonal, Diagonal, or Any Angle.

3. Move the pointer to the new location for the arc and click to complete the move. If you select 
the “Smooth adjacent segments” check box (Options dialog box > Routing  category > General 
subcategory), SailWind Router smooths adjacent trace segments as you move segments adjacent 
to the arc.

Figure 95. Moving an Arc
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Deleting Arcs From Existing Traces
You can remove an arc from an existing trace and replace it with a trace segment.

Procedure
1. Click an arc to select it then press the Backspace key. Alternatively, right-click and choose the 

Unroute  popup menu item.

SailWind Router removes the arc from the trace, leaving an unrouted gap between trace 
segments.

2. Select one of the trace segments to either side of the unrouted gap and click the Interactive Route 
toolbar button or right-click and click the Interactive Route  popup menu item.

3. Route a new trace between segments to complete the gap.

Related Topics
Deleting Existing Traces or Parts of Traces

Moving Trace Objects

Arcs

Options Dialog Box, Global Category, General Subcategory

Moving Corners
You can move corners from one place in the trace segment to another.

Restrictions and Limitations

• If the trace corner or T-junction is also a virtual point, you cannot move the corner or T-junction to 
a location that creates a subnet violation.

• When moving corners, SailWind Router does not smooth adjacent segments even if you select 
the “Smooth adjacent segments” check box (Options dialog box > Routing  category > General 
subcategory).

Procedure
1. Click a trace corner to select it then right-click and click the Move  popup menu item.

2. Move the pointer to the location at which to place the corner and click.

Deleting Corners
You can delete corners while interactively routing.
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Move Test Points

Restrictions and Limitations
You cannot delete corners or T-junctions that are also virtual points.

Procedure
1. Select the corner and press the Backspace key to remove the corner and unroute the adjacent 

trace segments.

2. Alternatively, to delete a corner without unrouting the trace, select the corner then right-click and 
click the Delete  popup menu item. Alternatively, press the Delete key.

SailWind Router removes the corner and replaces it with a straight trace segment. If the resulting 
trace segment encounters an obstacle, and you select the “Push segments away from obstacles” 
check box (Options dialog box > Routing  category > General  subcategory), the trace segment 
pushes away from the obstacle.

Related Topics
Corners

Deleting Existing Traces or Parts of Traces

Moving Trace Objects

Options Dialog Box, Global Category, General Subcategory

Move Test Points
You can move a test point via just as you can move a via.

For more information, see ““Moving Vias”  on page 360.”

Deleting Test Points
If desired, you can delete a test point from a pin or a via. However, in doing so, you delete only the test 
point assignment, not the via to which it is assigned.

Procedure
1. Select a via or a pin that is a test point.

2. Right-click and click the Properties  popup menu item.

3. Clear the “Serve as a test point” check box.

4. Click OK.

Deleting Test Point Vias
You can remove a test point via from the design.
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Restrictions and Limitations
You cannot delete a test point if you selected the Preserve Test Points box in the Options dialog box > 
Test Points  subcategory.

Procedure
Select a test point via then right-click and click the Delete  popup menu item.

Related Topics
Ending Traces

Adding Test Points While Interactively Routing

Moving Vias
You can move unprotected vias. Trace segments attached to the via stretch as you move the via. When 
you move a via, SailWind Router maintains pad entry rules regardless of design rules or DRC modes.

Procedure
1. Click a via to select it then right-click and click the Move  popup menu item.

2. Move the pointer to the new via location, and click to place the via.

Related Topics
Moving Trace Objects

Deleting Vias
You cannot delete protected vias or test points. You cannot use Delete to remove vias that are also virtual 
points: you must use the Unroute command instead.

Procedure
To delete vias during interactive routing, right-click and click Backup. To delete vias in completed traces, 
select a via then right-click and click Delete.

Results
If you assign a via as a test point, the test point also deletes when you clear the “Preserve test points” 
check box in the Options dialog box > Test Points  category.

Related Topics
Adding Vias While Interactively Routing

Deleting Existing Traces or Parts of Traces
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Deleting a Trace While Interactively Routing

Moving Trace Objects

Options Dialog Box, Global Category, General Subcategory

Deleting a Trace While Interactively Routing
Delete a trace or part of a trace while routing.

Procedure
To remove the last entered trace, trace segment, corner, via, or accordion, right-click and click the 
Backup  popup menu item. To exit interactive routing without completing any routing, press the Esc key. 
SailWind Router removes any trace segments and vias you added before pressing the key.

Deleting Existing Traces or Parts of Traces
Delete existing traces or parts of traces to reroute traces or segments.

Procedure
To delete traces or parts of traces, you must unroute the trace. See “Unrouting Nets and Trace Segments” 
on page 361. To remove trace corners, click to select a trace corner then right-click and click the Delete 
popup menu item. You cannot delete T-junctions or trace corners that are also virtual points.

Related Topics
Moving Arcs

Deleting Arcs From Existing Traces

Moving Corners

Deleting Corners

Moving Vias

Deleting Vias

Unrouting Nets and Trace Segments
Unroute a net or trace segment to delete it. You can unroute nets, paths, pin pairs, vias, and trace 
segments. You cannot unroute protected objects.

Prerequisites
To unroute traces, you must first select the “Allow trace unrouting” check box (Routing  tab of the Design 
Properties dialog box).

Procedure
Select an object then right-click and click the Unroute  popup menu item.
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Tip
Unlike SailWind Layout, in SailWind Router, the Delete command removes a trace corner only. 
You must use the Unroute command in SailWind Router to unroute a trace.

Results
The unrouting command unroutes selected traces or traces connected to selected objects. The result of 
unrouting varies depending on the object you select:

• Pin pair  — Unroutes the trace segment between the pin pair.

• Net  — Unroutes the entire net trace.

• Pin  — Deletes the trace segment entering the pin.

• Component  — Deletes the trace segment entering each pin of the component.

• Traces  — Unroutes the selected trace segment. When you unroute a trace, trace segment, or 
trace corner, adjacent vias are deleted.

• Protected Objects  — Cannot be deleted. You cannot unroute protected objects. If you try to 
unroute them, an error message appears. You can click on the text link in the message to zoom 
to the trace, via, or jumper location. Use the object’s Properties dialog box to unglue it. For more 
information see ““Design Rules”  on page 154.”

• Objects with a No Rip Up Rule  — Cannot be unrouted. The no rip up rule indicates that the 
autorouter cannot rip up and reroute a routed net. You can set this option in the Routing  tab of 
the Design Properties dialog box. You cannot unroute objects that have a no rip up rule. If you try 
to unroute them, an error message appears. You can click on the text link to zoom to the trace 
or via location. Use the object’s Properties dialog box to enable rip up. For more information see 
““Design Rules”  on page 154.”
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Chapter 21
Verify the Design

SailWind Router provides multiple tools for checking a design for errors.

Checking a Design for Errors
Verify Design Error Markers
Finding Errors
Displaying Ignored Errors
Exporting the Design Verification Errors to a Report
Ignoring Errors
Clearance Checks Using Hatch Outlines
Creating a Design Verification Scheme

Checking a Design for Errors
Set up design verification to inspect your design for errors. You can then view the errors in the Errors  tab 
of the Spreadsheet window or in the Error Properties dialog box.

Procedure
1. Click the Tools > Options  menu item; then, in the Options dialog box, click the Design 

Verification  category.

2. In the Design Verification  category, select a scheme name from the Design verification scheme 
name list if you want to modify a predefined set of design checks. To create a new design 
verification scheme, set the individual design checks and properties you want, and then click Save 
As.

3. In the “Conduct checks” area, restrict what you want to check in the design if needed.

4. In the “Check design for” area, select the check boxes of the parameters you want to verify.

Verification is based on the combination of your settings in both the Design Verification  category 
and the Fabrication  category of the Options dialog box.

5. When you finish making your verification settings, click OK.

6. On the Standard toolbar, click the Design Verification  button.

7. If necessary, on the Design Verification toolbar, click the Clear Errors  button to remove any error 
markers from the design.

8. On the Design Verification toolbar, choose the scheme you modified or created and saved in a 
previous step.

9. Click the Verify Design  button to check the design. Error locations are flagged in the work area 
with round symbols indicating the error type. Errors also appear in the list on the Errors  tab of the 
Spreadsheet window and in the Error Properties dialog box.

10. Correct any errors using Placement and Routing tools.
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Related Topics
Verify Design Error Markers

Creating a Design Verification Scheme

Exporting the Design Verification Errors to a Report

Ignoring Errors

Options Dialog Box, Design Verification Category

Options Dialog Box, Fabrication Category

Verify Design Error Markers
SailWind Router can visibly mark errors in your design after performing design checks.

Table  85. Verify Design Error Marker

Marker Description

Clearance Testability

Fabrication High-speed

Keepout Board outline

Assembly Maximum via number

 Tip
One marker is added for 
every net with too many 
vias.

Finding Errors
Use the error icon in the Type column of the Spreadsheet window for quick visual identification of the 
error.

Procedure
1. On the Errors  tab of the Spreadsheet window, click the hyperlink representing the error 

explanation.

The display zooms in and centers the corresponding error in the workspace.

2. Review the error information as follows:
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Displaying Ignored Errors

• Expand the error description in the Type column to view additional error details.

• Use the Layer column to identify the layer on which the error is found.

• View the design rule violation details in the Rule Violated column. To view the entire error, 
resize the column by double-clicking the right-hand column separator.

Displaying Ignored Errors
If you have chosen to ignore errors, you can redisplay them.

Procedure
Perform one of the following:

• Click the Display Ignored Errors  button on the Design Verification button

• Clear the “Ignore error during verification operations” check box in the Error Properties dialog box

• Clear the corresponding “Ignored” check box on the Errors  tab of the Spreadsheet window

Related Topics
Options Dialog Box, Design Verification Category

Verify Design Error Markers

Ignoring Errors

Exporting the Design Verification Errors to a 
Report
You can create an error report of the Design Verification errors and store it in HTML format, letting you 
share the information with other members of the design team.

Procedure
1. Run Design Verification to display errors in the Errors  tab of the spreadsheet window.

2. In the Spreadsheet window, click the Errors  tab.

3. In the Spreadsheet window, click the Export to HTML File  button.

4. When prompted, enter the name and location under which you want to store the file.

Related Topics
Finding Errors
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Ignoring Errors
Ignore errors if they are known acceptable conditions.

Procedure
1. Click an error in the work area to select it then right-click and click the Properties  popup menu 

item; then click the Error  tab.

2. Select the “Ignore error during verification operations” check box to ignore the error.

3. Click OK.

Clearance Checks Using Hatch Outlines
To completely check clearances, any hatch outlines (plane pour and non-plane pour) created by pouring 
operations in SailWind Layout must also be visible in SailWind Router.

If hatch outlines are invisible in a design, they are ignored during clearance checking. If pour outlines are 
visible, they are not verified during clearance checking.

Visible plane pour outlines are not obstacles to interactive routing and route editing, but are obstacles 
during automatic routing.

You can toggle the visibility of hatch and pour outlines:

• If the pour outline is visible, typing “po” displays the hatch outline and hides the pour outline.

• If the hatch outline is visible, typing “po” displays the pour outline and hides the hatch outline.

To see changes in your design when you toggle hatch or pour outline visibility, ensure you assign a visible 
color to layers of copper items.

Related Topics
Options Dialog Box, Design Verification Category

Setting Colors for the Design

Creating a Design Verification Scheme
Use the Design Verification  category to create a customized design verification scheme to reuse. A 
scheme is an easy way to save all your current settings on this tab. You can quickly switch among the 
schemes to run other checks without having to specify options individually.

Procedure
1. Choose the Tools > Options  menu item; then, in the Options dialog box, click the Design 

Verification  on page 425 category.

2. In the “Check design for” section, select the rules you want to add to the design verification 
scheme. A design verification scheme can consist of several design rules to check.

366 SailWind Router Guide



 
Verify the Design

Creating a Design Verification Scheme

3. After making your design verification selections, in the “Design verification scheme” area, click 
Save As.

4. In the Save Scheme box, type the name you want to assign to the new design verification scheme, 
and then click OK.

Related Topics
Options Dialog Box, Fabrication Category
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Chapter 22
Reports

SailWind Router allows you to generate a series of reports to help you analyze various characteristics of 
your design. Use these reports to review design statistics, perform a pre-routing analysis, and examine 
the testability of your final assembly.

Reporting Design Information
The Design Report
Generating a Design Report
Generating a Prerouting Analysis Report
Testability Report
Creating a Testability Report
Test Points Report
Creating a Test Points Report
The Routing Report
Creating a Routing Report
Testing Database Integrity
Creating an Integrity Test Report

Reporting Design Information
SailWind Router provides you with several types of reports for a given design.

SailWind Router reports are available from one of the following primary categories:

• Design— Provides information about autorouter-related design elements, such as the number of 
nets, connections, traces, vias, unroutes, and the percent of routed connections in the design

• Prerouting Analysis— Provides information about design properties that may impede 
autorouting, such as grid settings, nets that have a disabled routing status, or pin pairs that have 
a shove-protected status

• Testability— Provides information about which nets are inaccessible and why they are 
inaccessible.

• Test Points— Provides information about all test points in the design, such as the total number 
in the design, their location, probe nail diameter, the object and netname to which the test point is 
assigned.

You generate most reports from the Report commands on the File  menu.

The Design Report
The Design report displays information about autorouter-related design elements, such as the number 
of nets, connections, traces, vias, unroutes, and the percentage of routed connections in the design. 
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SailWind Router stores this report, DesignReport.txt, in \SailWind Projects. To view the report, click the 
link to the report file, \SailWind Projects\DesignReport.txt, in the Status  tab of the Output window.

The format of the design report follows. For more information, refer to “Generating a Design Report.”

Design Report Format
The Design Report allows you to examine the statistics of your design in detail.

The design report is formatted as follows:

HEADER
SailWind Router Version         <version>
Report Name         (Design Statistics)
Design:         Filename of the open design
__________________________________________________________
Count
Nets:     Number of nets in the design
Connections:     Number of pin pair connections in the design
Traces:     Number of traces in the design
Vias:     Number of vias in the design
Unroutes:     Number of unroute instances in the design
Completion:     Percent of completed, routed connections in the design
__________________________________________________________
Trace Length     (design units)
Design Total:     Total length of all traces in the design
Layer:     Total length of traces on each layer of the design
Net:     Total trace length of each net in the design 

Sample Design Report

A Design Report contains information to assist you in analyzing your design.

SailWind Router Version v2004 SPac1, Design Statistics
Design: \SailWind Projects\Samples\pwrdemoe.pcb
__________________________________________________________
Count
Nets:              40
Connections:       119
Traces:            132
Vias:              29
Unroutes:          17
Completion:        85.7
__________________________________________________________
Trace length (Mils)
Design
Total:         49599
Layer
TOP            22872
BOTTOM         26727
Net
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$$$1906        1816
$$$1928        1795
$$$1951        1880
X              1880 

Generating a Design Report
The Design report provides information about autorouter-related design elements, such as the number of 
nets, pin pair connections, traces, vias, unroute instances, and the percent of routed connections in the 
design.

Procedure
Choose the File > Reports > Design  menu item.

Results
SailWind Router creates the DesignReport.txt  file in the \SailWind Projects  folder, and a link to the report 
appears in the Status  tab of the Output window. Click the link to view the report.

Related Topics
Reporting Design Information

Generating a Prerouting Analysis Report
The Prerouting Analysis report provides information about design properties that may impede autorouting, 
such as grid settings, nets that have a disabled routing status, or pin pairs that have a shove-protected 
status.

Procedure
Click the Tools > Pre-routing Analysis  menu item.

Results
Any errors or warnings are written to the Status  tab of the Output window.

Related Topics
Reporting Design Information

Testability Report
The Testability Report allows you to assess the overall testability of your design and helps to locate any 
nets that may not have accessible test points.

The report provides test points results in two ways:
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• By a number at the end of a inaccessible net, indicating the reason a test point is not added 
(shown in the Status  tab of the Output window after each routing pass). To report with this 
number, select Generate Test Points on the Test Points  tab of the Options dialog box.

• By a testability report. This report, TestabilityReport.txt, displays information about inaccessible 
nets. The reasons also appear so you can correct the problems. This increases the probability 
that your design is 100% accessible. This report is stored in \SailWind Projects. To view the 
report, click the link to the report file, \SailWind Projects\TestabilityReport.txt, in the Status  tab of 
the Output window.

For more information, refer to “Creating a Testability Report.”

Testability Report Format
The Testability Report uses a pre-defined format that allows you to view and analyze the testpoint data 
related to your design.

HEADER
System Name         (DFT Audit)
Report Name         (Board Report)
Board Name:         Name of the open design
Generation Date:         Date and time of the report generation
 
ELEMENTS:         Total number of elements used in the PCB.
         Elements can be components and/or vias.
Components:         Number of components used in the PCB
Vias:         Number of vias used in the PCB
 
SIDE:         PCB side selected for auditing:
         the bottom or both the bottom and top
 
PINS:         Total number of component pins
 
CONNECTED PINS:         Number of component pins connected to nets
Accessible Pins:         Number of accessible component pins
Inaccessible Pins:         Number of inaccessible component pins
Probed Pins:         Number of component pins connected to test
         probes(tester pins)
Nonprobed Pins:         Number of component pins not connected to test
         probes(tester pins)
 
UNUSED PINS:         Number of component pins not connected to nets
Accessible Unused Pins:         Number of accessible unused component pins
Inaccessible Unused Pins:         Number of inaccessible unused component 
 pins
Probed Unused Pins:         Number of unused component pins connected
         to test probes (tester pins)
 
VIAS:          Total number of vias
Accessible Vias:          Number of accessible vias
Inaccessible Vias:          Number of inaccessible vias
Probed Vias:          Number of vias connected to test probes
         (tester pins)
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Nonprobed Vias:          Number of vias not connected to test probes
         (tester pins)
 
NETS:         Total number of nets on the PCB, including
         nonconnected nets
Nets with Test Points:          Total number of nets in the PCB that are
         connected to test probes. This number is
         independent of the selected PCB sides.
Nets Without Test Points:          Total number of nets in the PCB not 
 connected
         to test probes. This number is independent of
         the selected PCB sides. Before test probe
         (tester pin) placement, this number is equal to
         the number of nets on the PCB.
Accessible Nets:          Number of nets that are accessible to test
         probes (nail pins) from the indicated side of
         the board
Partially Tested Nets:          Number of nets that are not totally routed 
 and
         the minimum test points specified for the net
         was not met
Inaccessible Nets:          Number of nets that are not accessible to test
         probes (nail pins) from the indicated side of
         the board
 

Table 86  lists possible reasons for inaccessibility.

Table  86. Inaccessibility Reasons

Reason Explanation

No.: Table entry number

Net Name: inaccessible netname

Pins: Component pins and vias on that net. Component pin names are specified as: 
Component Name. Component Pin Number.
Vias are specified as Via Name and location.

Reason: Reason for inaccessibility of each component pin on the inaccessible net. The 
reasons for inaccessibility follow.

Accessible from 
opposite side

The component pin is accessible from the other side of the board.
Probe from the opposite side of the board in the Test Points  tab of the 
Options dialog box.

SMD pin The component pin is an SMD pin; therefore, it cannot be tested in the test 
point pass.

Covered pin The component pin is covered (hidden) by another component; therefore, a 
test probe cannot reach it.
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Table  86. Inaccessibility Reasons  (continued)

Reason Explanation

Pad too small The pad size for the component pin or via is smaller than the specified 
minimum pad or via size; therefore, the available test probes cannot test this 
component pin.
Change the minimum pad probing size in the Test Points  tab of the Options 
dialog box.

Probing not allowed Vias cannot be probed.
Select Probe Vias in the Test Points  tab of the Options dialog box.

Buried via Buried vias that are not accessible from the bottom side (or top side if probed) 
are not accessible.

Outside board outline Vias and component pins outside the board outline are not accessible.

Probe to Probe 
minimum distance

Component pins or vias under the specified minimum distance requirements 
for Probe-to-Probe clearance cannot be probed, even though other 
accessibility requirements are met.

Probe to Component 
minimum distance

Component pins or vias under the specified minimum distance requirements 
for Probe-to-Component clearance cannot be probed, even though other 
accessibility requirements are met.

Probe to Board 
minimum distance

Component pins or vias under the specified minimum distance requirements 
for Probe-to-Board clearance cannot be probed, even though other 
accessibility requirements are met.

Component Test Point 
Keepout Violation

Component pins or vias cannot be probed in the keepout area associated with 
component.

Board Test Point 
Keepout Violation

Component pins or vias cannot be probed in the keepout area defined at 
board level.

Drill Size is bigger 
than Pad Size

Component pins or vias have drill sizes larger than pad sizes. Pads cannot be 
probed.

Zero Nail Pin Count 
Specified for Net

DFT Audit Net Preferences (in SailWind Layout) specify that net has zero 
test points. You can also set this preference on the Test Point  tab of the Net 
Properties dialog box.

Tooling Hole Component pins are tooling holes as specified in DFT Audit preferences in 
SailWind Layout.

TEST POINTS:          Total number of test probes used to test both
         sides of the PCB. This number is independent of
         the selected PCB sides and provides the number
         of probes on the top side and the number on the
         bottom side.
 
NAIL SIZES TABLE:           Number of nail pins used in testing the
          selected sides of the PCB. In addition, the
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          table shows the total number of nail pins
          used of each size and the total number of
          nail pins used in testing the selected sides
          of the PCB.  

Sample Testability Report

Use the information in the Testability Report to review the testability of your design and identify any areas 
that might need attention.

------------------------------------------
SailWind Router Version v2004 SPac1 DFT Audit
Board Report
Board Name: \SailWind Projects\Samples\pwrdemoe.pcb
Generation date : Tue Jun 01 13:44:32 2004
------------------------------------------
 
ELEMENTS: 79
--------
Components: 23
Vias: 56
 
SIDE: BOTTOM
============
 
PINS: 212
----
 
CONNECTED PINS: 159
--------------
Accessible Pins: 154
Inaccessible Pins: 5
Probed Pins: 40
Non-probed Pins: 119
 
UNUSED PINS: 53
-----------
Accessible Unused Pins: N/A
Inaccessible Unused Pins: N/A
Probed Unused Pins: 0
Non-probed Pins: 53
 
VIAS: 56
----
Accessible Vias: 56
Inaccessible Vias: 0
Probed Vias: 0
Non-probed Vias: 56
 
 
NETS: 40
----
Nets With Test Points: 40
Nets Without Test Points: 0

SailWind Router Guide 375



Reports
Creating a Testability Report  

Accessible Nets: 40
Partially Tested Nets: 0
===========================
 
TEST POINTS: 40
-----------
Top Side: 0
Bottom Side: 40
 
NAIL SIZES:
|------|------|------|------|
| Name | 100  | 75   | 50   |
|------|------|------|------|
| Top  | 0    | 0    | 0    |
|------|------|------|------|
|Bottom| 40   | 0    | 0    |
|------|------|------|------|
| Total| 40   | 0    | 0    |
|------|------|------|------| 

Creating a Testability Report
The Testability report provides information about the testability of a board, including which nets are 
accessible and which are inaccessible.

Running the Testability report creates the file TestabilityReport.txt  in the \SailWind projects  folder. A link to 
the report appears in the Status  tab of the Output window.

Procedure
Click the File > Reports > Testability  menu item.

Results
The file TestabilityReport.txt is created in the \SailWind projects folder, and a link to the report appears in 
the Status  tab of the Output window. Click the link to view the report.

Related Topics
Reporting Design Information

Testability Report

Test Points Report
The Test Points report displays information about all test points in the design, such as the total number, 
location, probe nail diameter, the object, and the netname to which each test point is assigned. SailWind 
Router stores the report, TestPointReport.txt, in \SailWind Projects. To view the report, click the link to the 
report file, \SailWind Projects\TestPointReport.txt, in the Status  tab of the Output window.

The format of the test points report is described below. For more information, refer to “Creating a Test 
Points Report.”
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Test Points Report Format
The Test Points Report provides information describing the number and locations of test points in your 
design.

HEADER
Product     (SailWind Router)
Report Name     (Test Point List)
Design Name:     Name of the open design
_____________________________________________________________
Test Points:     Total number of test points in the design
_____________________________________________________________
X:     The X location of each test point
Y:     The Y location of each test point
Side:     The side of the PCB to which the test point is assigned
Probe:     The probe nail diameter
Object:     The component pin or via type to which the test point
     is assigned
Net Name:     The netname to which the test point is attached 

Test Points Report Sample

Use the Test Points Report to view and analyze the information describing testpoint quantities and 
locations in your design.

SailWind Router Version v2004 SPac1 Test Point List
Design: \SailWind Projects\Samples\pwrdemoe.pcb
_____________________________________________________________
Test Points: 40
_____________________________________________________________
X           Y         Side       Probe      Object     Net Name
_____________________________________________________________
950        900        BOTTOM     100        R3.8       $$$261
650        1100       BOTTOM     100        U5.32      $$$464
1150       1700       BOTTOM     100        U5.66      $$$1002
1150       1000       BOTTOM     100        U5.59      $$$1019
1050       1300       BOTTOM     100        U5.52      $$$1497
250        1800       BOTTOM     100        U5.9       $$$1562
0          0          BOTTOM     100        U2.1       $$$1879
200        725        BOTTOM     100        U1.12      SIG002
1225       725        BOTTOM     100        U4.10      SIG004
250        1600       BOTTOM     100        U5.7       SIGA
1025       425        BOTTOM     100        U4.3       X
1125       0          BOTTOM     100        U3.4       XX 

Creating a Test Points Report
The Test Points report provides information about all test points in the design, such as the total number 
in the design, their location, probe nail diameter, and the object and net name to which the test point is 
assigned.
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Procedure
Click the File > Reports >Test Points  menu item.

Results
SailWind Router createst the file TestPointReport.txt  in the \SailWind Projects  folder, and a link to the 
report appears in the Status  tab of the Output window. Click the link to view the report.

Related Topics
Reporting Design Information

The Routing Report
The Routing report displays information about the autorouting progress. SailWind Router stores the 
report, RoutingReport.txt, in \SailWind Projects. To view the report, click the link to the report file, 
\SailWind Projects\RoutingReport.txt, in the Status  tab of the Output window.

The format of the routing report follows. For more information, refer to “Creating a Routing Report”  on 
page 380.

Routing Report Format
The Routing Report uses a pre-defined format to organize data related to the routing of your design.

HEADER
SailWind Router Version <version>, Routing Report
Design: D:\design\demob1.pcb
 
SUMMARY
Number of passes:        Number of passes the autorouter performed
Routed:        Number of connections that were completely routed
Vias Total:        Total number of vias in the design, followed by
(added)        the number of vias added (+) or removed (-) in
        parentheses
Trace Length Total:         Total trace Length in the design, followed by
(increased)        the amount increased (+) or decreased (-) in
        parentheses
Test Points Total     :   Total number of test points, followed by how
(added)        many were added in parentheses
Total Time:        Amount of time the router spent routing
 
PASS DETAILS
Pass:        Pass number followed by the name of the pass,
        in parentheses, as it appears on the Strategy
        tab
Pins Processed:        For the fanout pass only. The number of pins
        the program attempted to fan out in the pass.
        The number includes successful and failed
        fanouts.
Fanouts Created:        The number of fanouts created in the pass.
Links Selected:        Number of unroutes to route in the pass. The
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        number is determined by the routing order or
        by the selection.
Links Processed:        Number of unroutes the program tried to route
        in the pass. Includes complete and incomplete
        routes.
        More unroutes are processed than selected
        because pins not connected by an unroute are
        considered when routing. For example, a net
        consists of three pins (A,B, and C) and two
        unroutes (A to B and A to C). The router
        considers an unroute between B and C. Therefore,
        the routing report lists two unroutes selected
        and three unroutes processed.
Routed:        Number of unroutes routed in the pass.
Vias:        Number of vias in the design, followed by the
        number of vias added (+) or subtracted (-)
        in the pass in parenthses
Trace Length:        Total trace length, in mils. in the design,
        followed by the total length added (+) or
        subtracted (-) in the pass in parentheses
Test Points:        Total number of test points in the design,
        followed by, in parentheses, by the number of
        test points added (+) or subtracted (-) in the
        pass
Accessible Nets:        Total number of accessible nets in the design,
        followed, in parentheses, by the number of nets
        made accessible (+) or made inaccessible (-) in
        the pass
Time:        Amount of time the router spent on this pass,
        followed by the total time spent routing in
        parentheses
 

Tip
All items do not appear for every pass.

Sample Routing Report

Use the information in the Routing Report to analyze and assess the routability of your design.

SailWind Router Version v2004 SPac1, Routing report
Design: \SailWind Projects\Samples\pwrdemoe.pcb
=============================================================
Tue Nov 09 12:22:19 2002
 
Autorouting \SailWind Projects\Samples\pwrdemoe.pcb
=============================================================
Number of Passes:          0 of 2
Routed:                    102
Vias:                      29(+29)
Trace Length:              49599(+49599) Mils
Test Points:               40(+0)
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Accessible Nets:           40(+0)
Time                       00:00:18
=============================================================
Pass:                      4 (Route)
Links Selected:            119
      Processed:           130
Routed:                    102
Vias:                      29(+29)
Trace Length:              49599(+49599) Mils
Time                       00:00:18(+00:00:18)
=============================================================
Tue Nov 09 12:27:32 2002
 
Autorouting \SailWind Projects\Samples\pwrdemoe.pcb
=============================================================
Number of Passes:          2 of 2
Routed:                    11
Vias:                      55(+26)
Trace Length:              78524(+28925) Mils
Test Points:               40(+0)
Accessible Nets:           40(+0)
Time                       00:00:19
=============================================================
Pass:                      4 (Route)
Links Selected:            17
      Processed:           27
Routed:                    11
Vias:                      55(+26)
Trace length:              78525(+28926) Mils
Time                       00:00:15(+00:00:15)
=============================================================
Pass:                      5 (Optimize)
Vias:                      55(+0)
Trace Length:              78524(-0) Mils
Rerouted:                  0
Time                       00:00:04(+00:00:04)
============================================================= 

Creating a Routing Report
This report provides information about the autorouter progress during autorouting, such as the number of 
passes, connections completely routed, vias, and test points in the design.

Running the report creates the file RoutingReport.txt  in the \SailWind projects  folder. A link to the report 
appears in the Status  tab of the Output window.

Procedure
Click the Routing toolbar  button, then click the Start Autorouting  button.
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Results
SailWind Router creates the RoutingReport.txt  file in the \SailWind Projects  folder, and a link to the report 
appears in the Status  tab of the Output window. Click the link to view the report.

Related Topics
Reporting Design Information

Testing Database Integrity
When a file loads, SailWind Router performs an integrity test on the database. SailWind Router bases its 
integrity test on the integrity test performed in SailWind Layout. Any integrity test error messages appear 
in the Status  tab of the Output window. Each error links directly to the location of the error in the design. 
Click on the error link to zoom in on the error in the design. The Status  tab displays up to 20 errors. All 
errors save to a report named TestIntegrity.txt  located in \SailWind Projects. To view the report, click the 
link to the report file in the Status  tab of the Output window.

Checking Database Integrity
You can run the same database integrity check at any time. The integrity check verifies the values within 
the database to be within an acceptable range. If the integrity check encounters any problems, the Status 
tab of the Output window displays the errors.

For more information, refer to “Creating an Integrity Test Report.”

Integrity Test Report Format

The Integrity Test Report uses a pre-defined format to organize the information related to the database 
integrity of your design.

HEADING
Product     (SailWind Router)
Report Name     (Database Integrity Test Results)
Design Name:     Name of the open design
Errors:     Description of errors 

Integrity Test Report Sample

Use the information in the Integrity Test Report to analyze and assess the database integrity of your 
design.

SailWind Router. Database Integrity Test Results for <\SailWind 
 Projects\Samples\bench98ulrouted.pcb>
 
Trace of net AVDD placed on non routable layer
Trace of net AVDD placed on non routable layer
Trace of net AVDD placed on non routable layer
Trace of net AVDD placed on non routable layer
Trace of net AVDD placed on non routable layer
Trace of net AVDD placed on non routable layer
Trace of net AVDD placed on non routable layer
Trace of net AVDD placed on non routable layer
Trace of net AVDD placed on non routable layer
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Trace of net AVDD placed on non routable layer
Trace of net AVDD placed on non routable layer
Trace of net TLCLK placed on non routable layer
Trace of net TSPCLK placed on non routable layer
Total problems found: 13 

Creating an Integrity Test Report
The Integrity Test report verifies that the values within the design database are within an acceptable 
range.

Procedure
Click the Tools > Integrity Test  menu item.

Results
SailWind Router creates the TestIntegrity.txt  file in the \SailWind Projects  folder, and a link to the report 
appears in the Status  tab of the Output window. Click the link to view the report.
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Licensing

Your license for the software may be limited and may not enable all software features. Read the sections 
that follow to learn more about SailWind Router licensing and associated features.

You may work in a multi-user setting where multiple licenses are available of which some enable general 
features and other licenses enable advanced features. You can use the Installed Options dialog box 
on page   to check which software features you are licensed to use, or to control which license or 
licenses you consume of the many licenses that are available when using the software. For example, if 
you have many suite licenses but limited atomic licenses of an advanced feature-set of the software, and 
you are not using those features, you can free up that license and allow it to be consumed by someone 
else who requires those software features.

Viewing a Node Locked License File
Viewing the Floating License Status
Checking Out Suite Licenses

Viewing a Node Locked License File
If you are using node-locked licensing, you can view the contents of a license file.

Procedure
1. Choose the Help > Installed Options  menu item; then, in the Installed Options dialog box, click 

the License File tab.

2. On theLicense File tab  on page 418, select the license file that you want to view from your list of 
license files.

3. Click View  to display the contents of the selected file in the bottom portion of the screen.

Viewing the Floating License Status
If you use a floating license, you cannot view the license file that is in use, but you can view the status of 
the features associated with the server license.

Procedure
1. Choose the Help > Installed Options  menu item; then, in the Installed Options dialog box, click 

the License File  tab.

2. On the License File tab  on page 418, select the server license file for which you want to display 
feature status.

3. Click Status. The feature usage information appears in the bottom portion of the screen.

SailWind Router Guide 383



Licensing
Checking Out Suite Licenses  

Checking Out Suite Licenses
Use the PADS Suite Configuration dialog box to manage which suite licenses you consume.

Restrictions and Limitations
To use this functionality, it is imperative that you remove any FlexNet Options files and/or batch script 
customization.

Prerequisites
This functionality is applicable only if you have floating licenses, and on your license server you have one 
of the following:

• A mix of different PADS Suite licenses. For example, PADS LS/padsls_c and PADS 
ES/padses_c.

• One or more PADS Suite licenses and one or more PADS Kit licenses. For example, PADS 
ES/padses_c and pwrshell and other similar features, as part of SailWind Layout 065 Kit.

Procedure
1. Choose the Help > Installed Options  menu item; then, in the Installed Options dialog box, click 

Suite Configuration.

2. The check the status of all listed licenses, click Check status.

3. Select the license file to use from the list.

4. To determine which Suite licenses are being used each time you start SailWind Router, select the 
“Show this dialog box on program startup” and “Automatically check license status on dialog box 
startup” check boxes.

5. Click OK.
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SailWind Router GUI Reference

The various dialog boxes throughout SailWind Router provide access to tools and settings. Each dialog 
box provides a Help icon for accessing additional information.

Add/Edit Command Dialog Box
Archiver Dialog Box
Archiver Additional Files Dialog Box
Archiver Libraries Dialog Box
Assign Shortcut Dialog Box
Check for Updates Dialog Box
Component Properties Dialog Box, Electrical Nets Tab
Customize Dialog Box, Commands Tab
Customize Dialog Box, Keyboard and Mouse Tab
Customize Dialog Box, Macro Files Tab
Customize Dialog Box, Options Tab
Customize Dialog Box, Toolbars and Menus Tab
Design Rule Checking Dialog Box
Edit Button Image Dialog Box
Edit Filter Dialog Box
Electrical Nets Dialog Box
Electrical Net Properties Dialog Box, Electrical Net Tab
Electrical Net Properties Dialog Box, Length Tab
Error Detected Dialog Box
Find Dialog Box
Find Dialog Box, Spreadsheet Window
Installed Options Dialog Box, License File Tab
Net Properties Dialog Box, Electrical Net Tab
Options Dialog Box, Colors Category
Options Dialog Box, Design Verification Category
Options Dialog Box, Display Category
Options Dialog Box, Fabrication Category
Options Dialog Box, Global Category, Backups Subcategory
Options Dialog Box, Global Category, File Locations Subcategory
Options Dialog Box, Global Category, General Subcategory
Options Dialog Box, Placement Category
Options Dialog Box, Flooding Category
Options Dialog Box, Routing Category, General Subcategory
Options Dialog Box, Routing Category, Strategy Subcategory
Options Dialog Box, Test Points Category
Options Dialog Box, Text and Lines Category
Options Dialog Box, Routing Category, Tune Subcategory
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SailWind Suite Configuration Dialog Box
Properties Dialog Box, Clearance Tab
Properties Dialog Box, Component Tab
Properties Dialog Box, Copper
Properties Dialog Box, Copper Cut Out Tab
Properties Dialog Box, Copper Cut Out Corner
Properties Dialog Box, Copper Cut Out Segment
Properties Dialog Box, Copper Plane Tab
Properties Dialog Box, Copper/Copper Plane Corner
Properties Dialog Box, Copper/Copper Plane Segment
Properties Dialog Box, Corner Tab
Properties Dialog Box, Drill Tab (Pin)
Properties Dialog Box, Drill Tab (Via)
Properties Dialog Box, Drill Tab (Virtual Pin)
Properties Dialog Box, Fanout Tab
Properties Dialog Box, Flooding tab
Properties Dialog Box, Grid Tab
Properties Dialog Box, Group Tab
Properties Dialog Box, Keepout Tab
Properties Dialog Box, Keepout Segment
Properties Dialog Box, Layer Biasing Tab
Properties Dialog Box, Layers Tab
Properties Dialog Box, Length Tab
Properties Dialog Box, Net Tab
Properties Dialog Box, No Properties Tab
Properties Dialog Box, Pad Entry Tab
Properties Dialog Box, Pad Stack Tab (Pins)
Properties Dialog Box, Pad Stack Tab (Vias)
Properties Dialog Box, Pad Stack Tab (Virtual Pins)
Differential Pair Properties Dialog Box, Pair Tab
Properties Dialog Box, Pin Tab
Properties Dialog Box, Pin Pair Tab
Properties Dialog Box, Routing Tab
Properties Dialog Box, Same Net Tab
Properties Dialog Box, Test Points Tab
Properties Dialog Box, Test Points Tab (Nets)
Properties Dialog Box, Test Points Tab (Component or Via Type)
Properties Dialog Box, Topology Tab
Properties Dialog Box, Trace Tab
Properties Dialog Box, Trace Segment Tab
Properties Dialog Box, Via Tab
Properties Dialog Box, Via Biasing Tab
Properties Dialog Box, Virtual Pin Tab
Selection Layers Dialog Box
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Shortcut Dialog Box
View Nets Dialog Box
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Add/Edit Command Dialog Box
To access: Click Tools > Customize  (menu item) > Commands  tab > New  or Edit  button

Create commands that you can use as selections on menus or as buttons on toolbars.

Objects

Field Description

Command name The name of the new command.

 Tip
Type an ampersand before the letter you want to use as the Alt 
keyboard shortcut.

Based on The command on which you want to base the new command.

Arguments Any arguments for the new command.
Tip: Use a space to separate arguments. If an argument contains 
a space, enclose the argument in quotation marks (““).

 Restriction:
SailWind Router only.

Description Lists what the new command does.

Use Default Image Use the recommended image.

Select User-defined Image Select or create your own image to associate with the new 
command.

New Open the Edit Button Image Dialog Box.

Edit Open  button in the Edit Button Image Dialog Box.
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Archiver Dialog Box

Archiver Dialog Box
To access:

• Click the File > Archive  menu item

Create archives of your schematics, designs, files and folders, and libraries.

Objects

Field Description

PCB Design Specifies the location and name of the PCB design you want to 
archive. SailWind Router automatically populates this box with the 
information from the current design. To change the design, or if no 
design is open, type the location or click the browse button next to the 
box.
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Field Description

 Note:
The Create PDF check box is unavailable in SailWind Router.

Schematic Specifies the location and name of the schematic file you want to 
archive. To choose the file you want, type the location or click the 
browse button next to the box.

Add libraries Specifies that you want to include libraries in the archive.
• All— Add all of your libraries to the archive.

• Select— Add only the libraries you specify.

Click the browse button next to the box to open the Archiver 
Libraries Dialog Box.

Additional files Specifies that you want to include other files and folders in your 
archive. Click the browse button to open the Archiver Additional Files 
Dialog Box.

Target folder Specifies where you want the archive to be located. Type the path or 
click the browse button next to the box.

 Restriction:
If you clear the “Compress using zip format” check box, the target 
folder must be empty.

Compress using zip format Creates a zip file when you select this check box. The resulting 
filename conforms to the following format:

<project_name>YYYYMMDDHHMMSS.zip
 

Where YYYY is the year, MM is the month, DD is the day, HH is the 
hour - in military time, MM is the minute, and SS is the second of the 
exact time you created the file.
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Archiver Additional Files Dialog Box

Archiver Additional Files Dialog Box
To access: Click the File > Archive  menu item > select the Additional Files check box > click the 
corresponding browse button

Add files and folders to the design you want to archive.

Objects

Field Description

Additional files list Lists the files and folders you want to include in your archive.

Add File  button Opens the Additional File dialog box where you can select individual 
files you want to add to the Additional files list.

Add folder  button Opens the Browse for Folder dialog box where you can select an entire 
folder to add to the Additional files list.

Remove  button Removes the selected file or folder from the Additional files list.

Remove All  button Removes all of the files and folders from the Additional files list.
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Archiver Libraries Dialog Box
To access: Click the File > Archive  menu item > select the Add libraries check box > choose the Select 
option > click the corresponding browse button

Add libraries to the design you want to archive.

Objects

Field Description

Available libraries Lists all of the libraries available for you to add to the archive.

 Restriction:
If your library is not listed in the Library Manager, it will not appear 
in this list.

Add  button Moves the selected library from the Available libraries list to the 
Selected libraries list.

Remove  button Moves the selected library from the Selected libraries list to the 
Available libraries list.

Add All  button Moves all of the libraries from the Available libraries list to the Selected 
libraries list.

Remove All  button Moves all of the libraries from the Selected libraries list to the Available 
libraries list.
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Assign Shortcut Dialog Box

Assign Shortcut Dialog Box
To access: Click the Tools > Customize  menu item > Keyboard and Mouse  tab > New button (in the 
Current Shortcuts area)

Create a new shortcut key.

Objects

Field Description

Press new shortcut key Type the shortcut keys and the combination you want to use. For 
example, if you want to run a macro by pressing the Shift key and 
F9 key simultaneously, type “Shift+F9” in the box.

Select a pointer event If you want to use a combination of mouse movements/button 
clicks instead of shortcut keys to initiate a command, specify the 
pointer/mouse combination here.

Similar shortcuts list Lists the shortcut keys already assigned to other commands.
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Check for Updates Dialog Box
To access: Click the Help > Check for Updates  menu item

Manually check for a new version of SailWind, and disable or enable automatic checks.

Objects

Field Description

Check for Updates  button Manually checks for a new version of the SailWind software.

Disable “Check for Updates” 
functionality

Determines if SailWind automatically checks for a new version of the 
software.
Select the check box to stop SailWind Router from automatically 
checking for a new version of the SailWind products; clear the check 
box if you want SailWind Router to automatically check for a new 
version.
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Component Properties Dialog Box, Electrical Nets Tab

Component Properties Dialog Box, Electrical 
Nets Tab
To access: Select a component > Right-click > Properties  popup menu item > Electrical Nets  tab

View and control the electrical net status of components.

Objects

Field Description

List box Name(s) of the electrical nets attached to or going through the 
component.
An electrical net name has a suffix of 3 caret symbols (^^^).

Create electrical net Select the check box to create an electrical net of the component’s 
nets.

 Tip
You can also affect this check box by the Create Electrical Net 
popup command for selected components.

Restrictions:
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Field Description

• If a net of a selected component is excluded from electrical net 
creation, you cannot include it in an electrical net.

(A component or net is excluded from electrical net creation if its 
“Create electrical net” and “Allow electrical net creation...” check 
boxes are both cleared.)

• If a selected component has more than two pins, the following 
conditions must apply, or the component cannot create an electrical 
net, that is, the electrical net cannot go through the component:

• All pins must connect to a gate.

• Each gate must have exactly two pins.

• If you select the “Create electrical net” check box in the Net 
Properties dialog box for the component’s nets, you must also clear 
the “Allow electrical net creation by refdes prefix and nets” check 
box.

Clear the check box to remove the component from electrical net 
creation, that is, to prevent an electrical net from going through it.

 Tip
You can also clear this check box by the Disable Electrical Net 
Creation  popup menu item for selected components.

Clear both this check box and the “Allow electrical net creation by 
refdes prefix and nets” check box to prevent the selected components 
from creating electrical nets (that is, to prevent any electrical net from 
going through them).

Allow electrical net creation 
by refdes prefix and nets

Select the check box to allow the component’s nets to be included 
in electrical nets automatically by specifying the component’s refdes 
prefix in the Electrical Nets dialog box, or by setting the “Create 
electrical net” check box in the Net Properties dialog box.
Clear the check box to prevent electrical net creation of the selected 
components’ nets through those components by nets or by refdes 
prefix. The nets can still be made into electrical nets by the other 
components attached to them.

 Tip
This check box is also cleared by the Disable Electrical Net 
Creation popup command for selected components.
 Restriction:
If you clear this check box, you must also clear the “Create 
electrical net” check box to prevent the selected components from 
creating electrical nets (that is, to prevent any electrical net from 
going through them).

Discrete length Enter the length to be used for this component when calculating net 
length.
Half the Discrete length value is added to each connected pin pair 
and net length measurement. You can add a value to represent the 
length of the component pin that will solder to the pad. For electrical 
nets, this value gives a more accurate total length measurement where 
physical nets are chained together through discrete components. 
Without a Discrete length value, lengths of connected pin pairs and 
nets are measured only up to the origin of the pad. This may not be the 
geometric center of the pad in offset pads.

396 SailWind Router Guide



 
SailWind Router GUI Reference

Customize Dialog Box, Commands Tab

Customize Dialog Box, Commands Tab
To access: Choose the Tools > Customize  menu item > Commands  tab

Add commands to menus or toolbars, or create custom menus.

Objects

Field Description

Categories list Limits the display of available commands in the Commands list, 
according to category. For example, clicking the “Routing Toolbar” 
category displays only those commands found in the Routing 
toolbar (such as Start Autorouting, Stop Autorouting, and so on).

Commands list Select from a list of commands available to add to a menu or 
toolbar.

Command toolbar Add a new command, delete a command you have added, or 
rename a command.
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Customize Dialog Box, Keyboard and Mouse 
Tab
To access: Choose the Tools > Customize  menu item > Keyboard and Mouse  tab

Create and customize shortcut keys.

Objects

Field Description

Mode list Restricts the displayed list of commands.

Commands list The list of commands available for which to assign a shortcut.

Command toolbar Add a new command (opens the Add Command Dialog Box  on 
page 388), delete a command you have added, or rename a 
command (opens the Edit Command dialog box  on page 388).

Current shortcuts list The list of shortcuts assigned to the selected command.

Current shortcuts toolbar Add a new shortcut (open the Assign Shortcut Dialog Box), or 
delete a shortcut you have added.

Description Lists what the selected command does.

Reset Sets the selected toolbar or shortcut menu to the default settings.
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Field Description

Report Saves a report of all current shortcut commands.
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Customize Dialog Box, Macro Files Tab
To access: Choose the Tools > Customize  menu item > Macro Files  tab

Create commands from macro files and add them to toolbars and menus.

Tip
To create a command from a macro command file, the macro command file (.mcr) must already 
exist. You can create a macro by recording it in a SailWind tool or scripting it in Macro language. 
For more information, see Creating Macros.

Objects

Field Description

Macro Command Files list Displays a list of macro files you have opened.

Add a macro to the list (opens the Open Macro dialog box), delete 
a macro from the list, or edit the location of a macro you have 
added.

Description Lists what the selected macro does.
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Customize Dialog Box, Options Tab
To access: Choose the Tools > Customize  menu item > Options  tab

Customize the SailWind interface by changing the appearance of menus and toolbars.

Objects

Field Description

Show ToolTips on toolbars Displays the button name over the toolbar button when you hover 
over it with your pointer.

Show shortcuts in ToolTips In addition to the name in the ToolTip, displays the shortcut for the 
button.

Large Icons Displays icons on the toolbar larger than the default size.

Menu animations list The type of animation for your menus: None, Unfold, Slide, or 
Fade.

Menu shadows Displays a shadow behind the menu.

Wait until <Enter> before 
executing long shortcuts

Delays the execution of shortcut keys until you press Enter.

Show recent commands first Displays your recent menu command selections at the top of the 
list.
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Field Description

Show full menus after delay Displays the full menu after a slight pause.

Reset my usage data Restores the default set of commands to the menus and toolbars.

 Tip
This option does not undo any explicit customizations you 
made.

Visual Style Sets the look and feel of your toolbars and title bars.

Interface Language Specifies the language for all dialog boxes and messages 
displayed: English, Japanese, Brazilian Portuguese, or Chinese 
Simplified.
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Customize Dialog Box, Toolbars and Menus 
Tab
To access: Choose the Tool > Customize  menu item > Toolbars and Menus  tab

Create custom toolbars and shortcut menus.

Tip
To create a custom main menu, use the Commands  tab on the Customize dialog box. See 
Creating a Custom Menu.

Objects

Field Description

Toolbars list Specify which toolbars to display in the main window.

Add a new toolbar, delete a toolbar you have added, or rename a 
toolbar you have added.

Show text labels Shows the text label on the button in addition to the icon.

Select shortcut menus Specifies the shortcut menu you want to customize.
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Field Description

 Restriction:
This option applies to SailWind Router only.

Reset Sets the selected toolbar or shortcut menu to the default settings.

Reset All Sets all toolbars or shortcut menus back to their default settings.
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Design Rule Checking Dialog Box
To access:

• Choose the Tools  > DRC Settings  menu item

• DRC Filter Toolbar  > DRC Settings  button

Select which design rules to enable during DRC checking and choose the desired error response for each 
rule category.

Objects

Column Description

Design Rules Shows the design rule categories available for design rule 
checking:

• Clearance  — Checks against all rules set on the “Properties 
Dialog Box, Clearance Tab”  on page 468

• Trace width  — Checks against Trace width rules set on the 
“Properties Dialog Box, Routing Tab”  on page 517

• Same net  — Checks against all rules set on the “Properties 
Dialog Box, Same Net Tab”  on page 519

• Placement  — Checks against the “Minimum spacing between 
components” rule set in the Component assembly area on the 
“Options Dialog Box, Fabrication Category”  on page 433

• Length  — Checks against any rules defined on the “Properties 
Dialog Box, Length Tab”  on page 501 for all net objects in the 
design

Enable When you enable DRC for a design rule, SailWind Router checks 
for design rule violations only for that design rule. When you clear 
the Enable check box for a specified design rule, the software 
ignores all the violations that occur for that design rule during 
interactive routing and route editing.
To enable DRC for all the design rules, click the Enable title to 
select the entire column, and then select one of the check boxes in 
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Column Description
this column. If you need to disable the column selection, click a cell 
in another column.
You can also select design rules on the DRC Filter toolbar. Click the 
button for each design rule you want to check.

Error Response In the Error Response column, click the cell of the design rule for 
which you want to set an error response. Select the appropriate 
response for how you want SailWind Router to handle design rule 
violations when it encounters them during interactive routing, trace 
editing, and placement editing operations.
Available error responses are as follows:

• Prevent— Prevents design rule violations. If errors are 
encountered during routing and placement editing operations, 
the program returns to the state that existed before encountering 
the error and displays a brief message in the Status  tab of the 
Output window and in the workspace near the pointer location. 
You can then manually initiate the Explain command to view the 
error details.

• Explain— Allows the temporary creation of a violation. When 
an error is detected, the operation is suspended, error markers 
are created, and the errors are automatically explained in 
the Spreadsheet window. The system may let you accept the 
violation and continue the operation with errors or reject the 
violation and return to the state that existed before the creation 
of the error.

• Warn— Creates error markers, warns, and continues with the 
next operation. The error is created in the database and marked 
with an error marker.

Error Response (Continued) Note that you can set the error response for adjacent rules, 
non-adjacent rules, or the entire design rule set:

• To set the same error response for multiple adjacent design 
rules, click the first design rule, press Shift, click the last design 
rule in the range, and select the error response you want from 
the list.

• To set the same error response for multiple nonadjacent 
design rules, click any design rule, press Ctrl while you click 
other design rules that you want to select, and select the error 
response you want from the list.

• To set the same error response for the entire design rule set, 
click the Error Response title to select the entire column, and 
then select the error response you want from the list.
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Edit Button Image Dialog Box
To access: Choose the Tools > Customize  menu item > Commands  tab > New  button > Select User-
Defined Image  option > New  or Edit  button

Create or edit button icons.

Objects

Field Description

Colors area Select a color to use with the tools

Tools area Select a tool to draw/edit the picture or icon of the button
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Edit Filter Dialog Box
To access: In the Spreadsheet window, click the Define Filter Settings  button. 

Use this dialog box to find objects in the currently selected tab of the Spreadsheet window.

Objects

Field Description

Show objects where: Displays the current list of conditions that compose the search 
expression.

New  button Click to add a condition to the search expression

More  button Click to expand the dialog box to create a multiple-condition search.

Less  button Click to contract the dialog box to create a simple single-condition 
search.

Boolean Selectors Set these appropriately to describe the boolean structure as you add 
additional conditions for multiple-condition searches.

Property List Select the object property you wish to test against the condition.

Condition List
Value Edit Box

Specify the condition and value to test the property against.
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Electrical Nets Dialog Box
To access: Choose the Setup > Electrical Nets  menu item.

Create and delete electrical nets by adding or removing the refdes prefixes of the associating 
components, that is, the components through which the electrical nets now pass (when you are deleting) 
or will pass (when you are creating).

Note:
Electrical nets are not available in engineering change order (ECO) operations.

Objects

Field Description

Maximum net count per electrical 
net

When creating electrical nets, it is possible that you may create 
electrical nets containing an unreasonable number of nets.
To prevent this, specify the maximum number of nets allowed in 
an electrical net. Electrical nets having more than this limit are not 
created.

 Tip
This limit also applies to the creation of electrical nets manually 
by component and by net.
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Field Description

Maximum non-plane-net pin count When creating electrical nets, it is possible that you may include 
nets that are potential plane nets. (Plane nets are not allowed in 
electrical nets.)
To prevent this, specify the maximum pin count for nets included in 
electrical nets.
Tips:

• This limit also applies to the creation of electrical nets manually 
by component and by net.

• Virtual pins are not included in a net’s pin count.

Discrete component prefixes Specify the refdes prefixes of the associating components to 
create new electrical nets. Examples:
R  specifies all R<num> components, where <num>  is a non-empty 
number.
#R  specifies all <num1>R<num2> components;
<num1>  can be empty.
#_R  specifies all <num1>_R<num2> components,
where <num1>and <num2>  are non-empty numbers.
Tips:

• The discrete type categories are only for convenience; prefixes 
for any type of component can be entered in any field.

• If a selected component has more than two pins, the following 
conditions must apply, or the component cannot create an 
electrical net, that is, the electrical net cannot go through the 
component:

• All pins must connect to a gate.

• Each gate must have exactly two pins.

Delete refdes prefixes of existing associating components to 
remove them from electrical nets.
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Electrical Net Properties Dialog Box, Electrical 
Net Tab
To access: Select an electrical net > right-click > choose the Properties  popup menu item > Electrical 
Net  tab

View and manage electrical net status.

Objects

Field Description

Unrouted length The length of the unrouted part of the electrical net.

Routed length The length of the routed part of the electrical net.

Total vias The number of vias on this electrical net.

Protect traces and vias; disallow 
editing

Specifies to prohibit unrouting or moving a routed trace.

 Tip
You can make protected traces visually distinguishable from 
unprotected traces. In the Options dialog box, in the Global 
category > General subcategory, select the “Distinguish 
protected traces and vias” check box. Protected traces will be 
displayed as outlines.

Trace width Specifies the width of all traces on an electrical net.
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Field Description

 Restriction:
If the electrical net has protected traces, these trace width 
properties cannot be modified.
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Electrical Net Properties Dialog Box, Length 
Tab
To access: Select an electrical net > right-click > choose the Properties  popup menu item > Length  tab

Restrict electrical net length.

Objects

Field Description

Restrict length Specifies that you want to set the minimum and/or maximum 
length values.

Minimum length Specifies the minimum value for the electrical net length.

 Restriction:
Available only when Restrict length is selected.

Maximum length Specifies the maximum value for the electrical net length.

 Restriction:
Available only when Restrict length is selected.
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Error Detected Dialog Box
To access: This dialog box is inaccessible unless the software crashes and crash detection is enabled in 
the software .ini  file.

The Error Detected dialog box opens at a crash and allows you to save a report of the SailWind 
environment as well as pertinent files into a compressed Dump File. You can then submit this file to 
Customer Support for troubleshooting.

Objects

Name Description

Comments box You can describe what you were doing when the error occurred 
or add additional information that might help when investigating 
the crash.

Attach BMW data check box You can include BMW data and your project files. This enables 
customer support to play back what you were doing in your 
design leading up to the crash. This check box is unavailable if 
the BMW feature is not enabled.
See alsoCrash Detection

Save  button You must click the Save  button if you want to create a report file. 
When you click the Save  button, you are prompted with a Save 
As dialog box. The file that is created is called a Dump File and is 
compressed in the .zip format. This is the file that you must send 
to customer support. It will include the report, the BMW data, and 
the project files.
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Find Dialog Box
To access: Choose the Edit > Find  menu item.

Find and select single or multiple objects by reference designator, part type, matched length pin pair 
group, or other attributes.

Note:
Find ignores the Selection Filter  on page 137 settings and selects whatever you ask it to.

Objects

Field Description

Object Type list Specifies how you want to search. You can find by any of the 
following:

• Reference Designators

• Part types

• Decals

• Net classes

• ML Net groups

• Electrical Net

• Nets

• ML Pin Pair groups
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Field Description

• Differential pairs

• Via types

• Jumper vias

• Keepouts

• Test Point types

Action Specifies the action to perform on items you find.
• Select

• Highlight

• Unhighlight

• Rotate 90

• Flip Side

• Move Sequential

Exception:  You cannot use Rotate 90, Flip Side, or Move 
Sequential on test points.

 Tip
When you select objects with the Find dialog box, the shortcut 
menus change to the relevant commands for modifying the 
items.

Value Narrows the search by the value you type. You can use wildcards 
or expressions.

Add to Selection Selects the items that you find. Each selected item appears in the 
Selected Items preview area.

 Tip
When you select objects with the Find dialog box, the shortcut 
menus change to the commands relevant for modifying the 
items.

Selected Items Preview area Displays the selected items.

Find lists The content and title of these lists change depending on what 
you select from the Find By list. For example, if you are finding by 
reference designator, the first list displays reference designator 
prefixes. When you select a reference designator prefix to 
search by, for example D, the second list displays all reference 
designators with the D prefix. You can further limit the search by 
choosing a specific D reference designator prefix to search by, 
such as D2.
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Find Dialog Box, Spreadsheet Window
To access: In the Spreadsheet window, click the Findbutton.

Use this dialog box to find objects in the currently selected tab of the Spreadsheet window.

Objects

Field Description

Show objects where: Displays the current list of conditions that compose the search 
expression.

New  button Click to add a condition to the search expression

More  button Click to expand the dialog box to create a multiple-condition search.

Less  button Click to contract the dialog box to create a simple single-condition 
search.

Boolean Selectors Set these appropriately to describe the boolean structure as you add 
additional conditions for multiple-condition searches.

Property List Select the object property you wish to test against the condition.

Condition List
Value Edit Box

Specify the condition and value to test the property against.

Backward Search Select this check box to search backward from the bottom of the list.
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Installed Options Dialog Box, License File Tab
To access: Choose the Help > Installed Options  menu item > License File  tab

If you are using node-locked licensing, you can view the contents of a license file. If you are using floating 
licenses, you cannot view the actual license file, but you can view the status of the features associated 
with a server license.

Objects

Field Description

License File column Displays the location of the license file(s) found on your computer.

Source column Displays the source of the license.

View  button Click to display the contents of the license file in the License 
Information box.

 Restriction:
Node-locked only.

Status  button Click to display the status of this license in the License Information box.

 Restriction:
Floating License only.

License Information box Displays the contents (Node-locked) or the status (Floating) of the 
selected license.

Suite Configuration button Opens the SailWind Suite Configuration Dialog Box.
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Field Description

 Restriction:
Available only with floating/server-based licenses, a mix of different 
SailWind Suites, or a mix of unbundled licenses and suites.
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Net Properties Dialog Box, Electrical Net Tab
To access: Select a net > Right-click > choose the Properties  popup menu item > Electrical Net  tab

View and control the electrical net status of nets.

Objects

Field Description

Name: Name of the electrical net of which the net is a part.
An electrical net name has a suffix of three caret symbols (^^^).

Create electrical net Select the check box to create electrical nets of the selected nets.

 Tip
You can also set this check box (and create electrical nets) using 
the Create Electrical Net popup command for selected nets.

Clear the check box to remove any selected net that is a part of an 
electrical net.
Clear both check boxes to exclude the selected nets from inclusion in 
any electrical net.

Allow electrical net creation 
by component

Select the check box to allow the selected nets to be included in 
electrical nets by the following:
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Field Description

• Specifying, in the Electrical Nets dialog box, the refdes prefix of the 
nets’ associating components, or

• Selecting the Create electrical net check box in the Component 
Properties dialog box.

Clear the check box to disable electrical net creation by component 
(including by refdes prefix).

 Tip
This check box is also cleared by the Disable Electrical Net 
Creation popup command for selected nets.
 Restriction:
Nets that have the Create electrical net check box selected are not 
disabled from electrical net creation by clearing this check box.

Clear both check boxes to exclude the selected nets from inclusion in 
any electrical net.
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Options Dialog Box, Colors Category
To access:

• Choose the Tools > Options  menu item > Colors category

• Click the Options  button > Colors category

• Press the Ctrl + Enter keys > Colors category

Control the visibility and display colors of design layers and objects. Save color schemes for reuse.

Objects

Field Description

Display scheme area

Color scheme name Select a previously saved color scheme.

Save As Click to type a name for the new color scheme created from your 
current settings. The new name appears in the Color scheme 
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Field Description
name list. The color scheme is saved in the .dsf file and is made 
active. For the location of the .dsf file and how to change the 
location, see File Locations Options  on page 439.

Color selection area

color palette Click a color tile. Then in the Layers\Object Types table, click the 
tile for the object type in a layer.

Custom Click to change the palette of colors from which you can select.

Default Click to return the palette of colors from a customized palette to 
the default color palette.

global object tiles area Background  — Specifies the color of the design space 
background. Setting other objects to this color makes those 
objects invisible.
Selections  — Specifies the color of selected objects.
Connection  — Specifies the color of unrouted pin pair 
connections otherwise known as the ratsnest.
Board outline  — Specifies the color of the board outline and 
board cut outs.
Test point  — Specifies the color of test point symbols that overlay 
test points. These symbols are only visible on the layer of the 
board set for probing.
Thermals  — Specifies the color of thermal symbols on pads 
and vias that have a thermal connection. You can enable and 
disable the thermal connection in pad and via properties using the 
“Connect to plane with thermal” check box.
Guard bands  — Specifies the color of the shaded areas around 
objects that appears while interactively routing traces. The guard 
band displays the clearance you must keep from those objects. 
The width of the guard band is the clearance required between the 
object and trace being routed. The display of these guard bands 
can be turned on/off in the Options dialog box > Global  category > 
General subcategory  on page 441 with the “Show guard bands 
on object” check box.

Layers \ Object Types matrix

Visible only Select the check box to list only visible layers. A layer is visible if at 
least one tile is assigned a non-background color. You can use this 
setting to shorten the layers list to only those layers with which you 
are working.

Layers (rows) The rows of layers lists the layers as you’ve named them in the 
Layers Setup dialog box in SailWind Layout.
Tips:
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Field Description

• You can clear the check box of a row to make the layer 
invisible.

• To make all items on a layer one color, click the number of the 
row to select all row objects and then click a color tile in the 
Selected Color area. You can also select multiple rows using 
Shift+click for a range or Ctrl+click for multiple selection.

Object Types (columns) The columns list object types in the design.You can clear the 
check box of a column to make the objects invisible on all layers.

• Top/Bottom Outline Objects  — Used to control the visibility 
of component body outlines. Tiles in these columns associated 
with the Top and Bottom Component Side layers (Top Outl./Bot. 
Outl.) or Top/Bottom Silkscreen layers control the visibility of 
the component body outlines.

• Top/Bottom Placement Outline Objects  — Used to control 
the visibility of component placement outlines (derived from 
SailWind Layout Layer 20 outlines or auto-generated). Tiles in 
these columns associated with the Top and Bottom Component 
Side layers (Top Plc./Bot. Plc.) control the visibility of the 
component placement outlines.

• Pin Numbers and Net Names  — Sizing is controlled by the 
settings on the Display Options category  on page 431.

 Restriction:
Even if the Net Nm. column check box is selected and the tiles 
on layers are given a color, the display of net names is still 
restricted by the state of the “Show net names on Traces, Vias, 
Pins” check boxes.

Show net names on Select the check boxes to activate locations where net names 
should be visible.
Requirement:  To display net names on these objects, you must 
also select the check box for the Net Nm. column and give colors 
to color tiles in the column.
Tips:

• You can use the modeless commands NNT, NNV, and NNP to 
toggle these check boxes.

• The sizing and frequency of net name placement is controlled 
by the settings on the Display Options category  on page 431.

Apply immediately SailWind Router applies to the design any color or visibility 
changes at the moment you make them in this dialog box; you do 
not need to click Apply  first.
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Options Dialog Box, Design Verification 
Category
To access:

• Click the Options  button > Design Verification category

• Choose the Tools > Options  menu item > Design Verification category

• Press the Ctrl + Enter keys > Design Verification category

Use the Design Verification category to set up design verification options.

Objects

Name Description

Design verification 
scheme area

Select a scheme name if you want a predefined set of design checks.
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Name Description

 Tip
A scheme is an easy way to save all your current settings on this tab. You 
can quickly switch among the schemes to run other checks without having 
to specify options individually.

Set the individual design checks and properties you want, and then click Save 
As. In the Scheme name box, type the name you want to assign to the new 
design verification scheme, and then click OK.

Conduct checks area On visible objects and layers only  — Select to avoid checking object and 
layers that have the Background color in the Layers/Object Types matrix in the 
Colors category.
In visible workspace only  — Select to avoid checking objects that outside the 
current view of the workspace.

Check design for  area

Object clearance Checks the minimum allowable clearance for each object type, and the 
minimum and maximum trace width.

 Tip
Set clearances on the Clearance  tab of the Properties dialog box. Set trace 
width on the Routing  tab of the Properties dialog box.

Net against all objects  — Checks clearance between each net or hierarchical 
level and any other obstacle type. Also checks clearance for each component 
or decal that has clearance rules set.
Objects against board outline  — Checks clearance between the centerline 
of the board outline and the edge of a board cutout or other object.
Text outside board outline  — Checks for text strings on electrical layers that 
are outside the board outline and flags all instances of off board text as errors.
Keepout restrictions  — Checks for keepout restriction violations. Does 
not check placement and height keepouts that are verified by Fabrication 
checking.
Unused pads on inner split/mixed plane layers  — Checks clearance for 
pads on inner split/mixed plane layers that do not connect to traces.
Same net restrictions  — Checks clearance between objects along the same 
net.
Minimum/maximum trace width  — Checks traces against the designated 
minimum and maximum widths.

Net, pin pair, and 
electrical net length

Checks the minimum and maximum length for nets, pin pairs and electrical 
nets.

 Tip
Set lengths on the “Properties Dialog Box, Length Tab”  on page 501.

Differential pairs Checks against differential pair property settings—the minimum and maximum 
length, the gap, the number and size of obstacles, and also against the 
minimum controlled gap length, and maximum irregular trace length settings 
here.
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Name Description

Figure 96. Differential Pairs Checking

Checks all areas between the gathering point and the split point that are 
not routed at the fixed edge-to-edge route gap value. Does not check areas 
where the number and size of obstacles do not exceed the maximum values 
set. Differential pair traces should be at the gap before they split around an 
obstacle. They should also join back together at the gap.

Figure 97. Differential Pairs - Splitting Around an Obstacle at the Gap

 Tip
The shoulder area may be wider (from the autorouting point of view) than it 
appears to be in reality.

Figure 98. Differential Pairs - Wider Shoulders

Differential pairs 
(continued)

Checks the number of routing obstacles routed around by each differential pair 
and reports if this number is over the specified value. Obstacles in the shoulder 
area are not counted toward the obstacles over the limit.
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Figure 99. Differential Pairs - Obstacle in Shoulder Area

Checks the maximum obstacle size routed around by each differential pair.
Minimum controlled gap length  — Set the percentage of the length of the diff 
pair that should have a controlled gap without obstacles.
Maximum irregular trace length  — Checks for trace segments not routed at 
the route gap and identifies any trace segments longer than the specified value 
that might affect the integrity of the differential pair. Irregular trace segments 
include shoulder traces in the start and end zones as well as trace segments in 
the controlled gap portion of the routing where the gap is wider than the value 
of the route gap. Reported lengths in error descriptions include trace segments 
to the center of pads and vias. In the following example, the shoulder area 
is extensive and bridges two components. The irregular trace length report 
includes the entire length shown with the white arrow.

 Tip
You set the gap between objects, restrict layer changes, minimum and 
maximum length, allow pair to split around obstacles, maximum number 
of obstacles, and maximum size of obstacles on the “Differential Pair 
Properties Dialog Box, Pair Tab”  on page 511.
 Restriction:
Maximum number and size of obstacles are not checked in the zone 
between the connection point and the shoulder of the differential pair.

Automatic testing 
violations

Checks for probe clearances, minimum pad sizes, SMD pin probing, test points 
on component pin on the component side, test point count per net setting, nail 
diameter settings, and test points on grid.

Maximum via count Checks for the maximum number of vias on nets and pin pairs.

Fabrication Checks the pad and trace size, drilling clearance, component assembly, acid 
trap size, and copper slivers.
SailWind Router does not have CAM document capabilities required to 
process some fabrication checks. Full fabrication checking can only be 
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performed within SailWind Layout. SailWind Router does not check the 
following:

• Minimum solder mask slivers

• Starved thermal checks

• Silk screen over pads

• Pad or drill to mask minimum annular ring

• Connect to plane (has thermal where needed)

• Solder bridge

 Tip
Set fabrication rules on the “Options Dialog Box, Fabrication Category”  on 
page 433.

Acid Traps  — Checks all visible electrical layers as defined by CAM 
documents. Maximum area size indicates the maximum area of the acid traps 
to flag. The area of pools that are flagged will be less than this value.

Figure 100. Acid Trap Maximum Area Size Checking

Maximum angle between objects is an angle between 0 and 90 degrees. Any 
copper items (traces, pads, or any other objects that exist on the layer) that 
form an angle smaller than this are flagged as an acid trap.

Figure 101. Acid Trap Angle Checking

Fabrication 
(Continued)

Copper slivers  — Checks if there are areas in the copper that are so narrow 
they may flake off. This check detects potential slivers on the electrical and 
composite layers in the design. Minimum width indicates the maximum width 
of copper slivers to flag. This flags slivers of a width less than this value. 
Minimum Copper checks all visible electrical layers as defined by CAM 
documents.

Figure 102. Sliver Checking

Mask slivers in the solder mask layer are areas of the solder mask so narrow 
they may flake off. These flakes float around and may drop into an area that 
needs to be soldered later, resulting in a bad board.
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Minimum Mask indicates the maximum size of the slivers to flag. This flags 
slivers of a width less than this value. Minimum Mask checks top and bottom 
solder mask layers, if visible as defined by CAM documents

Figure 103. Minimum Mask Checking

Drill hole clearance  — If drills are too close to one another, they may break 
out during board manufacturing. Drilling clearance checks the minimum 
distance between drill hole edges. It also checks the allowance for the plated 
drill.

Fabrication 
(Continued)

Traces and pads sizes  — Checks minimum trace width and minimum pad 
size of electrical layers.
Detects small electrical traces on the electrical layers in the design. Minimum 
Trace indicates the maximum allowable size of traces; traces with a width less 
than minimum trace will be flagged. This check runs on all visible electrical 
layers as defined by CAM documents.
Detects small pads on the electrical layers. Minimum Pad indicates the 
maximum allowable pad size; pads with a diameter less than minimum pad will 
be flagged. This check runs on all visible electrical layers as defined by CAM 
documents.

Via at SMD Violations Checks if the SMDs are to fit inside the pad, center within the pad, or be 
located at the end of the pad. The checking takes place only if the via outline 
intersects the SMD outline or is located completely inside SMD. The absence 
of a via at SMD is not considered an error.

Placement outline Checks that the distance between component placement outlines complies 
with the “Minimum spacing between components” value set in the Options 
dialog box, Fabrication category.
Measurements are made from the centerlines of the 2D lines that define the 
component placement outline.
This check applies to all placement outlines (derived from SailWind Layout 
Layer 20 outlines or auto-generated).

Component height 
restrictions

Checks the maximum component height on the top and bottom.
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Options Dialog Box, Display Category
To access:

• Choose the Tools > Options  menu item > Display category

• Click the Options  button > Display category

• Press the Ctrl + Enter keys > Display category

Set the text size of displayed net names and pin numbers, and the maximum allowable gap between net 
names on traces.

Objects

Field Description

Net name/pin number text size, 
pixels

Type values for the smallest and largest text sizes you use in 
the net names. Net names change in size depending on the 
shape on which they are placed. The text remains in proportion 
to the boundaries of the object. For example, the net name will be 
smaller on a 10 mil trace than it would on a 50 mil trace.
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 Restriction:
Net names will not appear on design objects, unless on the Colors Options category  on page 422, 
you also select the check box for the Net Nm. column, give colors to color tiles in the column on the 
layers where you want the net names to appear, and select one or more of the “Show net names 
on” check boxes.

Maximum gap between net 
names on traces, pixels

Type a value to set the gap at which the net names should be 
repeated at intervals along traces.
The gap must be between 50 and 3000 pixels.
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Options Dialog Box, Fabrication Category
To access:

• Choose the Tools > Options  menu item Fabrication category

• Options  button > Fabrication category

• Ctrl + Enter > Fabrication category

Use the Fabrication category to set design fabrication rules during design verification. Fabrication checks 
detect conditions that may result in errors in PCB fabrication or manufacturing.

Description

Restriction:
You cannot set fabrication rules at any level of the hierarchy except for component and drill 
clearances. You establish manufacturing clearances prior to performing the checks.

Restriction:
SailWind Router does not have the CAM document capabilities required to process some 
fabrication checks. Full fabrication checking can only be performed in SailWind Layout. SailWind 
Router does not check the following:
• Minimum solder mask slivers
• Starved thermal checks
• Silkscreen over pads
• Pad or drill to mask minimum annular ring
• Connect to plane (has thermal where needed)
• Solder bridge
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Name Description

Pad and trace sizes area

Minimum pad size Sets the minimum diameter of the pads allowed by the fabrication 
procedures.

Minimum trace width Sets the minimum trace width allowed by the fabrication 
procedures.

Acid trap detection area

Maximum area size Specifies the maximum size of the acid traps to detect. It flags the 
small areas where the acid might pool up. The area flagged for a 
pool up should be smaller than this value.

Maximum angle between objects Specifies areas of copper items (traces, pads, or any other objects 
that exist on the layer) with angles smaller than this value. Any of 
these items is flagged as an acid trap if it forms an angle smaller 
than the value specified here.

Copper sliver detection area
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Minimum width Specifies the minimum size of the copper slivers to detect as 
errors. Slivers with widths smaller than this value are flagged.

Drilling clearance area

Minimum spacing between holes Specifies the minimum value of the edge-to-edge spacing between 
two drill holes.

Allowance for plated drills Specifies the amount of space added to the plated drill holes to be 
used for copper plating inside a drill hole.

 Tip
You specify whether a via or pin is plated in Pad Stack 
Properties dialog box of SailWind Layout.

Component assembly area

Minimum spacing between 
components

Specifies the minimum distance between component placement 
outlines.
Measurements are made from the centerlines of the 2D lines that 
define the component placement outline.
This check applies to all placement outlines (derived from 
SailWind Layout Layer 20 outlines or auto-generated).

 Note:
Upon loading a design from SailWind Layout, this value 
populates with the value from the SailWind Layout “Body to 
body” clearance rule.

Maximum component height on 
top side

Specifies the maximum height for all components on the top side 
layer.

 Tip
Use the Clearance  tab of the Component or Decal Properties 
dialog boxes to set this value.

Maximum component height on 
bottom side

Specifies the maximum height for all components on the bottom 
side layer.

 Tip
Use the Clearance  tab of the Component or Decal Properties 
dialog boxes to set this value.
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Options Dialog Box, Global Category, Backups 
Subcategory
To access:

• Choose the Tools > Options  menu item > Global  category > Backups  subcategory

• Click the Options  button > Global  category > Backups  subcategory

• Press the Ctrl + Enter keys > Global  category > Backups  subcategory

Set the location and make other settings for automatic backups.
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Objects
Table  87. Options Dialog Box, Global Category, Backups Subcategory Contents

Field Description

Backups location Displays the backup file location. This location is set in the File Locations 
category  on page 439.

 Tip
Backup files have the .bre  extension.

Interval (minutes) Type the time in minutes between backups.

Number of backups Type the number of backups to keep before deleting old ones. When the 
number of backups reaches this limit, the oldest existing backup is deleted 
whenever a new backup is created. For example, if the number of backup files 
is set to 2, only the last two backup files are kept, depending on the interval 
you set.

 Tip
This limit can specify the maximum number of backups for all designs, 
or the number of backups for each design. For more information, see the 
“Table 88” table.

Use design name in 
backup file name

Check the check box to use the design name plus “Router” in the backup 
filename, as follows:
<design_name>_Router_<month_day_hour_minute>.bre
If this check box is not checked, backup files are named in this format:
Router_<month_day_hour_minute>.bre

Create backup files in 
design directory

Select this check box to place your backup files in the same directory as 
the design. This overrides the location set in the File Locations category  on 
page 439.

 Tip
Clear the check box if you want your backup files in one common backup 
directory.

Include extension 
directory 
(<project>_PCB)

Select this check box to create a directory containing the 3D support files used 
in the design. The directory is named in this format:
<design_name>_PCB
This check box is checked by default.

 Tip
Clear the check box if you do not want to create a backup directory 
containing the 3D support files used in the design.
 Note:
If you have assigned 3D models to parts in a design you must keep the 
<design_name>_PCB  folder and the .pcb  file together in the same directory 
location or the next time you open the .pcb  file the 3D models will not 
appear.
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Table  88. File Backup Strategies 

Backup Settings Resulting Backup Behavior

 Use design Name in backup file 
name

 Create backup files in design 
directory

All backups saved in the default backup directory, and named 
Router_month_day_hour_minute.bre.
“Number of backups” specifies the maximum total number of 
backups for all designs.

 Use design Name in backup file 
name

 Create backup files in design 
directory

All backups saved in the default backup directory, and named 
<design_name>_Router_month_day_hour_minute.bre.
“Number of backups” specifies the maximum number of 
backups for each design.

 Use design Name in backup file 
name

 Create backup files in design 
directory

Backups of each design saved in the design directory, and 
named Router_month_day_hour_minute.bre.
“Number of backups” specifies the maximum number of 
backups for each design.

 Use design Name in backup file 
name

 Create backup files in design 
directory

Backups of each design saved in 
the design directory, and named 
<design_name>_Router_month_day_hour_minute.bre.
“Number of backups” specifies the maximum number of 
backups for each design.
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Options Dialog Box, Global Category, File 
Locations Subcategory
To access:

• Choose the Tools > Options  menu item > Global  category > File Locations  subcategory

• Click the Options  button > Global  category > File Locations  subcategory

• Press the Ctrl + Enter keys > Global  category > File Locations  subcategory

Change file locations.

Objects

Field Description

File locations area— In the Location section, double-click the location you want to change and type a 
new location.
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Alternative: In the Location section, double-click the location you want to change, and then click the 
Browse  button to locate an existing folder. You can change to any location without compromising your 
data.
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Options Dialog Box, Global Category, General 
Subcategory
To access:

• Choose the Tools > Options  menu item > Global  category > General  subcategory

• Click the Options  button > Global  category > General  subcategory

• Press the Ctrl + Enter keys > Global  category > General  subcategory

Set user interface options that are global to the design process.

Objects

Field Description

Display settings area
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Show unroutes at recommended 
width

Displays unroutes at the recommended width of a trace being 
routed. This option allows you to see the width of the trace before 
routing it.

 Tip
You can set the recommended trace width on the Properties 
dialog box. In an open design with nothing selected, right-click, 
choose the Properties  popup menu item, then open the 
Routing  tab.

Auto-hide unroutes for interactive 
actions

Temporarily hides unroutes when you route or edit traces 
interactively.

Make objects transparent Shows traces on multiple layers at once and makes all obstacles 
that may be hidden directly under the active layer visible.

Show traces and pads as outlines Shows all objects as outlines instead of as filled objects to speed 
redraw time. Traces appear as two parallel lines separated by the 
defined trace width. This also makes it easier for you to see the 
true boundaries of overlapping objects.

Distinguish protected traces and 
vias

Displays normal unprotected objects as solid, and any protected 
objects as outlines. If you also select Show traces and pads as 
outlines, protected objects appear filled, and unprotected objects 
appear as outlines.

Show guard bands on object Displays guard bands around objects during interactive routing. 
A guard band is a shape around traces and other obstacles. The 
width of the guard band is the required clearance between an 
object and the trace being routed.

Maintain scale and view on 
window resize

Maintains the proportional scale and the same area of the 
workspace, when you resize the window.

Distinguish component rules 
traces

Displays traces under component rules as outlines.

Design units Select the design units you want to work with. All values in dialog 
boxes are displayed in these units, and any values you enter are 
interpreted in these units.
Tips:

• Values are converted when you change design units.

• You can also use the following modeless commands to set 
design units:

UM — Sets design units to mils.
UMM — Sets design units to millimeters (metric).
UI — Sets design units to inches.
UUM — Sets design units to microns.

Minimum line width Type a value to display lines with widths less than this value as 
centerlines, rather than as their actual width.

Highlighted object display area
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Distinguish highlighted objects by Select the way you want the highlighted objects to appear 
in the design. You can identify objects in the open design by 
differentiating them from other design objects.
Exception:  You can only set the Brightness level if you selected 
Dimming other object color.

Filled object display area

Keepout fill Specifies how keepout areas appear on the screen.
Transparency  — Becomes available when you select the 
“Transparent” fill option. The “high” setting is equivalent to no fill 
and “low” setting is equivalent to solid fill.

Copper fill
or
Copper, copper plane fill

Specifies how filled solid copper objects appear on the screen.
When the dynamic copper healing mode is disabled on the 
Flooding category  on page 447 of the Options dialog box, the 
title of this list changes to “Copper, copper plane fill” indicating that 
the copper fill setting also affects the display of copper planes.
Hatch spacing  — Becomes available when you set the fill setting 
to a “hatch” setting (Orthogonal hatch, Diagonal hatch, Orthogonal 
crosshatch, or Diagonal crosshatch). The Hatch spacing value 
must be between 1 and 32 in pixels.

Object movement area

Move object by • Origin—The pointer attaches to the origin of the object.

• Cursor location— The pointer attaches to a point that is set 
when you started the move and maintains its X/Y offset relative 
to the object during the move.

Example: If you start the Move command with the pointer 
at X=200,Y=500 and the selected component at X=0,Y=0, 
moving the pointer to X=1200,Y=1500 moves the component to 
X=1000,Y=1000.

• Midpoint— The pointer attaches to the center of a rectangle 
enclosing the object.

Drag object using • Drag and attach— Select the object, drag the object slightly 
to attach it to the pointer, and then release the mouse button. 
Move the pointer to the new location and click to complete the 
move.

 Tip
You can change the workspace view, start another 
command, or change the selected component properties, 
while the object is attached to the pointer.

• Drag and drop— Drag the object to the new location.

• No drag moves— Disables all drag moves.

Pointer settings area

Pick radius The Pick radius value must be between 1 and 100 in pixels. Larger 
values mean the pointer can be further away and still select an 

SailWind Router Guide 443



SailWind Router GUI Reference
Options Dialog Box, Global Category, General Subcategory  

Field Description
object, but this can cause you to select other unintended objects 
within the same vicinity.

 Tip
When many objects are in the same vicinity, you can cycle 
through them using the Tab key.

Style Select a style of cursor from the list.

Pan display with pointer 
movements

Select the check box to pan the display area when moving objects 
with the cursor.

Length monitor Select the check box to display net length values on the pointer.
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Options Dialog Box, Placement Category
To access:

• Choose the Tools > Options  menu item > Placement  category

• Click the Options  button > Placement  category

• Press the Ctrl + Enter keys > Placement  category

Specify the behavior of placement operations for components in a design.

Objects

Field Description

Optimize net topology Defines when to optimize the net topology. With net optimization 
enabled, the program tries to minimize connection lengths. You 
can optimize nets during component placement, after placing the 
component, or you can move the component without optimizing 
the net topology.
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See also “Setting Net Topology”  on page 291

Reroute traces Defines the rerouting behavior for placement commands when 
moving a component with connected traces.
During move  — Reroutes nets during placement. Traces that 
cannot be routed free of DRC violations during placement appear 
to be stretched and highlighted, and are rerouted again with batch 
routing tools after placement is completed.
After move  — Unroutes nets during placement, then reroutes 
them when placement is complete.
No rerouting  — Unroutes nets during placement and leaves 
them unrouted when placement is complete. When you disable 
trace rerouting, traces attached to components that are moved, 
rotated, spun, or flipped before the placement operation starts are 
unrouted.
See also “Reroute Traces”  on page 349

Set angle increment Sets the minimum angle increments for the Spin command. Type a 
value between 0 and 360 degrees to determine the angle by which 
to rotate objects when using the Spin command.
During the Spin command, the placement grid settings are ignored 
and angle increments are used instead.
See also “Manipulating Components”  on page 209

Move fanouts area Select the check box to specify whether or not to move fanout 
traces and vias and the selected component as a group during 
placement operations
Type the maximum length of fanout traces to move with the 
component.

Check violations during move Select to check placement rule violations when moving or spinning 
a component. If body-to-body violations occur when moving 
or spinning a component, the neighboring components are 
highlighted, including placement keepouts or board outlines.
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Options Dialog Box, Flooding Category
To access:

• Choose the Tools > Options  menu item > Flooding category

• Click the Options  button > Flooding category

Specify the behavior and settings for the representation of copper planes (“flooding”) in a design.

Objects

Field Description

Remove isolated copper In plane areas, toggles the visibility of copper material that is not 
connected to a net.

Add thermals to routed 
component pads

Allows placement of thermals on routed pads. Thermals are normally 
generated only on unrouted pads, and vias.
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 Tip
Small leftover trace segments attached to a pad prevent the pad 
from receiving thermals if this check box is not selected.

Replace unused pads with 
antipads

Removes unused pads and replaces them with antipads. All pads 
are removed on all internal “No Plane” and “Split/Mixed” layers 
unless the pin is connected to a trace or a copper plane on that 
layer. Prior to PADS VX.2.4, unused pads were removed only from 
“Split/Mixed” layers.

 Note:
For CAM planes, this setting has an effect only in SailWind 
Layout.

For partial vias, selecting the Preserve via pads on start and end 
layers  check box prevents removal of the starting or ending pad if 
either is on a plane layer.

Use design rule clearances to 
create thermals and antipads

Uses the hierarchical “Pad to Copper” clearance rule for thermals 
and the “Drill to Copper” clearance rule for antipads.

 Tip
Keep the following in mind:

• Enabling this option ignores the outer width/diameter/size 
settings for custom thermals and the width/diameter/size 
settings for custom antipads. Also, the external outlines of 
thermals and antipads are not displayed.

• This option does not affect custom thermals for which the 
outer width/diameters/size is less than, or equal to, the inner 
width/diameter/size in the flood over settings.

Enable dynamic copper healing Displays copper planes in dynamic healing  mode, meaning edits 
you make to copper plane flooding—such as changes to clearances 
around pads, vias, and other objects—appear in real-time. Dynamic 
copper healing mode has the following effects:

• Copper planes appear filled

• Solid copper areas display according to the settings in the “Filled 
object display area”  on page 443 on the Global category > 
General subcategory

• PCB files saved from within SailWind Router retain hatch areas 
created in SailWind Router

 Note:
When a design is first loaded and this option is not enabled, 
hatch areas created in SailWind Layout display according to 
the SailWind Layout settings. If this option is then enabled, fill 
settings from SailWind Layout are overridden by dynamic copper 
healing and they cannot be recalled. To reinstate the original 
settings, you need to reload the design from SailWind Layout.

Smoothing radius Controls the radius of copper plane corners, according to the 
following:
<corner radius> = <shape outline width> * <smoothing radius>
You can set the smoothing radius parameter between 0 and 5.
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Hatch direction Specifies the hatch orientation in the workspace. Choose one of the 
following settings:

• Orthogonal — Hatching consists of vertical and horizontal lines.

• Diagonal — Hatching consists of diagonal lines.

You can change the hatch spacing using the Grid tab  on page 491
of the Design Properties dialog box.

Minimum hatch area Specifies the square root, in current design units, of the minimum 
hatch outline area (the smallest island area created by flooding).
For example, if you do not want to display islands smaller than 9 
square design units, type “3” into the box.

Thermals Provides a table of thermal settings for through-hole and surface 
mount pad stacks.

• Spoke width  — Specifies the line width for the thermal relief in 
current design units.

• Spoke minimum  — Specifies the minimum number (1-4) of 
spokes.

• pad shape (Round pad, Square pad, Rectangle pad, Oval pad) 
— Indicates the thermal relief options for a given pad shape. 
Choose a relief option by clicking the corresponding dropdown 
list:

• Orthogonal  — Creates orthogonal-shaped thermal reliefs.

• Diagonal  — Creates diagonal-shaped thermal reliefs.

• Flood Over  — Creates thermal reliefs that flood over the pad.

• No Connect  — Creates no thermal reliefs.
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Options Dialog Box, Routing Category, 
General Subcategory
To access:

• Click the Options  button > Routing  category > General  subcategory

• Choose the Tools > Options  menu item > Routing  category > General  subcategory

• Press the Ctrl + Enter keys > Routing  category > General  subcategory

Specify interactive routing and autorouting settings.

Objects

Field Description

Routing angle  area Set the default angle used for interactive routing or the angle used 
globally for all autorouting.
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Field Description

• Orthogonal— Adds trace segments at 90 degree increments.

• Diagonal— Adds trace segments at 45 degree increments.

• Any angle— Adds trace segments at any angle.

Exceptions:
• While you can change this routing angle during interactive 

routing, you cannot change the routing angle while autorouting.

• Traces entering or exiting pads may ignore the routing angle to 
maintain other rules, such as first corner rules or grids.

Miters  area Use miters to specify values for replacing a corner with a diagonal 
segment or arc. These options also apply to the Miters pass of the 
autorouter.

• Ratio— Specifies the size of a diagonal miter or the radius of 
an arc miter. Type the ratio value to define the ratio of the arc 
radius to the trace width.

Example:  For a 12-mil trace, a ratio of 1 produces a radius of 
6; a ratio of 2 produces a radius of 12.

See also Miters

• Angle— Specifies the maximum corner at which miters or arcs 
are created.

• Use arcs— Select to create miters with arcs for both regular 
and differential pair traces.

 Tip
The Use arcs setting is used by the Miters Pass only.

See also Converting Corners to Arcs

Centering  area Maximum channel width— Set a maximum channel width to limit 
the number of channels to center. Any channel larger than this 
width is not eligible for centering.
Center is a pass of the autorouter that you can also interactively 
run on selected traces.
Centering places traces equidistant from the pads of adjacent 
component pins or vias to evenly distribute any available space in 
the channel, as shown below. Centering does not violate design 
rules.

Figure 104. Centering Traces

See also: Center Pass

Interactive routing  area
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Dynamically route Select to create trace patterns automatically as you move the 
pointer, as shown below. The software automatically adds corners, 
avoids obstacles, and creates an error-free trace pattern.
If the “Dynamically route” check box is cleared, you must click to 
manually enter corners and define the trace pattern.

 Tip
Dynamic routing is always enabled when you route differential 
pairs.

Alternative:  While interactively routing, right-click and choose the 
Dynamically Route  popup menu item to temporarily turn dynamic 
routing on or off.

Figure 105. Dynamic Routing

Allow loops when rerouting Select to allow a route loop. Add a second connection and the first 
connection will not be ripped up. When this check box is cleared, 
in interactively routing you are prevented from creating a loop in a 
trace. Any trace pattern you define that creates a loop is adjusted 
automatically and a more direct path is created instead.

Protect traces and vias when 
creating segments

Select to protect trace segments and vias as they are added.

 CAUTION:
You should protect arcs because autorouting operations and 
plowing in interactive routing may remove unprotected arcs.

Alternative: While interactively routing, right-click and choose the 
Protect Traces and Vias  popup menu item.

Allow trace necking Select to automatically reduce the trace width to the minimum 
trace width to escape the object from which you are routing when 
the recommended or current trace width is too large.
If this check box is not selected, and the trace width is too large, 
then interactive routing cannot start. You will have to manually 
reduce the trace width to escape the starting object and then 
increase the trace to the desired width.
Tips:

452 SailWind Router Guide



 
SailWind Router GUI Reference

Options Dialog Box, Routing Category, General Subcategory

Field Description

• Set the Minimum, Recommended, and Maximum trace widths 
on the Routing  tab of the Properties dialog boxes.

• For best results, set the Minimum trace width for the net equal 
to or smaller than the smallest pad width for the pins in the net.

• This feature is most useful when used with guard bands.

See also Showing Clearances Around Obstacles

Adjust trace segments around 
obstacles

Select to allow trace segments to adjust around obstacles when 
not using dynamic routing.
For example:  If you add a corner, and the trace encounters an 
immovable obstacle (such as a component pin), the last-entered 
trace corner moves automatically to a new position that allows the 
trace to pass the obstacle, as shown in Figure 106.

Figure 106. Adjusting Around Obstacles

Show estimated length of pin pair Select the check box to estimate the total length (total net length + 
unrouted length) of the current pin pair in the trace length monitor.
If the check box is cleared, the monitor estimates the total length of 
the entire net (routed length + unrouted length).
See also Monitoring Trace Length

Smooth adjacent segments Select to smooth adjacent trace segments when moving a 
segment, arc, or adding or moving vias.
If the check box is cleared, adjacent segments are stretched.

Figure 107. Stretched and Smoothed Adjacent Segments

Exception:  This option does not apply when adding or moving 
corners.
See also Trace Smoothing  for other smoothing options
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Field Description

Allow diagonal snap to traces Select to automatically snap trace objects to a diagonal axis.
Traces snap to a diagonal axis. This happens only when you 
modify trace objects and the routing angle is set to Diagonal or 
Any Angle.
For example, when you stretch a trace segment and the trace is 
near a grid point, the trace automatically snaps to that grid point, 
creating a perfect diagonal.
If the current routing angle is Orthogonal, the traces snap to 
90-degree grid increments. Once an object snaps diagonally, click 
to place the corner.
Objects snap when they are within one half the trace width of the 
diagonal axis.

Push segments away from 
obstacles

Select to let a trace “push away” from obstacles.

 Tip
The distance that a trace segment is pushed away from an 
obstacle meets clearance rules.

Exception:  Trace segments do not push away from obstacles if 
you right-click and click Ignore C during editing, or if the DRC  on 
page 405 mode for clearances is set to Prevent or Explain.

Figure 108. Pushing Segments Away From Obstacle

Smooth traces on complete Select to run a smoothing operation on a trace when you end the 
trace.

Preserve arcs during smooth Select to preserve arcs when you smooth a trace.

Layer pair  area Layer pair sets the first and second layer of the layer pair during 
routing. The layer pair increases your productivity when manually 
adding routes on multi-layer boards. When you add a via, the layer 
automatically switches to the other layer in the current layer pair.
Recommendation:  Set the layer pair to those layers upon which 
you expect to do most of your routing so you do not have to switch 
layers manually when you add a via.
See also Setting Layer Rules

Plower  area— Plowing moves unprotected traces, vias, and test points to make room for new traces 
and vias. Using plowing, you can continue routing without rerouting obstructing traces or stopping to 
move objects.
See also Plowing Traces
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Field Description

Turn on plower Select to enable plowing.

Plower and pointer interaction Choose when to plow obstacles:
• To plow objects as you move the pointer, click Plow with 

pointer.
• To plow obstacles immediately as the pointer passes them, 

click Real-time plowing.

• To plow obstacles after the pointer defines a potential path 
and then reaches an open area, click Guided plowing.

• To plow obstructing traces after you enter corners, click Plow 
after corner click.

Plow traces smoothly Select to smooth obstructing traces as they are plowed, thereby 
enhancing the quality of trace patterns.

Allow pushing of trace behind 
plower

Select to push obstructing traces both ahead of, and behind the 
pointer as you route.
Otherwise, traces are pushed ahead of the pointer.

Plower strength In the Plower strength list, select the strength of the plower: Low, 
Medium, or High.
Higher strength settings increase the depth of the plower so 
that more traces are plowed. Because more traces are plowed, 
additional time may be needed for each plow.
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Options Dialog Box, Routing Category, 
Strategy Subcategory
To access:

• Choose the Tools > Options  menu item > Routing  category < Strategy  subcategory

• Click the Options  button > Routing  category < Strategy  subcategory

• Press the Ctrl + Enter keys > Routing  category < Strategy  subcategory

Define a strategy for autorouting a design. The strategy defines the sequential operations to perform 
during autorouting, including: passes that the autorouter should run and the order in which to autoroute 
components, nets, net classes, differential pairs, and matched length groups.

Objects

Field Description

Pass definition area
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Field Description

Pass Type column Lists the types of passes that you can run on the design. The order 
of the passes is locked and proceeds from top to bottom.

Pass column Select the check box of each pass type you want to run. You can 
run any combination of passes.

Protect column Select the check box of those passes after which to protect the 
generated traces. This protects traces and glues vias that are 
completed during the pass.

Pause column Select the check box of a pass if you want the autorouter to pause 
after a pass. To continue after the pause, on the Routing toolbar, 
you must click the Resume Autorouting button.

Intensity column Select the appropriate intensity for the autorouting pass. Intensity 
determines the effort and time the router can spend on a pass.

 Restriction:
You cannot set an intensity for the Center pass.

Routing Order column Specify the order in which to autoroute components and nets (net 
classes, differential pairs, and matched length groups) for the 
selected pass.
Once you select and activate the Routing Order cell for a pass, 
the Routing order definition area at the bottom of the dialog box 
becomes active. Use this area to create the order for autorouting 
that pass.

 Tip
You can optimize routing by defining a routing order. For 
example, make a first quick trial pass at low intensity to see the 
resulting routing pattern of the autorouter. Look for components 
with many pins. Do any components have large numbers of pin 
nets that are unable to break out because of other connections 
that have already been routed in its breakout area? In this 
case, set the component at the top of the routing order and 
the nets of this component will be routed first by the autorouter 
ensuring a successful breakout and better overall autorouting 
completion.

Done column A check mark is displayed in the Done column for each pass 
that completes. The check marks remain until you modify the 
autorouting strategy, or restart autorouting.
This is a read-only column, you cannot manually mark a pass as 
complete.

Routing order definition area

Components/Net Objects tree Browse the tree to select individual nets or components to add the 
Routing Order list. Click Selected  to add.
When you add a component to the Routing Order list, all the nets 
attached to the component are routed at that stage of the routing 
order.
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Field Description

 Tip
You can also add nets or components to the routing order list 
by using the following:

• The Project Explorer—You add nets in exactly the same 
way as you add them using the Components/Net Objects 
tree. Select them in the Project Explorer, then click the 
Selected button in this dialog box.

• The work area—Select nets or components in the design 
area, then click the Selected button in this dialog box. You 
may need to set the Selection Filter to select those design 
objects.

buttons • Default—Click to clear the routing order list and add All Nets to 
the Routing Order list.

• Selected—Click to add the object selected in the 
Components/Net Objects tree to the Routing Order list. You can 
also use this button to add objects selected in the design area 
or the Project Explorer.

• All Nets—Click to add All Nets to the Routing Order list.

• Plane Nets—Click to add all nets assigned to plane layers.

• Clear—Click to remove all items from the Routing Order list.

Routing Order list Use the pane buttons to remove or reorder the items in the 
Routing Order list. Items at the top of the list are routed first in the 
autorouting pass. Make sure to add All Nets to the bottom of every 
routing order list, otherwise the autorouter will only route the few 
items you may have added to the routing order.
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Options Dialog Box, Test Points Category
To access:

• Click the Options  button > Test Points category

• Choose the Tools > Options  menu item > Test Points category

• Press the Ctrl + Enter keys > Test Points category

Use the Test Points category to define test point placement during autorouting, interactive routing, and 
trace editing. Test points allow probes of testing devices to make electrical contact with the board.

Objects

Field Description

Creating test points area

Create test points during 
autorouting

Select to insert test points automatically in the design during 
autorouting.
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Field Description

Preserve test points Select to prevent existing vias assigned as test points from being 
reassigned, removed, deleted, shoved, or modified.
Exception:  This option does not preserve new test points on 
new traces until all routing passes are completed or if the routing 
process is stopped.

Insert test point vias to convert 
inaccessible nets

Select this check box to add test point vias for nets that are 
inaccessible for other test points.
“Use test point via” dropdown list — If you choose to insert test 
point vias, also specify the type of via to insert.
“Allow stubs to make nets accessible” check box — Select the 
check box to allow short trace stubs to the test point via when 
making nets accessible.

Probe properties through  area

PCB top side Select to probe the board from the top side too.

 Tip
Pins are always available for probing from the bottom side, 
whether or not PCB top side is selected.

Vias Select to use vias as test points.

Pins Select to use Pins as test points.

Unused pins Select to assign test points for the unused pins in the design by 
selecting Unused pins and providing the net name for all unused 
pins in the design.
Unused pins net name— When you specify to use unused pins 
as test points, you also specify the net name of the unused pins.
This requires attaching a test point via, if it is an SMD pad, or 
assigning an unused component pin as a test point, if it is a 
through hole pin.
For SMD pins, this is achieved by adding one single pin net to 
each unused SMD pin. The net is partially routed and terminated 
with a test point via.

Probe Clearance  area Click the Setup  button to open the Test Points properties of the 
Design Properties.
See also Properties Dialog Box, Test Points Tab

Place test points using  area Click an option to specify the grid type to use for test point 
placement: Via grid or Test point grid.
Grid Setup  — This button is only available if you select the 
Test point grid. Click to open the Grid properties of the Design 
Properties where you can set the Test Point grid values.
See also Setting Grids

Select test probe sizes area Use the buttons to add, delete, and move a probe size name. Click 
in a cell to change values.
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Field Description

During the placement or assignment of test points, the values 
you specify in the Name cell are assigned as via or pin attributes. 
When you change these values, attributes for all vias and pins with 
these values are updated.

Field Edit the name of the probe size to uniquely identify probe types.

Fixture drill size Edit the diameter of the drilled hole in the fixture.
Recommendation:  Fixture drill size is used to calculate all rules 
relevant to the probe size and its diameter should usually be 
slightly larger than the probe size.

Enabled Specify whether or not to use the associated nail during automated 
testing

Minimum pad probing sizes 
area

Minimum pad probing values for both Vias and Component pins 
ensure that there is sufficient pad area for probe contact. These 
values determine the minimum pad size to allow during test point 
assignment.
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Options Dialog Box, Text and Lines Category
To access:

• Click the Options  button > Text and Lines category

• Choose the Tools > Options  menu item > Text and Lines category

• Press the Ctrl + Enter keys > Text and Lines category

Set the default width for border lines used in the drawing of copper planes.

Note:
You can change the border line width for individual copper planes by right-clicking and choosing 
the Width > Set  popup menu item.
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Objects

Field Description

Default Width Type a default width in the box. This becomes the default border 
width for all copper planes and shapes you draw using the Drafting 
Tools unless you specify otherwise.

Prompt for net name at 
completion of copper

When you select this check box, the Copper Plane Properties 
dialog box appears each time you finish drawing a copper plane.
The Copper Plane Properties dialog box  on page 475 provides a 
dropdown list for choosing a net to associate with a copper plane 
as well as other copper plane options.
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Options Dialog Box, Routing Category, Tune 
Subcategory
To access:

• Choose the Tools > Options  menu item > Routing  category > Tune  subcategory

• Click the Options  button > Routing  category > Tune  subcategory

• Press the Ctrl + Enter keys > Routing  category > Tune  subcategory

Control the accordions used in length-controlled nets and differential pairs.

Objects

Field Description

Routing to length constraints area
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Field Description

Accordion • Minimum amplitude (times trace width)— Type a number to 
specify the minimum height for accordions.

• Maximum amplitude (times trace width)— Type a number to 
specify the maximum height for accordions.

• Minimum gap (times trace to corner clearance)— Type a 
number to specify the minimum distance between traces in the 
accordions.

• Max hierarchy level— Type a number to specify how many 
levels of increased aggressive patterns can be used to 
complete the accordion.

See also: “Maximum Hierarchy Level” in Tune Pass

• Miter ratio— Type a number to specify the miter ratio for 
accordion corners.

• Use arcs in miters— Select the check box to use an arc 
instead of a diagonal segment in the accordion.

Extra length added above 
required by matched length group 
tolerance (percent)

Type a number to determine how much extra length is added 
above the required matched length group tolerance (in percent of 
the tolerance).
Example:  If you type 0, the tuned net will be <Leader length - 
tolerance> length. If you type 100, the net will get the same length 
as the group leader. The leader net is the net in the matched 
length group that has the longest length.

Ignore length rules when required 
to complete traces

Select this check box if you need break length rules to complete 
traces.

Differential pairs area

Add diff pair correction accordions 
when tuning

Select this check box to use an accordion to make differential pairs 
the same length.

• Do not create correction accordions in gap portion— Select 
this check box if you do not want to allow correction accordions 
where two traces go together at the gap

• Create correction accordions only when length difference 
is greater than the matched length tolerance— Select to 
ensure that correction accordions are not created when the 
differential pair net length difference is less than the tolerance 
of the matched length group.
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SailWind Suite Configuration Dialog Box
To access:

• Choose the Help > Installed Options  menu item > Suite Configuration  button

• (Optional) Opens on program startup

Manage SailWind Suite (composite) licenses.

Objects

Field Description

Control suite license checkout and 
select from the following list

Enables the Suite License table for you to control checkouts.

Suite Name column Lists the name of the suite for which the license works.

License Feature column Lists the specific features available for each license.

License status column Lists the status of the licenses when you click the Check status 
button.

Check Status button Specifies to check the status of all licenses listed in the table and 
displays the status in the License status column.

Reset List button Specifies to reset the list of suite licenses to only those detected in 
your licensing environment.

Move up button Moves the selected license up one row.

Move down button Moves the selected license down one row.

Select all button Selects all of the listed licenses.
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Field Description

Select none button Deselects all of the listed licenses.

Show this dialog box on program 
startup

Specifies to open the SailWind Suite Configuration dialog box 
when SailWind Layout starts.

Automatically check license status 
on dialog box startup

Specifies to check the status of the licenses when you open the 
SailWind Suite Configuration dialog box.
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Properties Dialog Box, Clearance Tab
To access:

• Click the Properties  button > Clearance  tab

• Right-click > choose the Properties  popup menu item > Clearance  tab

View and modify minimum spacing clearances between design objects. If you select an object, you set 
the clearance properties for that object. If you select nothing, you set clearance properties as design 
defaults.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

clearance matrix Type a value in the box setting the permissible clearance between 
the object listed in the row heading and the object listed in the 
column heading.
Alternative: To set the same value for an entire row or column, 
click on a column heading, row heading, or All. Type a value and 
click OK  to apply the value.
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Properties Dialog Box, Component Tab
To access: Select a component or pin > right-click > choose the Properties  popup menu item > 
Component  tab

View and modify the properties of a selected component or pin.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Component decal Lists the decal associated with the selected component or pin.

Part type Lists the part type associated with the selected component or pin.

Located on layer list Specifies the layer where the component or pin is located.

X/Y Specifies the X/Y coordinates of the component or pin.

Orientation Specifies the rotation angle of the component or pin.

Height of component Lists the height of the selected component or pin.

SailWind Router Guide 469



SailWind Router GUI Reference
Properties Dialog Box, Component Tab  

Field Description

Number of pins Lists the number of pins associated with the component.

Protect; disallow editing Prohibits moving a component when selected.

Exclude from electrical nets Specifies not to use the component or pin when creating electrical 
nets.
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Properties Dialog Box, Copper
To access: Select a copper shape, right-click, choose the Properties  popup menu item > Copper  tab.

Set the layer location, line width, and the assigned net of a copper shape. Also specify whether or not the 
copper shape is filled solid or with a hatching pattern.

Objects

Field Description

Width Type a line width for the outline width of the copper shape and 
for the line width of the “hatching” pattern of the fill. If you do not 
enable the solid fill option, the shape fills with lines placed on the 
X and Y axes on the copper grid.
In some cases, specifying a line width that is too wide 
would result in overlapping areas of the shape (known as a 
self-intersecting polygon). SailWind Router prevents you from 
specifying a width that results in such a self-intersecting shape.

Located on layer Select the layer where you want the copper shape to be placed.

Net Displays the assigned net for the copper shape.

Solid check box Displays the copper shape as solid without regard to the line 
width or grid setting.
When cleared, the copper fills according to the settings in the 
Options dialog box > Global  category > “General subcategory” 
on page 441 whenever the Pour Outline mode is disabled.

SailWind Router Guide 471



SailWind Router GUI Reference
Properties Dialog Box, Copper Cut Out Tab  

Properties Dialog Box, Copper Cut Out Tab
To access: Select a copper plane cut out, right-click, choose the Properties  popup menu item > Copper 
Cutout  tab.

View information about the layer location and the dimensions of a copper cut out.

Objects

Field Description

Width Type a line width for the outline of the copper cut out.
The line width applies to all lines used in the shape. In some cases, 
specifying a line width that is too wide would result in overlapping 
areas of the shape (known as a self-intersecting polygon). SailWind 
Router prevents you from specifying a width that results in such a 
self-intersecting shape.

Located on layer Specifies the layer on which the copper cut out is located.
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Properties Dialog Box, Copper Cut Out Corner
To access: Select a copper cut out corner > right-click > choose the Properties  popup menu item > 
Corner  tab

Set the coordinates of a copper cut out corner and view its other properties.

Objects

Field Description

Located on Layer Displays the layer on which the cut out corner is located.

X/Y coordinates Specifies the X/Y coordinates of the corner. You can edit the 
coordinates by typing directly in the boxes.
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Properties Dialog Box, Copper Cut Out 
Segment
To access: Select a trace segment of a copper plane cut out > right-click > choose the Properties  popup 
menu item > Segment  tab

Set the coordinates of the copper cut out segment.

Objects

Field Description

Located on layer list Displays layer on which the copper plane segment is located.

Coordinates Displays the location of the copper plane segment: X1, Y1, X2, Y2, arc 
center X (XC), arc center Y (YC), arc radius (R). You can edit these 
values by typing directly in the boxes. SailWind Router applies the 
change when you click OK.

 Tip
Change an arc to a straight line by typing 0 in the “R” box. Change 
a straight line to an arc by typing a non-zero value in the Arc radius 
box.

Dimensions Displays the line width and length of the copper plane segment.
You can edit the width by typing directly in the box. SailWind Router 
applies the change when you click OK.
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Properties Dialog Box, Copper Plane Tab
To access: Select a copper plane, right-click, choose the Properties  popup menu item > Copper Plane 
tab.

View information about the layer location and the assigned net of copper planes.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Width Type a line width for the outline of the copper shape.
The line width applies to all lines used in the shape, including 
borders and hatching. In some cases, specifying a line width that 
is too wide would result in overlapping areas of the shape (known 
as a self-intersecting polygon). SailWind Router prevents you from 
specifying a width that results in such a self-intersecting shape.

Located on layer Specifies the layer on which the copper plane is located.

Net Specifies the assigned net for copper planes.
Choose a net from the dropdown list.

Show plane nets only Select this check box to limit the display of nets in the Net list to 
only plane nets.
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Field Description

Use this feature when you want to assign nets to plane areas on 
a split/mixed plane, and you want to limit the list to display only 
those nets assigned for use on the plane layer.
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Properties Dialog Box, Copper/Copper Plane 
Corner
To access: Select a copper or copper plane corner > right-click > choose the Properties  popup menu 
item > Corner  tab

Edit the coordinates of a copper/copper plane corner and view its other properties.

Objects

Field Description

Located on Layer Displays the layer on which the copper or copper plane corner is 
located.

X/Y coordinates Specifies the X/Y coordinates of the corner. You can edit the 
coordinates by typing directly in the boxes.

Net Displays the net associated with the corner.
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Properties Dialog Box, Copper/Copper Plane 
Segment
To access: Select a segment of a copper or copper plane > right-click > choose the Properties  popup 
menu item > Segment  tab

Edit the coordinates of the copper/copper plane segment.

Objects

Field Description

Located on layer list Displays the layer on which the copper or copper plane segment is 
located.

Coordinates Displays the location of the copper/copper plane segment: X1, Y1, 
X2, Y2, arc center X (XC), arc center Y (YC), arc radius (R). You can 
edit these values by typing directly in the boxes.

 Tip
Change an arc to a straight line by typing 0 in the “R” box. 
Change a straight line to an arc by typing a non-zero value in the 
box.

Dimensions Displays the line width and length of the copper or copper plane 
segment.
You can edit the width by typing directly in the box.

Net Displays the net name associated with the copper or copper plane 
segment.
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Properties Dialog Box, Corner Tab
To access: Select a trace > right-click > choose the Properties  popup menu item > Corner  tab

Set the coordinates of a trace corner, and see which layer the corner is located on. Trace corners include 
T-junctions and trace end points.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Located on Layer Lists the layer on which the trace corner is located.

X/Y coordinates Specifies the X/Y coordinates of the corner.

Net Specifies the net associated with this corner.
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Properties Dialog Box, Drill Tab (Pin)
To access: Select a pin > right-click > choose the Properties  popup menu item > Drill  tab

View information about the pin pad stack, such as the finished drill hole size and the raw drill hole size. 
For slotted holes, you can view the finished length, length before plating, orientation, and offset.

Restriction:
This tab is for information only; these properties cannot be modified in SailWind Router. Use the 
Pad Stacks Properties dialog box in SailWind Layout to modify the properties displayed in this 
tab.

Tip
For plated holes, drill size includes global drill oversize value.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.
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Objects

Field Description

Slotted hole Enables a slotted hole for the selected pin.
See also: “Slotted Holes”  in the SailWind Layout Guide.

Finished length Sets the length of the slotted hole. This option becomes available 
when you select Slotted hole.

Length before plating Sets the length of the slotted hole before plating. This option 
becomes available when you select Slotted hole.

Orientation Sets the orientation of the slotted hole. This option becomes 
available when you select Slotted hole.

 Tip
A custom thermal or antipad for a slotted hole has the same 
orientation as the slot.

Offset Sets the slotted hole offset. Slot offset moves the center of the 
slotted hole relative to the electrical center of the pin–always in the 
opposite direction of the pad offset. This option becomes available 
when you select Slotted hole. The maximum amount of offset you 
can assign is one half of the slot's length. If you exceed this limit, 
the slotted hole display is suppressed in the Preview dialog box in 
CAM.

 Tip
A custom thermal or antipad for a slotted hole has the same 
offset as the slot.

Hole size Shows finished hole size and the size of the hole before plating.

 Restriction:
You cannot edit these fields.

preview Shows what the drill hole looks like.
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Properties Dialog Box, Drill Tab (Via)
To access: Select a via > right-click > choose the Properties  popup menu item > Drill  tab.

View the first and last layer the via connects, the finished drill hole size, and the raw drill hole size. The 
Drill  tab is for information only; you cannot modify the properties in SailWind Router. Use the Pad Stacks 
Properties dialog box in SailWind Layout to modify the properties displayed in the Drill  tab.

Tip
For plated holes, drill size includes global drill oversize value.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Start layer of drill hole Shows the layer on which the drill hole starts.

 Restriction:
You cannot edit this field.

End layer of drill hole Shows the layer on which the drill hole ends.

 Restriction:
You cannot edit this field.
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Properties Dialog Box, Drill Tab (Via)

Field Description

Hole size Shows finished hole size and the size of the hole before plating.

 Restriction:
You cannot edit these fields.

preview Shows what the drill hole looks like.
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Properties Dialog Box, Drill Tab (Virtual Pin)
To access: Select a virtual pin > right-click > choose the Properties  popup menu item > Drill  tab.

View the first and last layer that the virtual pin connects, the finished drill hole size, and the raw drill hole 
size. This tab is for information only; you cannot modify these properties in SailWind Router. Use the Pad 
Stacks Properties dialog box in SailWind Layout to modify the properties displayed in this tab.

Tip
For plated holes, drill size includes global drill oversize value.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Start layer of drill hole Shows the layer on which the drill hole starts.

 Restriction:
You cannot edit this field.

End layer of drill hole Shows the layer on which the drill hole ends.

 Restriction:
You cannot edit this field.
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Properties Dialog Box, Drill Tab (Virtual Pin)

Field Description

Hole size Shows finished hole size and the size of the hole before plating.

 Restriction:
You cannot edit these fields.

preview Shows what the drill hole looks like.
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Properties Dialog Box, Fanout Tab
To access: Right-click > choose the Properties  popup menu item > Fanout  tab

Use fanouts to make the routing easier and to ensure connections are made. The program tries to place 
fanout vias according to the alignment settings on this tab. Fanouts are most useful for some complex 
SMDs, like BGAs.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Description

Figure 109. Fanout tab

Figure 110. Fanout tab - BGA tab
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Properties Dialog Box, Fanout Tab

Figure 111. Fanout Tab - BGA staggered tab

Figure 112. Fanout Tab - SOIC / QUAD tab

Objects
Table  89. Fanout Tab Contents

Field Description

For pins on Specifies the type of fanouts to create. For pins on: Plane nets, 
Signal nets, or Unused nets.

Allow multiple connection to Specifies where to allow multiple connections: Pin, SMD, Via, and 
Trace.

Unlimited Enables unlimited fanout length.

 Tip
Clear the check box to specify a maximum length.

Maximum Specifies the maximum fanout length allowed.

 Restriction:
This box is available only when the “Unlimited” check box is 
clear.

BGA tab

Alignment list Specifies the via placement alignment: Quadrant, Diagonal, 
X-pattern.

Direction list Specifies the via placement direction. The choices change 
depending on what you selected in the Alignment list:
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Table  89. Fanout Tab Contents  (continued)

Field Description

• Quadrant— No choices.

• Diagonal— 45 degrees, 135 degrees, 225 degrees, 315 
degrees.

• X-pattern— Clockwise, Counterclockwise.

BGA staggered tab

Alignment Displays the via placement alignment: Ortho

Direction list Specifies the via placement direction: Horizontal, Vertical.

SOIC / QUAD tab

Alignment list Specifies the via placement alignment: Aligned, multiple rows; 
Alternate, multiple rows; Aligned, single row; Alternate, single row.

Direction list Specifies the via placement direction: Inside, Outside, Both sides.

Spacing list Specifies the via placement spacing: Use grid, One trace, Two 
traces.
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Properties Dialog Box, Flooding tab

Properties Dialog Box, Flooding tab
To access: Select a pour or a split plane > right-click > choose the Properties  popup menu item > 
Flooding  tab.

Use the Flooding  tab to change the flooding behavior or appearance of the selected copper plane or 
shape. Changes you make appear when you enable the dynamic copper healing feature (Options > 
Flooding  tab).

Objects

Field Description

Default Select this check box to use the default hatch grid, smoothing 
radius, and hatch direction settings  on page 447 in the selected 
copper area. Otherwise, specify these settings if you clear the check 
box.

Hatch grid Type a value for the hatch grid spacing. The value you type here 
supercedes the setting on the Grid tab  on page 491 of the Design 
Properties dialog box.

Smoothing radius Controls the radius of copper plane corners according to the 
following:
<corner radius> = <shape outline width> * <smoothing radius>
The smoothing radius parameter can be set between 0 and 5.

Hatch direction Specifies the hatch orientation in the flooded area.
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Field Description

• Orthogonal — Hatching consists of vertical and horizontal lines

• Diagonal — Hatching consists of diagonal lines

Flood over vias Allows copper flooding to extend over via thermals without affecting 
global settings in the Options dialog box.

Ignore board clearance Extends flooding beyond the board boundaries such as edges and 
cutouts.

Flood priority Establishes a priority order for flooding planes in the design. Type 
any whole number. A plane or object with a lower priority number 
floods before an object with a higher number.
Important:  SailWind Router does not route to overlapping portions 
of planes and pours that have the same priority setting.
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Properties Dialog Box, Grid Tab
To access: With nothing selected, perform one of the following actions:

• Double-click in the design area

• Right-click in the design area > choose the Properties  popup menu item > Grid  tab

• Click the Properties  button > Grid  tab

View and modify all grid settings in your design.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Displayed Sets the visual dot grid. This grid can also be set using the GD shortcut 
command.

Routing Sets the routing grid. This grid can also be set using the GR shortcut command.
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Field Description

Snap Objects to Grid— You can toggle this check box using the GS shortcut 
command. The GGS, GGM, and GGH commands require this check box to be 
selected for full functionality.

Test Point Sets the test point grid. You can also set this grid using the GT shortcut 
command.

Via Sets the via grid. You can also set this grid using the GV shortcut command.

Fanout Sets the grid for fanout vias. You can also set this grid using the GF shortcut 
command.

Component Sets the component placement grid. You can also set this grid using the GC 
shortcut command.

Copper Hatch Specifies the distance between hatch lines of copper planes. The hatch grid, 
when combined with the line width, creates varying degrees of hatch through to a 
solid pattern.
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Properties Dialog Box, Group Tab
To access: Select a group > right-click > choose the Properties  popup menu item > Group  tab

Set the tolerance between the members of the group and length restrictions for the group.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Tolerance Specifies the difference between the shortest member and longest 
member of the group.

Restrict length Restricts the length of the group to the range you specify in the 
“Minimum length” and “Maximum length” boxes.

 Tip
Unlike SailWind Layout, this program counts overlapping trace 
segments in the trace length calculation.

Minimum length Specifies the minimum length allowed for the group.

 Restriction:
This box is available only when “Restrict length” check box is 
selected.
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Field Description

Maximum length Specifies the maximum length allowed for the group.

 Restriction:
This box is available only when “Restrict length” check box is 
selected.
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Properties Dialog Box, Keepout Tab
To access: Select a keepout > right-click > choose the Properties  popup menu item > Keepout  tab

Set the layer on which a keepout is located and specify the objects to restrict from the keepout area.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
“Setting Design (Global and Default) Properties”  on page 154 and “Setting Object Properties”  on 
page 169.

Objects

Field Description

Located on layer Select a layer from the dropdown list where you want the keepout 
to be located.

Objects restricted from the 
keepout area

Specify the objects that you want to restrict from the keepout area.

SailWind Router Guide 495



SailWind Router GUI Reference
Properties Dialog Box, Keepout Segment  

Properties Dialog Box, Keepout Segment
To access: Select a segment of a copper or copper plane > right-click > choose the Properties  popup 
menu item > Segment  tab

Edit the coordinates of the Keepout segment.

Objects

Field Description

Located on layer list Displays the layer on which the keepout segment is located.

Coordinates Displays the location of the keepout segment: X1, Y1, X2, Y2, arc center 
X (XC), arc center Y (YC), arc radius (R). You can edit these values by 
typing directly in the boxes.

 Tip
Change an arc to a straight line by typing 0 in the “R” box. Change a 
straight line to an arc by typing a non-zero value in the box.

Dimensions Displays the length of the keepout segment.
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Properties Dialog Box, Layer Biasing Tab
To access:

• Click the Properties  button > Layer Biasing  tab

• Right-click > choose the Properties  popup menu item > Layer Biasing  tab

Enable or prevent routing of net objects on a layer. Layer biasing provides a finer level of control over 
route location than the settings in the Layers  tab, and restricts net objects to certain layers for routing. For 
example, you could use layer biasing to force SailWind Router to route power and ground nets on outer 
layers, and other nets on internal layers.

Restriction:
If a net object is selected, you specify the available routing layers for that object only. If a layer is 
selected, you can specify non-default availability for routing for any layer. If nothing is selected, 
you set the layer biasing properties as design defaults.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.
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Objects

Field Description

Layer Lists the layers of the design.

Allow Routing Enables the layer for routing.

 Note:
If you select a net object, this check box enables routing on the 
layer for the selected object.

Clear the check box to disable the layer for routing.
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Properties Dialog Box, Layers Tab

Properties Dialog Box, Layers Tab
To access: Select a layer > right-click > Choose the Properties  popup menu item > Layers  tab

Set routing parameters for a specific layer.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Layer Lists the layers of the design.

Route Enables the layer for routing.
Clear the check box to disable the layer for routing.

Direction Specifies the routing direction: Horizontal, Vertical, Diagonal (45), 
Diagonal (135), Any, or By Value.

 Tip
If you select By Value, you must set the desired routing angle 
in the Angle Value column.

Angle Value Specifies the desired routing angle.

 Restriction:
This box is available only when you select “By Value” in the 
Direction column.

Type Specifies the type of layer.
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Field Description

 Restriction:
This value is not editable; it is set in SailWind layout.

Cost Specifies the level of usage of the layer during routing. A higher 
number specifies less  use of the layer.
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Properties Dialog Box, Length Tab
To access: Select a net or a pin pair > right-click > choose the Properties  popup menu item > Length  tab

Restrict net or pin pair length.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Restrict length Restricts the net or pin pair length to the range specified by the 
“Minimum length” and “Maximum length” values.

Minimum length Specifies the minimum value for the net length.
You must select the Restrict length check box to make this box 
available. If the net is part of a matched length group or diff pair, 
you must open the Matched Length Net Group, Matched Length 
Pin Pair Group, or Differential Pair properties to change this value.

Maximum length Specifies the maximum value for the net length.
You must select the Restrict length check box to make this box 
available. If the net is part of a matched length group or diff pair, 
you must open the Matched Length Net Group, Matched Length 
Pin Pair Group, or Differential Pair properties to change this value.
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Properties Dialog Box, Net Tab
To access: Select a net > right-click > choose the Properties  popup menu item > Net  tab

View net properties, protect traces and vias, and modify the width of all traces on that net.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Unrouted length Displays the length of the unrouted net.

Routed length Displays the length of the routed net. Includes half the Discrete 
length value of each connected pin of components that have a 
Discrete length assigned.

Total vias Displays the number of vias on this net.

Protect traces and vias; disallow 
editing

Prohibits unrouting or moving a trace.

 Tip
If a net has some traces that are protected and some that are 
not, this check box is unavailable.

Trace width Specifies the width of all traces on a net.
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Properties Dialog Box, No Properties Tab

Field Description

 Restriction:
If the net has protected traces, these trace width properties 
cannot be modified.
 Tip
If a net has traces with different widths, the Trace width box is 
empty.

Properties Dialog Box, No Properties Tab
To access: with the Properties dialog box open, select an object with no properties, or two or more objects 
of different types.

Displays property information messages.

This tab appears with one of the following messages:

No properties available Indicates there are no properties for the selected object; for example, 
an unroute.

Multiple selection Indicates there are multiple object types selected; for example, a 
component and a net.
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Properties Dialog Box, Pad Entry Tab
To access: Select an object > right-click > choose the Properties  popup menu item > Pad Entry  tab

Enable pad entry and exit methods, soften first corner rules, and allow vias in surface mount pads.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Enter pads through  area Select one or more methods where a trace is allowed to enter or 
exit a pad (Side, Corner, Any angle).

Ignore first corner rules to 
complete traces when required

Select to set soft first-corner rules to help complete traces.

Via at SMD placement  area Allow vias on surface mount pad—Select to allow vias at 
Surface Mounted Device (SMD) pads.
Select any of these additional options:

• Fit Inside— Fits vias entirely inside the SMD pad to prevent 
vias from intersecting and breaking the edge of the SMD pads.

• Center— Places vias at the center of the SMD pad.

Exception:  For pins with associated copper, the via is placed 
at the origin of the pin, which may not be the center of the pad.
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Field Description

• Ends— Restricts via placement to the ends of the rectangular 
or oval SMD pads.

Exception:  For pins with associated copper, the via is not 
placed in the SMD.

 Tip
When using square pads, vias are placed at the midpoints 
of the sides of the pad. Round pads are ignored.

Result:  Depending on the option you select, the Preview section 
on the tab updates to show the placement of a via on an SMD pad.

 Tip
To verify the presence of vias at an SMD pad, click the Fanout 
tab. The Preview changes when you enable or disable Vias at 
SMD and change the settings.
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Properties Dialog Box, Pad Stack Tab (Pins)
To access: Select a pin > right-click > choose the Properties  popup menu item > Pad Stack  tab

View information about the pin pad stack, such as the layer, shape, size, length, orientation, offset, hole 
size, whether it is a plated hole, and the corner type and corner radius of rounded/chamfered pads.

Restriction:
This tab is for information only; properties cannot be modified. Use SailWind Layout to modify the 
information displayed in this tab.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Hole size Displays the size of the pad stack hole.

 Restriction:
You cannot edit this field.

Plated hole Indicates if this is a plated hole.

 Restriction:
You cannot edit this field.
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Properties Dialog Box, Pad Stack Tab (Pins)

Field Description

Pad Stack table Displays information about the pad stacks: layers, shape, and size.

 Restriction:
You cannot edit this field.

Preview area Shows what the pads stack looks like in your design.

SailWind Router Guide 507



SailWind Router GUI Reference
Properties Dialog Box, Pad Stack Tab (Vias)  

Properties Dialog Box, Pad Stack Tab (Vias)
To access: Select a via > right-click > choose the Properties  popup menu item > Pad Stack  tab

View information about the Via or Via type, such as the layers the via connects, the pad shapes and 
diameters, and the corner type and corner radius of rounded/chamfered pads.

Restriction:
This tab is for information only; the properties cannot be modified. Use the Pad Stacks Properties 
dialog box in  SailWind Layout to modify the information displayed in this tab.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Parameters table Displays information about the pad stack: layers, shape, and 
diameter.

 Restriction:
You cannot edit this table.

Preview area Shows what the pads stack looks like in your design.
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Properties Dialog Box, Pad Stack Tab (Virtual 
Pins)
To access: Select a virtual pin > right-click > choose the Properties  popup menu item > Pad Stack  tab

View information about the virtual pin or virtual pin type, such as the layers the virtual pin connects, the 
pad shapes and diameters, and the corner type and corner radius of rounded/chamfered pads.

Restriction:
This tab is for information only; you cannot modify the properties. Use the Pad Stacks Properties 
dialog box in  SailWind Layout to modify the information displayed in this tab.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Parameters table Displays information about the pad stack: layers, shape, and 
diameter.
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Field Description

 Restriction:
You cannot edit this table.

Preview area Shows what the pads stack looks like in your design.
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Differential Pair Properties Dialog Box, Pair Tab

Differential Pair Properties Dialog Box, Pair 
Tab
To access: Select a differential pair > right-click > choose the Properties  popup menu item > Pair  tab

Set the gap, trace width, length, and obstacle handling for differential pairs.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and “Setting Object Properties”  on page 169.

Objects

Field Description

Set trace width and gap for the 
pair by layer table

Specifies the width and gap for each layer.
Tips:

• The gap rule overrides any other rule defining a clearance 
between the differential pair members. Therefore, the gap is the 
minimal clearance and must be provided when possible.

• If you select multiple differential pairs, and a layer setting 
does not belong to all of the selected pairs, the Layer box is 
unavailable for that layer. If you enter a new value, it applies to 
the differential pairs that have this layer setting only.

• If you select multiple differential pairs that have the same layer 
setting, but the Width and Gap values do not match, the Width 
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Field Description
and Gap cells will appear empty. You can, however, type a 
new value, and the new value will be applied to all selected 
differential pairs when you click OK  or Apply.

Add  button Adds a row to the table where you can specify the width and gap 
for another layer.

Delete  button Removes the selected row from the table.

 Restriction:
You cannot remove the <All layers> row.

Trace Length Specify the minimum and maximum length allowed for a trace. 
Includes half the Discrete length value of each connected pin of 
components that have a Discrete length assigned.
Restrict layer changes during autorouting — Specifies to force 
the pair to be routed on a single layer. This setting applies to 
autorouting and does not restrict splitting around obstacles when 
routing interactively.

Allow pair to split around 
obstacles

Specifies to temporarily exceed the pair routing gap.

Maximum number of obstacles Specifies the maximum number of obstacles allowed when 
splitting the pair.

 Tip
Obstacles in the start zone or end zone are not counted. This 
is the zone between the connection point and the shoulder of 
the differential pair.
 Restriction:
This box is available only when you select the “Allow pair to 
split around obstacles” check box.

Maximum obstacle size Specifies the maximum size allowed for an obstacle when splitting 
the pair.

 Tip
Obstacle size in the start zone or end zone is not checked. 
This is the zone between the connection point and the shoulder 
of the differential pair.
 Restriction:
This box is available only when you select the “Allow pair to 
split around obstacles” check box.
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Properties Dialog Box, Pin Tab
To access: Select a pin > right-click > choose the Properties  popup menu item > Pin  tab

View and modify pin property information.

Description
You can modify only these options:

• Serve as a test point

• Probe from top side

• Probe name

• Nail number

• Connect to plane with thermal

Restriction:
All other options are for information only.
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Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Location area Displays the properties of the pin: the Component, the Pin number, 
and the Pin type.

Coordinates Displays the X,Y coordinates of the pin.

Allow teardrops Enables the use of teardrop shapes.

Connect to plane with thermal Enables the pin to connect to a plane.

Net Displays the name of the net(s) associated with this pin.

Probe name list If you select the “Serve as a test point” check box, choose one of 
the available test probe names from this dropdown list.
You can define probe names in the Options Dialog Box, Test 
Points Category.

Nail Number Specifies a unique label to the probe.

Serve as a test point Enables to pin to function as a test point.
If you select this check box, also select the probe you want to 
associate with the test point by choosing it from the Probe name 
list.

Probe from top side Specifies to make the test point pin accessible from the top side of 
the board.

 Restriction:
The ability to probe from the PCB top side must be enabled (on 
the Test Points category of the Options dialog box) before you 
can make a test point pin accessible from the top side of the 
board.

Pin pairs Displays the pin pairs associated with this pin.
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Properties Dialog Box, Pin Pair Tab
To access: Select a pin pair > right-click > choose the Properties  popup menu item > Pin Pair  tab

View and modify pin pair property information. You can modify only the Trace width and Protect traces 
options. All other options are for information only.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Unrouted length Displays the length of the unrouted pin pair.

Routed length Displays the length of the routed pin pair. The displayed length 
includes half the Discrete length value of each connected pin of 
components that have a Discrete length assigned.

Protect traces and vias; disallow 
editing

Prohibits unrouting or moving a trace.

 Tip
If a net has some traces that are protected and some that are 
not, this check box is unavailable.

Trace width Specifies the width of all traces on the pin pair.
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Field Description

 Restriction:
If the pin pair has protected traces, these trace width properties 
cannot be modified.
 Tip
If a pin pair has traces with different widths, the Trace width 
box is empty.

Net Displays the net for this pin pair.
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Properties Dialog Box, Routing Tab
To access: Right-click > choose the Properties  popup menu item > Routing  tab

Set the default routing rules, including trace width and autorouting properties. If you select an object, you 
set properties for that object. If you select nothing, you set the routing properties as design defaults.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Trace width area Specifies the trace width value you want: Minimum, 
Recommended, and Maximum boxes.

Maximum number of vias Specifies the number of vias properties.
• Unlimited vias— The autorouter can use as many vias as 

needed to complete traces.

• Maximum of— The autorouter can use up to this number of 
vias to complete traces. Type a value from 0 to 50000.

 Tip
An insufficient maximum number of vias might increase 
autorouting runtime and reduce completion rates. The 
autorouter considers this to be a hard rule. Interactive routing 
and design verification check this property.
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Field Description

Allow autorouting Enables autorouting operations.

Allow trace unrouting Enables you to unroute traces and delete trace corners.

Shove traces to complete 
connection when required

Enables the plower  on page 299 to move traces aside to complete 
another trace.

Shove protected traces when 
required

Enables the plower  on page 299 to move protected traces aside to 
complete another trace.
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Properties Dialog Box, Same Net Tab

Properties Dialog Box, Same Net Tab
To access:

• Select a design object > right-click >choose the Properties  popup menu item > Same net  tab

• With nothing selected > right-click > choose the Properties  popup menu item > Same net  tab

Set values for edge-to-edge clearance to items that are in the same net. If you select an object, you set 
properties for that object. If you select nothing, you set the clearance properties as design defaults.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Object clearance  matrix Type a value in the box for which you want to set the clearance.
Alternative: To set the same value for an entire row or column, 
click on a column heading, row heading, or All. Type a value and 
click OK  to apply the value.
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Field Description

 Restriction:
You are restricted to setting only clearances that apply to the 
type of object you have selected. For example, if you have 
selected a component and are viewing component properties, 
the Via-to-Via or Trace-to-Corner settings do not apply and 
they are unavailable.
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Properties Dialog Box, Test Points Tab

Properties Dialog Box, Test Points Tab
To access: With nothing selected > right-click > choose the Properties  popup menu item > Test Points 
tab

Specify minimum spacing clearances and set the maximum length of trace stubs created to gain access 
to a net on the entire design.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Object clearance matrix Type a value in the box for the objects for which you want to set a 
clearance.
Alternative: To set the same value for an entire row or column, 
click on a column heading, row heading, or All. Type a value and 
click OK  to apply the value.

Maximum length of trace stubs Type the maximum length value in current design units.
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Properties Dialog Box, Test Points Tab (Nets)
To access: Select a net > right-click > choose the Properties  popup menu item > Test Points  tab

Set the minimum number of test points on a selected net.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Number of probes Type a value (0 through 10)
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Properties Dialog Box, Test Points Tab (Component or Via Type)

Properties Dialog Box, Test Points Tab 
(Component or Via Type)
To access:

• Select a component or via type (must be selected using the Project Explorer) > right-click > 
choose the Properties  tab > Test Points  tab

Use the Test Points  tab to prevent or favor assigning test points to components or to via types. By 
default, SailWind Router makes all pins on a net available for test pin assignment and weighs them 
evenly as test point candidates.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Do not use as a test point 
(Exclude)

Select to prevent use as a test point.

 Tip
To apply even weighting, clear both check boxes.

Try to use as a test point (Prefer) Select to favor use as a test point.

 Tip
To apply even weighting, clear both check boxes.
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Properties Dialog Box, Topology Tab
To access:

• With nothing selected > right-click > choose the Properties  popup menu item > Topology  tab

• Select a net or net class > right-click > choose the Properties  popup menu item > Topology  tab

You can set different topology types for nets, which affects how they are routed whether you are routing 
interactively, autorouting, or editing traces. Topology types determine the order in which to connect pins in 
a net. Assign the default and net specific topology type and set the permissions for allowing junctions on 
nets while controlling the stub length.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Net topology type area Protected  — Do not change the order of the connectivity in this 
net.
Minimized  — Order the net by the shortest distance between pins. 
Net reorder or reconnect is permitted.
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Properties Dialog Box, Topology Tab

Field Description

Serial  — Order the net in a series order from source pins to load 
pins to a terminator.
Parallel  — Same as “Serial” and “Serial Source” except order the 
net with parallel branches for each source-to-load connection.
Mid-driven  — Divide the net into two branches and order each 
branch in a source to load to terminator order.

Allow junctions on area Control junctions on Vias and Traces. In 
SailWind Layout, this is known as Copper 

Sharing.
Maximum stub length  — Type the maximum length of the trace 
that enters another to create a t-junction. Type zero to prevent 
t-junctions. This setting is not available if the topology type is set to 
minimized.

SailWind Router Guide 525



SailWind Router GUI Reference
Properties Dialog Box, Trace Tab  

Properties Dialog Box, Trace Tab
To access: Select a trace > right-click > choose the Properties  popup menu item > Trace  tab

View and modify the width of the trace and the layer on which it is located, and protect the trace.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Located on layer list Specifies the layer on which the trace is located.
You can move the selected trace to another layer by choosing the 
layer from the dropdown list.
Selecting the “Protect” check box disables the dropdown list.

Protect; disallow editing Prevent unrouting or moving the trace, either manually or through 
autorouting.

Coordinates Displays the location of the trace.

Dimensions Specifies the width and displays the length of the trace. Length 
does not include any Discrete length.

Pin pairs Displays the pin pairs associated with this trace.
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Properties Dialog Box, Trace Tab

Field Description

Net Displays the net associated with this trace.
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Properties Dialog Box, Trace Segment Tab
To access: Select a trace segment > right-click > choose the Properties  popup menu item > Segment 
tab

Set the layer, coordinates, and dimensions of the trace segment.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Located on layer list Specifies the layer on which the trace segment is located.
You can change layers by selecting another from the dropdown list 
and clicking OK. The segment moves to the new layer.

Protect; disallow editing Prevents unrouting or moving the trace segment.

Coordinates Displays the location of the trace segment: X1, Y1, X2, Y2, Arc 
center X, Arc center Y, Arc radius. You can edit these values by 
typing directly in the boxes. SailWind Router applies the change 
when you click OK.

 Restriction:
If the segment ends on a pin, the corresponding X and Y 
coordinates are unavailable.
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Properties Dialog Box, Trace Segment Tab

Field Description

 Tip
Change an arc to a straight line by typing 0 in the Arc radius 
box. Change a straight line to an arc by typing a non-zero 
value in the Arc radius box.

Dimensions Specifies the width and displays the length of the trace.
You can edit the width by typing directly in the box. SailWind 
Router applies the change when you click OK.

Net Displays the net name associated with this trace.
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Properties Dialog Box, Via Tab
To access: Select a via > right-click > choose the Properties  popup menu item > Via  tab

View and modify via property information.

Restriction:
You cannot change the size of vias or add additional vias in SailWind Router. Use the Pad Stacks 
Properties dialog box  in SailWind Layout to do this.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Coordinates Specifies the location of the via: X, Y.
You can edit the location by typing directly in the boxes. SailWind 
Router applies the changes when you click OK.
SailWind Router disables these boxes when you select the 
“Protect; disallow editing” check box.

Type lists Specifies the type of this via.
You can choose another via type by selecting from the dropdown 
list.
SailWind Router disables this dropdown list when you select the 
“Protect; disallow editing” check box.

 Tip
Only the via types that can be applied without causing 
connectivity errors or via biasing violations appear in the list.

Protect; disallow editing Prohibits unrouting or moving the via.
Selecting this check box disables all other controls on the tab 
except for the Stitching check box.

Connect to plane with thermal Enables the via to connect to the copper plane.

Stitching Enables the via to function as a stitching via (that is, a via in an 
unroute).

Net Displays the net associated with this via.

Probe name list Specifies the name of the probe. You can choose a probe from the 
dropdown list.
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Properties Dialog Box, Via Tab

Field Description

The dropdown list becomes available when you select the “Serve 
as a test point” check box.

Nail number Specifies a unique label to the probe. Type a label directly in the 
box.

Serve as a test point Enables the via to serve as a test point when you select the check 
box.

Probe from top side Makes the test point via accessible from the top side of the board.
Select the “Serve as a test point” check box to enable this check 
box.
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Properties Dialog Box, Via Biasing Tab
To access:

• Click the Properties  button > Via Biasing  tab

• Right-click > choose the Properties  popup menu item > Via Biasing  tab

Restrict the via types that SailWind Router uses during routing. If you select a net object, you specify 
the available vias for that object only. If you select nothing, you set the via biasing properties as design 
defaults.

Restriction:
You cannot change the size of vias or add additional vias in SailWind Router. Use the Pad Stacks 
Properties dialog box  in SailWind Layout to do this.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.
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Properties Dialog Box, Via Biasing Tab

Objects

Field Description

Via table Lists the properties of each available via, including the name, type of 
via (for example, a through-hole or partial via type), and layers through 
which the via extends.
Selecting the check box in the Allow column enables the via for routing.
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Properties Dialog Box, Virtual Pin Tab
To access: Select a virtual pin > right-click > choose the Properties  popup menu item > Virtual Pin tab

View and modify virtual pin properties.

Note:
Use the Properties dialog box for setting design and object properties. For more information, see 
Setting Design Properties  on page 154 and Setting Object Properties.

Objects

Field Description

Coordinates Specifies the location of the virtual pin: X, Y.
You can edit the values by typing directly in the boxes. The virtual 
pin changes location when you click OK.

Type list Specifies the type of this virtual pin.

 Tip
Only the virtual pin types that can be applied without causing 
connectivity errors or via biasing violations are listed.

Protect; disallow editing Prevents or prohibits moving the virtual pin.
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Properties Dialog Box, Virtual Pin Tab

Field Description

Selecting this check box disables the other controls on the tab.

Net Displays the name of the net associated with this virtual pin.

Probe name list Specifies the name of the probe.
You can choose any available probe name from the dropdown list. 
This dropdown list is available only if you select the “Serve as a 
test point” check box.

Nail number Specifies a unique label for the probe. You can edit the label by 
typing directly in the box.
This box is available only if you select the “Serve as a test point” 
check box.

Serve as a test point Enables the virtual pin to function as a test point.

Probe from top side Enables access to the test point virtual pin from the top side of the 
board.
This field is available only if you select the “Serve as a test point” 
check box.

Pin pairs Displays the pin pairs to which the virtual pin belongs.
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Selection Layers Dialog Box
To access: Click the Selection Filter toolbar  button > Layers  button

Use the Selection Layers dialog box to enable or disable the ability to select objects on certain layers.

Objects

Field Description

All electrical layers Enables object selection on all electrical layers. Clear the check box to 
disable object selection on all electrical layers.

 Note:
This check box does not affect non-electrical layers such as the 
silkscreen layer.

Layer list Lists all of the layers in the design. Select the check box to enable 
object selection on the corresponding layer.

Anything button Enables object selection on all layers.

Nothing button Disables object selection on all layers.
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Shortcut Dialog Box

Shortcut Dialog Box
To access:

• Click the Shortcut Dialog  button on the standard toolbar

• Start typing the shortcut sequence (Note that if you open the Shortcut dialog box by typing a 
shortcut, you cannot delete the initial character in the text box).

The Shortcut dialog box displays the shortcut key sequence as you type, allowing you to check its 
accuracy before starting the shortcut. Shortcut information and syntax, if available, display below the text 
box. Parentheses enclose optional arguments. Similar shortcuts display in the Available commands and 
macros box.

Objects

Field Description

Shortcut text box Displays the shortcut you type.

More/Less button Displays or hides the Available commands and macros list.

Available commands and 
macros list

Displays the available commands or macros. The list updates based 
on what you type.
Tips:

• To re-sort the contents click a column header.

• Use the wildcard character * to substitute for any number of 
characters, and use the wildcard character ? to substitute for one 
character. For example, to highlight all nets whose names start with 
the letter A, type H A*.

Execute button Runs the selected command or macro.
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View Nets Dialog Box
To access: Choose the View > Nets  menu item

The View Nets dialog box lets you select and view nets. For each net, you can hide or show connections, 
routed paths, or unrouted paths. You can also specify color and show or hide various unroutes, making 
it easier to identify nets when you split planes. When you save the design, you also save any net color 
assignments you make.

Objects

Field Description

Net List Displays the Nets and Net Classes available. This list functions 
similarly to the Object View  tab in the Project Explorer; however, it 
displays nets and net classes only.

 Tip
Use Ctrl or Shift and click to select multiple nets.

Add/Remove  buttons Add moves selected net names into the View List box where you can 
highlight net names and set view details for them. Press the Ctrl key for 
multiple selections. Click Remove  to move the net from the View List 
to the Net List.

View Details area
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View Nets Dialog Box

Field Description

Colors of Pads, Vias, 
Unroutes

Displays the assigned color. Click to apply the color selected in the 
Palette. Click again to return the color to its default.

 Note:
Select the “Enable Color by Net” check box to enable this feature.

Highlight Specifies that the net always appears in the highlight pattern that you 
set in the General category of the Options dialog box.

Traces When you clear the Traces check box for a net, traces and unroutes 
associated with the net do not appear, and the unroute group becomes 
unavailable.

Unroutes Enables filtering of the unrouted connections.
• All

• All Except Connected to Plane

• Unrouted Pin Pairs
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Field Description

• None

Enable Color by Net Allows assignment of colors to pads, vias, unroutes, and coppers. You 
can also use the modeless command Y to toggle this setting—see the 
Status bar for confirmation. Selecting this check box also allows you to 
optionally select the “Include net colors on traces” check box to apply 
color assignments to traces.
Clearing this check box returns colors to their default assignments (as 
assigned in the Options Dialog Box, Colors Category).

 Note:
Re-selecting this check box restores any previously defined net 
color assignments.

Include net colors on traces Shows traces using the assigned color.
Selecting the “Enable Color by Net” check box enables this check box.
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Chapter 25
Software Launch Options

You can use software launch options, known as command line switches, to control the initial configuration. 
These switches can open a file, start macros, and record a session. You can use multiple command line 
options.

You add command line switches to the Start menu shortcut or a Desktop shortcut.

Table  90. Start-up Options

Option Description

full path to a file Opens the specified design file when you start the program. Type the full 
folder path and filename. Use double quotation marks for folders or file 
names with spaces. For example:

“C:\SailWind Projects\Samples\preview.pcb”

/BMW[=xx] Opens the Basic Media Wizard. Use the Basic Media Wizard to start 
recording a session log or to convert the previous session log to media that 
can be replayed by Basic Log Test. To create session media files for the 
current session, use the BMW Table 30  on page 104.
To use the BMW command line switch, type /BMW or /BMW=xx, where 
you replace xx with your initials.

/RUN=macro_name Runs the specified macro when you launch the software. Make sure to 
type a space between “SailWindRouter.exe” and the “-run” command. For 
example, to run the macro “mymacro”, type /RUN=mymacro. Instead of 
using the / character before the run command, you can use a hyphen, as 
in -run=mymacro. When paths or filenames have spaces, you must place 
double quotes around the full path. For example:

/run=“C:\SailWind Projects\Samples\mymacro.mcr”

Adding Start-up Options to a Shortcut
Editing BGA Fanout Controls With the SailWindRouter.ini File
Checking for SailWind Updates

Adding Start-up Options to a Shortcut
You can add various start-up options to a shortcut. Doing so allows you to start SailWind Router with 
certain designs already loaded, such as when you click a shortcut.

Tip
If you create your own shortcuts, copy the Start menu shortcuts instead of generating ones from 
the executables in the install directory. Start menu shortcuts contain a “wrapper” that allows the 
proper environment variables to be defined as the program launches.
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Procedure
1. In the shortcut properties, click in the box with the pathname.

2. Press End, press Spacebar, and then type the command line switch you want to use. Enclose with 
double quotes " " each string that contains a space. When specifying a file to start, do not use a / 
before the filename. You can specify multiple command line switches. For example, to start the 
program with preview.pcb, the command line might read:

“\<install_folder>\<version>\Programs\SailWindRouter.exe” “C:\SailWind 
 Projects\Samples\preview.pcb”

Related Topics
Creating Macros

Editing BGA Fanout Controls With the 
SailWindRouter.ini File
In some PCB designs, you may have one or more BGA devices that do not conform to standard BGA 
definitions in SailWind Router and therefore require additional controls for a successful fanout. You can 
define additional BGA controls in the SailWindRouter.ini  file to ensure SailWind Router creates a fanout 
for a device correctly.

BGA Commands in the SailWindRouter.ini File
You can designate a component as a BGA device through its decal name. SailWind Router automatically 
checks the name of each decal in the design. If SailWind Router finds any decal with the letters “BGA” (in 
order), it considers the component to be a BGA device.

Aside from decal names, you can add BGA control parameters to the SailWindRouter.ini  file. This file 
resides by default in the <install>/Settings  folder. Aside from decal names, you can add the following 
additional commands to the file using “[Fanout]” as the section header.

Table  91. BGA Control Parameters

Section Type Value 
Ranges Parameter Default 

Value Description

fanout Int 1-10 miminumfullnessgridrow 2 Number of minimum rows 
required for a component to 
be considered a BGA device.

fanout Int 1-10 minimumfullnessgridcol 2 Number of minimum columns 
required for a component to 
be considered a BGA device.

fanout String 1-99 maximumgridratio 40 Maximum ratio between rows 
and columns (number of 
rows divided by columns) 
required for SailWind Router 
to discard a component as a 
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Editing BGA Fanout Controls With the SailWindRouter.ini File

Table  91. BGA Control Parameters  (continued)

Section Type Value 
Ranges Parameter Default 

Value Description

BGA device. Anything less 
than this ratio is not a BGA.

fanout String 1-99 odbminimumgridfullness 25 The percentage of fullness 
(with pins) required for a grid 
to be considered as a BGA 
device grid.

Example
The following example illustrates the additional BGA control parameters with the required section header 
in the SailWindRouter.ini  file.

[Fanout]
minimumfullnessgridrow=2
minimumfullnessgridcol=2
maximumgridratio=40
odbminimumgridfullness=25
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Checking for SailWind Updates
The SailWind products automatically check for a new software version when you launch an application. If 
a SailWind product detects a new version, it displays a tooltip in the system tray.

Downloading the Update
Disabling the Check for Updates
Checking for Updates Manually

Downloading the Update
You can download an update if SailWind detects a new version is available.

Prerequisites
An Internet connection is required for the check.

Procedure
1. Right-click the icon in the system tray.

2. Click the Open download page  popup menu item.

3. Follow the instructions on the download page.

Disabling the Check for Updates
If you do not want to automatically check to see if a new version available, you can disable the Check for 
Updates feature. You can enable the check in the future, or you can manually check for updates at any 
time.

Procedure
1. Choose the Help > Check for Updates  menu item.

2. In the “Check for Updates dialog box”  on page 394, select the “Disable ‘Check for Updates’ 
functionality” check box.

Checking for Updates Manually
You can check for updates manually if you disable the automatic check.
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Checking for Updates Manually

Procedure
1. Choose the Help > Check for Updates  menu item.

2. In the “Check for Updates dialog box”  on page 394, click Check for Updates.
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Chapter 26
Customizing the Interface

You can customize the SailWind Router interface to suit your work style and needs. You can specify 
which toolbars to display, add items to toolbars and menus, and create custom toolbars, menus and 
shortcut keys.

You make customizations using the Customize dialog box. You can invoke the dialog box in two ways:

• From the SailWind interface, choose the Tools > Customize  menu item. All customizations you 
make apply to the main view of the SailWind tool.

• In a window of the interface (for example, the Output Window), right-click and select Customize. 
Your customizations apply only to that window.

Your customizations save with your current workspace so that all of the changes you make to toolbars, 
menus, and shortcut keys are present when you work in that workspace again.

Migrating User Settings
Customizing Toolbars and Shortcut Menus
Creating Custom Commands and Menus
Customizing Shortcut Keys
Creating Commands from Macro Command Files
Adding a Macro to a Menu
Customizing the Appearance of the Screen
Organizing Windows
Crash Detection

Migrating User Settings
You can use the User Settings Migration tool to extract your settings from one installation of SailWind 
Logic, Layout, and Router and import them into another installation or version.

For information on how to do this, see User Settings Migration in the User Settings Migration Guide.
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Customizing Toolbars and Shortcut Menus
Choose the Toolbars and Menus  tab on the Customize dialog box (Tools > Customize  menu item, 
Toolbars and Menus  tab) to create custom toolbars and shortcut menus.

Tip
To create a custom main menu, use the Commands  tab on the Customize dialog box. See 
“Creating a Custom Menu”.

Creating a Custom Toolbar
Editing a Custom Toolbar
Resetting Toolbars to Defaults
Customizing a Shortcut Menu
Resetting a Shortcut Menu

Creating a Custom Toolbar
Create a custom toolbar by creating a new empty toolbar and adding items (commands) to it.

Procedure
1. Choose the Tools > Customize  menu item, and click the Tools and Menus  tab.

2. In the Toolbars box, click the New  button.

3. Type the name for the toolbar and click OK.

The new, empty toolbar displays on the SailWind interface.

4. Drag the toolbar to the place on the SailWind interface where you want it.

5. To add items (commands) to your new toolbar, click the Commands  tab and proceed as follows: 

a. In the Categories list, select a menu or toolbar name to display commands specific to that 
menu or toolbar. Alternatively, select “All Commands.”

Restriction:
If you are working in a special mode in SailWind Layout or SailWind Logic (for 
example, the Decal Editor in SailWind Layout), some categories of commands are not 
available for customization.

b. In the Commands list, select the command you want and drag it to the toolbar.

c. When you have finished adding commands, click Close.

Related Topics
Removing Items from Toolbars and Menus
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Editing a Custom Toolbar
Make edits to your custom toolbars as necessary using the Customize dialog box.

Procedure
1. Choose the Tools > Customize  menu item.

2. In the Options dialog box, click the Toolbars and Menus  tab.

3. Perform one of the following:

Desired Outcome Steps

Showing or hiding a toolbar 1. In the Toolbars list, select the toolbar.

2. To display the toolbar in the interface, select the check box 
to the left of its name. To hide the toolbar, clear the check 
box.

Deleting a custom toolbar 1. In the Toolbars list, select the custom toolbar.

2. Click the Delete  button.

Renaming a custom toolbar 1. In the Toolbars list, select the toolbar and click the Edit 
button.

2. In the Toolbar Name dialog box, type the new name and 
click OK.

Note:
You cannot edit or delete standard toolbars and menus.

Resetting Toolbars to Defaults
You can reset one or all system toolbars to their default buttons.

Procedure
1. Choose the Tools > Customize  menu item and click the Toolbars and Menus  tab.

2. In the Toolbars list, select the toolbar.

3. Click Reset.

Tip
To reset all system toolbars to defaults, click Reset All.
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Customizing a Shortcut Menu
You can customize an existing shortcut menu by adding, deleting, or rearranging its menu items. You can 
also reset a shortcut menu to its default state.

Note:
You cannot create a new shortcut menu.

Procedure
1. Click the Tools > Customize  menu item; then, in the Customize dialog box, click the Toolbars and 

Menus  tab.

2. In the Shortcut Menus area, select the shortcut menu you want to modify. The shortcut menu 
(called Popup Menu) appears.

3. You can now add, delete or rearrange its menu items (commands).

• To add an item:

i. Click the Commands  tab of the Customize dialog box.

ii. In the Categories area, select a menu or toolbar name to display commands specific to that 
menu or toolbar. Or click All Commands.

iii. Drag the command to the shortcut menu.

• To delete an item: Select the item and drag it outside the shortcut menu.

• To rearrange items: Select an item and drag it to a new location on the menu.

4. When you have finished customizing the menu, close it (click X) or click Close.

Tip
If a command’s operation does not match the context of the shortcut menu, the Customize 
operation lets you add the command to the menu, but the menu does not display the 
command (menu item). For example, in SailWind Router, the “Smooth in router” command 
is a verb mode command. If you add the “Smooth in router” command to the Interactive 
Routing shortcut menu, the command does not appear on the menu.

Resetting a Shortcut Menu
If you customize shortcut menus and want to change them back to their original menu items, you can 
reset one or all of them to default settings.
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Resetting a Shortcut Menu

Procedure
1. Choose the Tools > Customize  menu item and click the Toolbars and Menus  tab.

2. In the Shortcut menus list, select the shortcut menu you want to reset.

3. In the Shortcut menus area, click Reset.

Tip
To reset all shortcut menus to their default settings, in the Shortcut menus box, click Reset 
All.

Related Topics
Customizing a Shortcut Menu
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Creating Custom Commands and Menus
The Commands  tab provides you the option of customizing commands or menus.

Creating and Editing a Custom Command
Deleting a Custom Command
Creating a Custom Menu
Adding Items to Toolbars and Menus
Moving Items on Toolbars and Menus
Removing Items from Toolbars and Menus

Creating and Editing a Custom Command
You can create custom commands from either commands that already exist or a macro command file.

• To use a command that already exists as a menu item or toolbar button, you select an existing 
command on which to base your new command. Then you define the properties of your new 
command.

• To use a macro command file, see Creating Commands from Macro Command Files.

Procedure
1. Choose the Tools > Customize  menu item and click the Commands  tab.

2. In the Categories list, click a menu or toolbar name to display items (commands) specific to that 
menu or toolbar, or select “All Commands” from the list.

Tip
If you made macro commands (on the Macro Files  tab) available as commands, the 
Categories list includes the Macro category and the Commands list includes the macros. 
For more information, see “Creating Commands from Macro Command Files”  on 
page 563.

3. In the Commands list, select the command on which you want to base your custom command. 
Then click the New  button. If you want to edit an existing custom command, select the command 
and click Edit.

4. In the Add Command dialog box (or Edit Command dialog box, if you are editing a custom 
command), specify or change the properties of your custom command:

a. In the Command name box, type the name of the command.

b. If the new command takes arguments, type the arguments in the Arguments box. Use a space 
to separate each one. If an argument contains a space, enclose the argument in quotation 
marks (“ ”).

c. In the Description box, type a description of the custom command.
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Deleting a Custom Command

d. If an image is associated with the original command, select “Use Default Image” to use that 
same image with your custom command. Alternatively, select “Select User-Defined Image” to 
use a different image, edit an image, or create a new image.

e. Click OK  to close the Add Command dialog box (or Edit Command dialog box) and return to 
the Customize dialog box.

5. When you finish with all customizations, click Close.

Tip
To add the command to a toolbar or menu, click the command and drag it from the 
Commands list to the toolbar or menu.

Deleting a Custom Command
You can remove any custom command you create.

Restrictions and Limitations
You can delete only custom commands (the commands you create). You cannot delete system 
commands.

Procedure
1. Choose the Tools > Customize  menu item and click the Commands  tab.

2. In the Categories list, click a menu or toolbar name to display items (commands) specific to that 
menu or toolbar, or select “All Commands.”

3. In the Commands list, select a custom command and click the Delete  button.

4. Click Close.

Related Topics
Adding Items to Toolbars and Menus

Creating Commands from Macro Command Files

Resetting Toolbars to Defaults

Creating a Custom Menu
Create a new empty menu and then add items (commands) to it to create a custom menu.

Procedure
1. Click the Tools > Customize  menu item; then, in the Customize dialog box, click the Commands 

tab.

2. In the Categories list, select “New Menu.”

3. In the Commands list, select New Menu and drag it to the location you want as follows:
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• To create a top-level menu, drag the new menu to the Menu Bar.

• To create a submenu, drag it over an existing menu name.

4. Click your new menu to select it. Then right-click and select Button Appearance.

5. In the “Button text” field, type the name for the menu and click OK.

Leave the Customize dialog box open on the Commands  tab.

6. In the Categories list, select a menu or toolbar name to display commands specific to that menu or 
toolbar, or select “All Commands.”

Restriction:
If you are working in a special mode in SailWind Layout or SailWind Logic (for example, 
the Decal Editor in SailWind Layout), some categories of commands are not available for 
customization.

7. In the Commands list, select the command you want and drag it to the menu.

8. When you have finished adding commands, click Close.

Adding Items to Toolbars and Menus
Add buttons to your custom toolbars and menus to populate them with commands and custom 
commands.

Procedure
1. Choose the Tools > Customize  menu item and click the Commands  tab.

2. In the Categories list, select a toolbar or menu name to display commands specific to that menu or 
toolbar, or select “All Commands.”

Restriction:
If you are working in a special mode in SailWind Layout or SailWind Logic (for example, 
the Decal Editor in SailWind Layout), some categories of commands are not available for 
customization.

3. In the Commands list, select the command you want and drag it to the toolbar or menu.

Tip
To remove an item from a toolbar or menu (while the Customize dialog box is open), click 
the item and drag it outside the toolbar or menu.

4. When you have finished adding commands, click Close.
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Adding Items to Toolbars and Menus

Related Topics
Creating and Editing a Custom Command

Creating Commands from Macro Command Files

Removing Items from Toolbars and Menus

Moving Items on Toolbars and Menus
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Moving Items on Toolbars and Menus
You can rearrange items on a menu or buttons on a toolbar. You can also move or copy an item from one 
menu or toolbar to another.

Moving Buttons on Toolbars
Moving Items on Menus

Moving Buttons on Toolbars
The method you use for moving toolbar buttons depends on whether the Customize dialog box is open.

Procedure
If the Customize dialog box is closed, press and hold the Alt key; then drag the toolbar button to a new 
place on the same toolbar or to a different toolbar. If the Customize dialog box is open, click the toolbar 
button and drag it to a new place on the same toolbar or to a different toolbar.

Tip
Instead of moving a button, you can copy it and move the copy. Press and hold the Ctrl and Alt 
keys while dragging the button.

Moving Items on Menus
You can rearrange the items on your custom menus.

Restrictions and Limitations
To move menu items, the Customize dialog box must be open.

Procedure
1. Choose the Tools > Customize  menu item.

2. In the main window of the SailWind tool, display the menu containing the item you want to move.

3. Click the menu item and drag it to its new location on the same menu or to a different menu.

Tip
Instead of moving a menu item, you can copy it and move the copy. Press and hold the Ctrl 
key while dragging the item.

4. Click Close.
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Removing Items from Toolbars and Menus

Related Topics
Creating Custom Commands and Menus

Adding Items to Toolbars and Menus

Resetting Toolbars to Defaults

Removing Items from Toolbars and Menus
You can customize the interface by removing a menu item or toolbar button. The method to use depends 
on whether the Customize dialog box is open.

Procedure
If the Customize dialog box is open, drag the item outside the toolbar or menu. Then close the Customize 
dialog box. If the Customize dialog box is closed, you can still remove toolbar items by pressing and 
holding the Alt key then dragging the item outside the toolbar.

Tip
You can reset a toolbar or shortcut menu back to its default list of items. See “Resetting Toolbars 
to Defaults”  on page 549.

Related Topics
Adding Items to Toolbars and Menus
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Customizing Shortcut Keys
You can create and customize shortcut keys by using the Keyboard and Mouse  tab of the Customize 
dialog box (Tools > Customize  menu item > Keyboard and Mouse  tab).

Creating a New Shortcut Key
Rules and Restrictions for Key Sequences
Listing Available Shortcut Keys
Expressions in Shortcut Keys
Deleting a Shortcut Key
Resetting Default Shortcut Keys
Assigning Shortcut Keys to Macros

Creating a New Shortcut Key
You create shortcuts that apply in any mode. Thus, the same shortcut key may have different functionality, 
depending on the mode in which you are working.

Procedure
1. Choose the Tools > Customize  menu item and click the Keyboard and Mouse  tab.

2. In the Mode box, select the mode to which you want to apply the shortcut. The available 
commands for that mode appear in the Commands box.

3. In the Commands box, select the command for which you want to create a new shortcut. If a 
shortcut already exists, it appears in the Current shortcuts box.

Tip
To replace an existing shortcut, select the existing shortcut and click Delete  to remove it; 
then create a new shortcut for the command.

4. Above the Current shortcuts box, click the New  button to open the “Assign shortcut” dialog box.

5. Select one of the following types of shortcut:

558 SailWind Router Guide



 
Customizing the Interface

Rules and Restrictions for Key Sequences

• To assign shortcut keys, select the “Press new shortcut key(s)” option, and then press the keys 
that you want to use. For detailed information about rules and restrictions for creating shortcut 
keys, see “Rules and Restrictions for Key Sequences”  on page 559.

Tip
As you enter the new shortcut, similar shortcuts appear in the Similar shortcuts assigned 
to other commands box. This helps you to avoid creating a new shortcut that conflicts 
with an existing shortcut.

• To create a mouse action, select the “or select a pointer event” option, and then select a 
combination of list box options, mouse button events, and modifier keys.

6. Click OK  to close the “Assign shortcut” dialog box.

Results
The new shortcut appears in the Current shortcuts box on the Customize dialog box.

Rules and Restrictions for Key Sequences
The first character of a shortcut key must meet certain requirements.

The first character of a shortcut key may consist of any item in the following list, plus Alt, Ctrl, or Shift 
modifiers:

• All printable characters including Space and Tab

• All function keys

• Extended keys: Up, Down, Left, Right, Insert, Delete, Home, PageUp, PageDown, End

• Numerical keypad keys (when Num Lock is off): Up, Down, Left, Right, Insert, Home, PageUp, 
PageDown, Del, End, /, *, +, -

• Mouse pointer events: Click, Double-click, RotateForward, RotateBackward

Restriction:
Mouse pointer events cannot be combined with key sequences, although the Ctrl, Alt, and 
Shift modifiers are allowed.

Subsequent characters may consist of the following:

• Alphanumeric (a-z0-9)

Tip
Exception: Some combinations, like Alt+Tab, are intercepted by Windows and thus are not 
available.
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Related Topics
Creating Custom Commands and Menus

Resetting Default Shortcut Keys

Listing Available Shortcut Keys

Listing Available Shortcut Keys
You can create a table of commands and the shortcuts assigned to them in an HTML file, letting you 
share the information over the Web with other members of the design team.

Procedure
1. Choose the Tools > Customize  menu item and click the Keyboard and Mouse  tab.

2. Click Report  and then select or type the HTML filename, then click Save.

3. In the Customize dialog box, click Close.

Results
A hyperlink to the file appears in the Output window, under the Status  tab.

Related Topics
Creating Custom Commands and Menus

Creating a New Shortcut Key

Resetting Default Shortcut Keys

Expressions in Shortcut Keys
You can substitute a regular expression for characters in shortcut key command arguments.

The following table describes the use of expressions.

Table  92. Expressions in Shortcut Keys

Expression Use to

* Match any number of characters.

? Match any one character.

[set] Match any character in the specified set.

 Tip
A set is composed of characters or ranges.

A range has the form: Character Hyphen Character, such as A-Z or 
0-9.
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Deleting a Shortcut Key

Table  92. Expressions in Shortcut Keys  (continued)

Expression Use to

The minimum set of characters supported in a set consists of 
[0-9a-zA-Z_].

[!set] or [^set] Match any character not in the specified set.

\ To suppress the special syntactic significance of the characters ` [ ] 
* ? ! ^ - \ ' within a set, and to match the character exactly.

The following table shows examples of regular expressions used in command arguments using the 
preview.pcb design, see Table 93.

Table  93. Shortcut Key Expression Examples

Shortcut key Result

H A* Highlights all nets starting with A, such as A00, A01, A02.

H +?? Highlights all nets starting with +, having two digits or characters after 0, such as 
+5V.

H A?0 Highlights all nets starting with A, ending with 0, and with any character in 
between, such as A00 and A10.

H [C-D]* Highlights all nets starting with C or D, such as CLKIN, D00.

H [!C-D]* Highlights all nets not starting with C or D, such as A00, GND.

Deleting a Shortcut Key
Delete shortcuts you no longer want to use, or delete an existing shortcut as the first step to changing it.

Procedure
1. Choose the Tools > Customize  menu item and click the Keyboard and Mouse  tab.

2. In the Mode box, select the mode for the shortcut you want to delete. The available commands for 
that mode appear in the Commands box.

3. In the Commands list, select the command whose shortcut you want to delete.

4. In the Current shortcuts list, select the shortcut you want to delete.

5. Click the Delete  button.

6. Click Close.

Related Topics
Creating a New Shortcut Key

Resetting Default Shortcut Keys
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Resetting Default Shortcut Keys
You can restore all shortcut keys to their default settings.

Procedure
1. Choose the Tools > Customize  menu item and click the Keyboard and Mouse  tab.

2. Click Reset All.

3. On the confirmation dialog box, click Yes.

Assigning Shortcut Keys to Macros
You can create a shortcut key that executes a macro.

Tip
In order to assign a macro to a shortcut key, the macro command file (.mcr) must already exist. 
You can create a macro by recording it in a SailWind tool or scripting it in Macro language. For 
more information, see “Creating Macros”  on page 60.

Procedure
1. Choose the Tools > Customize  menu item and click the Macro Files  tab.

2. In the Macro Command Files area, click the New  button.

3. In the Open macro file dialog box, select the macro file you want. Then click Open. SailWind 
Router loads the macro and makes it available for use as a command (and also selects the check 
box to the left of the macro name).

Tip
To close the macro file or make it unavailable in the Customize dialog box, clear the check 
box next to the macro name.

4. To assign the macro to a shortcut key, click the Keyboard and Mouse  tab.

5. In the Mode list, select “All modes.”

6. In the Commands area, double-click “Macros” to display a list of available macros. Then select the 
macro you want.

7. In the Current Shortcuts area, click the New  button. The software displays the “Assign shortcut” 
dialog box.

8. Select one of the following types of shortcut:
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Creating Commands from Macro Command Files

• To assign shortcut keys, select the “Press new shortcut key(s)” option, and then press the keys 
that you want to use. For detailed information about rules and restrictions for creating shortcut 
keys, see “Rules and Restrictions for Key Sequences”  on page 559.

Tip
As you enter the new shortcut, similar shortcuts appear in the Similar shortcuts assigned 
to other commands box. This helps you to avoid creating a new shortcut that conflicts 
with an existing shortcut.

• To create a mouse action, select the “or select a pointer event” option, and then select a 
combination of list box options, mouse button events, and modifier keys.

9. Click OK  to close the Assign shortcut dialog box.

Results
The new shortcut appears in the Current shortcuts box on the Customize dialog box.

Creating Commands from Macro Command 
Files
You can add custom commands created from macro files to toolbars and menus.

Tip
To create a command from a macro command file, the macro command file (.mcr) must already 
exist. You can create a macro by recording it in a SailWind tool or scripting it in Macro language. 
For more information, see “Creating Macros”  on page 60.

Procedure
1. Choose the Tools > Customize  menu item and click the Macro Files  tab.

2. Click the New  button.

3. In the Open macro file dialog box, select the macro file you want to use as a command then click 
Open. The software loads the macro and makes it available for use as a command (and also 
selects the check box to the left of the macro name).

Tip
To close the macro file, or make it unavailable in the Customize dialog box, clear the check 
box next to the macro name.

You can use the macro as you would any other command, for example, to create a Commands list 
for the Macros category.)
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Related Topics
Adding Items to Toolbars and Menus

Adding a Macro to a Menu

Adding a Macro to a Menu
Create a macro then add the macro command as an item on a menu or a button on a toolbar.

Tip
To add macro to a menu, the macro command file (.mcr) must already exist. You can create a 
macro by recording it in a SailWind tool or scripting it in Macro language. For more information, 
see “Creating Macros”  on page 60.

Procedure
1. Choose the Tools > Customize  menu item and click the Macro Files  tab.

2. In the Macro Command Files area, click the New  button.

3. In the Open macro file dialog box, select the macro file you want to use as a command. Then 
click Open. The software loads the macro and makes it available for use as a command (and also 
selects the check box to the left of the macro name).

Tip
To close the macro file or make it unavailable in the Customize dialog box, clear the check 
box next to the macro name.

4. To add the macro to the menu, click the Commands  tab.

5. From the Categories list, select “Macros.”

6. In the Commands list, select the macro and drag it to the menu.

7. When you finish adding macros, click Close.

Tip
You can use the same steps to add macros to shortcut menus and toolbars.
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Customizing the Appearance of the Screen

Customizing the Appearance of the Screen
You can customize the SailWind interface by changing the appearance of menus and toolbars. Use the 
Options  tab of the Customize dialog box (Tools > Customize  menu item > Options  tab).

Customize Display of Toolbars
Customize Display of Windows
Resizing the Layers List

Customize Display of Toolbars
You can add tooltips, display shortcut key information, or display large icons as ways of customizing the 
toolbar display.

Procedure
1. Choose the Tools > Customize  menu item and click the Options  tab.

2. Make one or more of the following selections:

• Select the “Show ToolTips on toolbars” check box to display tooltips for toolbar buttons or clear 
the check box to hide the tooltips.

• Select the “Show shortcuts in ToolTips” check box to display shortcut key information or clear 
the check box to hide it.

• Select the Large Icons check box to display large icons or clear the check box to retain normal 
sized icons.

Tip
To show or hide a toolbar in the SailWind interface, use the Toolbars and Menus  tab. See 
“Editing a Custom Toolbar”  on page 549.

Customize Display of Windows
You can add animation, shadows, and delays to your window display from the Options  tab of the 
Customize window (Tools > Customize  menu item, Options  tab).

You can make the following customizations to the display of windows:

• To change the way a menu is displayed, select an animation from the Menu animations list. For 
example, the “Unfold” animation displays part of the menu and an arrow you can click to display 
the rest.

• To show shadows on menu items, select the “Menu shadows” check box.
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• To display your recent menu selections before other menu items, select the “Show recent 
commands first” check box.

• If menus display recent commands first, you can display the full list of menu items after a delay. 
Select the “Show full menus after delay” check box.

• If you have a shortcut made up of a number of keys, you can delay its execution until you press 
the Enter key by selecting the “Wait until enter before executing long shortcuts” check box.

• To delete the record of commands you have used and restore the default set of commands to 
the menus and toolbars, click Reset my usage data. This option does not undo any explicit 
customizations you have made.

Resizing the Layers List
You can change the width of the Layers list on the Standard toolbar.

Restrictions and Limitations
You cannot use the Alt key to resize the Layers list.

Procedure
1. Choose the Tools > Customize  menu item to open the Customize dialog box.

2. Click on the Layers list box on the toolbar.  (Ignore the Customize dialog box.)

3. Resize as needed.

4. Click Close  in the Customize dialog box.
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Organizing Windows

Organizing Windows
You can customize the way windows appear in your workspace.

Showing and Hiding Windows
Hiding Windows Automatically
Detaching Windows from the Current View
Attaching Windows to the Current View

Showing and Hiding Windows
Several windows display when you start SailWind Router for the first time. You can show and hide any of 
these windows.

Tip
You can also hide windows automatically. See “Hiding Windows Automatically”  on page 567.

Procedure
To hide a visible window, click on its toggle switch on the View  menu, or on the Hide  command from the 
Window Position menu  on the window’s title bar. To show a hidden window, click on its toggle switch on 
the View  menu.

Hiding Windows Automatically
You can set a window to hide automatically so that it appears only when you hover the pointer over the 
hidden window’s tab.

Procedure
1. Move your pointer to the right side of the title bar in the window you want to hide.

2. Click the thumbtack  in the window's title bar.

The thumbtack picture changes to point sideways . A new bar appears on the side of the 
interface. The side on which the bar appears depends on the location of the window. For example, 
if the Project Explorer is located on the left side of the user interface, when you click the Auto Hide 
setting from the menu, the new bar appears on the left side of the interface.

The new bar contains a tab that has the same name as the window.

3. Hover over the tab in the new bar. The window reappears, extending over the application.

4. Move the pointer away from the window. The window minimizes to a tab.

Tip
To turn off the Auto Hide feature, hover over the tab in the new bar so the window 
reappears. Then repeat steps 1-2 so that the thumbtack icon points downward again.
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Detaching Windows from the Current View
You can detach a window from the current view. This is called floating. A floating window does not attach 
to the current view; instead, it hovers, blocking the view to anything below it.

Restrictions and Limitations
You cannot float a window that is currently set to hide automatically. Turn off the Auto Hide feature before 
floating a window.

Procedure
Double-click the window’s title bar. The window detaches and you can move it to any part of the screen.

Tip
To undo the floating, see “Attaching Windows to the Current View”  on page 569.
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Attaching Windows to the Current View

Attaching Windows to the Current View
You can attach a window to the current view. This is called docking. A docked window attaches to the 
current view, and therefore does not block the view to anything below it. You can dock a window in its last 
docked location, or dock a window to a different location.

Docking to the Last Location
Docking to a New Location
Embedding Windows within Other Windows
Managing Window Tabs

Docking to the Last Location
You can attach or dock a floating window to its last docked location.

Procedure
Double-click the window’s title bar. The window reattaches to the interface.

Docking to a New Location
You can drag a floating window and dock it from one location to a new one.

Procedure
1. Using the title bar, drag the window.

When you start dragging the window, additional graphics appear in the user interface. At the edges 
of the user interface, arrows containing graphics appear, as shown in Figure 113:

Figure 113. Window Dragging Graphic

Tip
A similar group of arrows appears in a group near the center of the screen. Ignore that 
group of arrows for this procedure.

2. While dragging the window, hover over one of the arrows on the edge of the user interface. For 
example, hover over the arrow on the left side of the user interface.

A transparent colored block appears along the side of the user interface to which you are pointing. 
This block indicates where the window will be docked when you release the mouse button. For 
example, if you hover over the arrow on the left side of the user interface, a block appears along 
the left side of the screen, as shown in Figure 114.
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Figure 114. Docking a Window

3. Release the mouse button while hovering over the arrow that indicates where you want to dock the 
window.

The window docks to the user interface, and the other windows in the user interface resize.
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Embedding Windows within Other Windows
In addition to attaching a window to a side of the user interface, you can embed a window within another 
window so that it shares the window space or becomes a tab within the original window.

Two Windows Sharing One Window Space
Creating Tabs Within Windows

Two Windows Sharing One Window Space
You can embed a window within another window’s space.

Procedure
1. Using the title bar, drag a window into another window.

When you start dragging a window, additional graphics appear in the user interface. A group of 
arrows containing graphics appears in the center of the window you are dragging, as shown in 
Figure 115. Depending on the window you are dragging, the group of arrows may also have a tab 
graphic in the center.

Figure 115. Dragging a Window— Arrow Group

Tip
A similar group of arrows appears at the sides of the user interface. Ignore those arrows for 
this procedure.

2. While dragging the window, hover over one of the arrows. For example, hover over the left arrow.

A transparent colored block appears along the side of the window you are dragging, as shown in 
Figure 116. This block indicates where the window will be docked when you release the mouse 
button. For example, if you hover over the left arrow, a block appears along the left side of the 
Project Explorer.
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Figure 116. Dragging and Docking a Window

3. Release the mouse button while hovering over the arrow that indicates where you want to dock the 
window.

Results
The window is embedded within another window, both sharing the space the original window occupied.

Tip
To maximize your workspace, try setting these embedded windows to hide automatically. Ctrl
+click the thumbtack in one of the window's title bars, and all of the windows within the original 
window frame hide automatically.

Creating Tabs Within Windows
You can embed a window as a tab in another window.

Procedure
1. Using the title bar, drag a window into another window.

When you start dragging a window, additional graphics appear in the user interface. A group of 
arrows containing graphics appears in the center of the window you are dragging, as shown in 
Figure 117. Depending on the window you are dragging, the group of arrows may also have a tab 
graphic in the center.

Figure 117. Dragging and Docking a Window— Arrow Commands
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Creating Tabs Within Windows

Tip
A similar group of arrows appears at the sides of the user interface. Ignore those arrows for 
this procedure.

2. While dragging the window, hover over the tab graphic.

A transparent colored block appears over the window you are dragging, as shown in Figure 118. 
This block indicates where the window will be docked when you release the mouse button. For 
example, if you hover over the tab in the Project Explorer window, a block appears over the Project 
Explorer.

Figure 118. Dragging a Window— Transparent Block

3. Release the mouse button while hovering over the tab.

Results
The window is embedded as a tab within a window, as shown in Figure 119. You can click each tab to 
access each window.
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Figure 119. Window Embedded as a Tab

Tip
To maximize your workspace, try setting these embedded windows to hide automatically. Ctrl
+click the thumbtack in one of the window's title bars, and all of the windows within the original 
window frame hide automatically.
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Managing Window Tabs

Managing Window Tabs
Some of the windows in the user interface contain tabs. You can reorganize the tab grouping to suit your 
needs or preferences.

Rearranging Tabs in a Window
Moving Tabs Between Windows
Converting Tabs to Windows

Rearranging Tabs in a Window
You can change the order of tabs in a window.

Restrictions and Limitations
You can only move tabs that you have embedded in other windows. In windows that have tabs by default 
(such as the Output Window in SailWind Router), you cannot move the tabs. You can only rearrange 
them. For information on rearranging tabs, see “Rearranging Tabs in a Window”  on page 575.

Procedure
Drag the tab to a new position within the row of tabs.

Moving Tabs Between Windows
You can move a tab from one window to another.

Restrictions and Limitations
You can only move tabs that you have embedded in other windows. In windows that have tabs by default 
(such as the Output Window in SailWind Router), you cannot move the tabs. You can only rearrange 
them. For information on rearranging tabs, see “Rearranging Tabs in a Window”  on page 575.

Procedure
1. Drag the tab to a new window. When you start dragging, the tab automatically behaves like a 

window.

2. Place the tab as you would a window.

Related Topics
Embedding Windows within Other Windows

Organizing Windows

Converting Tabs to Windows
You can create a new window from a tab.
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Procedure
1. Drag the tab. When you start dragging, the tab automatically behaves like a window.

2. Release the mouse button. Make sure the pointer is not over any arrow graphics.

You now have a floating window.

3. Place the tab as you would any floating window.

Related Topics
Organizing Windows

Crash Detection
Crash Detection provides the capability to capture and report unexpected terminations of the software.

If crash detection is enabled, the Error Detected dialog box  on page 414 opens at a crash and allows you 
to save a report of the SailWind environment as well as pertinent files in a compressed Dump File. You 
can then submit this file to SailWind Software Customer Support. You can also attach feedback to this 
report, and optionally, the Basic Media Wizard (BMW) media and project files.

The Error Detected dialog box is inaccessible unless the software crashes and crash detection is enabled 
in the software .ini  file.

Crash detection is controlled by the CrashDetection  switch in the SailWindRouter.ini  file (located in the C:
\<install_folder>\Settings  directory); it is turned off by default.

• If no CrashDetection  switch exists in the [General] section of the .ini  file, or if the switch exists 
with a value of 0 (zero), then crash detection is turned off. No report is created of the environment 
at the time of the crash.

• If the CrashDetection  switch exists in the [General] section of the .ini  file, with a value of 1, then 
crashes are detected and the Crash Detection dialog box appears.
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Glossary
absolute coordinates

Coordinates of a location based upon their distance from the origin (coordinates 0,0) of the design 
area.

accelerator keys
Key sequences used to invoke commands and change system settings without using the mouse. 
Accelerator keys are called shortcut keys in the SailWind product documentation.

accessible nets
Nets for which you can define test points. DFT Audit analyzes all nets. If DFT Audit determines that 
test probes can access them, the nets are accessible (also called adaptable).

accordion
A trace pattern resembling a signal wave that adds length to traces. The trace patterns are 
contiguous and do not include layer changes.

accordion gap
The gap of an accordion sets the pitch between chords. The gap is a user-definable number 
multiplied by the same net trace-to-corner clearance.

If the same-net trace-to-corner distance equals zero, then Trace Width is used for the gap 
calculation.

See also accordion, amplitude, pair routing gap
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acid trap
An acid trap is a location where acid gets trapped in an area due to the surface tension of the 
etching. This acid causes over-etching, which hurts yield.

active component
The active substituted component in an assembly variant. Active means that this substitution of the 
component is used in the current variant.

See also default.asc

active layer
The design layer to which new information is added. You select the active layer by choosing the 
layer in the Layer list on the Standard Toolbar. You can also do this by using the L modeless 
command.

ACTM#
The 16-digit number found on your security key.

adaptable nets
See accessible nets

adhesive
A substance used to attach the bodies of devices to a PC board.

aggressor nets
When using the Electrodynamic Checking program (EDC), a net or pin pair that is considered a 
source of interference.

align
To reposition placed parts to match the alignment of another part.

alignment tool
A small, temporary marker at each location where dimensioning occurs.

alpha pins
Pins with descriptive letters that are substituted for pin numbers. For example, GND for the ground 
pin. Alphanumeric pin assignments are made in the Library Manager's part type editor.

alphanumeric pins
Pins with alphanumeric pin numbers. An alphanumeric name consists of a prefix and suffix. The 
prefix or the suffix can contain either alpha letters or numeric numbers. For example, A1, 1A, or 
even DATA07 (consists of the prefix “DATA” and the suffix “07”).

amplitude
The amplitude of an accordion sets the accordion height (for horizontal accordions) or accordion 
width (for vertical accordions). The amplitude is a user-definable number, multiplied by the same net 
trace-to-corner clearance.
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analog board

If the same-net trace-to-corner distance equals zero, then Trace Width is used for the amplitude 
calculation.

See also accordion, gap (accordion)

analog board
A board with mostly discrete components and minimal integrated circuits.

analog circuit
A design composed of discrete components such as capacitors, resistors, and diodes.

angstrom
1/10,000 of a micrometer (10-4um).

annotation (forward and backward)
Forward annotation refers to the process of updating the design file to match the schematic file. 
Backward annotation refers to updating the schematic file to match the design file.

annular pad
A pad shape that enables you to specify an inside and an outside diameter. This creates a donut 
shape because the inner hole was used to center the drill bit when boards were hand-drilled on a 
drill press. Though obsolete, the annular pad is still offered for special circumstances.

annular ring
The conductive pad material surrounding the hole. The annular ring radius = pad diameter-(finished 
hole size) / 2.

antipad
For plane layers, a slightly oversized pad diameter that plots as a clearance for through-hole pins 
that should not connect to the plane.

any-angle coupling trace
Part of a route that connects SBP fanouts to serpentine routes.

aperture
A uniquely shaped window or hole that is attached to an aperture wheel on a photoplotting machine.
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aperture table
A table that matches the line widths necessary to print your design with the plotter setup. SailWind 
Layout can prepare the table automatically, or you can prepare it manually.

Artwork for printed circuit manufacturing is created by exposing clear film to light that is passed 
though the aperture. Although the aperture wheel has been made obsolete by laser plotters, an 
aperture table is still necessary to drive laser plotters.

apl.dcr
A setup file for Novell network security.

application-specific integrated circuit
An IC designed to meet a specific customer requirement.

area select
A method for selecting an object or a group of objects. If you enable area select by clicking Filter on 
the Edit menu, a selection rectangle is created and all items within the rectangle are selected.

array
A group of items, such as bonding pads, that are arranged in rows and columns.

artwork
Clear film with darkened areas representing pads and connecting traces, and used for 
manufacturing a printed circuit board. Each layer of a design has its own unique artwork, such as 
silkscreen and solder mask.

.asc
The file extension used to identify a proprietary PADS-format ASCII file.

ASCII format
A translation format that uses ASCII text to define the PCB design. ASCII format is widely used 
to list the parts and connections in a design, to import and export design items, and to check the 
design for binary corruption.

ASIC
An acronym for application-specific integrated circuit.

assembly drawing
A final design document that provides the part name, type, and orientation for each device on a 
printed circuit board. An assembly drawing is used for assembly of the final product.

assembly variant
A specific manufacturing configuration of a PCB. Assembly variants specify which components 
are used, which are not used, and which are substituted with a different decal part type. Several 
assembly variants can exist for a single PCB.

associated net
See electrical net.
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associating component

associating component
A component through which an electrical net passes.

associating copper
Copper combined with the terminals in the PCB Decal Editor.

attribute groups
A group of structured attributes. For example, the DFT group includes the following attributes:

• DFT.Nail Count Per Net

• DFT.Nail Number

• DFT.Nail Diameter

attributes
Attributes contain information you have associated with an object in your design. Attributes contain 
the types of part information that can be included in the parts library description and exported to a 
parts list. Examples are part manufacturer, package type, order number, and so on.

Auto Dimensioning tab
The tab on the Options dialog box that determines the appearance of newly created dimensions.

automation
A way for heterogeneous applications to communicate with each other. SailWind products make 
some data, such as the database in use, and some functionality, such as opening files or selecting 
objects, available to other applications.

autorouter pass types
Pass types are part of an autorouting strategy that determines how the autorouter routes a design.

Pass Description

Center Places traces equidistant from component pins or vias and each other to evenly 
distribute any available space in the channel.

Fanout Places vias for inaccessible SMD component pins and routes from the vias to 
the pins.

Miters Converts all route corners of a specified angle to diagonal corners.

Optimize Analyzes each trace and tries to improve the quality of the route pattern by 
removing extra segments, reducing via usage, and shortening trace lengths.

Patterns Searches for groups of unrouted connections that can be completed using 
typical C routing patterns, Z routing patterns, and memory patterns and then 
routes them.

Route Sequentially routes each unroute until all connections are attempted.
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Pass Description

Test Point Analyzes the testability of the design, determines which nets require testing, 
adjusts the routes, and inserts test points to improve testability.

Tune Adjusts the length of length-controlled traces. The Tune pass tunes all routed 
traces with length rules, and automatically adjusts length-controlled traces to 
meet design rules.

axial lead
A connection pin that protrudes straight out from the component body and bends at 90 degrees for 
insertion into the PC board. An axial lead is usually associated with discrete components such as 
resistors, capacitors, or diodes.

back-annotate
Update a schematic file to match its design file.

ball bonding
A bonding technique that provides increased contact between a gold wire and a chip bond pad. This 
method uses thermal compression to melt gold wire to form a ball.

ball grid array
A packaging method that uses a substrate to interconnect one or more die to an array of solder 
alloy spheres.

base option
The Base Option, in Assembly Variants, contains all of the common components in all of the 
existing  variants; in other words, it contains a filtered database. If you uninstall or substitute 
components in a variant, they are removed from the Base Option. Therefore, the Base Option, 
because it contains only installed options, is also a subset of the raw database. You can use the 
Base Option to view all of the items in all of the variants, or the base of all variants.

The Base Option always exists; you cannot delete it.

base part
When making a union, the part type of the first selected part. Base parts can either be left in 
position and joined by secondary parts, or repositioned to imitate the first selected prototype part.

baseline dimensioning
A type of dimensioning in which a series of dimensions have a common start point, such as datum 
dimensioning.

basic units
A basic unit is the smallest unit of measurement in a SailWind database. All values in the database 
are stored in binary format basic unit and are converted to the current user units (mils, mm, or 
inches) for screen display. If you need to re-import the information to .pcb  format, export in basic 
units.

Conversions are:
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BGA

• 1 mil = 38100 basic units

• 1 millimeter = 1500000 basic units

BGA
An acronym for ball grid array.

BGA fanout
A single-segment fanout that connects BGA array pads to BGA vias. This single-segment fanout 
always ends in a via.

BGA/PGA decals
A full matrix decal for BGAs and PGAs, including staggered array patterns.

biased pin pair
A layer biased pin pair is any pin pair with a design rule specifying a layer bias to one or more, but 
not all, electrical routing layers.

blind via
A via that connects an outer layer to one or more inner layers, without passing through all other 
layers of a printed circuit board.

bmp
An image file that can be pasted into documents or other programs such as Microsoft Word. 
SailWind products use the Copy Bitmap command to capture these as screen images.

board markings
Designers usually include identification information on a board. These may include the board part 
number, the assembly part number, the company name, the product name, the revision level, the 
serial number, the copyright notice, an anti-static symbol, warning messages, UL labels, test labels 
and many other types of information. This information may be in ink on the silkscreen layers, in 
copper on the top and/or bottom layer or some combination of the two. These are typically referred 
to as board markings.

Add text to an electrical layer and it will be created in copper. Add text to a Fabrication, Assembly, 
and Documentation Layer and it will be created during the silkscreen process.

Use the Text command to add board markings to your design.

See also Adding Free Text

board outline
The actual shape of the printed circuit board, defined by line segments and arcs. The board outline 
is entered on layer 0 and displayed on all layers.

bonding pads
Metallization areas placed around the perimeter of the integrated circuit die, to which aluminum or 
gold wires connect the die to the component package.
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bounding rectangle
The smallest rectangle that encloses all nontext graphics on all layers.

breakpoint marker
A small brown dot in the Output window gutter that indicates a breakpoint in a script or macro.

bumped chip
A die or chip that has been specifically processed with buffer metals over the I/O pads, followed 
by an addition of solder or gold bumps to provide bonding areas for direct chip attachment onto a 
substrate.

buried via
A via that connects only inner layers.

bus
A series of connections that share a common use, such as memory array or data array, and are 
usually routed parallel to each other.

bus routing
Routing two or more pin pairs simultaneously and in close proximity to each other in neat, flowing 
patterns.

C routing pattern
A collection of routes that form a pattern resembling the letter C.  

CAD
An acronym for Computer-Aided Design or Computer-Aided Drafting.

CAE
An acronym for Computer-Aided Engineering.

CAE Decal
The graphical representation of schematic symbols in SailWind products.

CAM
An acronym for Computer-Aided Manufacturing.
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CAM document

CAM document
A combination of plot type and output device you create and save with the design. For example, 
you can include "Silkscreen Top, Photoplot" and "Silkscreen Top, Laser Printer" on your CAM 
Documents List and run them selectively when needed.

CAMDir
The SailWindpcb.ini  file entry that enables you to specify the CAM master folder for creating CAM 
output.

capacitance
The ratio of charge within a trace that is a factor of the trace length and signal delay.

CBGA
An acronym for ceramic ball grid array.

CBP
An acronym for chip bond pad.

center pass
An autorouting pass that places traces equidistant from component pins or vias and each other to 
evenly distribute any available space in the channel.

CGA
An acronym for column grid array.

chamfered
A rectangle with the square corners cut off to create beveled edges on the corners.

chamfered path
A solid filled copper that, like a trace, acts as a conductor connecting pins and vias similar to a 
trace. But unlike a trace, which is created with a round aperture producing rounded outside corners, 
chamfered path copper allows for sharp specific outlines with a filled interior. When creating a 
chamfered path, you set options to create shapes with square or chamfered corners. The copper 
created by chamfered path has a Solid Copper property which overrides the Copper Hatch Grid and 
Drafting Line Width settings to make it a solid fill. Clearance rules for the chamfered path copper are 
also changed to match the clearance rules of a trace.

checking
Verifying the design meets previously defined rules, such as clearance and connectivity.

chip
An integrated circuit without packaging. A chip is also called a die.

chip bond pad
Interconnect areas on the die on which wire bonds are connected to the substrate.

chip carrier
A square or rectangular IC package, with I/O connections on four sides.

SailWind Router Guide 585



Glossary
chip on board  

chip on board
The packaging configuration in which a chip is bonded directly to a circuit board or substrate.

Chip Scale Package
A packaging configuration in which the dimension of the substrate is 1.2 times larger than the die.

chord
Half of an accordion.

See also accordion,amplitude, gap (accordion)

clam shell fixing
A test fixture that tests both the top and bottom side of the PCB.

class
A collection of nets with a common set of design rules.

clearance
The measured space between routed objects such as trace-to-trace, trace-to-pad, or pad-to-pad.

closed cluster
Clusters that you cannot delete or replace during automatic cluster creation.

cluster
In Cluster Placement, a group of parts that must be placed close to each other.

CMOS
An acronym for Complementary Metal Oxide Semiconductor.

COB
An acronym for Chip On Board.

coefficient of thermal expansion
A quantity used to determine the length change of a material due to temperature change. Thermal 
expansion differences between the die and substrate must be considered for quality assurance.
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collapse
To relocate the members of a cluster from their current placement to the center of the cluster.

column grid array
Similar to a ball grid array, but columns are used to improve the stresses of different thermal 
expansion between the board and the component.

Com port
Abbreviation for communications port. This port provides a connection between your computer and 
peripheral devices, such as plotters, modems, and other computers.

combine
Joining lines, or lines and text, together as one selectable object.

component side
The top or front side of a printed circuit board where devices are normally mounted.

composite fanout
A fanout from a pin that is common to two subnets. Often created by autorouting operations.

Composite fanouts provide access to component pins that may otherwise be inaccessible.

See also fanout, subnets

composite rule trace
A trace that is attached to a pin (typically an SMD) shared by two subnets. This type of trace is 
typically created by autorouting operations.

See also composite fanout, subnets

conditional rules
Rules placed on a signal that apply only if the signal is routed near another specified signal. 
Conditional rules are also known as against rules.

conductor
A material that causes heat or electrical current flow. For printed circuit design, a conductor is a 
piece of metal that connects pins of components together.

connected islands
A maximum set of subnet items already connected by a trace, copper unroute, or jumper.

See also subnets, subnet

connections
Points of connectivity, such as a pin pair or a net.

connector
A unique component used to connect a portion of a printed circuit board with other devices.
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container application
An application that can incorporate embedded or linked items into its own documents. The 
documents managed by a container application must be able to store and display both OLE 
components, and data created by the application itself. A container application must also allow 
users to insert new items or edit existing items.

When you insert objects into a SailWind product, the SailWind product is the container application. 
When you insert a SailWind file into another application, the other application is the container 
application.

controlled gap area
The part of the differential pair where the traces are drawn routed in parallel and separated by the 
pair routing gap. The controlled gap zone area starts at the gathering point and ends at the split 
point.

See also gathering point, pair routing gap, split point

controlled gap length
For a differential pair, the ratio of the controlled gap area routing length to the overall routing length, 
in percentage.

See also differential pairs

controlled length net
A net that has length rules, or contains pin pairs that have length rules.

The following high-speed rules are net length rules:

• Minimum/maximum length

• Matched length

• Differential pairs

converting database
The process that converts a non-native file, such as an .asc  file or a .dxf  file, to a native format, or 
.pcb, file.

copper connectivity
Means unroutes are always connected to a copper at some point in the copper outline. A copper 
outline can include arcs. The following graphic illustrates how copper connects to a net.
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copper plane

See also coppers, overlapping coppers

copper plane
A copper shape with insulation areas around traces and pins that pass through the copper, but are 
not attached or connected to the copper. Can be placed on any layer, except CAM plane layers.

coppers
Polygons on an electrical layer representing an area of the PCB to fill with metal.

When a copper is assigned to a net, it is joined to the net with a trace or via. Coppers are obstacles 
to net objects unless the copper and the net belong to the same net.

See also overlapping coppers, copper connectivity

copy route
The duplication of a trace or series of traces, using copy and paste.

corner
Point where a trace or line changes direction. The Selection Filter enables or disables picking 
geometric or route corners.

cost
Reduces usage of a layer. The higher the cost, the less a layer is used for routing.

cross-probing
Uses a link between SailWind programs to reflect, in one SailWind application, selections made in 
another SailWind application.

CSP
An acronym for chip scale package.

CTE
An acronym for coefficient of thermal expansion. It is also referred to as TCE.

cutouts
A closed polygon in a copper, copper plane, or board outline. In copper or copper planes, a cutout 
results in an area absent of copper.

See also overlapping cutouts
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cycle picking
To sequentially select objects in the vicinity of the selection point using the Tab key.

dangling route
Dangling routes are stubs or spurs off of traces that are not tied to any pin by a ratsnest. See also 
partial route.

database units
The use of mils, metric, or inches within a design.

datum dimensioning
A style of dimensioning in which all dimensions are measured from a common starting point. The 
origin extension line is marked as zero, with each dimension reflecting the measurement from that 
point.

See also Creating Baseline Dimensions

D-codes
Specific numbers assigned to photoplot machine apertures for program identification. D-CODES are 
included in the aperture table.

decal
The physical representation, or footprint, of a part.

decal copper
Open, closed, or associated copper produced within the physical representation of a component.

decal text
Documentation text produced within the physical representation of a component.

default component
The original component, before being replaced in the current assembly variant. The default 
component is always in the raw database, but not necessarily in the Base Option.

See also active component

default layer mode
A layer mode in which a design can consist of up to 30 electrical layers, or a combination of 
electrical and nonelectrical layers. You change from default layer mode to increased layer mode by 
clicking the Max Layers button in the Layers Setup dialog box.

default.asc
The ASCII file accessed for new file creation. This file provides startup design information such as 
grid sizes, default colors, or other information.

default.cam
A file usually found in the C:\<install_folder>\<version>\Programs  folder that contains default 
apertures, speed and feed settings, and drill symbols for CAM output. This file must exist in the 
same folder as specified by the UserDir variable in the SailWindpcb.ini  file.
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See also increased layer mode

defaults
Conditions or options that are set when the SailWind product starts.

delay
The time it takes for a signal to travel through a trace.

delete
To remove information from a design.

design area
The actual work area where a design is created.

design on the fly
To use ECO Operations to create a new design without first providing a netlist or parts list from 
schematic software. This can also be called design.

Design category
The Options category that controls design conditions, general routing conditions, and certain display 
and part movement method settings.

design rules
Established spacing and general routing constraints for electrical properties, or conductors, which 
are verified by clicking Verify Design from the Tools menu.

devicesn.dat
A file usually found in the C:\<install_folder>\<version>\Programs  folder that contains CAM 
printer and plotter driver data. This file must exist in the same folder specified by the UserDir 
SailWindpcb.ini  variable.

DFM
An acronym for Design for Manufacturing.

DFT Audit
DFT Audit analyzes every net for accessibility (adaptability) and creates a board report that 
identifies all inaccessible (non-adaptable) nets.

dice
The plural of die.

die
A single square or rectangular piece of semiconductor material into which a specific electrical circuit 
has been fabricated.

die bonding
To attach the semiconductor die to the package substrate with epoxy adhesives, gold eutectic, or 
solder alloy. It is also referred to as Die Attachment.
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die flag
Metal shapes placed under a die for thermal management and/or electrical connection; also 
referred to as a flower pattern.

die side of CBP
The side of the die on which the CBP lies. Usually the die side of the CBP is the same as its fanout 
side, but in some cases more complex patterns of wire bond fanout may mean that the two sides 
are not the same.

Die Wizard
This feature creates die part definitions parametrically or imports the die description using GDSII or 
formatted ASCII files. The Die Wizard replaces Component IQ by providing die capture directly in 
the Advanced Packaging Toolkit layout editor. This eliminates the need to transfer .ciq  files.

dielectric
A non-conductor of current; an insulator.

dielectric constant
A value given for manufacturing materials, such as FR-4, to describe electrical characteristics.

differential pairs
A group of two nets or two pin pairs routed side-by-side and separated by the pair routing gap for 
as much of the overall length as practical. A differential pair typically transmits two electrical signals 
that are driven 180 degrees out of phase from each other.

See also pair routing gap

digital board
A board with mostly integrated circuits in proportion to the analog components.

DIP
An acronym for Dual In-line Package.

DisableCaching
A SailWindpcb.ini  file entry that, when set at 1, shuts off graphics optimization and, when set at 0, 
enables graphics optimization.

discrete device
A device that contains one circuit element. For example, a resistor or toggle switch.

disperse
A command that is active on several levels of Cluster Placement. When selected, it clears the board 
of all parts or clusters that are not glued down, and arranges them around the outside of the board 
outline according to decal type.

dispersion routes
Partial routes, ending in vias, which tie surface mount components to plane layers.
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do file
The SPECCTRA router ASCII setup file that contains user-defined router commands to initiate 
batch routing.

dock
To take an isolated application dataset and pull the changes within the dataset into the main design 
project. Any conflicts with the merged data must be manually resolved.

documentation layers
Layers higher than the electrical layers in a SailWind Layout database that contain text and lines to 
illustrate assembly, annotation, and provide instructions for manufacturing.

double-click
Two mouse clicks, in immediate succession, that usually initiate an edit action or complete the 
current action.

double-sided board
A printed circuit board made up of two routing layers, and which has no internal layers.

double-sided die
A die that has substrate bond pads on one side, and a BGA grid array on the other side. The two 
sides are connected through vias.

See also single-sided die

drafting operations
Any operation that involves adding nonelectrical information, not associated with placement or 
routing, to a design.

drawn pads
Photoplot pads, usually finger pads, that are produced by opening the aperture and moving the 
board, with the aperture remaining open, to produce a pad shape.

DRC
An acronym for Design Rules Check.

drill chart
A diagram, produced on a drill drawing, that shows drill symbols matched with drill hole sizes. This 
is also referred to as a drill legend.

drill oversize
A factor applied to plated through holes for DRC purposes to account for drill oversizing during the 
PCB fabrication process.

drill pairs
Primarily for buried and blind vias, drill pairs define which layers are to be drilled and plated together 
during the fabrication process.
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drill symbols
Unique symbols on a drill drawing plot that represent the various drill hole locations and sizes.

drill.dat
A user-definable ASCII file that determines settings for NC Drill output format options. This file must 
exist in the same folder specified by the UserDir variable in the SailWindpcb.ini.

DXF
An acronym for Data eXchange Format, a standard ASCII format for sharing graphics database files 
between different environments.

dxfset.dat
A file that contains the information for drill size and library name equivalents in basic units for the 
DXF Setup dialog box.

dynamic route
To create a route using the Dynamic Route tool, which automatically creates turns and pushes other 
routes aside to complete the connection.

ecad hint.map
A user-defined text file that you create, edit, and maintain. This file enables the replacement of 
approximated parts from SailWind Layout, with geometrically accurate components previously 
modeled in Pro/ENGINEER. This file must exist in either the current working folder or in the Pro/
ENGINEER software loadpoint\text folder.

ECO
An acronym for Engineering Change Order. This refers to a file with netlist changes that needs to be 
annotated to update either the schematic or layout that has become out of sync with the new design 
changes.

ECO mode
A mode that SailWind Layout enters when the ECO Toolbar is open. Changes that affect the 
connection list or parts list can be recorded in a file for backward annotation.

See also ECO

ECO Options
The setup choices available for the ECO output file in the ECO Options dialog box.

ECO registration of attributes
Only ECO-registered attributes, set on the Objects tab of the Attribute Properties dialog box, can be 
added, deleted, or changed during the ECO process. Via attributes are not registered attributes and 
cannot be added, deleted, or changed during the ECO process.

You can modify ECO-registered attributes only in ECO mode.

Non-ECO-registered attributes are never recorded in an .eco  file during ECO operations.

To compare ECO-registered attributes, use the Compare Only ECO Registered Attributes option on 
the Comparison tab in the Compare/ECO Tools dialog box.
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EDA
An acronym for Electronic Design Automation.

EDC
An acronym for Electrodynamic Checking.

edge
One side of a polygon.

edge die
The two or three rows of dice along the outer circumference of a wafer.

edges
The Selection Filter preference that enables or disables selection of geometric segments.

editing
Any action that modifies a design.

electrical layers
Layers enabled for routing that are checked by DRC.

electrical net
A series of nets connected by one or more components. Length, differential pair and matched 
length rules can be applied to an electrical net as though it were a single net.

embedded objects
An object, including all of its data and the information needed to manage the object, that is 
contained within the framework of, and is a part of, the container application document.

See also linked objects

EnableMacroLanguage
The SailWindpcb.ini  file entry that, when equal to one, enables loading of all macro parameters on 
startup and, when equal to zero, disables loading of macro parameters upon startup.

end component
A component having at least one pin which is a final pin of an electrical net.

end no via
The mode initiated in the routing shortcut menus that, while routing, ends a partial route without a 
via.

end via
The mode initiated in the routing shortcut menus that, while routing, ends a partial route with a via.

end zone
The part of the differential pair between the split point and destination pins.
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The labels in the above graphic correspond to routing that starts at the left-hand set of pins and 
ends at the right-hand set of pins. The label positions are reversed if the routing starts at the right-
hand set of pins.

See also differential pairs, split point

ending layer
The finishing layer for a drill pair or via definition. Enter information about ending layer in the Pad 
Stacks Properties dialog box.

engineering change order (ECO) operations
Any processes that modify the connection list or parts list.

entry angle
The angle at which a route enters a pad.

Esc
To use the Escape or Cancel keys to stop a current action.

estimated total length
The trace length monitor calculates estimated length as the combined total of routed length (Rt), 
plus the routed length for the entire net—including overlapping segments— (Nt), the unrouted 
length (U1) of the trace being routed, and includes half the Discrete length value of each connected 
pin of components that have a Discrete length assigned (not shown).

Overlapping segments are counted only once.

See also routed length, unrouted length
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eutectic solder

eutectic solder
A tin/lead alloy (63% tin, 37% lead) that melts at optimum temperatures.

export
The translation command used to convert a design file into PADS-format ASCII or DXF.

extended rules
Clearance, routing, and high-speed rules consisting of classes (one or more nets), groups (one 
or more pin pairs), individual pin pairs, decals, components and differential pairs. Without the 
Extended Rules option, you can assign rules on the net level only.

extension lines
Lines extending from the points being measured.

extents
The limits of the x and y coordinate area that is occupied by all items within a design. This includes 
information external to the board outline, such as dimensions or fabrication notes.

Fabless
A semiconductor company that subcontracts wafer manufacturing because it does not have its own 
wafer manufacturing facility.

fabrication
With semiconductor manufacturing, the front-end process of making devices in semiconductor 
wafers only, not the package assembly or back-end stages.

fanout
A segment of trace or copper shape added to SMD pads to facilitate routing. A fanout typically 
consists of one or more trace segments connecting a component pad to a via, enabling the signal 
on an outer layer to connect to one or more internal signal layers or planes. A specialized repeated 
pattern is often necessary to break out multiple pads on the same component far enough from the 
component to enable easy routing.

Use fanouts to:

• enable on-grid access by autorouters that cannot handle off-grid pads.

• make routing easier, and ensure connections are made.

• connect SMD pins to an inner plane layer using vias.

• connect an SMD pad to an inner signal layer where more routing space is available.

fanout pass
An autorouting pass that places vias for inaccessible SMD component pins and routes, from the 
vias to the pins.
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fanout side of CBP
The side of the SBP Guide to which the CBP should be wire bonded. Usually the fanout side of the 
CBP is the same as its die side, but in some cases more complex patterns of wire bond fanout may 
mean that the two sides are not the same.

FCBGA
An acronym for flip chip ball grid array.

feature size
The smallest line width or spacing between lines or features on a semiconductor die.

feed-through hole
A drilled and plated hole that passes conductivity from one layer to another. This is also called a via.

fiducials
Fiducials are alignment marks, a type of target, used for calibration before placing objects.

There are at least three types of fiducials:

• Panel fiducials  — used for alignment and calibration of images on a multi-board panel.

• Board fiducials  — used align components on a specific board (on or off a panel). Fiducials 
are (typically) round solid targets placed near three corners of each board on each side 
of the board that will receive components. The pick and place system scans the board for 
these targets (shiny circles approximately .040" in diameter) and uses them to align the 
machine before it starts placing parts.

• Component (local) fiducials  — used for close tolerance placement of high pin-count 
components with fine pitch leads. The footprint (PCB decal) of a fine pitch component will 
typically contain two component fiducials at opposite corners of the footprint. This enables 
the pick and place machine to align the fine pitch component exactly on the footprint.

field upgrade
Programming options on your security key by entering in a key unlock code using plicense.exe or 
equivalent.

file sharing
Multiple users accessing the same file or files through a network.

file.dir
The SailWindpcb.ini  file entry that specifies the default location of your design files.

filter
A settings dialog box within that controls which types of objects can be selected.

find
The SailWind command that locates, and optionally selects, an object or group of objects in the 
database.
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finger pad

finger pad
One of many long pads placed in a series to represent an edge connector.

finished hole size
The size of a drilled or routed hole after plating and/or solder reflow has been applied.

flashed pads
Pads produced on a photoplotter by opening the aperture momentarily, without moving the board, to 
produce a pad shape.

flat pack
A component package where the leads extend away from the component and remain on a parallel 
plane with the base of the component.

flip
The command that moves the selected items to the opposite side of the board.

flip chip
An IC designed for face-down mounting by means of controlled-collapse solder pillars on a device's 
I/O bonding pads.

floating license
A method of licensing where a central security server manages a pool of licenses for use by a large 
number of clients.

floating toolbars
Toolbars you can undock from the sides of the application window and place anywhere on screen.

flood
To fill a previously defined copper plane.

flower pattern
Metal shapes placed under a die for thermal management and/or electrical connection; also 
referred to as a die flag.

A ceramic, surface-mounted hermetic package.

FlushUndoBeyondSize
The SailWindpcb.ini  file entry that determines the maximum size of the undo buffer before SailWind 
Layout removes previous commands from the undo buffer to make room for the current command. 
If adding the current command causes the undo buffer to exceed this maximum size, SailWind 
Layout removes previous commands until the undo buffer can store the current command.

follow route
The connections or pin pairs that are part of the bus routing, and which are routed following the 
guide route's path.
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footprint
The arrangement of pads for a given part decal. For example, the footprint of a fourteen DIP is two 
rows of seven pads, spaced 100 mils in the Y direction, and 300 mils in the X direction.

forward-annotate
Update a design file using data from a schematic.

FR-4
An acronym for Fire Retardant Number Four, an epoxy-resin substrate material used in laminate 
applications.

free copper
Open or closed copper that is not associated to other copper or pads.

free disk space
The physical amount of space available on your hard drive that is available for use by programs.

gap (accordion)
The gap of an accordion sets the pitch between chords. The gap is a user-definable number 
multiplied by the same net trace-to-corner clearance.

If the same-net trace-to-corner distance equals zero, then Trace Width is used for the gap 
calculation.

See also accordion, amplitude, pair routing gap

gate
An element of an electronic circuit whereby one or more signals are input, with one output being 
dependent on the state of the input(s) and the type of logic used to interpret the input.

Pin swapping involves exchanging like inputs

Gate swapping involves exchanging the entire element for a like element.

gate array
An IC consisting of a regular arrangement of gates that are interconnected to provide custom 
functions.
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gathering point
The point near the source pins where differential pair traces can start to be routed together at the 
pair routing gap.

The labels in the above graphic correspond to routing that starts at the left-hand set of pins and 
ends at the right-hand set of pins. The label positions are reversed if the routing starts at the right-
hand set of pins.

See also differential pairs

GDI memory
Memory reserved for Windows devices and graphics.

Geometry.Height
This attribute is used to indicate the height of the part. The attribute enables SailWind Layout to 
prevent the component from being placed in an area of the PCB which is height restricted.

In SailWind Layout, you can set board height restrictions for the top and bottom layers in the 
Drafting Options  or area height restrictions using a Keepout area with a “Component height” 
restriction. This attribute is also passed from SailWind Layout to mechanical tools where it can be 
used in 3D simulations to determine whether the part will meet spatial requirements.

In addition to the value, use one of the following units:

• Use the quotation symbol " for inches. The SailWind Layout Attribute Dictionary specifies 
the following limits of acceptable values. Min=0.00000", Max=25.00000".

Example:  GEOMETRY.HEIGHT=3.26548"

• Use the abbreviation mil in upper or lower case. The SailWind Layout Attribute Dictionary 
specifies the following limits of acceptable values. Min=0.00mil, Max=25000.00mil

Example:  GEOMETRY.HEIGHT=12654.83mil

• Use the abbreviation mm in upper or lower case. The SailWind Layout Attribute Dictionary 
specifies the following limits of acceptable values. Min=0.00000mm, Max=635.00000mm.

Example:  GEOMETRY.HEIGHT=123.21348mm

Gerber
The language used to drive a photoplot machine. This language is an ASCII file with instructions for 
selecting an aperture, moving the light source, and turning the light source on and off.

Global tab
Options tab that includes settings that affect an entire design, such as units of measurement and 
pointer size.
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Glue
Anchors component(s) in their current location so they cannot be moved

grab bars
The two vertical or horizontal bars to the left or top of the window.

graphics cache
The SailWind setting used to optimize graphics. This is handled by the DisableCaching entry in the 
SailWindpcb.ini  and SailWindlogic.ini  files.

green dot
The status indicator located in the upper left corner of the workspace. It is green when the system 
is idle or ready for operation. It is red when the workspace cannot receive user input, such as when 
producing CAM drawings.

grid
A division of the workspace into measurement steps to facilitate accurate spacing between placed 
parts and routed lines. Also refers to the display; small white dots locating the measurement steps

ground plane
A design layer completely filled with copper, except for clearances around nonconnected pads and 
vias.

group
A collection of pin pairs that share common design rules.

grow
An cluster placement feature that adds additional parts to an existing cluster.

guard band
An octagonal shape that appears at the end of a trace during routing operations whenever the head 
of the trace meets a clearance obstacle that it cannot shove. The guard band only appears when 
online design rules are enabled.

gui
An acronym for Graphical User Interface. The GUI includes such things as menus and commands 
that allow for interaction between the user and the software program.

guide route
A route segment that is used for the first connection and that is the lead for laying down two or more 
pin pairs simultaneously in neat flowing patterns.
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hard rule
A rule that is always followed. See also soft rule, and Hard and Soft Rules.

hard breakout
Use of associated copper within a surface mount decal to simulate a dispersion route. The 
disadvantage to this method is that routing channels will possibly be blocked.

hatch
A copper fill pattern that uses horizontal and vertical lines at a specified width and spacing.

HDI
An acronym for High Density Interconnect.

heat dissipating component
While all components generate heat, these components generally have a published wattage 
rating. Care must be taken to ensure components or materials adjacent to these heat generating 
components do not exceed their max temperature ratings. If more than one of these components 
are used in a design, they should be spread out and should also be positioned to not impede 
airflow.

heat sink
An assembly that serves to dissipate, carry away, or radiate heat into the surrounding atmosphere.

high density interconnect
A class of packaging involving boards, substrates, and components using extremely small trace and 
spacing dimensions.

highlight
A user-defined color, usually white, used to denote that an object is selected.

high-speed checking
Using the Electrodynamic Checking utility. A simulator-type check that finds traces that may run 
parallel to each other close enough, and for a long enough distance, to cause cross talk.

hole plating
A fabrication process where solder flows through a drilled hole to connect the pads on either side of 
the hole, to provide connectivity between two or more layers.

HPGL
An acronym for Hewlett Packard Graphics Language, a standard pen plotter interface language.

IC (Integrated Circuit)
An acronym for Integrated Circuit.

IDF
Intermediate Data Format. An industry standard format used for exchanging data between electrical 
and mechanical design systems.
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IMAPS
An acronym for International Microelectronics and Packaging Society.

impedance
Resistance to the flow of current in a trace. Measured in ohms.

in circuit testing
An exhaustive and thorough test of a PCB in final production that tests nets and unused pins for 
such things as correct voltage, correct parts, or bridging. Test point placement is critical for in circuit 
testing.

inaccessible nets
Nets for which you cannot define test points. DFT Audit analyzes all nets. If DFT Audit determines 
that test probes cannot access them, the nets are inaccessible (also called non-adaptable).

increased layer mode
A layer mode in which a design can consist of more than the default of 30 layers up to a maximum 
of 250 layers. The maximum number of electrical layers is 64, and the maximum number of non-
electrical layers is 186.

See also delay

INI file
An ASCII file, with the .ini  filename extension, that contains startup parameters.

An INI file for Windows might contain the following information: graphics drivers, mouse drivers, 
fonts, and so on.

An INI file for programs might contain the following information: folder structure, display colors, 
default editors, and so on.

inner layers
Design layers other than those on the top or bottom of a printer circuit board. Inner layers may be 
routing layers, plane layers, or a combination of both.

installed options
SailWind product features that you have bought and installed as part of the software package.

instruction pointer
A small yellow arrow in the Output window gutter that indicates the current line in a script or macro.

insulator
A material used to inhibit heat or electrical properties, such as current flow.

integrity check
A database check runs whenever a .job, .dxf, or .asc  file loads. You can also initiate an integrity 
check while you are working. Type the I modeless command, then press the Enter key.
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intensity
A value assigned to objects such as vias to weigh decisions made during the autorouting process 
in SailWind Router. The higher the intensity, the less the item is used. For example, set a high 
intensity for via usage to minimize the amount of vias added to the design.

interconnect
A conductive connection between two or more circuit elements.

IPC
An acronym for Interprocess Communications within the SailWind product.

irregular trace length
Sections or segments of differential pair traces not routed at the pair routing gap.

See also differential pairs

islands
Small, isolated sections of copper plane that are not attached to anything.

JEDEC
An acronym for Joint Electron Device Engineering Council.

Joint Electron Device Engineering Council
JEDEC is the semiconductor engineering standardization body of the Electronic Industries Alliance, 
a trade association that represents all areas of the electronics industry.

jumper
A physical part used to cross over traces on most one layer PCB designs. Jumpers can be 0 Ohm 
resistors or wires stretched between jumper pads.

keepout areas
Areas that automatically ban objects. Depending on the keepout Properties, these areas may be set 
to prevent: placement of components, components that exceed a specified height, component drill 
holes, traces and copper, copper planes, vias and jumpers, and test points.

keyview.exe
An executable file used to list the options programmed into your key. When you run keyview.exe, it 
creates a file named keyview.txt  that contains a listing of your key options.

label
A label is a display instance of a component or jumper attribute. If you want to make an attribute 
visible in the design, you must instantiate it as a label associated with a component or jumper. You 
can do this in the Design Editor or the Decal Editor. You can have multiple labels based on the 
same attribute. An attribute has two parts—a name, and a value. A label of an attribute can have 
one of four visibility settings—None, Value, Name and Value, and Full Name and Value.
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Latium rules
Latium rules are for advanced functionality in SailWind Router. Some constraints that you can set 
in Layout are only used by SailWind Router. For examples, see the Tune/Diff Pairs options, Fanout 
Rules, Pad Entry Rules. The Latium checks include:

• component clearance rules

• component routing rules

• differential pair rules

• via at SMD rules

layer biased net
A layer biased net is any net with a design rule specifying a layer bias to one or more, but not all, 
electrical routing layers

layer pair
The assignment of two routing layers to switch between using the Layer Toggle command. On two 
layer boards, the toggle is automatically set between 1 (top) and 2 (bottom).

layer toggle
To switch between layer pairs while routing.

layers
A standard CAD database feature that separates graphical information into sheets of similar 
information such as dimensions, construction lines, or text. For PCB applications, this enables the 
various fabrication layers to be created and output separately.

layout-driven design
A PCB design process in which no schematic is created, and both the logical (netlist) and physical 
conformations of the board are defined in a layout tool. Also, a design created using this process. 
See also schematic-driven design.

Layout.rep
The error report file that is created by the database integrity test and which is written to the 
\SailWind Projects  folder.

LCC
An acronym for Leadless Chip Carrier.

lead frame
A sheet metal framework that is etched to form an array of metal traces.

lead pitch
The sum of the lead width and lead spacing.

606 SailWind Router Guide



 
Glossary

lead spacing

lead spacing
The distance between a component's adjacent leads.

Leadless Chip Carrier
(LCC) Ceramic IC package with no physical lead. There are only pads on the bottom of the package 
around the edges.

length matching
A same-length requirement where the entered value represents a minimum/maximum length 
tolerance for nets belonging to the same class.

length minimization
A routing feature that configures unroutes to the shortest available distances, or in a specific 
topology, to facilitate high speed routing.

LGA
An acronym for land grid array.

LibDir
The SailWindpcb.ini  file entry that specifies the location of your library files.

libraries
The collection of part types, part decals, and drawn items included with a SailWind product or 
created by the user.

Library Manager
The SailWind feature that provides access to, and allows for modifying, the library of parts.

linked objects
When an object is linked, a presentation of the object and link to the source is contained within the 
framework of, and is a part of, the container application  document. The object is linked to its source, 
and the source continues to physically reside wherever it was initially created. Therefore, the file 
that contains the object is smaller than if the object were and embedded object. See also embedded 
objects.

Whenever you open the file that contains the linked object, the object checks the source to see if it 
changed since you last saved the file. If the source changed, then the linked object automatically 
updates.

LogCompressionMode
A SailWindpcb.ini  file entry that controls recorded mouse movements in a log file. When set to one, 
the default, recording of compressed mouse movement is enabled. When set to zero, recording of 
all mouse movement is enabled.

logic family
The assignment of an electrical type by name, such as CAP (capacitor) or RES (resistor), to 
indicate the appropriate reference designator prefix such as C or R.
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LOGMode
A SailWindpcb.ini  file entry for online macro recording to a log file. When set to 0, the default, 
recording is disabled. When set to one, macro recording is enabled, and the next.log  file is created.

loop
A pin pair that contains a route that branches off the original route, then branches back into the 
same route to form a loop.

loop routing
Used to create a loop in an existing route.

LPT port
A parallel printer port, usually referred to as LPT1 or LPT2.

macro
Internal objects that are handled using the macro engine vocabularies, and may or may not have 
the automation interface.

Manhattan distance (delta x + delta y)
Used to approximate unrouted net length for BoardSim. Add a percentage multiplier to account for 
indirect routing paths.

masking
The inhibiting of electrical interference between two traces on different layers due to separation by a 
ground or power plane.

material condition
There are three material conditions when creating component decals. They are Maximum (providing 
the most robust solder joint), Nominal (providing a general purpose solder joint) and Minimum 
(providing the least possible solder joint for very dense designs).

MCM
An acronym for multichip module.

memory pattern
A collection of routes between memory devices that form a distinctly repeatable pattern.
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micrometer

micrometer
One-millionth (10-6) of a meter; about 40 millionths of an inch. Micrometer is synonymous with 
micron.

micron
A term used for micrometer. One-millionth (10^-6) of a meter; 25.4 microns = 1 mil.

microvia
Vias that have a narrow drill hole. Because of their specific diameter to depth ratio, they are typically 
blind or buried vias and do not pass through many layers of the design.

minimum geometry
The smallest line width or spacing between lines or features on a semiconductor die.

miter
A diagonal segment or arc that replaces a corner.

miters pass
An autorouting pass that converts all 90 degree route corners to diagonal corners.

mixed plane layer
A plane layer that contains obstacles other than pads, such as routes, copper, or text.

modeless command
A command invoked through the keyboard. Commands include display options, design settings, 
and mouse click substitutions.

modify
To change information for a selected object.

moiré
Target-shaped objects located in the corners of finished artwork that are used to properly align each 
layer to others for design verification and fabrication.

monolithic device
A device whose circuitry is completely contained on a single die or chip.

mounted side
The side of the printed circuit board, either front or back, on which components are mounted.

mounting holes
Many (but not all) boards have mounting holes. Mounting holes are typically located around the 
perimeter of a board (most often in the corners). They are drilled holes, used to mount a printed 
circuit board to the finished product (for example, a mother board mounted to the computer casing), 
or used to attach bolt-on components to the printed circuit board (for example, stiffeners and ejector 
tabs).
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There are two types of mounting holes: plated and non-plated. Plated mounting holes have 
copper inside the hole and usually have a large annular ring of copper on both sides of the board 
connected by this copper cylinder (plating) inside the hole. These holes are typically connected to 
the GROUND bus or plane on the board and provide a method for grounding the board circuitry to 
the enclosure (for shielding purposes). The mounting hole ring diameter is usually slightly larger 
than the diameter of the head of the screw that will be used to fasten the board to the mounting 
device within the enclosure. Non-plated mounting holes are used for the same purpose, the only 
difference being that they are not internally plated and do not have a copper ring, therefore they are 
not used for grounding the board to the enclosure.

Plated mounting holes cannot be used as tooling holes as the thickness of the copper plating can 
vary and violate the close tolerance required by a tooling hole. Non-plated mounting holes can 
sometimes work double duty as tooling holes because there is no internal plating, therefore the 
tolerance of the hole size can be more closely controlled and fit within the requirements of a tooling 
hole.

Use the Decal Editor and the Pad Stacks dialog box to create tooling holes. Save the single-
terminal object as a part to the library for reuse.

See also Creating and Adding Board Mounting Holes  in the SailWind Layout Guide

multichip module
A package with multiple dice that is 20% or more silicon, has 100 or more I/O on a substrate, and 
four or more layers.

multilayer PC board
A design that contains routing and/or plane layers, in addition to those on the front and back side.

nail diameter
The diameter of the test probe.

NC drill
An abbreviation for numerical control drill. This technology involves producing an output file 
containing the x-y location and drill size for each hole, then feeding this information into a machine 
for automated hole drilling.

negative
A photographically produced reverse image of a plane layer. This allows cleared areas, or airgaps, 
to be created using normal drawing techniques. When reversed, all areas not drawn for clearance 
become the actual planes.

nested embedding
Nested embedding occurs when you insert an object using OLE into another object. For example, 
inserting a SailWind Logic schematic into your SailWind Layout Design or inserting a Microsoft 
Word document into a schematic.

nested macros
Macros called from other macros.

net
All pin pairs composing one individual signal. Nets contain at least one subnet, but may contain 
more than one.
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See also subnets

net class
A collection of nets with a common set of design rules.

net length rules
Rules that control a net's or pin pair's routing length.

The following high-speed rules are examples of net length rules: minimum/maximum length, 
matched length, and differential pairs.

The phrase controlled length net refers to nets that have length rules, or nets with pin pairs that 
have length rules.

net name
A specific name given to a net to describe its function; for example, GND, PWR, or DATA0.

The maximum net name length is 47 characters. You can use any alphanumeric characters except 
{ } * and space.

netlist
A point-to-point connection list for each signal in a design, providing the reference designator (part 
name) and pin number.

netlist file
A PADS ASCII file containing all of the nets in a design, including all component pins that make up 
the nets. The file may also contain a list of all parts in a design, and/or the settings that control the 
substrate bond pad numbers and functions for newly created substrate bond pads.

netlist.fmt
The ASCII setup file for the report format that produces a netlist without pin information.

network security
Use of one security key, programmed with multiple options, for network use with one or more 
systems at a time.

next.ini
A file produced in the C:\<install_folder>\<version>\Programs  folder when the SailWindpcb.ini  entry 
LOGMode is equal to one. The next.ini  file is a copy of your SailWindpcb.ini  file at the time next.log 
is written.

next.log
A file produced in the C:\<install_folder>\<version>\Programs  folder when the powerpcb.ini entry 
LOGMode is equal to one. The next.log  file records all activities within a SailWind Layout session so 
that they can be replayed to reproduce a series of steps or used to illustrate a problem.

node
A point along a trace where traces join other traces (T junction), where traces transition to other 
layers, or where traces end at pins, virtual pins, vias, or floating endpoints. Specifically, a node can 
be any pin, virtual pin, via, copper, trace junction, virtual point, or trace end.
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See also virtual point

node-locked
A license for a specific Host ID.

non-ECO-registered parts
These parts are found in the schematic and layout design. Parts not selected as an ECO-
Registered Part on the General tab of the Part Information dialog box are non ECO registered parts.

• A schematic non-ECO-registered part is required in the schematic but has no place in the 
layout of the circuit board. For example, a chip socket shown in the schematic for inventory 
tracking in the bill of materials.

• A layout non-ECO-registered part is required in the layout design but has no place in the 
schematic. For example, a plated and grounded mounting hole.

non-electrical parts
Parts with no pins. For example, a mounting screw shown in the schematic for inventory tracking in 
the bill of materials.

non-plated holes
Pads that are not reflowed with solder, usually reserved for mounting holes. Non-plated holes are 
not drilled with an oversize to accommodate the solder flow.

To determine plating status, in SailWind Layout, use the Pad Stacks Properties dialog box. In 
SailWind Router, use the Pad Stack tab in the Pin Properties dialog box.

nudge
A placement feature that relocates parts to make room for new parts being placed. Movement is 
based on previously defined clearance rules.

object
One discrete item in the design. For example, an object may be a route segment, a part, a drawing 
line, or a via.

object mode
Start a command by selecting one or more objects and then selecting the command to perform on 
them.

See also verb mode
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obstacles

obstacles
Objects that block routing, for example protected pins, vias, traces, keepouts, and board outlines.

odd pad shape
A pad that requires a special aperture, or plot sequence, to create. In SailWind Layout, in the Pad 
Stacks Properties dialog box, the odd shape setting should not be confused with trying to create a 
custom shaped pad which is accomplished by drawing copper in the decal and associating it to the 
pad.

offline plot
A plot that is sent to a file before it is copied to a printer or plotter for processing.

offset
The distance by which rectangular or oval pads are moved away from the electrical center of the 
pad stack.

offset pads
Rectangular or oval pads moved off the electrical center of the pad stack to facilitate identification/
selection, or for a special design consideration.

one pin nets
A net that contains only one pin. Also called single pin net. In SailWind products, a net must have a 
minimum of two pins.

online DRC
A SailWind feature that actively checks established-design rules during routing or placement 
operations.

online plot
A plot sent directly to a printer or plot.

open cluster
Clusters that you can delete or replace during automatic cluster creation.

optimization
Rearranging placed parts and/or swapping pins and gates on parts to minimize trace lengths and 
reduce the number of vias required for routing.

optimize pass
An autorouting pass that analyzes each route and tries to improve the quality of the route pattern 
by removing extra segments, reducing via usage, and shortening routed trace lengths. This pass 
includes glossing and smoothing processes.

overlapping coppers
Overlapping coppers are combined into one copper area, with possible cutouts.
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See also coppers, copper connectivity

overlapping cutouts
Overlapping cutouts are combined into one cutout area.

See also cutouts

overlapping segments
Multiple trace segments stacked on top of one another on one layer.

package
The protective container for an electronic component with terminals to provide electrical access to 
the die components inside.

pad entry
The point where a trace entering or exiting a pin first crosses the edge of a pad.

pad entry angle
The command in SailWind Layout and Router that establishes the angle at which a trace enters a 
pad. This may be orthogonal (90 degrees), diagonal (45 degrees), or any angle.

pad function
The die signal name to which the component bond pad is connected.
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pad number

pad number
The number of the component bond pad.

pad oversize
On plane layers, pads that are larger than normal, to generate proper clearances when the image of 
the pad is printed in a negative format.

Pad oversize is measured from the center of the pad, not the perimeter. For example, if you have a 
3 mil oversize, the measurement is actually1.5 mils in each direction from the center of the pad.

pad stacks
The combination of pads, drills, and pastes, for example, on a pin or via, for each layer of a design, 
stacked directly on top of one another.

pair routing gap
The fixed edge-to-edge clearance between the traces in the controlled gap area for a differential 
pair.

See also controlled gap area, differential pairs.

paired layer
The start and end layers used by the layer toggle command when changing layers while routing. It 
defines the default layers to use when you make layer changes.

palette
A user-definable color chart in the Display Colors dialog box.

pan
Up and down or side-to-side movement of the screen without zoom or redraw. Use the scroll bars or 
postage stamp to pan.

panning
Moving the view horizontally or vertically without changing the size of the design on your screen.

parallel port
A printer port, usually referred to as LPT1 or LPT2.

parallelism
Traces on the same layer that are checked for running parallel to each other.

The traces are subject to crosstalk if they run parallel to each other too long and the gap between 
them is too short.
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parasitic
An undesirable stray capacitance, inductive coupling, resistance leakage, or undesired transistor 
actions.

parent object
The object to which individual design elements, such as lines, arcs, or corners, belong.

part decal
The physical representation of a part, or footprint, assigned to the part type.

part list
An output listing of all parts belonging to the same design. This normally includes the reference 
designation, part name, and part type, and total number of each type.

part name
The text for each part that indicates the reference designator.

part outline width
The line width of 2D line shapes, created in the PCB Decal Editor, that represent silkscreen or 
documentation data within a part decal. The shapes do not include text, reference designators, or 
copper with the decal.

partial route
Partial routes are uncompleted routes where the ratsnest flightline is still visible. This occurs when 
you click End while routing or bus routing, or when you delete a trace segment. See also dangling 
route.

partial via
A via that does not travel through all of the board's electrical layers. The blind via  and buried via  are 
both types of partial vias.

parts1.fmt
An ASCII part list format file for the report file generator that consists of a reference designator, part 
type, and logic type.

parts2.fmt
An ASCII part list format file for the report file generator that consists of a part type, reference 
designator, and part description.

paste
A substance used to attach each pin of a surface mount device to a PC board.

paste mask
An artwork layer with a paste location for all pads of surface mount components.

patterns pass
An autorouting pass that searches for, and routes, groups of unrouted connections that can be 
completed using a typical C routing pattern, Z routing pattern, and memory pattern.
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PBGA
An acronym for plastic ball grid array.

PDF configuration
A set of PDF Configuration dialog box control settings. A PDF configuration can be saved as a .pdc 
file and reused to create PDF documents for multiple designs.

PGA
An acronym for pin grid array.

photoplotting
Using a machine to create printed circuit board fabrication artwork. The machine creates artwork by 
exposing clear film to light or by rasterizing an image onto clear film.

physical design reuse
A collection of design objects that you want to reuse, which are associated with one another. The 
collection of objects can be saved to a file.

physical design reuse elements
The objects that compose the reuse. They can include components, routes, vias, text items, and 
other elements.

pick and place
An automatic printed circuit board assembly machine, driven by outputting the part type, location, 
and orientation of suitable parts from a design.

pin
The through-hole or surface mount terminal that represents a connection to a part. Pins are also 
referred to as pads in pad stacks.

pin array/pin grid array
A package with pins distributed over much or all of the bottom surface of the package in rows and 
columns.

For more information, see Decal Wizard Dialog Box, BGAPGA Tab.

See also pin types.

pin number
Within a component, the numeric or alphanumeric designation that distinguishes pins from each 
other.

In the Status bar, pins are identified using the following format:

Pin:[Component name].[Pin number].[Pin type]

For example:

Pin:Y1.N.Nonelectrical
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See also pin types.

pin pair
The combination of a trace or unroute, and the pins on either side. A net can contain one or more 
pin pairs.

pin pair group
A collection of pin pairs that share common design rules.

pin type
A designation that indicates the electrical characteristics of the pin such as Source (S), Load (L), 
Terminator (Z), and Undefined (U). For example, U1.1.S may appear on the status bar.

pin types
Pins and pin pairs can be identified by one of the following pin types:

• Source

• Bidirectional

• Open Collector

• Or-Tieable Source

• Tristate

• Load

• Terminator

• Power

• Ground

• Nonelectrical

Pin types make up the last portion of the pin identifier in the Status bar. For example:

Pin:U10.C.Open Collector

See also pin number

placement check prints
Generate a CAM Assembly drawing to make a placement check print.

After the PCB Designer receives a schematic and a netlist from an Engineer, they (typically) place 
the components onto the board in a manner that best suits the routing of the board. Sometimes, 
the placement better suits the intentions of the Board Designer than the Engineer, so before 
routing proceeds, the Engineer will request to see a set of Placement Check Prints. Placement 
Check Prints show the placement of all components on both sides of the board, so  the Engineer 
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placement operations
can review the locations and confirm the Designer has correctly placed the components. These 
Placement Check Prints typically require agreement from both the Designer and the Engineer 
before routing can proceed.

placement operations
Operations where parts are relocated or added to a design to optimize an existing placement.

plane hatch outline
The outline of a copper plane shape after it has been flooded to differentiate it from the plane pour 
outline  as originally drawn. When you draw the copper plane pour outline and then flood the shape, 
the outline often changes to accommodate the design rules. You can switch plane display modes 
using the shortcut modeless command PO.

plane layers
A design layer where the entire surface is covered by copper, except for information not connected 
to the plane.

plane nets
Nets assigned to plane layers.

plane pour outline
The outline of a plane shape after it has been drawn to differentiate it from the plane hatch outline 
after it has been flooded. You can switch plane display modes using the shortcut modeless 
command PO.

plastic ball grid array
A surface mount package with an array of solder sphere-shaped interconnects arranged across the 
bottom surface of the package substrate.

plastic leaded chip carrier
A common surface mount package with leads on all four sides, used as a socket for devices that 
cannot withstand the heat of the reflow process, and/or to allow for easy component replacement.

plated holes
Drilled holes that have copper covering the inside surface of the hole, and which are connected to a 
pad on each side. Plated holes pass connectivity from one layer to others.

plating tail
A route that connects BGA vias to a plating bar or bus bar.

PLCC
An acronym for plastic leaded chip carrier.

plicense.exe
The program used to verify and program your security key during a field upgrade process.

polar decal
A single-radius, circular pattern decal with through-hole pins.
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polar SMD decal
A single-radius, circular pattern decal with SMD rectangular or finger pads.

polygon
A closed shape consisting of three or more line segments.

positive
An image of a plane layer where cleared areas, or airgaps, are created using normal drawing 
techniques. When reversed to create a negative, all areas not drawn for clearance become the 
actual planes.

power board
A board that is designed to control power to other circuit boards.

power plane
The plane layer where power supplied to the printed circuit board is dispersed to the proper pins of 
each component requiring a power source.

SailWindpcb.ini
The SailWind Layout initialization file for default settings.

powerpcb.mdb
The SailWind Layout message file that contains error messages, prompts, and other miscellaneous 
text strings. This file must be located in the same folder as SailWindPCB.exe.

powerpcb.reg
A file that defines all Registry keys required for the proper registration of SailWind Layout OLE 
components. In addition, other programs acting as clients access the SailWind Layout Automation 
Server through this Registry file.

The installation program automatically creates this file and saves it in the same folder as 
SailWindPCB.exe.  If errors occur in the Registry, or if this file is corrupted, you can restore the 
contents of the file.

preferred routing direction
In the main GUI combo box, the Horizontal [H] or Vertical [V] designation next to a routing layer 
name. This designation indicates optimal direction for routing completion and can be set by the user 
or the system.

prepreg
A resin pre-impregnated sheet used to bond substrate laminate-pair layers together when a 
multilayer board is pressed together.

preset files
Library IQ files that enable you to save the preference settings you have established for a die 
design and use them in other designs. The Bond Pad Preferences files have a .pre  file extension.
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preview of CBP assignments

preview of CBP assignments
A preview that displays the substrate bond pads and wire bonds created when component bond 
pads are assigned to rings. This preview appears in the work area when the Assign CBPs to Rings 
dialog box is active.

preview of SBP guides
A real-time preview that displays any changes made to the number, geometry, or location of SBP 
guides. This preview appears in the work area when the Wire Bond Wizard dialog box is active.

well as in the design in which you place the reuse.

See also private nets

primary component side
The mounted side of the board when using through-hole components. See also secondary 
component side

primary objects
Primary object groups in the Object View tab of the Project Explorer contain non-removable design 
elements shown in a high-level object hierarchy. Primary objects are:

• layers

• components

• part decals

• net objects (including nets and pin pairs)

• via types

private nets
Nets that are contained completely within a physical design reuse.

See also public nets

probing
The testing of individual IC dice using very fine probes to temporarily connect each to a test 
computer to verify operation.

properties
A set of dialog boxes used to view or edit information about the selected object.

protect
Glues the routes and attached vias and prevents the autorouter from modifying them in any way.

protected routes
Traces that are placed in a protected state by Route Protection. This means that they cannot be 
moved or modified.

SailWind Router Guide 621



Glossary
protected traces  

protected traces
Traces placed in a protected state (cannot be moved, or modified).

protected unroutes
Unrouted connections, or the unrouted portion of a partial route, that are placed in a protected state 
by the Route Protection feature. This means that they cannot be routed, moved, or modified.

public nets
Nets that are partially contained within a physical design reuse. Public nets exist in the reuse, as 
preferred routing direction

In the main GUI combo box, the Horizontal [H] or Vertical [V] designation next to a routing layer 
name. This designation indicates optimal direction for routing completion and can be set by the user 
or the system.

pulling an arc
Creating an arc from an existing line segment, where the diameter is derived from the line length.

QFP
An acronym for quad flat package - a surface mount IC with leads on each four sides.

quad
A square-shaped IC with pads on each of its four sides.

Quick Filter Settings
The shortcut menu selections available when no items are selected. These choices set the 
selection filter for commonly used tasks, enable quick access to the Find command, and Select All 
items as specified by the Selection Filter.

quick measure command
The Q modeless command  which attaches a measurement line to the pointer and displays dx, dy 
and hypotenuse information, depending on pointer movement.

radial lead
A discrete part with pins that protrude straight down and do not extend beyond the perimeter of the 
component body. An example of this is a capacitor.

RAM
An acronym for Random Access Memory. The volatile (on chip rather than on disk) memory area 
available to the system for program operation.

range select
To select a series of geometric or route segments by first clicking on the start segment, then 
pressing and holding Shift and right-clicking on the end segment.

ratsnest
A term used to describe the display of all of the unrouted connections in a design. Also known as air 
lines or unroutes.
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raw database

raw database
The raw database contains all components in the open database, regardless of assembly variants. 
When created, new assembly variants are based on the raw database, meaning that until you 
uninstall or substitute, a new assembly variant includes every component in the raw database.

read-only attribute
An attribute whose value cannot be changed in SailWind product dialog boxes. You can, however, 
modify attribute properties and the Attribute Dictionary entry, and can modify the attribute value in 
the library.

real width
To display traces at their specified width, as opposed to displaying them as one pixel centerlines.

real-time redraw
A feature that enables active regeneration of objects in the display any time the screen is redrawn. 
When you disable real-time redraw, regeneration occurs in the background, and the display is 
refreshed all at once after the background regeneration process is completed. Screen regeneration 
is quickest when real-time redraw is disabled.

record locking
Allowing two or more users to access the same library component at one time. However, only one 
user has access to save the component.

recover
Resolving an installation or operational issue, or salvaging a corrupt database by executing a 
specified series of steps.

redo
Repeats actions which have been undone.

redraw
Refreshes the display of the current screen image and the cursor.

reference designator
An identification assigned to each of a design's parts to distinguish them from other parts of the 
same type when placed on the printed circuit board. A reference designator is usually in the form 
of a letter that represents the part type, followed by a number. For example, C2 may represent the 
second capacitor in the design. SailWind Layout permits you to renumber the reference designators 
in one of several specific patterns enabling you to quickly find a part among thousands on the 
manufactured board. The reshuffled numbers that are rearranged in SailWind Layout are backward 
annotated to the schematic software to keep the designs synchronized.

relative coordinates
Coordinates that are based on a start point instead of the system origin.

rename
To assign a different name to a part or net.
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reroute
Specifying that a trace, or a portion of a trace, follow a path different than the one currently being 
taken.

restricted layer
Layers that are either disabled for routing or have been disallowed by layer biasing rules. When a 
layer is restricted, routing is not permitted on the layer. Layers can be restricted for specific objects, 
such as a net or a pin pair.

restricted via
A via that is not permitted for use in the Routing Rules  of SailWind Layout or Via Biasing properties 
on page 169 in SailWind Router at any level of the rule hierarchy.

reuse
See preview of CBP assignments.

reuse definition
The master copy of the physical design reuse that is saved to a file. The saved version of the 
physical design reuse is the version you should use in other designs. All resulting instances of the 
physical design reuse are based on this file.

reuse type
A name that identifies the type of reuse being created. A reuse type is equivalent to a library part 
type.

ring geometry
The shape of the die flag ring. The following shapes, or ring geometries, are supported: rectangle, 
rounded rectangle, chamfered rectangle, and arced shape.

romansim.fnt
The default file that contains definitions for the graphics for the SailWind stroke font, used to display 
text in SailWind products when system fonts are not in use.

rotate
The command that rotates by 90 degrees a component or object around its axis or selection point.

route
To create a metal etch trace of a specified width between pads.

route-completion target
This crosshair or bullseye symbol appears when routing from one pin of a pin pair to another pin or 
when rerouting a trace segment.

The partial target appears when you are overtop of an electrically compatible pin, but you have 
settings that are preventing you from routing to it - for example, the unroute of the pin pair you are 
routing is protected (you have selected the Protect Unroutes check box in the Pin Pair Properties).
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route loops

route loops
A pin pair that contains a route that branches off the original route, then branches back into the 
same route to form a loop.

route pass
The autorouting pass that is the core pass that performs the majority of autorouting. During 
this pass, SailWind Router attempts to sequentially route each unroute until all connections are 
attempted. The Route pass contains serial, rip up and retry, push and shove, and touch and cross 
processes.

routed length
The trace length monitor calculates routed length as the cumulative length of the trace. Includes 
half the Discrete length value of each connected pin of components that have a Discrete length 
assigned. If you start routing from the endpoint of a partially routed trace, the routed length includes 
the partially routed trace length. If the trace has branches, then the length is calculated from the 
branch point.

See also estimated total length, unrouted length

routes
A series of traces that represents routed connectivity.

routing angle
The angle applied to adjacent segments as new corners are added to traces. For example, an 
orthogonal routing angle means adjacent segments will be created at 90-degree angles to each 
other.

routing order
The order in which the autorouter routes components, nets, and net classes.

routing pass types
There are several pass types, each of which is designed to complete a specific task. Each pass 
may use more than one algorithm and may also perform a number of subpasses.

• center pass

• fanout

• miters pass

• optimize pass

• patterns pass

• route pass

• test point pass

• tune pass
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routing strategy
The collective information SailWind Router uses to autoroute a design. This information includes 
which pass types SailWind Router should perform, whether to protect  the resulting traces, and what 
intensity  to assign to objects.

ru.cfg
A configuration file used by the nrus.exe program for Novell network security support.

rule values
The values of any item, regardless of its default rules or rules set assignments.

rules
An established set of conditions for a given net or design.

rules set
A specific set of user-assigned nondefault rules such as pin pair, groups, or classes.

same net checking
Checks clearances between objects along the same net, as specified in the Clearance Rules dialog 
box. Object to object checking includes:

• Pad edge to pad edge.

• Pad edge to inside corner of trace.

• SMD edge to pad edge.

• SMD edge to inside corner of trace.

This check prevents solder bridging during board manufacturing caused by acute angles between 
conductive objects such as the acute angle between pad and trace shown below.
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same net rules

same net rules
Specifying conditional settings, such as spacing, for connections belonging to the same signal 
name or net, rather than against other nets.

SBP
An acronym for Substrate Bond Pad.

SBP fanout
A single-segment fanout that connects SBPs to any-angle coupling traces.

SBP guide
The virtual snap line along which substrate bond pads are aligned during wire bond fanout 
generation. Each SBP guide determines the alignment of the substrate bond pads that are 
associated with the SBP ring aligned with this SBP guide.

SBP ring
A set of substrate bond pads aligned along an SBP guide. A substrate bond pad belongs to the ring 
on which it is aligned. In creating a wire bond fanout, you assign each component bond pad to a 
specific SBP ring.

schematic-driven design
The “standard” PCB design process, in which a netlist is first created in a schematic tool, and then 
passed to a layout tool, where the parts are laid out on the board and the connections routed. See 
also layout-driven design.

scribe line or saw line
The separation between adjacent dies on the wafer. This path is used as the cutting area in sawing 
a wafer into the individual dies.

search
To locate specified information. One search method is to use the Find command.

secondary component side
The side opposite the mounted side for through-hole components. This side is typically wave 
soldered.

See also primary component side

secondary objects
Secondary object groups break primary objects into a more detailed hierarchy. You can add 
individual items to and remove individual items from secondary groups. Secondary objects include:
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• net class

• pin pair group

• conditional rule

• matched length net group

• matched length pin pair group

• differential pair

seed
A part used by Cluster Placement, during cluster building, to search outward for other parts to add 
to the cluster.

segment
A single drafting line, path, or trace, defined by a beginning x/y coordinate and an ending x/y 
coordinate.

segmentation fault
The termination of a SailWind product due to a system crash or illegal instruction executed.

Select All
The Edit menu command that lets you select all items of a type specified in the Selection Filter. This 
option is also accessible from the shortcut menu when nothing is selected.

select mode
Point to the object and click the left mouse button. Select the command to perform on the object.

selecting
To highlight an object for editing, moving, viewing properties, or deleting.

selection filter
The dialog box inhibiting or enabling the selection of specific items.

serpentine route
A route that connects an any-angle coupling trace and a BGA pad, forming a snake-like pattern as it 
travels through the BGA.

session log
Information on the current session that appears in the Status tab of the Output window.

shape
The Selection Filter setting that enables or disables selection of an entire geometric object, not just 
its individual segments.
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shared libraries

shared libraries
Libraries that can be accessed by more than one user across a network.

shielding
Specifying that one net be routed around another to provide protection from interference.

shortcut keys
A key sequence that starts a command directly from the keyboard and without navigating through 
menus.

shortcut menu
A menu listing the possible actions to perform, based on the selected object.

shoulder
The part of the differential pair trace between the source pin and the gathering point, or between the 
split point and the destination pin.

See also differential pairs, gathering point, split point.

signal
Voltage or current that is transferred between component pins by an electrical conductor.

signal pins
Pins that have a signal net, such as GND, assigned by the schematic capture program SailWind 
Logic during part type creation.

signal via
Via used to continue a signal from one layer to another.

silkscreen
An artwork layer containing the reference designator and component outline of all parts, used for 
the final board fabrication process.

single-sided board
A design where all pads, routing, and parts are placed on one side of the board.

single-sided die
A die that has substrate bond pads and a BGA grid array on the same side of the die.

See also documentation layers

sizing handles
Small, black squares that appear at the corners and along the sides of a rectangular area that 
surrounds a selected nontext object.
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sketch route
A SailWind Layout command that reroutes existing traces by enabling you to draw a new route path 
using the pointer.

slice
Another term for wafer.

slotted holes
Oval holes in a printed circuit board, which may be plated or non-plated.

SMD
An acronym for Surface Mounted Device: the pin of a component that is attached to the PCB only 
on an outer surface and does not require drilled holes for component mounting.

smoothing
A command that automatically removes unneeded corners and segments and centers trace 
patterns between route obstacles.

SMT
An acronym for Surface Mount Technology.

snap modes
Various modes, available during dimensioning, that force the pointer to pick points based on of the 
following parameters: intersection, any point on a line, any point in space, entire segments, the 
center point of an arc, and so on.

soft rule
A rule that is ignored if it alone prevents route completion. See also hard rule, and Hard and Soft 
Rules, in the SailWind Router Guide.

SOIC
An acronym for Small-Outline Integrated Circuit.

solder
A metal alloy used to attach each pin of a device to a printed circuit board.

solder dam
A small amount of solder mask used to limit molten solder from spreading further onto solderable 
conductors, in an area where solder mask is purposefully absent.

solder mask
The artwork layer for a nonconductive material that covers the entire board, except for pad 
locations. The solder mask provides a protective covering and prevents shorts during wave and 
reflow solder processes.

solder mask reliefs
Some components have large areas that need to dissipate heat. Others have large metallized areas 
(that are not pins) that need to be soldered to the board. To expose the copper area beneath these 
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solder side
parts for soldering, the solder mask layer must have a cutout representing these areas. These 
cutouts are called solder mask reliefs. When the distance between pads of a fine pitch component 
is too small, the webs or fingers of solder mask between pads can break and wander on the board 
surface. To prevent this, a solder mask relief is applied to entire pad areas of a component. This is 
commonly called gang relief or a gang opening.

solder side
The back or bottom side of a printed circuit board. Solder side is named for the post assembly 
process, where the board is run through a special bath to solder all pins.

source
A pin type that indicates a signal radiating from the pin.

SPECCTRA
The product name for the Cadence Design Systems autorouter.

special symbols
Alternate decals that you specify as connectors. You can associate a logical pin type with each 
alternate to provide a graphical indication of the connector pin function in a schematic.

spider bonding
A method of connecting an integrated circuit die to its package leads. A lead frame is placed over 
the chip and all connections are made by just one operation of a bonding machine. TAB  methods 
use this approach to interconnection.

spin
The command that rotates a component or object around its axis or selection point.

split
The command that creates a new corner at the pick point of the selected trace, enabling it to be 
rerouted.

split plane
A solid copper plane layer divided into two or more sections to isolate electrical signals from each 
other.

split point
The point near the destination pins where differential pair traces are no longer routed together and 
where the traces are routed individually to completion.

See also differential pairs, pair routing gap
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ssiact.exe
A program used to recommend set statement settings to properly adjust port access times for a 
security key.

stackup
The metal and dielectric layers used to implement the body of a printed circuit board. A signal metal 
layer carries signal traces. A plane metal layer is tied to a DC voltage. A dielectric layer is made 
from non-conducting material and separates two metal layers or coats the board surface.

start zone
The part of the differential pair between the source pins and gathering point.

See also differential pairs, gathering point

starting layer
The first layer in a drill pair or via definition.

step-by-step mode
A mode in which the debugger runs a single line of code at a time.

stitching vias
Any SMD via, through-hole via, or partial via added to nets (on traces or within plane areas) in a 
repetitive manner. You can add these vias, also called free vias, for various purposes, including 
current and thermal needs. For example, you can place stitching vias in a plane area to provide 
conduction between two plane areas. You must assign stitching vias to a net, but they do not have 
to have traces attached to them.

strategy
A set of options that defines how a board should be autorouted.

strong
Places cluster members as close together as possible during placement operations. The minimum 
distance for placement is the same as the distance for part clearances in Design Rules.

structured attributes
Attributes that are related to each other by the prefix in their name. For example, the DFT attributes 
such as DFT.Nail Count Per Net, DFT.Nail Number, and DFT.Nail Diameter are structured attributes. 
Together, these structured attributes make an attribute group.
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stub
A trace that enters another to create a T-junction. Stub lengths can be checked by the EDC 
program.

submicron
Dimensions smaller than one micron.

subnet
A collection of all traces and vias connecting two pins. Subnets are joined only through their 
common component pins and not through other nodes, such as a trace junctions, vias, or virtual 
points.

Subnets help to avoid errors or confusion caused when pin pairs of a net have unique, rather than 
common, design rules.

See also node, subnet, connected islands, virtual point.

Figure 120. One subnet in a net

subnets
If a net has at least one pin pair with a unique design rule, such as a trace width difference, the 
net is automatically divided into subnets. If two pin pairs having the same rules are separated by 
at least one pin pair with different rules, the pin pairs are considered separate subnets. Therefore, 
subnets are islands of pin pairs that form an unbroken fragment within the net, where each fragment 
has uniform rules.

See also differential pairs, differential pairs.

Figure 121. Multiple subnets in a net

substrate
A material between copper laminate layers that comprise a laminate pair, or a laminate set in the 
case of completed multilayer boards.

substrate bond pads
Copper areas on the substrate to which a die's wire bonds are connected.
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surface mount device
Pads are glued to the board rather than inserted.

swap file
The file created when a program runs out of RAM memory and writes memory to disk.

swapping
A placement optimization process that exchanges pins, gates, or entire parts.

The product .ini  file entry that specifies the path for the SailWind product configuration files.

system attribute
An attribute that is set by, used by, and critical to a SailWind product, an external program, or 
Automation script (such as Sax Basic). You cannot modify the properties of a system attribute or 
modify the Attribute Dictionary entry for a system attribute.

system toolbars
System toolbars are specific to the SailWind programs. They feature several system toolbars, such 
as standard, routing, selection filter.

SystemDir
The product .ini  file entry that specifies the path for the SailWind product configuration files.

T junction
A trace that branches into another.

TAB
An acronym for source.

tacks
Small, diamond-shaped objects that anchor traces to their current location. Tacks are automatically 
generated under certain conditions and may also be manually added to a selected trace.

tandem traces
Traces on different layers that are checked for running parallel to each other.

The traces are subject to crosstalk if they run parallel to each other too long and the gap between 
them is too short.
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Tape Automated Bonding (TAB)

Tape Automated Bonding (TAB)
A packaging method where silicon chips are joined to patterned metal traces, or leads, on polymer 
tape to form inner lead bonds which are attached to the next level of the assembly, typically a 
substrate or board.

Tape Ball Grid Array (TBGA)
A TAB packaging method in which tape automated bonding leads are replaced by a ball grid array.

TBGA
An acronym for Tape Ball Grid Array (TBGA).

teardrop
A triangle shape that provides a smooth transition from a trace to a pad.

tented vias
Vias that are covered by solder mask on both sides of the board to seal the hole and protect it from 
wave solder.

terminal
The electrical center of a pin, as defined in the part decal.

terminator
A pin type for high-speed circuit configurations that indicates a terminating resistor to match 
impedance of the trace. Terminators are used to reduce signal reflections that cause poor circuit 
performance.

test point
A test point is a group of objects that serve as a contact between the electrical element of the board 
and the probe of the testing device. A test point can also be a point on a node of a net, component 
pin, or via. Test points can also be a point on an unused component pin, such as a component pin 
that is not incorporated into any net.

When the via or pin is flagged as a test point, and Show Test Points is checked on the Routing tab 
of the Options dialog box, a down arrow symbol is drawn on the via or pad in the design:

test point pass
This autorouting pass analyzes the testability of the design, determines which nets require testing, 
adjusts the routes, and inserts test points to improve testability. You can select whether to add test 
points during routing or after routing.

testpnts.fmt
An ASCII file containing information about test points, including the test point name, the signal 
name, and the x/y coordinates. The report file generator creates this file.
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thermal
A multi-spoke connection of a through hole pin pad, via, or surface mount pad to a copper plane.

thermal compression bonding
A method of wire bonding that does not use an intermediary metal or melting, but rather the 
flow of materials resulting from the combination of heat and pressure. It is also referred to as 
thermocompression bonding.

thermal relief
A spoke-shaped pattern that connects a via or pin, in the same net as the copper plane, to the 
surrounding copper. Thermal reliefs provide good pin soldering by preventing heat from dissipating 
throughout the plane layer.

thermal via
Via used to dissipate heat from an area or component.

thick-film process
A hybrid microelectronic process where conductors, insulators, and passive components are 
screened from special pastes onto the substrate.

thin-film process
The use of deposited films of conductive or insulating material, which may be patterned to form 
electronic components and conductors on a substrate or used as insulation material between 
successive layers of components.

three-state check box
A three-state check box helps to identify the state of the check box in a collection of objects.

Check box Description

Cleared check box. The item or collection of items all have the check box in the 
cleared or unchecked state.

Selected check box. The item or collection of items all have the check box in 
the selected or checked state.

Indeterminate or mixed state check box. The collection of items have different 
states of the check box.

through holes
Although there are non-plated through holes, this term is used interchangeably with plated through 
holes. It indicates that the hole has internal plating. There are two basic types of components that 
can be placed on a circuit board: Surface Mount Technology (SMT) where the parts are soldered 
to the surface of the board, and through hole (TH) components, where the components have wire 
leads that are soldered into plated holes that go through the board (sometime written as thru-holes).

through-hole via
A via that passes through all electrical layers of the PCB design (as opposed to a partial via).

This is sometimes also called a through via.
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tooling holes
Every board requires at least two tooling holes that the blank board manufacturer uses for layer 
alignment purposes during the manufacturing process. If you do not include them in the design, 
the manufacturer will add them to the board. Tooling holes are typically .125" non-plated holes with 
a tolerance of +/-.002". If the board is so small that the tooling holes will not fit, the manufacturer 
will add them to an area outside of the board outline. (These would typically get removed after final 
assembly.) There are two types of tooling holes: board tooling holes and panel tooling holes. Most 
boards are manufactured by stepping and repeating the single board image onto a larger panel so 
that multiple boards can be processed on a single panel. So, the board tooling holes are used for 
alignment purposes for individual boards, while the panel tooling holes are used for alignment of the 
entire panel during the manufacturing and assembly processes.

Use the Decal Editor and the Pad Stacks dialog box to create tooling holes. Save the single-
terminal object as a part to the library for reuse.

See also Editing Pad Stacks

ToolTips
ToolTips appear below buttons and provide a command name or description for the buttons.

topology
The pattern of the trace and the order in which to connect pins in a net.

total length
The current routed length plus the total Manhattan length for remaining unroutes of the electrical net 
or pin pair. Includes half the Discrete length value of each connected pin of components that have a 
Discrete length assigned.

Total length is reported for pin pairs when all the following are true: length rules are defined for the 
pin pair, the electrical net is a high-speed net, and copper sharing is disabled.

If pin pair rules are reported, the estimated total length of the pin pair is shown; otherwise, total 
length for nets is reported.

trace
A line segment that represents physical etch. A trace can appear as a single pixel line or as a 
double line to indicate its actual width.

trace corner
The vertex at which two trace segments are joined. A trace corner can also be the endpoint of a 
partially routed trace. The trace segments may be in line.
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trace paths
A continuous sequence of trace segments in the same trace on the same layer. Paths start and end 
at nodes, and cannot pass through a node.

trace segment
One section of a trace. A trace segment has one starting point and one ending point. A trace 
segment can be arced.

Trace segments are contiguous when they are joined end to end, in one continuous path, and 
belong to the same trace.

transparent layers
The mode that displays layers in a see-through mode so you can view multiple objects stacked 
upon each another. This is the modeless command T.

TrueLayer
The default mode of operation in SailWind Layout whereby an object on a documentation layer 
moves with a component if the component is moved from one side of the board to the other. For 
example, when you place a component on the top layer of the board, the reference designator of 
that component is visible on the Silkscreen Top layer (the documentation layer associated with the 
top layer of the board). Moving the component to the bottom side of the board automatically moves 
the reference designator for the component to the Silkscreen bottom layer.

TrueLayer also correctly plots paste masks of documentation-level pad shapes in CAM. The layer 
that the definitions move to is set in the Component Layer Associations dialog box.

By default, TrueLayer mode is enabled. To disable it, use the /NTL command-line switch. See 
Software Launch Options.

TTL
Acronym for Transistor-Transistor Logic.
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tune pass
This autorouting pass adjusts the length of length-controlled traces. The pass examines trace 
lengths for only completely routed nets or pin pairs. The pass analyzes the current length of each 
net or pin pair if length rules and length control are enabled, based on the following conditions:

• If the cumulative length of the adjacent trace segments is within the range of minimum and 
maximum trace length, the tune pass skips the trace and does not adjust it.

• If the trace is longer than the maximum trace length, the tune pass rips it up and places it in 
a queue for routing.

• If the trace length is less than the minimum trace length, the tune pass changes the length 
by adding accordion patterns.

ultrasonic bonding
A wire bonding technique that uses ultrasonic energy and pressure to form the bond without heat.

underfill
Material injected under the die to ensure interconnect reliability against #unique_1218  mismatch 
between the die and the substrate in a flip chip  configuration.

undo
A command that enables you to remove the effects of the last command invoked.

undock
To isolate an application dataset from the main design project so it can be edited regardless of the 
network or the physical location of the dataset. The isolated dataset has no dependence on the 
main design project.

UndoMemorySize
The SailWindpcb.ini  file entry that limits the maximum size of the buffer that is used to store ECO 
operations for Undo.

unions
Parts assigned to each other in fixed relative positions using Cluster Placement. These positions 
are maintained whenever a union is moved in Cluster Placement. A common example is the 
relationship between bypass capacitors and ICs.

units of measure
A commonly used set of measurements.

unroute
To convert a trace back into a connection.

unrouted length
The trace length monitor calculates unrouted length as the distance from the endpoint of the current 
trace segment (attached to the pointer) to its destination.

The unroute length calculation depends on the current routing angle:
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Routing mode: The calculation:

Orthogonal Manhattan Length

Diagonal   The length of the shortest diagonal path between unroute ends

Any Angle Point-to-point distance

The unrouted length is recalculated as the unroute dynamically reconnects to connection points. 
The routing angle also effects this calculation.

See also routed length, estimated total length

unroutes
Thin, straight segments joining pins or coppers to indicate connectivity. Also called a link.

unused pins
Pins that are not connected to a net.

UserDir
An .ini  file setting that specifies the path for SailWind product configuration files.

verb mode
Start a command by attaching a command to the pointer and then selecting objects to which you 
apply the command.

You can enter verb mode by selecting a command when no objects are selected. A small V 
attaches to the pointer to show that the selected command is active. The command remains 
attached to the pointer until you cancel verb mode.

See also object mode

vertex
A single point in the work area, defined by x and y coordinates.

via
A drilled and plated hole that passes conductivity from one layer to another.

via pair
A pair of vias used to change the routing layer for a differential pair when routing the controlled gap 
area.

See also via, differential pairs.

via type
A via or virtual pin padstack definition that is defined and named in SailWind Layout in the Pad 
Stacks Properties dialog box.

victim net
Nets that are interfered with by those tagged as aggressor nets during High-Speed or 
Electrodynamic Checking.
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virtual memory
Writing memory areas to disk in the form of a swap file when RAM is filled. The size of the swap file 
is based on the free disk space or the limits imposed by the operating system.

virtual pin
A net object that, like a component pin, serves as a pin pair end, but uses the pad stack of a via. 
The pad stack can be through-hole or partial, or it can be a single-layer pad.

virtual point
A point along a trace segment that identifies a change in design rules, usually between trace rules 
and component rules. Virtual points are inserted into nets automatically when necessary, usually 
during autorouting operations. You cannot create, position, or otherwise edit a virtual point.

See also subnets

Visual Basic
Visual Basic is a scripting language developed by the Microsoft Corporation to enable users to 
customize applications using a standard scripting language.

visual editing
Visual Editing occurs when the source application for a linked or embedded OLE object opens 
within the container application.

wafer
A thin disk of semiconductor material (usually silicon) on which many separate chips can be 
fabricated.

wafer sort
The electrical testing of each die on the wafer  while still in wafer form.

WB
An acronym for wire bond.

wedge bonding
A form of thermal compression wire bonding where the bond shapes the wire into a wedge shape.

width
The thickness of a trace or line.

wire bond
Fine wires, usually aluminum or gold, connecting the bonding pads on a die to the component 
package.

Wire Bond Editor
The Wire Bond Editor opens (explodes) a selected die part, so you can move, add, delete, and edit 
individual component bond pads and wire bonds in addition to substrate bond pads. You can also 
edit the die size.
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wire bond fanout
A pattern of wires (typically gold) that arc out from component bond pads to substrate bond pads to 
provide connectivity between the die pins and the substrate package pins.

Wire Bond Wizard
A BGA toolbox feature that creates and places substrate bond pads and generates an automatic 
wire bond fanout between component bond pads and substrate bond pads.

wire bonder
The machine that connects wires between the chip bond pads and the substrate bond pads.

wire bonding
The process of electrically connecting a chip to the next level package with fine wires. The wires are 
either gold or aluminum.

workspace
The actual work area where a design is created.

yield
The ratio of the number of acceptable units to the maximum number possible.

Z routing pattern
A collection of routes that form a pattern resembling the letter Z.

zoom
Modifying the view to make objects appear larger or smaller. Zooming in or out affects the amount 
of what can be viewed in the work area.

See also protect.
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Third-Party Information
Details on open source and third-party software that may be included with this product are available in the 
<your_software_installation_location>/ThirdParty  directory.
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